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1 Getting Started 

1.1 Course Prerequisites 

This class in intended for ODOT personnel involved in the production of roadway construction plans. It is 
recommended that students have knowledge of the following: 
 

 Familiarity with ODOT design policies, procedures and CADD Standards 

 Plan preparation experience 

 A working knowledge of Windows XP 

 A working knowledge of MicroStation V8i SELECTseries 1 

1.2 Course Schedule/Conduct 

During this training class we will develop an ODOT project using ground survey provided by one of 
ODOT’s District Offices.  The project scope calls for partial relocation of State Route 185 by inserting a 
new spiral-curve-spiral to flatten out the existing curve. 
 

Day 1 CPD Credit* 

01 Getting Started 2.0 hours 

02 Digital Terrain Models 1.0 hours 

03 Coordinate Geometry 4.0 hours 

Day 2 CPD Credit* 

03 Coordinate Geometry 4.0 hours 

04 Project Manager 1.0 Hours 

05 Design and Computation Manager 3.0 hours 

Day 3 CPD Credit* 

06 Drafting Tools 2.0 hours 

07 Existing Ground Profiles 2.0 hours 

08 Proposed Vertical Alignments 2.5 hours 

Day 4 CPD Credit* 

09 Plan and Profile Sheets 3.0 hours 

10 Plan View Labeling 1.0 hours 

 
* Please note that final determination on what qualifies for CPD credit ultimately lies between the 
license holder and the State Board for Professional Engineers and Surveyors. 
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Web Browsing: Please limit web browsing to break times and lunch. 

 

Email: Please limit email usage to break times and lunch. 

 

Cell Phones: Please set cell phones to vibrate and take calls only at break times and lunch. 
Please refrain from texting during the class 

 

Start Time: 7:30 AM 
End Time: 3:30 PM 

 

Breaks: 15 Minutes per half day 

 
Lunch: 45 Minutes 

 

1.3 GEOPAK Support 

The Office of CADD and Mapping Services has been designated to provide GEOPAK Support and training 
for ODOT personnel.  The Office is also responsible for establishing, maintaining and distributing all 
ODOT CADD Standards. 
 
The Office of CADD and Mapping Services maintains a MicroStation/GEOPAK support website on the 
ODOT website: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/default.aspx 
 
This training guide is available on-line in Abode Acrobat format at the following URL: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/GPKManual.aspx 
 
The Design Resource Reference Center is a centralized reference center to help locate online or printed 
material.  Additionally, several mailing lists are available to keep you informed about updates to ODOT 
standards.  A CADD Standards mailing list is also available.  Visit the Design Resource Reference Center 
at the following URL: 
 

http://www.dot.state.oh.us/drrc/Pages/default.aspx 
 
The Bentley community offers another great way to get support with MicroStation and GEOPAK 
problems.  For more information, see the following URL: 
 

http://communities.bentley.com/ 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/default.aspx
http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/GPKManual.aspx
http://www.dot.state.oh.us/drrc/Pages/default.aspx
http://communities.bentley.com/
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1.4 ODOT CADD Standards for MicroStation and GEOPAK 

ODOT CADD Standards for MicroStation and GEOPAK are maintained and distributed by the Office of 
CADD and Mapping Services.  The ODOT CADD Engineering Standards manual for MicroStation and 
GEOPAK is available in Adobe Acrobat format at the following URL: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/CADDManual.aspx 
 
Each ODOT District, and Central Office, maintains a copy of the ODOT CADD standards on a network 
drive, usually the “i” drive, in the “ODOTstd\V8istd” subdirectory. 

1.4.1 Standard Directory Structure 

The ODOT CADD Engineering Standards Manual, Section 301, defines the standard project directory 
structure to be used on all ODOT projects. This training class will use the directory structure for a Minor 
Project. See the ODOT CADD Engineering Standards Manual for more information on directory 
structures. 
 
A Visual Basic program is available to assist the project manager with the task of setting up the standard 
project directory structure. ODOT personnel can access the program from the following directory: 
 

i:\ODOTstd\V8istd\vba\ODOT_Directory.exe 
 
The application can also be accessed by selecting ODOT > File Management > New Project Directory 
from the MicroStation pull-down menu. 
 
When the program is accessed, the dialog shown below is opened. 

 
Documentation for the program is available on the ODOT CADD Support website. 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/CADDManual.aspx
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1.4.2 Standard MicroStation Design File Names 

The ODOT CADD Engineering Standards Manual, Section 303, defines the standard MicroStation DGN 
file names to be used on all ODOT projects. See the ODOT CADD Engineering Standards Manual for more 
information. 
 
A program is available to assist the project manager with the task of creating design files following the 
standard naming convention and the standard directory structure. The application can be accessed by 
selecting ODOT > File Management > New Design File from the MicroStation pull-down menu. 
 
When the application is opened, the dialog shown below is opened. 

 
Note: This application has been rewritten for MicroStation V8i as a MicroStation Visual Basic 
Application. As such, the application runs directly in MicroStation V8i. Previous versions of the 
application were written as a stand-alone Visual Basic 6 executable and required the user to close 
MicroStation in order for the application to create new the new design files. This version no longer 
requires the user to close MicroStation, although GEOPAK will be deactivated. 
 
Documentation for the program is available on the ODOT CADD Support website, or by selecting the 
Help icon located at the upper right of the dialog. 
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Exercise 1A, Directory Structure 

In this exercise, students will create a standard project directory and the basemap design files to be 
used through the training class. 
 

1. Create the following subdirectory for Darke County to house the project files: 
 

c:\GPKclass\DAR\ 
 

2. Use the ODOT Standard Directory application, ODOT_Directory.exe, to create a Minor Project 
Directory Structure for the files. 

 

 Use the C:\GPKclass\DAR folder as the parent folder for the new project 

 Assign a PID number of 12345 for the project directory. 
 

3. Use the ODOT_Files visual basic application to create the proposed basemap design files for the 
project: 
 

 Proposed Roadway Basemap 

 Proposed Profile Basemap 

 Set the Annotation Scale to 20 for these new files 
 
After creating the file, answer the following questions: 
 

A. What is the name of the proposed roadway basemap design file? 
B. What is the name of the proposed profile design file? 
C. What folder are these files created in? 

 
4. Configure Windows Explorer to display the file properties (Title and Comments) as shown in the 

example below. See the ODOT CADD Engineering Standards Manual, Section 304.6 Viewing 
Supplemental Descriptions. 
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1.5 GEOPAK File Types 

Typically ODOT design personnel will be provided with survey data from either ground survey or aerial 
mapping. In either case, you can expect to receive the following files: 
 

Description Extension 

A MicroStation design file containing the project mapping. This may be 2D or 3D 
depending on the survey data. Typically the file will be mapped using State Plane 
Coordinates converted to ground. Occasionally, the data will be mapped using an assumed 
coordinate system. 

.dgn 

A Digital Terrain Model representing the existing ground elevations. .tin 

If the survey data was collected via ground survey, a GEOPAK Coordinate Geometry 
(COGO) database containing the survey data will be provided. If the survey data was 
generated by the Office of Aerial Engineering, a COGO database is not typically provided. 

.gpk 

 
The GPK file and the DTM file should be named according to the standards defined in the ODOT CADD 
Engineering Standards Manual, Section 305 and 306. 
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Exercise 1B, Training Files 

In the exercise, students will add the training files to the project directory structure that was created in 
Exercise 1A. The training data can be accessed on the ODOT website at the following location: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/GPKManual.aspx 
 
The following files are included in the zip file: 
 

 job185.gpk - Coordinate Geometry database containing the survey data. 
 

 12345BE001.dgn - 2D MicroStation v8 design file containing the mapping of the survey data for 
the project. 

 

 12345exgr.tin - Digital Terrain Model representing the existing ground. 
 
Unzip the project files to the c:\GPKclass\DAR\ directory. Be sure to toggle on the Use Folder Names 
option as shown below. 

 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/GPKManual.aspx


Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 1-8 Chapter 1 – Getting Started  
 

1.6 Working with Existing Ground Survey and Aerial Mapping 

1.6.1 Model Annotation Scale 

Existing ground information is typically provided by either ground survey or aerial mapping. In either 
case, the display of the custom line styles, text, and cells is mapped for a specific plotting scale, usually 
20 or 50 scale. This presents a problem if the final plans will include sheets at different plotting scales. 
For example, the text, cells, and line styles referenced into a 10-scale detail sheet from a survey 
basemap that was mapped for a 20-scale drawing will appear two times too big on the plotted sheets. 
 
With MicroStation V8i, the Model Annotation Scale can be used to control the display size of text, cells, 
and custom line styles in the active design file and also in any reference attachments. This will allow the 
designer to control the display size of these features for any intended plotting scale. 
 
Important! In order for the Model Annotation Scale to set the display size for the text, cells, and line 
styles, these features must be plotted in the basemap design file using a scale of 1. This is a change in 
procedure from past practices. As stated previously, cells, text, and line styles were typically plotted in 
the basemap at a specific scale, usually 20 or 50. 
 
MicroStation V8 introduced the concept of Models and the Model Annotation Scale. To review: 
 

 A V8 design file can have multiple independent drawing areas called a Model 

 Each model can be 2D or 3D 

 Three types of models are available: Design, Drawing,  and Sheet Models 

 According to ODOT CADD Standards: 
o Design Models are used to draw the mapping for your project 
o Sheet Models are used to draw plan sheets 
o Drawing models are not used for ODOT projects 

 
To set the Model Annotation Scale, select File > Models from the MicroStation pull-down menu to 
access the Models dialog shown below. 

 
Select Edit Model Properties as shown above to access the Model Properties dialog shown on the 
following page.  
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In the example above, the Annotation Scale is set to a value of Engr 1:20. The Line Style Scale is set to 
match the Annotation Scale. 
 
Changing the Annotation Scale value will cause the display of the text, cells, and custom line styles to 
change according to the value selected. This will affect elements drawn in the active file as well as 
referenced graphics depending on the settings when the references were attached as described in the 
following section. 

1.6.2 Model Annotation Scale and Reference Attachments 

When a basemap design file is attached as a reference, the designer can determine whether the text, 
cells, and line styles are displayed at the scale set in the original design file, or whether the master file 
will control the scaling. 
 
On the Reference File Settings dialog box, the Global LineStyle Scale option is used to set which file 
controls the line style display scale. 

 
 If the survey data was mapped with a scale of 1, set this option to Master to allow the 

Annotation Scale of the master design file to control the display scale for text, cells, and line 
styles on both the active file and all reference attachments. 

 

 If the survey data was mapped for a specific scale, such as 20, set the option to Reference to 
match the annotation scale value set in the original reference file, or to None to disallow scaling 
of the display of the line styles, cells, and text. 
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1.6.3 Editing Pre-V8i data for use with the Model Annotation Scale 

Design files created in previous versions of MicroStation have typically been mapped for a specific scale. 
To use the Model Annotation Scale to control the display size of the text, cells, and line styles, with 
these files, the data must be edited so that these features are all placed at a scale of 1 in the basemap 
design file. The data can be remapped at a scale of 1 as described below: 
 
Case 1 – GEOPAK Survey Basemaps: 
 
If you have ground survey processed through GEOPAK Survey, the survey points and lines are included in 
the GPK file for the project. The data can be re-visualized at a scale of 1 with COGO Visualization 
commands as described below: 

 

 Visualize the Survey data from the GPK file. See section 3.5 of this guide for more information on 
visualizing data contained in the GPK file. 
 

 After visualizing the data, use the MicroStation Element Selection tool to select all the elements 
in the file 
 

 Key in the MicroStation command “annotationscale add”. This will add the annotation 
scale to the selected text, cells, and line styles. These elements will now respond to changes in 
the Model Annotation Scale. 

 
Case 2 – Aerial Mapping Basemaps: 
 
If you have ground survey from aerial mapping that is not included in a GEOPAK GPK file, MicroStation 
commands can be used to change the cell scale, and the custom line style scale to a scale of 1. An 
overview of the commands is provided below: 

 
To rescale the cells: 
 

 Use the MicroStation Element Selection tool to 
select all the cells in the file 
 

 Use the Element Information tool to change 
the scale of the selected cells to 1 as shown in 
the example at right. 
 

 Key in the MicroStation command 
“annotationscale add”. 
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To rescale the custom line styles: 
 

 Use the MicroStation Element Selection tool to select all 
the custom line styles in the file as shown at right. Tip: 
toggle the selection item to line styles and then drag 
through all the line styles in the list. The line styles that are 
in use in the design file will remain selected as shown at 
right 

 

 Use the Element Information tool to change the line style 
scale of the selected elements to 1 as shown in the 
example below. 

 

 Key in the MicroStation command “annotationscale 

add”. 
 

 
Additional details about the use of models for ODOT projects can be found in the ODOT CADD 
Engineering Standards Manual. 
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1.6.4 Survey Data Levels 

Ground survey information mapped through GEOPAK Survey may contain several types of supplemental 
annotation that is not intended to be shown on the construction plans. In the example below, the survey 
point name and the elevation is plotted in the design file. 
 

 
 
This supplemental information is plotted on several levels that are not intended to be shown in the final 
plans. The table below documents the survey levels that the user may elect to toggle on/off. 
 

Level Feature Description 

SV_X_Break_Line Break Lines Breaks in topography 

SV_X_Center_of_Pavt Center of Pavement The pavement crown as shot in the field. 

SV_X_Random_Point Random Elevation Shot Cell placed at the location of a random elevation shot 

SV_X_Shot_Marker Shot Marker Cell placed at the location of a survey shot along a survey chain 

SV_X_Text_Comment Comment Text Text comments keyed in the data collector by the surveyor 

SV_X_Text_Description Description Text Supplemental description information 

SV_X_Text_Elevation Elevation Text Text representing the elevation of the point 

SV_X_Text_Name Point Name Text Text representing the name of the point 
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Exercise 1C, Survey Data 

The Survey Data in the file 12345BE001.dgn has been mapped using GEOPAK Survey with a scale of 1 for 
the display of the line styles, cells, and text. In this exercise, we’ll use the model annotation scale to set 
the display of these features. 
 

 Open the following design file: 
 
c:\GPKclass\DAR\12345\survey\basemaps\12345BE001.dgn 

 
 Set the Model Annotation Scale to a value of 10. Observe the behavior of the text, line styles, 

and cells 
 

 Select the MicroStation Save Settings command 
 

 Open the following design file: 
 
c:\GPKclass\DAR\12345\roadway\basemaps\12345BP001.dgn 

 

 Attach the survey design file, 12345BE001.dgn, as a reference attachment 
 

 Set the Model Annotation Scale to a value of 20. Note that the display of the text, line styles, 
and cells is independent of the value set in the original design file. 
 

 Turn off levels for the supplemental survey information that you do not wish to display 
 

 Select the MicroStation Save Settings command 
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1.7 Activating GEOPAK 

GEOPAK can be activated by selecting Applications > GEOPAK> Activate GEOPAK from the MicroStation 
pull-down menu as shown below. 

 
After activating GEOPAK, the Applications pull down menu shows an entry for each GEOPAK product 
that has been activated, as shown below. 
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1.8 Accessing GEOPAK Road Functions 

There are several ways to access the individual functions in GEOPAK Road. Individual functions can be 
accessed from the Applications pull down menu, as shown below. 

 
The GEOPAK Road Tools palette can also be used to access the GEOPAK Road functions. Select 
Applications > ROAD > Road Tools. The tool palette shown below is opened. Each icon on the Road 
Tools palette is a tool box that can be opened to become a separate tool box.  

 
See the GEOPAK online help under Command Reference > GEOPAK Road Tools for a complete list of all 
the functions available in each tool box. 
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The GEOPAK tools are also available from the MicroStation Tasks dialog by selecting GEOPAK Suite as 
shown below. 

 
 
Note: The Roundabouts and the Civil Geometry tools have not 
been incorporated into the ODOT workflow and will not be 
covered in this training class.  
 
The Data Acquisition tools are new for the V8i release. These 
tools are used for processing Survey data and will not be covered 
in this class. 
 
Throughout the training guide we will make use of many of the 
functions contained in these tool boxes. This guide will typically 
demonstrate selecting the tools from the Road Tools palette. 
 
 
 

1.9 GEOPAK User Preferences 

GEOPAK provides numerous system parameters to allow the user to easily set or change the number of 
decimal places for output files, station formatting, coordinate format, English or Metric units, etc. These 
parameters are called the GEOPAK User Preferences. These parameters are primarily associated with 
the Coordinate Geometry functions, but also affect many other GEOPAK functions. 
 
The user preferences can be set for the current session, or saved as part of a specific project 
configuration as detailed in Chapter 4 of this guide. To access the settings for the current session, select 
Applications > ROAD > User Preferences to access the GEOPAK User Preferences dialog box shown 
below. 

 
Once these preferences have been set, they are stored in a MicroStation resource file. Every time 
GEOPAK is started, the settings of this dialog box are retained from the last design session. 
 
The options on the GEOPAK User Preferences dialog are explained below: 
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Unit System (English, Metric) 
This option determines whether GEOPAK operates according to the English or Metric system of 
measurement. The Unit parameter affects every GEOPAK component. 
 
Coordinate (NE, XY) 
Sets either NE (Northing/Easting) or XY coordinate values in Coordinate Geometry and in the GEOPAK 
labeling tools. 
 
Direction (Bearing, Azimuth) 
Sets the direction format for the line direction in Coordinate Geometry, Labeling, and components 
within the Design and Computation Manager. 
 
Station Format (1+234, 12+34, 1234) 
Sets the format for station variables in Coordinate Geometry, Labeling, and components within the 
Design and Computation Manager 
 
Output Accuracy: 

Distance (0 to 6 decimal places) 
Station (0 to 6 decimal places) 
Angle Seconds (0 to 6 decimal places) 
 
These options are used to sets the number of decimal 
places for Coordinate Geometry, Labeling, and components 
within the Design and Computation Manager. 

 
Working Directory 
The Working Directory is the most important parameter on the GEOPAK User Preferences dialog. Simply 
stated, the Working Directory is used to assign the default directory where GEOPAK will look for files 
when opening a file, as well as the default directory where GEOPAK will store files when a file is saved.  
The working directory can be assigned in one of two ways: 
 

Leave the Working Directory field blank 
By leaving the Working Directory field blank, GEOPAK will search the same directory as the 
design file that you currently have open for all files accessed during the current design session. 
This method is preferred when all of the files for the project are located in the same directory as 
the design file. It should be noted that placing the GPK file in the same folder as the design files 
does not comply with ODOT CADD Standards for directory structures. 
 
Specifying a specific directory 
This is the preferred method for ODOT projects. When using this method, you are telling 
GEOPAK to search a specific directory for all of the files associated with the project. For 
example, keying in c:\GPKclass\12345\geopak will tell GEOPAK to look in this directory for all 
files accessed during the design session. This method is preferred when the GEOPAK related files 
are stored in a separate directory from the MicroStation design files. 
 

Pressing the Select button invokes the Select Directory dialog, wherein the desired Working Directory 
may be selected. 
 

TIP: Decimal Precision 
Setting the number of decimal 
places for the Distance Decimal, 
Station Decimal, and Angle 
Seconds Decimal options only 
affects the rounding of the screen 
output. Internally, GEOPAK 
computes all values using double 
precision floating point 
computations. 
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1.9.1 Feature Preferences… 

The Features Preferences… push button invokes the Feature Preferences dialog shown below. 

 
The values assigned in the Feature Preferences dialog are used when visualizing COGO elements and 
mapping survey data with assigned feature codes as described below. 
 

Feature Database 
The symbology for the elements drawn from survey data is determined by the feature code of 
each element. These feature codes are stored in a database, the Survey Manager Database 
(.SMD file), that can be assigned by the user. The following ODOT Standard feature database is 
automatically assigned: 
 

I:\ODOTstd\V8istd\geopak\survey\ODOT.smd 
 
When survey data is mapped to the DGN file, GEOPAK searches the SMD file for a matching 
feature name. If a match is found, then the symbology for that feature is used. If a match is not 
found and there is a feature named "default" in the .SMD file, then the "default" feature 
symbology is used. If the feature is not found in the .SMD file and no "default" feature is defined 
in the .SMD file, the current MicroStation symbology is used. 
 
Apply Best Match Feature 
When the Apply Best Match Feature toggle is active, the best match feature from the feature 
survey preference database is utilized. This option allows placement of one feature in the 
database per item and locates derivatives of that feature in the field. For example, assume that 
feature EP is the Edge of Pavement, but in the field 3 different EP's need to be located. The 
different EP chains can be located as EP1, EP2 and EP3. During the mapping process, these 
features are matched to the Edge of Pavement feature EP in the database. Therefore, the user 
does not have to define multiple EP features in the database. 
 
Plot Scale 
This parameter is used to set the scale for elements mapped by GEOPAK Survey, or elements 
drawn by COGO Visualization. When visualizing Survey Data, the Plot Scale should normally be 
set to a value of 1 for ODOT projects. 
 
Use Shared Cells 
If Use Shared Cells toggle is off, cells are placed as unshared cells. If Use Shared Cells toggle is 
on, cells are placed as shared cells. Note: For ODOT projects, this option should always be 
toggled off. 
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Point Label Redraw 
Two options are provided to control how the labels are redrawn if COGO or Survey information 
is redrawn. 
 

Redraw according to SMD 
The label is drawn with parameters defined within the specified survey database when 
the map is drawn or redrawn. 
 
Position relative to symbol 
The user can move the point name, elevation, etc using MicroStation tools and if the 
data is remapped the labels retain their same position relative to the point symbol at 
the new mapped position. 

 OK 
Closes the Feature Preferences dialog, and sets all Visualization and Mapping Parameters based 
on the current dialog settings. 
 
 
Cancel 
Closes the Feature Preferences dialog, without changing any dialog settings. 

1.9.2 COGO Preferences… 

Pressing the COGO Preferences… button invokes the COGO Preferences dialog shown below. 

 
The COGO Preferences dialog has the following options: 
 

Job (GPK) Open Mode 
When the user accesses the GEOPAK Coordinate Geometry (COGO) functions, the software will 
automatically open the COGO database specified by the user by looking in the Working 
Directory for the database. If no data base is found matching the Job Number specified by the 
user, GEOPAK will respond in one of three ways as described below: 

 

 Create – When this option is selected, GEOPAK will automatically create a new 
coordinate geometry database if the Job number does not already exist in the current 
Working Directory. 
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 No Create - The software will not create a new database and the COGO dialog box will 
not be opened. 

 

 Query - With this mode, the user is queried when a job number is requested that does 
not correspond with a job**.gpk file in the Working Directory. Once queried, the 
designer may proceed with the database creation or cancel it. 

 
If no GPK file is found in the Working Directory when the user attempts to open the COGO 
database, and the Job (GPK) Open Mode is set to Query, the Alert dialog shown below appears. 
We recommend leaving this option set to Query. 

 

 
Job (GPK) Directory 
COGO Input File Directory 
COGO Output File Directory 
These three options can be used to specify the directory location for the COGO database, COGO 
input files and COGO output files. If all three fields are left blank, the software will use the 
directory location specified by the Working Directory. 
 
Redefinition of Elements 
The Redefine function will allow users to overwrite COGO elements. Checking this toggle on will 
force the Redefine function on when COGO is activated. Note: Redefine can be turned on/off 
directly from the COGO dialog box once COGO has been activated. See Chapter 4, Coordinate 
Geometry for more information on the Redefine function. 
 
Force Redefinition Off Upon COGO Activation 
If the Redefine function was left on the last time a user exited COGO, checking this toggle on will 
force the Redefine function off. We recommend checking this option on. 
 

Show this dialog at GEOPAK startup 
Checking on the Show this dialog at GEOPAK startup option will force the User Preferences dialog to 
automatically open when GEOPAK is activated. 
 
 
 
 
 
 

Tip: 
If you are not using Project Manager (see Chapter 4) be sure to review the Working Directory 
every time you start GEOPAK to ensure that it is set correctly for your project. Toggle on Show 
this dialog at GEOPAK startup to help you to remember to set the Working Directory. 
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2 Digital Terrain Models 

2.1 What is a Digital Terrain Model? 

A Digital Terrain Model (DTM) represents the topography of a project in a three dimensional (3D) file. 
 
Triangulation is a mathematical process applied to stored point elevations to produce the DTM. The 
triangulated model is stored in a binary file as a triangulated topological network. GEOPAK DTM files are 
named with a .tin extension. An isometric view of a DTM that has been plotted, using triangles, in a 
MicroStation design file is shown below. 

 
GEOPAK provides the capabilities to generate a DTM from a wide range of data sources including 
MicroStation elements, survey data, GEOPAK cross sections, or ASCII files with X,Y,Z coordinates. For 
most design projects, an existing ground DTM will be provided from ODOT’s Survey personnel or the 
Office of Aerial Engineering. 
 
The DTM is used by GEOPAK to extract existing ground profiles and cross sections, display contours, 
display drainage flow patterns, etc... We will concentrate on the most commonly used DTM functions 
during this training class. 
 
 
 
 
 
 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 2-2 Chapter 2 – Digital Terrain Models  
 

2.2 DTM Feature and File Types 

DTM models can be generated from several feature types. The following features are the most 
commonly used feature types: 
 

 Spots are points that have no relationship to any other point. Random survey shots in open 
terrain would be an example of spot elevations. 

 

 Breaks are used to designate linear features such as edges of pavement, ditch bottoms, ridges, 
etc. 

 

 Void areas are closed shapes to designate areas of missing data or obscure areas. No point or 
break data located within the void area is utilized and no triangles are created inside the void 
areas. A building is an example of a void area. 

 

 Boundary is used to constrain the external boundary of the triangulated model. No triangles are 
created outside the boundary polygon. In addition, any point data outside the boundary polygon 
is ignored. A boundary polygon must start and finish with the same point. 

 
Less commonly used feature types that are supported by GEOPAK are listed below: 
 

 Contours are a special feature intended for use when importing contour lines from a 
MicroStation design file in order to generate a TIN file. 
 

 Island is used to place data within a void, i.e., islands in the middle of rivers, lakes, etc. 
 

 Triangles previously plotted in a 3D MicroStation design file can be extracted using the Graphic 
Triangles option to generate a GEOPAK TIN model. This option is useful for generating a GEOPAK 
TIN model from 3D triangles that were plotted utilizing another software package. 
 

 The Drape Void element utilizes the X,Y coordinates of the void area and the elevation is 
determined by draping the void are onto the TIN model, thereby obtaining its elevation from the 
model. It is then inserted into the model. 

 
Triangle models generated by GEOPAK Survey typically consist of Spots, Breaks, and Voids. 
 
Before GEOPAK can triangulate the DTM, the information for the feature types listed above must be 
stored in a DTM input file. This file has a .DAT file extension. The DTM data input file can be stored as an 
ASCII or Binary file. 
 
GEOPAK uses the DTM Input file as input for the triangulation process. The resulting triangulated DTM 
file is given a .TIN file extension. 
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2.3 The DTM Tool Frame 

GEOPAK DTM functions are accessed from either the GEOPAK DTM tool frame or the DTM menu bar. 
The tool frame can be invoked by selecting Applications > Road > DTM Tools or from the GEOPAK Road 
Tools tool frame as shown below. 

 
If you prefer to use the DTM Menu Bar instead of the DTM tool frame, select the Menu Bar icon from 
the DTM tool frame. The DTM Menu Bar is shown below. 

 
We will use the DTM tool frame throughout this training guide. 
 
This training guide will cover the tools most commonly used in roadway design to display and analyze 
DTM information provided by ground survey or Aerial mapping. 
 
See the GEOPAK on-line documentation for more information on the DTM tools. 
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2.4 Load DTM Features 

GEOPAK supports a wide variety of options to draw and display DTM Features. Select Load DTM Feature 
to access the Load DTM Features dialog shown below. 

 
The symbology settings for each Feature can be uniquely defined. These settings can be saved in a 
preference file for later recall. Several preference files have been configured to set the element 
symbology according to ODOT CADD Standards. To access the preference files, select File > Open… from 
the Load DTM Features dialog. 
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For ODOT employees, these files are maintained on the “i” drive at the following location: 
 

i:\ODOTstd\V8istd\geopak\road\DTM_prefs\ 
 
The following preference files are available: 
 

File Name Description 

ODOT_P_1-Scale.lpf Proposed DTM Features, 1-Scale text size 

ODOT_P_10-Scale.lpf Proposed DTM Features, 10-Scale text size 

ODOT_P_20-Scale.lpf Proposed DTM Features, 20-Scale text size 

ODOT_P_50-Scale.lpf Proposed DTM Features, 50-Scale text size 

ODOT_P_100-Scale.lpf Proposed DTM Features, 100-Scale text size 

ODOT_P_200-Scale.lpf Proposed DTM Features, 200-Scale text size 

ODOT_P_500-Scale.lpf Proposed DTM Features, 500-Scale text size 

ODOT_X_1-Scale.lpf Existing DTM Features, 1-Scale text size 

ODOT_X_10-Scale.lpf Existing DTM Features, 10-Scale text size 

ODOT_X_20-Scale.lpf Existing DTM Features, 20-Scale text size 

ODOT_X_50-Scale.lpf Existing DTM Features, 50-Scale text size 

ODOT_X_100-Scale.lpf Existing DTM Features, 100-Scale text size 

ODOT_X_200-Scale.lpf Existing DTM Features, 200-Scale text size 

ODOT_X_500-Scale.lpf Existing DTM Features, 500-Scale text size 

 
Each file is configured for a specific text size that is used with the Contour and Spot feature types. 
 
Information can be loaded from three different Load File types as shown below. 

 
Select TIN to load information from a GEOPAK TIN file. 
 
The TIN file is selected by use of the Select File icon as shown below. 

 
The Load button is used to initiate the drawing or displaying of DTM Features in the active MicroStation 
design file. 
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Display Preferences 
The Display Preferences portion of the dialog box is used to set the symbology and display status for 
each feature type. 

 
Load 
Three options are available: 

 Extent - The features for the full extent of the model are drawn. 

 For Fence - The features within a fence area are drawn. 

 View - This option draws only features within the current view window. 
 
Display Only 
When this toggle is activated, elements are not drawn into the MicroStation file and disappear 
when an update view command is issued. When toggled off, elements are drawn into the file at 
the specified element symbology. 
 
Graphic Group 
When activated, all elements placed within a single processing (each pressing of the Load 
button) are placed as a graphic group for easy manipulation and / or deletion. 

 
By default, each Feature type is toggled off. The light bulb icons to the right of the dialog can be used to 
toggle on/off the display for all features, or selected features. 
 

DTM Feature Symbology List Box 
For each Feature, there are element symbology options and a Display mode on/off off toggle. 

 
Floating your cursor over the symbology box will reveal the current settings for the selected 
Feature as shown above. 
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As each Feature is highlighted, its element symbology is displayed directly below the list box in 
the symbology box. The toggle to the right of the element symbology indicates whether the 
display is on (toggle is on) or off (not toggled). 

 
The symbology for the selected item can be changed by double-clicking the symbology box to 
access the GEOPAK Set Feature dialog shown below. 

 
If the selected feature requires text (i.e., Spots) the dialog dynamically changes as shown below 
when the feature is highlighted.  

 
Text parameters may be defined or modified by double clicking on the symbology box. 
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2.4.1 Plotting Triangles 

The triangles for the selected TIN file can be plotted as shown below. 

 
The triangles are plotted as a single Mesh element which can easily be deleted as a single element. 
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2.4.2 Plotting the Tin Hull 

The Tin Hull option is used to plot the external boundary of the triangle model. This option is useful to 
view the extents of the surveyed data without plotting the individual triangles. An example is shown 
below. 

 
 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 2-10 Chapter 2 – Digital Terrain Models  
 

2.4.3 Plotting Contours 

Contours require additional parameters as shown below. 

 
Minor Interval 
Major Interval 
Major contour intervals should be even increments of minor contour intervals. For example, a 
minor contour interval of 2 and a major contour interval of 10 would be reasonable values. 
Every fifth contour element would reflect the level, symbology and text attributes defined for 
major contours. Conversely, a minor contour interval of 2 and a major contour interval of 5 
would not be reasonable since 5 is not an even increment of 2. 
 
Smooth Contours 
Three options are available to smooth the contour display: 

 None 
When None is used, no smoothing of contours is done. 
 

 Three Point 
The Three Point Smoothing algorithm replaces each contour vertex with a curve that is 
tangent to the preceding and following contour segments. The curve starts and finishes 
at tangent points that are equal distances on both sides of the contour vertex. The 
distance is hard coded to one third of the minimum of the length of the preceding or 
following contour segment. Three curve points are then calculated between the two 
tangent points. 
 

 B Spline 
The B Spline smoothing places a smoothing cubic B-spline through the contour vertices. 
To achieve the smoothing effect, five additional vertices are calculated on the B-Spline 
between the vertices of the unsmoothed contour. Note the B-Spline produces the best-
looking contours; however, the B-Spline is also the slowest method.  

 
Registration 
Contour placement is dictated by the major and minor interval. The placement can be offset by 
the value typed into the Registration field. The elevations at which contours are drawn is equal 
to the Minor Interval plus the Registration value. For example, a Minor Contour Interval of 10 
and a Registration value of 0.5 will result in contours drawn at elevations 10.5, 20.5, 30.5, etc. 
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Range or Single 
When Range is selected, contours may be placed for a specific Minimum Z and Maximum Z 
elevation range as shown below. The Read button is used to set the Minimum Z and Maximum 
Z values based on the elevation range of the current TIN file. 

 
The Single option is used to plot a single contour line at the specified elevation. 

 
There are four sub-items to set the contour symbology: 
 

Major Lines 
The Major Lines item is used to set the element symbology for the major contour lines. 
 
Major Labels 
The Major Labels item is used to set the text symbology for the elevation labels placed along the 
major contour lines. The Distance Between Labels can be set using the key-in field. 
 
Minor Lines 
The Minor Lines item is used to set the element symbology for the minor contour lines. 
 
Minor Labels 
Minor Labels are typically not shown on ODOT plans. 

 
When the Load button is selected, the contours are drawn into the active design file. An example of the 
plotted contours is shown below. 
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2.4.4 Contour Label Editor 

Contour labels can be edited using the Contour Label Editor VBA application.  The application can be 
accessed from the ODOT pull-down menu as shown below: 
 

 
 

When accessed, the dialog shown below is opened. 
 

 
 
The application has the following three editing options: 
 

 Slide Label 

 Remove Label 

 Flip Label 
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Tip: 
The number of decimal places 
shown in the Cursor Point Values 
portion of the dialog is based on 
the GEOPAK User Preferences. 

2.5 Height / Slope Tool 

The Height / Slope tool is used to query the selected TIN file for the plan view coordinates, elevation, 
and slope at an identified location on the TIN model. 
 
From the DTM tool frame, select the Height/Slope icon to access the Height / Slope dialog shown below. 

 
 
To determine the Elevation or Slope: 
 

 Key-in the name of the TIN File, or use the Select File icon to the right of the key-in field. 
 

 Select the Mode, either Elevation or Slope. If the Mode is Elevation, turn on the desired Show 
features. If the Mode is Slope, set the Display Options. 

 
 Turn on Display Only if you do not want the data drawn into the MicroStation file. 

 
 Click Start. Move the cursor over any location within the 

boundary of the triangulated model. The plan view 
coordinates, elevation, and slope of the triangulated model 
are dynamically displayed in the Cursor Point Values portion 
of the dialog. If the cursor position is outside the limits of the 
triangulated model, only the X and Y coordinates of the 
cursor location are displayed. 

 
 Issue a Data Point to place the text in the design file. If Display Only is toggled off, the slope or 

elevation text will be written to the file. The text font and size is based on the active 
MicroStation settings and the active Model Annotation Scale. 
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Display options for Elevation Mode 
When Elevation is selected, the dialog appears as shown below. 

 
Three options are available in Elevation mode: 
 

Show Contour - displays a contour of the same elevation as the selected point. 
 

Show Triangle - identifies the triangle wherein the point is located. 
 

Show Flow Arrow - displays an arrow to indicate direction of flow from the selected 
point. 

 
To utilize any option, simply activate the toggle to the left of the option, and then select the 
desired color. The Contour, Triangle, and Flow arrow are dynamically displayed as shown in the 
example above. 

 
When a data point is issued, the elevation is placed in the design file along with the contour, 
triangle, and flow arrow options if they are toggled on. If Display Only is toggled on, the 
elements are not written to the file and will be erased from the screen when an update view 
command is issued. 
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Display options for Slope Mode 
When Slope is selected, the Options portion of the dialog changes as shown below. 

 
Slopes can be displayed in a variety of formats, such as rise:run, run:rise, percent, and unit/unit. The 
slope can be the specified as the triangle slope at the point of the cursors or between points. 
 
When a data point is issued, the slope value is plotted in the design file. If Display Only is toggled on, the 
elements are not written to the file and will be erased from the screen when an update view command 
is issued. 
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2.6 Profile Tool 

The Profile tool is used to extract a profile from the TIN model along a user defined line or line string. To 
access the Profile tool, select the Profile icon from the DTM tool frame as shown below. 

 
The main dialog has three tabs: 
 
 Object Selection 

Used to select the TIN file and set the symbology for the profile. 
 
Create Profile 
Used to define the location to extract the profile, and preview the results. 
 
Profile Preferences 
Used to set the grid scales, text parameters, elevation, and station ranges for the profile. 

 
To extract a profile, take the following steps: 
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 Identify the TIN file(s) and set symbology for the profile line(s). 
 

 Select or draw the element whose X,Y values are utilized to generate a profile along the TIN 
Model. This is accomplished via the Profile tab. 

 
 Set the element symbology and text parameters for the grid. In addition, Minimum and 

Maximum Stations and Elevations may also be set. This is accomplished via the Preferences tab. 
 

 Generate the profile and view it in the Profile window. Optionally, draw the profile into the 
MicroStation file. These activities are accomplished via the Profile tab. 

 
 (Optional) Create a Legend or store the profile into COGO via the Selection tab. 

 
The Selection, Profile, and Preferences tabs are discussed in more detail on the following pages. 
 

2.6.1 Object Selection Tab 

The selection tab, shown below, is used to select the TIN File(s) to use for profile extraction and to set 
the symbology for the profile line(s).  

 
The triangulated model is specified in the TIN File key-in field or by using the Select Files icon 
immediately to the right of the key-in field. 
 
The Symbology box, immediately to the right of the Select Files icon, is used to 
set the element symbology for the profile lines. Floating your cursor over the 
symbology box will reveal the current settings as shown at right. 
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The symbology for the profile line is set by double-clicking the element symbology box to access the 
GEOPAK Set Feature dialog, shown below.  

 
Once you have selected the TIN File, and set the symbology for the profile line, you must add the TIN file 
name to the list of files to be processed. The three icons to the right of the dialog are used to accomplish 
this task. Each icon is described below. 
 

 Add List Item 
Press the Add button to add the TIN file to the list of files to process. 
 

 Modify List Item 
To modify a line that has previously been added to the list box, highlight the line to be modified, 
change the desired field(s) then press the Modify button. 
 

 Delete List Item 
To delete a line, simply highlight the line then press the Delete button. 

 
Create Legend 
Once the desired TIN model(s) have been added to the list box, a legend can be created. This is 
accomplished by clicking Create Legend in the lower left corner of the dialog, opening the Legend 
Definition dialog shown below. 

 
Specify the Title of the legend along with the Text and Border parameters. After the symbology is set, 
click Place Legend, which attaches the legend to the cursor. A data point places the legend in the design 
file.  
 
After a profile has been extracted using the Create Profile tab, select the TIN file in the list box to reveal 
three additional icons, displayed directly below the edit buttons, on the right side of the Selection tab 
dialog. 
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 Show Extracted Points 
When pressed, small circles are displayed in the plan view wherever profile points are extracted. 
This option is only visible after a profile has been extracted and the line is highlighted in the list 
box. 
 

 Export to ASCII File 
Highlight one line within the list box, and then press this button to export the profile based on 
the highlighted TIN to the user specified File. When pressed, the ASCII File for Exported Profile 
dialog opens, wherein the file name may be specified. Note the profile element must be 
selected (or placed) prior to exporting to ASCII. One sample fragment from and ASCII export is 
illustrated below. 
 

0.000 870.553 

53.542 870.814 

84.516 870.184 

158.611 868.678 

211.744 868.913 

 
The format for the file is Station Elevation. 
 

 Store to GPK 
This option is only visible after a profile has been extracted and the line is highlighted in the list 
box. Highlight one line within the list box, then click to create an input file of the profile, based 
on the highlighted TIN. When pressed, the COGO Input File for Exported Profile dialog opens, 
wherein the file name may be specified. Note the profile element must be selected (or placed) 
prior to exporting to ASCII. One sample fragment is illustrated below. 
 

STORE PROFILE ???? 

VPI 1 S 0+00.00 E 870.553 

VPI 2 S 0+53.54 E 870.814 

VPI 3 S 0+84.52 E 870.184 

VPI 4 S 1+58.61 E 868.678 

END PROFILE 

 
Note the ???? must be replaced with a valid profile name before the file is imported into COGO. 
 

 Place Extracted Line in 3D 
When pressed, GEOPAK draws a line string denoting the location of the generated profile. This 
option is only visible in a 3D file after a profile has been extracted and the line is highlighted in 
the list box. 
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2.6.2 Create Profile Tab 

 
Three action buttons are available on this tab: 
 

Select Element 
Identify a previously drawn MicroStation element, i.e., line, curve, line string, etc., to extract a 
profile along the element. Once identified, the Place Profile button is enabled. 
  
Place Element 
Allows the user to identify the profile location by placing a temporary line or line string in the 
Design File to be used in lieu of selecting a graphic element for which the profile will be 
extracted. 
 
Place Profile 
To place the profile into the MicroStation file, simply press the Place Profile button and select a 
data point in a blank area of the file. The profile is drawn as depicted below utilizing symbology 
in the Preferences tab. 

 
Curve Stroking 
This option is utilized to add interpolated shots along curves, if required. 
 
Extracted Profile View 
Once the line has been selected or placed, the profile is fitted within the view window as shown above. 
Note that all displayed element symbology is defined within the Preferences tab. 
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2.6.3 Profile Preferences Tab 

The Preferences tab consists of a variety of element and text parameters discussed below. 

 
Scale 
Specify the Horizontal and Vertical scale utilized to draw the profile. Note the horizontal is drawn to 
true measurements, while the vertical is distorted. 
 
Elevations 
When the Reset Vertical button is pressed, the Minimum and Maximum values from the TIN file are 
populated in the appropriate fields. The user may choose to round the values in order to draw a 
complete grid. 
 
Stationing 
The profile is stationed from 0.00. Pressing the Reset Stations button sets the fields to the beginning 
and end of the profile element. Once again, to draw a complete grid, the user may round off the values 
in the fields. 
 
Horizontal Grid, Vertical Grid 
These options are used to specify element and text symbology for the horizontal and vertical grid lines. 
The information is utilized within the Profiles tab and also when drawing the profile into the 
MicroStation file. 
 
Major Interval is the distance between the major grid lines, while the Minor Interval is the number of 
lines between each major grid. GEOPAK supports unique symbology for both major and minor intervals. 
The levels SH_Major_Grid_Line and SH_Minor_Grid_Line should be used for Major Symbology and 
Minor Symbology values as shown above. Double-click the symbology boxes to set the values. 
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3 Coordinate Geometry 

3.1 Introduction 

The most important component of any GEOPAK design project is the Coordinate Geometry (COGO) 
database. The database is used to store geometric elements such as points, lines, curves, spirals, chains, 
parcels and profiles. Survey information, processed through GEOPAK Survey, is also stored in the COGO 
database. This database is used by various GEOPAK processes for a variety of tasks. 
 
The database is recognized by its file name, job***.gpk, where *** is a one to three alphanumeric 
character job number. 
 
The following element types are stored in the GEOPAK COGO database: 

 Points 

 Lines 

 Curves 

 Spirals 

 Chains 

 Profiles 

 Parcels 

 Survey chains 
 
This database file is initially created by the Survey personnel for each GEOPAK project. You will normally 
be provided with a GPK file with your ground survey data. In the event that you do not receive a GPK file 
with your survey data, a new GPK file must be created for each project. Two element types are stored by 
GEOPAK Survey: Points and Survey Chains. 
 

 Survey points represent individual survey shots, such as a telephone pole or an elevation shot 
that are not connected to another point. Each survey point is assigned a COGO point number 
and stored in the GPK file. 

 

 Survey chains are comprised of a set of survey points connected together to represent a linear 
feature such as an edge of pavement or a drainage pipe. 

 
An unlimited number of Points, Curves, Lines, Spirals, Chains, Profiles, Parcels, or Survey Chains can be 
stored in the GPK file. 
 
To access the GEOPAK Coordinate Geometry functions, select COGO from the Road Tools palette as 
shown below. 
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You can also access COGO from the main MicroStation Applications pull down menu by selecting 
Applications > Road > Geometry > Coordinate Geometry. 

 
When COGO is initiated, the Coordinate Geometry dialog below will appear: 
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The window consists of a pull-down menu, icons, a COGO key-in combo box, and a Command Output 
window. It is resizable by dragging any side or corner. In addition, the entire dialog is completely 
customizable, for ease of use. 
 
The individual COGO functions can be accessed in a variety of ways as summarized below: 
 

 The pull down menu bar provides a quick and easy method to access various COGO commands 
via dialogs. 

 

 Commands can be keyed in manually via the COGO Key-in field. 
 

 Commands can be accessed directly via the Command Icons. The icons displayed on the main 
COGO dialog box can be customized by the user to allow direct access to the most commonly 
used functions. 

 
Once a command has been executed, the output field is where the results of each command are 
displayed. 
 
A listing of the previously used commands is available via the drop down menu just to the right of the 
Key-in field. 
 
An example of a command to store a COGO point, and the resulting output is shown below. 
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3.2 COGO Processing 

When a coordinate geometry command is generated, whether it is via a dialog box or a command line, 
the command is added to a buffer in memory. The buffer provides an “audit trail” list of all coordinate 
geometry commands that you have processed during the current session. 

 
When each command is processed, the results are displayed in the coordinate geometry output 
window. 
 
The audit trail of coordinate geometry commands contained in the memory buffer can be optionally 
saved into an Input File. These input files can be later retrieved and loaded into the buffer whereupon 
the COGO commands can be edited and reprocessed. See Section 3.12 for more information on saving 
input and output files. 
 
It is important to note that all COGO elements are immediately stored in the GPK file. It is not necessary 
to manually “save” the contents of the GPK file before exiting COGO. When exiting COGO, the user is 
prompted as to whether or not the input file should be saved. 

 
A Yes response to this prompt merely saves the input file, as the COGO Elements that were generated as 
a result of the commands are already stored within the database. A No response will exit the coordinate 
geometry session without saving the contents of the buffer into an Input File. 
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3.3 COGO Element Naming Conventions 

As elements are stored in the GPK file, each element is given a unique name. COGO element names have 
specific rules that must be followed: 
 

Point names can be alphanumeric, but not numeric-alpha. For example, R2 is supported, 
however, R2D2 is not. If the point is all numeric, there is a maximum of 8 characters. If it is 
alpha-numeric, there is a maximum of 15 characters. No special characters (such as hyphen, 
percent, slash, etc.) are supported. 
  
Curves, Spirals, Lines, Chains, Parcels, Profiles, and Survey Chains can have alphanumeric names 
with a maximum of 15 characters. Underbars and hyphens are supported, but no other special 
characters. 

 
The ODOT CADD Engineering Standards Manual Section 306 establishes guidelines for standard COGO 
Element names. The manual is available at the following URL: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/CADDManual.aspx 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/CADDManual.aspx
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3.4 Customizing the COGO Dialog 

The COGO dialog can be customized in a variety of ways to facilitate the needs of the individual user. 
This enables the user to select which icons (if any) are displayed on the screen, display the COGO key-in 
command line, etc. For example, the COGO dialog could be configured to only display the Key-in field 
with the pull down menu as shown below: 

 
The customization is easily accomplished via the View pull down commands, as shown below. 

 
Icons 
Select the icons to be displayed at the top of the COGO dialog. These can be selected by group, 
(i.e., file, edit, element, etc.) or individually. 
 
Redefine 
Displays the define / redefine toggle.  
 
Visualization 
Options determine whether COGO commands are temporarily visualized, permanently written 
into the file, or not displayed. In addition, the feature database file, which controls the 
visualization symbologies, is specified. 
 
Format 
Options for a variety of user parameters are supported, i.e., number of decimal places, station 
format, etc. 
 
COGO Key-in 
Displays the COGO Key-in combo box. 
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Command Output 
Options include text coloring, navigation buttons, and file utilities such as saving and clearing of 
the output window content. 
 
Error Alert 
Audio and visual options when GEOPAK encounters a syntax or operator error. 

 
Within the Icon, Visualize, and Format pull-downs, several common procedures are supported. These 
are detailed below. 
 

Attach This Group 
Attaches all checked items (settings or icons) in the group to the COGO dialog. If a group is 
attached, an individual item can be added to the COGO display by simply toggling on that item. 
 
Detach This Group 
Detaches all checked items (settings or icons) in the group from the COGO dialog. If a group is 
detached, toggling on an individual item in a group does not add that item to the COGO dialog. 
The group must be attached before an item is shown in the dialog. 
 
Check All Items 
Selection of this pull-down is used to toggle on all items in this group, regardless of their current 
status. If the group is already attached, the checked items are dynamically added. 
 
Uncheck All Items 
Selection of this pull-down un-toggles all items in this group, regardless of their current status. If 
the group is already attached, the unchecked items are dynamically removed. 
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3.5 Visualizing COGO Elements 

The visualization tools within GEOPAK are used to display COGO elements as they are stored, or 
elements that have been previously stored can be redisplayed. These visualization graphics are drawn 
using features from the currently selected Survey Manager Database (SMD) file. The SMD file is specified 
by use of the GEOPAK User Preferences dialog box. 
 
The visualization group can be customized, attached or detached by selecting View > Visualization from 
the Coordinate Geometry dialog as shown below. 

 
In the example above, On/Off Control, Feature, and Browse Feature Library (SMD) are toggled on. Each 
option is displayed on the main COGO dialog as shown below. 

 
Visualization On/Off Control 
The Visualization On/Off Control will allow you to select how COGO elements are placed in the design 
file. Three options are available as detailed below. 
 

Disable Visualization 
When a COGO element is stored, no visualization graphics will be displayed in the design file. 
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Tip: 
Regardless of the type of 
visualization (Temporary or 
Permanent), GEOPAK can 
visualize to a level that is not 
active, in which case the 
visualized element does not 
appear. Therefore, verify that 
levels being visualized are 
active, as GEOPAK does not 
activate them automatically. 

Temporary Visualization 
When a COGO element is stored, visualization graphics will be 
drawn in the design file for the element. These graphics are 
temporary graphics and will be removed from the file upon 
exiting COGO. 
 
Permanent Visualization 
Elements drawn with Permanent visualization are written to 
the design file and will remain in place upon exiting COGO. 

 
Use Permanent mode if you are drawing the survey data in a 
new design file or adding additional existing features to the 
GPK file. 

 
Use Temporary mode if you are drawing proposed information. This information will be plotted 
to the design file permanently by use of the D&C Manager, covered in section 5 of the training 
guide. 

 
Feature 
In this key-in combo box, located to the right of the Visualization On/Off Control, the active feature is 
displayed. The feature name may be typed in or selected using the Browse button. Once a feature has 
been selected, a history list of the session is created on the pull down, enabling the user to reselect 
previously utilized features. Two default options are displayed within the Feature field: Off and Delete, 
which correspond to command line options from prior versions of GEOPAK. 
 
When the Off option is set, any element subsequently stored does not have a Feature attached. This is 
also a useful setting when modifying points which were assigned several different features. For example, 
several points need to have their coordinates modified, but some are trees, others are power poles, 
some are light poles. Rather than changing each feature as you are editing, simply set the Feature to 
Off. The original stored Feature is maintained while you edit the required data. The Delete Feature 
deletes any feature on subsequent commands, or does not attach features to newly stored elements. 
 
Drawing Elements with the default feature (Feature OFF) 
In the event that no feature is selected (Feature Off), GEOPAK will draw Temporary and Permanent 
visualization graphics using default features for each element type (points, curves, spirals, chains and 
parcels). The default features have been defined as follows in ODOT.smd: 
 

COGO Feature Level Weight Color Line Code Cell 

Points GK_Visualization 1 3 NA X 

Curves GK_Visualization 1 6 0 NA 

Spirals GK_Visualization 1 1 0 NA 

Chains GK_Visualization 1 3 0 NA 

Parcels GK_Visualization 1 2 0 NA 

Easement GK_Visualization 1 18 0 NA 

Taking GK_Visualization 1 21 0 NA 

Lines GK_Visualization 1 7 0 NA 

Survey Feature Default 2 3 NA NA 
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Drawing Elements by Selecting an active Feature 
If you wish to store COGO elements with a feature from the Survey Manager Database file (SMD), The 
Feature field can be used to key in the name for the active feature, or the Browse button can be used to 
select a feature from the current SMD file. Selecting the Browse button will access the Select Survey 
Item... dialog shown below. 

 
Select the item from the SMD file that you wish to designate as the active feature. The COGO dialog will 
reflect the selection as shown below. 

 
The active feature has been set to T for a Tree. All COGO Graphics will be plotted using this feature until 
it is changed or turned off. 
 
Since the features used for Visualization are taken from the Survey Manager Database file (SMD), only 
features corresponding to existing topographical information are available. Proposed items are not 
available in the SMD file. 
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Tip: 
It is good practice to leave the 
Redefine option toggled off 
until it is specifically needed. 
If Redefine is left toggled on, 
and COGO element stored 
with the same name as a 
previously stored element will 
overwrite the previous 
definition of the element. 
There is no “undo” in COGO. 

3.6 Redefine 

As elements are stored in COGO, each element is given a unique name. If 
an element is stored with a name that already exists in the GPK file, the 
user must instruct the software whether to overwrite the previous 
definition of the element or now. This is accomplished with the Redefine 
option. 
 
When the Redefine option is toggled on, an element stored with the 
same name as a previously stored element will overwrite the previous 
definition. You are not prompted whether you would like to redefine the 
element. 
 
If Redefine is not toggled on, any attempt to overwrite previously stored data will not be processed and 
a "Data Already Exists" message is displayed. The new definition of the element is not stored in the 
database. 
 
The Redefine option can be turned on/off in one of two ways: 
 

 From the COGO dialog, select File > Preferences > Redefinition of Elements to toggle the 
current value off or on 

 
 Select View > Redefine to display the Redefine toggle on the face of the COGO dialog. The 

status can be toggled on/off using the check box. 
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3.7 The COGO Element Menu 

The Element commands are the foundation for GEOPAK Coordinate Geometry. These commands are 
used to store, modify, and view reports on the various elements stored in the database. 

 
This section will provide a summary listing of the commands used to store COGO elements. 
Documentation for the individual commands can be found in the GEOPAK online help. 
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3.7.1 Element Menu: Point Commands 

 
The most basic command in GEOPAK coordinate geometry is the storing of points. Numerous formats 
and various types of data (i.e., coordinates, stationing, elevations, cells) can be combined to provide the 
designer with maximum flexibility. The required information to store a point is an alphanumeric point 
number and N/E or X/Y coordinates. If the coordinates must be computed at a distance and direction 
from another point, then a locate command rather than a store command will be used. Once a point has 
been stored, it can be recalled to view the coordinates, printed in an output file, or used to compute 
other points. 
 
There are two types of point elements, COGO points and Survey points. COGO points are generated via 
the GEOPAK Coordinate Geometry point options. Survey points are stored by GEOPAK Survey when the 
survey data is processed. 
 
The following commands are available from the Points menu: 
 

Utility Displays a list of all stored points, has options for deleting, printing, or visualizing points 

Cell Associates a cell to a previously defined point 

Copy Copies points or a point range to a new point number or range within the same GPK file 

Elevation Adds an elevation to a previously defined point 

Equate Stores a new point with the same values as a previously defined point 

Station Stores the specified station to a previously defined point 

Store Stores a point in the GPK file 

Transform Routines to transform a set of points into a new coordinate system 

Compare Points to TIN This reporting tool compares the elevation to selected COGO points to the TIN elevation 
of the same X, Y coordinates 

Set Elevation from TIN The Set Point Elevation by TIN Surface tool adds or updates an elevation to a previously 
defined point, based on a TIN model 
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3.7.2 Element Menu: Line Commands 

 
The following tools are available for Lines: 
 

Utility Display, Transpose, Delete, Print, or Visualize previously stored lines 

Cell Stores a line based on one point and a direction, or two points 
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3.7.3 Element Menu: Curve Commands 

 
A Curve is defined in GEOPAK as a segment of a circular arc in the horizontal plane. Curves can be 
defined by arc definition (central angle which subtends a 100 ft. arc) or chord definition (central angle 
which subtends a 100 ft. chord). Alphanumeric names up to 15 characters can be assigned to each 
curve. Delta angles greater than 180 degrees are supported in GEOPAK. 
 
The following curve commands are supported via the Curve menu: 
 

Utility Display, Transpose, Delete, Print, or Visualize previously stored curves 

Copy Copies a specified curve to another curve name 

Data Calculates the geometric parameters of a curve between two given points 

Segment Defines new curves by dividing a stored curve into segments 

Station Defined the stationing for the selected curve element 

Store By Tangents Defines and stores a circular curve using optional directions and curvatures 

Store By End Points Defines and stores a circular curve from the PC and PT 

Store Concentric Defines and stores a new curve as an offset from a previously defined curve 

 
Additionally, the following key-in only commands are documented in the GEOPAK on-line help: 
 

Station on Curve Re-stations a Point by projecting the point radial to the curve 

Store Curve Thru Stores a circular curve passing through three previously stored points 

Store Curve as Circle Store a circular curve by use of the center or radius point and the radius distance 

Locate Tangent to 
Curve 

Store a new point on a curve at the point of tangency of a line 
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3.7.4 Element Menu: Spiral Commands 

 
Spirals are transitional curves which provide a gradual change in curvature between a tangent and most 
circular curves or between circular curves of substantially different radii. The transition curve length 
provides a natural path for drivers and a convenient location for superelevation runoff. The Euler or 
clothoid spiral is used in GEOPAK. The following Spiral commands are supported via the pull down 
menu: 
 

Utility Display, Transpose, Delete, Print, or Visualize previously stored spirals 

Copy Copies a specified spiral to another spiral name 

Store Stores three geometric elements: back spiral, circular curve and ahead spiral 

 
Additionally, the following key-in only commands are documented in the GEOPAK on-line help: 
 

Store Spiral-Type 1 Stores spirals from a tangent to a circular curve 

Store Spiral-Type 2 Stores spirals from a circular curve to a tangent 

Store Spiral-Type 3 Stores spirals from a flatter curve to sharper curve 

Store Spiral-Type 4 Stores spirals from a sharper curve to flatter curve 

Spiral Data Calculate the geometric parameters of a spiral 

Offset From Spiral Calculate and display the radial offset distance from a spiral to a point(s) 
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3.7.5 Element Menu: Chain Commands 

 
GEOPAK Chain Commands create and store horizontal alignments composed of stored points, curves, 
spirals, SCS curves, shifts and other chains. Each new element is connected or linked to the previous 
one, forming an ordered succession of links to be stored in the database. The following Chain commands 
are supported via the pull down menu: 
 

Utility Display chains, Compute Area, Describe, Delete, Print, and Visualize chains 

Layout Offset Compute station, offset, distance and direction between two chains or a chain and a 
point(s) 

Station Re-stations the chain starting from the specified element 

Station Equation Store a station equation on the chain 

Store From Elements Store a new chain by linking elements 

Store Offset Chain Compute and store a chain parallel to a stored chain 

Store Transition Chain Store a chain comprised of a series of station/offset values from a stored chain 
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3.7.6 Stations and Station Equations 

In GEOPAK COGO, the station values are stored with the individual COGO elements. The Chain is merely 
a list of COGO elements (points, curves, and spirals) that are connected to define the chain. 
 
When storing a chain, the Store Chain from Elements dialog provides three options to assigning the 
stationing to the elements that make up the chain: 

 
Begin at 0.00 
The Begin at 0.00 option ignores stationing values previously assigned with the individual 
elements and assigns station 0+00 to the beginning of the chain. Every element in the chain is 
redefined with a new station value relative to the beginning station of 0+00. 
 
Begin Station 
The Begin Station option is used to key in a specific beginning station for the chain. This option 
ignores stationing values previously assigned with the individual elements and assigns the 
station keyed in by the user to the beginning of the chain. Every element in the chain is 
redefined with a new station value relative to the beginning station. 
 
As Is 
The As Is option preserves the station of each individual element. Care must be exercised when 
utilizing this option, as any inconsistencies in stationing from one element to the next will result 
in the addition of a station equation. This option is not recommended. 

 
Station equations can be stored at any point on a GEOPAK chain with the exception that equations are 
not permitted within the limits of a spiral. There are two types of equations as shown on the following 
page: 
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Overlap Station Equations 

 
Overlap station equations present the possibility of the same station occurring more than once on the 
chain. In the example below, station 102+00 occurs before the station equation and after the equation. 
In order to differentiate between the two stations, GEOPAK treats each portion of the chain as a 
“region”. Station 102+00 before the equation is designated as “102+00 R 1”. Station 102+00 after the 
station equations is designated as “102+00 R 2”. 
 
 
Gap Station Equations 

 
It is not necessary to specify the region number with Gap station equations. 
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3.7.7 Element Menu: Parcel Commands 

 
The GEOPAK parcels component can store property lines, taking lines, easement lines and building 
outlines. Property lines define the border of public or private property. Taking lines are typically 
proposed right-of-way lines associated with the new or expanded roadway project. Easements are used 
to supplement the right-of-way requirements for use on lands outside the roadway right-of-way for 
temporary construction purposes, permanent drainage and/or utility maintenance. 
 
Areas are calculated for closed parcels. These areas include the parcel area, the area taken from the 
parcel subsequent to the definition of a taking line, the area remaining in the parcel subsequent to the 
definition of a taking line, and easement areas. For an open parcel, areas are not calculated but the 
elements of the open parcel are stored. 
 
Optionally, the user can substitute user defined phrases for the default wording in the legal description. 
 
The Parcel commands are not covered in this training class. 
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3.7.8 Element Menu: Profile Commands 

 
Profile Commands are components of GEOPAK which are used to store vertical alignments and to define 
a series of grade lines, each of which intersects at a Vertical Point of Intersection (VPI), with or without 
parabolic vertical curves. All distances along vertical curves are measured horizontally so that the length 
of a vertical curve is expressed as its horizontal projection. A vertical curve is said to be symmetrical 
when the tangents are equal in length and asymmetrical when these tangents are unequal. 
 

Utility Display, print, and delete previously stored profiles 

Elevation Compute elevations along a profile 

Offset Generate and store a new profile at a vertical offset from a previously stored profile 

Restation Create a profile from a previously stored profile using the station defined by the user 

 
Storing proposed profiles is best accomplished via the Vertical Alignment Generator. See Chapter 8 for 
information on the Vertical Alignment Generator. 
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3.7.9 Element Menu: Next Available Settings 

 
When any tool requiring an element name is opened, the next available element name is used as the 
default. However, the user has the option to change to any supported element name.  
 
The user may set the next available element name by toggling on the element in the Next Available 
Settings, then entering the appropriate value. 

 
If GEOPAK encounters a name already in use, the next available feature skips over the already used 
name and does not overwrite current data regardless of the current setting of the Redefine toggle. For 
example, if the next available point name is 6, and points 8, 9, and 10 are already used, GEOPAK utilizes 
6 and 7, then skips to point 11 with no message given. 
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3.8 The COGO Tools Menu 

The tools menu provides a variety of useful functions. Each function is briefly summarized below. A 
detailed description of each command is available via the GEOPAK on-line help. Select Applications > 
Road > Help to access the on-line help. From the help dialog, select Command Reference > Geometry > 
Coordinate Geometry> Command Reference > Tools to view detailed information on the commands 
listed below. 

 
 
Navigator 
The Navigator is used to assist viewing, storing, manipulating, and editing coordinate geometry 
elements. See Section 3.9 for more information on use of the Navigator tool.  
 
Inverse 
The Inverse command computes and displays the distance and direction between each pair of specified 
points. 
 
Locate 
Locate Commands enable the user to locate and store point(s) by reading and processing from 
previously stored points, geometry and/or stationing. The following commands are available: 
 

Traverse Locate a new point at a direction and distance from another point 

By Angle Locate a point at an angle from a line formed between two points 

Tangent to Curves Locate and store two points at the tangent between two arcs 

On Element Store a new point on a previously stored curve, spiral or chain 

Point on Curve Store a new point on a curve from a point on the curve 

Along Element Store new points along a line, curve or chain 

Elevations by Profile Assign elevations to point(s) based on a specified chain and profile 
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Intersect 
The Intersect commands enable the user to locate and store point(s) by reading and processing from 
previously stored points, curves, lines, spirals and chains, all from one dialog. The following intersections 
are supported: 
 

Line-Line Intersection  Line-Arc Intersection  Line-Curve Intersection 
Line-Spiral Intersection  Arc-Arc Intersection  Arc-Spiral Intersection 
Curve-Curve Intersection Curve-Spiral Intersection Line-Chain Intersection 
Curve-Chain Intersection Spiral-Chain Intersection Chain-Chain Intersection 

 
Best Fit 
Based on a series of points, error estimates, and optional offsets, GEOPAK computes the best fit 
alignment utilizing a least squares methodology. 
 
Translation and Rotation 
Translate and rotate coordinates within a coordinate geometry database. 
 
Map Check 
The Map Check / Store Parcel tool enables the user to store or edit parcels (based on directions, 
distances, and curve data), and compute closure. Parcels can be loaded from the coordinate geometry 
database or manually typed in. Once a parcel is complete, pressing the Store Parcel stores or updates 
the parcel in the database. 
 
Roadway Intersections 
Based on user-supplied data, the Intersection tool draws a wide variety of roadway or right-of-way 
intersections and stores the geometry data within the coordinate geometry database. 
 
Cul-De-Sacs 
The Cul-de-sac tool enables the user to store a variety of cul-de-sacs based on user-defined inputs. 
 
Redraw Visualized Elements 
When selected, all visualized elements are redrawn. If the location of an element in the design file does 
not correspond to its coordinates in the database, the element is redrawn utilizing the database 
information. 
 
Clear Visualized Elements (Temporary) 
When selected, all temporary visualized elements are deleted. Please note that elements are not 
deleted from the database. 
 
Clear Visualized Elements (All) 
When selected all temporary and permanent visualized elements are deleted. Please note that the 
elements are not deleted from the database. 
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Exercise 3A – Existing State Route 185 

The approximate centerline for the existing S.R. 185 has been provided from the Survey department. 
Using the data provided below, store a chain named CLXS185. 
 

 Store point PI01 first, using these coordinates:  
N 723481.9012 E 1360611.9275 

 

 Store points PI02-PI04 using the Locate > Traverse 
command with the bearings and distances listed at right. 

 
 Store a curve named XS18503 using point PI02 as the 

backsite, point PI03 as the point of intersection and point 
PI04 as the ahead point. Use a radius of 300’ to store the 
curve. 

 
 Store a chain named CLXS185 using points PI01, PI02, 

PI04 and curve XS18503. Assign a beginning station of 
35+90.72 when you store the chain. 

 
After you have stored the chain, use the Describe Chain command 
to review chain CLXS185 and answer the following questions: 
 
1. What is the station at point PI02? _________________ 
 

2. What is the station at point PI04? _________________ 
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Exercise 3B – Existing Jameson Road 

The survey department has also provided a tangent line down the center of Jameson Rd. Store a chain 
named CLXJAME using the information provided below. 
 

 Store points PI05 and PI06 with the following coordinates: 
 

Point Name Northing Easting 

PI05 720,519.84 1,360,097.80 

PI06 720,330.15 1,360,542.17 

 
 Store chain CLXJAME using points PI05 and PI06. Set 10+00 as the beginning station. 

 
After storing the chain, answer the following questions: 
 
1. What is the bearing and distance from point PI05 to PI06? 

 
Bearing: _________________ Distance: _________________ 

 

2. What is the station at point PI06? _______________ 
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3.9 The COGO Navigator 

One of the most useful tools in the GEOPAK Coordinate Geometry software is the COGO Navigator. This 
one tool can be used for a variety of functions as summarized below: 
 

 Store new COGO elements. 

 Review/modify previously stored COGO elements. 

 Delete COGO elements. 

 Visualize individual or all COGO elements. 

 Describe COGO elements. 

 Select groups of elements, based on user defined search criteria, for further manipulation. 
 
The Navigator dialog, shown below, is accessed by selecting Tools > Navigator from the GEOPAK 
Coordinate Geometry dialog box. 

 
In order to use the navigator, the type of element to be reviewed edited or manipulated must be 
selected. The Element option button is used to select the element type as shown below. 

 
As each element type is selected, the list box displays all specified elements within the current 
coordinate geometry database. For example, if Point is selected, all of the COGO points stored in the 
GPK file are displayed in the list box as shown above. 
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Just above the Element option button, a row of command icons is available for basic element storing 
and manipulation. 

 
From left to right, the icons represent the following commands: 
 

 Add Element 

 Delete Element 

 Edit Element 

 Identify Element 

 Visualize Element 

 Print/Describe Element 

 Create a selection set 
 
Each of these commands work in conjunction with the currently selected element type.  
 
The Navigator dialog is resizable and the columns can be customized by right-clicking on the column 
heading to access the menu shown below. 

 
Up to four different dialog configurations can be stored for each Element type by use of the Save Layout 
option. Once a custom layout has been saved, it is available for recall on the menu. 
 
The Restore Defaults command is used to restore the Navigator dialog to its default display 
configuration. 
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3.9.1 Add Element 

With the Element option toggled to Point, selecting the Add Element button opens the Store Point 
dialog box as shown below. 

 
For each Element type, selecting the Add Element icon activates the following COGO Dialog boxes: 
 
 Point   Store Points 
 Line   Store Line 
 Curve   Store Curve from Tangents 
 Spiral   Store Spiral from Tangents 
 Chain   Store Chain from Elements 
 Survey Chain  This option is not available unless GEOPAK Survey is installed. 
 Parcel   Store Parcel 
 Profile   Invokes Vertical Alignment generator 
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3.9.2 Delete Element 

The Delete Element icon is used to delete the select COGO element. In the example below, the curve 
E185 is selected and will be deleted by executing the Delete icon. The software will prompt the user 
before executing the command, as shown below, depending on the status of the Redefine toggle. 
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3.9.3 Edit Element 

The Edit Element icon will invoke the appropriate Store Element dialog (based on the Element option) 
and populate the dialog with associated data for the selected element. In the example below, point PI05 
has been selected in the Navigator dialog. Selecting the Edit Element icon invokes the Store Point dialog 
box, with the values for point PI05 in the dialog box. After making the desired edits within the Store 
Point dialog, selecting Store Point will re-store point PI05 with the new values, depending on the status 
of the Redefine toggle. 
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3.9.4 Identify Element 

The Identify Element (ID) icon is used to select a COGO element in the Navigator dialog box by 
identifying the visualization graphics in a MicroStation design file. 
 
First, press the Identify Element button, then identify AND accept the COGO element to be identified. 
GEOPAK changes (if necessary) to the Element type of the selected element. For example, if the Element 
type is set to Chain, and a point is identified, GEOPAK changes the type to Point. GEOPAK identifies the 
selected point and highlights it in the Name / Feature display as shown in the example below. If the 
selected element is not a GEOPAK COGO element, the message “Not a GEOPAK COGO Element” is 
displayed on the lower left of the MicroStation window. 
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3.9.5 Visualize Element 

The Visualize Element tool is utilized to visualize any COGO element. First, either temporary or 
permanent visualization must be active (see page 3-9 for information on the visualization mode). 

 
In the example above, point PI01 is currently selected in the Navigator dialog box. Selecting Visualize 
Element will draw the selected COGO element into the MicroStation design file. Since point PI01 was 
not stored with any Feature, the default visualization is used for the graphics as shown above. 
If the elements were previously visualized, a second set of elements is not drawn. Rather, the previously 
placed graphics are updated to reflect the current information in the database. 
 
Visualization graphics for Curves and Spirals include symbols placed at the control point locations as 
shown in the example below. The control point graphics can be utilized by GEOPAK dialog boxes by 
selecting the elements. 
 
 
 
 
 
 
 
 
 
 
 
 
 
Additional visualization commands are available within the Navigator dialog via the Tools pull down 
menu, as shown below. 
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In order to use the visualization tools, either the Permanent or Temporary visualization must be active. 
These tools are summarized below: 
 

Visualize Element 
When selected, the highlighted elements are visualized, based on the associated Features. If no 
features are associated with the elements, the default features are utilized. 
 
Unvisualize Element 
When selected, the visualization graphics for the highlighted element(s) is deleted. Note that 
the element is not deleted from the database, just the visualization graphics. 
 
Visualize All: Points, Lines, Curves, Spirals, Chains, Survey Chains, Parcels, Elements 
Select the desired Visualize option from the option pull down menu. 
 
Redraw Visualized Elements 
When selected, all visualized elements are redrawn. If the location of a visualized element in the 
design file does not correspond to its coordinates in the database, the element is redrawn using 
the database information. 
 
Clear Visualized Elements (Temporary) 
When selected, all temporary visualized elements are deleted. Note that the elements are not 
deleted from the database. 
 
Clear Visualized Elements (All) 
When selected all temporary and permanent visualized elements are deleted. Note that the 
elements are not deleted from the database. 
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3.9.6 Print/Describe 

The Print/Describe element tool invokes a print point, print curve, describe chain, describe parcel or 
print profile command, based on the current element type. Simply highlight the desired element within 
the feature / list box, and then press the button. The appropriate print / describe command is issued. 
The results of the command are displayed in the main COGO dialog box, as shown below 
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3.9.7 Selection Tool 

The last icon on the Navigator dialog is used to access the Selection Set tool. The selection tool is used 
to select COGO elements based on a user definable search criteria. The Selection Set Tool dialog box is 
shown at right below. 

 
Several options are supported for the Selection Basis. As each option is selected, the dialog dynamically 
changes to reflect the current selection. These options include: 
 

 Name & Feature 

 Area Limits 

 Elevation Range 

 Linear Limits 

 Membership 

 Survey Attributes 
 
See the GEOPAK on-line documentation for detailed information on each option. For the purpose of this 
training guide we will illustrate using the Selection Set Tool dialog for a few common tasks. 
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Example 1: Find the station and offset for all the existing telephone poles. Get the coordinates for each 
telephone pole. 
 

 From the Navigator dialog, select Select > Clear Selection to clear any elements that may be 
currently selected in the Navigator. 

 
 Open the Select Set Tool dialog. The upper right portion of the dialog should read 0 Highlighted 

Items. 
 

 Toggle the Element option to Point in the Navigator dialog 
 

 Toggle the Selection Basis option to Name & Feature 
 

 Toggle the Feature option on 
 

 Key-in the name of the Telephone Pole feature, TP. 
 

 Pick the Select button. 

 
To satisfy the selection criteria above, a Point must be currently selected, Or it must have the Feature TP 
assigned. 10 telephone poles are found in the GPK file as shown in the upper right portion of the dialog 
above. These points are also highlighted in the Navigator dialog as show at left above. 
 
To get the coordinates for the highlighted items, select the Print/Describe Element icon from the 
Navigator dialog. The results of the Print/Describe command are displayed in the Coordinate Geometry 
dialog as shown on the following page. 
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This could have also been accomplished without the use of the Selection tool. You can sort the elements 
in the COGO Navigator dialog by selecting the column header. In the example below, the points are 
sorted by the Feature name. All the TP points are grouped together and can be easily selected. 
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Example 2: Let’s expand the selection set to include power poles along with the telephone poles that 
are already selected. Once we have selected all the telephone and power poles, let’s get the station and 
offset for each pole, but only the ones between station 50+00 and 60+00 along existing State Route 185 
within 50’ left and right of the centerline. 
 

 Make sure the Selection Basis criteria is toggled to Or as shown below 
 

 Type in a Feature name of PP for power poles 
 

 Pick the Select button 
 
Using the selection criteria above, a point must have the Feature PP Or it must have been one of the 10 
Highlighted Items that were found in Example 1. Our selection set now includes 50 points that have the 
Feature TP assigned, Or the Feature PP. 

 
Now let’s refine our search to find the telephone poles and power poles between station 50+00 and 
60+00, within 100’ of the centerline. 
 

 Toggle the Selection Basis option to Linear Limits 
 

 Change the Selection Basis criteria to and 
 

 Select the Chain CLES185 
 

 Toggle on the Station option. Key-in the station range for the search as shown below. 
 

 Toggle on the Offset option. Key-in offsets of -50 and 50 as shown below. 
 

 Pick the Select button 
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Using the selection criteria shown above, a point must be one of the 50 previously highlighted items And 
it must meet the Linear Limits defined above. There are 7 telephone poles or power poles between 
station 50+00 and 60+00, and within 50’ left and right of the centerline of existing State Route 185. 
 
The last step is to get the station and offset of these 7 points. To accomplish that task, use the Layout 
Offset tool. 
 

 From the Coordinate Geometry dialog, select Element > Chain > Layout Offset  
 

 Select the Baseline CLEXS185 
 

 Toggle the mode to Point 
 

 To populate the Point List field, select the Populate point list from COGO Navigator icon 
 

 Select the Compute button.  

 
The results are displayed in the Coordinate Geometry dialog as shown below. 
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The Select pull down menu is used in conjunction with the Selection Set tool. The dialog has the 
following functions as shown below. 

 
Select All 
Highlights all elements within the Name / Feature list box  
 
Invert Selection 
Reverses the highlighting 
 
Clear Selection 
Removes highlighting from those elements in the Name / Feature list 
that were previously highlighted. 

 
Fit View (Selection Set) 
First, highlight the desired elements in the Name / Feature list box. When this tool is selected, the 
screen is fitted to display only the selected elements. 
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3.9.8 Navigator Settings 

The navigator includes several tool settings for user flexibility. Select Tools > Settings from the 
Navigator dialog to access the dialog below. 

 
Alert Prior to Clearing Selection Set 
When activated and the user selects a command which 
requires a new selection set, an Alert message is displayed on 
the screen. 
 
Mouse Click Actions 

 
If the Single Click Highlight Visualized Element is 
active, a single click on any element within the Name / 
Feature list box highlights the visualized element in the 
MicroStation design file. 

 
 When the Single Click Window Center Visualized 
Element option is active, a single click on any element 
in the Name / Feature list box window centers the 
element in the MicroStation view. 

 
When Single Click Enables List Cell Edition is active the various fields in the Navigator list box 
may be edited. When toggled off, no editing within the Navigator list box is supported. 

 
Double Click Action 
As a shortcut to many of the frequently used element commands, 
this option enables the user to select one of the commands as 
shown at right. When an element in the Name / Feature list box is 
double clicked, the selected command in the tool settings is 
invoked. For example, if the Print Element command is selected in 
the tool settings, then when any element in the Name / Feature list 
box is double clicked, the print element command is invoked. If the 
Do Nothing option is selected, a double click does not invoke a command. 
 
Display Options 
If the current GPK file has both Survey points and COGO points, the View options support viewing all 
points (both survey and COGO), COGO only, or Survey Only. 
 
Area 
Options for Square Foot and Acre are supported, which are used in various parcel tools. A setting for 
number of decimal places for area computations is also supported. 
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Exercise 3C – Proposed State Route 185 

Store a centerline chain proposed S.R. 185 using the 
information provided below. 
 

 Use the Equate Point or Copy Point command to 

store points PI10-PI13 at the same location as 
points PI01-PI04. 

 
 Store a Spiral-Curve-Spiral combination using the 

curve data shown at right. 
 

 Using ODOT’s Recommended GEOPAK Naming 
Standards, what should you name the curve and 
spirals for this alignment? 

 
 Curve Name  _______________ 
 Back Spiral Name _______________ 
 Ahead Spiral Name _______________ 
 

 Store a chain for the proposed centerline of State 
Route 185 using 35+90.72 as the beginning station. 
Using ODOT’s Recommended GEOPAK Naming 
Standards, what should you name the proposed 
chain? 
 

 Chain Name  _______________ 
 
 
 
After storing the chain for proposed State Route 185, answer 
the following questions: 
 
1. What is the station at the ST of proposed State Route 185? ____________________ 
 
2. What is the station on the existing centerline of State Route 185 at the location of the ST of proposed 
State Route 185? __________________ (Hint: use “Layout Offset Chain Chain”)  
 

 Using the stations from questions 1 and 2, store a station equation on the proposed centerline. 
The Back station will be the station on proposed State Route 185 at the ST location. The Ahead 
station is the station where the ST of the proposed centerline chain meets the existing chain 
CLXS185. What should you name the point that is stored at the Station Equation? 
_______________ 

 
Tip: Make sure the redefine toggle is on before you initiate the station equation command. 
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Exercise 3D – Proposed Jameson Road 

Store a chain for the proposed relocation of Jameson Road using the information shown in the figure 
below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Store points PI15 and PI16 at the same location as points PI05 and PI06. 
 

 Store point PI17 such that the line defined by points PI16 and PI17 is perpendicular to 

proposed State Route 185. Hint: Point PI17 will intersect proposed S.R. 185 within the limits of 
the curve. In order to be perpendicular to a curve, the line defined by point PI16 and point 
PI17 must pass through the center (CC) of the curve. 

 
 Store a curve using the radius shown in the curve data above. Following the ODOT GEOPAK 

Guidelines, what should you name the curve? _______________ 
 

 Store a chain for proposed Jameson Road using 10+00 as the beginning station. Following the 
ODOT GEOPAK Guidelines, what should you name the chain? _______________ 

 
After storing the chain for proposed Jameson Road, answer the following questions: 
 

What is the station on proposed S.R. 185 at the intersection with proposed Jameson Road ? 
 
 What is the station on proposed Jameson Road at the intersection with S.R. 185 ? 
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3.10  The COGO File Menu 

When a coordinate geometry command is generated via dialog or command line, the command is added 
to a buffer in memory. The buffer provides an audit trail of all coordinate geometry commands that you 
have processed during the current session. This audit trail is created whether the COGO operations are 
generated via key-ins, dialog boxes or stored MicroStation graphics. 
 
The audit trail of coordinate geometry commands contained in the memory buffer can be optionally 
saved into an Input File. These input files can be later retrieved and loaded into the buffer whereupon 
the COGO commands can be edited and reprocessed. The adjusted buffer contents can be re-saved into 
the original Input File or saved into another Input File.  
 
To facilitate saving and retrieval of this audit trail, GEOPAK provides numerous commands within the 
coordinate geometry software. Saving, appending, loading, cataloging, and deleting audit trail input 
files, in addition to printing input and output file commands, assist the user in productively utilizing the 
coordinate geometry throughout the a project. These file commands are selected via the File menu and 
the Edit menu. 
 
In this section, we will summarize the available commands. See the GEOPAK online help for complete 
documentation of these commands. 

 
Input File Utility 
Includes options to load, save, delete, and print input and output files.  
  
Input File Restore 
Loads input files created via the Store Graphics dialog. 
 
Database Utilities 
Two utilities are available for database maintenance. 
 

Validate 
Looks for problems and errors in the GPK database and reports the findings. This command does 
not attempt to clean or compress the database. 
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Clean and Compress 
This command scans the current GPK file and removes any corrupt element(s). As part of the 
rebuilding process it also compresses the GPK file. The results of the rebuilding are saved in a log 
file in the same directory as the GPK file. 

 
Import 
The Import options listed below are available: 

 Merge GPK File 

 ASCII Points 

 SDMS Alignments and Points 

 LAND XML 1.0 Geometry 

 RDS 

 VDOT PLT 
 
Export 
The Export options listed below are available: 

 ASCII Points 

 SDMS Points 

 SDMS Alignments 

 LandXML 1.0 Geometry 

 Alignments and Profiles 
  
Exit 
Exits coordinate geometry session 
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3.11  The COGO Edit Menu 

Whereas the File commands control the file management of input and output files, the Edit pull down 
controls the content of the COGO command buffer. Numerous Edit commands within the coordinate 
geometry session facilitate basic modification, addition and deletion of lines within the active input file. 
From within the Coordinate Geometry window, these Edit commands are selected via the Edit pull down 
as shown below. 

 
A detailed description of each command is available via the GEOPAK on-line help. Select Applications > 
Road > Help to access the on-line help. Each item is summarized below. 
 
From the help dialog, select Command Reference > Geometry > Coordinate Geometry> Command 
Reference > Edit > Edit Commands to view detailed information on the commands listed below. 
 

Clear Removes the current list of COGO statements from the buffer 

Delete Deletes the specified line or range of lines 

Insert Inserts the specified line at the specified location 

Modify Replaces a specified text string with a redefined text string 

Read All Processes all lines in the current input file 

Type All Displays all lines in the current input file 

Line Range Reads or processes the specified line range 

Editor Invokes the GEOPAK text editor populated with the current input file 
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3.12  Working with COGO Input and Output Files 

COGO input and output file names can be user-defined, but must be within the software parameters as 
detailed below. For the example, assume the job number is 185, and the operator code is “tu”. 
 

File Type Naming Convention Example 

Database job***.gpk job185.gpk 

Input name***.iOC align185.itu 

Output name***.oOC temp185.otu 

Auto generated input j***oOC.inp j185otu.inp 

Journal jou***.iOC jou185.itu 

 
Input files contain a list of the commands that have been processed during a COGO session. The 
input file can be later retrieved and loaded into memory whereupon the COGO commands can 
be edited and reprocessed if desired. 
 
Output files contain the list of commands that were processed during the COGO session as well 
as the results of the command. 
 
The Journal Files are used to recover a coordinate geometry session that is abnormally 
terminated.  
 
During some of the procedures in GEOPAK, the software automatically generates an input file. 
The Store Graphics command is one example. In these cases GEOPAK names the created file 
j***oOC.inp where *** is the job number and OC is the operator code. 

 
This naming convention is enforced to allow the software to sort input and output files by type, operator 
code, and job number. When the Input File Utility dialog is accessed, by selecting File > Input File Utility, 
the name of previously stored files is shown in the dialog. Only the files that match the current operator 
code and job number are shown in the list box. An example is shown below. 
 

 
The Input File Utility commands are used to save both COGO input and output files. 
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From the COGO dialog, select File > Input File Utility to access the dialog below. 

 
The dialog has the following functions: 
 

Load Clears the COGO memory buffer and then loads (into memory) the current contents of a 
previously stored input file. Once loaded, the COGO commands entered in the input file can be 
processed (read), edited, modified or deleted 

Append Appends the specified input file to the current input file 

Catalog Displays a listing of all input files for the current operator within the specified project 

Delete Deletes the selected input file 

Output Save the COGO output in an ASCII output file in a format suitable for reviewing, editing or 
printing to a printer 

Print Input File Prints the selected input file to the Windows printer 

Print Output File Prints the selected output file to the Windows printer 

Save Saves an Input file containing the commands that have been processed during the current COGO 
session  
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3.12.1 Saving an Input File 

As commands are processed, the list of commands is available from the COGO Key-in field as shown in 
the example below. 

 
Commands can be selected from the list, edited directly in the COGO Key-in field, and reprocessed. The 
commands can also be edited and reprocessed in an editor by selecting Edit > Editor. 

 
To save an input file, take the following steps: 

 Select File > Input file Utility, and then select the Save option as shown below 
 Type in the Name and an optional Subject line for the input file 
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The file is saved in the current Working Directory. The actual file name is modified to comply with the 
naming convention detailed previously in this section. The resulting file name is demo185.itu. The 
content of the file is shown below. 
 

Copyright: (c) 2008 Bentley Systems, Incorporated. All rights reserved.    

Project:  12345_Design               

Subject:  STORE CHAIN DEMO              

Job No.  185    Operator: TU           

Date:  Thursday December 11, 2008 2:47 pm         

                     

SYSTEM FIX 4 ASEC 2 BEAR PRI 0 RED NE STA 2 FILE: 'DEMO'       

                     

                     

* 1 STORE POINT DEMO1 723810.40788423 1364341.1371467       

* 2 STORE POINT DEMO2 721975.88047186 1364443.5141026       

* 3 STORE POINT DEMO3 721798.94635595 1365672.0375731       

* 4 STORE CURVE DEMO PB DEMO1 PI DEMO2 DEGREE 6.0 PA DEMO3      

* 5 STORE CHAIN DEMO DEMO1 CUR DEMO DEMO3          

* 6 END 

 
 

3.12.2 Saving an Output File 

Output files are saved via the Input File Utility dialog. Take the following steps to save an output file. 
 

 Select File > Input file Utility, and then select the Output option as shown below 
 

 Type in the Name for the file 

 
The file is saved in the current Working Directory. The actual file name is modified to comply with the 
naming convention detailed previously in this section. The resulting file name is demo185.otu. The 
content of the file is shown below. 
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Copyright: (c) 2008 Bentley Systems, Incorporated. All rights reserved.    

Project:  12345_Design               

Subject:                   

Job No.  185    Operator: TU           

Date:  Thursday December 11, 2008 2:56 pm         

                     

SYSTEM FIX 4 ASEC 2 BEAR PRI 0 RED NE STA 2 FILE: 'DEMO'       

                     

                     

                     

*  1 Store Point DEMO1 723810.40788423 1364341.1371467      

                     

N 723,810.4079 E 1,364,341.1371 

Point DEMO1 redefined. 

                     

*  2 Store Point DEMO2 721975.88047186 1364443.5141026      

                     

N 721,975.8805 E 1,364,443.5141 

Point DEMO2 redefined. 

                     

*  3 Store Point DEMO3 721798.94635595 1365672.0375731      

                     

N 721,798.9464 E 1,365,672.0376 

Point DEMO3 redefined. 

                     

*  4 Store Curve DEMO PB DEMO1 PI DEMO2 Degree 6.0 PA DEMO3     

                     

         Curve Data 

         *----------* 

Curve DEMO      

P.I. Station    7+81.75 N  721,975.8805 E  1,364,443.5141 

Delta  =  78° 36' 37.44" (LT) 

Degree  =  6° 00' 00.00" 

Tangent  =   781.7456 

Length  =   1,310.1734 

Radius  =   954.9297 

External =   279.1760 

Long Chord =   1,209.8025 

Mid. Ord. =   216.0216 

P.C. Station    0+00.00 N  722,756.4116 E  1,364,399.9561 

P.T. Station   13+10.17 N  721,864.4419 E  1,365,217.2761 

C.C.        N  722,809.6193 E  1,365,353.4022 

Back  = S 3° 11' 38.81" E  

Ahead  = S 81° 48' 16.25" E  

Chord Bear = S 42° 29' 57.53" E  

Curve DEMO redefined 

                     

*  5 Store Chain DEMO DEMO1 CUR DEMO DEMO3         
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3.12.3 View > Command Output > Save Content As 

Output files are useful for saving a report containing specific information such as a Describe Alignment 
command, however keep in mind that the output file will contain the output for all the commands that 
have been run in the current COGO session. There is another way to save a report containing only the 
desired contents. 
 
The View pull down menu contains commands to clear the COGO window, and to save the contents of 
the COGO window as an ASCII file. The Clear and Save Content As… commands are shown below. 

 
Take the following steps to save an ASCII file with the results of a Describe Alignment command. 
 

 Select View > Command Output > Clear to clear the contents of the COGO window 
 Open the Chain Utility dialog by selecting Element > Chain Utility 
 Select the desired chain name from the list, and then select the Describe icon 

 
 Save the results of the Describe Chain command by selecting View > Command Output > Save 

Content As… to save the file. The contents of the file are shown below. 
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<*  5 Describe Chain CLXS185                       

                               

Chain CLXS185 contains:                          

 PI101 PI102 CUR XS185103 PI104              

                               

Beginning chain CLXS185 description                       

===============================================================================            

                               

Point PI101   N  723,481.9012 E 1,360,611.9275 Sta  35+90.72            

                               

Course from PI101 to PI102 S 0° 45' 30.00" W Dist 864.4200                 

                               

Point PI102   N  722,617.5569 E 1,360,600.4869 Sta  44+55.14            

                               

Course from PI102 to PC XS185103 S 1° 03' 01.00" W Dist 2,097.5253               

                               

         Curve Data                    

         *----------*                    

Curve XS185103                            

P.I. Station   67+42.79 N  720,330.2912 E  1,360,558.5548            

Delta  =  64° 43' 44.00" (LT)                      

Degree  =  19° 05' 54.94"                       

Tangent  =   190.1247                       

Length  =   338.9197                       

Radius  =   300.0000                       

External =    55.1724                       

Long Chord =   321.1816                       

Mid. Ord. =    46.6019                       

P.C. Station   65+52.67 N  720,520.3841 E  1,360,562.0397            

P.T. Station   68+91.58 N  720,245.9888 E  1,360,728.9676            

C.C.        N  720,514.8851 E  1,360,861.9893            

Back  = S 1° 03' 01.00" W                       

Ahead  = S 63° 40' 43.00" E                       

Chord Bear = S 31° 18' 51.00" E                       

                               

Course from PT XS185103 to PI104 S 63° 40' 43.00" E Dist 1,119.5753               

                               

Point PI104   N  719,749.5626 E 1,361,732.4663 Sta  80+11.16            

                               

===============================================================================            

Ending chain CLXS185 description                       
 
 
Note that the Describe Chain command in the sample file above was the fifth command processed 
during the COGO session. There are two Clear commands in the GEOPAK COGO pull-down menus. The 
commands differ as follows: 
 

Edit > Clear 
Issuing this command does not clear the COGO window. This command clears the COGO 
memory buffer. All commands previously processed are discarded and cannot be recovered 
unless they were saved in an Input File before issuing the Edit > Clear command. The next 
command that is entered will be command number one. 
 
View > Command Output > Clear 
This command clears the output window, but does not clean the COGO memory buffer. 
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3.12.4 Loading, Editing, and Reprocessing an Input File 

COGO Input files are ASCII files that can be edited using any ASCII text editor. The contents of an input 
file can be reloaded and edited directly in GEOPAK before reprocessing. 
 
To load a previously saved input file, take the following steps: 
 

 Select File > Input file Utility, and then select the Load option as shown below 
 

 Select the file and press Apply 

 
The contents of the file are loaded into memory. The first 10 lines of the file are displayed in the COGO 
window. 
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After loading the input file into memory, the command lines can be edited before processing as follows: 
 

 Select Edit > Editor to open the Cogo Command Line Editor shown below 

 
The contents of the file can be edited and reprocessed from this editor. Most of the functions in the 
editor are familiar text editing options. The dialog two specialized functions detailed below. 
 
The leftmost icon is Restore. When pressed, all information from the editor is placed in the COGO buffer 
and displayed in the Command Output window; however, none of the lines are processed. 
 
The second icon, Restore / Read, places the information in the COGO buffer AND processes all lines.  
 
When exiting the editor, the user is returned to GEOPAK, however any changes made within the editor 
are lost if a File > Save or Restore / Process command was not completed prior to exiting. 
 
Input files can also be reprocessed after loaded by selecting Edit > Read All from the main COGO dialog. 
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3.12.5 Make Input File 

Input files can be generated from COGO elements stored in the GPK file at any time by use of the Make 
Input File key-in command. The format of the command is as follows: 
 
MAKE INPUT FILE file-name element-list 
 
where: 

file-name Name of the input file where GEOPAK commands are written. 

element-list List of GEOPAK elements for which input file commands are to be created. The 
format for the element-list must include at least one of the following: 

  CHAIN name 

  CURVE name 

  PARCEL name 

  point number or range of point numbers 

  PROFILE 

  LINE name  

  SURVEY CHAIN name ( Survey Chains) 

  SPIRAL name 

  ALL 

 
The element names may include wild card characters. Selection of a chain implies the inclusion of the 
store chain command but also implies the inclusion of additional store commands for each individual 
component element (e.g., point, curve, or spiral comprising the chain). 
 
The Make Input File command is typically used to:  

 Reconstruct lost or disorganized input files or  
 Transfer elements to different job numbers. 

 
Example: 

Make Input File CLXS185.itu chain CLXS185 
 
The contents of the input file are shown below. 
 
$ Job Name: 185 

$ 

$ -- COGO CHAIN COMMANDS -- generated by pattern: CLXS185  

$ 

$ Chain CLXS185 

STO POI PI101 N 723481.9012000000 E 1360611.9275000000 STA 3590.7200000000 DESCRIPTION "PR SR185 PI 1" 

STO POI PI102 N 722617.5569117873 E 1360600.4868778947 STA 4455.1400000001 DESCRIPTION "PR SR185 PI 2" 

STO POI PI104 N 719749.5626393603 E 1361732.4663295001 STA 8011.1601781014 DESCRIPTION "PR SR185 PI 4" 

STO CUR XS185103 PC N 720520.3840512725 E 1360562.0397041284 DB 181.0502777778 D 19.0985931710 DEL -

64.7288888889 STA PC 6552.6652542104 

STO CHA CLXS185 PI101 PI102 CUR XS185103 PI104 AS IS 

$ 
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Exercise 3E – COGO Input and Output Files 

 Store an input file named TRAIN containing the COGO commands that you used during the lab. 
 
 What is the full name of the resulting file?  ____________________ 
 
 By default, where will the file be stored?  ____________________ 
 

 Store an output file named OUT containing the output for all of the COGO commands that you 
have run during the lab exercises. 

 
 What is the full name of the resulting file?  ____________________  
 
 By default, where will this file be stored?  ____________________  
 

 Describe the proposed S.R. 185 chain. Store an output file containing only the results of the 
Describe command. 
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3.13  Graphical COGO 

GEOPAK provides a set of Graphical COGO commands to store coordinate geometry elements, points, 
lines, curves, spirals, chains, and parcels, using a MicroStation “point and click” interface while 
maintaining full double precision. Elements placed using Graphical COGO commands are stored in the 
coordinate geometry database (GPK file). The Graphical COGO tools can be accessed from the GEOPAK 
Road Tools palette as shown below. 

 
Elements created with Graphical COGO commands are stored in the GEOPAK coordinate geometry 
database. A coordinate geometry session must be open whenever the Graphical COGO tools are 
invoked. If COGO is not active, you will be prompted to open a GPK file as shown below. 

 
Enter the Job Number and the Operator Code. The Project Name and Subject are optional. Select OK to 
access the Graphical COGO tool frame shown below. 
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Each icon in the tool frame is a tool box that one can be "torn off" to become a separate "tool box." The 
individual tool boxes can be docked and resized. There are four tool boxes, with the following titles: 
 

 Store Elements 

 Modify Elements 

 Manipulate Elements 

 Groups 
 
Operation of the individual Graphical COGO tools is very thoroughly documented in the GEOPAK online 
help. Select Applications > Road > Help to access the online help. From the online help, select Bentley 
GOPEK Road V8i > Command Reference > Geometry > Graphical Coordinate Geometry. A summary of 
the available tools is show in the next few pages. 
 

Store Elements 
The Store Elements tool box contains eleven icons: (from left to right) 

 
 Store a Point 

 Store Equally Spaced Points 

 Locate Point 

 Store Line From Existing Points 

 Store Line By Two Points 

 Store Tangent Line 

 Store Curve by Three Points 

 Store Curve by Center 

 Store Tangent Curve Constrained 

 Store Tangent Curve Unconstrained 

 Store Tangent Spiral 

 
Modify Elements 
The Modify Elements tool box contains nine icons: (from left to right) 

 
 Partial Delete 

 Extend Plan View Elements 

 Trim Elements 

 Intersect Elements 

 Extend Element to Intersection 

 Extend Elements to Intersection 

 Construct Circular Fillet 

 Construct Chamfer 

 Cut Element 
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Manipulate Elements 
The Manipulate Elements tool box contains four icons: (from left to right) 

 
 Move Plan View Element 

 Rotate Plan View Element 

 Copy Parallel 

 Delete Element 

 
 
Groups 
The Groups tool box contains two icons: (from left to right) 

 
 Store Chain 

 Store Parcel 

 
 
Element Names 
When COGO elements are stored using the Graphical COGO commands, the element name is 
automatically assigned using the “next available” element name. When any tool requiring an element 
name is opened, the next available element name becomes the default. However, the user has the 
option to change to any supported element name. 
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3.14  Horizontal Alignment Generator 

The GEOPAK horizontal alignment generator tools provide the capability to graphically design and 
modify horizontal alignments in either a MicroStation 2D or 3D file. The tool frame is displayed in 
response to selecting the Applications > Road > Geometry > Layout Alignments Horizontal pull down or 
from the GEOPAK Road tool palette as shown below. 

 
Elements created within the Horizontal Alignment Generator may be stored within a GEOPAK 
coordinate geometry database. However, a coordinate geometry session must be open whenever the 
generator is invoked. If COGO is not active you will be prompted to open a GPK file as shown below. 

 
Enter the Job Number and the Operator Code. The Project Name and Subject are optional. Select OK to 
access the Horizontal Alignment Generator tool frame shown below. 

 
 
 
 
 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 3 – Coordinate Geometry Page 3-63 
 

 
Preferences 
Select File > Preferences from the Horizontal Alignment Generator dialog to access the Preferences 
dialog. See the GEOPAK On-Line help for detailed information regarding the Preferences dialog and its 
settings. For the purpose of this training guide, we will detail only the dialog options that relate to 
selecting and using the ODOT Design Tables. 
 

Curve Design Tables 
When the Curve Design Tables category is selected, the Preferences dialog dynamically changes 
as shown below. 

 
The following Curve Design Tables have been configured according to ODOT Standards: 
 

Symmetrical 3 Centered Curve 
i:\ ODOTstd\V8istd\geopak\road\Design_Tables\HA_Sym3CC_2002.tbl 
 
Asymmetrical 3 Centered Curve 
i:\ ODOTstd\V8istd\geopak\road\Design_Tables\HA_Asym3CC_2002.tbl 
 
Symmetrical Tapered Curve 
i:\ ODOTstd\V8istd\geopak\road\Design_Tables\HA_TaperCurve_2002.tbl 

 
 
 
 
 
 
 
 
 
 
 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 3-64 Chapter 3 – Coordinate Geometry 
 

 
Spiral Design Table 
When the Spiral Design Tables category is selected, the Preferences dialog dynamically changes 
as shown below. 

 
The following Spiral Design Tables have been configured according to ODOT Standards: 
 

i:\ODOTstd\V8istd\geopak\road\Design_Tables\HA_spiral_emax60.tbl 
i:\ ODOTstd\V8istd\geopak\road\Design_Tables\HA_spiral_emax83.tbl 

 
 
Parameter Formats 
When the Parameter Formats category is selected, the Preferences dialog dynamically changes 
as shown below. 

 
For ODOT projects utilizing the ODOT Design Tables, set the Curve Parameter option to Degree 
(arc) as shown above. The other options can be set as desired by the user and are detailed in the 
GEOPAK on-line help. 
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Each design table can be used with its corresponding Horizontal Alignment command to set default 
values for various parameters within the Horizontal Alignment command. For example, from the Place 
SCS dialog you can select the Design Table and the Degree. The Entry Spiral and Exit Spiral values are 
set according to the values configured in the selected Spiral design table. 

 
Tools 
When Tools > Main is selected, the tool frame shown below opens. 

 
Each icon in the tool frame is a tool box that can be "torn off" to become a separate "tool box." The 
individual tool boxes can be docked and resized. There are six tool boxes, with the following titles: 
 

 Lines / Curves 

 Curve Combinations 

 Spiral Combinations 

 Complex Transitions 

 Alignment 

 Manipulate 
 
Alternately, each of the tool boxes may be opened by selecting them from the Tools option on the main 
menu bar, as shown below. 
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Operation of the individual Horizontal Alignment Generator tools is very thoroughly documented in the 
GEOPAK online help. Select Applications > Road > Help to access the online help. From the online help, 
select Bentley GEOPAK V8i > Command Reference > Geometry > Layout Horizontal Alignments. A 
summary of the available tools is show in the next few pages. 
 

Lines / Curves 
The Lines / Curves tool box is depicted below and has seven icons (left to right): 

 
 Store a Line By Two Points 

 Store a Line Tangent To an Element 

 Store a Circular Curve by Three Points 

 Store a Circular Curve by Center Point 

 Store a Unconstrained Tangent Curve 

 Place Simple Curve 

 Place Simple Transition Element 
 
Curve Combinations 
The Curve Combinations tool box is depicted below and has five icons (left to right): 

 
 Place Turning Path 

 Place Compound Curves 

 Place Three Centered Curves 

 Place Reverse Curves 

 Place Taper Curves 
 
Spiral Combinations 
The Spiral Combinations tool box is depicted below and has six icons (left to right): 

 
 Place SC Tangent to Line 

 Place ST Tangent to Curve 

 Place SC Tangent to Curve 

 Place SCS (Intersecting Elements) 

 Place STS (Disjoint Curves) 

 Place SCS (Disjoint Curves) 
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Complex Transitions 
The Complex Transitions tool box is depicted below and has three icons (left to right): 

 
 Place Complex Ramp 

 Place Ramp Connector 

 Place SCSCS Curves 
 
 
Alignment 
The Alignment tool box is depicted below and has three icons (left to right): 

 
 Place Dynamic Alignment 

 Place PI Alignment 

 Store Chain 
 

Manipulate 
The Manipulate tool box (second column, third row) is depicted below and has four icons (left to 
right): 

 
 Move a Plan View Element 

 Rotate a Plan View Element 

 Extend a Plan View Element 

 Delete an Element 
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3.15  Multicenter Curve Tool 

The Multicenter Curve Tool can be accessed from the Road Tools dialog, or by selecting Applications > 
GEOPAK > Road > Geometry > Design Multicenter Curve from the MicroStation pull down menu. 

 
The Multicenter Curve Tool dialog, shown below, 
is opened. 
 
The Multicenter Curve tool is used to store 
curves for the radius return between two COGO 
chains. The application can store one, two, and 
three centered curves. Optionally, the 
application can be used to design the vertical 
profile along the radius returns. This can be 
particularly useful for designing the vertical 
grade along the radii for import into the GEOPAK 
Corridor Modeling tool. 
 
See the GEOPAK online help for more 
information on the operation of this command. 
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3.16  Store Graphics 

The Store Graphics tool can be used to store points, curves, chains, and parcels into the coordinate 
geometry database from graphical elements in a 2D or 3D MicroStation file. When the Store Graphics 
tool is used within a 3D file, only the XY coordinates are used to store the COGO elements and no profile 
is generated. 
 
Note: In previous versions of MicroStation the accuracy of the data stored within the GPK file by use of 
the Store Graphics command was based upon the Working Unit resolution of the MicroStation design 
file. With the release of MicroStation v8 all graphic elements are stored with double precision 
coordinate values. ODOT has not recommended use of the Store Graphics tools with previous versions 
of MicroStation due to potential errors in the accuracy of design file graphics. Coordinate accuracy 
should no longer pose a problem with MicroStation v8. 
 
The Store Graphics dialog can be accessed by selecting Applications > Road > Geometry > Store 
Graphics, or from the Road tool palette as shown below. 

 
 
The following graphical elements can be stored in the Coordinate 
Geometry database by use of the Store Graphics dialog: 
 

 Point 

 Curve 

 Chain 

 Parcel 
 
For detailed instructions on use of the Store Graphics dialog, see the 
GEOPAK on-line help 
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COGO Exercise 3A – Answers 

As you store COGO elements in the GPK file, the graphics are drawn utilizing the current visualization 
settings. Before you begin, set the COGO Visualization settings to display the COGO elements. 
 

 Make sure the Feature Preferences are set to use the ODOT Standard SMD file ODOT.smd. 
 

 The Plot Scale is used when visualizing the COGO features. Use a plot scale that is large enough 
to read the point numbers when you are zoomed out. 

 

 
Within the main COGO dialog box, set the visualization mode to Temporary Visualization as shown 
below, or Permanent Visualization. In Temporary Visualization mode, the visualization graphics will be 
removed from the design file when you exit COGO. 
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To store the centerline for Existing State Route 185, first store points PI01-PI04 using the Store Point 
command and the Locate Traverse command. Select Element > Point > Store from the GEOPAK 
Coordinate Geometry dialog box. The Store Point dialog shown below is opened. 
 

 Key in the Point Number PI01. 
 

 Key in the Northing and Easting coordinates shown below 

for point PI01. 
 

 Select the Store Point button. Point PI01 is now stored in 
the COGO database and the visualization graphics are 
displayed at the coordinate location in the MicroStation 
design file. 

 

 
To locate points PI02, PI03 and PI04, use the Locate Traverse command. To access the Locate 
Traverse dialog shown on the following page, select Tools > Locate > Traverse from the GEOPAK 
Coordinate Geometry dialog box. 
 

 Key in point number PI02 in the Locate Point field. 
 

 Key in point PI01 as the Station Point Name. 
 

 Toggle the Direction option to Bearing. 
 

 Key in the bearing between points PI01 and PI02 shown below. Be sure to toggle the 
directions to the correct values. 

 
 Set the Distance option to Distance. 

 
 Key in the Distance value shown above for the existing centerline between points PI01 and 

PI02. 
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 Select Locate. Point PI02 is stored at the bearing and distance specified from point PI01. 

 
 Store point PI03 using point PI02 as the Station Point and the bearing and distance shown in 

the diagram on the previous page. 
 

 Store point PI04 using point PI03 as the Station Point and the bearing and distance shown in 
the diagram on the previous page. 

 
To store a curve for existing SR 185 centerline, select Element > Curve > Store > By Tangents from the 
GEOPAK Coordinate Geometry dialog. 

 
 Key in the Curve Name XS18503. 

 
 Select the Back Tangent and Ahead Tangent options as shown above. Point PI02 represents 

the back tangent point. Point PI03 is stored at the PI of the curve and point PI04 is the ahead 
tangent. 

 
 The Radius for the curve is 300. 
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 Select the Store Curve button. 
 
A curve named ES18503 is now stored in the COGO database. The next step is to make a chain from 

points PI01, PI02, PI04 and curve XS18503. 
 
Use the GEOPAK Store Chain command to store a COGO chain. From the GEOPAK Coordinate Geometry 
dialog, select Element > Chain > Store > From Elements to access the dialog shown below. 

 
 Key in the Chain Name CLXS185. 

 
 Key in the Begin Station of 35+90.72. 

 
The Element List portion of the dialog box is used to build a list of elements that will make up the chain. 
If you use the proper syntax, you can key in the list of elements manually. Point numbers can be keyed 
in directly without any special syntax. Curves must be keyed in as follows: 
 
 CUR name 
 
Spirals are keyed in as follows: 
 
 SPI name 
 
All elements must be separated by a space in the dialog box. 
 
 
A second option to build the list of Elements that will be used to make up the chain is to use the < Add 
button with the element selection options. For example, to add point PI01 to the Element List, take the 
following steps: 
 

 Select the Element Type: Point option. 
 

 Key in Point Name PI01. 
 

 Select the < Add button. Point number PI01 is added to the list box. Key in Point Number PI02 
and select < Add to add point PI02 to the Elements list box. 
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To add the curve XS18503 to the list box, take the following steps: 
 

 Select the Element Type: Curve option. 
 

 Pick the curve XS18503 from the list box. 
 

 Select the < Add button. The curve XS18503 is added to the list box. 
 

 Use the Element Type: Point option to add point PI04 to the Element List. 
 

 Select the Store Chain button. The new chain is created and stored in the COGO database. 
 
A third option to build the Element List is to select the visualization graphics from the MicroStation 
design file in the order that you wish the elements to be chained. Take the following steps: 
 

 Issue a Data Point in the Element List box so that the dialog item receives focus and is ready for 
your input. 

 
 Select the visualization graphics for point PI01, accept the point by issuing another data point. 

Point PI01 is added to the Element List. Repeat the step for point PI02, curve XS18503, and 
point PI04. 

 
Select the Store Chain button. The new chain is created and stored in the COGO database. 
 
 
Answers to the Questions: 
 

1. What is the station at point PI02?    44+55.14 

2. What is the station at point PI04?    80+11.16 
 
Use the Describe Chain command to answer the questions above. 
 

 From the Coordinate Geometry dialog, select Element > Chain > 
Utility to access the dialog show at right. 
 

 Select Chain CLXS185 from the list, and then select the Describe icon. 
The results of the Describe command are displayed in the Coordinate 
Geometry dialog.  

 
 
 
 
 
 
 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 3 – Coordinate Geometry Page 3-75 
 

COGO Exercise 3B – Answers 

To store the centerline for existing Jameson Road you must first store points PI05 and PI06 using the 
Store Point command. 
 
From the GEOPAK Coordinate Geometry dialog, select Element > Point > Store to access the Store Point 
dialog. 
 
Use the coordinates shown below to store the points: 
 

Point Name Northing Easting 

PI05 720,519.84 1,360,097.80 

PI06 720,330.15 1,360,542.17 

 
Next, use points PI05 and PI06 to make a chain for existing Jameson Road. From the GEOPAK 
Coordinate Geometry dialog, select Element > Chain > Store > From Elements. 
 

 Key in the Chain Name CLXJAME. 
 

 Key in the Begin Station 10+00. 
 

 Identify the elements, points PI05 and PI06, which will make up the chain. 
 

 Select Store Chain to create the chain. 
 

1. What is the bearing and distance from point PI05 to PI06? 
 

 Use the Inverse command or Describe Chain to answer question 1. 
 

Bearing = S 66° 53’ 01” E 
Distance = 483.164’ 

 
2. What is the station at point PI06? 
 

 Use the Describe Chain command to answer question 2. 
 

Station = 14+83.164 
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COGO Exercise 3C - Answers 

Points PI01, PI02, PI03 and PI04 represent the centerline tangents that were used to store the 
centerline of existing State Route 185. The same centerline traverse will be used to store the proposed 
relocation of State Route 185. 
 
Before storing the centerline chain for proposed State 
Route 185, we recommend that you copy of points PI01, 
PI02, PI03 and PI04 as new COGO points PI10, 
PI11, PI12 and PI13 to be used with the new centerline 
chain. This is necessary because GEOPAK COGO stores the 
stationing for the chain with the individual COGO elements. 
If we were to use points PI01-PI04 for the proposed 
alignment, at first it appears that there will not be any 
problems because both chains will start at station 
35+90.72. However, the proposed relocation of S.R. 185 
will result in the stationing at the last point on the chain 
(point PI04) being different from the existing alignment. 
Since a COGO point can only have one station value 
associated with it, the station at point PI04 will be 
redefined when the proposed chain is stored. This will 
result in a station equation being inserted into the chain for 
existing S.R. 185 in order to account for the new station 

value at point PI04. 
 
To avoid problems with the stationing on future projects, it 
is good practice to copy COGO elements to ensure that no 
elements are shared by multiple COGO chains. 
 
To copy points PI10-PI13 from points PI01-PI04 take 
the following steps: 
 

 From the GEOPAK Coordinate Geometry dialog, 
select Element > Point > Copy to access the Copy Point dialog. 

 
 Key in the Point Name for the new points to be created. 

 
 Key in the number of the previously stored points that you 

wish to copy in the From Point field. 
 

 Select Copy Point 
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Next we will store a spiral-curve-spiral (SCS) combination using points PI11, PI12 and PI13 as the 
back tangent, point of intersection and ahead tangent reference as shown below. 

 
From the GEOPAK Coordinate Geometry dialog, select Element > Spiral > Store to access the dialog 
shown above. 
 

 Toggle the Spiral Type option to SCS. 
 

 Key in the Spiral Name 
 

 Select the Back Tangent and Ahead Tangent options as shown above 
 

 Key in the Entry Length, Degree (Arc) and the Exit Length values as shown above 
 
After selecting the Store Spiral button, 2 new spirals and a curve are stored in the COGO database. The 
curve and the two spirals are named as follows: 
 

Entrance Spiral name = “PS18512B” (back spiral) 
 
Curve name = “PS18512" 
 
Exit Spiral name = “PS18512A” (ahead spiral) 

 
The next step is to create a chain from points PI10, PI11, and PI13, spirals PS18512B and 
PS18512A, and curve PS18512. From the GEOPAK Coordinate Geometry dialog, select Element > Chain > 
Store > From Elements to access the dialog shown below. 
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Tip: 
A Spiral-Curve-Spiral combination can be entered 
as one group in the Element List using the SCS 
syntax as shown in the dialog above. Using this 
syntax will identify the SCS as a set and will 
instruct the Describe Chain command to include 
the Total PI information in the description 

 
 Key in the Chain Name CLPS185. 

 
 Key in the Begin Station 35+90.72. 

 
 Compose the list of elements that will 

make up the new chain. 
 

 Select Store Chain. 
 
 
Next we will store a station equation on chain CLPS185 at the location where the proposed centerline 
meets the existing centerline of SR 185 on chain CLXS185. 

 
Proposed State Route 185 
will meet Existing State 
Route 185 at the ST of spiral 
PS18512A. To store the 
station equation, we will 
need the station along chain 
CLPS185 at the ST of spiral 
PS18512A, and the 
corresponding station on 
chain CLXS185. The Layout 
Offset Chain command can 
be used to get these stations. 
From the Coordinate 
Geometry dialog, select 
Element > Chain > Layout 
Offset to access the dialog 
shown at left. 
 

 
 
The results of the command are shown on the following page. 
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From the dialog above, you can see that the station at the ST of spiral PS18512A is 73+17.80. The 
corresponding station on chain CLXS185 is 74+10.27. We’ll use these stations to store the station 
equation. 
 
From the Coordinate Geometry dialog, select Element > Chain > Station Equation to access the dialog 
below. 
 
In order to store a station equation on a chain, the Redefine option must be toggled on. 

 
 

 Select Chain CLPS185 from the list. 
 

 Select Label Point ST PS18512A  
 

 Key in a Tangent Point name of CS01 
 

 Select Insert Station Equation 
 
 

 
After the station equation has been stored, the Describe/List/Print Chain command can be used to 
review the results of the station equation command as shown below. 
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COGO Exercise 3D - Answers 

To store a chain for the proposed relocation of Jameson Road, first store new points PI15 and PI16 at 
the location of points PI05 and PI06 using the Element > Point > Copy command. 
 
Next we will store a new point PI17 at the location where proposed Jameson road will intersect the 
proposed State Route 185 relocation. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Point PI17 should be located so that the tangent line between points PI16 and PI17 intersects the 
proposed S.R. 185 chain within the limits of curve PS18512 at a 90° angle. In order for the line formed by 
points PI16 and PI17 to be perpendicular to curve PS18512, it must pass through the center of curve 

PS18512 (CC PS18512). The Intersect tool can be used to locate point PI17. Select Tools > Intersect to 
access the dialog shown at right. 
 

 Key in point number PI17 for the new point 
you wish to store in the Locate Point field. 

 
 Toggle the Intersect Element option to Point 

to Point as shown at right. 
 

 To define the line that will intersect the chain 
CLPS185, key in the point number PI16 to 
use for the start of the line in the Point field. 
The To Point field will determine the other end 
point of the intersection line. Key in CC 
PS18512 as shown at right. 

 
 Toggle the With Element option to Chain. 

Select Chain CLPS185 for the element that 
will be intersected with the line defined by 
points PI17 and CC PS18512. 

 
 Select Intersect to store point PI17 
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Next we’ll use points PI15, PI16 and PI17 to store a curve for the relocation of Jameson Road. From 
the COGO Navigator dialog, toggle the Element option to Curve. Select the Add Element button to 
access the Store Curve by Tangents dialog as shown below. 

 
 Key in the Curve Name PJAME16 

 
 Select the Back Tangent and Ahead Tangent options as shown using points PI15, PI16 and 

PI17 
 

 Key in the Radius of 230 
 

 Select Store Curve. The new curve PJAME16 is stored in the COGO database 
 
Next we’ll make a chain for proposed Jameson Road using point PI15, curve PJAME16 and point PI17. 
From the COGO Navigator, toggle the Element option to Chain. Select the Add Element button to access 
the Store Chain From Elements dialog box as shown below 

 
 Key in the Chain Name CLPJAME. 

 
 Key in the Begin Station 10+00 

 
 Compose the list of elements that will make up the new chain as shown above. 

 
 Select Store Chain. 
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Once you have stored the chain CLPJAME for proposed Jameson Road, you can use the Layout Offset 
Chain command to get the station on chain CLPS185 at the intersection of Jameson Road. 

 
The station on chain CLPJAME with the intersection of the CLPS185 chain also occurs at point PI17 and 
can also be determined from the command results shown above. 
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COGO Exercise 3E – Answers 

To store an input file, from the GEOPAK Coordinate Geometry dialog, select File > Input File Utility. The 
dialog below will appear: 

 
 Toggle the option to Save. 

 
 Key in train for the name of the input file to save in the Name field. The Subject is optional. 

 
 Select Apply to save the input file. All of the input commands that you have used during the 

COGO session are saved in the input file. 
 

By default, the input file will be stored in the Working Directory. 
 

The file will be named train***.iOC, where *** is the Job Number and oc is your Operator Code. 
 
To save an output file, from the GEOPAK Coordinate Geometry dialog, select File > Input File Utility. 
 

 Toggle the option to Output. 
 

 Key in the name for the Output File you wish to save. 
 

 Select the Apply button. The output from the COGO session is saved to the file. 
 
A list of all the previously stored ouptput files will appear in the dialog under the File Name heading. 
 
By default, the output file will be stored in the Working Directory. 
 
The output file will be named test***.oOC, where *** is the Job Number and OC is our Operator Code. 
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Saving an output file will store all of the output from all of the commands that you ran during the 
current COGO session. To store an output report of only specific commands, you have two options: 
 

1. Clear the output buffer, issue the desired commands, and they save the output file. 
 

To save an output file containing only the output from the Describe Chain command using this 
method, take the following steps: 

 
o From the GEOPAK Coordinate Geometry dialog, select Edit > Clear to clear the COGO 

buffer 
 

IMPORTANT!!! The Edit > Clear command will clear both the input and output 
commands from the COGO buffer. If you wish to store an input file containing the list of 
COGO input commands that you ran during the COGO session, be sure to save the input 
file before issuing the Clear command. 

 
o Select Element > Chain >Utility to access the Chain Utility dialog. Select the chain name 

from the list, and then select the Describe command. 
 

o Select File > File Utility to save an output file. 
 
 

2. Clear the COGO View Window, issue the desired commands, save the text file. 
 

To save an output file containing only the output from the Describe Chain command using this 
method, take the following steps: 
 

 From the GEOPAK Coordinate Geometry dialog, select View > Command Output > Clear 
to clear the COGO window. The COGO Buffer is not cleared. 
 

 Select Element > Chain >Utility to access the Chain Utility dialog. Select the chain name 
from the list, and then select the Describe command. 
 

 From the GEOPAK Coordinate Geometry dialog, select View > Command Output > Save 
Content As… and enter a name for the file. 
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4 Project Manager 

4.1 The GEOPAK Project Manager 

Each design project will have its own set of alignments, profiles, cross sections, design files, directories, 
etc. On larger projects, keeping track of all the information associated with your project can be 
cumbersome. The GEOPAK Project Manager is available to help organize the information associated 
with each specific design project. 
 
The following information can be stored as part of a GEOPAK project: 
 

 The settings for the GEOPAK User Preferences dialog box. Opening a specific project will reset 
the values of the GEOPAK User Preferences dialog box to the values stored with the project. This 
will eliminate the need to reset the GEOPAK User Preferences dialog box manually every time 
you switch to a new project. 

 

 Design file information. Project Manager is also used to store the names of the design files 
associated with a project. 

 

 Coordinate Geometry information. Each specific alignment within a given project will have a 
centerline, existing profile, proposed profile, cross sections, etc. associated with it. This 
information is also stored in Project Manager. 

 

 Digital Terrain Model information. The name of the existing and proposed DTM files can be 
stored with Project Manager. See Chapter 3 for more information on Digital Terrain Models. 

 
In addition to storing information about your project, the 
GEOPAK Project Manager provides a flow chart dialog box to 
help you step through the GEOPAK software functions in a 
project workflow.  
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: 
Use of the GEOPAK Project Manager is 
optional. Users may elect to access the 
individual GEOPAK software functions 
without using the GEOPAK Project 
Manager by selecting Applications > 
Road from the MicroStation pull down 
menu. 
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Tip: CADD Standards 
Information about ODOT’s recommended directory structure can be found in the ODOT CADD 

Engineering Standards Manual: 
http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/CADDManual.as
px 

4.1.1 Creating a new GEOPAK Project 

There are three steps to create a new GEOPAK Project: 
 

 Create the project file. 
 Set the project preferences. 
 Create users for the project. 

 
These steps are detailed on the following pages. 
 
To create a new project, select Applications > ROAD > Project Manager, or select the Project Manager 
icon from the GEOPAK Road Tools tool frame to access the Project Manager dialog shown below. 

 

 
 
 
 
 
 
 
Take the following steps to create a new GEOPAK 
Project: 
 

 Identify the directory where the new project is to be created. GEOPAK Projects are typically 
stored in the GEOPAK sub-directory. 

 
 
 
 
 
 

 Next, select Projects> New… from the Project Manager dialog box to access the Create New 
Project dialog box. 
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The Create New Project dialog has the following components: 

Project Name - The name of the new project you are creating. The project file will be created in 
the directory that was specified in the Project Manager dialog box shown on the previous page. 
Project files have a .prj file extension. We recommend using the PID Number for the Project 
Name. 
 
Working Directory - This parameter is used to specify the default directory that GEOPAK will use 
to open files and to save files. Use the Select… button to select an existing directory that will be 
utilized as the default directory for the project. 

 
Job Number - This is a 1 to 3 digit alpha/numeric designation to be used by GEOPAK to create a 
Coordinate Geometry (COGO) database for the project. In the example above, using the three 
characters 185, a Coordinate Geometry data base named job185.gpk will be created in the 
directory that is specified as the Working Directory. The Select button is used to select a 
previously created GPK file for use by this project. 
 
Project Description - The Project Description is optional. You may wish to store the following 
optional information in the Project Description: 
 

County-Route-Section:  
PID Number:  
State Job Number: 
Project Manager:  
Project Designer:  
Project Description:  

 
Preferences - Select this button to access the GEOPAK User Preferences dialog shown on the 
following page. 
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Tip: User Preferences 
If you select Applications > Road > User Preferences to make changes to the current preferences, 
these changes are not stored as a part of your GEOPAK Project. To change preferences associated with 
a GEOPAK Project, select Projects > Edit… from the GEOPAK Project Manger dialog box. 

 
Notice that the user preferences dialog shown above is the same dialog that is accessed by 
selecting Applications > Road > User Preferences. In this case, the values you enter in the 
GEOPAK User Preferences dialog will be stored as part of the project. When the project is 
opened, the values associated with the project will override the current GEOPAK User 
Preferences settings. 
 
After you have set the GEOPAK User Preferences, select OK to close the dialog. 
 
 
 
 
 

 
To create the project, select OK from the Create New Project dialog box. A new file with a .prj extension 
is created in the directory specified on the Project Manager dialog. 
 
After creating the new GEOPAK Project, the project file is available for selection from the Project 
Manager dialog. 
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Select the project name, and then select OK to open the project (or double click on the project name) to 
access the Project Users dialog. 
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4.1.2 Project Users 

The information stored in Project Manager is saved by each User for the project. New users are created 
by selecting Users > New from the Project Users dialog shown below. A minimum of one user must be 
defined for each project. 

 
The New User dialog is shown at right. 

 
ODOT recommends using the following standard for user 
information: 
 

 Name: The log in name of the user 

 Full Name: The users full name 

 OP Code: The initials of the user 

 Description: Optional 
 
Select OK to create the user. 
 
You will be prompted to password protect the user name. 
Select Yes if you wish to password the user name or No if you 
do not want to use a password. ODOT recommends that you do 
not assign a password for the users on a GEOPAK project. 
 
Once the Project Users dialog has been completed, and a minimum of one user has been defined, 
clicking OK (or double clicking on a Project User) closes the Project Users dialog and opens the Road 
Project dialog shown below. 
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4.1.3 The Road Project Dialog 

The GEOPAK Project Manager associates a project with its respective job number, user and working 
directory. When the setup is complete, the Road Project dialog appears on the screen. 

 
Each item on the Road Project dialog box represents a specific GEOPAK function. The dialog has a few 
operational functions that are described below: 
 

File 
The File menu has two options: Close and Exit. 

 
Select Close to close the Road Project dialog box. Select Exit to exit from Project Manager. 
 
Remember 
The options on the Remember menu will allow you to select whether GEOPAK will automatically 
open the last Project, or User when Project Manager is opened. We recommend leaving these 
functions toggled off unless you will be working on one project for an extended period of time. 
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Options 
The Options menu will allow you to turn the Auto Sink function on or off. With Auto Sink turned 
on, selecting any of the Road Project dialog options will automatically sink the Road Project 
dialog behind the MicroStation window. Once the dialog box for the selected function is closed, 
the Road Project dialog will automatically pop back to the top. 

 
The Road Project dialog can be alternately minimized or maximized by selecting the small button to the 
right of the dialog. The minimized dialog is shown below. 

 
 

4.1.4 GEOPAK Project Directory Structure 

After you have created a new GEOPAK Project and User, a new sub-directory named projdbs is created 
in the Working Directory as shown below. This directory is used to store Project Manager Information 
for each user. If you create multiple users for a project, a sub directory for each user is created under 
the projdbs directory. 
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4.1.5 The Working Alignment 

Within each GEOPAK project there may be several horizontal alignments, vertical profiles, cross sections, 
etc., each representing the individual roads of the project. In order to better organize this information, 
GEOPAK uses the Working Alignment to store information about each roadway within a project. These 
settings are shared with other dialog boxes within GEOPAK to minimize re-entering the same 
information in multiple dialog boxes through the project workflow. 
 
An unlimited number of Working Alignment definitions can be created within a GEOPAK project. Each 
Working Alignment definition will represent a different road alignment within the design project.  
 
The Working Directory, User and Job # are shown across the top of the dialog box as shown below. The 
currently selected Working Alignment is shown on the left. 

 
There are two steps to setting up a working alignment 
 

 Create an alignment “run” 
 Define the conditions for the “run”. 

 
The Select button is used to choose an existing working alignment or create a new one. The Define 
button is used to define information about the working alignment. Each process is described in further 
detail below. 
 
Click the Select button to access the Select Working 
Alignment dialog box shown at right. By default there 
is always a Working Alignment named Untitled. 

 
To create a new Working Alignment select Run > 
New... from the Select Working Alignment dialog box. 
The New Run Name dialog box shown below appears.  
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Each Working Alignment is stored as a separate “run” by GEOPAK. Key-in the Run Name for the new 
Working Alignment. ODOT recommends the following standard: 
 

Working Alignments: aa### 
Alternatives Alignments: aa###A** 

Where: 
aa = Road type. 
IR = Interstate Route 
US = US Route 
SR = State Route 
RP = Ramp 
CR = County Road 
TR = Township Road 

 
Note: In cases where the roadway doesn’t fall within the Road Type categories 
above, the name of the street may be used up to the maximum character limit 
of 8 characters, or 5 characters when alternatives are studied. 

 
### = Three digit route number. For example, SR 4 would be 004 
  = Ramp Number 2S, 3A, etc. 

 
A** = Alternate number. Example: A or A01 for more than one. 

 
The Description field is optional. ODOT recommends including the following information as a standard: 
 
 Alternate: 
 Roadway: 
 Design Speed: 
 Max. e: 
 Design Functional Classification: 
 Description: 
 

Example 1: 
Roadway: State Route 185 // Design Speed: 55 MPH // Max e: 0.08 // Design Functional 
Classification: Rural Collector // Description: Main Road of Project // Relocation of 0.5 
Miles of SR 185 to upgrade horizontal and vertical alignments to meet current roadway 
design standards. 
 

Example 2: 
Roadway: County Road 108 // Street Name: Jameson Road // Design Speed: 55 MPH // 
Max e: 0.06 //Design Functional Classification: Rural Local // Description: Side road of 
project located at station 66+50. Improvement of CR 108 by reconstruction of vertical 
and horizontal alignments to improve the intersection with SR 185. 
 

Select the OK button to create the new Working Alignment. 
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After you have created a new Working Alignment, the name of the alignment is displayed in the Select 
Working Alignment dialog box as shown below. 

 
Select the Working Alignment that you wish to use and click the OK button, or double click the name of 
the Working Alignment. The Road Project dialog box is updated to reflect the currently selected Working 
Alignment as shown below. 

 
From the Road Project dialog box, select the Define button to access the Working Alignment Definition 
dialog box shown below. 
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Each item on the left of the Working Alignment Definition dialog box represents a different piece of 
information that can be defined for the alignment. As you work through a GEOPAK project, you will 
continue to update the Working Alignment Definition dialog box as new information is developed. 
 
The first item in the Working Alignment dialog is the Plan View item. This item is used to store the name 
of the Design File that contains the proposed graphics for the project, and the name of the Chain in the 
Coordinate Geometry database that is used for the centerline of the road. 
 
When accessing the various functions of the GEOPAK Road Project dialog box, the settings and 
parameters of the current Working Alignment run are shared with the dialog boxes for the various 
functions if the parameters have been specified in the Working Alignment and if the Working Alignment 
Influence Runs toggle is active, as shown above. This eliminates the need to repetitively enter the same 
data in every dialog box. 
 

4.1.6 Pattern and Cross Section Placement Symbology 

After creating the Working Alignment for a specific roadway, it is recommended that you set the default 
placement symbology for the Pattern and the Cross Section View Existing Ground items. Both of these 
options are used in the GEOPAK Road 2 class, not in Road 1, but it is good practice to set these values 
immediately after creating a new working alignment definition.  
 
Take the following steps to define the default parameters for pattern line placement: 
 

 Select the Pattern item as shown below. 

 Select the By Design File option. 

 Double-click the Placement symbology box to access the Set Feature dialog shown at right 
below. Set the Symbology as shown. Select OK.  
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Take the following steps to define the default parameters for the Existing Ground line placement: 
 

 Select the Cross Section View Existing Ground item as shown below. 

 Double-click the Placement symbology box to access the Set Feature dialog shown at right 
below. Set the Symbology as shown. Select OK.  

 

 
 
Additional information on the use of these parameters can be found in the GEOAPK Road 2 training 
guide. 
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4.1.7 Creating “Runs” in Project Manager 

In larger, more complex design projects, the Project Manager functions as a data repository and file 
management tool. In order to accomplish this, the dialog setting for each process is assigned a name and 
stored as a Run for the selected process. This unique name identifies the specific information for the 
processing. The designer can access previously saved runs to quickly and easily review what data was 
entered for a specific processing function. 
 
In addition, minor changes can be quickly made by accessing the run, modifying the value or key-in that 
has changed and rerun the process. The changes can be saved within the Project Manager, so, if the 
alternate did not produce the desired results, it can be discarded. 
 
When the user selects a GEOPAK function with the GEOPAK Project Manager active, the Select run 
dialog shown below is activated before the function is accessed.  

 
Note: A few processes do not create runs.  These include most COGO functions, Plan Production tools, 
Tabular Summaries, and 3D Models. 
 
If the project is small and only one run of a particular processing is expected, the user can use the 
default run “Untitled” and continue by clicking OK. However, for projects where processing multiple 
iterations of the same application for separate alignments is expected, (i.e., two different sets of 
proposed cross sections), it is prudent to assign names and the optional description for easy recognition 
at a later date.  
 
If no options have been previously run, Untitled appears in the Run list box along with the current time. 
If prior runs have been processed, they are listed with the last run time. The description of the run file 
can be seen in the bottom of the dialog when each file is highlighted. 
 
To select a previously defined Run, highlight the Run from the list, and then click OK. Double clicking on 
the Run file name also selects a previous run for subsequent processing. Clicking Cancel closes the Select 
Run dialog. 
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Several options are supported in the Run menu. These include New, Copy, Modify, and Delete. 
 

New Run 
The Run Name is a one to eight character 
alphanumeric name. The Description field is 
a multi-line field which enables the user to 
define the contents of the run file. Pressing 
the OK button will automatically close the 
dialog and return to the Select Run dialog 
where the new Run file name is displayed. 
Clicking Cancel closes the dialog without 
saving the new Run Name. 

 
Copy 
Several options are supported under the Copy menu item. These include: Project, User, and 
Run. If a Run is similar to another Run, it is easier to copy the previous run and modify, rather 
than entering all the information a second time. Similarly, Projects and Users can also be copied. 
When the Copy… > Projects option is selected, the Project Selection dialog opens for identifying 
the existing project to be copied. Highlight the project to be copied, and then click OK. The 
Project Users dialog and Select Run dialogs are then displayed for the User and Run to be 
identified. 

 
Modify 
The Name is a one to eight character 
alphanumeric file name. The Description field 
is a multi-line field which enables the user to 
define the contents of the run file. If a new 
description is not keyed in, the description 
from the original file will be utilized. Clicking 
OK automatically closes the dialog and 
returns to the Select Run dialog. Clicking 
Cancel closes the dialog without modifying 
any files.  
 
Delete 
When the Run file to be deleted is highlighted and the Run > Delete option is selected, an Alert 
message box is displayed prompting, "Are you sure? Clicking Yes deletes the Run and returns to 
the Select Run dialog, while clicking No returns to the Select Run dialog with no deletion 
occurring. 
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Exercise 4 

Create a new GEOPAK Project, user, and Working Alignment Definitions for State Route 185 and 
Jameson Road. 
 

 Open the file 12345BP001.dgn. 
 

 Use the GEOPAK Project Manager to create a new project. 
 

Which sub-directory should be used to create the project? 
 

Using the recommended standard, what should you name the project? 
 

Which directory should you assign for the Working Directory? 
 

What is the default file extension for the project file? 
 

 Set the Project Preferences to values that are appropriate for English unit projects. 
 

 Open the newly created project. Create a new user for the project using your name, full name 
and operator code. Select the newly created user to access the Project Manager dialog box. 

 
 Create a Working Alignment definition for State Route 185. 

 
What should you name the Working Alignment for State Route 185? 

 
 Define the following information for the State Route 185 Working Alignment: 

 
Plan View: Design File (identify the design file with the proposed plan view graphics) 
Plan View: Chain (identify the proposed centerline) 
DTM: Existing Ground TIN (identify the TIN file delivered from survey) 
Pattern: Define the Pattern placement symbology as shown on page 4-12 
Cross Section View Existing Ground: Define the symbology as shown on page 4-13 

 
 Create a Working Alignment definition for Jameson Road. 

 
What should you name the Working Alignment for Jameson Road? 

 
 Define the following information for the Jameson Road Working Alignment: 

 
Plan View: Design File (identify the design file with the proposed plan view graphics) 
Plan View: Chain (identify the proposed centerline) 
DTM: Existing Ground TIN (identify the TIN file delivered from survey) 
Pattern: Define the Pattern placement symbology as shown on page 4-12 
Cross Section View Existing Ground: Define the symbology as shown on page 4-13 
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5 Design & Computation Manager 

5.1 Overview 

The Design & Computation Manager is used by GEOPAK for several functions. The following operations 
can be performed with the D&C Manager: 
 

 Set drafting standards for plotting COGO elements into MicroStation 

 Set drafting Standards for drawing MicroStation graphics 

 Place MicroStation graphic elements as “pay items” that can later be tabulated by GEOPAK 

 Identify the GEOPAK pay item attribute for MicroStation elements previously placed with the 
D&C Manager 

 Filter the MicroStation display to show only selected items. For example, display only the 
proposed drainage items 

 Draw pavement markings including various gore treatments 

 Draw pavement shapes that can be used to compute pavement quantities 
 
The Design and Computation Manager can be accessed by selecting Applications > Road > Design & 
Computation Manager from the MicroStation menu bar, or from the Road tool palette as shown below 

 
The Design and Computation Manager consists of two separate dialog boxes, one for settings, as shown 
on the following page. 
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The D&C Manager dialog has a row of shortcut buttons across the top of the dialog box. The function of 
each button is summarized below. 
 

Switching to Toolbox Mode will change the appearance of the D&C Manager dialog box 
into a slim dialog that can be “docked”. This mode is detailed in section 5.8. 

 
The Identify mode is used to set the D&C Manager item to match an existing 
MicroStation element previously drawn using the D&C Manager. If no item is found 

within the specified database, GEOPAK displays the following message in the prompt field: “No 
matching database item." 
 

Display mode is used to filter the MicroStation display to show only selected features. 
See section 5.6. 

 
Design mode is used to plot COGO elements into MicroStation with the desired 
symbology by use of the Draw Plan and Profile dialog. It can also be used to set drafting 

standards to be used in conjunction with MicroStation’s element placement commands with the 
Place Influence option toggled on. See section 5.4 and 5.5 for information on using Design 
mode. 
 

Set mode is similar to Design mode in that it is used to set the symbology of MicroStation 
elements. The difference is that Set mode is used to change the symbology of previously 

stored MicroStation graphic elements 
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Compute mode is used for tabulating quantities of items that have been placed as a “Pay 
Item” by use of the Design or Set mode. 

 
The Shape mode uses plan view MicroStation graphics to place shapes required for 
pavement calculations. 

 
Several options for placing pavement striping and marking are accessed via the 
Pavement mode. These options are covered in Section 6.7 - Pavement Marking. 

 
The Preferences mode is used to configure the Design and Computation Manager and is 
not covered by this class. 

 
The use of these functions will become more apparent once you understand the structure and use of 
the hierarchical database. This is the subject of the next few subsections. 
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5.2 ODOT Standard D&C Manager Database 

The Office of CADD and Mapping Services in Central Office is responsible for the development of the 
ODOT standard GEOPAK Design and Computation Manager Database, ODOT.ddb.  The database has 
been developed to comply with the CADD Standards. 
 
For ODOT personnel, the Design and Computation Manager database is located in the following 
directory: 
 

i:\ODOTstd\V8istd\geopak\road\ddb\ 
 
The database can also be downloaded from the ODOT CADD Support website: 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/default.aspx 
 
When the Design & Computation Manager is opened, the default database, ODOT.ddb, is opened as 
defined in the ODOT configuration.  
 
The D&C Manager database is a password protected file and cannot be edited by the designer. 
Suggestions or requests for enhancements should be forwarded to the Office of CADD and Mapping 
Services. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

http://www.dot.state.oh.us/Divisions/Engineering/CADDMapping/CADD/Pages/default.aspx
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5.3 D&C Manager Database Structure 

Elements in a MicroStation file representing a roadway project can be classified according to features 
(e.g., pavement, shoulders, curb and gutters) and/or pay items. The Design and Computation Manager 
dialog employs a hierarchical database wherein an unlimited number of features and/or pay items can 
be organized in an unlimited number of categories and subcategories. 
 

5.3.1 Categories 

The basic component of the hierarchical tree is the Category. The database ODOT.ddb contains two child 
categories: Drafting Standards and Pay Items as shown below. 
 

 
 
Double-clicking on a category will reveal sub-categories, or items depending on how the database is 
configured. A double-click on the Drafting Standards category will reveal several child categories as 
shown below. 
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5.3.2 Items 

The other database component is the item. Items contain specific functions related to defining element 
symbology or placing pay items. A double-click on the Profiles category reveals several items as shown 
below: 

 
 
There are three types of Items in the D&C Manager database, each with a unique icon as summarized 
below. 
 

 Report Icon - These items are used to set drafting standards for MicroStation commands or 
to draw COGO elements without annotation. 
 

 Paintbrush Icon - These items can be used to set drafting standards for MicroStation 
commands or to draw COGO elements with annotation. 
 

 Calculator Icon - These items are used to set drafting standards for MicroStation commands 
or to draw COGO elements. The resulting graphics are tagged with a pay item attribute that can 
be used to calculate plan quantities. 

 
Note that each item in ODOT.ddb has an Item ID and a Description as shown above. The ID is a short, 
cryptic name that is required by the software. The Description is to the right of the item ID. 
 
The use of these items will be detailed in the following sections 
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5.3.3 ODOT.ddb Categories 

The two main categories of the ODOT D&C Manager database are Drafting Standards and Pay Items. 
Double-click the Drafting Standards category to reveal several child categories as shown at below. 
 

 
 
The Drafting Standards categories are summarized below. 
 

Cross Sections - Drafting standards for cross section items can be found in this category. Double 
click on Cross Section in the Design and Computation Manager dialog box to bring up a list of 
items. 
 
Existing Plan View - Drafting standards for existing roadway items can be found in this category. 
Double click on Existing Plan View in the Design and Computation Manager dialog box to bring 
up a list of the child categories. 
 
Proposed Plan View - Drafting standards for proposed roadway items can be found in this 
category. Double click on Proposed Plan View in the Design and Computation Manager dialog 
box to bring up a list of the child categories. 
 
Parcels - Drafting standards for existing parcels can be found in this category. Double click on 
Parcels in the D&C Manager dialog box to bring up a list of parcel items. 
 
Profiles - Drafting standards for existing and proposed profiles can be found in this category. 
Double click on Profiles in the D&C Manager dialog box to bring up a list of profile items. 

 
The next few sections will focus on using the Drafting Standards to place elements in MicroStation 
according to ODOT standards. The Pay Items category has not been developed at this time and will be 
documented at a later date. 
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5.4 Design Mode 

 
 

Design mode is the default mode when the Design and Computation Manager dialog is opened, and can 
be used for the following functions: 
 

 Set Drafting Standards by use of the Place Influence option for the placement of MicroStation 
elements using MicroStation commands. 

 
 Place elements as Pay Items that can be tabulated. 

 
 Plot COGO elements into the Design file according to the drafting standards set by the D&C 

items. 
 

 Run Three Port Criteria (3PC) applications. 
 
The following sections will detail the procedure to set drafting standards for MicroStation commands 
and for the plotting of COGO elements. The placement of MicroStation graphics as Pay Items will be 
documented at a later date. 
 

5.4.1 Design Settings and the Model Annotation Scale 

Before you begin placing MicroStation elements in Design Mode, 
it is good practice to check the Design Settings to ensure that the 
Custom Line Style Creation Scale Factor and the Cell Plot Scale 
values are set properly. 
 
From the Design and Computation Manager dialog, select 
Settings > Design to access the Design Settings dialog shown at 
right. 
 
The following options are available on the Design Settings dialog: 
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Element Connectivity 
These options are used when computing pay item quantities. 
 

Maximum Gap Tolerance 
If the distance between two specified elements in a MicroStation file is smaller than the 
Maximum Gap Tolerance, the software assumes the two elements intersect and act 
accordingly. If the distance is larger than the Maximum Gap Tolerance, GEOPAK 
assumes the two elements do not intersect. 
 
Deduction Tolerance 
The Deduction Tolerance is utilized in the Compute mode. For example, if the pay item 
is specified for a curb line, and for each manhole (drawn in as a cell), there is a 
deduction of six feet. The origin of the cell does not have to be on the curb line, but 
must be within the deduction tolerance in order for the cell to be recognized and the 
deduction to be made. 

 
Custom Line Style Creation 
The default custom line style Scale Factor used when drawing MicroStation elements is specified 
here. Note: Some items in ODOT’s D&C Manager database, such as a lane line, are configured 
specifically for a scale factor of one. When these items are placed, the D&C Manager will 
automatically override the scale factor entered by the user in the Design Settings dialog. For 
ODOT plans, this value should be set to 1.0 to allow the Model Annotation Scale to control the 
custom line style scale. 
 
Cell Creation 
The default scale factor for placing cells is specified here. Note: Some items in ODOT’s D&C 
Manager database, such as a catch basin, are configured specifically for a scale factor of one. 
When these items are placed, the D&C Manager will automatically override the scale factor 
entered by the user in the Design Settings dialog. For ODOT plans, this value should be set to 1.0 
to allow the Model Annotation Scale to control the cell scale. 
 
Influence Graphic Cell Level Symbology 
When active, the Influence Graphic Cell Symbology utilizes the symbology within the Design 
and Computation Manager, ignoring the element symbology used when the cell was created. 
The option should always be toggled off for ODOT plans. 

 
As noted above, the Custom Line Style Creation Scale Factor and the Cell Creation Plot Scale values 
should be set to 1.0 for ODOT plans. This will allow the current Model Annotation Scale value to control 
the size of the cells and the custom line styles. 
 
The annotation scale is set as follows: 
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From the MicroStation pull-down menu, select File > Models to access the Models dialog shown below. 

 
From the Models dialog, select Edit Model Properties to access the Model Properties dialog shown 
below. 

 
Set the Annotation Scale and the Line Style Scale as desired. In the example above, the Annotation Sale 
is set to a value of Engr 1:20 for a 20 scale plan, with the Line Style Scale value set to match the 
Annotation Scale. 
 
Note: This is a change in procedure from previous releases. See the ODOT CADD Engineering Standards 
Manual for more information on the annotation scale. 
 
The ODOT Design & Computation Manager Database for GEOPAK V8i has been specifically modified to 
accommodate placing cells using the Model Annotation Scale. Previous versions of ODOT.ddb will not 
allow the cells to be scaled using the Annotation Scale. 
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5.4.2 Using "Place Influence" With MicroStation Commands 

The Place Influence toggle is used to temporarily override the currently active MicroStation symbology 
settings. The Place Influence toggle button is located on the D&C Manager Tool Settings dialog as shown 
below. 

 
By toggling on Place Influence, you can use MicroStation commands to place elements utilizing the 
drafting standards established for the currently selected item in the D&C Manager database. 
 
Example 1: Place SmartLine 
In the example below, the Proposed Curb item is selected in the D&C Manager Dialog with Place 
Influence toggled on. The line is placed using the correct symbology for a proposed curb line. 
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Example 2: Partial Delete 
If Place Influence is toggled on, it will impact the symbology of elements created using any MicroStation 
Command, even when using commands that do not normally change element symbology. The Partial 
Delete command was used in the example below to delete a portion of the proposed curb line that was 
drawn in example 1. The new elements take on the symbology of the active item in the D&C Mananger 
dialog, in this case a proposed Fence Line, as shown below. 

 
Example 3: Place Cell 
Some of the items in the D&C Manager Database have been configured to place a cell. In the example 
below, an existing Electric Manhole is drawn using the Place Cell command. 

 
 
 
 
 
 
 
 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 5 – Design and Computation Manager Page 5-13 
 

As the examples above demonstrate, some items in ODOT.ddb have been configured to represent 
curvilinear features, such as the edge pavement, or a fence line, and others have been configured to 
represent point features such as a telephone pole or mailbox. Whether placing point features, or 
curvilinear features using a custom line style, the user must determine how to set the drawing scale for 
the elements placed. 
 
The cell and custom line styles defined in ODOT’s CADD Standards are defined in one of two ways: 
 

 “Physical” items are used to represent the location and size of an item. These items have been 
drawn at their actual physical dimensions and are placed in the design file at a scale of 1.0. 

o A pavement marking right-turn arrow is an example of a physical cell which is always 
placed at it’s actual size. 

o A pavement marking line, such as a lane line, is an example of a physical line style that is 
always placed using the actual dash and gap dimensions of the line. 

 

 “Cosmetic” cells used the represent the location of an item, but not the actual size. These items 
are placed in the design file using the active Model Annotation Scale. 

o A Mailbox is an example of a cosmetic cell that is used to designate the location of the 
item, but not the actual size of the item. 

o A fence line is an example of a cosmetic line style. The location of the “x” on the fence 
line is used as a symbolic representation of the line type and does not represent specific 
post spacing for the fence line. 

 
ODOT’s CADD standards have been configured to automatically account for these different types of cells 
and custom line styles. An example of each of these cases follows: 
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5.4.3 Placing “Cosmetic” cells using the active Model Annotation Scale 

For items that are used to represent the location of point features and not the size of the feature, it is 
necessary to place them using the active Model Annotation Scale. A mail box is an example of an item 
that is placed representing the location of the feature, but not the size. To place a proposed mail box 
using Place Influence, take the following steps: 
 

 Check the Design Settings dialog to ensure that the Cell Creation Scale Factor is set to the value 
of 1.0. 

 
 Select the proposed Mail Box item from the database as shown below. 

 
 Toggle on Place Influence. 

 
 Select the MicroStation Place Cell command. The name of the cell associated with the selected 

item appears in the Place Active Cell dialog as shown below. 
 

 Turn on the Annotation Scale lock 
 

 Issue a data point to place the cell. 
 
Note that the X Scale and Y Scale values for the cell are set to a value of 1.0 according to the Cell 
Creation Scale Factor value. The cell is scaled according to the Model Annotation Scale when placed. 
 
If you double click the name of any item in ODOT’s Design and Computation Manager that is used to 
place a cell, the place cell command will be automatically selected. If Place Influence is on, the cell will 
be floating on your cursor, ready to place in the design file. 
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5.4.4 Placing “Physical” Cells Using the Model Annotation Scale 

For items that are used to represent the location and the size of a point feature, the cell definition has 
been configured so that these cells are not scaled by the active Model Annotation Scale. 
 
Pavement marking turn arrows are an example of “physical” cells that are placed using real world 
dimensions. To place a right-turn arrow, take the following steps: 
 

 Select the Lane Arrow Right item from the D&C Mananger 
 

 Toggle on Place Influence. 
 

 Select the MicroStation Place Cell command. The name of the cell associated with the selected 
item appears in the Place Active Cell dialog as shown below. 
 

 Leave the Annotation Scale lock toggled on. The right-turn arrow cell has been configured to 
ignore the Annotation Scale value and will be placed at a scale of 1.0 

 
 Issue a data point to place the cell. 

 
In the example above, the right-turn arrow was placed next to the mailbox cell for comparison. 
 
Note: Changing the active Model Annotation Scale value will result in these cells being redrawn to match 
the current scale. 
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5.4.5 Placing Drainage Cells (Catch Basins, Manholes, Inlets, and Headwalls) 

Drainage items are also defined as “physical” cells representing the location and size of the item. ODOT 
has developed several Visual Basic Applications to assist the user when placing existing or proposed 
catch basins, manholes, inlets, headwalls, and storm sewer lines. Each of these applications is available 
from the MicroStation pull-down menu in the ODOT > Drainage Apps category. 
 

 
 
As of January 2011, all DDB items for placing catch basin, man holes, and inlets have been removed from 
ODOT.ddb. The Visual Basic applications referenced above should be used for placement of these items. 
See the documentation by selecting the Help icon on the individual applications for more information on 
the operation of these applications. 
 
 

5.4.6 Using Place Influence with Curvilinear Features and Custom Line Styles 

D&C Manager items that do not represent "point" features are configured to set the active MicroStation 
symbology for placing curvilinear MicroStation elements. Several of these items have been configured to 
use custom line styles. The custom line styles are contained in the resource files ODOT_Linestyles.rsc. 
 
Like cells, some custom line styles are intended to be placed as “Physical” features, using real world 
dimensions, while others are defined as “Cosmetic” features which are placed using the active Model 
Annotation Scale. 
 
Curvilinear features that should always be placed at a set scale of one, such as a pavement marking lane 
line, have been configured within the ODOT line style resource file as non-scalable. Other items, such as 
a fence line will use the active Model Annotation Scale. 
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5.4.7 Placing “Cosmetic” Line Styles using Place Influence 

An example placing a Proposed Fence Line is shown below. 
 

 Select the Proposed Fence Line item as shown below. 
 

 Toggle on Place Influence. 
 

 Select the MicroStation Place SmartLine command or double click on the Existing Fence Line 
item in the Design and Computation Manager dialog. Place a line. 

 
The line will be placed using the level, color, weight and custom line style settings associated with the 
Fence Line item. The line style scale will be placed with the active Model Annotation Scale.  

 
After you have placed the fence line, toggle Place Influence off. Notice that the MicroStation symbology 
settings are returned to the previous values. 
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5.4.8 Placing “Physical” Line Styles using Place Influence 

An example placing a Proposed Lane Line is shown below. 
 

 Select the Proposed Lane Line item as shown below. 
 

 Toggle on Place Influence. 
 

 Select the MicroStation Place SmartLine command or double click on the Existing Fence Line 
item in the Design and Computation Manager dialog. Place a line. 

 
The line will be placed using the level, color, weight and custom line style settings associated with the 
Lane Line item. The line style scale will be placed at a scale of 1.0 regardless of the current Model 
Annotation Scale. 
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5.5 Using Design Mode to Plot COGO Elements 

The Design and Computation Manager is also used to plot GEOPAK COGO elements into MicroStation 
with the proper element symbology. The items in the D&C Manager database are configured in one of 
three ways as detailed below.  
 

 Report Icon - These items are used to set drafting standards for MicroStation commands or 
to draw COGO elements without annotation. 
 

 Paintbrush Icon - These items can be used to set drafting standards for MicroStation 
commands or to draw COGO elements with annotation. 
 

 Calculator Icon - These items are used to set drafting standards for MicroStation commands 
or to draw COGO elements. The resulting graphics are tagged with a pay item attribute that can 
be used to calculate plan quantities. 

 
Let’s take a look at plotting items from the COGO database using each of the item types listed above. 
 

5.5.1 Plotting COGO Elements Utilizing Report or Calculator Items 

The process to plot COGO elements using report or calculator items is identical. The only difference is 
that calculator items are tagged with a pay item attribute that will allow GEOPAK to tabulate quantities 
from the graphics. 
 
When these items are used to plot COGO elements, no 
annotation is placed in the design file. For example, the 
Existing Benchmark Found item can be used to set the 
active MicroStation cell and symbology according to ODOT 
Standards by use of the Place Influence toggle. If you wish 
to place the cell for a benchmark at the location of a 
COGO point, the Draw COGO Element option can be used. 
 
Select Draw COGO Element to access the Draw dialog 
shown below. 
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To plot the Benchmark cell in the design file, simply key in the point number and press the enter key. 
The cell from the selected D&C Manager item will be plotted at the location of the COGO point. 
 
Several other COGO elements can be plotted by use of the Draw dialog by selecting the desired COGO 
element from the Operation pull down. The options are shown below. 

 
 
Toggle Operation to Lines. A line can be drawn through a range of COGO points using the selected D&C 
Manager symbology. In the example below, a fence line was draw through points DN250, DN251 and 
DN252 by keying in the range of points as shown in the dialog below. 

 
When a range of points is keyed in, all of the points are connected in numeric order as shown above. To 
draw a line through a series of points in nonconsecutive order, the “/” is used to separate the point 
numbers. For example, the draw the Fence Line from point DN250 to DN252, key-in DN250/DN252. 
 
Toggle the Operation option to Curves, Spirals or Chains to plot these 
items from the COGO database. Once the Draw dialog is toggled to one of 
these options, a listing of the Curves, Spirals, or Chains in the COGO 
database is included in the dialog. An example of plotting a chain is shown 
at right. 
 
To plot the chain, simply select its name from the list. Do not double-click 
the chain name which will result in plotting the chain twice. 
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5.5.2 Plotting COGO Elements Using Paintbrush Items 

Items in the D&C Manager database with the Paintbrush 
icon can be used to set symbology for MicroStation 
commands by use of the Place Influence toggle, or to 
plot COGO elements with annotation. The annotation 
includes curve data, stationing, bearings, distances, etc... 
The majority of the items in ODOT.ddb are not 
configured to plot annotation. 
 
When a paintbrush item is selected, the Draw Plan & 
Profile option is now available as shown at right. 
 
Select Draw Plan & Profile to access the dialog shown 
below. 

The top portion of the dialog includes an 
option button to select the Element Type 
mode. The following Operation options are 
available: 
 

 Points 

 Lines 

 Curves 

 Spirals 

 Chains 

 Stationing 

 Parcels 

 Profiles 

 Parallel Chains 
 

 
A detailed discussion of each of the drawing operations is available in the GEOPAK on-line help. 
 
In the next few sections we will take a look at using the D&C Manager with ODOT.ddb to plot Chains and 
Stationing. 
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5.5.3 Plotting COGO Chains 

Several items in ODOT.ddb are configured to plot centerlines and stationing. The Proposed Roadway 
centerline items are shown in the dialog below. 
 
Additional items for plotting centerlines can be found in the following locations within the DDB file: 
 

Existing Centerlines: 

Drafting Standards > Existing Plan View > GE - Geometry and Stations > CL or BL Construction 

Drafting Standards > Existing Plan View > RW - Right-of-Way > CL Right-of-Way 

Drafting Standards > Existing Plan View > SV - Survey > CL Survey 

 

Proposed Centerlines: 

Drafting Standards > Proposed Plan View > GE - Geometry and Stations > CL or BL Construction 

Drafting Standards > Proposed Plan View > RW - Right-of-Way > CL Right-of-Way 

Drafting Standards > Proposed Plan View > SV - Survey > CL Survey 

Drafting Standards > Proposed Plan View > MT - Maintenance of Traffic > Temporary Road CL and Stations 

 
To plot a COGO chain, select the desired Centerline item from ODOT.ddb, then pick the Draw Plan & 
Profile option from the D&C Manager Tools Settings dialog 

 
From the Plan & Profile Draw dialog, toggle the Element Mode mode to Chains as shown above. 
 
The list of available chains in the COGO database is shown in the list box on the left hand side of the Plan 
& Profile Draw dialog. 
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The right side of the Plan & Profile Draw dialog contains a list of options for plotting the currently 
selected item. ODOT.ddb has been configured with the Line Direction Label and the Curve Data items 
toggled on. The other options can be toggled on or off as needed. With all options toggled off, only the 
centerline will be plotted without any labels. 
 
The Label Scale is used to specify the plotting scale for the text labels. Note that the label scale must be 
manually set by the user and is not set by the D&C Manager. The GEOPAK default value is 100. 
 
To plot a COGO chain, simply select the name of the chain from the list box on the left. The chain is 
plotted with the symbology of the currently selected D&C Manager Item.  
 
Selecting the chain name more than once will result in duplicate graphics being plotted in the 
MicroStation file. 
 
A sample of the plotted chain and curve data for CLPRS185 and CLPRJAME is shown below. 
 

 
 
Each centerline item in ODOT.ddb is configured to place the centerline, curve data, and bearing labels 
on the levels as shown in the following tables. 
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Proposed Centerline or Baseline of Construction and Stations 
Drafting Standards > Proposed Plan View > GE – Geometry and Stations > CL or BL Construction 

Item ID Description Line Style Level 

P_CL10 Centerline 10 Scale cl10 GE_P_CL_10 

P_CL20 Centerline 20 Scale cl20 GE_P_CL_20 

P_CL50 Centerline 50 Scale – 100’ Label Interval cl50 GE_P_CL_50 

P_CL50 Centerline 50 Scale – 500’ Label Interval cl50 GE_P_CL_50 

P_CL100 Centerline 100 Scale cl100 GE_P_CL_100 

P_CL200 Centerline 200 Scale cl200 GE_P_CL_200 

P_CL500 Centerline 500 Scale cl500 GE_P_CL_500 

P_CL1000 Centerline 1000 Scale cl1000 GE_P_CL_1000 

P_CL2000 Centerline 2000 Scale cl2000 GE_P_CL_2000 

 

Proposed Centerline of Right-of-Way and Stations 
Drafting Standards > Proposed Plan View > RW – Right-of-Way > CL Right-of-Way 

Item ID Description Line Style Level 

P_CLRW20 CL of RW 20 Scale cl20 RW_P_CL_20 

P_CLRW50 CL of RW 50 Scale – 100’ Label Interval cl50 RW_P_CL_50 

P_CLRW50 CL of RW 50 Scale – 500’ Label Interval cl50 RW_P_CL_50 

P_CLRW100 CL of RW 100 Scale cl100 RW_P_CL_100 

P_CLRW200 CL of RW 200 Scale cl200 RW_P_CL_200 

P_CLRW500 CL of RW 500 Scale cl500 RW_P_CL_500 

P_CLRW1000 CL of RW 1000 Scale cl1000 RW_P_CL_1000 

P_CLRW2000 CL of RW 2000 Scale cl2000 RW_P_CL_2000 

 

Proposed Centerline of Survey and Stations 
Drafting Standards > Proposed Plan View > SV - Survey > CL Survey 

Item ID Description Line Style Level 

P_CLSV20 CL of Survey 20 Scale cl20 SV_P_CL_20 

P_CLSV50 CL of Survey 50 Scale – 100’ Label Interval cl50 SV_P_CL_50 

P_CLSV50 CL of Survey 50 Scale – 500’ Label Interval cl50 SV_P_CL_50 

P_CLSV100 CL of Survey 100 Scale cl100 SV_P_CL_100 

P_CLSV200 CL of Survey 200 Scale cl200 SV_P_CL_200 

P_CLSV500 CL of Survey 500 Scale cl500 SV_P_CL_500 

P_CLSV1000 CL of Survey 1000 Scale cl1000 SV_P_CL_1000 

P_CLSV2000 CL of Survey 2000 Scale cl2000 SV_P_CL_2000 
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Proposed Temporary Road Centerline and Stations 
Drafting Standards > Proposed Plan View > MT - Maintenance of Traffic > Temporary Road CL 
and Stations 

Item ID Description Line Style Level 

P_TC20 Temp Road Centerline 20 Scale cl20 MT_P_CL_20 

P_TC30 Temp Road Centerline 30 Scale cl20 MT_P_CL_30 

P_TC40 Temp Road Centerline 40 Scale cl50 MT_P_CL_40 

P_TC50 Temp Road Centerline 50 Scale cl50 MT_P_CL_50 

 

Existing Centerline or Baseline of Construction and Stations 
Drafting Standards > Existing Plan View > GE – Geometry and Stations > CL or BL Construction 

Item ID Description Line Style Level 

X_CL10 Centerline 10 Scale cl10 GE_X_CL_10 

X_CL20 Centerline 20 Scale cl20 GE_X_CL_20 

X_CL50 Centerline 50 Scale – 100’ Label Interval cl50 GE_X_CL_50 

X_CL50 Centerline 50 Scale – 500’ Label Interval cl50 GE_X_CL_50 

X_CL100 Centerline 100 Scale cl100 GE_X_CL_100 

X_CL200 Centerline 200 Scale cl200 GE_X_CL_200 

X_CL500 Centerline 500 Scale cl500 GE_X_CL_500 

X_CL1000 Centerline 1000 Scale cl1000 GE_X_CL_1000 

 

Existing Centerline of Right-of-Way and Stations 
Drafting Standards > Existing Plan View > RW – Right-of-Way > CL Right-of-Way 

Item ID Description Line Style Level 

X_CLRW20 CL of RW 20 Scale cl20 RW_X_CL_20 

X_CLRW50 CL of RW 50 Scale – 100’ Label Interval cl50 RW_X_CL_50 

X_CLRW50 CL of RW 50 Scale – 500’ Label Interval cl50 RW_X_CL_50 

X_CLRW100 CL of RW 100 Scale cl100 RW_X_CL_100 

X_CLRW200 CL of RW 200 Scale cl200 RW_X_CL_200 

X_CLRW500 CL of RW 500 Scale cl500 RW_X_CL_500 

X_CLRW1000 CL of RW 1000 Scale cl1000 RW_X_CL_1000 

X_CLRW2000 CL of RW 2000 Scale cl2000 RW_X_CL_2000 

 

Existing Centerline of Survey and Stations 
Drafting Standards > Existing Plan View > SV - Survey > CL Survey 

Item ID Description Line Style Level 

X_CLSV20 CL of Survey 20 Scale cl20 SV_X_CL_20 

X_CLSV50 CL of Survey 50 Scale – 100’ Label Interval cl50 SV_X_CL_50 

X_CLSV50 CL of Survey 50 Scale – 500’ Label Interval cl50 SV_X_CL_50 

X_CLSV100 CL of Survey 100 Scale cl100 SV_X_CL_100 

X_CLSV200 CL of Survey 200 Scale cl200 SV_X_CL_200 

X_CLSV500 CL of Survey 500 Scale cl500 SV_X_CL_500 

X_CLSV1000 CL of Survey 1000 Scale cl1000 SV_X_CL_1000 

X_CLSV2000 CL of Survey 2000 Scale cl2000 SV_X_CL_2000 
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5.5.4 Plotting Stationing 

Stationing for COGO chains can also be plotted using the D&C Manager database. Each centerline option 
in ODOT.ddb is also configured to plot stationing for the alignment. 
 
To plot the stationing for a COGO chain, select the desired Centerline item from ODOT.ddb, then pick 
the Draw Plan & Profile option from the D&C Manager Tools Settings dialog. 

 
From the Plan & Profile Draw dialog, toggle the Operation mode to Stationing as shown at left. 
 
The list of available chains in the COGO database is shown in the list box on the left hand side of the Plan 
& Profile Draw dialog. 
 
The right side of the Plan & Profile Draw dialog contains a list of options for plotting the currently 
selected item. ODOT.ddb has been configured with the Tick Marks, Tick Mark Stations, and PC & PT & 
CS… labels options toggled on. 
 
The Label Scale is used to specify the plotting scale for the station labels. Note that the label scale must 
be manually set by the user and is not set by the D&C Manager. The GEOPAK default value is 100. 
 
The options for the placement of Small Ticks, Large Ticks and Control Point Labels should normally be 
set as shown at left. 
 
To plot the stationing, simply select the name of the chain from the list box on the left. The stationing is 
plotted with the symbology of the currently selected D&C Manager Item.  
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Selecting the chain name more than once will result in duplicate graphics being plotted in the 
MicroStation file. 
 
An example of the stationing for Jameson Road is shown below. 
 

 
 
Note: Typically, the stationing will not line up with the short dashes in the centerline as shown above. 
Many users prefer to have the station ticks line up with the short dashes along the centerline. Several 
factors contribute to the stationing not lining up with the short dashes as described below: 
 

 The components of the chain are placed as separate MicroStation elements and not as one 
complex chain. The custom line style cycle is started over for each component of the chain as 
shown in the example above. Connect all of the components of the centerline as one continuous 
element using the MicroStation Complex Chain command. Remember that when you create a 
complex chain the new chain is created using the active MicroStation symbology. 

 

 If your chain begins at an even station, all of the ticks will line up with the short dashes after 
creating the complex chain.  

 

 If the stationing does not start at an even station, the ticks will not line up with the short dashes 
as shown in example below: 
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Use the MicroStation Modify Line Style Attributes command with the shift option to align the centerline 
dashes with the station tic marks. The example below shows how to modify the custom line style for the 
first segment of CLPS185. The shift amount is determined as follows: 
 
Subtract the even station amount from the actual station at the beginning of the line, spiral, or arc 
segment. Then multiply the answer by -1. In the example below 35+90.72 – 35+00.00 = 90.72. The line 
segment is shifted by -90.72 as shown below. 
 

 
 
The example below shows how to shift the arc on CLPJAME. 13+65.94 – 13+00.00 = 65.94. Shift the arc 
with a value of -64.94. 
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5.6 Identify Item 

 
The Identify Item tool allows users to navigate the hierarchy by selecting a MicroStation element. After 
selecting and accepting the element, GEOPAK moves to the item in the hierarchy which corresponds to 
the selected element. If no matching item is found within the specified database, GEOPAK displays the 
following message in the prompt field: "No matching database item." 
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5.7 Display Mode 

Display mode allows the designer to filter the display of MicroStation elements in the design file so only 
specific features are displayed. When Display Mode is selected, the Design and Computation Manager 
and the tool settings dialog dynamically change as shown below. 

 
Users can filter the display by Items or by categories. Select the Add Highlighted to Collection button to 
add the currently selected category or item to the Collection box, at the bottom of the dialog, as shown 
below. Multiple categories and items can be added. 

 
The D&C Manager Tool Settings dialog is used to select how GEOPAK will filter the display of elements. 
Four options are available as shown below. 
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From left to right, the following options are provided: 
 

 Normal Display 

 Highlight Selection 

 Hide Selection 

 Display Only Selection 
 
To remove an item or category from the collection box, select the Clear All Items in Collection icon. 

 
Note: Only items placed using the D&C Manager are recognized by the Display Mode. Graphics placed 
by GEOPAK Survey, COGO Visualization or MicroStation Commands (without using Place Influence) are 
not recognized by Display Mode. 
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5.8 Set Mode 

The Set mode is used to change the element symbolgy of previously drawn MicroStation elements to 
match the symbology of the current D&C Manager item.  

 
Two methods of setting elements are supported: 
 

 Individual Element Selection 

 Complex Chain 
 
The first step for all methods is the selection of the desired item. Navigating through the hierarchy, 
highlight the desired item. Note the title block of the auxiliary dialog dynamically changes during the 
navigation process. Once an item is selected, the auxiliary dialog buttons are un-ghosted. 
 

Individual Element Selection 
Select the desired item in the D&C Database and then click Set. GEOPAK prompts to select the 
desired MicroStation element. Note the element must be selected AND accepted in order to set 
the symbology / attribute. Multiple elements may be set to match the D&C Item symbology by 
use of MicroStation selection sets. 
 
Complex Chain Method 
The Complex chain method utilizes the MicroStation automatic complex chain creation 
command in the background, while setting Element attributes. After selecting the desired item, 
activate the Use Complex Chain toggle, which expands the auxiliary dialog as depicted below. 

 
Note the Set button is ghosted, as it is not utilized in this method. The following details the steps for this 
method: 
 

1. Click ID Element 
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2. Identify and accept a line or arc that constitutes the beginning of the chain.  
 

 
 

3. Like the MicroStation Automatic Create Complex Chain, successive connected elements are 
highlighted one at a time for inclusion or rejection as long as the initial point of each subsequent 
element is within 0.75 master units (feet or meters) of the end point of the current element. As 
shown below, after the first element is selected and accepted, the next connected element is 
highlighted. 
 

 
 

If more than a single element is located within tolerance to the next element end point, the 
message "Fork Accept/Reject" is displayed. A data point accepts the highlighted element. 
Pressing the reset cursor button rejects the highlighted element and highlights another. 

 
4. Once the end of the chain is reached or the user presses the reset cursor button when no more 

connecting elements are available, the identification of component chain elements is complete. 
The highlighting is deactivated and the elements symbology and attributes are now set. 
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5.9 Favorites 

The Favorites pull down is a very useful tool that allows the designer to save a list of commonly utilized 
D&C items for quick access. When selected, two options are available as shown below. 

 
Add to Favorites 
To add an item to the Favorites list, take the following steps: 
 

 Select the item in the Design and Computation Manager dialog. 
 

 Select Favorites > Add to Favorites. 
 
The user may select up to twenty items, with each additional item being added at the top of the 
list. When the twenty first item is selected, the first item is deleted from the list. The dialog 
width will expand to include all of the selected paths as shown above. 

 
The second tool under the Favorites pull down is Organize Favorites, which invokes the My Favorites 
dialog shown below. 

 
The current Favorites are displayed within the list box. The six action buttons at the bottom of the dialog 
are detailed below. 
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Up / Down 
Favorites can be moved up or down within the list by highlighting the Favorite to be moved, 
then pressing the Up or Down button. Each press of the button moves the Favorite one position. 
 
Delete 
Highlight the Favorite to be deleted, and then press the Delete button to remove it from the list. 
 
Open 
Previously saved Favorite lists can be utilized by pressing the Open button, which invokes the 
File Manager, wherein the desired listing file may be selected. 
 
Save As… 
Favorite lists can be saved for recall in a subsequent session by pressing the Save As... button, 
which invokes the File Manager, wherein the current listing file may be named and saved. 
 
Close 
Closes the dialog, returning to the Design and Computation Manager. 
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5.10  Toolbox Mode 

The D&C Manager dialog box can be configured in one of two modes: 
 

 Dialog 

 Toolbox 
 
The default mode is dialog, as shown in the graphic below. The menu bar and shortcut buttons are on 
the top of the dialog, with the list box below. 

 
The second mode is the Toolbox mode, shown below. 

 
Select the Switch To Toolbox Mode icon to change the dialog to toolbox mode. In this mode, the dialog 
is condensed and is dockable. The icons on the Toolbox mode dialog are detailed below.  
 
Place Influence (Leftmost Toggle) 
 

 The toggle to the left of the dialog activates the Place Influence tool. 
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Hierarchy 

 
The right field displays the current position within the hierarchy, along with its associated icon. The left 
field displays its parent. The arrows display the surrounding hierarchy from which categories or items 
may be selected. 
 
 
Level Up/Level Down 

 
Another method for navigating the hierarchy is the use of the Level Up or Level Down buttons. One 
press of the button moves one position. This is utilized in conjunction with the Design Settings dialog, 
invoked by selecting Settings > Dialog (when in the dialog mode). The dialog is displayed below.  

 
Two options are supported: By Category or By Item. When By Category is set, pressing the Level button 
moves the current position up or down in the hierarchy by category, ignoring the presence of items. 
When set to By Item and one of the Level buttons is pressed, the current position stays within the 
current category and moves up or down one item. Note: if the current position is at the bottom position, 
and the Level Down button is pressed, a prompt is displayed. Conversely, if the current position is at the 
top position, and the Level Up button is pressed, a prompt is displayed. 
 
 
 
 
 
 
 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 5-38 Chapter 5 – Design and Computation Manager 
 

Shortcut button for the Edit > Find tool. 

 
 Various searches can be processed throughout the database, utilizing Item, Category, or Item / 
Category options. The Name and/or Description fields are specified and Case Matching options may be 
invoked. The search will begin at the highlighted Item or Category at the time of invocation. When Start 
is clicked, the software scans the database for the specified parameters. If the end of the database is 
encountered before the specified parameters are met, the software prompts if you want to continue at 
the beginning of the database. When the specified parameters are found, the correct category and/or 
item path are listed in the Starting From: field. 

 
 
Shortcut button for the Identify mode. 

  
Another tool that enables the user to better navigate the hierarchy is the Identify mode. The tool is 
accessed via the shortcut button at the top of the dialog or from the Edit pulldown. When pressed, the 
user is prompted to select a MicroStation element. After selecting and accepting the element, GEOPAK 
moves to the item in the hierarchy which corresponds to the selected element. If no item is found within 
the specified database, GEOPAK displays the following message in the prompt field: "No matching 
database item." 
 
 
Shortcut buttons for the Display mode. 

 
The same Display tools can be utilized within the Toolbox mode, as well as the dialog mode.  
 
 
 
 
 
 
 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 5 – Design and Computation Manager Page 5-39 
 

Shortcut button for the Set mode. 

  
This shortcut button is used to access the Set mode. 
 
 
Shortcut buttons to execute Design, Display, and Set key-in scripts. 

  
Each item in the DDB file can have a key-in command associated with the item. Separate key-in 
commands can be assigned for Design, Display, and Set mode. When the user double-clicks an item from 
the D&C Manager dialog, the associated key-in command is executed. 
 
When in Tool Box mode, there is no way to double-click an item. These three icons are provided to 
process a key-in command while in tool box mode. 
 
For example, the Proposed Fence Line item has the key-in command “Place SmartLine” assigned for 
Design mode. Double clicking the Proposed Fence Line item will execute the key-in command. In Tool 
Box mode, selecting the Proposed Fence Line item and clicking the Design Key-in Icon will execute the 
“Place SmartLine” key-in command. 

 
 
Switch back to dialog mode. 

 
When switching back to dialog mode, only the main D&C Manager dialog is opened. To open the second 
dialog with the Place Influence toggle, select the Design Mode icon as shown below. 
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Exercise 5 

 Plot the proposed S.R.185 and proposed Jameson Road chains using the correct design and 
computation manager features for a 20 Scale proposed centerline. 

 

 Plot the stationing for proposed S.R. 185 and proposed Jameson Road for a 1:20 plotting scale. 
 

 Use the MicroStation Copy Parallel command with the D&C Manager Place Influence option to 
place a proposed edge of pavement 12' to the left and right of proposed S.R. 185 and proposed 
Jameson Road. 

 

 Use the MicroStation Construct Circular Fillet command with Place Influence to place 50' radius 
returns between proposed S.R. 185 and proposed Jameson Road. 

 

 Use the D&C Manager in conjunction with MicroStation to draw the proposed shoulder for 
proposed S.R. 185. The shoulder width is 4'. Draw the shoulders around the radius returns as 
shown below. 

 
The intersection for proposed S.R. 185 and Jameson Road should look as shown below when completed. 
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6 Drafting Tools 

6.1 Overview 

GEOPAK provides several tools to assist in the drafting of plan view features. The following tools are the 
focus of this chapter: 
 

 DP Station Offset 

 Draw Cell by Feature 

 Draw Cell Group by Feature 

 Draw Transition 

 Active Chain Control 

 Pavement Marking 
 
Each of these tools can be used in conjunction with the Design & Computation Manager’s Place 
Influence command to ensure that plan view items are drawn in accordance with ODOT standards. 

6.2 DP Station Offset 

 
The DP Station Offset dialog is used to issue a MicroStation 
data point in terms of a station and offset relative to a 
GEOPAK coordinate geometry chain.  
 
The dialog can be invoked by selecting Applications > Road > 
Plans Preparation > DP Station/Offset or from the GEOPAK 
Road Tools palette as shown at right.  

 
The DP Station Offset dialog is shown below. 

 
Once invoked, DP Station Offset can be used with 
MicroStation commands to place plan view graphics at a 
specific station and offset relative to a COGO chain. Let's look 
at a few examples and applications of this useful tool. 
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The most obvious use of the DP Station Offset dialog is the precision placement of lines, curves, cells, 
etc. for plan view features which are located by station and offset measurements from a previously 
stored chain. This could include guard rail, fencing, walls, right of way features, sidewalks and so forth. 
Let's review the dialog shown on the previous page. To place a proposed fence line, take the following 
steps: 
 

 Establish the desired element symbology using the D&C Manager as shown below 
 

 Next, select the MicroStation Place SmartLine command 
 

 Fill in the DP Station Offset dialog with the desired information for the initial point. This includes 
the Job number, the reference Chain, the desired Station, and Offset. DP Station Offset utilizes 
standard surveying convention for offsets. A positive offset (i.e., 45.6) would be to the right of 
the chain and a negative offset (i.e., -92) would be to the left according to the direction of 
stationing. Note: The plus (+) sign is not required, as GEOPAK will assume a positive offset if no 
sign is given. 

 
 Select DP to send the station and offset to MicroStation. The first endpoint of the SmartLine is 

drawn from the Station and Offset values specified. 

 
 Change the DP Station Offset dialog settings to reflect the next endpoint for the fence line. 

Select DP to send the second data point to MicroStation. 
 
If there are station equations in the chain, regions are not required unless the given station exists in 
more than one region. The syntax for regions is 45+56 R 2 with a minimum of one space between the 
station and the R and a minimum of one space between the R and the region number. 
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Other uses for DP Station Offset include text and cell placement. It might be desirable to draw a cell 
representing such features as lighting fixtures and drainage structures perpendicular or tangent to the 
chain. The bottom part of the DP Station Offset dialog provides four options to control the orientation of 
cells as shown in the dialog below. 

 
Options include text or element placement Tangent to the chain, 
Tangent + 180 degrees, Radial, and Radial + 180 degrees. All 
orientations are relative to the direction of stationing. To use 
these options, select the preferred option (such as Radial), then 
press the AA button. GEOPAK will display the Active Angle radial 
to the chain at the designated station in the MicroStation 
Command Window and set the Active Angle.  
 
To place a cell, take the following steps: 

 
 

 Set the active cell appropriately, and then choose the Place Cell command. 
 Key-in the correct Station and Offset into the dialog 
 Select the desired rotation option. 
 Press the AA button 
 Press the DP push button. The cell will be placed in the MicroStation file at the desired location 

and orientation as shown below 

 
It can be cumbersome to keep selecting the AA button to set the Active Angle each time a new station 
and offset value is entered. The Auto Angle toggle can be selected to automatically change the active 
angle automatically every time a new station and offset is keyed in. 
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6.3 Draw Cell by Feature 

The Draw Cell by Feature tool is used to draw cells with a variety of options for all project scenarios. For 
example, trees can be placed at specific station / offsets, guard rail posts can be evenly spaced along the 
railing, and all are selected by D&C Manager Feature, rather than searching for cells. 
 
The Draw Cell by Feature dialog can be accessed from the GEOPAK Road tool palette as shown below, or 
by selecting Applications > Road > Plans Preparation > Draw Cell by Feature from the MicroStation pull 
down menu. 

 
 
The Draw Cell by Feature dialog shown below is opened. 

 
 
 
 
 
 
 
 
 
 

The dialog has the following options: 
 
Feature 
This option is used to select the Design and Computation Manager Feature which determines the cell to 
be placed. The items configured to place a cell from the current DDB file are available in the drop down 
list. If another category or DDB is desired, click the Browse Features (Category) button to open the 
Select Design and Computation Payitem dialog shown below 
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The items within the selected category that have been configured to place cells will become available in 
the drop down list. In the example below, the Existing Vegetation category was selected. The list is 
constrained to contain only the cells from that category. 

 
Placement 
Cells can be placed along an element, by using the On Element option or singly by using the By Point 
option. When By Point is selected, the rest of the dialog is ghosted except for Dynamic Rotation. 
 
Angle 
This key-in field is used to specify the Angle of the cell. If set to Absolute, the Angle is based on 0 
degrees as horizontal. If set to Relative, the Angle is based relative to the selected element or chain. 
 
Element 
If the Placement option is set to On Element, the Element option is un-ghosted and has two options: 
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DGN - Cells are placed relative to a MicroStation element. Click Identify DGN Element to identify the 
element.  

 
Chain – Cells are placed relative to a COGO chain. Select a Chain from the list of chains in the current 
GPK file, or graphically by using the Identify Chain button. 

 
Station 
When a Chain is specified, the station, in conjunction with the offset, is used for determining the 
placement of the cell. When a DGN element is selected, the station represents the distance along the 
element. 
 
Offset 
Offset of the cell, based on the specified chain or from the MicroStation element. It is not necessary to 
key in negative offsets for elements placed to the left of the reference element. The cell will dynamically 
move to the left or right side of the reference element depending on the cursor position during 
placement. 
 
Dynamic Rotation 
When toggled on, the cell can be rotated to the desired angle. When toggled off, the Angle is entered in 
the angle field. 
 
Draw 
Click the Draw button to start cell placement. Depending on the options selected, various prompts are 
displayed to guide the user in placement. 
 
An example of placing a proposed Power Pole is shown below. 
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6.4 Draw Cell Group by Feature 

The Draw Cell Group by Feature tool is used to place groups of cells based on user defined spacing and 
offsets. 
 
The Draw Cell Group by Feature dialog can be accessed from the GEOPAK Road tool palette, as shown 
below, or by selecting Applications > Road > Plans Preparation > Draw Cell Group by Feature from the 
MicroStation pull down menu. 

 
 
The Draw Cell Group by Feature dialog shown below is 
opened. 

 
 
 
 
 
 
 
 

 
 
The dialog consists of two tabs: 
 

 Feature Group - defines the D&C Manager Features (which in turn dictate the cells) to be used 
within the group 

 

 Location - the placement of the cells based on a graphic element or chain. 
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Feature Group 
The Feature Group tab has the following options: 

 
By default, one cell will be placed using the parameters specified on the Location tab. Up to 
three cells can be placed by clicking on the toggle for the Upstream and Downstream cells as 
shown above. The Offset and Spacing can be specified as show above. 

 
Location Tab 
The Location Tab is used to specify where the cell group will be placed in the design file. The group can 
be placed relative to a design line element or a COGO chain. 

 
Element 
The cell group may be placed relative to a DGN element or a COGO Chain. 
 
DGN - Cells are placed along a MicroStation element. Click Browse to identify the element (i.e., 
lane line in the example of turning arrows). If multiple elements need to be selected, use the 
Complex Chain option. 
 
Chain - Select a chain from the list of chains in the current GPK file. 
 
 
 
 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 6 – Drafting Tools Page 6-9 
 

Begin / End 
Used to specify the location where the cells begin and end. If the Element is a Chain, then the 
fields are populated with the beginning and ending station of the chain. Cells may be placed 
along a portion of the element or chain either by changing the entries manually, or by graphical 
selection via the DP buttons. 
 
Buffer Distance 
The Buffer Distance is intended for the case where the Begin/End station is known, but the cells 
have to be kept a certain distance inside that stationing. For example, if the begin station = 
1+50.00 and end station = 7+50.00, the cells are drawn from 1+50 to 7+50. But if buffer distance 
= 20.00 and 40.00, then the adjusted stations are as follows: 
 

Begin Station = 1+70.00 (1+50.00 + 20.00) 
End Station = 7+10.00 (7+50.00 - 40.00) 

 
Spacing 
The entire cell group can be repeated and placed multiple times along the selected Element. 
The following options are available: 
 
Increment – Cell groups are placed along the specified Element starting from the Begin value. 
For example, if the Begin value is 35+90.72, and the Increment value is set to 500’, then the 
next cell group will be placed at station 40+90.72. 
 
Even - Cell groups are placed along the specified Element starting from the first Even increment 
past the Begin value. For example, if the Begin value is 35+90.72, and the Increment value is set 
to 500’, then the first cell group will be placed at station 40+00. 
 
Max Spacing - The location of the beginning and ending cell are determined, then a sufficient 
number of cells are placed in between such that the distance between them is no more than the 
specified Max Spacing. 
 
Once - Only one cell group is placed. Note the Ending Buffer Distance and End key-in fields are 
ghosted. 
 
Each Vertex - The origin of the cell is placed at each vertex of the selected element. The key-in 
field is ghosted for this option. 
 
Each Endpoint - The origin of the cell is placed at the endpoints of the selected element. The 
key-in field is ghosted for this option. 
 
Angle 
Cells can be placed at a specified angle. If set to Absolute, the Angle is based on 0 degrees as 
horizontal. If set to Relative, the angle is based relative to the selected element or chain. 
 
 
 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 6-10 Chapter 6 – Drafting Tools 
 

Justification 
The justification can be based on the center, upstream or downstream cell. Only those toggled 
on in the Feature Group are available for setting Justification. 
 
Draw 
Click to commence cell placement. Depending on the options selected, various prompts are 
displayed to guide the user in placement. 
 
An example of a cell group is shown below: 
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Tip:  
Draw Transition is not 
limited to drawing 
transitioning elements that 
have a different beginning 
and ending offset. Draw 
Transition can also be used 
to quickly draw the Edge of 
Pavement and Shoulder by 
using the same value for 
the beginning and ending 
offsets.  

6.5 Draw Transition 

The GEOPAK Draw Transition tool is used to assist the designer in the drafting of transitions such as 
those for a turn lane, bypass lane, or acceleration lane. This could be accomplished with the DP Station 
Offset tool in conjunction with the MicroStation Place SmartLine tool. However, the Draw Transition 
tool is especially useful in transition areas that are not in tangent sections of the alignment. 

 
The Draw Transition tool is essentially a specialized DP 
Station Offset dialog which allows for two stations and 
offsets to be input simultaneously. GEOPAK will then 
draw a transition curve between the two station and 
offsets using the active symbology. To invoke the Draw 
Transition dialog, select Applications > Road > Plans 
Preparation > Draw Transition or select its icon from 
the GEOPAK Road tool palette as shown at left 

 
 
 

 
Fill in the Draw Transition dialog with the information for the transition. This includes the Job number, 
the reference Chain, the desired Beginning Station, Beginning Offset, 
and Ending Station and Ending Offset. 
 
Draw Transition utilizes standard surveying convention for offsets. A 
positive offset (i.e., 45.6) would be to the right, while a negative offset 
(i.e., -92) would be to the left, of the chain. Orientation is according to 
the direction of stationing. Note the plus (+) sign is not required as 
GEOPAK will assume a positive offset if no sign is given.  
 
If there are station equations in the chain, regions are not required 
unless the given station exists in more than one region. The syntax for 
regions is 45+56 R 2 with a minimum of one space between the station 
and the R and a minimum of one space between the R and the region 
number. 
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6.6 Active Chain Control 

The Active Chain Control enables the user to manage plan, profile, and cross section views 
simultaneously. It also allows the use of MicroStation tools to place elements in any view (plan, profile, 
or cross section) in accordance with the Curvilinear Coordinates tool. 

 
 
To access the Active Chain Control, select Applications > 
Road > Active Chain Control from the MicroStation pull 
down menus, or from the Road tool palette as shown at 
left. 
 
 
 
 
 
 
 

 
The Active Chain Control dialog is shown below 

 
First, select the desired Job number and Chain from the list box at the left end of the Active Chain 
Control dialog. The list of available chains is updated every time a new chain is created or deleted, or if a 
new GPK file is opened. 
 
The remaining icons on the Active Chain Control dialog are documented below. 
 

Graphically select the active Chain. 
 

 
Opens the Curvilinear Coordinates dialog which enables the user to enter precise 
curvilinear coordinates relative to the active chain. The Curvilinear Coordinates command 

is described below. 
 

Activates the current profile, which is associated to a Profile Cell. The Profile Cell Status 
function is described on page 6-14. 

 
Activates the current Cross Section system. The Cross Section Cell Status command is not 
covered in this training guide. 

 
 

View control icons. See page 6-17 for more information.  
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6.6.1 Curvilinear Coordinates 

When the Curvilinear Coordinates icon is pressed, the Curvilinear Coordinates dialog, as shown below, 
opens. 

 
The Curvilinear Coordinates dialog can be used to track the current cursor position relative to the 
selected COGO Chain, or to enter station, offset, and elevation values that can be Applied to the active 
MicroStation command. 
 
The fields in the dialog are described in the table below. 
 

< Select this button to lock the S field at the beginning station on the Chain 

> Select this button to lock the S field to the ending station on the Chain 

S This field reports the Station value of the cursor relative to the selected Chain. 
As the cursor is moved, the station continuously updated. This field can also be 
used to enter the station along the active chain. Use the left toggle to lock the 
value of this field 

Ext. If the cursor is moved before the beginning of the selected chain, or after the 
end of the selected chain, the distance along an assumed tangent extension of 
the alignment is reported in this field. A negative value means that the 
extension is before the beginning of the chain. A positive value means that the 
extension is after the end of the chain 

O Use this field to track the offset of the cursor or to enter an offset from the 
active chain. Use the left toggle to lock the value of this field 

Z Use this field to enter an elevation. Use the left toggle to lock the value of this 
field 

DS Use this field to enter a delta station from the previous data point or tentative 
point. Use the left toggle to lock the value of this field 

DO Use this field to enter a delta offset from the previous data point or tentative 
point. Use the left toggle to lock the value of this field 

DZ Use this field to enter a delta elevation from the previous data point or 
tentative point. Use the left toggle to lock the value of this field 

Permanent 
Lock 

When this toggle is checked, coordinates locks remain active, even after a data 
point is issued 

Apply Select this button to send a data point to the active MicroStation command 
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The Curvilinear Coordinates dialog can be used in conjunction with generic MicroStation commands. For 
example, select the Place SmartLine command. When prompted for the first data point, move the cursor 
around the screen and note the dynamics within the dialog. Set the station and offset by activating the S 
and O toggles, then press the Apply button. The first endpoint of the line is placed and moving the 
cursor displays a line as shown in the graphic below. 

 
Move the cursor to view the dynamics again. The second endpoint can be defined by entering a data 
point on screen, entering Station and Offset, entering a DS value, or entering a DO value. 
 
 

6.6.2 Profile Cell Status 

A Profile Cell can be drawn to easily reference the profile in subsequent tasks. Once the cell has been 
placed, it can be utilized by any process where the profile’s DP Station, Elevation, X, Y, Horizontal Scale 
or Vertical Scale values are needed. 
 
The Profile Cell can be located in the master file or in any of the reference files. When the right mouse 
button is pressed on the Profile Cell Status icon, a pop-up menu appears as shown below. 

 
The Place Profile Cell option of the pop-up menu allows placement of a profile cell in the active 
MicroStation design file. Note: The profile cell may be placed by many other applications in GEOPAK, 
i.e., D&C Manager, Vertical Alignment Generator, Project Manager and Plan / Profile Sheets. When 
selected, the dialog on the following page is displayed. 
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Station Use this field to define the Station of the reference data point at the origin of 

the profile cell 

Elevation Use this field to define the Elevation of the reference data point at the origin 
of the profile cell. It should be an even value to correspond with the major 
grid and lower in elevation than the minimum elevation of the profile 

Horizontal Scale 
Vertical Scale 

Use these fields to set the scale and subsequently the distortion utilized to 
draw the profile 

Gap / No Gap Use these fields to set the scale and subsequently the distortion utilized to 
draw the profile 

Cell Range Use these fields to define the height of the Profile Cell. The option buttons 
allow selecting the values as shown below 

 
The Top Delta and Bottom Delta values are given in true length without 
taking into account horizontal and vertical scales. Care must be given that 
the Top Delta and Bottom Delta values of the profile cell are set large 
enough to ensure that all profile elements fall completely within the limits of 
the profile cell. 
 
The Top Elevation and Bottom Elevation values are used to key in elevations 
corresponding to the top and bottom elevations of the profile cell. Care must 
be given that the Top Elevation and Bottom Elevation values of the profile 
cell are set large enough to ensure that all profile elements fall completely 
within the limits of the profile cell 

 
By default, the profile cell is placed on level “Default”, and contains a vertical and horizontal datum, plus 
a text node containing the information shown below. 
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The text size and spacing is controlled by the active MicroStation text attributes. 
 
 
Profile Cell Control 
The Profile Cell Control dialog enables the user to place or manipulate profile cells and associated data. 
When the right mouse button is pressed, a pop-up menu appears as shown below 

 
When the Profile Cell Control option is selected, the dialog shown below opens. 

 
The dialog is comprised of two main parts: 
 

Active Chain Combo box to select the Active Chain 

MicroStation File, 
Station, etc. 

This list box gives information about all the Profile Cells that are 
associated with the Active Chain 
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Three action icons are located on the right side of the dialog and are detailed below: 
 

 Use this button to place a new Profile Cell. This is the same as the Place Profile Cell 
command described on page 6-15. 
 

 Use this button to activate the selected Profile Cell. 
 

 Use this button to delete the selected Profile Cell. 
 
For more information on Profiles and Profile Cells, see Chapters 8 and 9. 
 
 
View Control Icons 
The right side of the Active Chain Control dialog has eight icons corresponding to the eight MicroStation 
view windows. These icons are shown below. 

 
Each icon can be used to define the type of view (Plan, Profile, or Cross Section) that is assigned to the 
associated MicroStation view window (1 through 8). Once the type of view has been assigned, clicking 
on the view control icon will execute a MicroStation Fit View command in the corresponding 
MicroStation window. 
 
To assign the Plan, Profile, or Cross Section to one of the 
MicroStation view windows, right click on one of the view icons to 
open the pop-up menu shown at right. 

 
 
 

Plan Selecting this option will assign the Plan view to the corresponding 
MicroStation window. After the Plan view has been assigned, the icon will 
appear as shown in the example for View 1, below

 
 

Profile Selecting this option will assign the Profile view to the corresponding 
MicroStation window. After the Profile view has been assigned, the icon will 
appear as shown in the example for View 2, below 
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Cross Section Selecting this option will assign the Cross Section view to the corresponding 
MicroStation window. After the Cross Section view has been assigned, the icon 
will appear as shown in the example for View 3, below 

 
 
After the Plan, Profile, or Cross Section view has been assigned, selecting the icon with the left mouse 
button will execute a MicroStation Fit View command in the corresponding MicroStation window. The 
Plan, Profile, or Cross Section is fitted in the corresponding MicroStation window. 
 
After the Cross Section view has been assigned, when the right mouse 
button is pressed on a Cross Section view icon, the Cross Section 
Navigate option is added to the pop-up menu as shown at right. 
 
 
 
Select Cross Section Navigate to open the XS Navigate dialog shown below. 

 
The options and icons are detailed below. 
 

 Use this item to select the active cross section view. Only views that have been 
assigned as Cross Section views on the Active Chain Control dialog are available 

 
Use this icon to go to the first cross section 

 
Use this icon to go to the previous cross section 

 
Use this icon to set the station option in the Curvilinear Coordinates dialog box. 
After the icon is selected, enter a data point on the screen in the cross section 
view. The station of the nearest cross section is read into the Curvilinear 
Coordinates dialog 

 
Use this icon to go to the next Cross Section 

 
Use this icon to go to the last Cross Section 
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Exercise 6 

 Use DP Station Offset or the Curvilinear Coordinates tool with the D&C Manager and 
MicroStation’s Place SmartLine command to draw the following pavement tapers for Jameson 
Road: 

Station Offset Left Offset Right 

12+00 -8.0’ 8.0’ 

12+50 -12.0’ 12.0’ 

 
 Use Draw Transition with the D&C Manager to draw a right turn lane at the intersection of S.R. 

185 and Jameson Road. The transition for the edge of pavement and shoulder is shown in the 
table below. 
 

Begin Sta. End Sta. EOP Beg. Offset EOP End Offset SH Beg. Offset SH End Offset 

63+50 64+00 12’ 24’ 16’ 28’ 

 
 Use the Draw Transition tool to draw 2.5’ curve widening for the edge of pavement and 

shoulder on the inside (left side) of S.R. 185. The transition stations for the curve widening are 
shown in the table below. 
 

Begin Sta. End Sta. EOP Beg. Offset EOP End Offset SH Beg. Offset SH End Offset 

60+33.98 62+38.98 -12’ -14.5’ -16’ -20.5’ 

62+38.98 71+12.80 -14.5’ -14.5’ -20.5’ -20.5’ 

71+12.80 73+17.80 -14.5’ -12’ -20.5’ -16’ 

 
 Use MicroStation commands with the D&C Manager to revise the edge of pavement and the 

shoulder as shown in the diagram below. 
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6.7 Pavement Markings Tools 

The Pavement Marking tools facilitate the production of traffic control plans.  The following options are 
provided for various pavement marking requirements: 
 

 Striping places lines parallel to a specified alignment at a user defined offset. 
 

 Separation draws markings between two identified selection sets. 
 

 Merge and Diverge Chevrons. Chevrons will not be covered during this training session. For 
more information on these tools, please see the GEOPAK documentation. 

 
Features such as stop lines, lane arrows, words on pavement (such as ONLY or SCHOOL), etc. can be 
placed using the Place Influence option of the Design and Computation Manager in conjunction with 
the DP Station Offset tool, or by use of the GEOPAK Draw Cell tool. 

 
The Pavement Markings tools are an option on the 
GEOPAK Design and Computation Manager. The tools 
can be accessed as follows: 
 

 Select the Pavement Markings icon from the 
GEOPAK Road Tools palette as shown at left. 
 

 Open the Design and Computation Manager and 
then select the Pavement Marking mode. 
 
The Design and Computation Manager is opened in 
Pavement Marking mode as shown below. 

 
 
 
 
 
 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 6 – Drafting Tools Page 6-21 
 

Four icons for pavement striping are available as detailed below. 
 

 Striping 
 

 Separation 
 

 Chevron Diverge 
 

 Chevron Merge 
 
A double click onto an Item within the Design and Computation Manager dialog will open the striping 
dialog associated with the depressed push button from the top of the dialog. Alternately, you can single 
click an item and press the pavement push button. 
  
Note: Pavement Marking Items in ODOT.ddb have been configured to use custom line styles to draw the 
various striping lines. This training guide will detail the process of placing pavement marking using 
custom line styles instead of using the Pavement Marking tool’s Skip/Stripe option. 
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6.7.1 Striping 

While the desired Item is highlighted, the selection of the Striping option in the upper right portion of 
the dialog invokes the Draw Striping dialog as shown below. 

 
Pattern 
In the case of the Single Stripe options, two different configurations (A and B) can be stored, so 
the user can change the type of striping being placed with a minimum of effort. In the case of 
the Double Stripe, up to four configurations (A, B, C, and D) can be stored. These configurations 
are automatically stored in a resource file. In this manner, they can be accessed in future 
sessions and the user does not have to re-configure the options. 
 
Single / Inside / Outside 
When either Single Stripe A or B options are selected, 
the Single option is used to specify the current item 
that will be used to draw the pavement striping. When 
one of the Double Stripe options is selected, Inside and 
Outside striping lines can be specified as shown at 
right. 
 
The Item highlighted when the Striping option was selected is placed in the Pay Item box by 
default. Note that this can be changed anytime during the process by clicking Single, Inside, or 
Outside. The display field immediately displays the currently selected D&C Manager Item. 
 
The Distance Between Stripes option is expressed in terms of master units. 
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Tip: 
For ODOT projects, the 
Solid option should always 
be used since the pavement 
marking items requiring 
dashed lines have been 
configured within 
ODOT.ddb to use a custom 
line style to set the dash 
lengths. 

Solid, Skip 
Solid/Solid, Skip/Solid, Solid/Skip, Skip/Skip 
GEOPAK provides the option to place solid or dashed lines by 
use of the Solid and Skip options as shown below.  

 
When using the Double Stripe options, as shown at right, 
multiple options are available to control whether the Inside 
or Outside lines will be placed as Skip or Solid lines. 

 
  
 
 
 
 

Tolerance 
If the length of a segment of pavement marking is less than the Tolerance, the line will not be 
placed. It will only be utilized at the ending point to determine where the final piece of marking 
is placed. 
 
Reference Element 
Options are provided to place pavement markings relative to a MicroStation DGN element or a 
COGO Chain as shown below. 

 
DGN 
The following options are available to select the DGN element: 
 

Single Element - When selected, the user is prompted to select the element.  
 

Selection Set - Create the selection set, then set the toggle to Selection Set. Click ID 
Element which computes the stationing for the selection set. If the selected elements 
are in reference files, this method must be utilized as Complex Chains cannot be 
selected from reference files. 
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Complex Chain - Select the option, which invokes the MicroStation Create Automatic 
Complex chain tool to define the elements. The complex chain is created in memory for 
the purpose of generating the pavement markings. 

 
Begin, End – These values begin at 0.00 and are based on the length of the selected 
element(s). 

 
Chain 
Select the Chain from the list or graphically with Identify Chain. The Begin and End station fields 
are automatically populated with the beginning and ending station on the chain as defaults. The 
values may be changed manually or graphically by using the buttons to the right of the Begin 
and End fields. 
 
Begin identifies the beginning of the striping. Note that Begin does not have to be on the 
element which is used as the basis for the offset, as the software constructs a perpendicular to 
the element and utilize the projection. By utilizing Begin (and End), the length of the striping is 
determined by the designer, not the length of the chain. Begin is set by clicking the DP icon, 
then placing a data point at the desired location or by keying in the desired station. The station 
of the point is displayed to the left of the DP icon. 
 
End serves the same function as Begin, but at the opposite end. Like Begin, it does not have to 
be located on the element. The End is set by clicking the DP icon, then placing a data point at 
the desired location. The station of the point is displayed to the left of the DP icon. 
 
Offset 
This option is used to specify the Offset from the selected elements to the striping. Definition of 
plus (RT) or minus (LT) is not necessary as the designer graphically indicates the stripe 
orientation relative to the chain after Draw Stripes is clicked. 
 
Draw Stripes 
Clicking Draw Stripes attaches the striping to the cursor at the appropriate offset. By moving the 
cursor on the screen, the designer can move the striping to the desired side of the chain, and a 
Data Point places the striping into the MicroStation file. The striping is placed (with each Data 
Point) in a graphic group for easy deletion, if desired. 
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6.7.2 Separation 

While the Striping option draws pavement markings at specified offsets from selected elements or a 
Chain, the Separation option draws pavement markings between two sets of selected elements. 
 
When a Transverse Line item is highlighted in the Design and Computation Manager dialog and the 
Separation option is selected, the Draw Separation dialog shown below is opened 

 
 
The Transverse Line is shown in the Pay Item output field in the Draw Separation dialog and can be 
changed at any time by highlighting the desired pavement marking item in the Design and Computation 
Manger and pressing the Item push button. 
 

Distance Between Stripes 
This key in field is located below the pavement marking description and is expressed in terms of 
master units. 
 
Slash Stripe Angle 
Angle at which the striping line will be placed measured in degrees. Two Slash Stripe Angle 
options are available: Fixed or Variable as shown below. 

 
Fixed 
If the Fixed toggle is selected, the stripes will all be placed parallel to the first stripe (relative to 
the Reference Point), even in non-tangential areas. 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 6-26 Chapter 6 – Drafting Tools 
 

Tip: 
Use the Variable option for 
most ODOT applications 
where the transverse lines 
are in non-tangential areas. 

Variable 
With the Variable option, the angle will be maintained 
between the stripe and the location side element, even 
around curves. 

 
Tolerance 
If the length of a segment of pavement marking is less 
than the Tolerance, the line will not be placed. It will 
only be applied at the ending point to determine where the final piece of marking is 
placed. 
 
Begin Point 
This option identifies the beginning X and Y coordinates of the striping. Note that Begin 
does not have to be on the element (but inside the striping area) as the software 
constructs a perpendicular to the element and utilizes the projection. By utilizing Begin 
(and End), the length of the striping is determined by the designer, not the length of the 
chain. Begin is set by clicking the DP icon, then placing a data point at the desired 
location. The coordinates of the point are shown to the left of the DP button. Note: if 
the beginning area is in a gore, DO NOT snap to the gore itself, as the point must be 
inside the striping area. 
 
Reference / Pivot Point 
Another point is required by the software in order to place the pavement marking, the 
Reference / Pivot Point. This point is projected onto the Side 1 element where the first 
pavement marking line is to be placed. The remaining marking are placed relative to this 
first stripe. 
 
End Point 
The End Point serves the same function as Begin Point, but at the opposite end. 
 
Side 1, Side 2 
Identify the two edges to generate the marking, Side 1 and Side 2. In order to place the 
pavement markings correctly, one must understand the difference between Side 1 and 
Side 2. Side 2 is used when turning the Slash Stripe Angle. The software begins on Side 
2, and draws the marking at the specified angle until it intersects the Side 1 element, 
where the marking stops. It is also desirable to have the total length of the Side 2 
elements longer than the Side 1 elements, however it is not mandatory. Three methods 
are supported to define the elements. It is not necessary to use the same method on 
both sides. 
 

Single Element - When selected, the user is prompted to select the element.  
 

Selection Set - Create the selection set, and then set the toggle to Selection Set. Click Identify 
DGN Element to accept the selection set. If the selected elements are in reference files, this 
method must be utilized as Complex Chains cannot be selected from reference files. 

 
Complex Chain - Select the option, which invokes the MicroStation Create Automatic Complex 
Chain tool to define the elements. 
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An example Separation pavement marking is shown below. 

 
The Reference/Pivot Point is used to determine the orientation of the pavement markings. If 
the cursor is positioned up-station from the Reference/Pivot Point, the markings are drawn as 
shown above. If the cursor is positioned down-station from the Reference/Pivot Point, the 
pavement markings are placed as shown below. 
 

 
 
 
 
 
 
 
 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 6-28 Chapter 6 – Drafting Tools 
 

6.7.3 Chevron Diverge 

The Chevron Diverge option is used to draw pavement markings between two sets of selected 
elements. 
 
When a Transverse Line item is highlighted in the Design and Computation Manager dialog and the 
Chevron Diverge option is selected, the Draw Chevron Diverge dialog shown below is opened. 
 

 
 
The Transverse Line is shown in the Pay Item output field in the Draw Chevron Diverge dialog and can be 
changed at any time by highlighting the desired pavement marking item in the Design and Computation 
Manger and pressing the Item push button. 
 

Distance Between Chevrons 
This key in field is located below the pavement marking description and is expressed in terms of 
master units. 
 
Tolerance 
If the length of a segment of pavement marking is less than the Tolerance, the line will not be 
placed. It will only be applied at the ending point to determine where the final piece of marking 
is placed. 
 
Gore Point (Wide End of Gore) 
Specify the X, Y coordinates for the wide end of the gore area. 
 
 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 6 – Drafting Tools Page 6-29 
 

Breaking Line 
The software utilizes the Gore Point, the intersection of the two sides and the Breaking Line 
point to construct an arc which demarcates the breaking in the diverging chevron.  The Breaking 
Point must be placed between the two sides utilized to draw the chevron. 
 
Diverge Point (Narrow End of Gore) 
Specify the X,Y coordinates at the narrow end of the gore area. 
 
Side 1, Side 2 
Identify the two edges to generate the marking, Side 1 and Side 2. In order to place the 
pavement markings correctly, one must understand the difference between Side 1 and Side 2. 
Side 2 is used when turning the Slash Stripe Angle. The software begins on Side 2, and draws 
the marking at the specified angle until it intersects the Side 1 element, where the marking 
stops. It is also desirable to have the total length of the Side 2 elements longer than the Side 1 
elements, however it is not mandatory. Three methods are supported to define the elements. It 
is not necessary to use the same method on both sides. 
 
Single Element - When selected, the user is prompted to select the element.  

 
Selection Set - Create the selection set, and then set the toggle to Selection Set. Click Identify 
DGN Element to accept the selection set. If the selected elements are in reference files, this 
method must be utilized as Complex Chains cannot be selected from reference files. 

 
Complex Chain - Select the option, which invokes the MicroStation Create Automatic Complex 
Chain tool to define the elements. 
 

An example of the Chevron Diverge is show below. 
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Exercise 6B 

 Place the pavement markings at the locations shown below using the Striping Tool. 
 

Proposed S.R. 185 Centerline 

Begin Station End Station Pavement Marking Offset 

53+00 60+33.98 Centerline Dashed 0 

60+33.98 62+38.98 Centerline Passing Prohibited Right 0 

62+38.98 71+12.80 Centerline Double Solid 0 

71+12.80 74+10.27 R 2 Centerline Passing Prohibited Left 0 

74+10.27 R 2 77+50 R 2 Centerline Dashed 0 

Proposed S.R. 185 Channelizing Line 

Begin Station End Station Pavement Marking Offset 

64+00 66+40 Channelizing Line 12 

Proposed Jameson Road Centerline 

Begin Station End Station Pavement Marking Offset 

12+00 13+65.94 Centerline Passing Prohibited Right 0 

13+65.94 16+27.00 Centerline Double Solid 0 

  
 Use Draw Cell Group by Feature to place the following lane arrows and word “ONLY” on 

proposed S.R. 185 at the locations shown below. 
 

Station D&C Feature Spacing Offset 

66+10 Lane Arrow Right  18 

 Word “ONLY”, 8.0’ 80’ Edge to Edge 18 

 Lane Arrow Right 80’ Edge to Edge 18 

 
 Place a Stop Line on proposed Jameson Road at station 16+27. Which GEOPAK tool is best for 

this application? 
 
 
The completed pavement markings in the intersection area are shown below. 
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7 Existing Ground Profiles 

7.1 Overview 

Existing ground profiles can be extracted directly from a GEOPAK DTM or from triangles plotted in a 3D 
MicroStation design file. 
 
This chapter will cover the following profile commands: 
 

 Creating the Profile Basemap design file 
 

 Extracting ground profiles from DTM files 
 

 Adding profile information to the Working Alignment Definition 
 

 Using the D&C Manager to plot existing ground profiles 
 
GEOPAK provides two tools to extract ground profiles. The Ground Profiles dialog, which is accessed 
through Project Manager, is detailed in section 7.3. The Draw Profiles dialog is detailed in section 7.6. 
 

7.2 Profile Basemap Design File 

Profiles are drawn in their own basemap design file. It is not necessary to draw the profile for each 
alignment in a separate design file, all of the profiles for the entire project, both existing and proposed, 
may be drawn at different locations within in the same design file. 
 
Use the ODOT_Files.mvba application to create the profile basemap. The application is accessed from 
the MicroStation pull-down menu by selecting ODOT > File Management > New Design File. The profile 
basemap is created as shown in the example on the following page. 
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7.3 The Ground Profile Dialog 

Select Existing Ground Profile from the Road Project dialog to access the Create Run dialog as shown on 
the following page. 
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Select Run > New to create a new Run as shown below. Enter an appropriate Name and Description for 
the Run. 

 
Open the Run to access the Ground Profile dialog shown below. 
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When the Ground Profile dialog is opened, information that has been stored in the Working Alignment 
Definition is shared with the Ground Profile dialog. The following information is taken from the Working 
Alignment Definition: 
 

 Job Number – The GEOPAK COGO Database Job Number. 
 

 Operator – The user’s Operator Code. 
 

 Chain – The name of the COGO Chain to extract the ground profile along. 
 

 Tin File – The name of the GEOPAK DTM file to be used to extract the ground profile. 
 
The remaining items on the Ground Profile dialog are explained below: 
 

Profile Name 
Use this field to key in the name of the new profile that will be created. The profile will be 
stored in the COGO data base. 
 
Beg Station 
This field identifies the beginning station of the profile. All profile stationing is relative to the 
baseline defined on the dialog. This setting also serves as the starting point when the designer 
chooses the Increment option, described below.  
 
End Station  
This field identifies the ending station of the profile. 
  
Extraction Method 
GEOPAK provides four methods to extract existing 
ground profiles: Increment, Intersect, Even and 
POT as shown at right. The Intersect and Even 
options should normally be used by ODOT 
personnel as described in further detail below. 
 

Intersect 
The Intersect option is used to extract 
elevations from triangles plotted in a 3D MicroStation design file or from the selected 
TIN file. Every location where the selected Chain crosses a triangle side will be stored as 
a VPI for the existing ground profile. 
 
Even 
The Even method is used to extract elevations from the selected TIN File at the 
increment keyed in by the user. In the example above, a value of 5.00 master units is 
keyed in. This means that GEOPAK will extract the elevations for the profile at every 
station that is divisible by the keyed in value. For example, with a Beg Station value of 
35+90.72, the first VPI for the existing ground profile is taken at station 35+95. The 
second VPI will be at station 36+00, the third at 36+05 etc... 
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Which option should I use, Even or Intersect? 
The Even option is used to thin out the number of vertices that will be stored in the 
existing ground profile. On projects where the proposed centerline is on the existing 
pavement you may choose to use the Even option. 
 
For relocation or new location projects, where the proposed work crosses existing 
ground, the Intersect option is more desirable. Since this option stores a VPI at every 
location that the chain intersects a triangle side a more accurate profile, with more 
vertices, will be generated. 
 

Increment 
The operation of the Increment is identical to the Even option with the exception that 
elevations are extracted incrementally along the chain from the Beg Station. With this 
option set to a value of 5 and a Beg Station of 35+90.72, the first VPI will be extracted at 
station 35+90.72. The second VPI will be at station 35+95.72. The third at 36+00.72... 
For ODOT projects, we recommend using the Even option instead of Increment. 
 
POT 
The POT option will only extract elevations from the DTM at the locations of POT’s on 
the chain. This option is of limited use to ODOT personnel. 

 
 
 
 

Apply 
Select Apply from the GEOPAK Ground Profile dialog box to initiate extraction of the existing 
ground profile. You are given the option to store the commands necessary to generate the 
ground profile in a COGO input file. The dialog box shown below will allow you to accept the 
default name for the input file, or change the name of the input file that will be stored. Select 
OK to initiate extraction of the ground profile 

 

 
As the ground profile elevations are extracted from the DTM, a dialog box is displayed listing the 
stations being extracted as shown below: 
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After GEOPAK has extracted all of the elevations along the chain, the following dialog box is 
displayed: 

 
Select Yes to store the profile in the COGO database (GPK file). After the profile is stored, the 
following dialog box appears: 

 
GEOPAK draws some temporary graphics in the active MicroStation design file at the locations 
where elevations were extracted. These graphics should normally be deleted. Select Yes to 
delete the graphics. Note: this message will appear even if you are processing the profile in a 2D 
design file. 

 
 
When the Ground Profile dialog is closed, select Yes to save the settings of the dialog box in the Project 
Manager run. 
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7.4 Reviewing Profile Information with COGO 

There are several COGO commands that can be used to review stored profiles as shown below. 

 

7.4.1 Profile Utility 

The Profile Utility tool displays all stored profiles, and has options for deleting or printing profiles. 

 
 

 Delete - highlight profile, then click Delete. 
  

 Print - prints the geometric data for the profile name, including stations, elevations 
(including the high point), grades and lengths (back, ahead and total) for VPCs, VPIs and VPTs as 
they relate to each other on the profile. Highlight profile, then click Print. 
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7.4.2 Profile Elevation 

The Profile Elevation tool is used to compute elevations along a profile based on user-defined 
parameters.  

 
Elevation Options 

Station 
Enter a station or series of stations separated by blank spaces. 
  
Even Stations 
Reads the Begin station, and then determines the next even station (divisible by the Even 
Station value). For example, the beginning station is 125+87 and an Even value of 100 is set. The 
display’s first station will then be 126+00, followed by 127+00, 128+00, 129+00, 130+00, etc….  
  
Increment Stations 
Reads the Begin stationing, then adds the Incremental Value with no rounding. For example, the 
beginning station is 125+87 with an Incremental value of 75. The software displays the first 
station as 125+87, followed by 126+62, 127+37, 128+12, 128+87, 129+62, 130+37, 131+12, 
131+87, etc...  

 
When Compute Elevation is selected, the results of the command are displayed in the Coordinate 
Geometry dialog as shown below. 
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7.4.3 Offset Profile 

The Offset Profile command generates and stores a new Target Profile by shifting a Source Profile by 
the Vertical Offset specified by the user. 
 
Vertical offsets can be specified in positive numbers, or negative numbers. By using the value of 0, a 
profile can be copied with no change in station or elevation values. 
 
Select the Source profile and enter a name for the Target Profile. Enter the Begin and End Station, 
Vertical Offset, and then click Add. Continue adding lines for various station ranges. When complete, 
click Create Profile. 

 
 

7.4.4 Restation Profile 

The Restation Profile tool creates a new Target Profile based on a Source Profile and Chain, but uses 
the Begin Station specified in the dialog.  
 
Select the Chain and Source Profile from the lists. Enter the Target Profile (use a new profile name so it 
does not overwrite a current profile). Enter the Begin Station and click Restation Profile. 
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7.5 Adding Profile Information To The Working Alignment 

After storing a new existing ground profile, be sure to add the information about the profile to the 
Working Alignment definition. Select Define from the Road Project dialog to access the Working 
Alignment Definition dialog shown below. 

 
The Profile View item is used to identify the existing and proposed profiles for the working alignment. 
 
Use the Design File option to identify the MicroStation design file where the profile will be plotted. Use 
the File button to browse the directory structure, or key-in the file name manually.  
 
Use the Select buttons to browse the GEOPAK COGO data base (GPK file) for the name of the Existing 
Profile. After you select the Existing Profile, the station range of the profile is automatically displayed in 
the dialog box. 
 
The Location item, shown below, is used to identify the location where the profile will be plotted in the 
MicroStation Design File specified by the Plan View item. 
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Horizontal and Vertical Scales 
The combination of vertical and horizontal scales defines the distortion of elevations (vertical scale) on 
the design profile. Using a Horizontal Scale of 20 and Vertical Scale of 5, the vertical scale is distorted by 
the factor ratio between the horizontal and vertical scales. GEOPAK divides the horizontal scale (20) by 
the vertical scale (5), which produces a distortion factor of 4, i.e. 20/5=4. The resulting horizontal and 
vertical scale distortion is depicted in the figure below. 

 
For ODOT plans, the following values should be typically used for the Horizontal and Vertical Scale: 
 

 20 Scale Plan 50 Scale Plan 100 Scale Plan 200 Scale Plan 

Horizontal Scale 20 50 100 200 

Vertical Scale 5 5 20 40 

 
Station Equation 
Use the Station Equation item to select whether station equations will be plotted with or without a gap 
as shown below. 
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DP Station, DP Elevation 
The DP Station and DP Elevation items are used to define the station and elevation of the location 
defined by DPX and DPY, where the profile origin will be placed. 
 
DPX, DPY 
The DPX and DPY items are used to define the location in the MicroStation Design file where the profile 
origin will be placed. The BY DP button can be used to specify the location in the design file that you 
wish to use at the origin of the profile. Select BY DP and then identify the location graphically by 
identifying a data point in the design file where you wish the profile to be plotted. The coordinates of 
the specified data point are automatically updated in the Profile dialog box. 
 
Profile Cell 
A Profile Cell can be drawn to easily reference the profile in subsequent tasks. Two options are available 
on the Working Alignment Definition dialog: 
 
Draw Cell at X,Y 
Select this option to draw a new Profile Cell in the design file. The DP Station, Elevation, X, and Y fields 
must be populated before the profile cell can be created. A sample profile cell is shown below. 

 
Using ODOT’s level library, the cell is drawn on level GK_Cells. The active color, weight, and text 
parameters are used for the profile cell creation. The Job Number, Chain, DP Station, DP Elevation, 
Horizontal Scale, Vertical Scale, and Gap are all displayed as a part of the profile cell as shown above. 
Identify Cell 
If a profile cell has been previously placed in the design file the Identify Cell option can be used to read 
the Job Number, Chain, DP Station, DP Elevation, Horizontal Scale, Vertical Scale, and Gap parameters 
from the cell. These values are read into the Working Alignment Definition dialog when the cell is 
selected. 
 
Once a profile cell has been placed, it can be utilized in subsequent processes where the DP Station, 
Elevation, X and Y values are needed. Simply press the Identify Cell button, then select and accept the 
cell which will automatically populate the four fields. 
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7.6 Plotting Existing Profiles With D&C Manager  

There are several items in the ODOT D&C Manager database files for plotting existing ground profiles. 
To access these items, select Drafting Standards and then Profiles as shown below. 

 
Several items are configured to plot profiles at a variety of scales as shown above. Select one of the 
profile items from the D&C Manager list box. The Draw Plan and Profile button will now become 
available. Select Draw Plan and Profile to access the Draw Plan & Profile dialog box shown at right 
above. 
 
The top of the dialog box lists the currently selected item and the plotting Operation that is to be 
performed. The Operation is automatically toggled to Profiles as shown above. 
 
The left portion of the dialog box contains a list box with the names of all of the available profiles in the 
COGO database (GPK File). 
 
The right side of the dialog box contains several plotting options. Normally you will plot the profile using 
only the options that have been configured as defaults. 
 
The Label Scale is used to set the size of the text labels that will be plotted with the profile. The value of 
the label scale is not set when an item is selected and must be manually set by the user as shown below. 
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D&C Item Label Scale Value 

1 Scale Existing 1 

10 Scale Existing 10 

20 Scale Existing 20 

40 Scale Existing 40 

50 Scale Existing 50 

100 Scale Existing 100 

200 Scale Existing 200 

 
To plot a profile, simply select the name of the profile from the Select Profile list box on the left of the 
Draw Plan & Profil dialog box.  The Profile dialog box below is opened after a profile name is selected. 

 
 
The top portion of the Profile dialog box displays 
information about the selected profile. 
 
The dialog box items described below are set according to 
the values assigned in the Working Alignment Definition: 
 

 Horizontal Scale  

 Vertical Scale 

 Reference Station 

 Reference Elevation 

 DP X 

 DP Y 
 
The Horizontal Scale and Vertical Scale items are used to 
specify the scale ratio between the horizontal and vertical 
axis of the profile. Note that the actual horizontal distances 
of the profile will not be scaled in the MicroStation design 
file. The distance between station 11+00 and 12+00 will 
always measure 100' regardless of the Horizontal Scale 
specified. Only the Vertical Scale will be distorted. 
 
 
 
The Begin Station and Ending Station items are used to 

specify the station range that you wish to plot in the MicroStation design file. These items are not 
automatically set to the limits of the selected profile. Be sure to review the values before plotting the 
profile. 
 
Strip Grade Increment is used to specify the increment for the existing elevations that will be plotted on 
the horizontal axis of the profile. If this field is left blank no elevations will be plotted. 
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The X and Y items are used to define the location in the MicroStation Design file where the profile origin 
will be placed. 
 
The DP button can be used to specify the location in the design file that you wish to use as the origin of 
the profile. Select DP and then identify the location graphically by identifying a data point in the design 
file where you wish the profile to be plotted. The coordinates of the specified data point are 
automatically updated in the Profile dialog box. 
 
The Reference Station and Reference Elevation items are used to define the station and elevation of 
the profile’s origin at the location defined by X and Y. 
 
A Profile Cell can be placed in the design file using the values defined for the Reference Station, 
Reference Elevation, X, and Y fields by using the Draw Cell at X,Y button. If a profile cell has been 
previously placed in the design file, the values for the Reference Station, Reference Elevation, X, and Y 
fields can be read by using the Identify Cell button and then selecting and accepting the cell. 
 
Select OK to plot the profile. An example of a plotted profile is shown below. 
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7.7 The Draw Profile Dialog 

The Draw Profile tool enables the user to draw several profiles simultaneously from a variety of data 
sources. 
 

 The GEOPAK coordinate geometry database where the vertical alignment is stored.  
 

 The GEOPAK binary TIN file. 
 
In addition, if the source data is a TIN file, the resultant profile may be stored within the coordinate 
geometry database. 

 
Select Applications > Road > Plans Preparation > Draw 
Profiles, or select the Draw Profiles icon from the 
GEOPAK Road tool palette to access the Draw Profile 
dialog shown below. 

 
The Draw Profile dialog is a powerful tool that allows users to perform the following tasks, all from one 
dialog: 
 

 Extract profiles from a GEOPAK TIN Model (Surfaces Tab) 
 

 Store the Profile in COGO (Surfaces Tab) 
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 Draw the profiles using D&C Manager features (COGO Tab) 
 

 Project a profile (defined by a COGO Chain, Profie, or a Survey Chain) onto the Profile Cell of 
another profile (Project Tab). For example, this option can be used to draw a drive pipe from the 
survey data onto the current profile cell. 

 
These functions are detailed on the following pages. 
 
Before a profile can be drawn, it is necessary to place a profile control cell in the design file. Select the 
Dialog Profile Cell Control icon to access the Profile Cell Control dialog as shown below. 

 
The dialog is comprised of two main parts: 

 
Active Chain 
Combo box to select the Active Chain. 
 
MicroStation File, Station, etc. 
This list box gives information about all the Profile Cells that are associated with the Active 
Chain.  

 
Three action icons are located on the right side of the dialog and are detailed below: 
 

 Use this button to place a new Profile Cell. This is the same as the Place Profile Cell 
command described on page 6-15. 
 

 Use this button to activate the selected Profile Cell. 
 

 Use this button to delete the selected Profile Cell. 
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After a profile cell has been placed in the design file for the Active Chain, the Place Profile Cell dialog will 
contain the information for the profile cell as shown above. 
 
The Surfaces Tab 

 
The Surfaces tab is used to define the source data for drawing profiles. Multiple surfaces from a variety 
of sources can be drawn in a single processing. A profile cell must be placed in the active design file for 
the selected Chain before the options on the Surfaces tab of the Draw Profile dialog become available 
 
The Details portion of the dialog has the following options: 
 

TIN File 
Identify the TIN model to be used to extract the profile. 
 
Method 
The Method options are used to determine how the TIN File is read to extract profile elevations. 
The Triangles method is recommended. 
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Display Settings 
The Display Settings item is used to set the symbology for the profile. Two options are 
supported. 
 
By Level Symbology 

 
Use this option to define the symbology of the profile by selecting the Level, Color, Style, and 
Weight. Double-click the symbology box to access the GEOPAK Set Feature dialog shown below. 

 
By Feature 

 
Use this option to define the profile symbology by selecting a feature from the Design and 
Computation Manager database. The Browse Feature icon is used to select the item. 
 
Filter Tolerances 
Both Horizontal and Variance filter tolerances are considered together for each pair of profile 
segments. The middle point is deleted if both segment lengths are less than the Horizontal filter 
tolerance while the projected distance between the mid-point and the chord between the two 
end points is less than the Variance tolerance. 
 
Station Limits 
When the Chain field at the top of the dialog is populated, its beginning and ending station are 
displayed in the Station Limits group box. The defaults may be utilized if the entire profile is 
drawn. Manually entering stations or clicking Set Station and graphically identifying a location is 
supported. 
 
Offsets 
Vertical or Horizontal Offsets may be specified in terms of master units (i.e., feet or meters). 
The Horizontal offset is the distance offset from the Chain. Once the horizontal location for the 
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profile is determined, the data source is utilized to determine the profile. Any Vertical offset is 
applied after the profile is generated from the source data. 
 
Void 
The Void Plot Parameters specify the element symbology of the existing ground lines being 
generated which are located within a void in the model. 
 
Each surface to be drawn must be added to the list box. This is accomplished via the buttons on 
the right side of the dialog. When a line is added to the list box, the profile is drawn. To add an 
item to the list box, simply select the source data type and data, and then populate the Display 
Settings, Filter Tolerances, Station Limits, and Offsets. Then click Add Surface Settings as 
shown below. Note: clicking on the draw toggle in the list box deletes or redraws the profile. 

 

 Modify a line by highlighting the desired line in the list box, make the desired 
changes in the fields directly below the list box, and then click the Modify Line icon. 
 

 To delete a line from the list box, simply highlight the line to be deleted and click 
the Remove Surface icon. 
 

 After the profile is drawn, click the Store Surface in COGO icon to store the profile 
in COGO. The Store Profile dialog shown below is opened. 

 
The profile may be stored, or just the input file may be created. If an input file is created, the 
Operator Code and File Name are required. If the dialog is invoked while in a 3D file, the user 
may toggle on the option to create a 3D profile string. 
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The COGO Tab 

 
Multiple profiles may be drawn from COGO by populating the tab, then using the edit buttons on the 
right side of the list box. 

 

 To add to the list box, simply select the source data type and data, and then populate the 
Details, Display Settings, Filter Tolerances, and Offsets. Then click the Add COGO Profile 
Settings icon to the right. 
 

 Modify a line by highlighting the desired line in the list box, make the desired changes in the 
fields directly below the list box, and then click the Modify COGO Profile Settings icon. 
 

 To delete a line from the list box, simply highlight the line to be deleted and click the 
Remove COGO Profile Settings icon. 

  
Station Limits and Vertical Offset are identical to the Surfaces tab. 
 
To define the symbology of the profile(s), the user may specify the parameters via the By Symbology 
option, or By Feature. When the By Feature option is selected, the user must identify an Item from the 
Design and Computation Manager. Other options which are found on the Draw Plan and Profile dialog 
within Design and Computation Manager are also supported within the Draw Profile dialog, i.e., General 
Labels, VPI, VPC, etc. Simply highlight the desired option in the list box, and then set the toggles and 
fields accordingly. 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 7-22 Chapter 7 – Existing Ground Profiles  
 

The Projection Tab 
 
The Projection tab can be used when the chain / profile to be drawn is different than the chain / profile 
used to create the profile cell. When the Projection tab is selected, the dialog dynamically changes, as 
shown on below. 

 
Each projected profile to be drawn must be added to the list box. This is accomplished via the icons on 
the right side of the dialog. 
 

 To add to the list box, simply select the Type, Chain, Profile, and Vertical Offset, then 
populate the Display Settings, Filter Tolerances and Extraction from TIN, if desired. Then click 
the Add Line icon to the right. 
 

 Modify a line by highlighting the desired line in the list box, make the desired changes in the 
fields directly below the list box, and then click the Modify Line icon. 
 

 To delete a line from the list box, simply highlight the line to be deleted and click the Delete 
Line icon. 

 
When a line is added to the list box, the profile is drawn. Note: clicking on the draw toggle in the list box 
deletes or redraws the profile. 
 
The following fields are defined in the Details group box. 
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Type 
A COGO chain or Survey chain may be selected. 
 
Chain/Survey Chain 
After the desired Type has been selected, the Chains or Survey Chains in the currently selected 
GPK file are listed for selection. 
  
Profile 
(COGO Chain option only) Select the profile to be used.  
  
Vertical Offset 
Key in the Vertical Offset to be applied after the profile is generated from the source data. 
 
Display Settings 
To define the symbology of the projected profile(s), the user may specify the parameters via the 
By Symbology option, or By Feature. When the By Feature option is selected, the user must 
identify an Item from the Design and Computation Manager. 
 
The example below shows the profile of a drive pipe defined by the Survey Chain “P1” projected 
onto the profile of existing State Route 185. 
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7.8 Profile Grid 

The ODOT Standard D&C Manager Database ODOT.ddb contains an item to plot a profile grid on profiles 
previously plotted using D&C Manager. This item is configured to run the ODOT Three Port Criteria (3PC) 
file PROFILE_GRID.3PC when the user double-clicks the item in the D&C Manager dialog. 

 
3PC files are normally saved in a standard directory. In order for the D&C Manager to process a 3PC file, 
we need to tell GEOPAK where to find the files. This is accomplished by the use of a Configuration 
Variable. This Configuration Variable has already been defined as follows for ODOT personnel: 
 

GPK_DC_3PCDIR = i:/ODOTstd/V8istd/geopak/road/ddb/3pc/ 
 
The Profile Grid 3PC application requires a GEOPAK Profile cell in order to draw the profile grid. 
 
When the user activates the Profile Grid 3PC application by double-clicking on the Profile Grid item in 
D&C Manager, the following prompt is displayed: 

 
Key in the Job Number for the COGO database containing the profile. Select the OK button to proceed. 
Select Cancel to exit. 
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The user is prompted to key in the Chain Name that was used to extract the profile as shown below. 

 
Key in the Chain Name of the COGO chain that was used to extract the profile. Select the OK button to 
proceed. Select Cancel to exit. 
 
The 3PC application will draw the profile grid starting from the reference DP Elevation of the profile cell. 
The upper limit of the profile grid is not read from the profile cell and must be keyed in by the user. The 
application prompts the user for the Maximum Grid Elevation as shown below. 

 
Key in the Maximum Grid Elevation (typically this will be a value that is evenly divisible by the vertical 
scale of the profile). Select the OK button to proceed. Select Cancel to exit. 
 
Next the user is prompted as to whether or not they want the 3PC application to draw Minor grid lines 
(Major grid lines are always drawn). 

 
Select Yes to draw both the major and minor grid lines. Select No to draw the major grid lines only. 
Select the OK button to proceed. Select Cancel to exit 
 
The grid lines are drawn using the same symbology as the grid provided on a Standard ODOT plan and 
profile sheet as detailed below: 
 

 Level Weight Color Style 

Major Gird Lines SH_Major_Grid_Line 1 44 0 

Minor Grid Lines SH_Minor_Grid_Line 0 40 0 

 
The major and minor grid lines are placed as separate graphic groups. 
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The 3PC application will search the active MicroStation design file for a profile cell matching the Job 
Number and Chain Name keyed in by the user. An example of a profile cell is shown below. 
 

 
 
The following information is read from the profile cell when the Profile Grid item is processed: 
  

 DP X, Y Coordinate (read from the Profile Cell origin.) 
 

 DP Reference Station (35+90.72 in the example above.) 
 

 DP Reference Elevation (950 in the example above.) 
 

 Horizontal Scale (20 in the example above.) 
 

 Vertical Scale (5 in the example above.) 
 
If the 3PC Application cannot find a profile cell in the active MicroStation design file matching the Job 
Number and Chain Name that was keyed in by the user, the following error message is displayed: 

 
An example of the profile grid, without the minor grid lines is shown below. 
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The profile grid is optional and is not normally used since the ODOT sheet cells contain a gridded profile 
area. The application is typically only used in cases where the user wishes to plot a profile, with the grid, 
for review, during the design process. 
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Exercise 7 

 Extract an existing ground profile along the proposed S.R. 185 chain. 
 

o Using the GEOPAK COGO Element Names defined in the ODOT CADD Engineering 
Standards Manual, what should you name this profile? __________ 

 
o Which method: Intersect, Even or Increment should you use and why? 

 
 

 Extract an existing ground profile along proposed Jameson Road. 
 

o Using the ODOT Guideline for GEOPAK Element Names, what should you name this 
profile? ____________________ 

 
o Which method: Intersect, Even or Increment should you use and why? 

 
 Use the ODOT_Files.exe application to create a new design file to contain the ground profile 

graphics for S.R. 185. 
 

o What is the name of the profile design file? 
 

o Which sub-directory is this file stored in? 
 
The profile for Jameson Road can be plotted in the same design file as the profile for S.R. 185, or a new 
design file can be created to contain the graphics for the Jameson Road profile. 
 

o If you elect to create a new design file for the Jameson Road ground profile, what is the 
name of the design file? 

 
o Which sub-directory is this file stored in? 

 
 

 Use the D&C Manager to plot the existing profiles for S.R. 185 and Jameson Road at 20 scale. Be 
sure to place a profile cell for each profile. If you created separate design files, be sure to use 
the appropriate file for each profile 

 
 

 Update the Working Alignment definition for each road to include the existing ground profile 
information. 

 
 

 Optional: Using the D&C Manager, plot a profile grid for both S.R. 185 and Jameson Road. After 
plotting the grid, be sure to turn the levels off or delete the grid since it is not needed for the 
plan and profile sheets. 
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8 Proposed Vertical Alignments 

8.1 The Vertical Alignment Generator 

The Vertical Alignment Generator is used to graphically create and modify proposed design profiles or 
existing ground profiles. Profile generation and modification is achieved under the control of an 
interactive dialog box and dynamic graphical manipulation. The designer can define and manipulate 
profile geometry by specifying grade, design speed, k-value, elevation, and station values. Alternately, 
the designer can graphically manipulate these same parameters dynamically. 
 
The Vertical Alignment Generator can be accessed by selecting Vertical Alignment from the Road 
Project dialog as shown below. 

 
Or by selecting VPI Based Vertical Alignment Design Tools from the GEOPAK Road Tools palette, as 
shown below. 
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When the Vertical Alignment Generator is 
activated, the Settings dialog shown below is 
opened. 
 

 
This dialog is used to initialize the design process and 
define the location in the MicroStation file where the 
profile is to be designed. 
 
 
To initialize the profile process, each field on the Settings dialog must be defined. If you are using the 
GEOPAK Project Manager, all of the fields in the Settings dialog box will be automatically filled in if you 
have previously defined the profile information in the Working Alignment definition. 
 
The individual fields on the Settings dialog are below. 
 

Job Number 
This alphanumeric text string defines the coordinate geometry data base where baseline and 
profile data are retrieved and stored. 
 
Operator Code 
A maximum of two characters, this is the code used to identify the user for a COGO session. 
 
PGL Chain 
Identify the name of the horizontal chain that serves as the profile grade line (PGL) and is to be 
used as a stationing reference. 
 
Horizontal and Vertical Scales 
The combination of vertical and horizontal scales defines the distortion of elevations (vertical 
scale) on the design profile. See section 8.3 on page 8-4 for an explanation on the Horizontal 
and Vertical Scales. 
 
 
 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 8 – Proposed Vertical Alignments Page 8-3 
 

 
Reference Station 
In the MicroStation design file, the station that is defined in the Reference Station field is 
assigned the coordinate location specified in the X and Y fields.  
 
Reference Elevation 
In a MicroStation graphical design file, the elevation that is defined in the Reference Elevation 
field is assigned the coordinate location specified in the X and Y fields. 
 
X, Y 
These fields correspond to the Reference Station and the Reference Elevation information 
defined above. The reference X and Y coordinate location defines where the profile origin is to 
be located in the MicroStation file. The actual location of the reference data point is depicted in 
the X, Y fields. These values can be keyed in. However, it is much easier to use the DP button. 
Upon selecting the DP button, the user is prompted for a data point. The coordinate values of 
the selected data point are then depicted in the X and Y fields. If the proposed profile is being 
superimposed onto an existing ground profile, the X and Y location as well as the Reference 
Station and Reference Elevation should all correspond to the same parameters and coordinate 
location used when originally drawing the existing ground profile with the Plan and Profile 
dialog. 
 
Profile Cell 
A Profile Cell can be placed in the design file at the values defined for the DP Station, Elevation, 
X, and Y fields by using the Draw Cell at X,Y button. If a profile cell has been previously placed in 
the design file, the values for the DP Station, Elevation, X, and Y fields can be read by using the 
Identify Cell button and then selecting and accepting the cell. 

 
After pressing the OK push button on the Settings dialog, the Profile Generator dialog shown below 
appears. 

 
The operation of the GEOPAK Profile Generator will be discussed in the following sections. 
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8.2 File Operations 

The Profile Generator dialog’s File menu provides the following functions:  

 
Each option is described below: 

8.2.1 Preferences 

The Preferences dialog box is activated by selecting File > Preferences from the Profile Generator dialog. 
In short, this dialog permits the specification of rounding parameters. 
 
The increments defined on this dialog primarily affect the 
dynamic operations applied during the course of profile design. 
For example, suppose you dynamically manipulate the VPI. 
Simultaneous with the movement of your cursor, the back and 
forward grades are stretching (i.e., rubber banding) while the 
length of the vertical curve is being continuously adjusted to 
maintain the selected design speed. At all times and with every 
slight shift in your cursor, the back and forward grades are 
rounded to the nearest 0.1 percent, the elevation of the VPI is 
positioned to the nearest 0.01', the station of the VPI is rounded 
to the nearest 0.01' and the length of the back grade, the forward 
grade and the vertical curve is rounded to the nearest 0.1'. 
 
The Hold Vertical Curve toggle and the Maintain VC K Value / Maintain VC Length option button dictate 
vertical curve dynamics. If the Hold Vertical Curve toggle is active and if the option button is set to 
Maintain VC K Value, then dynamic operations lock the K value. This in essence allows the user to slide 
the grades along a continuous parabola representing the vertical curve. If the Hold Vertical Curve toggle 
is active and if the option button is set to Maintain VC Length, then dynamic operations create a similar 
effect in that the vertical curve length is held constant. 
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Window Center Current VPI  
If the dialog is adjusted to a current VPI that is outside the view and the Window Center Current VPI is 
active, then the view is automatically adjusted via a Window Center to that VPI. 
 
The Load Profile function is used to retrieve a profile from the coordinate geometry data base for 
modification. 
 
Once the design of the profile is complete, the profile can be stored into the coordinate geometry data 
base with either the Save or Save As... functions. The Save option stores the adjusted profile under the 
same name at which it was loaded. The Save As... function permits the user to store the profile under 
another name. 
 

8.2.2 Profile Cell Settings 

Selecting File > Settings from the Profile Generator dialog will open the Settings dialog shown at right. 
 
This is the same dialog that is opened when the Profile Generator dialog is initially activated. This option 
is provided to allow users to alter these settings without restarting the profile command.  
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8.2.3 K-Value Table 

The K Values dialog defines the stopping sight distance K-values for crest and sag conditions at various 
user specified design speeds. This dialog, shown below, is invoked by selecting File > K Value Table from 
the Profile Generator dialog. 

 
GEOPAK allows the user to save and retrieve customized K Value tables. The following K-Value table is 
active when using the ODOT configuration: 
 

I:\ODOTstd\V8istd\geopak\road\kvalues\ODOT.kvl 
 
The current K Value table name is displayed in the title bar of the Profile Generator dialog as shown 
below. 
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8.2.4 Load Profile 

To load a previously defined profile for editing, select File > Load Profile from the GEOPAK Profile 
Generator dialog. The Load Profile dialog is opened as shown below. 

 
Select the profile name and confirm the selection by selecting the OK button. GEOPAK will access the 
previously defined profile, display it on the screen, and adjust the Profile Generator dialog to display the 
parameters for the profile: grades, elevations, stations, lengths of vertical curves, speeds, etc.   
 
The previously defined profile can be either an existing ground profile or a proposed design profile. 
Typically, an existing ground profile is loaded if there is an error that needs to be corrected, such as a 
spike. The existing profile can be graphically modified to correct the error and then be saved back into 
the coordinate geometry data base. 

8.2.5 Save Profile, Save Profile As 

Once the design of the profile is complete, the profile can be stored into the coordinate geometry data 
base with either the Save Profile or Save Profile As functions. 
 
The Save Profile option stores the adjusted profile under the same name at which it was loaded. 
 
 The Save Profile As function permits the user to store the profile under another name. 
 
The Save Profile As option (and the Save Profile option when storing the profile for the first time) 
prompts for an Input File name, wherein the generated COGO profile commands are written. 

8.2.6 Clear Profile 

The Clear function erases the working profile from the MicroStation graphics and erases all profile 
information from the Profile Generator dialog box. This does not clear the profile from COGO if it has 
been saved. 

8.2.7 Draw Profile 

During the profile design process, temporary graphics are displayed representing the profile. The Draw 
function is used to draw the profile graphics permanently into the MicroStation file. The Design and 
Computation Manager should normally be used to plot and annotate profiles. 
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8.3 The Tools Menu 

The Profile Generator dialog’s Tools menu provides the following functions:  

 
Each of these functions is described below. 
 
 

8.3.1 Issue Data Point 

From the GEOPAK Profile Generator dialog box, select Tools > Issue Data Point to access the dialog 
shown below. 

 
The Issue Data Point tool permits the user to type in stations and elevations and issue a MicroStation 
data point that can be part of a place line, place cell or any other common MicroStation operation. For 
example, a line endpoint can be placed at a location on the profile corresponding to a specific station 
and elevation. 
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8.3.2 Critical Points 

Vertical curves can also be defined in terms of one or two critical points. The station and elevations for 
the critical points can be either typed in or defined via a data point in the MicroStation file. If 
mathematically solvable, the vertical curve is drawn and the speed option button adjusted to the 
appropriate design speed. 
 
Select Tools > Critical Points from the Profile Generator dialog to access the Critical Points dialog shown 
below. 

 
The Station and Elevation for the critical points can be either typed in manually or defined via a data 
point in the MicroStation file by use of the DP buttons. If mathematically possible, the vertical curve will 
be drawn and the Speed option button adjusted to the appropriate design speed. 
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8.3.3 Best Fit 

Three Best Fit tools are supported within the Profile Generator: 

 
Best Fit Line  
The Best Fit Line tool fits a line between the candidate elements. The resultant line data is displayed in 
the dialog and the line is drawn onto the profile cell. 

 
Best Fit Parabola  
The Best Fit Parabola tool fits a vertical curve between the candidate elements. The resultant curve data 
is displayed in the dialog and the curve is drawn onto the profile cell. 
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Best Fit Profile  
The Best Fit Profile tool fits a profile (comprised of tangent lines and vertical curves) between the 
candidate elements based on the constraints in the design parameters. As there is no symbology option, 
the active symbology is used.  

 
When you do a best fit profile there is a unique mathematical solution. You can further restrict or 
constrain the conditions to find a different solution by using the Envelope Distances. For example, By 
setting a lower and upper envelope value of 5, the fitted profile is expected to stay within -5 and +5 of 
the original ground. To create a newly fitted profile that does not cut into ground, use a lower envelope 
of 0 and upper envelope of any positive number, i.e., 3. The new fitted profile will be between 0 and 3 
above the ground (inside of that range). 
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8.4 Storing VPI’s 

The GEOPAK Vertical Alignment Generator offers a large number of tools for creating a new profile. The 
creation of a new profile must always begin by placing the first VPI. This step is followed by drawing the 
first grade. At this point in the process, subsequent VPI's and grades can be specified by precision input 
or placed dynamically. Vertical curves can be drawn between any successive pairs of back and ahead 
grades. 
 
The following options are available to define a VPI: 
 

 Precision input: Simply type in the station and elevation of the VPI. 
 

 The VPI can be placed dynamically: Select the Dynamic push button. The cursor turns into a 
circle representing the VPI point. As you move the cursor in the design file, the current station 
and elevation is continuously updated on the dialog. The VPI will be set upon selection of a Data 
Point in the design file. 

 
Once the initial VPI is located, the Profile Generator dialog appears as shown below. 

 
The Station and Elevation for the first VPI appear along with two push buttons labeled Insert Before and 
Insert After.  If you wish to create a VPI before the current the VPI, then select the Insert Before push 
button to the left of the VPI display. Press the Insert After push button to the right of the VPI display to 
create a VPI up station from the current VPI. 
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After selecting the Insert After push button to the right of the VPI display, the dialog appears as shown 
below. 

 
The Station and Elevation values for the first VPI now appear on the left of the dialog box. The second 
VPI is displayed in the center of the dialog box as shown above. 

 

The designer has a wide range of options to choose from in defining the second VPI. The Back Grade 
and Length could be defined in relation to the previous VPI or the length and slope of the grade line. 

Individual station, elevation, grade and length parameters could be defined via precision input, dynamic 
manipulation or some combination of both. The following will review some of the available options: 

 
 The grade can be defined with precision input by defining any two of the following fields: 1) VPI 

Station, 2) VPI Elevation, 3) Back Grade and 4) Length (length). 

 

 Type in the station for the VPI and select the Dynamic push button. The slope of the grade line 

and the current elevation can be dynamically manipulated with the cursor while the length of the 
grade and the downstream station will be fixed. 

 
 Type in the elevation for the VPI and select the Dynamic push button. The slope of the grade 

line, the length of the grade line and the current station can be dynamically manipulated along a 

fixed elevation. 

 
 Type in the slope of the grade line and select the Dynamic push button. Cursor manipulations 

will adjust the length of the grade line along a fixed slope. 

 
 Define the grade completely with dynamics. First, select the Dynamic push button. A line 

appears connecting the current VPI and the cursor. As you move the cursor in the design file, the 

current VPI Station and Elevation is continuously updated on the dialog along with the Back 
Grade slope and Length (length). The VPI location will be set upon selection of a data point. 

 

The definition of subsequent back and ahead grades is essentially a repetition of the operations described 
above. You have the option to insert new grade lines from the beginning and the end of the current set 

of grade lines or a VPI could be inserted between two existing VPI's. Inserting a VPI between existing 
VPI's will split a grade line into two components. 
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8.5 Defining Vertical Curves 

Given back and ahead grades, vertical curves can be defined by simply setting the Speed option button 
to the desired design speed. For each Speed setting, GEOPAK references the K-value table and draws a 
vertical curve at the maximum K-value settings applicable to the selected speed. 

 
A wide variety of operations are available for dynamically adjusting vertical curves, VPI's and grade lines. 
Full dynamics can be applied or some appropriate combination of back grade, ahead grade, station and 
elevation can be "locked." 
 
The locking of profile parameters is controlled by option buttons located adjacent to each parameter 
field. As can be seen on the dialog above, this option button can be adjusted to three settings: OFF, INC 
for increment, and LCK for locked. These three settings are defined below: 
 
OFF: Full unencumbered dynamics are available. GEOPAK will attempt to round the associated 
parameter to the increment defined via the Increment dialog but there is no guarantee. If a complicated 
dynamics operation makes it mathematically impossible to satisfy all increment definitions, some 
rounding variations could occur. Of course, reasonable rounding variables will mitigate if not eliminate 
any rounding conflicts. 
 
INC: Ensures that the designated profile parameter will be rounded in accordance with the increment 
defined on the Vertical Alignment Preferences dialog. 
 
LCK: Forces all dynamic operations to maintain the designated profile parameter. This "locked" mode is 
automatically established when the associated profile parameter is typed in. Only one profile parameter 
one can be "locked" (LCK) at any time. 
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8.6 Profile Navigation 

The GEOPAK Profile Generator provides three options to navigate the VPI’s of a profile. The “current” 
VPI is always displayed in the center of the dialog box.  

 
In the dialog above, VPI 2 is the current VPI. In the MicroStation design file, the location of VPI 2 is 
designated by a circle at the VPI location. 
 
There are two methods by which the user can move to either the previous VPI (VPI 1) or the next VPI 
(VPI 3). First, the scroll bar at the bottom of the Profile Generator dialog can be used to scroll through 
the VPI’s by selecting the “handle” and sliding it forward or backward. 

 
The second method is to select the Prev VPI or the Next VPI buttons located on the left and right side of 
the Profile Generator dialog. 
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8.7 Reviewing Proposed Profiles in COGO 

The COGO tools for Profiles are summarized in Chapter 7. The Print Profile command, accessed from the 
Profile Utility dialog, includes vertical curve information when a proposed profile is described. An 
example is shown below. 
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8.8 Plotting Proposed Profiles with D&C Manager 

There are several items in the ODOT D&C Manager database, ODOT.ddb, for plotting proposed profiles. 
To access them, select Drafting Standards > Profiles as shown at left below. 
 
Select the desired item from the D&C Manager list box. The Draw Plan and Profile button will now 
become available. Select Draw Plan and Profile to access the GEOPAK Plan and Profile Draw dialog 
shown at right below. 

 
The procedure to plot the proposed profile is similar to plotting an existing ground profile as described 
in Chapter 7 of this guide. 
 
The top of the Draw Plan & Profile dialog box lists the currently selected item and the plotting Operation 
that is to be performed. The Operation is automatically toggled to Profiles as shown above. 
 
The left portion of the dialog box contains a list box with the names of all of the available profiles in the 
COGO database (GPK File). 
 
The right side of the dialog box contains several plotting options. Normally you will plot the profile using 
only the options that have been configured as defaults. 
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The Label Scale is used to set the size of the text labels that will be plotted with the profile. The value of 
the label scale is not set when an item is selected and must be manually set by the user as shown below. 
 

D&C Item Label Scale Value 

1 Scale Proposed 1 

10 Scale Proposed 10 

20 Scale Proposed 20 

40 Scale Proposed 40 

50 Scale Proposed 50 

100 Scale Proposed 100 

200 Scale Proposed 200 

 
To plot a profile, simply select the name of the profile from the Select Profile list box on the left of the 
GEOPAK Plan & Profile Draw dialog box.  The Profile dialog box below is opened after a profile name is 
selected. 

 
The top portion of the Profile dialog box displays 
information about the selected profile. 
 
The dialog box items described below are set according to 
the values assigned in the Working Alignment Definition: 
 

 Horizontal Scale  

 Vertical Scale 

 Reference Station 

 Reference Elevation 

 X 

 Y 
 
The Horizontal Scale and Vertical Scale items are used to 
specify the scale ratio between the horizontal and vertical 
axis of the profile. Note that the actual horizontal distances 
of the profile will not be scaled in the MicroStation design 
file. The distance between station 11+00 and 12+00 will 
always measure 100' regardless of the Horizontal Scale 
specified. Only the Vertical Scale will be distorted. 
 
 
 
 
 

The Begin Station and Ending Station items are used to specify the station range that you wish to plot in 
the MicroStation design file. These items are not automatically set to the limits of the selected profile. 
Be sure to review the values before plotting the profile. 
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Strip Grade Increment is used to specify the increment for the existing elevations that will be plotted on 
the horizontal axis of the profile. If this field is left blank no elevations will be plotted. 
 
The X and Y items are used to define the location in the MicroStation Design file where the profile origin 
will be placed. 
 
The DP button can be used to specify the location in the design file that you wish to use as the origin of 
the profile. Select DP and then identify the location graphically by identifying a data point in the design 
file where you wish the profile to be plotted. The coordinates of the specified data point are 
automatically updated in the Profile dialog box. 
 
The Reference Station and Reference Elevation items are used to define the station and elevation of 
the profile’s origin at the location defined by X and Y. 
 
A Profile Cell can be placed in the design file using the values defined for the Reference Station, 
Reference Elevation, X, and Y fields by using the Draw Cell at X,Y button. If a profile cell has been 
previously placed in the design file, the values for the Reference Station, Reference Elevation, X, and Y 
fields can be read by using the Identify Cell button and then selecting and accepting the cell. 
 
Select OK to plot the profile. An example of a plotted profile is shown below. 

 
 
Note: The ODOT Design and Computation Manager database has been configured to yield the best 
results possible for ODOT construction plans using the available parameters for profile display and 
annotation. It may be necessary for the designer to edit the labels in order to achieve the desired 
results. This is especially true if you toggle on other labeling options such as the K-Value or the Stopping 
Sight Distance as GEOPAK does not offer any capabilities to customize the location of where these 
values are plotted with relation to the other annotations. 
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Exercise 8A – S.R. 185 Profile 

1. Define and store a proposed profile for S.R. 185 with the following conditions: 
 

a. The proposed profile will start at Sta. 53+00 by tying into the existing pavement. What is the 
existing pavement elevation at Sta. 53+00? ____________ 

b. The proposed profile should be tie back into the existing pavement at Sta. 77+50 R 2. What 
is the elevation of the existing pavement at Sta. 77+50 R 2? ____________ 

 
Using the elevations obtained above, and the information below, store the proposed profile for S.R. 185. 
 

 
Hint: When creating Vertical Curves it is a good idea to create all VPI’s first then adjust Vertical Curve 
Lengths. 

VPI Vertical Curve Length 

2 350’ 

3 550’ 

4 350’ 

 
c. When you have completed the profile, use the Save Profile As option to save the profile. 

Using ODOT’s GEOPAK Guidelines, what should you name the profile? ___________ 
 

d. What is the Station and Elevation of the low point on the vertical curve with VPI #2? 
Station = ____________________ 
Elevation = __________________ 

 
Hint: Use the COGO profile commands to print the profile information. 

 
e. What is the Station and Elevation of the high point on the vertical curve with VPI #3?                  

Station = ____________________ 
Elevation = __________________ 

 
2. Update the Working Alignment Definition for S.R. 185 to include the name of the proposed vertical 

alignment. 
 
3. Plot the proposed profile for S.R. 185 using the Design and Computation Manager. 
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Exercise 8B - Jameson Road Profile (if time permits) 

1. Define and store a proposed profile for Jameson Road with the following conditions (set the working 
alignment to Jameson Road): 

 
a. What is the Station on the chain CLPS185 at the intersection with chain CPLJAME? 

Station = _______________ 
b. What is the Station on the chain CLPJAME at the intersection with CLPS185?                   

Station = _______________ 
c. What is the Elevation on the profile PS185P at the Station from (a)? _____________ 
d. The proposed profile will start at Sta. 12+00 by tying into the existing pavement.  What is 

the existing elevation at Sta. 12+00 on profile XJAMEP? _______________ 
 

 
VPI Vertical Curve Length 

2 100’ 

3 10’ 

4 No Curve 

 
e. When you have completed the profile, use the Save As… option to save the profile. Using 

ODOT’s GEOPAK Guidelines, what should you name the profile? ___________ 
 
Hints: Start at the intersection of S.R. 185 and Jameson Road and work backwards. With the Working 
Alignment set to Jameson Road, open the Vertical Alignment Generator and key-in the data for VPI #5. 
When this is accomplished, select the Insert Before button. The first VPI now becomes VPI 2 and the 
cursor is now located at VPI 1 (which will end up as VPI#4). Enter the Length and Grade between VPI #4 
and VPI #5 as shown above in the dialog between VPI 1 and VPI 2. After following the preceding step, 
select the Insert Before button. The VPI’s will now be renumbered and the current cursor will be VPI 1 
which will now be used for VPI#3 shown above. Repeat this procedure until all VPI’s are entered. The 
VPI’s should match the graphic above when completed. 
 
2. Update the Working Alignment Definition for Jameson Road to include the name of the proposed 

profile. 
 
3. Plot the proposed profile for Jameson Road using the Design and Computation Manager. 
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8.9 Component Based Vertical Alignment Design Tools 

The Component Based Vertical Alignment tools provide the user with tools to place, modify and delete 
profile components individually. Tools include the placement of tangent lines and a variety of vertical 
curves. Vertical alignment components interact with each other to automatically trim vertical curves and 
connect various elements. Additional tools are available to modify copy and rotate components. The 
user also has the option to store completed profiles in the coordinate geometry database. 
 
The Component Based Vertical Alignment tools can be accessed by selecting Applications > Road > 
Geometry > Layout Profiles (Component Based) from the MicroStation pull down menu, or from the 
GEOPAK Road tool palette as shown below. 

 
Once selected, the Component Based 
Vertical Alignment Design tool palette, 
shown below, opens. 
 

 
 
 
 
 
 
 
 

 
 
This tool requires the Active Chain Control command to be opened with an active chain and an active 
profile defined. See Chapter 6 for information on the Active Chain Control command. If the Active Chain 
Control command is not open when one of the Component Based Vertical Alignment Design Tools is 
selected, the following Information dialog will appear. 

 
Operation of the individual Component Vertical Alignment tools is very thoroughly documented in the 
GEOPAK online help. Select Applications > Road > Help to access the online help. 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 8 – Proposed Vertical Alignments Page 8-23 
 

Place Vertical Alignment Lines 
The Place Vertical Alignment Lines tool palette, the first tool of the Component Based Vertical Alignment 
Design Tools palette, is shown below. 

 
Three commands are available as described below: 
 
Create a Profile Line by Two Points 
This tool enables the user to place a profile line by defining two points. 

 
Create a Profile Line Tangent to One Element 
This tool enables the user to place a profile line tangent to one element. 
 
Create a Profile Line Tangent to Two Elements 
This tool enables the user to create a profile or Vertical Alignment line tangent to two elements. 

 
 
Place Vertical Alignment Curves 
 
The Place Vertical Alignment Curves tool palette, the second tool of the Component Based Vertical 
Alignment Design Tools palette, is shown below. 

 
Five commands are available as described below: 
 
Place a Vertical Curve by Three Points 
This tool enables the user to place a profile curve by three points. 

 
Place a Vertical Curve by High Point 
This tool enables the user to place a vertical curve by defining a high point (or in the case of a 
sag curve, the low point). 
 
Place a Vertical Curve Tangent to One Element and Through One Point 
This tool enables the user to place a profile curve tangent to one element (line or curve) and 
passing through a used-defined point. 
 
Place a Vertical Curve Tangent to One Element Given High Point 
This tool enables the user to place a profile curve tangent to one element and pass it through a 
used-defined high or low point. 

 
Place a Vertical Curve Tangent to Two Elements 
This tool enables the user to place a profile curve tangent to two elements. 
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Manipulate Vertical Alignment Elements 
 
The Manipulate Vertical Alignment Elements tool palette, the third tool of the Component Based Vertical 
Alignment Design Tools palette is shown below. 

 
Three commands are available as described below: 
 
Move a Profile View Element 
The Move a Profile View Element command enables the user to move an 

element or to make copies. Note the moved or copied element must remain 
within the confines of the profile cell and its associated delta top and bottom values. 
 
Rotate a Profile View Element 
The Rotate Plan View Element rotates the selected tangent about a user-defined point. A 
selection set may also be defined when multiple elements need to be rotated. Note: This 
command is not supported for vertical curves. 
 
Extend a Profile View Element 
The Extend a Profile View Element tool can extend or shorten both tangent and vertical curve 
components. 

 
Profile Tools 
 
The Profile Tools palette, the fourth tool of the Component Based Vertical Alignment Design Tools 
palette, is shown below. 

 
Five commands are available as described below: 
 
Store a Vertical Alignment in COGO 
This tool enables the user to store graphical profile components into 

coordinate geometry. This command requires COGO to be active. 
 
Graphical Profile Preferences 
This tool enables the user to define the preferences used within the Component Based Profile 
Generator. 
 
Import Vertical Alignment from COGO 
This tool enables the user to import a previously stored profile from the coordinate geometry database. 
This command requires COGO to be active. 
 
Place Profile Cell Anchor 
This tool enables the user to place a profile cell which is as a prerequisite to any profile creation using 
the Component Profile tools.  
 
Profile Cell Control 
The Profile Cell Control dialog enables the user to place or manipulate profile cells and associated data. 



October, 2012 Ohio Department of Transportation, GEOPAK Road Training Guide 

 

 

Chapter 9 – Plan and Profile Sheets Page 9-1 
 

9 Plan and Profile Sheets 

9.1 Overview 

GEOPAK provides the capability to assemble plan and profile sheets from MicroStation design files in 
which the plan and profile information has been previously placed. Based on user-defined parameters 
and sheet sizes, the software will place clipping borders into the master design file based on the 
geometrics of a specified chain and/or profile. The designer has the option to modify the clipping 
borders by adjusting their size or moving them to a new location. Once the clipping borders are in the 
desired location, the software will draw the sheets into separate design files by placing sheet border 
cells and attaching reference files. The designer determines how many sheets are placed into each 
design file. 
 
There are a few steps that need to be performed before clipping the sheets, as listed below: 
 

 Prepare plan view graphics for the existing and proposed project information. Multiple 
specialized basemaps may be used to represent this information according to ODOT standards. 

 Prepare the profile information in a separate profile base map. This will also include a separate 
row of profile elevations that will be referenced into the completed plan and profile sheets. The 
profile elevations can be placed using the GEOPAK Draw Profile Tabular Data tool. 

 Determine whether to process sheets with the Use Current Design File option or the Customize 
with Motif Files option. 

 
If the Use Current Design File option is selected: 
 

o Attach all the reference files that will be used on the completed sheets (both plan and 
profile) to the clipping border design file. 

 
If the Customize with Motif Files option is selected: 
 

o Create a new design file to be used as a control file for the plan view reference files. This 
file, called a “Motif” file, will establish all the reference file parameters for the plan view 
portion of the clipped sheets. Each file that will be shown in the plan “Port” should be 
referenced into the plan view Motif file. 

 
o Create a new design file to be used as a control file for the profile view reference files. 

This “Motif” file will establish all the reference file parameters for the profile view 
portion of the clipped sheets. Each file that will be shown in the profile “Port” should be 
referenced into the profile view Motif file. 

 
 Create a new file to contain the clipping borders. 
 Run the clip sheets application. 
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9.2 Sheet Layout Files and Configuration Variables 

Many different types of plan and profile sheets can be configured with GEOPAK. Each sheet type is 
stored in a sheet library. An unlimited number of sheet definitions can be stored within one library. 
When the user begins the sheet process, the desired sheet layout is selected from the attached library, 
which loads the associated parameters. 
 
The sheet library has a .psl file extension. ODOT’s standard plan and profile sheet library, ODOT.psl, is 
located in the following directory: 
 

i:\ODOTstd\V8istd\geopak\road\sheet_library\ODOT.psl 
 
By default, GEOPAK will look in the product installation directory for the sheet library. GEOPAK can be 
configured to look for the sheet library in another directory by use of Configuration Variables. The ODOT 
Standard configuration has the following variables defined for GEOPAK sheet clipping: 
 

GPK_SHEETCLP_SHEET_LIBRARY_DIR  = $(V8iSTD)/geopak/road/sheet_library/ 
GPK_SHEETCLP_SHEET_LIBRARY_NAME   = odot.psl 
GPK_SHEETCLP_SHEET_CELL_LIBRARY_DIR   = $(V8iSTD)/cell/ 
GPK_SHEETCLP_PLAN_MOTIF_FILE_DIR   = ../roadway/basemaps/ 
GPK_SHEETCLP_PROFILE_MOTIF_FILE_DIR   = ../roadway/basemaps/ 
GPK_SHEETCLP_TABULAR_DATA_MOTIF_FILE_DIR  = ../roadway/basemaps/ 
GPK_SHEETCLP_SHEET_OUTPUT_DIR   = ../roadway/sheets/ 

 
The configuration variables listed above are defined within ODOTV8i.pcf. 
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9.3 Plan and Profile Sheet “Ports” 

Each plan and profile sheet type is made up of one or more “Ports”. A Port is defined as follows: 
 

 A Port is used to define the clipping areas that are configured for each sheet. 
 

 There are three types of ports that can be included on a sheet: 
o Plan view 
o Profile view 
o Tabular Data (used for profile elevations) 

 

 Each sheet can be comprised of any combination of plan, profile, or tabular data ports. 
 
Let’s take a closer look at the ODOT sheet configuration for a plan and profile sheet as an example of 
how the ports are used to assemble a completed plan and profile sheet.  

 
The graphic above shows the ports that have been configured for a typical ODOT plan and profile sheet 
layout item. Each port can have one or more reference file attachments. For example, the plan port 
might have a reference file attachment to the design file containing the survey data, another reference 
file attachment to the design file containing the proposed geometry, and another attachment with 
proposed right-of-way information. 
 
When the plan and profile sheets are clipped, the user must specify which design files will be attached 
to each port.  
 
GEOPAK provides two options to specify the port attachments; Use Current Design File or Customize 
with Motif Files. Each option has pros and cons which are discussed below. This section will focus on 
defining these options; the dialog to select the processing option is covered later in this chapter. 
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Use Current Design File 
The current design file (the file containing the sheet clipping borders) will be attached to each port on 
the completed plan and profile sheet. Every reference file that is attached to the current design file is 
also attached to each port in the completed sheets. 
 
This option is advantageous because it requires less setup and is easier to process, but it has one 
significant disadvantage as listed below: 
 

 There is no way to individually specify which reference file should be attached to which port. 
Every reference file attached to the current design file is attached to each port of the completed 
sheets. 

 
Customize with Motif Files 
A Motif File is an empty MicroStation design file with reference file attachments. Motif Files are used as 
follows: 
 

 Each Port (plan, profile, or tabular) can have one Motif File assigned. 

 The Motif File is used as a template to control the reference file settings for a Port. When the 
sheets are clipped, the reference files that are attached to the Motif File are attached to the 
associated Port in the completed sheet. 

 The Motif File itself is not referenced to the completed plan and profile sheets. 

 Graphics placed in the Motif File are not used in the completed plan and profile sheets. 

 The motif file’s reference file settings are used to determine which levels are turned on/off in 
each of the reference file attachments that make up the completed sheets. 

 
More than one motif file can be used. For example, the user can assign a motif file to control which files 
are attached in the plan port. A separate motif file can be used to control the reference files for the 
profile port, and another for the tabular port information. 
 
Although the Customize with Motif Files option requires more setup work prior to generating the 
sheets, this option is advantageous since it gives the user greater control over each file that will be 
attached as a reference to a port. The diagram below illustrates the use of two motif files to control the 
reference attachment settings for a plan and profile sheet. 

 
It is up to the user to determine which option will be used. 
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9.4 Clipping Borders 

GEOPAK places clipping borders in a MicroStation design file to designate the clipping range for each 
plan and profile sheet. Each clipping border corresponds to a port on the completed sheet. 
 
An example of the clipping borders for the plan, profile, and tabular ports is shown below. 

 
For ODOT projects, the clipping borders are normally drawn in a separate design file. 
 
The clipping borders for the plan, profile, and tabular ports are all drawn in the same design file. 
 
The clipping borders are drawn using the following symbology: 
 

Port Level Color Style Weight 

Plan View  GK_Clip_Borders 3 2 1 

Profile View GK_Clip_Borders 2 2 1 

Tabular Annotation GK_Clip_Borders 1 2 1 

 
Regardless of the method used to clip the sheets, Use Current Design File or Customize with Motif Files, 
it is necessary to create a design file for the clipping borders. The ODOT_Files application can be used to 
create the clipping border design file. The application is accessed from the MicroStation pull down menu 
by selecting ODOT > File Management > New Design File. 
 
The design file can be created using the application as shown on the following page: 
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Note: The application requires that GEOPAK is deactivated in order to create the design files. In the 
example above, three files are created to be used in the sheet clipping process. It is recommended that 
you create the files all at once in order to avoid repeatedly reactivating GEOPAK. 
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9.5 Placing Profile Elevations for the Tabular Port 

The ODOT plan sheet library, ODOT.psl, has been configured to use a separate reference attachment for 
the existing and proposed profile elevations that will be displayed in the Tabular Port of the completed 
plan and profile sheets. By using a reference attachment and the GEOPAK profile cell information, the 
elevations can be easily updated if the designer makes a change to the profiles.  
 
Before processing the sheets, the user must draw a row of existing elevations, and another row of 
proposed elevations, in a MicroStation design file that will be referenced into the Tabular Port on the 
completed sheets. Care must be taken to ensure that the elevations are plotted with the correct 
horizontal and vertical spacing to fall into the proper location on the completed sheets. 
 

This section will detail the process to place the existing 
and proposed profile elevations beneath the GEOPAK 
Profile Cell using the GEOPAK Draw Profile Tabular Data 
tool.  
 
The tabular data is drawn in the active design file. Open 
the profile design file before accessing the Draw Profile 
Tabular Data command. 
 
The tool can be accessed by selecting Applications > 
Road > Plans Preparation > Draw Profile Tabular Data, 
or from the GEOPAK Road tool pallet as shown at left. 
 
The Draw Profile Tabular Data tool requires Active 
Chain Control to be active. If Active Chain Control is not 
active, you will be prompted to activate it as shown 
below. 

 
 
The Draw Profile Tabular Data dialog shown on the following page will open, along with the Active Chain 
Control dialog. 
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The Active Chain Control dialog is covered in Chapter 6 of this training guide. To use Active Chain Control 
with the Draw Profile Tabular Data tool, take the following steps: 
 

 Select the Chain name that was used to extract the profile that will be used to annotate the 
Tabular Data 
 

 Right-Click on the View 1 icon within the Active Chain Control Dialog and select Profile option. 
The profile will automatically be fitted to the view. 
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The Draw Profile Tabular Data tool can be used to place a variety of data, in tabular format, onto 
profiles according to user-defined parameters. A comprehensive set of preferences enables the user to 
determine what data is placed, the grid, leader lines, titles, how to handle overlapping text, and where 
the tabulation is placed in relationship to the profile. 
 
Preference Files 
Preferences for the Draw Profile Tabular Data tool can be saved in a .cch files for later recall and use. 
This training guide will detail the process to use the ODOT file profile_elevations.cch file for placing the 
existing and proposed elevations at an offset to a profile cell to be used for clipping plan and profile 
sheets. See the GEOPAK online help for details on how to configure the preferences. 
 
From the Draw Profile Tabular Data dialog, select File > Open to open a preference file. After the ODOT 
preference file is selected, the Draw Profile Tabular Data dialog should appear similar to the example 
shown above. The ODOT preference file can be accessed from the following location: 
 

i:\ODOTstd\V8istd\geopak\road\cch\profile_elevations.cch 
 
The first entries required in the dialog are at the top of the dialog. These include: 

 
Job Number 
Required to identify the coordinate geometry database where the chain for generating the 
profiles is stored. 
 
Chain 
Required to reference an alignment associated with the profile. Note: The Job Number must be 
defined in order to populate the Chain list. 
 
XS Station Range 
This group box is ghosted out, as it is not utilized in the Draw Profile Tabular Data tool. 
 
Scale 
This option is used to specify the Scale used for drawing tabular data. Both Inches and 
millimeters are supported. 
 
Draw 
When the dialog and associated preferences are complete, press the Draw button to start 
processing. Prior to pressing the Draw button, all elements (tabular data, grids, etc.) are 
visualized elements only. 
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Two tabs on the dialog support the input data required to draw profile tabular data: 
 

 Row Definition 

 Design Elements 
 
Each option is discussed below. 
 
Row Definition 
When the Row Definition tab is selected, the bottom portion of the dialog dynamically changes as 
shown below 

 
Three icons are supported for various annotations: 
 

 Frame Annotation 1 
This option provides a single set of parameters for tabular data. The set-up includes text 
parameters, what tabular data is to be placed, leader lines, grids, etc. When the button is 
pressed, all data stored within the Frame Annotation 1 is populated in the dialog. 
 

 Frame Annotation 2 
Identical in functionality to Frame Annotation 1, the second annotation frame is provided to 
enable the user to have two set-ups within one tabular data preference file. For example, Frame 
Annotation 1 may be configured to place profile tabular information below the profile while 
Frame Annotation 2 may be configured to place a different set of profile tabular annotation 
above the profile. 
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 On Surface Annotation 
This option places text on the surface rather than in tabular format. For example, labeling 
pavement slopes would use this format. The option has not been configured to place any 
graphics using the profile_elevations.cch preference file. 

 
Location/Cell 

The Distance is measured from the data or profile cell origin vertically 
to top of the chart. The dialog value is multiplied by the Scale for the 
actual measurement. The Rounding relates to the Datum value.  

 
 
Limits 

By default, GEOPAK draws the tabular data the width of the data 
or profile cell, based on the preferences. Using this group box, 
the data will be tabulated only within the limits specified. 

 
 

The rest of the Row Definition tab contains a list of profile items that will be annotated. In the 
example below, two items will be annotated, the Proposed Elevation and the Existing Elevation. 
The list box contains the definitions from the current preference file and cannot be added or 
modified within this dialog. The toggle to the left of the Name indicates which Rows are to be 
used in the current tabular layout. 

 
 

The only edit buttons (located to the right of the list box) are Up / Down arrows to change the 
order of the rows. To change, simply highlight the row, then press the Up or Down arrow. Each 
pressing moves the line one position. 
 
The Frequency list box displays information for the selected row Name. In the example above, 
the Proposed Elevation will be annotated at the frequency indicated in the dialog. 
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Design Elements 
When the Design Elements tab is selected, the bottom portion of the dialog dynamically changes as 
shown below. 

 
The ODOT preference file profile_elevations.cch has two profile variables that must be defined by the 
user before the elevations can be placed in the design file. To define the variables, take the following 
steps: 
 

 Select the variable Name from the list box. 
 

 Select the corresponding profile from the Definition drop down list. The list of profile names is 
taken from the COGO database specified by the Job Number. 

 
 Press the Modify Line icon, located to the right of the list box, to add the Definition to the list 

box. 
 
After the Profile Name has been defined for each Name, the elevations will be dynamically displayed 
below the profile cell origin as shown in the example below. 
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Changes to the dialog settings will be dynamically displayed in the design file. For example, changing the 
Start station to 50+00 will cause the dynamics to update the profile elevations to reflect the current 
station range values. Changing the Scale will cause the elevation text size to dynamically update to 
reflect the current scale value. 
 
Once you are satisfied with the appearance and location of the profile elevations, select the Draw 
button to write the profile elevations to the design file. 
 
A border is drawn around the elevations as shown above. The border is placed on level Default and will 
be used to assist the user in defining the origin for the tabular elevations when the sheets are 
processed. The existing elevation text is placed on level PF_P_Sta_Elev_Text. Proposed elevation text is 
placed on level PF_P_Sta_Elev_Text. 
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Using Frame Annotation 1 and Frame Annotation 2 
The configuration of Frame Annotation 1 and Frame Annotation 2 appears to be identical until the 
profile elevations are placed in the design file. Each annotation option has been configured to place a 
row of existing profile elevations and a row of proposed profile elevations beneath the profile cell with 
different spacing as detailed below. 
 
When Frame Annotation 1 is selected, the Row Definition portion of the Define Profile Tabular Data 
dialog appears as shown below. 

 
The elevations are placed in the design file with spacing appropriate for use with the ODOT standard plan 

and profile sheet cells PLPRO1, PLPRS1, or PROF2. 
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When Frame Annotation 2 is selected, the Row Definition portion of the Define Profile Tabular Data 
dialog appears as shown below. 

 
Notice that the Proposed Elevation and Existing Elevation items for Frame Annotation 2 are toggled off 
by default as shown above. Be sure to toggle off the Proposed Elevation and Existing Elevation for 
Frame Annotation 1, then toggle on the Proposed Elevation and Existing Elevation for Frame 
Annotation 2. The elevations are placed in the design file with spacing appropriate for use with the 
ODOT standard plan and profile sheet cell PLPRO3 as shown below 
 

 
 
A second preference file, profile_elevations2.cch, is available to set the spacing of the profile elevations 
appropriately for a profile only sheet using the standard sheet cell PROF3. 
 
 
 
 
 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 9-16 Chapter 9 – Plan and Profile Sheets  
 

9.6 The Plan Sheet Layout Dialog 

To access the plan and profile sheet function select Applications > Road > Plans Preparation > 
Plan/Profile Sheet Composition from the MicroStation menu bar or select the plan and profile sheet 
icon from the Road tool palette, as shown below. You can also select the Plan & Profile Sheets icon from 
the Road Project dialog box. 

 
The Select Run dialog shown below will open.  

 
By default, a run named Untitled is always created. To 
create new “run”, select Run > New... from the Select 
Run dialog box to access the New Run Name dialog box 
shown below. 

 
Key-in the Run Name and Description for the new run. Select OK to create the new run. The new run 
name will appear in the Select Run dialog box. 
 
Select the new run from the list box and then pick OK to open the new run. The GEOPAK Plan Sheet 
Layout dialog appears as shown below. 
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The name of the current sheet library (ODOT.psl) is displayed in the title bar as shown above. A row of 
icons is available to access the dialog boxes listed below. The corresponding menu access selections are 
noted in parenthesis. 
 

 Sheet Composition (Tools > Sheet Composition) 
 

 Layout Sheets (Tools > Sheet Layout)  
 

 Clip Sheets (Tools > Sheet Clip) 
 

 Modify Sheets (Tools > Modify) 
 

 Sheet Number Manager (Tools > Sheet Number Manager) 
 

 ID (Tools > Identify Sheet) 
 
To the right of the icons is the Sheet Name list box. This list box contains a list of the sheet types that are 
configured in the currently selected sheet library. The example below shows a partial listing of the sheet 
types that are available in ODOT.psl. 

 
The key in field to the right of the dialog is used to specify the scale for the completed sheets. 
  
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 9-18 Chapter 9 – Plan and Profile Sheets  
 

9.6.1 File Menu 

 The File menu has the following functions: 

 
Sheet Library 
This menu item contains commands to create, attach, and edit sheet libraries. For a detailed 
discussion of setting up a sheet library, see the GEOPAK online documentation. 
 
Exit 
This menu item exits the GEOPAK Plan Sheet Layout dialog 

 

9.6.2 View Menu 

 
After clipping borders have been drawn into the MicroStation file, the View menu options can be used 
to control which sets of clipping borders are displayed on screen. The View menu has the following 
functions: 
 

Filter by Sheet Name 
The clipping shapes of the currently selected sheet name are displayed. A MicroStation update 
view must be issued if Automatic Update is not toggled on. 
 
Filter by Scale 
The clipping shapes of the currently selected Scale are displayed. A MicroStation update view 
must be issued if Automatic Update is not toggled on. NOTE: Filter By Sheet Name and Filter By 
Scale can be used together. 
 
Automatic Update 
If this option is toggled on when Filter By Sheet Name or Filter By Scale is selected, the view is 
automatically updated. 
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9.6.3 Settings Menu 

 
When the Settings > Sheet Layout option is selected, the Sheet Layout Settings dialog shown below 
opens. 

 
The Sheet Layout Settings dialog has the following options: 
 

Sheet Layout Progression 
Two options are available: Left to Right (Standard) or Right to Left (Rail). 

 
Profile Stair Stepping 
Profile stair stepping can be turned either On or Off. 

 
Sheet View Attributes 
Two options are available, Use Current Design File and Customize with Motif Files.  
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9.6.4 Tools Menu 

 
The Tools menu has the following functions: 
 

Identify Sheet 
Select Identify Sheet, then select and accept a previously placed clipping shape. GEOPAK 
determines the settings used to place the original sheet clipping border and automatically 
populates the dialog settings with the Sheet Name and Scale. In addition, the Sheet Name, 
Scale, Sheet Number and Port are displayed in the MicroStation prompt field at the bottom of 
the screen. If the parameters for the selected sheet are not found within the current library, a 
warning message is displayed indicating the sheet is not found 
 
Sheet Composition 
This menu item opens the Sheet Composition dialog. See section 9.7.5 for information on this 
dialog. 
 
Sheet Layout 
This menu item opens the Layout Sheets dialog. See section 9.7.6 for information on this dialog. 

 
Sheet Clip 
This menu item opens the Clip Sheets dialog. See section 9.7.7 for information on this dialog. 
 
Sheet Modify 
After the sheets are laid out, the user may want to adjust individual sheets to conform to the 
project limits, etc. This can be accomplished with the tools in the Modify dialog, which is 
detailed in section 9.9. 
 
Sheet Number Manager 
The Sheet Number Manager dialog is detailed in section 9.10. 
 
Draw Tabular Annotation (Sheet Clip Mode) 
This option is used to draw tabular annotation into clipping shapes which have been previously 
placed in the DGN file. This option will not be detailed in this training guide. 
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9.7 Process Sheets: Customize With Motif Files 

As stated previously, Motif Files are empty MicroStation design files with reference files attached, and 
are used to designate which reference files will be attached to each Port on the completed sheets. 
Before processing the sheets, the user must create the Motif Files that will be used during the sheet run. 
The ODOT_Files application can be used to create the Motif Files. The application is accessed from the 
MicroStation pull-down menu by selection ODOT > File Management > New Design File. 
 
The Motif files can be created as shown in the example below: 

 
Toggle the Category to GEOPAK Specific Basemap Files. Note the folder where the files are created, and 
the file names. 
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9.7.1 Configuring the Plan Motif File 

The plan view motif file is used to specify which reference files will be attached to the Plan Port of the 
completed plan and profile sheets. 
 
Section 303 of the ODOT CADD Engineering Standards Manual specifies that all plan sheets are to be 
placed in the Sheet Model of the sheet design file. The GEOPAK Clip Sheets application does not give you 
the opportunity to specify whether the completed sheets will be placed in a Sheet Model or a Design 
Model in the newly created sheet files. 
 
When using the Customize with Motif Files option, the motif file assigned to Port 1 (the plan port in 
most cases) is used as the seed file for the newly created plan and profile sheet design files. In order to 
ensure that the completed plan and profile sheets are placed in a Sheet Model, be sure to make all 
reference attachments in the motif file that is assigned to Port 1 in a Sheet Model. 
 
Take the following steps to configure the plan motif file: 
 

 Open the plan view motif design file. 
 

 In order for the GEOPAK Clip Sheets application to place the completed plan sheets in a sheet 
model, select the Sheet model as the active model as shown below: 

 
Design files created using ODOT’s seed files will contain two models as shown above. To select 
the active Model within MicroStation, open the Models dialog as shown above and then double 
click the name of the desired Model. 

 
 Edit the model properties to set the Annotation Scale for the custom line styles. From the 

Models dialog shown above, select Edit Model Properties to access the dialog shown below, 
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For a typical ODOT design project using MicroStation V8i, the Line Style Scale parameter should 
be set to Annotation Scale as shown above. 
 
If the custom line styles have been placed with a specify plotting scale in mind, the option 
should be set to Global Line Style Scale with a value of 1.0 as shown below. 
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 Attach the reference files that will be used for the plan port of each sheet. In this example, four 
references are attached as shown below. 

 
There are numerous parameters to be aware of when attaching references. Two parameters of 
particular note are mentioned below: 
 

1. Be sure to use the MicroStation option to Save Relative Path when attaching all 
reference files as shown below. 

 
2. On the Reference Attachment Settings dialog, shown on the following page, the Global 

LineStyle Scale option is used to set whether the line styles in the reference attachment 
are scaled using the original value in the reference file, or using the active Model 
Annotation Scale of the completed sheet file. 
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Set the Global LineStyle Scale option to Master as shown on the following page for 
projects where the survey data was mapped at a scale of 1.0. 
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 After the references have been attached, turn on/off the levels that you want turned on/off in 
the completed sheets for each reference attachment. Use the MicroStation Level Display dialog 
to accomplish this task. 
 
An example turning on/off the desired levels for the Survey basemap is shown below. 

 
 From the MicroStation pull-down menu, Select File > Save Settings. 

 
The plan motif file is now configured and ready for use. 
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9.7.2 Configuring the Profile and Tabular Motif File 

The profile basemap 12345BF001.dgn contains the graphics for both the profile port and the tabular 
port as shown below. 
 

 
Since all the graphics for the profile and tabular port are contained in one design file, the profile motif 
file is used to specify which reference files will be attached to both the profile port and the tabular port 
on the completed plan sheets. 
 
The steps to prepare the profile motif file are similar to the steps to prepare the plan motif file and are 
briefly summarized below. Take the following steps to configure the profile motif file: 
 

 Open the profile view motif design file, 12345KF001.dgn. 
 

 Select the Sheet Model as the active model to attach the references. 
 

 Attach the reference file that will be used for the profile and tabular port of each sheet. In most 
cases, the profile design file will be attached once for both the profile and tabular ports. 

 
 Turn on/off the levels that you want to see in the completed sheets. Use the MicroStation Level 

Display dialog to accomplish this task. 
 

 From the MicroStation pull-down menu, Select File > Save Settings. 
 
The profile motif file is now configured and ready for use. 
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9.7.3 Sheet Clipping Borders 

GEOPAK places clipping borders in a MicroStation design file to designate the areas that will be clipped 
into each port of the completed plan and profile sheets. We recommend creating a separate design file 
to house the clipping borders.  
 
The ODOT_Files application can be used to create the clipping border design file. The application is 
accessed by selecting ODOT > File Management > New Design File from the MicroStation pull-down 
menu. 
 
The file can be created as shown below: 

 
Note: When using the Customize with Motif Files option, the clipping sheet border file is used only to 
house the clipping borders. It is not necessary to attach any references to the clipping sheet border 
design file. 
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9.7.4 Plan Sheet Layout: Settings 

After creating a new sheet Run as detailed in section 9.6, select Settings > Sheet Layout from the Plan 
Sheet Layout dialog to access the Sheet Layout Settings dialog shown below. 

 
Toggle the Sheet View Attributes option to Customize with Motif Files as shown above. 
 

9.7.5 Plan Sheet Layout: Sheet Composition 

Select the Sheet Composition icon to access the Plan Sheet Layout: Sheet Composition dialog shown 
below. 

 
 
This dialog is used to configure how 
the clipping borders will be placed for 
the plan view. Four options are 
available in the center of the dialog to 
select how the sheets will be clipped. 
Each of these options is detailed in the 
GEOPAK on-line help. The ODOT sheet 
library has been configured to work 
specifically with the By Station Range: 
Radial method as shown at left. 
 
We will limit our discussion to the By 
Station Range: Radial option and how 
to generate sheets in accordance with 
ODOT Standards using this option. 
 
 
 
 
 
 
 

 
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 9-30 Chapter 9 – Plan and Profile Sheets  
 

By Station Range: Radial 
The By Station Range: Radial option will allow the user to specify how many feet will be placed 
on each sheet. This interval is entered in the Station Range field. 
 
Station Range 
The Station Range key-in is used to specify the horizontal length of plan and profile to be placed 
on each sheet. 

 
IMPORTANT! The ODOT configured sheet library has been configured to work with the Station Range 
lengths listed in the table below. 
 

Sheet Name 

Sc
al

e
 

Description 

Station Range 

Sheet 
Cell 

2
0

  
Sc

al
e

 

3
0

 S
ca

le
* 

4
0

 S
ca

le
* 

5
0

  

Sc
al

e
 

20 Plan/Pro 20 Plan and profile - no summary 500 -NA- -NA- -NA- PLPRO1 

20 Plan/Pro/Pro 20 Plan and two profiles 500 -NA- -NA- -NA- PLPRO3 

20 Plan/Pro/Sum 20 Plan, profile, summary 400 -NA- -NA- -NA- PLPRS1 

20 Pro/Pro 20 Two profile views on one sheet 500 -NA- -NA- -NA- PROF2 

20 Profile 20 Profile view only 500 -NA- -NA- -NA- PROF3 

40 MOT Plan/Pro 40 40 Scale MOT plan and profile -NA- -NA- 1000 -NA- PLPRO1 

40 MOT Plan/Pro/Sum 40 40 Scale MOT plan, profile, sum -NA- -NA- 800 -NA- PLPRS1 

50 Plan/Pro 50 Plan and profile - no summary -NA- -NA- -NA- 1250 PLPRO1 

50 Plan/Pro/Pro 50 Plan and two profiles -NA- -NA- -NA- 1250 PLPRO3 

50 Plan/Pro/Sum 50 Plan, profile, summary -NA- -NA- -NA- 1000 PLPRS1 

50 Pro/Pro 50 Two profile views on one sheet -NA- -NA- -NA- 1250 PROF2 

50 Profile 50 Profile view only -NA- -NA- -NA- 1250 PROF3 

Plan Any Plan view only 500 750 1000 1250 BLKW 

Plan/Plan Any Two plan views on one sheet 500 -NA- -NA- 1250 BLKW 

Plan/Summary Any Plan view with summary 400 -NA- -NA- 1000 PLPRS3 

 
*Important Notes Regarding 30 and 40 Scale Sheets: 
 

Acceptable scales for Plan and Profile sheets are defined in section 1300 of the Location and Design 
Manual Volume 3 Highway Plans. The options for 30 and 40 scale sheets are intended for use on 
Maintenance of Traffic (MOT) plans ONLY. The following guidelines apply: 

 

 30 scale sheets can be used for MOT plan sheets when a temporary road profile is not shown. 
 

 20, 40, or 50 scale sheets can be used for MOT plan sheets that include a temporary road 
profile. 

 

 30 and 40 scale sheets are never acceptable for use on sheets other than MOT sheets. 
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9.7.6 Plan Sheet Layout: Layout Sheets 

Select the Layout Sheets icon to access the Plan Sheet Layout: Layout Settings dialog shown below. 
 

 
Specify the Job number for the GEOPAK COGO Database where the chains and profiles are stored that 
will be used to lay out the clipping borders.  
 
An option button is provided to select whether to process Multiple Sheets or a Single Sheet. 
 
The center of the dialog lists the ports that have been configured for the selected plan and profile sheet 
type. Each Port must be assigned an Alignment and a Motif File. 
 

 Double-click the Plan port line in the dialog to access the Plan Sheet Layout: Plan Port Data 
dialog shown below. 

 
 Select the Chain that will be used to layout the plan view clipping shapes. An optional Offset can 

be specified. 
 

 Select the file you have configured for use as the plan view Motif File. 
 

 Select OK to accept the dialog settings. 
 

 Double-click on the Profile port line in the dialog to access the Plan Sheet Layout: Profile dialog 
shown below. 
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The Profile Data portion of the dialog is used to specify the information for the profile origin in the 
design file. This data is read from the current Working Alignment. 
 
 Select the Profile that will be used to layout the profile clipping borders. In many cases, this will 

be the existing profile. 
 

 Select the file you have configured for use as the profile view Motif File. 
 
The Profile Cell portion of the dialog provides the following options: 

 
Draw Cell at X,Y 
Use this option to draw a profile cell in the current design file using the current Profile data. 

 
Identify Cell 
Use this option to set the Profile Data settings to match the values of a cell previously drawn in 
the design file. 

 
Identify Profile Port 
Use this option to set the Profile Data settings to match the values of a previously drawn profile 
port clipping shape. 

 
 Select OK to accept the dialog settings. 

 
 

 Double-click on the Tabular port line in the Plan Sheet Layout: Layout Settings dialog to access 
the Plan Sheet Layout: Tabular dialog shown below. 
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The Profile Data is read from the current Working Alignment. 
 
 Select the Profile that will be used to layout the profile clipping borders. In many cases, this will 

be the existing profile. 
 

 Select the file you have configured for use as the profile view Motif File. 
 
The Profile Cell portion of the dialog provides the following options: 
 

Draw Cell at X,Y 
Use this option to draw a profile cell in the current design file using the current Profile data. 
 
Identify Cell 
Use this option to set the Profile Data settings to match the values of a cell previously drawn in 
the design file. 
 
Identify Profile Port 
Use this option to set the Profile Data settings to match the values of a previously drawn profile 
port clipping shape. 

 
The Clipping Shape Vertical Offset is not used for ODOT plan and profile sheets. See the GEOPAK 
online documentation for information on this option. 
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Assigning the Origin for the Tabular Data Port 
The origin of the Tabular Data port will need to be assigned based on the location where the tabular 
data is plotted in the design file relative to the profile cell. As detailed previously, the tabular data is 
placed below the profile cell when using the ODOT preference file profile_elevations.cch. We have 
elected to place the tabular data that will be used for the tabular port below the profile for the following 
reasons: 
 

 This is the only way to ensure that the tabular ports will not overlap the profile, the profile cell, 
or station text. The idea is to have nothing drawn in the tabular ports except the profile 
elevations. 

 

 Since the profile ports will typically be stair-stepped to follow the profile (unless your profile is 
very flat) it would be time consuming for the user to move the elevations so that they fall within 
the limits of the profile ports. 

 
Take the following steps to assign the origin for the tabular port to ensure that it lines up with the 
plotted tabular annotation: 
 

 Draw a perpendicular line that bisects the left side of the tabular annotation border to intersect 
the profile cell as shown below. 

 
 From the GEOPAK Sheet Layout: Tabular dialog, select the Identify Cell button and identify the 

profile cell. This will ensure that the proper values for the Profile, Chain, Station, Horizontal 
Scale, and Equation Treatment are read into the dialog from the identified profile cell. 

 
 The X and Y values read from the profile cell in the step above need to be adjusted to 

correspond to the correct X and Y origin for the tabular annotation. Select the By DP button and 
snap to the new origin for the tabular port at the intersection of the bisector line drawn in step 
one and the profile cell, as shown in the example below. 
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After the plan, profile, and tabular port information has been defined the information will be included in 
the Layout Sheets dialog as shown below. 

 
After the port data is complete, the user has an option to layout sheet clipping borders for all or part of 
an alignment or profile. When the alignment or profile is defined within the port data dialogs, the Begin 
Station and End Station range is automatically populated. This stationing is used as the default, but can 
be adjusted by the user as desired. The Extend fields can be used to specify a starting and ending station 
outside the limits of the alignment. 
 
Select the Layout Sheets button to initiate placement of the sheet clipping borders. Note: the Layout 
Sheets button specifies the approximate number of sheets that will be generated.  
 
After the Layout sheet button is selected, the clipping borders are placed in the active model in the 
current design file. An example is shown below. 
 

 
Note: When using the Customize with Motif Files option, the clip border design file does not need to 
have any other elements drawn in the file, or any reference attachments. The example above is shown 
with the plan and profile basemap design files attached as references for the purpose of showing how 
the clip borders are aligned in relation to the plan and profile design files 
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9.7.7 Plan Sheet Layout: Clip Sheets 

Select the Clip Sheets icon to access the dialog shown below. 

 
The Directory specifies the drive and path for the directory where the new design files containing the 
sheets will be created. The path and name can be input manually or selected via the Sheet Output 
Directory icon. 
 
The Sheet Name Prefix identifies the root name for the initial file. Additional files are named by adding 
the sheet number to the end of the prefix. The default extension is .dgn. In the example above, 
12345GP01.dgn would be the name of the initial file. The second file would be 12345GP02.dgn, the third 
12345GP03.dgn, etc. Note: If the entire file name is given, the default extension is not used. 
 
There are two options for rotating sheets: Rotate View and Rotate Reference. Each option is described 
below. 
 

Rotate View 
The Rotate View option will attach all reference files and then rotate the MicroStation view to 
conform to the sheet orientation. The reference file attachments are not rotated. In this case, 
the integrity of the original coordinates and angles of the master and reference files will remain 
intact. With Rotate View selected, the Sheets per File option is ghosted as only one sheet per file 
can be placed to maintain coordinate integrity. 
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TIP: 
Use the Rotate View option 
for ODOT projects. 
 

 
Rotate Reference 
When sheets are clipped using the Rotate Reference option, 
the sheet cell and view are not rotated. The reference files 
are rotated and moved to the correct location with respect 
to the sheet cell. This arrangement allows multiple sheets to 
be placed in one design file. The user specifies the number of 
sheets per file via the Sheets per File key-in field. 

 
The Sheet Range defaults to the entire sheet range, however, the user may generate a partial set by 
selecting the Begin and End number of the sheet range from the list. 
 
The Labels and Annotations group box contains fields for annotating the Sheet Title, Project Number, 
and Match Line. Each is described below. 
 
Sheet Title 
The ODOT standard sheet library, ODOT.psl, has not been configured to allow the placement of a Sheet 
Title on the completed sheets.  
 
Project Number 
The Project Number will be placed in the title block of each sheet as shown in the example at right. Note 
that the sheet number is automatically placed. 
 
Match Line 
If desired, key in the text that you wish to appear before and after the station number on the match 
lines. 
 
Auxiliary Sheet Annotations 
Toggle on the Auxiliary Sheet Annotations option to place a label at 
the lower left of each sheet. The label contains the sheet number, 
rotation angle, and the alignment name. The rotation angle can be 
used to properly orient the north arrow on the sheet. Double-click 
the symbology box to the right of the toggle to access the Plot 
Parameters dialog at right. 
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Select Process Sheets to initiate creation of the plan and profile sheets. An example of a completed 
sheet is shown below. 
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9.8 Processing Sheets: Use Current Design File 

The process to clip sheets with the Use Current Design File option is similar to the process using motif 
files. The biggest difference is that Motif files are not used to specify the reference attachments for the 
plan, profile, and tabular ports. The references that are attached to the design file containing the 
clipping borders will be attached to each port in the completed sheets. 
 
The procedure to clip sheets using the Current Design File option is described below. 

9.8.1 Configuring the Clipping Border Design File 

Create a new design file to house the clipping borders as described in section 9.4. 
 
Section 303 of the ODOT CADD Engineering Standards Manual specifies that all plan sheets are to be 
placed in the Sheet Model of the sheet design file. The GEOPAK Clip Sheets application does not give you 
the opportunity to specify whether the completed sheets will be placed in a Sheet Model or a Design 
Model in the newly created sheet files. 
 
The clipping border design file is used as the seed file for the new sheet design files. Be sure to select the 
Sheet Model as the active model in the clipping border design file. 
 
Take the following steps to configure the clipping border design file: 
 

 Open the clipping border design file. 
 

 In order for the GEOPAK Clip Sheets application to place the completed plan sheets in a sheet 
model, select the Sheet model as the active model as shown below: 

 
Design files created using ODOT’s seed files will contain two models as shown above. To select 
the active Model within MicroStation, open the Models dialog as shown above and then double 
click the name of the desired Model. 
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 Edit the model properties to set the Annotation Scale for the custom line styles. From the 
Models dialog shown above, select Edit Model Properties to access the dialog shown below, 

 
For a typical ODOT design project using MicroStation V8i, the Line Style Scale parameter should 
be set to Annotation Scale as shown above. 
 
If the custom line styles have been placed with a specific plotting scale in mind, the option 
should be set to Global Line Style Scale with a value of 1.0 as shown below. 
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 Attach the references to the clipping border design file. In the example below, 5 references are 
attached. 

 
Note that attachments for both the plan and profile view are made to the clipping border design 
file. 

 
There are numerous parameters to be aware of when attaching references. Two parameters of 
particular note are mentioned below: 
 

1. Be sure to use the MicroStation option to Save Relative Path when attaching all 
reference files as shown below. 
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2. On the Reference Attachment Settings dialog, the Global LineStyle Scale option is used 
to set whether the line styles in the reference attachment are scale using the original 
value in the reference file, or using the active Model Annotation Scale of the completed 
sheet file. 
 
Set the Global LineStyle Scale option to Master as shown on the following page for 
projects where the survey data was mapped at a scale of 1.0. 
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 After the references have been attached, turn on/off the levels that you want turned on/off in 
the completed sheets for each reference attachment. Use the MicroStation Level Display dialog 
to accomplish this task. 
 
An example turning on/off the desired levels for the Survey basemap is shown below. 

 
 From the MicroStation pull-down menu, Select File > Save Settings. 

 
The clipping border design file is now configured and ready for use. 

 
 
 

9.8.2 Plan Sheet Layout: Sheet Composition 

The Sheet Composition dialog is not configured any differently when using the Use Current Design File 
option. Complete the Plan Sheet Layout: Sheet Composition dialog as described in section 9.7.5. 
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9.8.3 Plan Sheet Layout: Layout Settings 

Complete the Plan Sheet Layout: Layout Settings dialog as described in section 9.7.6. 
 
The option to select a Motif File will be unavailable when assigning the Alignment information for the 
Plan, Profile, and Tabular ports since the current file will be used to determine the reference 
attachments. 
 
The procedure to assign the origin for the Tabular port is the same as described in section 9.7.6. 
 
When completed, the Plan Sheet Layout: Layout Settings dialog will appear similar to the example 
shown below with the Current file assigned as the Motif File. 

 
Select the Layout Sheets icon to place the clipping borders in the design file. The borders are placed as 
shown in the example below. 
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9.8.4 Sheet Layout: Clip Sheets 

The Sheet Composition dialog is not configured any differently when using the Use Current Design File 
option. Complete the Plan Sheet Layout: Clip Sheets dialog as described in section 9.7.7. 
 
Since the Use Current Design File option does not allow you to specify which references are attached to 
each port, users may wish to review the reference attachments and delete any unnecessary 
attachments. 
 
In this example, a total of five references were attached as shown in section 9.8.1. Each of these five 
attachments is attached to each port of the completed sheet. Additionally, the clipping border design 
file is also attached to each port. There are a total of 18 reference attachments as shown below. 
 
It is up to the user to determine whether to delete the redundant reference attachments. 
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9.9 Modify Sheets 

After the clipping shapes have been drawn, the user may want to modify or adjust some shapes prior to 
generating the plan and profile sheet design files. GEOPAK provides tools to modify plan, profile or 
tabular data clipping shapes. Select Modify Sheets to access the GEOPAK Sheet Layout dialog shown 
below. 

 
Although it is possible to modify clipping shapes using the standard MicroStation Move and Modify 
Element tools, this is highly inadvisable. In order for sheets to be generated correctly during the clip 
process, the tools provided by GEOPAK on the Modify Sheets dialog must be used for all changes. 
 
Two major modifications are supported and are selected in the upper left corner (via icon): 
 

 Slide Sheets  
 

 Modify Drawing Area  
 
As the modification type is selected, the dialog changes to reflect the selection. The Slide Sheets option 
is shown in the example above. Each option is described on the following pages. 
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Slide Sheets 

 
First, identify the sheet to be modified by selecting from the list of all clipping borders in the current set. 
This can also be done graphically by pressing the id button, then graphically selecting a clipping shape. 
 
Next, determine whether only one sheet is to be modified or if the modification should be carried over 
to adjoining sheets. If the sheets preceding the sheet to be modified are also to be moved, then activate 
the Slide Preceding Sheets toggle. If the sheets after the modified sheet are to be moved a 
corresponding amount as the original shape, activate the Slide Following Sheets. 
 
The sheets can be moved dynamically or by value. The Station field for a sheet is populated when the 
sheet is selected. The displayed station is the Right, Center or Left edge stationing. To move the sheet 
along the alignment, enter the value (in terms of master units) in the Extend field or just enter the new 
station value. If entering a value in the Extend field, a positive number moves in the direction of 
increased stationing, while a negative number moves in the direction of decreased stationing. To move 
dynamically, press the Dynamic button to the right of Extend, which will attach the sheet clipping 
border to the cursor. Then place a data point to initiate moving the cursor. The Station and Extend 
values changing as you move the cursor. Place a final data point to identify the location and slide the 
selected clipping border. 
 
To move the sheet longitudinally relative to the alignment, without changing the stationing, use the 
Sheet Chord Offset. Once again, the value can be entered or the Dynamic button may be utilized. A 
positive chord offset moves to the right, while a negative value moves to the left (based on increasing 
stationing). Place a final data point to identify the location and slide the selected clipping border. 
 
The Rotation can be entered as an angle or dynamically. Rotation always pivots about the left edge of 
the clipping shape. Rotation alone does not cause preceding or following sheets to slide. 
 
Note: Rotating a sheet does not change its station range coverage. Large rotations (such as 90 degrees) 
will cause the visible coverage of a Plan Port to be different than its station range. This means that an 
associated Profile Port will not modify itself to cover fewer stations and preceding or following sheets 
will not slide in response. 
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Modify Drawing Area 

 
The function of this tool is to change the actual drawing area of the selected sheet. When the sheet is 
identified, the Drawing Shown, Horizontal and Vertical fields are automatically populated. The user has 
the option to hold the Left Station, Right Station or Center Station. In order to change the drawing area, 
only one can be held while the other two are adjusted to the revised drawing parameters. Set the 
desired values, and then press the Apply button to modify the selected sheet. 
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9.10  Sheet Number Manager 

 
After the clipping shapes have been placed, the user has the option to adjust the sequence of sheets or 
their numbers. This is accomplished in the Sheet Number Manager as shown below.  

 
The list box contains the Sequence (order the sheets will be drawn) and the Sheet number (based on the 
order the clipping shapes were drawn). The Begin Station and Extension (if one was used), End Station 
and Ending Extension are also displayed. 
 
The toggles on the bottom of the dialog assist the user in locating a particular sheet. Simply activate one 
or both of the toggles, then highlight a sheet in the list box. The clipping shape associated with the 
highlighted sheet is either highlighted or centered or both, depending on the setting of the toggles. 
 
By default, the Sequence of the sheets matches the Sheet number. To change the order, highlight the 
line to be changed or moved, then use the arrow icons to the right to move the sheet up or down in the 
sequence. 
 

 Edit Sequence 
The Edit Sequence tool is useful when they are too many 
sheets to move with the arrows. Highlight the sheet(s) to be 
moved, and then press the icon. The dialog shown at right 
opens. Key in the Beginning Sequence Number and select OK 
to apply the changes. 
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 Edit Sheet Number 
Sheet Numbers can be changed for any sheet or set of sheets by highlighting the sheets to be changed, 
then pressing the Edit Sheet Number icon, which opens the dialog shown below. 

 
A prefix can be added to the sheet number by activating the toggle and keying in the desired prefix. 
 
Sheet Numbers can be changed by the following options: 
 

To Sequence Number Add – uses the sequence number plus the added value. 
 
Starting at Sheet Number – starts at the specified number and increments. If the specified 
number is 101, then sheet 1 would be 101, sheet 2 would be 102, etc. 

 
The other options for alphanumeric sheet numbers will not be covered in this training guide. 
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9.11  Sheet and Motif File Properties 

Section 303.4 of the ODOT CADD Engineering Standards Manual details the use the Title and Comments 
file properties to assign supplemental description information to MicroStation design files. The 
supplemental descriptions can be displayed in Windows Explorer or in the MicroStation Manager. An 
example showing the supplemental descriptions in the MicroStation Manager is shown below. 

 
When the GEOPAK Plan and Profile Sheet Clip application is used to generate plan and profile sheets 
using the Motif Files option, the completed plan and profile sheet design files will copy the Title and 
Comments properties from the Plan Motif File. The example below shows the completed plan and 
profile sheet design files, and their associated properties, as they appear in Windows Explorer. 
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It is recommended that you edit the Title and Comment properties to reflect the correct descriptions for 
plan and profile sheets. To edit the file properties, right-click on the file name in Windows Explorer and 
select Properties. The Properties dialog, shown below, will open. Select the Summary tab to edit the 
Title and Comments properties. 

 
The Title property should be changed to “Roadway Plan and Profile”. 
 
The Comments property can be assigned with the station range for each plan and profile sheet. 
 
The completed plan and profile sheets should have the Title and Comments properties assigned similar 
to the example shown below. 
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Exercise 9 

 Using this chapter as a guide, clip a set of 20 scale plan and profile sheets for S.R. 185. Take the 
following steps to create the sheets: 
 

 Use the Draw Profile Tabular Data tool to plot the tabular annotation for the existing and 
proposed profiles in the profile design file. Which file should you use to draw the Tabular Data? 

 
 Use the ODOT_Files application to create the following design files: 

 

o Plan view motif file 
o Profile motif file 
o GEOPAK Clipping borders file 

 

What is the name of the plan view motif file? 
 
Which sub-directory is the plan motif file created in? 
 
What is the name of the profile motif file? 
 
Which sub-directory is the profile motif file created in? 
 
What is the name of the design file? 
 
Which sub-directory is the file created in? 

 

 Open the Plan View Motif file. Which design files should be attached to this file for the plan view 
portion of the plan and profile sheets? 
 
After attaching the reference files, turn on/off the desired levels in the reference attachments 
and save settings. 

 
 Open the profile motif file. Attach the profile design file as a reference file to the profile motif 

file.  Turn on/off the desired levels in the reference attachments and save settings. 
 

 Open the sheet clipping border design file. 
 

o Which model in the sheet clipping design file is used to place the clipping borders? 
 

o Clip the sheets using either 20 Plan/Pro or 20 Plan/Pro/Sum as the sheet type. Be sure 
to use the Station Range value shown in the table in section 9.7.5 that corresponds to 
the sheet type you elect to process. 

 
o Using the ODOT Design File Naming Convention found in the ODOT CADD Engineering 

Standards Manual, what should you use as the name for the plan and profile sheet files?  
 

o Which folder should you specify for the completed sheets? 
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10 Plan View Labeling 

10.1  Overview 

GEOPAK provides several labeling tools that can be used to compose and place various labels onto 
drawings. The following label tools are available: 
 

 Plan View Labeling 

 Profile Labeling 

 Cross Section Labeling 
 
The operation of each labeler is nearly identical. This training guide will focus on use of the Plan View 
Labeler. The labeling tools permit the creation of a variety of labels using the following features:  
 

 Computed Text Inserts permit standardized computed values to be easily incorporated into 
labels. These computed values are based on the type of element to be labeled and change as 
different elements are selected by the user. Types of elements available for computed inserts 
include points, lines, arcs, complex graphic elements, COGO features, drainage features, etc… 

 

 User Text Inserts facilitate the inclusion of user defined text strings in the label. These inserts 
can be customized to include frequently used labeling terms and be saved and reused. 

 

 Borders can be placed around labels to accommodate different plan label formats. 
 

 Leader lines and line terminators can be used to create the desired label formats. 
 

 Frequently used label formats can be stored as Label Styles for subsequent recall. The complete 
label, including computed text inserts, user inserts, borders, and leaders, are all stored within 
the style. 

 

 Tools to edit, move, and extract labels are also provided to make manipulation and plan changes 
easier. 

 
The GEOPAK labeling tools can be accessed from the Applications menu as detailed below: 
 

 To access the GEOPAK - Plan View Labeler dialog, select Applications > Road > Plans 
Preparation Tools > Plan View Labeling. 

  

 To access the GEOPAK - Profile View Labeler dialog, select Applications > Road > Plans 
Preparation Tools > Profile View Labeling. 

 

 To access the GEOPAK – Cross Section Labeler dialog, select Applications > Road >Cross Sections 
> Cross Section Labeling. 
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Each labeler can also be accessed from the GEOPAK Road tool palette. The Plan and Profile labeling 
options are shown below. The Cross Section Labeling tools is covered in the ODOT GEOAPK Road 2 
Training Guide. 
 
   Plan View Labeling    Profile Labeling 
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10.2  Text Options 

The first tab within the GEOPAK - Plan View Labeler dialog is the Text option, as shown in the graphic 
below. 

 
Job No.  
The coordinate geometry database file (.gpk) used for computed text inserts. 
 
Element (display only) 
Whenever one of the Label Feature tools is used, the selected element type is displayed in the dialog.  
 
Chain 
Select the GEOPAK Chain previously stored within the specified coordinate geometry database. 
 
TIN File 
Select the GEOPAK TIN file to be used with Computed Text Inserts that are used to label an elevation. In 
lieu of typing, pressing the File button invokes a TIN file dialog where the required file may be selected. 
 
Label Feature 
Four options are available to select the type of label to be placed as detailed below: 

 
 Select GEOPAK or MS Element 
Press this button, and then select the GEOPAK or MicroStation element you wish to label. The 

labeling options change to reflect values appropriate for the selected element type. 
 
Data Point Location 
Press this button, and then issue a data point on the screen. The labeling options change to 

reflect values appropriate for a data point. 
 

2 GPK Point Line 
Press this button, and then select any two visualized COGO points. The labeling options change 

to reflect values appropriate to labeling a line. 
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3 GPK Point Arc 
Press this button, and then select three visualized COGO points representing the PC, PT and CC 

of a curve. The labeling options change to reflect values appropriate to labeling an arc. 
 
As you compose the label, the content of the label is displayed in the upper right field of the Labeler 
dialog. You can compose the label by keying in text, or by use of the Computed Inserts or the User 
Inserts. 
 
Computed Inserts 
One of the most powerful features of the labeling tools is the use of Computed Inserts. The Computed 
Inserts are values computed by GEOPAK for various labeling items such as Station, Offset or Elevation. 
The list of available Computed Inserts changes based on the element type being labeled (i.e., point, line, 
curve, etc.). Once these inserts are added to a label, their values are automatically recomputed during 
subsequent element identification. Two examples of the available Computed Inserts are shown below: 
 
Data Point Location  Select GEOPAK or MS Element (Line) 

  
 
To use a Computed Insert, highlight the desired variable and the computed value is displayed below the 
Computed Text list box as shown in the examples above. If the value cannot be computed because of 
missing information or computing error, the dialog will display "N/A" or "Error". The decimal precision of 
the inserts can be controlled with the drop down list as shown above. Double clicking the Computed 
Insert adds it to the label at the current cursor position in the label editing field.  
 
User Inserts 
A customizable list of User Inserts is available to assist the user in building labels containing commonly 
used words or phrases. These words or phrases can be inserted in the label by selecting them from a list 
instead of typing them in manually. Commonly used User Inserts can be saved in an ASCII text file for 
future access. 
 
GEOPAK supports an unlimited number of user insert files. Each line of the file is one word or phrase 
followed by a space. In this way, when two words are placed together by successive data points, a space 
is placed between them. Several ASCII text insert files are located in the 
default GEOPAK directory. 
 
When the User Insert toggle is active, the icons for file manipulation are 
displayed as shown at left. The far left icon edits the current text file, while 
the second icon opens an insert file. The third icon (disk) saves the current 
file, while the fourth icon is the Save As…. option. The last two sort the 
current insert file in ascending or descending alphabetical order. 
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Tip: 
If the value of a computed 
text insert is manually 
edited within the labeler 
dialogs, it loses the 
intelligence of a computed 
label. The computed text 
insert becomes inserted 
text and will no longer be 
computed when 
subsequent labels are 
placed. 

10.3  Label Edit Field 

The Label Edit Field, located to the upper right of the Labeler dialog, is used to display the text of the 
current label. The label can be constructed by manually typing in text into the display or by adding 
selected Computed Inserts or User Inserts. An example of a Data Point Location station and offset label 
that was created by a combination of keyed in text and computed inserts is shown in the dialog below. 

 
When subsequent data points are issued the Computed Inserts are automatically updated to reflect the 
current data point location. 
 
The five buttons under the Label Edit field function as follows: 
 

Space 
Press to add a Space within a label. A single space is added 
with each pressing of the button. 
 
Return 
Press to add a Return within a label and move to the next 
line down. 
 
Clear 
Press to clear the entire label from the label display window. 
 
Delimit 
Press to place a delimiter between lines. 
 
Place Label 
When the label is constructed and ready to place, press this button, then move the cursor for 
dynamic placement. 

 
   
 
 



Ohio Department of Transportation, GEOPAK Road Training Guide October, 2012 

 

  

Page 10-6 Chapter 10 – Plan View Labeling  
 

10.4  Parameters Options 

When the Parameters tab is selected the dialog changes, as shown below, to control the text 
parameters of the label. 

 
Text Preferences / Symbology 
This portion of the dialog, as shown above, is used to set the text parameters and symbology. Four icons 
are available at the bottom of the dialog to facilitate setting these parameters: 
 

 By Current 
After pressing this button, GEOPAK determines the active MicroStation symbology (level, 
weight, color and style) and populates the dialog. 
 

 By Element 
After pressing this button, GEOPAK prompts the user to select a previously drawn MicroStation 
element, and populates the dialog with its element symbology. 
 

 By D&C Symbology 
After pressing this button, the user can select a D&C Manager item to set the element 
symbology. 
 

 Set All 
GEOPAK reads the current settings (level, weight, color and style) within the dialog, and 
populates the similar fields in the Shape and Leader dialog tabs. 
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10.5  Shape Options 

When the Shape tab is selected the dialog dynamically changes, as shown below, to set type and 
symbology of a surrounding shape. 

 
Shape Preferences 
Twelve shape selections are available plus a no shape option, as shown above. The shape drawn is 
proportional to the size of the label. As the label gets larger, the shape is expanded to fit. 
 
Shape Offset 
This key-in field is used to specify the distance from the edge of the text to the shape. 
 
The Level Symbology options are similar to those described for the Params. tab. 
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10.6  Leader Options 

When the Leader tab is selected the dialog dynamically changes, as shown below, to provide control 
settings for the type of leader and leader terminator. 

 
Leader Type 
Four leader types, plus a no leader option are supported. Depending on the type selected, the user is 
prompted for data point(s) to provide maximum flexibility over location of the leader. Each shape has 
several origination points around the circumference to accommodate leaders. 
    
Terminator 
Supported options include No terminator, closed arrow, open arrow, and active terminator. To use the 
active terminator, the MicroStation line terminator must be defined and the cell library containing the 
terminator must be attached. If a terminator is selected and no cell library is attached, an alert message 
is displayed. 
 
Symbology 
The Level Symbology options are similar to those described for the Params. Tab. 
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10.7  Rotation Options 

When the Rotate tab is selected, the dialog dynamically changes, as shown below, to set the rotation 
options for the label. Note that these commands can also be issued from the Label Control tool frame 
before or during label placement. 

 
Current Angle 
This option is used to place a label at the current active angle, or to key in the angle for the label. 
 
Element Angle 
This option is used to set the label angle according to the angle along a MS graphic element. 
  
Alignment Angle 
This option is used to rotate a label, either before or during placement, at an angle relative to a Chain. 
First specify the Job No. and the Chain in the Text tab. 
 
Set Angle By 
Three options are supported: DP, Element and AA (Active Angle.) 
 
An example of a completed label is shown below. 
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10.8  Styles Options 

When the Styles tab is selected the dialog dynamically changes, as shown below, to create, modify, or 
use a previously defined Label Style. 

 
One of the most useful tools of the labeler is the ability to store and reuse labels. The Computed Inserts, 
User Inserts, Shapes, Leaders, element and Text parameters of the label can all be stored under a 
unique name. This enables the user to create a complete library of labels to use in subsequent sessions. 
The styles are stored in *.lsf files, with default files for plan label styles (def_plan.lsf) delivered with the 
GEOPAK software. 
 
New style files can be created, opened, and saved via the Style Files pull-down menu in the upper left 
corner of the main dialog. With each style file, a hierarchy system is employed to easily and quickly 
organize and subsequently locate the desired label styles. The user has complete control over the 
naming of categories and labels within each category. Several utilities are supported within the dialog 
for creating, editing and renaming styles, which are detailed below. 
 

 Rename Style / Category 
To rename a style or category, simply highlight the item to be renamed, and then press the Rename 
Style button to access the dialog shown below. 

 
Change the name, and then press the OK button. The display list dynamically changes to reflect the new 
name. 
 

 Create Style Category 
This icon is used to create a new category. 
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 Delete Style Category 
This icon is used to delete the selected category 
 

 Refresh Style List 
To refresh the style list, simply press the Refresh button. 
 
If a Style Name is selected in the Labeler dialog, the following options are available: 
 

 Select Style Item 
Pressing this button makes the current highlighted style the active style. 
 

 Delete Style Item 
Pressing this button deletes the current highlighted style.  
  

 Copy Style Item 
If two labels are similar, it is more efficient to copy a label style, then modify and save, rather than 
creating a completely new style. To accomplish this, highlight the style item to be copied, then press the 
Copy Style Item button, and a copy of the style is created. 
  
Update Style 
After modifying a style, the user may want to update the style to include the current modifications. 
Simply press the Update Style button to invoke the dialog shown below. Both From: and To: labels are 
shown so the user can easily discern the changes. 

 
Press OK to accept the update, while Cancel simply 
closes the dialog with no updating occurring. 
 
 
 
 
 
 
 
 
 

 
Style Preview 
This window displays the current style. Note: The label is scaled to fit the entire label within the preview 
window and is not indicative of the scale at the time of placement. 
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Tip: 
Before you can save a label 
you must first place the 
label in the design file. The 
New Style… button will 
remain ghosted until you 
place the label. To save the 
label in the style file select 
the category where the 
label is to be stored, and 
press the New Style… 
button. 

Complete Style / Node and Shape Only 
 

 
 
Two options are supported when creating a new style. The entire layout of the label can be retained, or 
simply the Node and Shape, without the leader line options, etc. 
 
New Style… 
Select this button to create a new style from the current label. The Create Style dialog, shown below, is 
opened. Key in the new Style Name and Style Scale. 

 
When complete, press the OK button to store the new style, which is added to the Item Selector list 
box. In order to retain the style after closing the labeler, perform a Style Files > Save before exiting. 
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10.9  Menu Options 

The menu bar options include: 
 
Style Files – File utilities to create, open and save stored Style files containing stored label layouts. 
 
Options – User definable options for tool and dialog control over labeling functions. 
 
Scale – Proportionalizes any label in addition to displaying the current scale. 
 
Tools – Provides access to the Label Updater, Selection Set Labeling, and Plan Label Preferences tools. 
 

10.9.1 The Style Files Pull-Down Menu 

 
The Style Files menu provides options to open, and save Style libraries as shown above. In order to un-
ghost the entire Style Files pull-down menu, you must select the Styles tab.  
 

10.9.2 The Options Pull-Down Menu 

Five options are supported under the Options pull-down as detailed below. 

 
Minimize Dialog 
If this option is toggled on, when the Place Label button is pressed the main labeling dialog will 
automatically minimize as shown below. The Label Viewer dialog and the Plan View Label 
Control tool palette, also shown below, will automatically open.  
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Use Reference File Coordinates 
When working with elements within a reference file, it is useful to use the reference file 
coordinates, rather than those of the current active file. Simply activate the toggle and 
subsequent computed text inserts using reference file elements or data points will reflect the 
reference file coordinates. If the snap and locate settings in the reference file are active. 
 
Use DP Element Association 
This option will enable the association between MS elements and DP (data point) labels that are 
snapped to the element. If the element is modified, the point labels will move with the element 
when the Label Update feature is used. Note: This only applies to elements within the active 
design file. 
 
Label Tools   

 
The Plan View Label Control tool palette contains numerous tools that are useful during the 
placement of labels. The tools are detailed below. 
 

 Rotate Label to Active Angle 
This option is used to rotate a label, either before or during placement, to the active angle.  
 

 Rotate Label By Element Angle 
Utilized to rotate a label to the angle of a MS graphic element. GEOPAK prompts the user to 
select the element. 
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 Rotate Label by Two Data Points 
Utilized to rotate a label to an angle between two data points. GEOPAK prompts the user for the 
two data points. 
 

 Rotate Label 180 
Utilized to rotate a label 180 degrees from the current rotation of the label. 
 

 Rotate Label by Alignment Angle  
Utilized to rotate a label at an angle relative to a Chain. First, in the Text tab of the main dialog, 
specify the Job No. and the Chain. 
 

 Increase Text Size 
Each press of this button increases the text size of the dynamic label by the scale specified in the 
dialog. 
 

 Decrease Text Size 
Each press of this button decreases the text size of the dynamic label by the scale specified in 
the dialog. 
 

 Data Point 
This button is a shortcut for the DP button located on the main dialog. 
 

 Identify Element 
This button is a shortcut for the Identify Element button on the main dialog. 
 

 2 GPK Point Line 
This button is a shortcut for the 2 GPK Point Line button on the main dialog. 
 

 3 GPK Point Arc 
This button is a shortcut for the 3 GPK Point Arc button on the main dialog. 
 

 Edit Label 
After selecting the Edit Label tool, GEOPAK prompts for the selection and acceptance of a 
previously placed label. The label must have originally been placed with the GEOPAK labeler, not 
simply MicroStation place text or note commands. Once accepted, the GEOPAK labeler 
dynamically changes to reflect all parameters of the selected label. Make any necessary edits to 
the label and then select Place Label and replace the label. 
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 Move Label 
Once a label has been placed with any of the GEOPAK labelers, it can be easily moved. Note the 
data points for any leader lines are not retained and must be placed again. 
 

 Extract Label 
To place several labels similar to a previously placed label, the user does not have to know the 
style, sizes, etc. GEOPAK loads the style as well as all required element and text parameters. 
 

 Place Label 
Select this button to initiate label placement. 
 

 Restore Label Dialog 
When the main dialog is minimized, pressing this button restores the main dialog to full size. 

 
 
Label Viewer 
When the Label Viewer option is selected, the Label View dialog displayed as shown below. 

 
A single label can be placed by pressing the Place Label button, and then issuing a data point at the 
desired location. The Automatic Label option is only supported when the sample label includes 
computed text inserts. When the Automatic Label button is pressed and a data point is selected, the 
placed label includes the updated computed text inserts in the same style as the original label. 
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10.9.3 The Change Scale… Pull-Down Menu 

 
This menu item allows labels to be scaled from their original creation scale. For example, if a label was 
created with a text scale of one (TH = 0.14, TW = 0.14) and is to be used on a 20 scale plan sheet, 
changing the scale from one (1) to 20 would set the size of all the items contained in the label to the 
correct scale. 
 

10.9.4 The Tools Pull-Down Menu 

The Tools pull-down menu contains the options shown below. 

 
These options are summarized below. See the GEOPAK online help for more information regarding the 
tools. 
 
Label Updater 
The Label Update tool is a powerful tool for updating GEOPAK labels. 
When alignments are modified, TIN files updated, labels moved, etc., 
GEOPAK "remembers" the computed text information used in the 
placement of the original label. Therefore, the software can update the 
label based on updated data. The tool utilizes the dialog shown at right 
and is invoked by selecting Tools > Label Updater from the menu bar in 
the main Label dialog. 
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Selection Set Labeling 
The Selection Set Label tool is a powerful tool for placing or updating labels within a selection set. The 
workflow is as follows: 
 

 Select a style from the Styles tab. 
 From the labeler menu bar, select Tools > Selection Set Labeling. 
 Populate the dialog as desired. 
 Using the Power Selector or MicroStation selection set commands, identify a selection set. 
 Click Apply to commence the procedure. 

 
 
Plan Label Preferences 
The Plan Label Preferences dialog is used to set default labeling options. To set or activate the Label 
Preferences, toggle on the Use Label Preferences at the top of the dialog. 

 
 
 
 
 
 
 


	GEOPAK V8i SS1 Road 1

	Table of Contents

	1 Getting Started
	1.1 Course Prerequisites
	1.2 Course Schedule/Conduct
	1.3 GEOPAK Support
	1.4 ODOT CADD Standards for MicroStation and GEOPAK
	1.4.1 Standard Directory Structure
	1.4.2 Standard MicroStation Design File Names

	Exercise 1A, Directory Structure
	1.5 GEOPAK File Types
	Exercise 1B, Training Files
	1.6 Working with Existing Ground Survey and Aerial Mapping
	1.6.1 Model Annotation Scale
	1.6.2 Model Annotation Scale and Reference Attachments
	1.6.3 Editing Pre-V8i data for use with the Model Annotation Scale
	1.6.4 Survey Data Levels

	Exercise 1C, Survey Data
	1.7 Activating GEOPAK
	1.8 Accessing GEOPAK Road Functions
	1.9 GEOPAK User Preferences
	1.9.1 Feature Preferences…
	1.9.2 COGO Preferences…


	2 Digital Terrain Models
	2.1 What is a Digital Terrain Model?
	2.2 DTM Feature and File Types
	2.3 The DTM Tool Frame
	2.4 Load DTM Features
	2.4.1 Plotting Triangles
	2.4.2 Plotting the Tin Hull
	2.4.3 Plotting Contours
	2.4.4 Contour Label Editor

	2.5 Height / Slope Tool
	2.6 Profile Tool
	2.6.1 Object Selection Tab
	2.6.2 Create Profile Tab
	2.6.3 Profile Preferences Tab


	3 Coordinate Geometry
	3.1 Introduction
	3.2 COGO Processing
	3.3 COGO Element Naming Conventions
	3.4 Customizing the COGO Dialog
	3.5 Visualizing COGO Elements
	3.6 Redefine
	3.7 The COGO Element Menu
	3.7.1 Element Menu: Point Commands
	3.7.2 Element Menu: Line Commands
	3.7.3 Element Menu: Curve Commands
	3.7.4 Element Menu: Spiral Commands
	3.7.5 Element Menu: Chain Commands
	3.7.6 Stations and Station Equations
	3.7.7 Element Menu: Parcel Commands
	3.7.8 Element Menu: Profile Commands
	3.7.9 Element Menu: Next Available Settings

	3.8 The COGO Tools Menu
	Exercise 3A – Existing State Route 185
	Exercise 3B – Existing Jameson Road
	3.9 The COGO Navigator
	3.9.1 Add Element
	3.9.2 Delete Element
	3.9.3 Edit Element
	3.9.4 Identify Element
	3.9.5 Visualize Element
	3.9.6 Print/Describe
	3.9.7 Selection Tool
	3.9.8 Navigator Settings

	Exercise 3C – Proposed State Route 185
	Exercise 3D – Proposed Jameson Road
	3.10  The COGO File Menu
	3.11  The COGO Edit Menu
	3.12  Working with COGO Input and Output Files
	3.12.1 Saving an Input File
	3.12.2 Saving an Output File
	3.12.3 View > Command Output > Save Content As
	3.12.4 Loading, Editing, and Reprocessing an Input File
	3.12.5 Make Input File

	Exercise 3E – COGO Input and Output Files
	3.13  Graphical COGO
	3.14  Horizontal Alignment Generator
	3.15  Multicenter Curve Tool
	3.16  Store Graphics
	COGO Exercise 3A – Answers
	COGO Exercise 3B – Answers
	COGO Exercise 3C - Answers
	COGO Exercise 3D - Answers
	COGO Exercise 3E – Answers

	4 Project Manager
	4.1 The GEOPAK Project Manager
	4.1.1 Creating a new GEOPAK Project
	4.1.2 Project Users
	4.1.3 The Road Project Dialog
	4.1.4 GEOPAK Project Directory Structure
	4.1.5 The Working Alignment
	4.1.6 Pattern and Cross Section Placement Symbology
	4.1.7 Creating “Runs” in Project Manager

	Exercise 4

	5 Design & Computation Manager
	5.1 Overview
	5.2 ODOT Standard D&C Manager Database
	5.3 D&C Manager Database Structure
	5.3.1 Categories
	5.3.2 Items
	5.3.3 ODOT.ddb Categories

	5.4 Design Mode
	5.4.1 Design Settings and the Model Annotation Scale
	5.4.2 Using "Place Influence" With MicroStation Commands
	5.4.3 Placing “Cosmetic” cells using the active Model Annotation Scale
	5.4.4 Placing “Physical” Cells Using the Model Annotation Scale
	5.4.5 Placing Drainage Cells (Catch Basins, Manholes, Inlets, and Headwalls)
	5.4.6 Using Place Influence with Curvilinear Features and Custom Line Styles
	5.4.7 Placing “Cosmetic” Line Styles using Place Influence
	5.4.8 Placing “Physical” Line Styles using Place Influence

	5.5 Using Design Mode to Plot COGO Elements
	5.5.1 Plotting COGO Elements Utilizing Report or Calculator Items
	5.5.2 Plotting COGO Elements Using Paintbrush Items
	5.5.3 Plotting COGO Chains
	5.5.4 Plotting Stationing

	5.6 Identify Item
	5.7 Display Mode
	5.8 Set Mode
	5.9 Favorites
	5.10  Toolbox Mode
	Exercise 5

	6 Drafting Tools
	6.1 Overview
	6.2 DP Station Offset
	6.3 Draw Cell by Feature
	6.4 Draw Cell Group by Feature
	6.5 Draw Transition
	6.6 Active Chain Control
	6.6.1 Curvilinear Coordinates
	6.6.2 Profile Cell Status

	Exercise 6
	6.7 Pavement Markings Tools
	6.7.1 Striping
	6.7.2 Separation
	6.7.3 Chevron Diverge

	Exercise 6B

	7 Existing Ground Profiles
	7.1 Overview
	7.2 Profile Basemap Design File
	7.3 The Ground Profile Dialog
	7.4 Reviewing Profile Information with COGO
	7.4.1 Profile Utility
	7.4.2 Profile Elevation
	7.4.3 Offset Profile
	7.4.4 Restation Profile

	7.5 Adding Profile Information To The Working Alignment
	7.6 Plotting Existing Profiles With D&C Manager
	7.7 The Draw Profile Dialog
	7.8 Profile Grid
	Exercise 7

	8 Proposed Vertical Alignments
	8.1 The Vertical Alignment Generator
	8.2 File Operations
	8.2.1 Preferences
	8.2.2 Profile Cell Settings
	8.2.3 K-Value Table
	8.2.4 Load Profile
	8.2.5 Save Profile, Save Profile As
	8.2.6 Clear Profile
	8.2.7 Draw Profile

	8.3 The Tools Menu
	8.3.1 Issue Data Point
	8.3.2 Critical Points
	8.3.3 Best Fit

	8.4 Storing VPI’s
	8.5 Defining Vertical Curves
	8.6 Profile Navigation
	8.7 Reviewing Proposed Profiles in COGO
	8.8 Plotting Proposed Profiles with D&C Manager
	Exercise 8A – S.R. 185 Profile
	Exercise 8B - Jameson Road Profile (if time permits)
	8.9 Component Based Vertical Alignment Design Tools

	9 Plan and Profile Sheets
	9.1 Overview
	9.2 Sheet Layout Files and Configuration Variables
	9.3 Plan and Profile Sheet “Ports”
	9.4 Clipping Borders
	9.5 Placing Profile Elevations for the Tabular Port
	9.6 The Plan Sheet Layout Dialog
	9.6.1 File Menu
	9.6.2 View Menu
	9.6.3 Settings Menu
	9.6.4 Tools Menu

	9.7 Process Sheets: Customize With Motif Files
	9.7.1 Configuring the Plan Motif File
	9.7.2 Configuring the Profile and Tabular Motif File
	9.7.3 Sheet Clipping Borders
	9.7.4 Plan Sheet Layout: Settings
	9.7.5 Plan Sheet Layout: Sheet Composition
	9.7.6 Plan Sheet Layout: Layout Sheets
	9.7.7 Plan Sheet Layout: Clip Sheets

	9.8 Processing Sheets: Use Current Design File
	9.8.1 Configuring the Clipping Border Design File
	9.8.2 Plan Sheet Layout: Sheet Composition
	9.8.3 Plan Sheet Layout: Layout Settings
	9.8.4 Sheet Layout: Clip Sheets

	9.9 Modify Sheets
	9.10  Sheet Number Manager
	9.11  Sheet and Motif File Properties
	Exercise 9

	10 Plan View Labeling
	10.1  Overview
	10.2  Text Options
	10.3  Label Edit Field
	10.4  Parameters Options
	10.5  Shape Options
	10.6  Leader Options
	10.7  Rotation Options
	10.8  Styles Options
	10.9  Menu Options
	10.9.1 The Style Files Pull-Down Menu
	10.9.2 The Options Pull-Down Menu
	10.9.3 The Change Scale… Pull-Down Menu
	10.9.4 The Tools Pull-Down Menu



