
ODOT User Guide for StormCAD  
          

January 17, 2014 Sheet 1 of 33 

Table of Contents 
 
Disclaimer...................................................................................................................................................... 2 
Introduction .................................................................................................................................................. 3 
Installation .................................................................................................................................................... 4 
Activation and Settings ................................................................................................................................. 5 

StormCAD for MicroStation ....................................................................................................................... 5 
StormCAD Toolbars ................................................................................................................................... 5 
ODOT Standards ........................................................................................................................................ 5 

Using StormCAD ............................................................................................................................................ 6 
Starting a New Project ............................................................................................................................... 6 
Layout ........................................................................................................................................................ 8 

Default Settings ..................................................................................................................................... 8 
Nodes ..................................................................................................................................................... 8 
Links ....................................................................................................................................................... 9 
Catchments ............................................................................................................................................ 9 
Labels ..................................................................................................................................................... 9 

View ......................................................................................................................................................... 10 
Properties ............................................................................................................................................ 10 
FlexTables ............................................................................................................................................ 10 
Prototypes ........................................................................................................................................... 12 
Element Symbology ............................................................................................................................. 13 
Element Levels ..................................................................................................................................... 14 

Components ............................................................................................................................................ 15 
Engineering Libraries ........................................................................................................................... 15 
Catalogs ............................................................................................................................................... 15 
Storm Data ........................................................................................................................................... 17 
Default Design Constraints .................................................................................................................. 19 

Design and Analysis ................................................................................................................................. 20 
Scenarios .............................................................................................................................................. 20 
Alternatives .......................................................................................................................................... 21 
Calculation Options.............................................................................................................................. 23 
User Notifications ................................................................................................................................ 23 
Compute .............................................................................................................................................. 23 
Putting It All Together (Storm Sewer System) ..................................................................................... 24 

Review Results ......................................................................................................................................... 26 
Reports ................................................................................................................................................. 26 
Profiles ................................................................................................................................................. 28 

Drainage Basemap ...................................................................................................................................... 29 
ODOT CADD Standards ............................................................................................................................ 29 

Additional StormCAD Capabilities ............................................................................................................... 31 
Pavement Drainage ................................................................................................................................. 31 
Ditch Design ............................................................................................................................................. 32 
Advanced Features .................................................................................................................................. 33 



ODOT User Guide for StormCAD  
          

January 17, 2014 Sheet 2 of 33 

Disclaimer 
The ODOT StormCAD Standards provided do not exempt the professional from performing responsible 
engineering. This document along with the ODOT custom seed files are for public use, however no ODOT 
support will be provided. There are no expressed or implied warranties concerning the accuracy, 
completeness, reliability or usability of this information. Further, ODOT assumes no responsibility for 
any incorrect results or damage resulting from the use of this information. All users shall expressly hold 
ODOT harmless from any liability or loss due to any computer or software generated problems 
associated with this product. The professional shall have final responsibility for the accuracy of all input 
and output of computer-based applications and any technical issues or questions that may arise. 
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Introduction 

What Is StormCAD and Why Do We Want to Use It? 
Bentley StormCAD is a software product that allows the user to design a new storm sewer system or 
analyze an existing system. As an alternative to the ODOT CDSS storm sewer modules, StormCAD is 
customizable and supports ODOT drainage design criteria (see Location and Design Manual, Volume 2). 
It also performs pavement spread, inlet bypass and open channel flow calculations, but this document 
focuses on the storm sewer applications.  
 
With the StormCAD graphical interface, the designer creates either a schematic network or storm sewer 
system drawn to scale. StormCAD for MicroStation operates in the familiar CADD environment, uses 
standard ODOT levels and line styles, and supports drainage basemap development.  
 
StormCAD for MicroStation is featured in this document. It is interoperable with the standalone mode 
and provides the same functionality, computations and reporting capabilities. The steps presented for 
hydraulic design and analysis are also applicable to the standalone mode, and most of the tools, icons 
and dialog boxes are identical. 
 

Additional Resources 
Bentley StormCAD Help (StormCAD Help Menu) – includes quick start lessons plus comprehensive 
guidelines for creating a project, calculating the model, presenting results, engineering theory, and 
features of the MicroStation workspace environment. This information is also available in .pdf format as 
the StormCAD V8i User’s Guide (installed with program on the hard drive). 
 
Bentley Technical Support (http://selectservices.bentley.com/en-US/) – for StormCAD technical 
support, it is recommended that you take advantage of the Bentley Knowledge Base or Service Request 
Manager. You will need to sign in, and you can contact your CADD administrator if you need assistance 
with setting up a Bentley account. 
 
Bentley Learn Server (http://learn.bentley.com) – has extensive on-demand training with lectures and 
hands-on exercises (Storm Sewer Design and Modeling using StormCAD Learning Path). The StormCAD 
standalone version is featured. Please see your CADD administrator for help with getting started. 
 

Software Versions 
This user guide was developed using the following software versions: 
 

StormCAD V8i (SELECTseries 3) v08.11.03.83 
MicroStation V8i (SELECTseries 3) v08.11.09.459 

 
StormCAD SELECTseries 3 is compatible with MicroStation SELECTseries 2 and does not require an 
upgrade to MicroStation SELECTseries 3. If MicroStation is already on the machine when you install 
StormCAD, it should integrate automatically. 
 
Important: StormCAD V8i (SELECTseries 3) v08.11.03.83 is not compatible with GEOPAK SELECTseries 3. 
There is a new release of StormCAD,  version 08.11.03.84, that was released after this documentation 
was complete.  This version resolves the compatibility issue with GEOPAK SELECTseries 3. Although 
StormCAD for MicroStation and GEOPAK are not intended to be integrated products, they  share the 
MicroStation interface.  

http://learn.bentley.com/
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Installation 

Before You Start 
 StormCAD V8i (SELECTseries 3) works best when installed on a system with MicroStation V8i 
(SELECTseries 3).  If GEOPAK Suite V8i (SELECTseries 3) is installed, then StormCAD V8i (SELECTseries 3) 
v08.11.03.84 must be used.  
 
You must also make sure that you have the ODOT Standard StormCAD sub-directory in your 
ODOTstd\V8istd directory. For an ODOT installation, verify that you have an 
I:\ODOTstd\V8istd\StormCAD folder. If not, please ask your CADD Administrator to update ODOTstd 
from the Central Office site.  This directory contains ODOT’s Engineering Libraries, StormCAD project 
seed file, FlexTables and Properties settings, and this documentation. The I:\ODOTstd\V8istd directory 
includes three additional StormCAD for MicroStation files: stm.cel, stormcad.ucf and 
StormCADSeed.dgn, found in the cell, config and seed folders, respectively.  
 

Installation 
You must have administrator privileges to perform the installation. 
 
 For a typical ODOT installation, the StormCAD software is found in: 
 \\itcfs007\support1\Win7Software - PC\Bentley\StormCAD\stmc08110383en\. Run Setup.msi and 
accept the defaults. After installation, run: 
 \\itcfs007\support1\Win7Software - PC\Bentley\StormCAD\sewergems08110383en.exe to install the 
latest patch.  
 

The desktop shortcut for the standalone version probably needs to be modified. The target should be 
"C:\Program Files (x86)\Bentley\StormCAD8\StormCAD.exe". There is a separate StormCAD.exe file in 
the x64 subdirectory that creates error messages if launched. 
 

User Configuration Setup 
Each user will need to copy the MicroStation User Configuration File for StormCAD (stormcad.ucf), from 
I:\ODOTstd\V8istd\config to the user’s home drive location. For an ODOT installation the location will be 
W:\BentleySS3. 
 
The final step is optional but recommended. Copy the following FlexTables and Properties files located 
in the ODOTstd\V8istd\StormCAD directory, and then replace the default files installed by StormCAD in 
the C:\Users\username\AppData\Local\Bentley\StormCAD\8 directory: 
 

 AttributeFlexTables.xml 

 FlexTables.xml 

 PredefinedFlexTables.xml 

 SharedWorkspaces.xml 
 
These settings affect information display (shared and predefined FlexTables and Properties). 
 
Note: The first time you use StormCAD for MicroStation, you may notice that your individualized 
MicroStation environment and workspace preferences (e.g., toolbars, dual monitors, etc.) have reverted 
to default settings. Find the familiar toolbars (Tools > Tool Boxes) and adjust the workspace preferences 
as desired. 
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Activation and Settings 

StormCAD for MicroStation 
When StormCAD for MicroStation is launched, the MicroStation File Open dialog box appears. The User 
should be set to stormcad and the Project should be ODOTV8iSS3. After a .dgn file is opened, the 
StormCAD pull-down menu appears on the main toolbar. This menu contains some features that are not 
accessible in the StormCAD toolbars. 
 

StormCAD Toolbars 
In MicroStation mode, the StormCAD toolbars (e.g., View, Layout, Compute, etc.) are found under the 
MicroStation Tools Menu (Tools > Tool Boxes). They are also located in the Tasks Dialog. The StormCAD 
toolbars and dialog boxes are dockable and can be pinned if desired. This document covers the tools and 
icons most frequently used. Full explanations can be found in Bentley StormCAD Help. 
 

 

ODOT Standards 
The StormCAD project seed file (StormCADSeed.stws) incorporates ODOT standards with the following 
customized features: Engineering Libraries, Catalogs, Storm Data, Default Design Criteria, User Data 
Extensions, Element Symbology, Prototypes, Project FlexTables and Reports, Property Grid 
Customization, Alternatives, Calculation Options, Scenarios and Project Options. 
 
The MicroStation seed file (StormCADSeed.dgn) affects placement of new StormCAD elements on ODOT 
standard levels (StormCAD for MicroStation Element Levels feature). 
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Using StormCAD 

Starting a New Project 
A StormCAD for MicroStation project requires three files – one MicroStation .dgn file attached to two 
StormCAD project files (.stws, .mdb). Starting a new project requires three steps. 

 
1. Create new .dgn file from seed (ODOTstd\V8istd\seed\StormCADSeed.dgn). If starting with the 

StormCAD standalone version, the project can be attached to a .dgn file later if desired. 
 

 
 

2. Attach new StormCAD project file from seed (StormCAD > Project > Seed > New from Seed). 
Navigate to ODOTstd\V8istd\StormCAD\seed\StormCADSeed.sews. The seed file creates 
multiple untitled StormCAD project files at the default location on the user hard drive 
(C:\Users\username\AppData\Local\Temp\Bentley\StormCAD). The ODOT customized settings 
outlined in this document are dependent on these seed files. 

 

 
 

3. Save attached project file to the appropriate directory (StormCAD > Project > Save Attached As). 
The default file name is the .dgn file name with the .stws extension. Navigate to the appropriate 
project directory (the default prompt is W:\MyDocuments\Bentley\StormCAD). 
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Notes: 

 A new StormCAD project can also be attached to an existing .dgn file (e.g., drainage basemap). 
You can lay out a StormCAD system on top of features previously drawn on drainage levels. In 
this case, it would probably be best to use the StormCAD levels so that duplicate/overlapping 
elements can be turned off when plotting construction plans. See the Element Levels section of 
this document to change the default levels for placing new StormCAD elements. 
 

 It is a good idea to edit the Project Properties. (StormCAD > Project > Project Properties). All 
report headings include the Project Title, which defaults to the project file name (.stsw) if left 
blank. The Project Inventory Report also includes the additional fields (Engineer, Date, etc.). 
 

 StormCAD for MicroStation autosaves as you go. The standalone mode requires manual saves. 
 

 Sharing a StormCAD project with another user requires both the .stws and .mdb files. The .dgn 
file is not necessary for non-MicroStation users. 
 

 You might get a pop-up message, “About to compact database.” This is not necessary, and if 
desired, this feature can be turned off (StormCAD > Tools > Options > Global). 
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Layout 
After starting a project, the first step is to create the 
system using the graphical interface and StormCAD 
Layout tools. The StormCAD Layout toolbar includes 
links, nodes and catchments, and the tools are similar 
to using MicroStation Place Line, Place Active Cell, and 
Place Shape, respectively. 
 
Before placing new elements, however, it is a good 
idea to review a few settings. 

Default Settings 

The StormCAD for MicroStation Element Levels feature (StormCAD > View > Element Levels) controls 
the default MicroStation levels on which new items and annotations will be placed. The levels can be 
changed later with normal MicroStation tools if necessary (Change Element Attribute, etc.). 
 
 
 

 
 
 

 
 
 
The Prototypes feature (StormCAD > View > Prototypes) controls the 
default StormCAD attributes (e.g., catch basin type, conduit length to scale, 
etc.) of new elements placed. Later the elements are edited with FlexTables 
or the Properties dialog. For more details about Element Levels and 
Prototypes, see the View section of this document. 

Nodes 

The Layout toolbar includes the following node elements: catch basin, manhole, transition, cross section 
and outfall (every system requires an outlet node). The cell library (stm.cel) includes only one cell for 
each type of element (e.g., a square symbol for all catch basins). Click on the icon to activate the layout 
tool or use the dropdown menu (StormCAD > Tools > Layout). You may prefer to place the cell features 
on the fly while laying out conduit (see Links), but nodes can also be placed first using MicroStation 
precision placement tools (e.g., Snaps, AccuDraw, etc.). StormCAD permits node morphing or link 
splitting when you place a node on top of an existing element. 
 

                

Catch Basin 

Manhole 

Outfall 

Catchment Conduit 
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Links 

The Layout toolbar includes the following link elements: conduit, channel and gutter. For storm sewer 
systems, connect the nodes with conduits. If you want to place nodes on the fly, a manhole is the 
default conduit end. This can be set to catch basin in the Layout Conduit tool dialog. Alternately, you can 
take advantage of the morph node feature for elements that have already been placed. 
 
Links require a node on both ends. If you delete a node, any attached links will also be deleted. If you 
move a node, the link geometry is automatically modified. 
 
StormCAD is capable of performing culvert inlet control equations for open-ended storm sewers. From 
the Properties dialog, edit the Physical (Culvert) attributes (e.g., Is Culvert? True). You can use a 
“transition” node at the inlet end in lieu of a catch basin. In general, however, StormCAD should not be 
used for culvert calculations (HY-8, the FHWA Culvert Analysis Program is an excellent alternative to the 
ODOT CDSS culvert analysis modules). 

Catchments 

The Layout toolbar includes a catchment element. Drainage areas are represented as polygons, and they 
can be drawn to scale if desired. The catchment layout tool is slightly different than the normal 
MicroStation Place Shape. Click to place the vertices and then finish with a right click. 
  

 
 
You will use FlexTables or the Properties dialog to connect the drainage areas to nodes and edit the 
StormCAD attributes for all elements. For more details, see the View section of this document. 
 
Note: A StormCAD model generally requires catchments as well as an outfall. 

Labels 

The label prefix and numbering is controlled by StormCAD Options (StormCAD > Tools > Options > 
Labeling). System elements should generally be placed in order from upstream to downstream for the 
best results when reviewing tabulated data. Element Symbology (StormCAD > View > Element 
Symbology) affects label placement and annotation properties as well as the element appearance (e.g., 
red lines for conduits).  
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View 
The View menu (StormCAD > View) includes several key StormCAD features. 

 
 
 
 
 

 

Properties 

The StormCAD Property Editor dialog box is 
similar to MicroStation Element Information – it 
is used for viewing and editing information for 
elements and prototypes, and it is also used for 
scenarios and calculation options. 
 
Click on an element in the drawing view to 
activate the Properties dialog, or use the search 
box/dropdown menu at the top to select an 
element. The dialog also includes buttons to 
Navigate Upstream/Downstream. 
 
The number of element attributes can be 
overwhelming. The element attributes are 
organized by category. Use the plus/minus 
button next to the heading to expand/contract a 
category. The default profile is <Show All>. 
Select Custom Properties (Project) from the 
dropdown menu to hide some attributes and 
categories (advanced users might want to use 
the Propertygrid Customizations feature to 
create or edit a Shared profile). 
 
The fastest way to edit text or data is to click on 
the label to the left of the field and start typing. 
Calculated values and results are represented 
with gray text. Some calculated values, such as 
conduit slope, are automatically generated. 
Results are visible after a scenario is run. 

FlexTables 

Use StormCAD FlexTables to enter information for multiple elements quickly, view calculated results and 
generate reports. As an alternative to the Property Editor, a FlexTable accesses the same element 
attributes and displays the same information. By default, a FlexTable may not display all of the fields 
shown in the Property Editor, but all FlexTables can be modified if desired by adding or deleting fields, 
changing column widths, editing labels, etc. Elements can also be sorted or filtered by attribute. 

Element Symbology Prototypes FlexTables Properties 
 

Element Levels 



ODOT User Guide for StormCAD  
          

January 17, 2014 Sheet 11 of 33 

The FlexTable manager shows three categories: Project, Shared 
and Predefined. The Project FlexTables are included with the 
StormCAD project file. Changes made to the Shared and 
Predefined FlexTables are stored on the user hard drive. 
 
The Storm Sewer Design and Analysis FlexTables are types of 
conduit tables that include calculated result fields (indicated 
with yellow columns). The HGL Analysis FlexTable conveys the 
same information as the Storm Sewer Analysis using a two-row 
format.  These FlexTables are intended to be used to generate 
reports after a scenario is computed. 
 
Hint – use Global Edit to save time with FlexTables. Right click 
on a column heading to take advantage of this feature. 
 
Catch Basins – the same inlets are used with both storm sewer and pavement drainage calculations (the 
FlexTable below shows only the data fields needed for storm sewer calculations – additional attributes 
are accessible through the Properties dialog). Select the ODOT inlet from the dropdown menu. For 
storm sewer calculations, the Inlet Location should be In Sag to capture all inflow (alternately, set the 
Inlet Type to Full Capture or the Catalog Inlet to Generic Default 100%). Enter the ground and invert 
elevations for existing analysis. For a new system design, only the ground elevation is necessary. 
 

 
 
Conduits – review and modify the section size (diameter), invert elevations and length if needed. By 
default, StormCAD adjusts the inverts as well as size when it runs a design scenario. If using length to 
scale and inverts that match the start and stop nodes, no initial data entry may be needed. 
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Outfalls – enter the ground and invert elevations. For the Boundary Condition Type, Free Outfall is 
appropriate for design mode. For hydraulic grade line analysis, enter a User Defined Tailwater.  
 

 
 
Catchments – specify the Outflow Node by using the dropdown menu (select from drawing). Enter the 
area, rational coefficient and time of concentration. Multiple subareas can be incorporated.  
 

            
 
Hydrology Note: StormCAD can also accommodate fixed flows (e.g., peak flow obtained from USGS 
regression equations). Use the Properties dialog to edit the Inflow (Wet) Collection. 

Prototypes 

Prototypes affect new elements placed. They can save 
time by automatically populating various attribute fields. It 
is a good idea to review the prototypes prior to laying out 
a new system. Later the attribute values can be edited as 
needed with FlexTables or the Property Editor. 
 
Prototypes are viewed and edited using the Properties 
dialog. The active conduit here (To Scale) has a 12 inch 
section size, with length to scale and invert elevations that 
match the start and stop nodes. By default, both size and 
invert elevations will be affected in design mode. For a 
quick schematic or existing system analysis, consider the 
User Defined conduit prototype (Make Current). 
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Element Symbology 

Use the Element Symbology dialog to manage the 
appearance of elements and labels. The checkboxes control 
visibility of annotations and color coding as well as the 
elements themselves. 
 
Annotations, or labels, are placed at fixed offsets, and the 
default text height is 5.6 (40 scale). Labels can include 
attribute fields like conduit length or diameter. StormCAD 
Options also affect the label scale, prefixes and numbering 
(StormCAD > Tools > Options). Avoid overlapping labels, 
because all annotations are visible in the .dgn file when 
StormCAD is not active. StormCAD text is not influenced by 
the MicroStation model annotation scale.  
 

Selecting an element category (e.g., Conduit) 
activates the Properties dialog as shown here. 
Element appearance is controlled by StormCAD 
settings (e.g., red conduits) that override the 
MicroStation color and line weight. For issues 
related to ODOT CADD standards, see the 
Drainage Basemap section of this document.  
 

Color Coding is a feature that affects element color, size or line width only when its box is checked in the 
Element Symbology manager. It visually represents ranges of attribute values or calculated results. For 
example, the color coding below symbolizes the average conduit cover. A quick glance shows you where 
the depth might be problematic. Here, the upstream pipes (green) are a little bit shallower than the 
downstream ones (cyan), but no pipes are too shallow (red or orange). 
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Element Levels 

The StormCAD for MicroStation Element Levels feature controls the default MicroStation levels on 
which new items and annotations will be placed. Use the dropdown menu to change the default level or 
specify the active level prior to placing elements. Changing the Element Levels selections does not affect 
previously created StormCAD elements, for which it is necessary to use the normal MicroStation 
selection and attribute tools. Element Levels are attached to the .dgn file, and the settings shown below 
are part of the ODOTStormCAD.dgn seed file. Otherwise, levels are not available in the dropdown 
selection unless they have already been used in the drawing.  
 
To add a level to the dropdown list, you can draw a scratch line on the desired level and then delete it 
(this is how the StormCADSeed.dgn file was created), or change an existing MicroStation or StormCAD 
element to the desired level. The levels in the dropdown list are arranged in the order in which they 
were placed, with the newest additions at the bottom – not necessarily alphabetically. 
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Components 
 
The StormCAD Components menu (StormCAD > Components) provides access to a number of ODOT 
customized features. 
 

Engineering Libraries 

Engineering Libraries are external 
to a StormCAD project file, and 
StormCAD installation includes 
some Bentley default libraries that 
are not used for ODOT purposes. 
The first time you use StormCAD, 
you will need to add the ODOT 
Engineering Libraries that are 
shown here at right (navigate to 
ODOTstd\V8istd\StormCAD\ 
EngineeringLibraries). 
 
The Storm Data, Inlet Catalog and 
Conduit Catalog found on the 
Components menu have elements 
and properties imported from the 
engineering libraries, and these 
components are included with the 
StormCAD project seed file. The 
ODOT Material Library does not 
have a corresponding catalog, but 
it is necessary to specify the 
conduit material when running 
StormCAD in design mode. 
 
Note: Engineering Library updates are not automatically pushed to existing catalogs. 

Catalogs 

The Conduit Catalog includes elements imported from the ODOT Conduit Engineering Library. The 
Material should be Smooth Pipe from the ODOT Material Engineering Library. The Manning’s “n” value is 
based on diameter as per the Location and Design Manual, Volume 2 (for ODOT purposes, this is not the 
same as the basic “n” value for smooth pipe). When using a conduit FlexTable or the Properties dialog, 

Storm Data Inlet Catalog Conduit Catalog 

Engineering Libraries Default Design Constraints 
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the Section Size (Conduit Catalog) field has a dropdown selection menu with all of the Conduit Catalog 
elements. The alternative to a Catalog Conduit is a User Defined Conduit, but StormCAD design mode 
requires use of catalog conduits. The default conduit Prototype is a 12 in. catalog conduit. 
 

 
 
The Inlet Catalog includes elements imported from the ODOT Inlet Engineering Library and which 
correspond to the ODOT Standard Construction Drawings. The catalog also includes a generic full 
capture inlet (Generic Default 100%). These same inlets are used for both storm sewer nodes and 
pavement spread calculations, and many of the catalog data fields are not pertinent to storm sewers 
(e.g., grate and curb window dimensions). For example, the difference between CB No. 3A (Curb & 
Gutter) and CB No. 3A (Curb) is irrelevant for storm sewer calculations. The “Dummy Node” with no 
captured flow is only intended for use with certain pavement spread calculations. 
 
The Properties dialog and catch basin FlexTables have 
an Inlet Type field. The Full Capture type is suitable 
for storm sewer calculations, but selecting Catalog 
Inlet provides access to the Inlet pulldown menu. 
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The Inlet Catalog manager has another Inlet Type dropdown menu. Flow to Inlet vs. Flow Captured is 
used for catch basins in ditches and Generic Default 100%, because it allows the designer to model full 
capture with a catalog inlet. The Ditch Inlet Type should not be used for ODOT purposes, because it 
requires additional channel section elements. For Gutter, Curb and Combination Inlets, bypass 
calculations are performed for inlets located on grade. Setting the inlet location to in sag for these inlets 
ensures that all flow is captured for purposes of storm sewer calculations. 
 

 
 
Note: StormCAD uses FHWA grate types (e.g., 30˚ tilt bar), not ODOT standard Neenah grates. The ODOT 
Inlet Library uses the closest approximation for modeling purposes. For details about the FHWA grate 
types, see the NHI Urban Drainage Design Manual (HEC-22). 

Storm Data 

The Storm Data components include the rainfall intensity-duration-frequency curves for Ohio 
geographic areas as given in the Location and Design Manual, Volume 2. Similar to a catalog, these 
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components are attached to the StormCAD project seed file. The original storm data can be imported 
from the ODOT IDF Curves Engineering Library (ensure that the equation duration and intensity units are 
selected). The Global Storm Events manager is a separate feature accessible through the Components 
menu. It is used for defining Rainfall Runoff Alternatives after storm events have been imported from an 
engineering library. 

 
In addition to the ODOT IDF curves, there is a User Defined IDF Table for the hydraulic grade line check 
based on constant rainfall intensity, and it requires editing. The example shown below uses the25-year 
outfall system intensity. For more details, see the Design & Analysis section of this document. 
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Default Design Constraints 

The Default Design Constraints incorporate ODOT design criteria for storm sewer velocity, cover, part 
full design and crown matching as per the Location and Design Manual, Volume 2. Taking advantage of 
the StormCAD minimum cover design constraint means that the designer is not required to provide pipe 
crown elevations prior to running a design scenario (minimum cover values include conduit wall 
thickness). The default inlet and conduit Prototypes include invert elevation design.  
 
ODOT does not have minimum slope criteria, per se, but StormCAD assumes that the most economic 
storm sewer design is as shallow as possible. As a result, the minimum slope default design constraint 
directly impacts the size of automatically designed conduits, because StormCAD gives preference to 
meeting the minimum slope criteria first. The designer should understand that a smaller diameter pipe 
at a slightly steeper slope might also meet the just full design and minimum velocity constraints. If the 
conduit sizes generally seem too large, try increasing the minimum slope design constraint. 
 

 
 
In the Default Design Constraints manager, the inlet tab is for designing the window opening length of a 
curb inlet based on efficiency or pavement spread – this feature is not used for ODOT purposes, and the 
default inlet Prototype excludes inlet opening design. 
 
Local Constraints – some of the StormCAD conduit and inlet attributes in the design category refer to 
local constraints. These are design constraints for a given element that are not subject to the general 
default design constraints. By default the Prototypes do not specify local constraints, but this can be 
modified for any element using the Properties dialog. 
 
The Default Design Constraints primarily affect the design mode outcomes, but User Notifications in the 
analysis mode may also include warnings when elements do not meet slope or cover restraints. 
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Design and Analysis 

 

After laying out a system and editing the 
element attributes, the next step is to perform 
design and/or analysis computations. There are 
two toolbars (shown above) with features from 
the Analysis menu, and the Compute Center 
manager (StormCAD > Analysis > Compute 
Center) also provides access to these tools. 
 
A typical ODOT storm sewer is sized to flow just 
full for the 10-year frequency storm, and the 
hydraulic grade line (HGL) is checked using the 
25-year or 50-year frequency. The HGL analysis 
is influenced by the outlet tailwater elevation. 
To accomplish this, StormCAD uses Scenarios, 
Alternatives and Calculation Options. 

Scenarios 

A StormCAD Scenario is comprised of a group of Alternatives 
and Calculation Options. Some of the customized Scenarios, 
Alternatives and Calculation Options are featured in the table 
below. Base is the current scenario for a new project. To 
change this, right click on the selected scenario and use the 
popup menu or click the Make Current icon. Alternately, use 
the dropdown selection in the Compute Center. The scenario 
can be viewed or edited in the Properties dialog. 
 
StormCAD Scenarios are subject to parent-child relationships, or inheritance, represented in the 
Scenarios manager tree view above (e.g., Storm Sewer Check is a child scenario of Storm Sewer Design).  
 

 Base  
Scenario 

Storm Sewer Design 
Scenario 

Storm Sewer Check 
Scenario 

Constant Intensity Check 
Scenario 

Physical Alternative Base  Design <I> Design <I> Design  

Boundary Condition 
Alternative 

Base <I> Base User Defined 
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<I> User Defined  
Tailwater 

Rainfall Runoff 
Alternative 

Base  Design Storm  
(10-Year) 

Check Storm  
(25-Year) 

Constant Intensity Storm 
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Calculation Options  Analysis Design Analysis <I> Analysis 

Alternatives 

Calculation Options 
 

Scenarios 
 

Compute Validate 
 

User Notifications 
 

Compute Center 
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For a child scenario, “inherited” Alternatives are indicated in the Properties dialog with <I> (see below). 
From the Properties dialog, the Alternatives are selected by using the dropdown choices. Pay particular 
attention to the Rainfall Runoff Alternative that must be specified before performing computations. 

Alternatives 

Most StormCAD Alternatives consist of data from the element attributes. For example, the Physical 
Alternative includes conduit sizes and invert elevations. The ground and invert elevations of an outlet 
are also part of the Physical Alternative, but the boundary condition (Free Outfall or User Defined 
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Tailwater) is separate (Boundary Condition Alternative). For 
catchments, the area is included with the Physical 
Alternative, but the runoff coefficient and time of 
concentration are part of the Hydrology Alternative. The 
Rainfall Runoff Alternative (storm event) is independent of 
any element attributes. Some of the Alternatives are specific 
to sanitary or pressure flow systems and are irrelevant for 
ODOT purposes.  
 
In the Alternatives manager, each selected alternative 
associated with the current scenario has a red checkmark 
icon. To specify a different alternative for the current 
scenario, use the Scenarios manager and Properties dialog. 
 
In the Rainfall Runoff Alternatives, Base Rainfall Runoff, 
Storm Sewer Design Storm, and Storm Sewer Check Storm 
are placeholders. From the Scenarios manager, select a 
scenario and use the Properties dialog dropdown choices to 
specify the actual storm event (e.g., Zone C – 10 Year). 
 
As shown in the tree view, Alternatives are subject to 
“inherited” properties, similar to Scenarios. There are two 
ways to edit element properties for an alternative. To use the Alternatives dialog, double click on an 
alternative to open it (alternately, right click and select Open from the popup menu, or use the icon at 
the top of the Alternatives manager). In the example below, none of the data is inherited from Base 
Physical, even though it is the parent scenario. All of the physical conduit data is local data as indicated 
by the checkmark in the first column (see the key at the bottom of the dialog). Editing data in this dialog 
is similar to using a FlexTable. The tabs at the top are to select other element types. 
 

 
 
The other way to modify element data is to make sure the selected scenario is current (use the 
Scenarios manager or Compute Center) and then edit a FlexTable or use the Properties dialog. The 
advantages of this method are that you do not need to worry about the Alternatives manager, and the 
visible attribute fields are limited. When you change the current scenario, attributes in the FlexTables 
and Properties automatically switch to reflect the current Alternatives. Remember, though, that the 
various data fields in FlexTables (and Properties) may be parts of different categories of Alternatives. 
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Calculation Options 

The StormCAD Calculation Options help to define a scenario, 
and the most important distinction is whether the 
computations will be performed in design or analysis mode. 
Base Calculation Options are for analysis. If Design 
Calculations Options are selected, then StormCAD will 
automatically size conduits and set invert elevations based 
on the Default Design Constraints. 
 
The Calculation Options include the minimum time of concentration, and the default is 10 minutes. To 
edit the selected Calculation Options, use the Properties dialog. 

User Notifications 

It is a good idea to validate input data prior to running a Scenario. Use 
the Validate tool (accessible through the Compute Center as well as the 
StormCAD Compute toolbar). If the User Notification manager appears, 
resolve any errors with red icons and review the other warnings. 

Compute  

After resolving User Notification errors, click Compute (accessible through the Scenarios manager and 
Computer Center as well as the StormCAD Compute toolbar). StormCAD runs the current scenario (it is 
also possible to perform a Batch Run with multiple scenarios). If the Calculation Options are set to 
design mode, there will be a popup query – it is not necessary to create a new physical alternative. If 
you click No, StormCAD will modify the current physical alternative. 
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Putting It All Together (Storm Sewer System) 

The following StormCAD steps and descriptions apply to a typical ODOT storm sewer project: 

1. Begin 

a. Use Base scenario 

 Base Physical Alternative 

b. Layout system and edit element attributes  

2. Design 

a. Change current scenario to Storm Sewer Design  

 Design Physical Alternative  

o Data inherited from Base Physical Alternative 

o Data modified by design computations 

 Free Outfall Boundary Condition Alternative 

 Design Calculation Options 

b. Select Rainfall Runoff Alternative (e.g., Zone C – 10 Year) 

c. Validate data , resolve errors and compute scenario 

d. Review results and create report 

3. Analysis 

a. Change current scenario to Storm Sewer Check 

 Design Physical Alternative (inherited) 

 User Defined Tailwater Alternative 

 Analysis Calculation Options 

b. Verify the outlet tailwater elevation  

c. Select the Rainfall Runoff Alternative (e.g., Zone C- 25 Year) 

d. Validate data, resolve errors and compute scenario 

e. Review outfall system intensity 

4. HGL Check 

a. Change current scenario to Constant Intensity Check 

 Design Physical Alternative (inherited) 

 User Defined Tailwater Alternative (inherited) 

 Analysis Calculation Options (inherited) 

b. Edit the Constant Intensity Storm in the Storm Data manager 

 Use outfall system intensity from Storm Sewer Check 

c. Validate data, resolve errors and compute scenario 

d. Review results, make profiles and create report 

 
Notes: 

 Use Base Scenario to analyze an existing system with a 10-year storm event. Use Storm Sewer 
Check Scenario and Constant Intensity Check Scenario to compute the 25-year HGL.  

 

 Design Physical Alternative inherits data from the Base Physical Alternative. If Storm Sewer 
Design Scenario is not computed and the inherited data is not modified, then these two physical 
alternatives will be identical. 
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 If you want to use your preferred design alternative for any other scenarios, simply make sure 
the Storm Sewer Design Physical Alternative is selected. 
 

 Design Structure Elevation? This element attribute setting is irrelevant for analysis mode. In 
design mode, StormCAD sets the invert elevation of node elements (conduits are similar). This 
default setting can be changed to False using the Properties dialog. For example, the system 
outlet may have a fixed elevation. 

 

 If you are running a design scenario for a system that includes an existing drainage feature or 
fixed physical data, make sure the corresponding design setting is False in the Properties dialog. 
This is also true if you are redesigning a system (e.g., with a different minimum slope) and want 
to keep certain portions of StormCAD’s initial design. 
 

 If you change any input data (e.g., conduit size, storm event, etc.), the hydraulic results do not 
automatically update. You need to compute the scenario again. 

 

 Is Active? This attribute field is part of the Active Topology Alternative. Among other things, you 
could use this to model multiple systems in a single project, because it allows you to work on 
selected elements at a time without affecting any other systems.   
 

 The StormCAD project seed file includes customized Scenarios and Alternatives to assist with 
standard ODOT design and analysis workflows. If it is necessary to create any new Alternatives 
or Scenarios, StormCAD Help provides additional guidance (StormCAD > Help > StormCAD Help 
> Contents > Scenarios and Alternatives). 
 

User Notifications: 

 Conduit discharge is above design discharge. It is not unusual for this warning to appear after 
Storm Sewer Check or Constant Intensity Check is computed for a new storm sewer design – 
conduits are typically sized for a lower intensity storm, and then the HGL is checked for a higher 
intensity storm. Depending on the user defined outlet tailwater elevation, there may also be a 
velocity warning: Conduit does not meet minimum velocity constraint. These warnings should 
not be cause for concern with the HGL Analysis, provided that Storm Sewer Design does meet 
conduit discharge and minimum velocity design criteria. 

 

 If there is a global storm event error, check the scenario properties and make sure the 
appropriate Rainfall Runoff Alternative has been selected.  If the problem persists, open the 
Global Storm Events manager from the Components menu. Look for an alternative with an 
undefined storm event and use the dropdown selection list. 
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Review Results 
Properties – view results for individual elements. 
The calculated results are indicated with gray 
attribute field names, and they are found at the 
bottom of the Properties dialog.  
 
Calculation Summary – is automatically generated 
when you compute a scenario. It allows you to 
view detailed results for all elements. 
 
FlexTables – are convenient and customized for 
ODOT purposes. Use the Storm Sewer Design 
FlexTable when Storm Sewer Design is the current 
scenario. Use the Storm Sewer Analysis or HGL 
Analysis FlexTables when Storm Sewer Check or 
Constant Intensity Check is the current scenario.  

 
The yellow cells hold calculated results. Input data in the white cells can be modified – compute the 
scenario to update hydraulic results. 

Reports 

At least two storm sewer reports are necessary for typical ODOT purposes, because the design and 
analysis require more than one scenario. From any FlexTable, select the Report icon to generate a hard 
copy or save as a .pdf file.  
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From the Preview pane, use Page Setup to switch to landscape orientation if desired. In this example, 
the Notes attribute field is used to create duplicate labels for the second row. The FlexTable formats can 
be modified (column width, headings, etc.), but the final reports should include all the necessary 
information as per the Location & Design Manual, Volume 2 (see Form LD-34 in Appendix A). 

 
The Project Properties (StormCAD > Project > Properties) include the project title. If this field is blank, 
the default title will be the name of the StormCAD project file (e.g., Example2.stsw). The report heading 
indicates the type of FlexTable as well as the active scenario. 
 
The StormCAD Reports menu includes additional types of reports as well as 
Report Options. The Project Inventory includes all of the project properties 
plus a summary of the active scenario and all network elements. 
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Profiles 

 The Profiles tool is accessible from the 
StormCAD View menu. It is helpful for viewing 
the HGL when Storm Sewer Check or Constant 
Intensity Check is the current scenario.  
 
To quickly create a profile from an inlet to the 
system outlet, select the beginning node from 
the drawing. Right click and hold, and then 
select Create Profile from the popup menu. 

 
Alternately, use the Profiles manager to create 
a new profile. From the Profile Setup, use the 
Select tool to add the first and last nodes, and 
then click Done. Open the profile. 
 
From the Profiles manager, right click on an existing profile to view it and create a printable report if 
desired. The default profile is shown below. The alternative engineering profile is drawn to scale. The 
stations here are referenced to the storm sewer system, not the roadway centerline.  
 

 

Profiles 
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Drainage Basemap 

ODOT CADD Standards 
StormCAD for MicroStation allows the designer to integrate hydraulic calculations with plan 
development by creating a storm sewer system plan view drawn to scale. It is best to have a drainage 
basemap file (e.g., 12345BD001.dgn) that contains only StormCAD elements with editing permission 
only for StormCAD users. The general roadway basemap (e.g., 12345BP001.dgn) can reference this file. 
 
ByLevel Attributes – when opening the .dgn file with regular MicroStation, linear StormCAD elements 
(e.g., conduits) are displayed with standard ODOT levels, colors and styles. However, StormCAD for 
MicroStation sets the line weights to 0. Prior to plotting plan sets in regular MicroStation, you can 
correct the line weights using Element Selection and a tool like Change Element Attributes.  
 

 
 
Standard ODOT Cells – the StormCAD cell library (stm.cel) includes only one cell for each type of 
element (e.g., a square symbol for all catch basins). The MicroStation Replace Cells tool can be used for 
the various ODOT catch basins, etc., with a few minor symbology differences. View 1 below shows 
proposed CB-3A cells. The Replace Cells tool was used on the left hand side to replace one of the generic 
StormCAD cells. The line weights are correct, but the cell component colors and line styles are ByLevel.  

 
The normal Place Active Cell tool was used on 
the right hand side. The differences are most 
noticeable with cells placed on the DR_X_Cells 
level, but for construction plans they are fairly 
insignificant. These variances are related to the 
Shared Cells used by StormCAD. Cells can be replaced as described here without adversely affecting 
StormCAD elements, but dropping a shared cell deletes a StormCAD node and any connected links. 
 
Annotations – the StormCAD element labels are not subject to the MicroStation annotation scale, and 
the default size and element offset correspond to 40 scale. This should be adequate for creating a 
schematic drawing to accompany calculations and reports, but not necessarily for construction plan sets. 
All StormCAD annotations are visible when the file is opened with regular MicroStation, so it is 
recommended that you place StormCAD text on its own level. Also see Element Symbology. 
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StormCAD Modifications – deleting elements in StormCAD for MicroStation removes them from the 
StormCAD model. In fact, any MicroStation tool that deletes part of an element (e.g., IntelliTrim) will 
remove the entire element from the StormCAD model but not the .dgn file. You can safely move a node 
within StormCAD for MicroStation, and any connected link geometry will automatically update. Also 
remember that you can use the Node Morphing or Link Splitting features of the StormCAD Layout tools 
to add or change catch basins or manholes. 
 
Drawing Modifications – when the file is opened in regular MicroStation, avoid manipulating, modifying 
or deleting StormCAD elements. These changes will not be reflected in the StormCAD model. If 
necessary, you can use the Synchronize Drawing tool (StormCAD > Tools > Database Utilities > 
Synchronize Drawing). This is helpful for inadvertent changes made in regular MicroStation. With this 
tool it is possible to delete all StormCAD elements when the file is opened with regular MicroStation and 
then recreate the system when the file is opened with StormCAD using the default StormCAD symbology 
(e.g., a single square for all catch basins, ByLevel line styles, etc.). 
 
Roadway Profiles and Cross Sections – StormCAD does not support GEOPAK integration. While it can 
assist the designer with system layout and plan views, additional drafting is still needed for profiles and 
cross sections. Options include ODOT Drainage VBA applications and GEOPAK Road Draw Ancillary 
Features (VBA documentation and the GEOPAK Road Training Guide are found on the CADD website).  
 
Although StormCAD does allow you to create an Engineering Profile that is drawn to scale, the stations 
do not correspond to the roadway centerline, and no additional pipe connections are shown in the catch 
basins and manholes. It might be possible to use this feature as a starting point for separate storm 
sewer profiles, however, if those plan sheets are necessary. 
 

 
 
Bentley StormCAD Help – for additional details, see The MicroStation Environment Graphical Layout 
section (StormCAD > Help > StormCAD Help > Contents > Introducing the Workspace). 
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Additional StormCAD Capabilities 

Pavement Drainage 
StormCAD uses the same catch basin elements for inlet spacing and storm sewer calculations, reducing 
duplicate information. The additional system elements are gutter links. Keep in mind that models 
typically require all inlets to have subsurface outlets well as a system outfall. If needed, two inlets can be 
connected with both a gutter and a conduit, although the drawing will have line elements that coincide.  
  
StormCAD follows the criteria outlined in the FHWA Urban Drainage Design Manual (HEC-22). It is 
important to note that the grate types and inlet bypass calculations differ from ODOT standards and 
methodology. The local depression concept is also somewhat different, because it only affects curb 
opening inlets or combination inlets in a sag (i.e., not catch basin grate bypass calculations). 
 
Calculating spread in a sag presents additional considerations. CDSS calculates spread for each of the 
incoming gutters as well as the combined flow at the inlet using a weir/orifice equation. It typically 
involves two separate drainage areas. StormCAD, however, performs only the weir/orifice analysis using 
a single drainage area. One workaround uses a “dummy node” on grade for each incoming gutter – it 
has a contributing catchment but is modeled with zero captured flow. In this scenario, the inlet in a sag 
does not have a separate catchment, but it receives all of the flow coming from both gutters. This 
approach allows the designer to check the maximum gutter spread on either side which might exceed 
the calculated spread at the inlet itself. Adding these dummy nodes to the model can be done fairly 
quickly with the Link Splitting feature of the Layout tool, which interpolates elevations. The model 
requires a conduit outlet even for a dummy inlet, but it will not carry any flow. 
 

 
 
The StormCAD project seed file includes FlexTables for pavement inlets and gutter elements as well as a 
custom report. Keep in mind that the Pavement Inlet Table and storm sewer Catch Basin Table include 
identical elements, but different attribute fields are featured. In general, it is recommended that gutters 
use the upstream inlet cross section geometry to minimize data entry, and the Inlet Spread Report is 
based on the inlet elements. If StormCAD is used for inlet spacing analysis, reports should include all 
information as required by the Location & Design Manual, Volume 2 (see Form LD-40 in Appendix A, or 
use CDSS as a general guide). 
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Notes: 

 Use the FlexTable Global Edit feature with caution, particularly when selecting the catalog inlet. 
It is recommended that you select each catch basin individually. Otherwise, the associated grate 
and curb inlet geometry might not automatically update, which could lead to incorrect bypass 
and spread results. You can use Properties or add FlexTable columns to view these fields. 
 

 The inlet geometry requires a longitudinal slope attribute field for structures on grade. This 
value should generally match the calculated slope of the upstream gutter. StormCAD calculates 
the gutter slopes by using the inlet ground elevations and gutter length. 

Ditch Design 
StormCAD can perform open channel flow analysis using various material options. The custom ODOT 
Material Library includes the protective linings listed in the Location and Design Manual, Volume 2, and 
the StormCAD project seed file includes a shear stress element attribute. There are two seeded lining 
items corresponding to the CDSS approach, with the Manning’s n value of 0.030 used for shear stress 
determination and 0.040 for depth determination (the ditch depth check scenario has its own physical 
and rainfall runoff alternatives). Compared to CDSS, the main difference is that StormCAD does not 
automatically select the ditch lining – the designer must manually select the lining type from the 
pulldown menu and ensure that drainage criteria are met. The Element Symbology feature of StormCAD 
can be used to visually identify channels with specific attributes (e.g., shear stress that exceeds 0.4 psf).  
 

 
 
Ditch channels can be modeled as either conduit elements or channel elements, and cross sections are 
the node elements. The channel element characteristics are based on the cross sections, and they can 
interpolate changes between two sections. When using conduit elements to model ditches, the cross 
section geometry is ignored (transition elements are nodes that could be used in lieu of cross sections). 
StormCAD performs the same open channel flow calculations for both element types. The advantage of 
using conduits rather than channels to model ditches has to do with reports, which can include 
upstream/system drainage areas, times and intensities. Neither cross sections nor channels display 
these calculated result fields.  
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Prior to laying out a system, select the appropriate conduit Prototype (e.g., Ditch To Scale) in order to 
minimize data entry (the red check mark indicates the current Prototype). It is also recommended that 
you change the labeling prefix for the open channel conduits prior to laying out the surface drainage 
system (StormCAD > Tools > Options > Labeling). For projects that combine enclosed storm sewers with 
open channel conduits, it may be necessary to use the FlexTable filter feature for the sake of clarity (e.g., 
right click on a column heading to create a custom filter based on section type). If StormCAD is used for 
ditch analysis, reports should include all information as required by the Location & Design Manual, 
Volume 2 (see Form LD-41 in Appendix A, or use CDSS as a general guide). 

Advanced Features 
StormCAD includes some additional features and tools beyond the scope of this document but still 
worth mentioning. For additional details see the StormCAD Help menu. 
 
User Data Extensions – the ODOT StormCAD project seed file takes advantage of this feature to include 
additional element attribute fields that are not otherwise part of a typical StormCAD model. Examples 
include Roadway Station and Side, plus Total Allowable Spread and Allowable Depth for pavement 
drainage. These are for information only and intended to assist the reviewer. User Data Extensions can 
also be created using numeric formulas. Examples include Ground Minus HGL, Total Inlet Surface Flow 
(corresponds to CDSS Inlet Spacing Total Flow) and Shear Stress (necessary for ditch calculations). 
 
ModelBuilder – StormCAD has a tool that can be used to import data to create or update a system. If 
you are starting with a .dgn file, however, it is first necessary to export elements to a .dxf file. This 
process is fairly complex, and you may encounter difficulties using ModelBuilder with StormCAD for 
MicroStation (it works fine with the standalone version).  
 
If you have an existing system drawn using regular MicroStation tools, it might be most convenient to 
simply use this file as a background reference and place StormCAD elements in a separate drainage 
basemap by “tracing” over the existing drawing. Either way, you will have two overlapping systems, only 
one of which is linked to the StormCAD model. 
 
TRex Terrain Extractor – this tool can be used to automatically assign elevation data to nodes (e.g., 
catch basin grates). The elevations used to calculate minimum conduit cover are based on the ground 
elevations at the nodes. 
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