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503 Template Exercises 503-1 

 

OpenRoads Designer: 
Template Exercises 

 

Exercise 1: Create Templates from Components 

In this exercise we will assemble the template for St. Peter Road by dragging and dropping components 
from the ODOT template library. 
 

✓ Open ProjectWise Explorer 

 
 

✓ Browse to the folder containing the training data. The folder location will be provided by the 

instructor for each class. 
✓ Browse to the 400-Engineering\Roadway\Basemaps\ folder.  

✓ Open the file 123456_BK001.dgn. The design file that is used does not matter since we are editing 

the template library .itl file. 

✓ From the Corridors tab, choose Template > Create Template. The Create Templates dialog is 

opened with the template library for the WorkSet loaded 

✓ Create a folder named St. Peter Road to store all the templates for St. Peter Road. Right-click on the 

Project Templates folder and choose the New > Folder option. 

 
Take the following steps to create the template for St. Peter Road: 

 
✓ Right-click on the St. Peter Road folder and choose New > Template to create the first template for 

St. Peter Road. Name the template “St. Peter Road”. 
✓ Open the Dynamic Settings dialog (Tools > Dynamic Settings) to define the Step increment 

values as 0.5 and 0.1. This is helpful to ensure that the initial pavement placement is constrained on 
the “grid” 

✓ In the Dynamic Settings dialog, turn off the Affixes option. We will drag in a pavement backbone 
that already has the left and right sides defined.  

✓ Drag the following pavement backbone into the template at the 0,0 origin: 
 
ODOT > Backbones > Undivided Roadways > Pavement and Shoulder 301-8E Uncurbed > 2-
Lane > Asphalt Concrete without Stabilization 
 

St. Peter Road will use a pavement width of 10’. Take the following steps to define the pavement width: 
 

✓ Edit point L-ACSC_T_EP to define the Horizontal constraint with a value of  -10 
✓ Edit point R-ACSC_T_EP to define the Horizontal constraint with a value of  10 

Next add the end conditions to the template. 
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✓ In the Dynamic Settings dialog, turn on the Affixes option 
✓ Drag the following component onto the edge of shoulder point. 

 
ODOT >  End Conditions > 307-4E Common and Barrier Grading > 307-4E Cut 3:1 
 
Tip: Since this template is symmetrical, you can right-click while dragging the end condition into 
the template to activate the Mirror option (CTRL-R) to place it on both sides simultaneously. 

 
The completed template should appear as shown below. 

 
✓ When complete, save your template by choosing File > Save from the Create Template dialog pull-

down menu. 
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Exercise 2: Creating the S.R. 185 and Jameson Road Templates 

In this exercise we will create the templates for S.R. 185 for and Jameson Road 
 

✓ Open ProjectWise Explorer 

 
 

✓ Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

✓ Browse to the 400-Engineering\Roadway\Basemaps\ folder.  

✓ Open the file 123456_BK001.dgn. The design file that is used does not matter since we are editing 

the template library .itl file. 

 

S.R. 185 Template 
 

✓ From the Corridors tab, choose Template > Create Template. The Create Templates dialog is 

opened with the template library for the WorkSet loaded 

o Create a new template named S.R. 185 in the Project Templates folder. 

o Open the Dynamic Settings dialog to ensure the Step values are defined as desired. 

o Create the S.R. 185 template by dragging in the components listed below. 

Be sure to pay attention to the Apply Affixes setting (Dynamic Settings dialog). Should this 
setting be toggled on or off as each of the components listed below is dragged into the 
template? 

 
ODOT > Backbones > Undivided Roadways > Pavement and Shoulder 301-8E Uncurbed > 2-

Lane > Asphalt Concrete without Stabilization 

 

ODOT > End Conditions > 307-4E Common and Barrier Grading > 307-4E 3:1 Cut, Fill Table 

 

✓ After dragging in the end conditions, the next step is to remove some of the options. For this 
project, slopes of 3:1 or 2:1 will be used. 
 
There are two different Graded Shoulder components in the end condition on each side of the 
template. The components R-GSH1 and L-GSH1 are used when the 6:1 slope is used. Remove these 
two components by right-clicking on the component and choosing the Delete Component option. 
Since these two graded shoulder solutions overlap, you are prompted to select the component you 
wish to delete as shown on the following page. Remove the R-GSH1 and L-GSH1 components. The 
6:1 slope component is also removed since it has been defined as a “child” component of the graded 
shoulder 1 component. 
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✓ Delete the 4:1 fill slope component on each side of the template. The completed template should 

appear as shown below. 
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Intersection and Driveway Display Rules 
The backbone for the template contains four Null Points that are used to seek the intersection with another 
road (INT-Left and INT-Right) and points that are used to seek the intersection with a driveway (DRIVE-
Left and DRIVE-Right). These points are defined to find elements of specific symbology defining the limits 
of an intersecting road or driveway. The properties for the point INT-Left are shown below. 

 
The Horizontal Feature Constraint item 
defines the symbology for the element that the 
point will seek. 
 
The Range defines the horizontal limit that the 
software will search for an element matching 
the defined symbology. 
 
When the template is applied to a corridor, 
these points will seek for any elements 
matching the assigned symbology and will 
move to intersect the element. If the point 
moves, a Display Rule is applied to toggle off 
the display of selected components. 
 
For example, if a driveway is found to the right, 
point DRIVE-Right moves to intersect the line 
that defines the limits of the drive. The display 
rule turns off the display of the shoulder 
components. 
 

 
 

The behavior of the points can be tested in the template dialog. Take the following steps to test the 
behavior of the DRIVE-Right point: 
 

✓ Right-click the point DRIVE-Right 
o Choose Test Point Controls > Test Horizontal Point Control 
o Move the cursor to the left and right of the template center point. Observe the behavior of 

the template components 
 

As the point is moved to the right, the shoulder components on the right side of the 
template disappear. Notice that the end condition components are not defined to observe 
the display rules at this point, as shown below. 
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Take the following steps to assign the display rule to the end condition components: 

 
✓ Left click in the template window to terminate the testing process 

 
The Display Rule is applied to the top shoulder component. Take the following steps to review the 
display rule: 
 

✓ Double-click the top component of the right shoulder, R-ACSC-SH 
 

✓ Select the Edit button to the right of the Display Rule parameter to open the Component Display 
Conditional Expression dialog. 
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✓ Review the display rule settings. Select the Cancel button when complete. 

 
✓ From the Component Properties dialog, select Close. 
 

Note that the display rule is only applied to the top component of the shoulder buildup in this template. 
Each of the sub-components of the shoulder are defined as “child” components with the top component as 
the parent component. Display rules assigned to the parent are inherited by the children. 
 
This parent-child relationship can be reviewed or defined using the Active 
Template portion of the Create Template dialog as shown at right. 
 
The parent component is at the top of the hierarchy for each branch. 
Components can be arranged in a hierarchal relationship by using drag-and-
drop operations within the Active Template portion of the dialog. 
 
If a display rule is set to turn off the display of the parent component, the 
display of each child component is also toggled off. 
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When an intersection or a driveway element is encountered, the display of the end conditions must also be 
turned off. 
 
Take the following steps to apply displays rule to the parent component of the left and right end conditions: 
 

✓ Double-click on the component L-GHS2 to access the Component Properties dialog 
o Select the Edit button to the right of the Display Rules 
o Add the following display rule: 

NOT (Intersection-LT or Drive-LT) 
o Select OK to accept the display rule 
o Select Apply on the Component Properties dialog 

 
✓ Test the point control by right-clicking on points INT-Left and DRIVE-Left to test the Horizontal 

Point Control. 
 
If the display rule is applied correctly, the shoulder and end condition will not display when point 
INT-Left is moved to the left, and the shoulder steps and the end condition will not display when 
point DRIVE-Left is moved to the left. 
 
Note: The Library option must be selected to test the display rule behavior. If the Active Template 
option is selected, the display rules cannot be tested. Be sure to select the Library option before 
testing the point and display rule behavior. 
 

✓ Repeat the process to define the display rule for the right end condition by editing the R-GSH2 
component. 
 

✓ When complete, choose File > Save from the Create Template dialog to save the changes to the 
template library. 
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Jameson Road Template 
The Jameson Road template will use the same design as the S.R. 185 template. 

✓ Right-click on the name of the S.R. 185 template 

✓ Chose the Copy command 

✓ Right-click on the Project Templates folder 

✓ Choose the Paste command 

✓ Rename the copied template as “Jameson Road” 

 
The pavement width for proposed Jameson Road is 20’. Take the following steps to edit the template with 

the pavement width values: 

✓ Double-click on the name of Jameson Road template to edit the template 

✓ Edit points R-ACSC_T_EP and L-ACSC_T_EP to change the Horizontal constraint value to 10 

 
This completes this exercise. 

✓ From the Create Template dialog, choose File > Save. Close the Create Template dialog. 

✓ Exit OpenRoads designer, checking the design file back into ProjectWise 
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Additional Template Exercises 

Simple Components 
In this exercise we will create a simple template consisting of pavement and shoulders for a two-lane road. 
 

✓ Open ProjectWise Explorer 

 
 

✓ Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

✓ Browse to the 400-Engineering\Roadway\Basemaps\ folder.  

✓ Open the file 123456_BK001.dgn. The design file that is used does not matter since we are editing 

the template library .itl file. 

Take the following steps to create a new template for this exercise: 

✓ From the Corridors tab, choose Template > Create Template. The Create Templates dialog is 

opened with the template library for the WorkSet loaded 

✓ In the Template Library list, right-click on the Project Templates folder and choose the New > 

Template option. Name the new template Exercise 1. 

 

o Select Tools > Options to open the Template 

Options dialog. Set the parameters for the 

dialog as shown at right. 
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o Select Tools > Dynamic Settings to open the 

Dynamic Settings dialog. Set the parameters as 

shown at right. 

o Right-Click in the template window and choose 
Add New Component > Simple. A simple 
component is floating on the cursor using the 
default settings for the Slope, Thickness, and 
Width. 

 
o Set the parameters for the new component that 

will be created as follows: 
Name:  ACSC 

Feature: MD_P_Asphalt_Concrete_Surface_Course 

Slope:  -1.60% 

Thickness: 1.25”  

Width:  12 

o Right-Click in the template window and choose the Mirror option (Ctrl-M). The simple 
component is now mirrored and appears on both the left and right sides. The component is 
mirrored about the Dynamic Origin location.  

o Identify the template origin by issuing a data point at the (0,0) coordinate location in the 
template window. The component constrained to the nearest point in the grid by the Step 
values defined in the Dynamic Settings dialog. The mirrored components are shown below. 

 
Tip: You can use the XY= option in the Dynamic Settings dialog to enter the (0,0) coordinate. 

 
Take note of the point names for the components. Each point is named according to the Point 
Name parameter in the Dynamic Settings dialog. Points to the left and right of the origin are 
prefixed according to the affixes defined in the Template Options dialog shown on the previous 
page. The Point Style (feature definition) is the same for each point. It is necessary to review 
and edit the points to assign the appropriate point name and style. 

 
The Point Properties dialog is used to edit points. 

 
✓ Double-click on point L-ACSC_T_CL to review and edit the properties of the point. Take the 

following steps in the Point Properties dialog: 
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o Change the point name to ACSC_T_EP by selecting the name from the list. 

 
o When the point name is selected from the list, the corresponding Feature Definition is 

automatically assigned for the point. Verify that the Feature Definition is now set to 
MD_P_ACSC_T_EP 
 

o The point name still needs to have a prefix assigned. Add the prefix L- to the point name. 
The point name and feature definition should be set as shown below. 

 

o Select the Apply button to save the changes. 
 

✓ Review the remaining points to set the appropriate point Name and Feature Definition for the top 
and bottom of the pavement layer. Remember, the feature definition that is assigned to each point 
will control the level symbology for the 3D line strings that are drawn in the corridor model. 
 

✓ Add a simple component for the shoulder surface to the template using the Mirror option with the 
following settings: 

Name:  ACSC-OS 

Feature: MD_P_Asphalt_Concrete_Surface_Course 

Slope:  -4.00% 

Thickness: 1.25” 

Width:  4 

✓ Edit the point names for the shoulders by double-clicking on each point to open the Point Properties 
dialog. Be sure the pick the point names from the drop-down menu list so that the corresponding 
feature definitions are assigned. When completed, the points should be named as shown below. 
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✓ When complete, save your template by choosing File > Save from the Create Template dialog pull-

down menu. 
 
 

Creating and Testing End Conditions 
In this exercise, you will create a simple cut end condition with a 3:1 foreslope and a 2’ ditch. The backslope 
will contain two end conditions, a 3:1 slope and a 2:1 slope as shown below. 

  
 

✓ Open ProjectWise Explorer 

 
 

✓ Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 
 

✓ Browse to the 400-Engineering\Roadway\Basemaps\ folder.  

 

✓ Open the file 123456_BK001.dgn. The design file that is used does not matter since we are editing 

the template library .itl file. 
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Take the following steps to create a new template for this exercise: 

 

✓ From the Corridors tab, choose Template > Create Template. The Create Templates dialog is 

opened with the template library for the WorkSet loaded 

✓ Right-click on the Project Templates folder and choose New > Template. Create a new template 
named Normal Ditch. 
 

✓ Open the Dynamic Settings dialog and select the Point Name to “EC_HINGE” from the list. The 
Point Style is automatically set. Set the Step values as desired. Uncheck Apply Affixes. 

 
✓ Add an end condition for the graded shoulder 

o Right-click in the template window and choose Add New Component > End Condition. 
o Start the End Condition at coordinate 0, 0 (xy=0, 0). 
o Name the component “GSH1” 
o Use the Feature “MD_P_Graded_Shoulder” for the component 
o Be sure to check off Check for Interception in the Dynamic Settings dialog after placing the 

first point. 
o Change the Point Name in the Dynamic Settings dialog to “EC_GSH1” After placing the first 

point but before placing the second point. By choosing the name from the list, the Feature 
Definition is automatically assigned. 

o Place the second point 6’ horizontally from the first point at a slope of -8% (hs=6, -8%) 
o Right click and select Finish. 

 

✓ Add an End Condition for the ditch foreslope. 
o In the Dynamic Settings dialog, select the Point Name EC_FSLP. 
o Right-click in the template window and choose Add New Component > End Condition. 
o Name the component “3:1 Foreslope” 
o Use the Feature “MD_P_Foreslope” for the component 
o Create the component with a vertical constraint of -1.5 at a 3:1 slope (vs=-1.5,-1:3) from the 

point EC_GSH1. Be sure to check off Check for Interception in the Dynamic Settings dialog 
after placing the first point. 

o Right click and select Finish. 
o Double click on the 3:1 Foreslope End Condition and set the Parent component to GSH1. Hit 

Apply. 
 

✓ Add an End Condition for the 2’ ditch bottom. 
o In the Dynamic Settings dialog, select the Point Name EC_DITCH. 
o Right-click in the template window and choose Add New Component > End Condition. 
o Name the component “DITCH” 
o Use the Feature “MD_P_Ditch” for the component 
o Create the component with a horizontal constraint of 2.0 and a vertical constraint of 0 

(dl=2,0) from the point EC_FSLP. Be sure to check off Check for Interception in the 
Dynamic Settings dialog after placing the first point. 

o Right click and select Finish. 
o Double click on the DITCH End Condition and set the Parent component to 3:1 Foreslope. 

Hit Apply. 
 
Next, define two end conditions for the backslope. 

✓ In the Dynamic Settings dialog, select the Point Name EC_BKSLP 
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✓ Right-click in the template window and choose the Add New Component > End Condition option. 
✓ Name the end condition “3:1 Backslope” 
✓ Set the Feature for the end condition to “MD_P_Backslope” 
✓ Create the component with a vertical constraint of 5’ at a 3:1 slope (vs=5,1:3) from the point 

EC_DITCH. Be sure to check on Check for Interception in the Dynamic Settings dialog after placing 
the first point. 

✓ Right click and select Finish. 
✓ Double click on the 3:1 Backslope End Condition and set the Parent component to DITCH. Hit 

Apply. 
 

Add a second End Condition for the 2:1 backslope using the settings detailed below. 
✓ In the Dynamic Settings dialog, select the Point Name EC_BKSLP 
✓ Right-click in the template window and choose Add New Component > End Condition. 
✓ Name the end condition “2:1 Backslope” 
✓ Set the Feature for the end condition to “MD_P_Backslope” 
✓ Set the component Priority to 2 
✓ In the Dynamic Settings dialog, toggle on the Check for Interception and End Condition is Infinite 

options (options not available until the first point of the end condition is placed).  
✓ Create the component with a vertical constraint of 5’ at a 2:1 slope (vs=5,1:2) from the point 

EC_DITCH 
✓ Right click and select Finish. 
✓ Double click on the 2:1 Backslope End Condition and set the Parent component to DITCH. Hit 

Apply. 
 
Next, review the point names and feature styles, as well as the Override names for the points and 
components. 

✓ Double-Click on the point EC_BKSLP to make the following change: 
o Toggle on the Use Feature Name Override option and enter an override name of “BKSLP” 

and change the name to “EC_BKSLP3” then hit Apply. 
✓ Double-Click on the point EC_BKSLP1 to make the following changes: 

o Toggle on the Use Feature Name Override option and enter an override name of “BKSLP” 
and change the name to “EC_BKSLP2” then hit Apply. 

 
Review the component properties for the backslope components to set the override name. 
 

✓ Double-click the 2:1 Backslope component. Toggle on the Use Name Override option and set the 
override name to “Backslope” 
 

✓ Double-click the 3:1 Backslope component. Toggle on the Use Name Override option and set the 
override name to “Backslope” 

 
The completed template should appear as shown below. 
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✓ Use the Test option to ensure that the backslope components behave as intended. The 3:1 

backslope should solve first for backfills up to 5’ high. The 2:1 solution should solve for backslopes 
greater than 5’. 
 

✓ When complete, choose File > Save from the Create Template dialog to save the changes to the 
template library. 
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OpenRoads Software Version 

This document was prepared using the following software version: 

OpenRoads Designer CONNECT Edition – 2021 Release 1 Update 10 – Version 10.10.01.03 

 

Contacts 

For any questions, suggestions, or problems with this document please contact the ODOT Office of CADD 

and Mapping Services by use of the following form on the ODOT website: 

https://odot.formstack.com/forms/cadd_servicerequest 

 

 

https://odot.formstack.com/forms/cadd_servicerequest

