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OpenRoads Design: 
Intersection Modeling 

 

Exercise 1: St. Peter Road Corridor 

The St. Peter Road corridor model will be created in its own design file. The design files for the corridor 

models were created in a previous exercise. Take the following steps to prepare the 12345_KM002.dgn file 

for the corridor modeling process. 

✓ Open ProjectWise Explorer 

 
 

✓ Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

✓ Browse to the 400-Engineering\Roadway\Basemaps\ folder. 

✓ Open the file 123456_KM002.dgn. 

✓ From the Home tab, choose Attach Tools > References to attach the following references with a 

Nest Depth value of 0: 

• Survey Field Book: 

o 300-Survey\Basemaps\123456_FB001.dgn 

o Set the survey terrain model as the active terrain model (Use the Element Selection 

tool to select the terrain boundary, allow the cursor to pause over the boundary 

element until the pop-up menu appears. Choose the Set As Active Terrain icon). 

• Geometry for proposed S.R. 185: 

o 400-Engineering\Roadway\Basemaps\123456_BK001.dgn 

• Geometry for Existing St. Peter Road: 

o 400-Engineering\Roadway\Basemaps\123456_BK002.dgn 

• S.R. 185 Corridor Model 

o 400-Engineering\Roadway\Basemaps\123456_KM001.dgn 

• Before closing the References dialog, turn off the display of the self-referenced 3D model, 

Design-3D 

The template for St. Peter Road was created in a previous exercise. Take the following steps to create the 

corridor model for St. Peter Road 

✓ Use the Element Selection tool select the alignment for St. Peter Road. Allow the cursor to rest on 

the alignment element until the pop-up menu appears. Select the Create Corridor icon. 

 

✓ Create the corridor using the settings shown below. 
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The corridor is created like the example below. 
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Exercise 2: St. Peter Road Intersection using a Civil Cell 

This exercise will demonstrate the use of a civil cell for the intersection of St. Peter Road with S.R. 185. 

Part 1: Placing the Civil Cell 
With the references attached and the existing terrain active, take the following steps to place a civil cell for 

the St. Peter Road intersection: 

✓ From the Model Detailing tab, select the Place Civil Cell command 

 
✓ Choose the Browse button to select the civil cell. 

 

 

 

 

 
 

The Pick Civil Cell dialog is opened 

 

 
o Choose the T-Intersection civil cell shown above and select OK 
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The civil cell requires two elements for placement: The centerline of the intersecting road 

and the edge of pavement of the through road. 

 

o When prompted, select the element that represents the centerline of the intersecting road 

(St. Peter Road) and the through Edge of Pavement for S.R. 185. 

  

After selecting the two reference elements, the solution is displayed. Depending on the direction of the 

elements and how the civil cell was created, the solution may of may not appear correctly. 

In the example below, the direction of the elements differs from the way the civil cell was created. This can 

be remedied by clicking on each of the reference elements to view different placement alternatives. 

 

Left-clicking on the center line of St. Peter Road will reverse the direction of the element for the civil cell 
placement as shown below.  
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The edge of pavement element can also be reversed by left-clicking the edge of pavement line. 

 
✓ When the solution appears correct, issue a reset (right-click) to skip the process of viewing 

alternatives 
 

✓ Issue a data-point (left click) to accept the civil cell placement. 2D and 3D graphics are placed to 
represent the surface of the intersection. 
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The length of the civil cell overlaps the St. Peter Road corridor. This can be corrected either by editing the 

civil cell length, or my adjusting the ending location of the corridor. 

✓ To adjust the corridor, select the template range graphic, and then select the arrow handle to move 

the ending location of the corridor. The location can be specified by snapping to the end of the civil 

cell as shown below. 

 
✓ To adjust the civil cell, select the civil cell element that overlays the St. Peter Road alignment. The 

length of the civil cell is a rule that can be edited (the value is 100.000’ in the example below), or the 

length can be dynamically modified by choosing the left arrow at the end of the civil cell and 

dragging the length to the desired location. 
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The civil cell can be edited to further meet specific project requirements. Take the following steps to edit 

the lane widths for the civil cell: 

✓ Use the Element Selection command to select the edge of pavement on the north side of St. Peter 

Road 

o The underlying rules for the element are displayed but are grey cannot be edited until the 

underlying element is selected. 

o Right-click the element until the rules are editable 

o Select the center lane width rule. Change the value to -10 

o The edge of pavement is adjusted to the new value 

o Repeat this process to change the lane width for the opposite side to a value of 10 

 
✓ The same type of editing can be applied to the radius returns. 

o Edit one of the radius returns to use a radius value of 40’ 

▪ Observe the behavior of the civil cell elements. The interval displayed for the edge of 

pavement is automatically adjusted according to the new radius value and the 

surface terrain model for the civil cell is also adjusted in response to the radius 

change 

o Change the edited radius value back to 50’ 

 

✓ Additionally, the radius returns have start and ending offset values for the tie-in with the edge of 

pavement lines. This is useful for meeting differing pavement widths on each side of the 

intersection. 

o Select the radius return element on the south of St. Peter Road. The Properties dialog can be 

used to edit various parameters. From the Fillet Rule group, change the Ahead Offset value 

to -12. The fillet is adjusted as shown below. 
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✓ Change the Ahead Offset parameter back to 0 
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Part 2: Defining the Pavement Buildup 
The pavement surface for the intersection is placed as a terrain model. The feature definition assigned to 

the terrain model is P_Pavement_Surface which is configured to display contour lines for the pavement 

surface at 0.1’ intervals. 

To complete the St. Peter road pavement, a template will be applied to the surface terrain. Take the 

following steps to apply a template with the pavement buildup for St. Peter Road: 

✓ From the Corridors tab, select Template > Create Template 

o Copy the St. Peter Road Template 

o Paste the copy into the Project Templates folder 

o Rename the copied template to St. Peter Road Pavement 

o Double-click the St. Peter Road Pavement template to make it active 

o Right-click in the Current Template window and choose the Delete Components 

command. Delete the shoulders and the side slopes on both sides of the template 

o Delete the pavement layers for the left lane, leaving the pavement layers for the right lane in 

place 

o Delete the Null points above the pavement layers (right-click on each point and choose the 

Delete Point command) 

o Close and save the template library 

The completed St. Peter Road Pavement template contains only the pavement as shown below. The 

pavement slope and width of the components is irrelevant as the terrain model for the intersection will 

define the slope and width. 

 
Take the following steps to assign the pavement template to the intersection terrain model. 

✓ From the Model Detailing tab, select Apply Surface Template 

o When prompted to Locate a Terrain Model, select the surface terrain model for the 

intersection 

o Select No for the Apply Clipping Boundary option 

o Choose the St. Peter Road Pavement template 

o Left-click (data point) to accept the selection 

o Data point to accept the selection. The pavement template is applied to the terrain model as 

shown below. 
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Part 3: St. Peter Road Shoulder Templates 
A new template is necessary to define the pavement, shoulders, and side slopes for the St. Peter Road 

intersection area. 

Take the following steps to create the radius return template: 

✓ From the Corridors tab, select Template > Create Template 
o Copy the St. Peter Road template 

o Paste the copy into the Project Templates folder 

o Rename the copied template to St. Peter Road Shoulder 

o Double-click the St. Peter Road Shoulder template to make it active 

o Right-click in the Current Template window and choose the Delete Components 

command. Delete the pavement, the left shoulder, and end conditions on the left side. Leave 

the right shoulder and the right end conditions in place. 

o Delete the null points above the pavement layers (right-click on each point and choose the 

Delete Point command) 

At this point, the template should appear like the example below. 

 
The shoulder components are currently located 10’ right of the origin. The next step is to move the 

shoulder to the 0,0 origin in the template dialog. 

✓ Open the Dynamic Settings dialog to ensure the Step values are defined 
 

✓ Right-click on point R-ACSC_T_EP and choose the Move Point command. Move the point to the 

(0,0) position 
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Notice the point at the shoulder break is partially constrained (the point location is show with a yellow 
plus sign indicating that only one constraint is defined). When the pavement lane was deleted, the rule 
for the slope was removed since it referred to point PGL as part of the rollover lock definition. Take the 
following steps to define a Slope constraint for point R-ACSC_T_SB: 
 
✓ Double-click point R-ACSC_T_SB to access the Point Properties dialog. Add a Slope constraint to the 

point with a -4.00% slope from point R-ACSC_T_EP as shown below.

 

The completed template for the radius returns should appear as shown below 

 
✓ Save and close the Template library. 
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Take the following steps to apply the St. Peter Road Shoulder template to the edge of pavement tangent 
lines and the radius return elements: 
 

✓ Select the right radius return graphic and choose the Apply Linear Template command from the 
pop-up menu. Alternately, the Apply Linear Template command can be selected from the Model 
Detailing tab. 

 
✓ Choose the St. Peter Road Shoulder template from the library 

o The template can be applied for a portion of the selected graphic, or the entire element. 
Define the Start Station and End Station to encompass the entire length of the element by 
using the <ALT> key  

o When applying a linear template, the template can be placed on either the left or right side 
of the selected element. When prompted to Select Side – Reflect Option, issue a data point 
on the side of the element that you wish to apply the template 

o Use the default Exterior Corner Sweep Angle value of 5 degrees 
 

The template is applied to the radius return. Repeat the process for the remaining edge of 
pavement lines and radius return. 

 
When complete, the intersection should appear like the example below. 
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Part 4: Adjusting the S.R. 185 Corridor in the Intersection 
The last step is to remove the left shoulder and end conditions on the S.R. 185 corridor through the 
intersection area. 
 
The template for S.R. 185 is defined with Null Points to seek an intersection with an element in the design 
that defines the limits of the intersection. If the intersection graphic element is found, a display rule is used 
to turn off the side slopes. 
 
Take the following steps to draw a line in the design that will be used as the intersection element the null 
point will seek: 
 

✓ Open the design file containing the corridor model for S.R. 185 
400-Engineering\Roadway\123456_KM001.dgn 

 
✓ Attach the St. Peter Road corridor as a reference 

o From the Home tab, select Attach Tools > References to attach the following file: 
400-Engineering\Roadway\123456_KM002.dgn 

 
✓ From the Geometry tab, choose Standards > Feature Definition Toggle Bar 

o Set the Feature Definition to Linear\Modeling > Template Points > Misc > 
MD_P_INTERSECTION_MATCHLINE 

o Turn on the Use Active Feature Definition option  
o Turn off the Persist Snaps and Rule option as shown below 

 
  

✓ From the Geometry tab, Horizontal group, select Offsets and Tapers > Single Offset Partial 
o When prompted to Locate Element, choose the S.R. 185 alignment 
o Name the element St. Peter Match Line 
o Create an offset line 50’ to the left of S.R. 185 by snapping to the radius returns of St. Peter 

Road 
 

The completed line should be like the example shown below. 
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The match line element must be added as a corridor reference to the S.R. 185 corridor for the template to 
find the graphic. Take the following steps to add the match line element as a corridor reference: 
 

✓ From the Corridors tab, select Corridor References > Add Corridor Reference 
o When prompted to Locate Corridor, choose the S.R. 185 corridor 
o When prompted to Locate First Reference, choose the match line element 
o Reset (right-click) 

 
The element is added as a corridor reference and the corridor is reprocessed. The corridor model 
should appear like the example below. 
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Depending on the template drop interval and the location of the radius returns, there may be a gap 

in the model as shown above. This can be remedied by inserting a key station on the S.R. 185 

corridor to ensure that the model is processed up to the station where the radius return starts. 

Take the following steps to insert a key station on the S.R. 185 corridor: 

✓ From the Geometry tab, select Edits > Create Key Station 

o Make sure the Persist Snaps and Rule option is toggled off in the Feature Definition toggle 

bar when adding key station locations to a corridor 

o When prompted to Locate Corridor, choose the S.R. 185 corridor 

o Identify the station by snapping to the radius return at the point where it meets the S.R. 185 

edge of pavement but do not accept this location 

o This function works best if you use a station value that is slightly outside of the range of the 

radius return. For example, if the station value is 399+89.30 at the snap point of the first 

radius return, key in a value of 399+89.29 that is just before the start of the radius return. 
For the second radius return, key in a station value that is just beyond the ending station 

value. 

 

Note: You can adjust the key-point location after it has been placed by selecting the line that 

is drawn at the key point location and then edit the station rule. 

The key station graphic is drawn on the level CM_Corridor_Key_Station 

There may be a small gap on the south end of the intersection as well. Inset another key station 

to close this gap. 

 

This completes this exercise. 

✓ Exit OpenRoads Designer and check the file back in to ProjectWise. 
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Optional Exercise 3: Intersection Modeling Step-by-Step 

This section will step through the process to model the intersection of S.R. 185 and St. Peter Road using the 
OpenRoads tools without the use of a civil cell. This exercise is used in place of Exercise 2 Part 1 above. 

Process Overview 
The process to model the intersection will take several steps as summarized below: 
 

• Define the Horizontal and Vertical geometry for each road 
• Create Templates for each road 
• Model the mainline corridor 
• Model the side road corridor 
• Add radius returns to the side road and define the vertical profile for each of the radius returns 
• Modify the mainline corridor to remove any side slopes through the limits of the intersection 
• Adjust the side road corridor to end at the radius return 
• Create a surface terrain for the pavement surface of the side road in the intersection area. The 

surface terrain is defined by the radius returns, the edge of pavement for the mainline corridor, and 
the centerline and profile of the side road corridor. 

• Apply a “surface template” to the surface terrain of the intersection. This will establish the 
pavement buildup components beneath the pavement surface terrain. 

 
Apply linear templates to the radius returns to model the shoulders and side slopes for the intersecting side 

road. 

Modeling the Intersection Pavement 
The corridor for St. Peter Road was created up to station 19+25 in this example. Ending at this station will 
allow room for modeling the intersection with S.R. 185. The intersection will be modeled by first defining a 
terrain model representing the pavement surface for the intersection. Start by placing the edge of 
pavement lines and radius returns for the intersection. 
 
The edge of pavement lines and the radius returns must be created using Civil Geometry tools. Take the 
following steps to create the edge of pavement lines: 

 
✓ From the Geometry tab, open the Features Definition Toggle Bar by choosing Standards > Feature 

Definition Toolbar. Set the active feature definition to Linear > Pavement > 
PV_P_Edge_of_Pavement.  
 

✓ In the Features Definition Toggle Bar, toggle on the Use Active Feature Definition option 
 

✓ From the Geometry tab, choose Offsets and Tapers > Single Offset Partial. This command is used 
to place a civil geometry element at an offset from the selected alignment. 

 
o When prompted to Locate Element, choose the St. Peter Road alignment. 
o Enter a Name for the element a shown below, R-EOP St Peter Road. 
o Using an Offset of 10’, define the starting point of the offset element by snapping to the edge 

of pavement line at the end of the corridor as shown below. 
o Enter the End Distance by entering the <ALT> key to lock to the end of the alignment. 
o When prompted to Mirror the solution, choose Yes. 
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o The mirrored line is named R-EOP St Peter Road1. Change the name to L-EOP St Peter 
Road by selecting the line element and choosing the Properties command from the pop-up 
menu. 

 

 
Next, assign a profile to the newly created edge of pavement elements. 

 
✓ From the Geometry tab, choose Element Profiles > Profile By Slope From Element 

 
o When prompted to Locate First Element to Profile, choose one of the edge of pavement 

elements. Continue by choosing the other element when prompted to Locate Next Element 
to Profile. After choosing both elements, right click (reset) to end the selection process. 

o Choose the centerline of St. Peter Road when prompted to Locate Reference Element. 
o Enter a Slope value of -1.6% 
o Choose the Point Selection mode All 
o Use a Profile Adjustment of None 
o Enter a Vertical Offset of 0 

 
Next, create the radius returns for the intersection. 
 

✓ From the Geometry tab, select Arcs > Arc Between Elements > Simple Arc. 
 
Create the first arc on the right side of St. Peter Road using a 50’ radius. 

o Be sure to enter a Name of R-Radius St Peter Road for the radius return element. 
o Choose the R-EOP St Peter Road line as the first element. 
o When prompted to Trim/Extend, choose the Back option. 
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✓ Create the second arc on the left side of St. Peter Road with a Radius of 50’, a Name of L-Radius St 

Peter Road, and use the Trim/Extend Back option. 
 
Next, assign a profile to the radius return elements using the Quick Profile Transition command. 
 
✓ From the Geometry tab, select Element Profiles > Quick Profile Transition 

o After selecting the command, you are prompted to choose the Quick Transition Method. 
Select the Parabolic option. 

o When prompted to Locate What to Define, select one of the radius return elements. A 
quick profile is created for the element. 

o Repeat the procedure for the second radius return 
 

After the profiles are assigned, the edge of pavement and radius return lines should appear in the 3D 
model like the example shown below. 

 
The profile for each radius return can be reviewed and edited by selecting one of the radius returns and 
selecting the Open Profile Model command. The profile for R-Radius St Peter Road is shown below. 
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In addition to the two radius returns, it is necessary to define a line that follows the edge of pavement for 
S.R. 185 that extends from the ends of the radius returns. This is necessary to define the boundary of the 
intersection area that will be used to make the surface terrain model. We cannot use the edge of pavement 
line from the CLP_S185 corridor model as the line must be constrained to the limits of the radius returns. 
 
Since this new edge of pavement line will overlap the edge of pavement lines already drawn for the 
CLP_S185 corridor we will use a different feature definition. 
 

✓ In the Features Definition Toggle Bar, set the active feature definition to Modeling > Template 
Points > Misc > MD_P_DNC. The initials “DNC” stand for Do Not Construct. This feature definition 
can be used for linear elements used in the modeling process whose graphics will not be used for 
part of the plan production process. Graphics drawn with this feature are placed as construction 
elements on the level MD_P_DNC. 
 

✓ From the Geometry tab, choose Offsets and Tapers > Single Offset Partial. 
o Create an offset line 12’ to the left of the CLP_S185 alignment from the ends of the radius 

returns. 
o Because this new line is drawn on top of the edge of pavement line for S.R. 185, it is easier to 

temporarily turn off the reference file display of the S.R. 185 corridor model to ensure the 
line was drawn correctly. Open the References dialog and turn off the display of the 
12345_KM001.dgn file. 
 

The completed graphic should appear like the example below. 
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Next, assign a profile to this new DNC line. 

✓ From Geometry tab, choose Element Profiles > Profile By Slope From Element. 
o When prompted to Locate First Element to Profile, choose the DNC line 
o Reset (right-click) to complete the location process 
o When prompted to Locate Reference Element, choose the S.R. 185 alignment 
o Define the profile with a -1.6% slope from the centerline of S.R. 185 

 
The edge of pavement and radius return lines will be used to define the boundary of a terrain model for the 
surface of the pavement in the intersection. 

 
✓ From the Terrain tab, choose the From Elements command. 

 
o Set the Feature Type to Boundary 
o Set the Edge Method to None 
o Set the Feature Definition to Terrain > Proposed > 

P_Pavement Surface. Since this is a terrain feature it 
cannot be selected from the Feature Definition tool 
bar. 

o Set the feature Name to St Peter Road 
o When prompted to Locate Elements to Add, choose 

the edge of pavement and radius returns for St. Peter 
Road as well as the DNC for S.R. 185 (five elements total – don’t forget the edge of pavement 
lines for St. Peter road between the radius returns and the corridor). 

o Reset when the elements are selected. 
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The surface is created, and contour lines are 
drawn as shown at right. 

 
One more graphic is necessary to complete the 
pavement surface definition. The center line and 
profile of St. Peter Road will be added to define the 
crown of the pavement surface. This will be 
accomplished by creating one more partial offset 
element. 
 
✓ In the Features Definition Toggle Bar, set the 

active feature definition to Modeling > 
Template Points > Misc > MD_P_DNC. 
 

✓ From the Geometry tab, choose Offsets and 
Tapers > Single Offset Partial command. 
 

✓ Choose the centerline of St. Peter Road when prompted to Locate Element. 
 

o Start the line at the end of the St. Peter Road corridor, Station 19+25 with an Offset value of 
0. 

o Use the MicroStation Intersection Snap to end the line at the intersection of St. Peter Road 
with the S.R. 185 Edge of Pavement. 

  

After placing the line, assign a profile to the line using the Profile By Slope From Element command. 
 

✓ From the Geometry tab, select Element Profile > Profile Slope from Element 
✓ The Reference Element is the centerline of St. Peter Road. 
✓ Since the new element overlaps the centerline of St. Peter Road, use a Slope value of 0.0%. 

 

The 3d line is created as shown below. 
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Add this new partial offset line to the surface terrain model as a break line. 

✓ From the Terrain tab, select Feature Management > Add Features. 
o When prompted to Locate Terrain Model to Add Elements, select the St. Peter Road 

pavement surface terrain model. 
o When prompted to Locate Element to Add, select the DNC line at the center of St. Peter 

Road. 
o Reset (right-click) 
o Set the Feature Type to Break Line 

 
After the break line element is added, the St Peter Road terrain model should appear like the example 
below. 

 
The process to define the pavement buildup, add the shoulder and side slopes, and trim the S.R. 185 

corridor model through the limits of the intersection are detailed in Parts 2, 3, & 4 of Exercise 2. 

This completes this exercise. 

✓ Exit OpenRoads Designer and check the file back in to ProjectWise. 
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OpenRoads Software Version 

This document was prepared using the following software version: 

OpenRoads Designer CONNECT Edition – 2021 Release 1 Update 10 – Version 10.10.01.03 

 

Contacts 

For any questions, suggestions, or problems with this document please contact the ODOT Office of CADD 

and Mapping Services by use of the following form on the ODOT website: 

https://odot.formstack.com/forms/cadd_servicerequest 

 

 

https://odot.formstack.com/forms/cadd_servicerequest

