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OpenRoads Survey: Terrain Models  
 

The OpenRoads tools provide functions to generate terrain models from multiple sources. Traditional topo 

survey, ground and aerial based LiDAR data are frequently used to generate the existing ground terrain 

model, and can be combined to create a single terrain model as necessary. 

This document will discuss the process to create a combined complex terrain model from three sources: 
ground survey, ground based LiDAR data, and Aerial LiDAR data. 
 

Design File Types for Existing Ground Terrain Models 

The existing ground terrain model is usually created directly from the topo survey data in the Field Book 

(FB) design file. If the exiting terrain model will be combined using disparate data sources, it is best to 

create the combined terrain in a separate design file. The OHDOT CADD Standards include a new file type 

for a Field Digital Terrain Model (FD) that is used when the terrain model will be created by combining 

different sources. 

The OHDOT Create Design Files application provides three design file types used for Survey processing as 

shown below. 

 

If the terrain model will be generated from only the topo survey information, the best practice is to create 

the terrain model from the Field Book directly in the FB design file. 

The Point Cloud (PC) file type is used to generate a terrain model from LiDAR information. This file type 

may be used for ground based or aerial based LiDAR pint cloud information.  

The FD file type may be used for multiple purposes. 
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• Most commonly, the FD file type is used to create a combined terrain model from other sources. In 

this case, the other files are referenced to the FD file. The Create Complex Terrain Model 
command is used to generate the combined terrain model 

• The FD file type may also be used to create a terrain model from the Survey Data using the Create 

Terrain Model from Graphical Filter command. It is possible the WorkSet will contain multiple 

FD design files. 

Care must be taken to ensure that the design personnel understand which design file, FB or FD, contains 

the terrain model used for the design process. 
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Exercise 1: Creating a Terrain Model from the Survey Field Book 

This exercise will cover the process to create a terrain model from the topo survey information that was 
processed in section 300 of this training guide. 
 
Terrain models are typically generated in the Field Book (FB) design file. In some cases, it may be desirable 

to create the terrain model in a separate DGN file (FD) depending on the size of the project and the needs of 

the design personnel. 

If the terrain is created in the Field Book (FB) design file, editing the terrain by deactivating the survey 

processing rules is no longer recommended. An alternate method will be demonstrated in this manual. 

If the terrain is to be created in a separate FD design file, the process is summarized below: 

1. Create a 3D Terrain Model (FD) design file 

2. Attach the Field Book (FB) design file as a reference 

3. Use the Create Terrain from Graphical Filters command to generate a terrain model from the 

survey data in the Terrain Model (FD) design file. 

 

Note: At this time, we are not documenting this process since it is not typically used by ODOT’s 

survey personnel to generate the terrain model. There are graphical filters in the OHDOT 

WorkSpace intended to be used for his process, however with the current release of the software 
graphical filters based on Survey linear features and point features are not working. A defect has 

been logged with Bentley. 

Take the following steps to create a terrain model from the survey information that was processed in the 
previous chapter: 
 

• Open ProjectWise Explorer 

 
 

• Open the file shown below using your home District and your user name.  
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• Open the Survey tab in Project Explorer 

 

• Right-click on the Field Book and choose the Create Terrain Model… option as shown below 
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The terrain model is created in the 

active file as shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

Notes: 

The terrain model is named 

according to the name of the Field 

Book. The name can be edited in the 

terrain model properties dialog 

 

If there are multiple datasets 

contained in one field book, all of the 

datasets are combined to make one 

terrain model 

 

Point and linear features are used to 

create the terrain model according to 

the Terrain Model Attribute for the 

field code. 
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Terrain Model Properties 
Use the MicroStation Element Selection tool to select a terrain model in the design file. Allow the cursor to 
rest on the terrain model element for a few seconds to reveal the pop-up menu shown below. 

 

The following commands are available: 

• Properties 

• Set As Active Terrain Model 

• Export Terrain Model 

• Update From Source 

• Templates 

• Delete 

See the online help for more information on items not 

covered in this document. 

The Properties options are shown at right. 

Edge Method 
In the OHDOT workspace, the default Edge Method has 
been set to Max Triangle Length with a Length value of 
100. The following Edge Method options are available: 
 

• None 
• Slivers 
• Max Triangle Length 

 
The option to key in a Length value is only available when 
the Edge Method is set to Max Triangle Length. 
 

Feature Name 
The Feature Name is the name of the terrain model. This 
field may be edited as necessary. 
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Feature Definition 
The Feature Definition item is used to select the surface feature that will be used to control the terrain 
model display. Surface feature definitions are defined in OHDOT_Feature_Definitons.dgnlib. When using 
the OHDOT workspace, the surface feature X_Boundary is the default. This feature has been configured to 
display the terrain model boundary. 
 
Various feature definitions have been configured for ODOT projects. The Feature Definition is selected from 
the drop-down list as show below. 

 
 

• Change the Length parameter for the Edge Method to a value of 25. 
o Note the changes to the terrain boundary. Are there triangles missing that you would like to 

see included in the terrain model? 
o Try changing to a value of 50. 

 
• Change the feature definition to use one of the options that draws contour lines. Which contour 

interval works best for this dataset? 
 

• Change back to the X_Boundary feature definition when complete. 
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Terrain Model Editing 
 
The terrain model is dynamically linked to the survey points and lines. Edits made to the points and linear 

features that comprise the terrain model are immediately and dynamically reflected in the terrain model. 

On the left and right side of the terrain model there are survey points included in the terrain that are 

located far enough away from the main portion of the survey that probably should not be included in the 

terrain. These points can be removed from the terrain by changing the Terrain Model Attribute value. 

• From the Survey Workflow Home tab, select the MicroStation Element Selection tool. Floating the 

cursor over a point or a linear feature will reveal the survey attributes as shown below 

 
• Select the point and allow the cursor to rest until the pop-up menu appears. Select the Properties 

icon 

 
• Change the Terrain Model Attribute value to Do Not Include. The point is immediately removed 

from the terrain model 
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Multiple elements can be removed from the terrain model by selecting the elements, and then 

changing the Terrain Model Attribute in the Properties dialog 

 

• Use the Element Selection tool to select all the points to the left of the terrain model 

 

• In the Properties dialog, change the Terrain Model Attribute value for the selected elements to 

Do Not Include. All the selected elements are immediately removed from the terrain model 
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• Repeat this process for the points on the right side of the terrain model. The edited terrain 

model should look like the example below 
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Removing Edge Triangles 
After survey processing and editing is complete, it may be necessary to delete some of the terrain model 

edge triangles that are formed in areas along the boundary of the terrain. 

The example below shows several triangles that are formed across an area where no survey data was 

collected 

 

Setting the terrain model’s Edge Method to Max Triangle 

Length with a shorter value can eliminate some of these 

triangles, however it may still be desirable to manually 

remove some of these triangles. 

 

 

 

 

Terrain models are “ruled” by the survey points and chains. Changes made to the survey points and chains 

are dynamically reflected in the terrain model. 

Previously, we had recommended deactivating the Survey Processing Rules to allow editing the terrain 

model directly. That workflow is no longer recommended. 

Deactivating the processing rules means that you cannot add any additional survey information to the 

design file without reactivating the processing rules. For example, if you are returning to an area previously 

surveyed to collect additional data, and that data will be processed as a new dataset in the same design file 

that has had the survey processing rules deactivated, the linework for any linear features will not be drawn 

since this function required that the survey processing rules are activated to generate the linework. 

The recommended procedure to remove edge triangles is as follows: 

• Add a Ruled Boundary to the terrain. This is a physical element that can be edited with the 

element manipulation tools. 

• Use the element manipulation tools, such as Inset Vertex, or Remove Vertex, to redefine the 

boundary and eliminate unnecessary edge triangles. 

The Add Boundary command is selected from Terrain > Edit > Boundary Options as shown below. 
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The tool has three methods: 

• Extract Graphic - extracts the current boundary for the triangulation to an editable 3D 

linestring. 

• Add Boundary - extracts the current boundary for the triangulation as an explicit boundary in 

the terrain element - ie locked boundary. 

• Add Ruled Boundary - extracts the current boundary for the current triangulation to an 

editable ruled draped boundary element. Deleting this element will remove the boundary from 

the terrain. 

Use the Add Ruled Boundary method to add a fixed boundary to the selected terrain model. This 

boundary element is ruled to the terrain. Edits to the boundary are automatically applied to the terrain 

model. 

Take the following steps to create a ruled terrain boundary 

• Choose the Add Boundary command 

 

• Set the Method to Add Ruled Boundary 

 

• Choose the Linear > Survey Office Use > Terrain Editing > X_Terrain_Boundary feature 

definition as shown at right 

 

• Enter a Name for the boundary element 

 
• Select the terrain model to add the boundary 
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After adding the ruled boundary, unnecessary edge triangles can be eliminated by editing the boundary 

element. 

• Change the triangle model feature definition to X_Triangles 

 

• From the Drawing tab, select the Modify > Insert Vertex command 

 
• Inset a vertex in the terrain boundary to eliminate unnecessary triangles in the lower right corner 

of the triangle model, as shown below. 
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Swap Line 
Another common triangle model edit is swapping triangle lines. This can be accomplished by graphically 

drawing a line in the file representing the new triangle leg, and then adding the line to the terrain as a 

break line. 

Take the following steps to add a break line to flip the triangulation lines: 

• Select the Survey > Office Use > Terrain Editing > 

X_Terrain_Break_Line element template as shown at 

right. The element template defines the active 

symbology settings. 

 

• Draw a SmartLine as shown below 

 

• Be sure to snap to the triangle vertices, or the Survey 

points so the elevation is defined for the SmartLine 

element 
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• Select the Add Features command from the Terrain > Edit group. 

 

• Add the SmartLine as a Break Line to the terrain. The triangles are swapped as shown below. 

 

Note: The triangles can be reverted by deleting the SmartLine element. 
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Exercise 2: Terrain Models from Point Cloud Data 

LiDAR data in LAS format from terrestrial scans or aerial sources is often incorporated with traditional 

ground survey information to create a combined terrain model for the project. This information can be 

imported directly from the LAS file to create the terrain model, or optionally imported as a Point Cloud in 

POD format in order to visualize the data in the design file. The POD file can be used to generate a terrain 

model for the point cloud. The terrain model can then be merged with the ground survey terrain 

information. 

When creating complex terrain models, the best practice is to use a separate design file for each data source 
rather than importing the data into the FB design file. This eliminates confusion over which terrain model 
should be used that can occur when there are multiple terrain models contained in one design file. 
 
In this exercise, we will generate two terrain models. The first is from a ground based terrestrial scan of the 
pavement surface in LAS format. The second is from aerial mapping in XYZ format. Each terrain model will 
be created in its own design file 

Part 1: Creating a Terrain Model from LAS Data 
 
The process to import LAS data into the Point Cloud (PC) design file is summarized below: 

1. Create a 3D Point cloud (PC) design file 

2. Optional: Use the Point Cloud tools to attach the LAS file and save a POD file 

3. Use the Create Terrain From Point Cloud tool to create the terrain model 

Take the following steps to import the point cloud information: 
 

• Open ProjectWise Explorer 

 
 

• Open the Field Book design file (FB) as shown below using your home District and your user name.  
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• Create a Point Cloud design file for the LiDAR data using the Ohio DOT > Apps > OHDOT Create 

Design Files application 
 

 
• Open the newly created PC design file 
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Optional: Create a POD File 
Bentley products use the POD file format for point cloud data. A POD file is not required to create the 

terrain model from the point cloud data, but can be useful if you want to visualize the point cloud data in 

ORD. 

Take the following steps create the POD file: 

• From the Survey workflow Home tab, select Attach Tools > Point Clouds as show below 

 

• From the Point Clouds dialog, select File > Attach. 

o Change the Filter to LAS (*.las) to attach the following file: 

300-Survey\SurveyData\FieldData\MRW-314-2057-SCAN-Scaled.las 

 

• The Convert LAS dialog is opened. Change the 

Source Geometry Unit to Survey Feet. Select 
OK to initiate the process 

 

• The Specify new pod file dialog is opened. Save 

the new POD file to the 300-

Survey\SurveyData\FieldData\ folder. 

 

The point cloud is created in the file and 

displayed as show below. 
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• Use the Element Selection tool to select the point cloud in the design file. The properties for the 

point cloud are displayed in the Properties dialog as shown below. 
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Change the Level for the point cloud to 

PC_PointCloud1 as shown at right 

 

• If desired, change the Weight to 1. This will display the 

individual points a little bolder in the design file 

 

 

 

 

 

 

 

 

 

 

Create the Terrain Model 

The terrain model can be generated from the POD file, or directly from the LAS file. 

To create a terrain model directly from the LAS file, from the Survey workflow Terrain tab, select the 

From File option as shown below. Choose the LAS file type from the Select Files to Import dialog. 

 

In this exercise, we will create the terrain model from the POD file. Take the following steps to generate a 

terrain model from the point cloud POD file: 

• From the Survey workflow Terrain tab, select the Additional Methods > Create From Point 

Cloud command 
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• Create the terrain using the settings shown below. The Feature Definition is set to Terrain > 

Existing > X_Triangles2 in this example 
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The terrain is created as shown below. Note: The image has been rotated 90 degrees to show the terrain 

horizontally on the page. 
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Take the following steps to rename the terrain model: 

• Select the terrain model with the MicroStation Element 

Selection tool 

 

• In the Properties dialog, change the Feature Name 

parameter to MRW-314 Ground Scan as shown at 

right 

 

 

 

 

 

 

In some cases, it may be desirable to define a boundary for the terrain to eliminate triangles that span 

across areas where no data was collected. In the example above, the triangles formed at each end of the 

terrain model are crossing across the pavement surface and do not accurately represent the cross slope of 

the pavement. The best way to eliminate these triangles is to define a boundary for the terrain model. 

Take the following steps to generate a boundary for the terrain: 

• Review the terrain model Properties to refine the Edge Method parameter. Use the Element 

Selection tool to select the terrain model. Let the cursor rest in place for a second until the pop-up 

menu appears. Select the Properties option 

 
A portion of the terrain model properties dialog is shown 

at right. 

 

• Set the Edge Method to Max Edge Length. Experiment 

with different values for the Length. Be sure to review the 

entire terrain model to see how the value is applied to the 

surface. Values that are too short will result in eliminating 

some triangles that you may wish to keep. 
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• With the Edge Method set, the northern end of the terrain should look like the example below 

 
Note that there are some triangles formed that still cross over the pavement crown. A boundary 

element can be defined to further constrain the formation of triangles as described below 

 

• From the Survey workflow’s Terrain tab, select the Add Boundary command 

 
• Add a boundary to the terrain using the following settings: 

 

Set the Method parameter to use the Add Ruled 

Boundary option. 

 

Use the following Feature Definition: 

 

Linear > Survey Office Use > Terrain Editing > 

X_Terrain_Boundary 

 

 

 

• The boundary element is drawn around the external limits of the terrain model. This element can 

be modified as necessary to constrain the triangles. 
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The triangles at both the north and south ends 

of the point cloud cross over the crown of the 

pavement. These triangles do not accurately 

represent the pavement slope and can be 

removed by establishing a new boundary. The 

northern end of the point cloud is shown at 

right. 

 

 

 

 

• Use the Survey > Drawing > Manipulate > Insert Vertex command to add vertices to the 

boundary element. Before starting to insert vertices, it is useful to set the Point Cloud weight to a 

value of 5 to see the points while editing (Use the Element Selection tool to select the Point cloud 

element and change the Weight parameter to a value of 5). 

 
 

Add vertices corresponding to the point locations. This will dynamically clip the terrain model to 

the boundary as edits are made. When complete, the terrain model boundary at the north end of the 

project should appear like the example as shown below 
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The Delete Vertex command also useful to edit the terrain boundary element. 

 

• Repeat this process to define a new boundary for the southern end of the terrain 

 

• Be sure to review the triangles along the edges of the terrain model. Are there areas on the sides 

that you would like to constrain to a new boundary? 

 

When complete, the terrain model should appear similar to the example delow. 

 

 

 

 

 

Notes: 

o The example below has been rotated 90 degrees for display on this page. 

o The Point Cloud Weight parameter was changed to a value of 0 after editing. 
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Part 2: Creating a Terrain Model from Aerial Point Cloud Data 
The process to create a terrain model from Aerial point clouds is like the above example to create a point 

cloud from a terrestrial scan with one notable exception: 

• The aerial point cloud data is not in ground coordinates, nor does it have a sister file to define the 

coordinate system. It is necessary to set the design file to use the appropriate State Plane 

coordinate system for the point cloud data. 

The process to import LAS data into the Point Cloud (PC) design file is summarized below: 

1. Create a 3D Point cloud (PC) design file 

2. Optional: Use the Point Cloud tools to attach the LAS file and save a POD file 

3. Use the Create Terrain From Point Cloud tool to create the terrain model 

Take the following steps to create a terrain model for the aerial point cloud data: 

• Open ProjectWise Explorer 

 
 

• Open the file shown below using your home District and your user name.  

 
• Create a Point Cloud design file for the LiDAR data using the Ohio DOT > Apps > OHDOT Create 

Design Files application 
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• Open the new design file 

 

• From the Drawing workflow, choose Utilities > Geographic > Coordinate System  

 

• Change the point cloud to the appropriate coordinate system. Marrow County is in the 

OH83/2011-NF coordinate system 

 
• Select the OK button to apply the coordinate system definition to the file 
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Optional: Create a POD File 
Bentley products use the POD file format for point cloud data. A POD file is not required to create the 

terrain model from the point cloud data, but can be useful if you want to visualize the point cloud data in 

ORD. 

Take the following steps create the POD file: 

• Select the Attach Point Cloud command 

 
• Attach the following file: \300-Survey\SurveyData\FieldData\n190350.xyz 

 

The Convert ASCII Files dialog is opened as shown below. 
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• Set the Source Geometry Unit appropriately for the source data. In this example, set the parameter 

to Survey Feet 
 

• Select OK to convert the ASCII data to a point cloud. Save the point cloud file in the \300-

Survey\SurveyData\FieldData\ folder 

 

The point cloud data is displayed in the file like the example below. 

 

 
• After saving the POD file, use the MicroStation Element Selection tool to select the point cloud in 

the design file and change the level to PC_PointCloud1 
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Create the Terrain Model 
The terrain model can be generated from the POD file, or directly from the LAS file. 

To create a terrain model directly from the LAS file, from the Survey workflow Terrain tab, select the 

From File option as shown below. Choose the LAS file type from the Select Files to Import dialog. 

 

In this exercise, we will create the terrain model from the POD file. 

Take the following steps to create the terrain model from the POD file: 

• Use the Survey > Terrain > Additional Methods > Create From Point Cloud command to create 

a the terrain model for the point cloud using the X_Triangles3 Feature Definition. 

The Filter parameter may be used to thin the point cloud data. The Test Filter option will report 

the percentage of reduction as shown in the example below.  

 

• Select the Import button to create the terrain model. 
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Take the following steps to rename the terrain model: 

• Select the terrain model with the MicroStation 

Element Selection tool 

 

• In the Properties dialog, change the Feature Name 

parameter to MRW-314 Aerial Terrain as shown at 

right 

 

 

 

 

 

 

 

 

 

 

 

 

This completes Part 2 of the exercises. 
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Exercise 3: Create Complex Terrain Model 

In this exercise we will create a terrain model by combining the ground survey terrain model with the 
terrestrial scan terrain model and an aerial terrain model. 
 
Take the following steps to create a terrain model for the aerial point cloud data: 

• Open ProjectWise Explorer 

 
 

• Open the file shown below using your home District and your user name.  

 
• Use the OHDOT Create Design Files application to create a Digital Terrain Model (FD) design file. 

This file is created in the 300-Survey\Basemaps folder 
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• Open the newly created design file 

 

• Use the Attach References command to attach the design files that will be used to create the 

combined terrain model, listed below 

o 300-Survey\Basemaps\96213_FB001.dgn 

o 300-Survey\Basemaps\96213_PC001.dgn 

o 300-Survey\Basemaps\96213_PC002.dgn 

 

When attaching the PC002 design file containing the Aerial information, be sure to set the 

Orientation to use the Geographic - Reprojected option. 
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• Select the Create Complex Terrain Model command 

 
The Create Complex Terrain Model dialog is opened like the example below. 

 
The available terrain models from the active design file and references are listed at left. 

 

• Select the base terrain model from the left and choose the Add button to add it to the list on the 

right. 

 

• Select additional terrain models in the left one at a time. Select either the Merge or Append option 

(described below) and then click Add. 
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Append 
When appending, the software triangulates the combined data from the two terrain models using 
all data from both models and ignoring none. The two models may overlap or be adjacent to one 
another. If there is data in both models in a common area, it is all utilized for triangulation.  

 
Merge 
When merging, the software triangulates the combined data from the two terrain models in areas 
where they do not overlap. The two models must overlap at least one point. If there is data in both 
models in a common area (overlap), the data from the primary model is discarded, and only the 
data from the merging model is used. Therefore, order is critical. 

 
• The Process Order and the Merge/ Append options are critical. Add the data to the dialog as 

shown in the example below. 

 
• Set the Feature Definition for combined terrain model using one of the Terrain\Existing\ feature 

definitions. 
 

• Key in the Name for combined terrain model. MRW-314 Combined Terrain is used in the example 
above. 
 

• Select Finish to initiate the command. The combined terrain model is created in the active design 
file. 

 
This concludes this exercise. Save Settings and exit OpenRoads Designer when complete. 
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OpenRoads Software Version 

This document was prepared using the following software version: 

OpenRoads Designer CONNECT Edition – 2020 Release 3 - Update 9 – Version 10.09.00.91 

 

Contacts 

For any questions, suggestions, or problems with this document please contact the ODOT Office of CADD 

and Mapping Services by use of the following form on the ODOT website: 

https://odot.formstack.com/forms/cadd_servicerequest 

 

 

https://odot.formstack.com/forms/cadd_servicerequest

