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Section 100 OpenRoads Designer 
Introduction 

OHDOT OpenRoads Training Configuration 

This Ohio Department of Transportation training material is available for both internal and external users. 
This training guide is structured for ODOT’s internal users with the training data located in the ProjectWise 
environment. 

Training Guides 
ODOT’s training guides for ORD are available in the OHDOT CADD Standards. As these training guides are 
updated, the current version can be found in the following folder: 

For an installation of the OHDOT CADD Standards within ProjectWise: 

Ohio DOT Projects\Documents\03 Standards\CONNECT_Config\WorkSpaces\OHDOTCEv02\ 
Standards\OHDOT Utilities\Training\OpenRoads\ORD Design\ 

For an installation of the OHDOT CADD Standards external to ProjectWise: 

...\OHDOT\Standards\OHDOT Utilities\Training\OpenRoads\ORD Design\ 

The training guide is modular in approach, with each topic presented in individual documents. This allows 
ODOT to easily update individual sections without impacting other sections. 

Training Datasets 
For external users, the files used in this training are available in the OHDOT CADD Standards. See the 
following document for more information: 

...\OHDOT\Standards\OHDOT Utilities\Training\Setting up Training.pdf 

The training manual is presented in a modular approach; however, the training exercises are sequential 
with each training example building off the previous exercises. Additional datasets, with the sample project 
partially completed in various states appropriate for the exercises, are planned for a future update. 
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Bentley CONNECTION Client 

Bentley Connect licensing requires users to log into their 
Bentley account to secure a software license. 

ODOT users should log in using your ODOT email address. The 
password is automatically applied based on your ODOT 
credentials. 

Contact your District CADD Administrator if you are unable to 
log into your Bentley account. 
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OpenRoads Designer Introduction 

OpenRoads Designer (ORD) is Bentley’s civil design software solution for surveying, drainage, subsurface 
utilities, roadway, and site design. ORD supersedes Bentley’s previous design software packages InRoads, 
GEOPAK, MX, and Power Civil. 

ORD contains all the functionality of MicroStation CONNECT Edition with the addition of Civil design 
capabilities. 

ORD/SS10 Compatibility 
Many of the civil design and 3D modeling functions in ORD are identical in behavior and functionality to the 
OpenRoads tools that were available in previous Bentley civil design software offerings. However, the 
underlying technology has undergone significant enhancements and is not backwards compatible with the 
SELECTseries versions of InRoads, GEOPAK, MX, or Power Civil. Data can be exchanged between SS10 and 
ORD formats by use of XML files to export and import specific information. It is highly recommended that 
all users on the project, including any consultants or sub-consultants, use the same software versions. 

ORD Software Updates 
Bentley’s software updates alternate between major and minor revisions. 

• Major updates are indicated by the second 
number in the version number. These updates 
include new software functionality that changes 
the underlying software schema. Major updates 
are not backwards compatible with previous 
versions. 
 
In the example on the right, a file that was last 
edited with OpenRoads version 10.10 is opened 
with OpenRoads 23. Opening the file will 
upgrade the civil data to ORD 23. The file will no 
longer be editable in versions prior to 10.10 or 
10.12. 
 

• Minor updates do not change the underlying 
schema and do not require the file to be 
upgraded from a previous release with the same 
major version number. 

As ODOT moves forward with software updates and the CADD Standards for ORD are updated, some of the 
updates to the CADD Standards will not be backwards compatible with prior versions of ORD due to 
changes to the schema. Therefore, it is important for both internal and external users of ORD and ODOT’s 
CADD Standards for ORD to stay up to date with the current version of the software that is in use by ODOT. 

The current ORD version that is in use by ODOT can be reviewed at the following web page: 

https://www.transportation.ohio.gov/working/engineering/cadd-mapping/cadd/current-cadd-
software  

https://www.transportation.ohio.gov/working/engineering/cadd-mapping/cadd/current-cadd-software
https://www.transportation.ohio.gov/working/engineering/cadd-mapping/cadd/current-cadd-software


 
Ohio Department of Transportation 
Office of CADD and Mapping Services May, 2023 

 

Section 100 - OpenRoads Designer Introduction 100-4 
 

Ribbon Interface 

ORD presents the user with a modernized ribbon interface, much like the various Microsoft Office products. 
Learning the ribbon is relatively easy but it will take a little time for users to get familiar with the new 
command layout. 

The interface is organized by WorkFlows, Tabs, and the Backstage. Each is described below. 

WorkFlows 
The WorkFlow is selected by a drop-down menu in the upper left corner of the ORD interface. 

 

The WorkFlows present the various ORD commands logically 
organized according to a task. For example, the Drawing 
workflow contains commands that are used for typical 
MicroStation drawing tasks. 

Some of the most used drawing functions are available in the 
other workflows. 

 

 

 

Tabs 
When a Workflow is selected, the various commands are organized into Tabs like the example below. 

 

Each tab groups like commands into a logical organization of the various tools.  

Note: Most WorkFlows contain a Drawing tab with commonly used MicroStation drawing tools. 

 

Search Ribbon 
The Search Ribbon key-in field, which is located at the top-right of the ORD user interface, is useful to 
quickly find a desired command as you learn the ribbon interface without manually searching the ribbon. 
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As you key-in the name of a command, the Search Ribbon function will show a list of commands matching 
the text string as it is entered. An example is shown below. 

 

 

Most Recently Used commands 
matching the key-in entry are 
displayed at the top. 

Floating the cursor over one of 
the results will expand the item 
to list the various places in the 
ORD interface where the 
command can be found. 

Click on the command name, 
without expanding the list, to 
run the command. 

Click on the command location, 
with the list expanded, as shown 
at left, to navigate to the 
appropriate Tab in the ribbon. 

  

 

BackStage 
The ribbon contains commands that are used for ORD and 
MicroStation related drawing and design tasks. Tools that 
are not command related, such as Plotting, Design File 
Settings, User Preferences, etc. are in the “BackStage” 
view. 

To access the BackStage, select the File tab at the upper 
left of the ORD user interface. 

 

The BackStage has a list of commands at left, along with a list of recently opened design file, as shown 
below: 
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We will not cover all the functions available from the BackStage in this introductory class. Two of the most 
accessed functions are listed below. 

User Preferences 
User Preferences are accessed from the BackStage by selecting Settings > User > Preferences.  

Design File Settings 
Design File Settings are accessed from the BackStage by selecting Settings > File > Design File Settings. 
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ProjectWise 

ProjectWise, Bentley’s engineering project collaboration software, is used to manage, share, and distribute 
engineering project content. ProjectWise integrates with Bentley applications and other products including 
Autodesk software and Microsoft Office. 

With the migration to OpenRoads Designer (ORD), all internal projects started using ORD will be housed in 
ProjectWise. 

ProjectWise Explorer 
ProjectWise Explorer is used to access project information stored in ProjectWise. The application is 
accessed using the desktop shortcut shown below. 

 

Data Sources 
ODOT’s ProjectWise environment is configured with three main datasources as described below: 

 

• Ohio DOT Archive 
o Read Only repository for completed plan sets. 

• Ohio DOT Projects 
o Active projects directory (directly replacing the “idrive”). 
o All ODOT Connect projects will be housed here. 

• Ohio DOT Training-Testing 
o Sandbox area for training and testing which mirrors the active projects directory. 
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Select the datasource from the ProjectWise Explorer 

• The first time you access ProjectWise on any PC, you will see the create working directory dialog. 

 
• ProjectWise copies the working files to your local hard drive, called the Working Directory. It 

contains temporary copies of the document files that you checked or copied out from a ProjectWise 
server. 

Ohio DOT Projects 

• 00 Closed, Inactive and Cancelled Projects* 
o Archive of project data that is completed or cancelled. 

• 01 Active Projects 
o Active PID projects (replacement of the project data folder). 

• 02 Sold Projects 
o Project Data location when project is in construction. 

• 03 Standards 
o CADD Standards, Help Documents, Templates, etc. 

• 04 Admin Configuration 
o Access control models and other ProjectWise configuration documents. 

• 05 Additional Projects 
o Area where projects without a PID may be worked on using OHDOT standards. 
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Active projects are organized by District, County, and PID 
as shown in the image to the right.  

• The _D## folder is used for District-wide projects. 

 

 

 

 

 

 

Opening Files with ProjectWise 
Files are opened by double-clicking on the file name in the ProjectWise Explorer dialog. The file is opened 
with the associated program. Right-click on a file name and choose Open With to select the default 
program for a given file type. 
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The icons to the left of the file name are described below: 

 File has Read/Write access 

• The user can check out the file for revisions. While the file is checked out locally, the file on 
the server is locked to other users. 

 File has Read Only access 

• This symbol means the user can read the file but cannot edit the file. The user can view the 
file, but it remains available (and unlocked) to other users. 

 File is Checked Out by you (others see the Locked symbol) 

• A copy of the file has been sent to your local working directory for editing. The file remains 
locked to other users until you check the file back in. 

 File is Locked 

• The file is being accessed by another user (Checked Out or Exported) and is not available. 
Users can still open the file as Read Only. 

 File has been Exported by you (others see the Locked symbol) 

• Files are typically exported to a local folder and then worked on outside of ProjectWise. 
When finished, the files are then Imported back into ProjectWise. 

 File is in Final Status 

• No changes are allowed. This is an archived file status. 
 

When a file is opened from ProjectWise Explorer, the file is copied to your local computer and is locked on 
the server. Other users can view the file but cannot edit the file while it is checked out by another user. 

Changes to the file are not reflected on the server copy until one of the following actions is preformed: 

1. The file is closed and checked back into the server using the Check In option. 
2. The server copy is updated by choosing File> Update Server Copy in ORD. 

 

Opening Multiple MicroStation Design Files 
Double-clicking on a file name opens the selected file. By default, ProjectWise does not allow the user to 
open multiple design files simultaneously. If a MicroStation design file is currently opened, the software 
forces the user to close the current design file. 

Multiple files can be opened with ProjectWise as follows: 

• To open a second file for write access (assuming the file is not locked by another user), hold down 
the Shift key while double-clicking a file name. 

• To open a second file for read access, right-click the file and choose Open as Read-Only. 
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Closing Files 
After completing work on a document, in a supported application, ProjectWise will provide options for 
checking the document back into the server. 

• Check In 
o Upload any document changes from your local copy to ProjectWise and mark the file 

available to other users. 
• Update Server Copy 

o Updates any changes to ProjectWise but keeps the file checked out. (Also, under File > 
Update Server Copy.) 

• Free 
o Checks document in but ignores any local document changes. This command also purges the 

document from your local working directory. 
• Close 

o Dismisses the Check In window. Changes to the document are retained on your local copy 
but are not uploaded to ProjectWise and are not available for other users. The document 
remains checked out to you.  
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The OHDOT WorkSpace 

This section presents a brief introduction to the OHDOTCEv02 WorkSpace. More information can be found 
in the OHDOT CADD WorkSpace Basics training guide, available in the following location within 
ProjectWise: 
 

03 Standards\CADD Standards\CONNECT_Config\WorkSpaces\OHDOTCEv02\Standards\ 
OHDOT Utilities\Training\OHDOTCADDWorkSpaceBasics\ 

 
OpenRoads uses a WorkSpace to define the CADD Standards for a WorkSet. A Workspace is a custom ORD 
environment or configuration. By selecting a workspace, you are customizing ORD for a specific discipline, 
project, or task. The workspace contains pointers to the CADD standards, DGN libraries, cell libraries, seed 
files, symbology resources, etc. necessary for the project. 
 
ODOT maintains a custom WorkSpace for Open Roads Designer as described below. The CADD standards 
for ORD are maintained by the Office of CADD and Mapping Services. 
 
When you access an ODOT project through ProjectWise Explorer, you enter a managed workspace 
environment. The CADD Standards are defined for ODOT projects and do not need to be specifically 
selected by the user. 
 
ODOT’s CADD Standards for Bentley CONNECT products are housed within ProjectWise in the following 
location: 
 

Ohio DOT Projects > 03 Standards > CADD Standards > CONNECT_Config > WorkSpaces 

Two WorkSpaces that have been configured for ODOT Standards are available, OHDOTCEv01 and 
OHDOTCEv02, as described below. 
 

The OHDOTCEv01 WorkSpace (Retired 3/6/23) 
The OHDOTCEv01 WorkSpace has been superseded by the OHDOTCEv02 WorkSpace. This WorkSpace is 
provided to allow users to complete projects that were started with this WorkSpace. New projects are all 
configured to use the OHDOTCEv02 WorkSpace. OHDOTCEv01 will no longer be updated. 
 

The OHDOTCEv02 WorkSpace 
With the September 24, 2021, update to the ODOT CADD Standards, ODOT has released the OHDOTCEv02 
WorkSpace. This workspace differs from the previous version primarily with the fonts that are used for 
plan production. 

In the previous version, font Aerial was used for the annotation of both existing and proposed items. This 
made it difficult to differentiate between existing and proposed annotations. With the OHDOTCEv02 
workspace, ODOT is moving to using font Calibri Italic for proposed items and font Calibri Light for existing 
items. 

The OHDOTCEv02 WorkSpace also removes the old Drainage and Utilities dgn library (.dgnlib) from the 
standards. 

Projects started with the OHDOTCEv01 WorkSpace should normally be completed using that WorkSpace. 
As new projects are started, the OHDOTCEv02 WorkSpace should be used.  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services May, 2023 

 

Section 100 - OpenRoads Designer Introduction 100-13 
 

When projects are created, the WorkSet is associated with the WorkSpace. ODOT’s users do not need to do 
anything to select the appropriate WorkSpace for a project. The associated WorkSpace is automatically 
loaded when a design file is opened. 

The WorkSpace that is assigned to a WorkSet can be reviewed in ProjectWise by right-clicking on the 
WorkSet folder name and choosing the Properties option. 

 

From the WorkSet Area Properties 
dialog, select the WorkSpace tab to 
review the assigned WorkSpace as 
shown at left. 

In the ODOT environment, users are 
not permitted to change the 
WorkSpace that is assigned to a 
WorkSet. Contact the ProjectWise 
team if the WorkSpace needs to be 
changed for a WorkSet. 

The assigned WorkSpace can also be 
reviewed within a design file be 
selecting File > Settings > 
Configuration > About 
Configuration. 

Exercises in this manual use the 
OHDOTCEv02 WorkSpace. 
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WorkSets 

Projects in ORD are known as WorkSets. A WorkSet is used to house the files for each individual ODOT 
design project. WorkSets serve the following purpose: 

• Used to store all related project information. 
• Define the folder structure for the project. 
• House project specific CADD Standards. 

WorkSet Creation inside the ProjectWise Environment 
Projects that have been assigned an ODOT Project Identification Number (PID) are created in the Ohio DOT 
Projects > 01 Active Projects. 

Projects that do not yet have a PID number assigned but may be assigned a PID number at a future date are 
created in the Ohio DOT Projects > 05 Additional Projects data source. 

In either case, the District ProjectWise Administrator is tasked with creating new projects using a custom 
application. The application is available in the OHDOT CADD Standards in the following location: 

...\OHDOT\Standards\Applications\OHDOTCreateWorkSet.exe 

 

See the application’s support documentation for more information. 
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Geographic Coordinate Systems 
OpenRoads Designer (ORD) contains Geo-Coordination features which allow users to specify the position of 
the design contents on the earth´s surface. Once that position is established, the design can be easily 
coordinated with other data for which the geographic location is known. A library of predefined Geographic 
Coordinate Systems (GCS) is available in ORD. Additionally, custom coordinate systems can be defined for 
projects that have been mapped to ground coordinates by defining a custom coordinate system. 

When a GCS is initially selected, you are simply defining the coordinate system where the data resides. 
Choosing a GCS when one has not been previously defined does not re-project existing data in the design 
file to the selected GCS. The content of the design file will be re-projected when changing from one GCS to 
another. 

Once a GCS is defined, ORD understands the geographic location of your design and provides additional 
capabilities such as: 

• Referencing other geo-located designs and raster data. 
• Displaying geographic latitude and longitude. 
• Entering latitude and longitude data. 
• Interfacing with a Global Positioning System device to correlate your physical position with the 

design on a mobile computer. 

NOTE: The intent of the GCS is to define the location of the data for easy integration with other 
georeferenced data. It is not intended to be used “on the fly” to translate the data from grid to ground, or 
vice versa. Once defined, the survey data should be left in the defined coordinate system. 

When a new WorkSet is created in ProjectWise, the ODOT application that is used to create projects 
provides the option to identify the GCS for the project. The project can be defined to use the appropriate 
State Plane coordinate zone, or the coordinate system can be left undefined in preparation for defining a 
custom coordinate system. 

Before any work begins on the project, it is a best practice to discuss the coordinate system requirements 
with the District Survey Operations manager, and then to review the coordinate system assigned to the 
seed files for the project to ensure it has been correctly defined. 

Grid Coordinates: 

• If the project is mapped to grid coordinates, the coordinate system for the project is defined using 
one of the standard coordinate projection systems for Ohio. 

• The coordinate system is assigned to the seed files for the project when the project is created. 

Ground Coordinates: 

• If the project is mapped to ground coordinates, a custom Geographic Coordinate System (GCS) can 
be defined with the combined scale factor for the project. This step is not required, but it does 
provide advantages for users of the project data. 

• If a custom coordinate system is used, the project is created with No GCS assigned. A DTY file is 
copied into the project that can later be customized by the Surveyor with the combined scale factor 
for the project. 
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Reviewing the current GCS 
The seed files for the WorkSet are defined for the appropriate coordinate system. Open each seed file to 
ensure that the coordinate system is correctly defined. See files for the WorkSet are in the following folder: 

990-WorkSet Standards\Seed\ 

The GCS is defined by selecting Drawing > Utilities > Geographic > Coordinate System to access the 
Geographic Coordinate System dialog shown below. 

 

The current coordinate system is displayed on the 
dialog as shown at left. If no coordinate system has been 
defined, the Name will display “None”. 

If the correct system is assigned for the project, close 
the file, and continue reviewing the remaining seed files 
for the WorkSet. 

 

If the coordinate system is undefined, or set incorrectly, it is best to coordinate with the District Survey 
Operations Manager before making any changes. 

If a custom coordinate system has been defined by the Survey personnel, it will be named using the County 
and PID Number with the word “Ground” in the name like the example show below. 

 

The process to define a custom coordinate system for 
projects mapped to ground coordinates is detailed in 
ODOT’s training material for OpenRoads Survey. 
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WorkSet Folder Structure 
All ODOT projects use a standard folder structure for the WorkSet. An Excel file detaining the intended 
usage for each folder can be found in the ODOT Standards in the following location: 

• Ohio DOT Projects > 03 Standards > CADD Standards > CONNECT_Config > WorkSpaces > 
OHDOTCEv02 > Standards\OHDOT Utilities\Documentation\CONNECT_Project_Folders.xlsx 

A summary of the folders used for ORD design and drafting is included below. 

300-Survey 
• 300-Survey\Basemaps\ 

Used to store survey and existing basemap design files. 
DGN Files: 
o BA - Aerial Mapping 
o BC - Aerial and Ground Combined 
o FB - Ground Survey Basemap 

 No Alignments 
 No Right-of-Way 
 No Parcels 
 No Exceptions! 

o FD - New file for field terrain models 
o PC - New file for Point Cloud data 

Retired Files: 

o BE - No longer used for ORD Projects 

Notes: 

• By default, ODOT’s Roadway personnel have read-access to the 
300-Survey folder and sub-folders. 

• Designers will reference the Survey information. Any changes 
that are required by the design personnel must be coordinated 
with Survey. 

• New folders can only be created at the bottom level folders. 
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400-Engineering 
Each discipline specific folder in the 400-Engineering folder has three sub-
folders as shown at right. 

Alignments are stored in the following file: 

• BK – Geometry Basemap, located in the (400-
Engineering\Roadway\Basemaps folder). 

• One alignment per file. Use multiple files for multiple alignments. 
Example: 123456_BK001.dgn, 123456_BK002.dgn, etc. 

Notes: 

• ODOT’s Surveyors have Write access to the 400-Engineering folder 
and sub-folders. 

• ODOT doesn’t recommend using container files for alignments. 
Example: 123456_BK000.dgn, 123456_BK100.dgn, etc. 

 

 

 

990-WorkSetStandards 
CADD Standards specific to a project are stored in the 990-WorkSet 
Standards folder. When a new project is created in ProjectWise, WorkSet 
specific CADD Standards are placed in these folders as detailed below: 

• GCS 
o This folder contains the DTY file defining the Geographic 

Coordinate System in the case where a custom scale factor is 
defined for the project. The DTY file is copied from the OHDOT CADD Standards and is 
named “######_Custom.dty” using the PID number for the project. 

• Plotdrv 
o This folder contains the PSET file for the WorkSet. The file is copied from the OHDOT CADD 

Standards into this folder. The copied file is renamed “######.pset” using the PID number. 
• Seed 

o Seed files are copied from the OHDOT CADD Standards and renamed using the PID number 
for the project. 

o These seed files are defined using the appropriate Geographic Coordinate System when the 
WorkSet is created. 

o The Design seed files are renamed with the ODOT PID Number. 
o The Drawing and Sheet seed files are not renamed with the PID number. It is necessary to 

maintain generic names for these two seed files for the ORD sheet clipping process. 
• Template Library 

o The OHDOT_Templates.itl file is copied from the OHDOT CADD Standards into this folder. 
The copied file is renamed “######_templates.itl” using the PID number. 
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WorkSet Design File Names 
Design files are named using the format defined in the Location & Design Manual, Volume 3 - Highway 
Plans, Section 1204.3.4. 

Creating MicroStation DGN Files 
New Design Files are created within ORD by use of the OHDOT Create Design Files application. The 
application is accessed from the Ohio DOT Workflow by selecting the OHDOT Create Design Files icon as 
shown below. 

 

 

 

 

 

 

 

 

 The dialog is shown below. See the application help for more informati
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Section 101 WorkSet Exercises 
Exercise 

In this exercise we will access ProjectWise Explorer to open a design file, explore the ORD ribbon interface, 
and create a new design file for the WorkSet. 

Part 1: Accessing the Training Workset and Creating Design Files 
• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• From the training folder, browse to the 300-Survey\Basemaps\ folder 
• Right-Click on the file 123456_FB001.dgn and choose the Open With… option to open the file with 

OpenRoads Designer XXXX. Toggle the Always use the program option ON 

 
• Select OK to open the file. 
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Let’s review the Geographic Coordinate System (GCS) assignment. The seed files for all ODOT projects 
should have a GCS defined. 
 
After opening the file, take the following steps: 

 
• Select the Drawing Workflow from the upper left of the ORD interface 
• Select the Coordinate System icon from the Utilities tab to review the assigned coordinate system 

value. 
o What is the name of the currently assigned Geographic Coordinate System? 

__________________________________________________________ 
o There is no need to change the coordinate system parameters. If the coordinate system has 

not been defined, contact the survey personnel. 
o It is good practice to make sure the GCS has also been defined for the Seed3d and the 

Drawing Seed files. Open those seed files to verify the GCS has been defined. 
o As each file is opened, be sure to check the files back into ProjectWise using the Check In 

option when prompted. Alternately, since no edits were made to the file, the Free option 
can be used to release the file without saving any changes. 

Next, we will create some design files for the WorkSet. 

• Select the Ohio DOT Workflow from the top left of the ORD interface. 
• From the Apps tab, select the OHDOT Create Design Files icon 
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The application is opened as shown below: 
• Create the following DGN files: 

o Set the Filters to Roadway and Sheet as shown above. 
o Create the following files: 

 Title Sheet 
 Schematic Plan 
 Typical Sections 

Which Seed File is used to create these design files? ____________________________________ 
Which folder are the files created in? ___________________________________________________ 
What should be entered for the Comments field for each file? 

Title Sheet: __________________________________________ 
Schematic Plan: __________________________________________ 
Typical Sections: __________________________________________ 

 
What should be entered for the Scale field for each file? 

Title Sheet: __________________________________________ 
Schematic Plan: __________________________________________ 
Typical Sections: __________________________________________ 

 
• After creating the design files, close the Create Design File application 
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Part 2: Exploring the ORD Interface 
 

• Without using the Search Ribbon key-in (unless you absolutely cannot find the command), locate 
the following commands and write down the location where you found the command: 

 
Place Smartline _______________________________________________________________________________________________ 
Place Text _____________________________________________________________________________________________________ 
Edit Text _______________________________________________________________________________________________________ 
Annotation Scale ______________________________________________________________________________________________ 
OpenRoads Line Between Points ____________________________________________________________________________ 
OpenRoads Spiral-Arc-Spiral ________________________________________________________________________________ 
OpenRoads Create Template _________________________________________________________________________________ 
OpenRoads Create Corridor __________________________________________________________________________________ 
 

• What is the Geographic Coordinate System that is assigned to the file? _______________________________ 
How was the GCS assigned to the file? ______________________________________________________________________ 
 

• In which folder are the Seed files for the WorkSet located? 
__________________________________________________________________________________________________________________ 
 

• In which folder is the OpenRoads Template Library for the WorkSet located? 
__________________________________________________________________________________________________________________ 
 

• What is the name of the User Preferences file? ___________________________________________________________ 

This completes this exercise. 

• Exit the current file and check it back in to ProjectWise 
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Section 200 Working with ORD Survey 
Files 

Survey Basemaps 

Survey mapping processed with the OpenRoads Survey tools is written directly to a MicroStation design file 
without the use of any external databases. This “field book” (FB) design file is in the following folder within 
the ODOT WorkSet folder structure: 

..\PID\300-Survey\Basemaps\ 

The Survey information is processed in a 3D design file. Designers will work in 2D files and will attach the 
3D survey information as a reference attachment. 

An existing ground terrain model is typically generated from the survey information. The terrain model is 
typically contained in the FB design file in cases where the terrain is comprised of only the ground survey 
information. In cases where the survey information is combined with other terrain data, such as LiDAR 
data, the combined terrain model is usually stored in a separate design file using the “FD” two-character 
code in the file name. Contact the survey personnel for clarification on which design file contains the 
terrain model that is to be used for the project, particularly in cases where a complex terrain model is 
generated from multiple sources in a separate FD design file. 

Survey Data Integrity 
Protecting the integrity of the survey information has always been a concern for ODOT’s Survey personnel. 
The accuracy of the Survey information is the responsibility of the surveyor and therefore the original 
survey information should not be edited by design personnel. Under no circumstances should design 
personnel edit the survey data contained in the Survey field book FB design file. If changes need to be 
made to the survey files, these changes should be coordinated with the originator of the survey data. 

Survey Point Features 
When survey data is processed, each field shot is stored as a Point Feature in a Field Book within the 
survey field book FB design file. For example, the field code “PP” is used to designate a power pole. When 
the survey data is processed, the power pole code is plotted in the design file using an ODOT standard cell 
element as shown below: 
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When the survey field book is attached 
as a reference, the data for an 
individual point can be reviewed as 
follows: 

From the Home tab, choose the 
Element Selection command. Float 
the cursor over a referenced survey 
point and allow the cursor to rest over 
the element. 

A pop-up dialog will appear showing 
the survey information for the point as 
shown at left. 

 

 

 

With the December 2020 update to the OHDOT CADD Standards, macros have been added to annotate 
points like GEOPAK Survey. An example of the annotation placed by a macro for a point is shown below. 

 
 
 
 
 
 
 

 
 

These annotations are placed as text elements in the file on the levels listed below.  
 

Annotation MicroStation Level 
Point Name SV_X_Text_Name 
Point Elevation SV_X_Text_Elevation 
Field Code SV_X_Text_Comment 

 
The display size of the annotations is based on the Annotation Scale parameter. 
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Linear Features 
A series of survey points representing curvilinear features can be connected as a Linear Feature as shown 
in the example below. 

 

With the Element Selection tool active, floating your cursor over the referenced linear feature will open a 
pop-up menu with information about the feature line as shown in the example above. 

 

Field Attributes 
Many of the ODOT field codes allow for the use of attributes to store additional information with a specific 
survey shot. For example, the feature code “PP”, used to specify a Power Pole, has the following attributes: 

Material 
Owner 
Pole# 
 

The attributes may or may not be plotted in the file depending on whether the survey personnel have 
elected to annotate the model. Annotations are not automatically placed in the design file as they were with 
previous software.  

 

In the example at left, the annotation is placed in the file on the level 
SV_X_Text. These annotations are intended for information only. See the 
Annotating Survey Elements section for more information. 

 

Attributes can also be reviewed in the pop-up dialog that is displayed when floating the cursor over a point 
as described on the previous page. 
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Design File Levels for Survey Data 
The OHDOT CADD Standards include several MicroStation levels that are specific to survey information. 
These levels are grouped in the level library using the prefix “SV”. 

The levels can be turned on/off using the Level Display dialog. The Level Display dialog can be opened in 
all the various Workflows by selecting icon in the Primary group of the Home tab as shown below. 

 

The Level Display dialog includes the ability to filter the dialog to only show specific levels. By selecting the 
Survey filter, the dialog will show only the survey levels. 

 

 

The following levels are typically not shown on the plan 
and should normally be turned off after the survey 
basemap has been attached as a reference. 

• PV_X_COP (center of pavement) 
• SV_X_Break_Lines 
• SV_X_Random_Point 
• SV_X_Shot_Marker 
• SV_X_Text_Comment 
• SV_X_Text_Elevation 
• SV_X_Text_Name 
• SV_X_Text 
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Annotating Survey Elements 
Annotation for Survey elements is not automatically placed in the FB design file when the survey data is 
processed as it was in PowerGEOPAK. 

Survey elements can be annotated in the Field Book (FB) design file by the surveyor, or in any file that the 
FB design file is attached as a reference. 

In the example below, the attributes for the building were entered by the surveyor as the data was 
collected in the field. 

 

The Feature Definition assigned to the element controls how each Survey item is annotated. The 
annotation is also dependent on whether the surveyor entered any attribute data in the field as the survey 
data is collected. 

Annotation is placed in the active model by selecting an individual element, by a selection set, or for all the 
civil elements in the active mode by use of the annotation commands shown below: 

 

An example of the annotation that is placed for a building using the Element Annotation command is 
shown below. 
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Annotations can be removed by manually deleting the text, or by use of the Remove Element Annotation 
or the Remove Model Annotations command. 
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Geographic Coordinate Systems 

A Geographic Coordinate System (GCS) is used to define the position of the survey and design information 
on the Earth’s surface. Once the position of the data has been established, the design can be easily 
coordinated with other data for which the geographic location is known such as Google Earth, Bing Maps, 
Geo-Referenced Imagery, or GIS systems. 

Defining the Geographic Coordinate System is a requirement of the OHDOT CADD Standards. See the 
Location & Design Manual, Volume 3 – Highway Plans, Section 1204.3.5 for more information. 

A library of predefined GCS is available in ORD. Optionally, a custom GCS can be defined for projects that 
have been mapped to ground coordinates, if required. 

The process to create a custom GCS for Grid-to-Ground conversions is the responsibility of ODOT’s Survey 
personnel and is not covered in this manual. This manual will cover the basics of reviewing the GCS and 
create new design files using the same GCS that has been defied by the Survey personnel. 

Note: The purpose of the GCS is to define the location of the data on the earth’s surface. ODOT does 
not recommend changing the GCS to re-project the data. 

WorkSet Seed Files and Geographic Coordinate Systems 
A seed file is an empty MicroStation design file that has been configured to meet ODOT requirements. The 
seed file is used as a template when new design files are created. The seed file selected by the user is copied 
and renamed to create the new file.  

When a new project is created, 2D and 3D seed files are copied from the CADD Standards folder to the 
project’s 990-WorkSetStandards\seed\ folder. If necessary, the WorkSet seed files can then be modified 
by the survey personnel to define a custom GCS definition that is used to facilitate Grid-to-Ground 
projection. 

It is the responsibility of the Surveyor to define the appropriate GCS for the project data. As the designer for 
the project, it is your responsibility to ensure that all new design files created for the project use the same 
GCS as defined by the Surveyor. 

Reviewing/Selecting the GCS Definition 
The GCS can be reviewed by selecting the Drawing WorkFlow, Utilities > Coordinate System as shown 
below.  

 

The Geographic Coordinate System dialog shown below is opened. 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services May, 2024 

 

Section 200 - Working With ORD Survey Files 200-8 
 

 

To choose a GCS from the library, select the second 
icon, From Library. The Select Geographic 
Coordinate System dialog shown below is opened. 

  

 

 

 

 

The OHDOT workspace defines the State Plane coordinate systems typically used on ODOT projects in the 
Favorites folder as shown above. Choose the appropriate GCS from the list. A different GCS can be selected 
by browsing the Library folder. The GCS definitions for Ohio shown below are available by selecting 
Library > Projected (northing, easting) > North America > United States of America > Ohio. 

When a GCS is initially selected, you are simply telling MicroStation where the data resides. It is important 
to note that choosing a GCS when one has not been previously defined does not re-project existing data in 
the design file to the selected GCS. The data is only re-projected when changing from one GCS to another. 
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Reference Attachments 

References are used to display the contents of another DGN file within the current ORD model. The Home 
tab in each WorkFlow contains the reference tools as shown below. 

 
When attaching references in ProjectWise, the Attach Reference dialog shown below is opened. 

 

The Attachment Method can be 
specified at the bottom of the 
dialog. If one of the methods is 
selected, the attachment is made 
without accessing the normal 
MicroStation dialog. 

Browse to the file to be attached.   
Choose the Interactive method to 
access the MicroStation 
Reference Attachment 
Properties dialog, shown below, 
when the OK button is selected. 
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The various options available in the 
Reference Attachment Properties dialog 
are not covered in this manual. See the 
online help for more information. 

When attaching the survey design file, the 
Coincident -World option is typically 
used since all the files in the project 
should be using the same GCS. 

• Choose the Geographic – 
Reprojected option to re-project 
the referenced model to the 
coordinate system that is defined 
in the active model if the file being 
referenced uses a different GCS 
definition. 
 

• If a GCS is not defined, choose the 
Coincident – World option. 
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Terrain Models 

Terrain models generated by OpenRoads Survey are stored in a design file as a Terrain Model element type. 

The terrain model can be accessed by design personnel by attaching the survey Field Book (FB) design file 
as a reference attachment. Depending on the project, the terrain model may be created in a separate Field 
Terrain design file (FD). Contact the survey personnel for clarification on which design file contains the 
terrain model that is to be used for the project, particularly in cases where a complex terrain model is 
generated from multiple sources and an FD file is used. 

In the example below, the active file is 123456_BK001.dgn. The terrain model is contained in the file 
123456_FB001.dgn which has been attached as a reference file. 

 

Defining the Active Terrain 
After attaching the design file containing the terrain model element, it is a best practice to set the ground 
terrain model as the “Active Terrain”.  The active terrain model is used to define the existing ground for 
profiles and cross sections. 

To define the active terrain, from the Terrain tab, choose Active > Set Active. Select the terrain model 
when prompted. 

 

 

 

 

The active terrain can also be defined by selecting the Set As Active Terrain Model command from the 
pop-up menu when the terrain is selected using the Element Selection tool, as shown below. 
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When the terrain is activated, the software will automatically create a 3D model in the active design file. 
This 3D model is attached as a self-reference to the active file as shown below. 

 

 

Terrain Model Display Settings 
The display of the terrain model is controlled by the feature definition that is assigned in the design file that 
contains the terrain element. In the example above, the terrain is displayed using the X_Boundary feature 
definition. 

The terrain display can be defined uniquely for the active file as follows: 

• Use the Element Selection tool to select the terrain model element. 
 

• Allow the cursor to rest over the terrain element. The menu shown below appears. Choose the 
Properties command. 
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The properties dialog appears as a pop-up dialog as shown below. 

Since the terrain model is contained in a reference 
attachment, all the fields are ghosted and cannot be 
edited. 

The user may wish to override the assigned feature 
definition to turn on/off contours and triangles or 
change the contour interval settings. This is 
accomplished as follows: 

• Set the Override Symbology option to Yes to 
allow editing the terrain model properties. 
 
After setting the Override Symbology setting 
to Yes, the display of the terrain features can be 
toggled on/off using the options shown at right 
for turning on/off contours, triangles, etc. Note 
that the interval for the contours is controlled 
by the feature definition assigned to the terrain 
model, which cannot be edited across 
references. 
 
The Override Template option is used to 
select a different element template for the 
terrain display. The OHDOT Standards contain 
several element templates for terrain display in 
the Terrain Models category, as shown below. 
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When one of the element templates is selected from the library, the element template definition is 
copied from the library to the active file. If necessary, the terrain display can be further customized 
by editing the local copy of the element template, as follows: 
 

• From the Home tab, select the Manage option from the Element Template drop-down list (located 
in the Attributes group). This opens the Element Templates dialog. 
 

• The Element Templates dialog, shown below, lists any element templates that has been copied into 
the active file. Expand the active file to access the Terrain Models group. The settings for the 
element template can be edited in this dialog. 

 
The General Settings group controls how the terrain is displayed in the cross sections. These 
values should not be changed. 
 
The Calculated Features Display group allows turning on/off which features (contours, triangles, 
etc.) are displayed. Note that if the feature display is turned on, the display can also be turned 
on/off in the Level Display dialog. 
 
The Calculated Features Settings group contains the settings for contour intervals and symbology 
settings. 
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Note: The major contour text labels are placed at an interval along the contour line, defined by the 
DisplayText and TextInterval parameters. This may result in contour labels falling into locations 
where they may overlap other elements or annotations. The Label Terrain Contours command 
(OpenRoads Modeling > Terrain > Labeling) can be used to annotate the major contour lines at 
user defined locations in the active file. 
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Section 300 Geometry Basemaps 
Basemap Design Files 

ODOT’s CADD Standards detail the use of various basemap design files to store data such as plan, profile, 
corridor modeling, and cross section information. The basemaps store this information in real world 
dimensions, not scaled for a specific plan sheet presentation. These drawings are then referenced into 
sheet design files to produce the plan sheets for the project. 
 
Several basemap files may be used depending on the project complexity. The ODOT CADD Standards allow 
for multiple basemap design files for each unique discipline (Drainage, Lighting, MOT, Roadway, Signals, 
etc.) 
 
The following basemap design file types will be used in this training course: 
 

DGN File Type Two-character 
code 

Location 

Survey Field Book FB 300-Survey\Basemaps \ 
Geometry BK 400-Engineering\Roadway\Basemaps \ 
Right-of-Way BR 400-Engineering\RW\Basemaps\ 
Superelevation KS 400-Engineering\Roadway\Basemaps\ 
3D Modeling KM 400-Engineering\Roadway\Basemaps\ 

 
The OHDOT Create Design Files application is used to create new design files using the seed files for the 
project. 
 
See the Location & Design Manual, Volume 3 - Highway Plans, Section 1204.3 File Management for 
more details. 

Geometry Basemaps 
With OpenRoads Designer, all geometric information is stored in a MicroStation design file. A separate 
external database is not used as it was with Bentley’s PowerGEOPAK software. 
 
ODOT’s CADD Standards designate a specific basemap design file for storing OpenRoads geometry. It is not 
recommended to store the OpenRoads geometry information in the same design file as the plan view 
graphics or the survey basemap. Geometry basemaps are stored in 400-Engineering\Basemaps\ folder 
for the project. 
 
Geometry basemap design files are named as follows: 

nnnnnn_BK###.dgn 
 
where: 

 nnnnnn = the six-digit PID number for the project 
### = a three-digit number for the file (001, 002, 003, etc.) 

 
Example: 123456_BK001.dgn 
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Using Multiple “Federated” Basemaps 
ODOT recommends a “federated” approach to store each geometric alignment in its own design file. This 
“federated” approach will allow multiple designers to work on different alignments simultaneously. 
 
The OHDOT Create Design Files application is used to create geometry basemaps for the WorkSet.



 
Ohio Department of Transportation 
Office of CADD and Mapping Services September, 2024 

 

Section 301 – Geometry Basemaps Exercise 301-1 
 

Section 301 Geometry Basemaps 
Exercise 

Overview 
The sample project uses three alignments as listed below. Each alignment will be contained in its own 
design file. 
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Exercise A – Geometry Basemaps 

For the sample project, the Survey personnel have created a design file containing the existing survey 
information: 
 

File Name Content 
300-Survey\Basemaps\123456_FB001.dgn Survey mapping and the existing ground 

terrain 
 
In this exercise we will create multiple design files to house the proposed geometry for the project. 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 400-Engineering\Roadway\Basemaps\ folder.  

 
Create new design files for the project using the OHDOT Create Design Files application. To create these 
files, the project FB file may be opened. If there aren’t any basemap deign files defined for the project you 
may use one of the project seed files but not the recommended workflow. 

 Browse to the 300-Survey\Basemaps\ folder. 
• Open the 123456_FB001.dgn file from the 300-Survey\Basemaps\folder. 
• Select the Ohio DOT Workflow 
• Select the OHDOT Create Design Files application 
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• Click on the Category drop down   and select the Roadway Category. Next click on the Type  
and select Basemap. 

• Within the Create column check the box  for Roadway Basemap Geometry BK file. 

• Under column # of Files type in 3. Using the information in the table below, fill out the columns 
File Suffix (generally prepopulated) and Comments. 

 
 
 
 
 

• To Create three new Geometry basemaps for the project click the Create Files button. This will 
open the last created file 123456_BK003.dgn. 
 

Note: If the user doesn’t want to open the last created file. The user can turn this off by clicking the 
Settings to the upper left of the application and unchecking the Open Last Created File. 

 
• Exit OpenRoads Designer (ORD), checking the file back in to ProjectWise. This completes this 

exercise. 

File Name Comments 
123456_BK001.dgn Proposed S.R. 185 
123456_BK002.dgn Proposed St. Peter Road 
123456_BK003.dgn Proposed Jameson Road 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services February, 2024 

 

Section 302 – Horizontal Geometry 302-1 
 

Section 302 Horizontal Geometry 
OpenRoads Geometry Tab Overview 

The OpenRoads Geometry commands are selected from the Geometry tab of the OpenRoads Modeling 
workflow, as shown below. 

 
The commands are separated into two main categories, General Tools and Horizontal as shown above. 

This training guide will not document each geometry tool that is available in the OpenRoads interface. See 
the online help for commands not detailed in this document. 

Feature Definitions 

As you draw information using the OpenRoads horizontal geometry tools, OpenRoads Feature Definitions 
are used to define the plan view representation of an object as well as how the object will appear in other 
contexts such as the profile, cross sections, and 3D. 
 
What is a Feature? 
Simply stated, a feature is anything in your design that represents a real-world object such as: 
 

• Curb and Gutter 
• Pavement 
• Catch basins, Manholes, Inlets 
• Walls 
• Ditches 
• Cut and Fill Slopes 
• Etc. 

 
Features are defined in MicroStation DGN Libraries. The OHDOT configuration defines which feature 
libraries are available for ODOT use. The available feature definitions can be reviewed in the Explorer 
dialog as shown below. 
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In addition to defining the symbology settings, 
feature definitions can also define annotation 
settings for each item. 
 
For example, the Alignment feature 
definitions also define how an alignment will 
be annotated using the OpenRoads Element 
Annotation and Model Annotation 
commands. These tools are described later in 
this document. 
 
The features are organized by categories. 
Expanding a category will reveal the features 
available in the category. 
 
 
 
 
 
 
 
 
 
 
 
 

The feature definition is assigned when an element is placed. This can be accomplished by choosing the 
Feature Definition from the Tool Settings dialog as shown below. 
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Feature Name 
As civil geometry elements are placed, each element is given a feature name. The Name field displays the 
seed name that has been assigned to the selected feature definition. 
 
In the example at right, the Line Between Points command has been 
selected. The GE_P_Alignment feature definition has a seed Name 
prefix of CLP_1 defined. If the name value is not changed, the software 
will automatically increment the name of each line placed. For 
example, the first line placed is named “CLP_1”, the second is named 
“CLP_2”, etc. 
 
Note: By default, the software always displays the seed name, not the 
actual name of the element that is placed. 
 
The element name can be reviewed by using the Select Element tool and 
floating the cursor over the element as shown below (you do not need to select the element). 

 
The Feature Definition and Feature Name for a selected element can be edited in the Properties dialog as 
shown below. 
 
 
 

 
Standard element names for alignments are defined in the 
Location & Design Manual, Volume 3 – Highway Plans,  
See section 1204.3.6.2 
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Feature Definition Toggle Bar 
 
The Feature Definition Toggle Bar is accessed from the ribbon by selecting OpenRoads Modeling > 
Geometry > Standards > Feature Definition Toolbar. 

 
Toggle on the first icon to automatically assign the selected feature as the active feature as you use various 
OpenRoads Geometry commands. 
 
In the example below, the Line Between Points command is selected. The Feature Definition is defined 
by the active feature selected in the Feature Definition Toggle Bar. 

 
See the online help for a description of the remaining Feature 
Definition Toggle Bar icons. 
 
 
 
 
 
 

 
 

Geometry Rules 

Civil Geometry elements drawn using the OpenRoads tools are “ruled” graphics that behave according to 
the geometric rules that define how the element was placed. 
 
For example, a line drawn using the Line Between Points command has the following rules: Distance and 
Line Direction as shown below. 

 
These parameters can be entered in the Tool Settings dialog, shown at right above, or by using the 
parameters floating on the cursor. 
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• If you use the input field that floats on the cursor, the left and right arrow keys are used to switch 

between multiple parameters. 
 

• When a parameter value is entered, it is locked as shown below. The parameter can be unlocked by 
unchecking the item in the Tool Settings dialog, or by pressing the End key on the keyboard while 
the parameter value on the cursor has the keyboard focus. 

 
• After a parameter value has been keyed in, use the left and right arrow keys, or the Tool Settings 

dialog to enter values for the remaining parameters 
 

• Issue a data point (left-click) to place the element. 
 
 
The rules can be reviewed and edited by using the MicroStation Element Selection tool to select the 
element. In the example below, the rules for the selected line are displayed. 

 
The rules can be edited by left clicking on one of the parameters as shown below. 

 
The rules for the selected element can also be reviewed and edited in the Properties dialog as shown 
below. 
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MicroStation’s Manipulate commands (Copy, Scale, Rotate, etc.) cannot be used on ruled geometry. The 
rule must be removed to use these commands. 
 
To remove a rule, select the element and let the cursor rest on the selected element until the pop-up menu 
appears. Choose the Rules menu as shown below. 
 

 
The following options are provided: 

• Deactivate Rules (Activate Rules is the selected elements rules are currently deactivated) 
• Remove Rule 
• Activate Referencing Rules 
• Deactivate Reference Rules 
• Remove Rule (Remove Referencing Rules) 

 
Selecting the Deactivate/Activate Rules and Remove Rule icons affect only the selected element. 
 
Reference rules are elements upon which the chosen element is dependent, thus a curve between elements 
depends on the two other elements that define it. This command allows deactivating the rules for those 
other elements. 
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Element Manipulators 
OpenRoads Geometry elements have Manipulators that are displayed in MicroStation when an element is 
selected. These manipulators can be used to edit the selected element graphically or by entering a value. 
 
Clicking on one of the key-point manipulators will display direction arrows to edit the line, as shown on the 
example below. 

  
Tip: The size and color of the Manipulator Text can be adjusted in the User Preferences. From the 
MicroStation menu, select File > Settings > User > Preferences and then choose the View Options – Civil 
item on the left side of the dialog. The Manipulator Size or the Manipulator Font Scale parameters can be 
used to adjust the text size. 

Design Intent 
As geometric elements are drawn in MicroStation using the OpenRoads Horizontal Geometry tools, the 
software retains information about not only what element was drawn, but how it was drawn. This is 
referred to as the Design Intent. 
 
In the example below, the horizontal line was drawn first. The second line was drawn using the 
Perpendicular snap to draw the line at a perpendicular form the horizontal line to a specific ending point. 

 
 
If the horizontal line is modified by changing the 
direction of the line, the design intent for the 
perpendicular line is preserved. The 
Perpendicular rule, and the ending location are 
preserved as shown below.  
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Snaps 
As geometry elements are placed in the design, the elements are “ruled” to one another using snaps. 
 
The most common snap is the Key Point snap. In the example below, the second line was placed using a Key 
Point snap. When the line is selected, the icon for the snap mode that was used is displayed. 
 
If the first line is modified, the second line will maintain its relationship to the first line according to the Key 
Point snap rule. 
 

 
 
 
 
 
 
 
 

 
 

Occasionally you may wish to create civil geometry elements that are not “ruled” to other elements. Turn 
off the Persist Snaps icon on the Feature Definition Toggle Bar to place civil geometry elements by 
snapping to other geometry without creating a rule. 
 

  

Editing Dynamic Text 
When a civil geometry element is selected, and the various rules are displayed, some rules are shown in 
grey and cannot be edited by left clicking on the text. To edit these rules, you must select the underlying 
geometry directly. 

 
Take the following steps to select the underlying element. 
 

• Use the MicroStation Element Selection tool to select the geometry element 
• Right-click on the element that you wish to edit 
• The underlying element is selected, and the associated rules can be edited as shown below 
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Deactivating Rules 
Geometry elements that have active rules can be selected, edited, and deleted at any time. Deactivating the 
rules will lock the element in place so that it cannot be edited or deleted unless the rules are reactivated. 
This is useful to lock an alignment in place once the design has been completed. 
 
To deactivate the rules on a given element, select the element and let the cursor rest on the element until 
the pop-up menu appears. Choose the Deactivate Rule option as shown below. 

 
Multiple elements can be locked at once by choosing Geometry > Civil Toggles > Deactivate Rules. 
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Design Standards  

Design Standards are used to monitor various alignment parameters on OpenRoads geometry elements. 
The standards are stored in the DGN Library OHDOT_DesignStandards.dgnlib. 
 
The design standards can be used for two purposes: 
 

• Provide default values for element creation tools such as radius of a curve for a selected ODOT 
standard 

• Check and report on the compliance of a geometric element with the design standard that has been 
assigned to the element 

 

When a design standard is violated, the user is notified in two ways: 
 

• An icon is displayed on the graphics to indicate that there is a problem 
• The Civil Message Center reports any errors 

 
The Design Standards Toolbar allows you to select and apply a design standard. From the OpenRoads 
Modeling Geometry tab, select Standards > Design Standards Toolbar to access the dialog shown below. 

 
The toolbar contains a drop-down list to select the design standards and the design speed. The vertical 
design standard, displayed in the drop-down menu to the right, is automatically set when the horizontal 
design standards is selected. 
 
There are two icons located to the left of the drop-down menus. The first, Set Design Standard, is used to 
apply the current design standard to selected geometric elements. The second, Toggle Active Design 
Standard, is used to set the selected design standards active for relevant commands. 
 

To Apply a Design Standard 
The example below details the process to apply a selected design standard to the Simple Arc command to 
place a curve between two tangent lines. 
 

• The Design Standards Toolbar is set to the ODOT standard 202-7E, 2-Lane Undivided with a 
design speed of 55 MPH 
 

• The Toggle Active Design Standard icon is checked on 
 

• Using the Simple Arc command, the Radius value defaults to the value defined in the selected 
design standard, 954.9279 
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• The design standard defines a minimum transition length of 205 for the default radius. Spirals will 
be placed even though the Simple Arc command was initially selected. 

 

Design Standards can also be applied to an element after it has been created by using the Set Design 
Standard icon on the Design Standards Toolbar. 
 

To Review a Design Standard Violation 
If a design standard is violated, the software will display an icon on the element with the violation like the 
example below. Floating the cursor over the icon will display the error message. 

 
Errors can also be reviewed in the Civil Message Center by selecting Geometry > Standards > Civil 
Message Center. Toggle on the Error option to view any errors. 

 
You can zoom to the error by right-clicking on the error and choosing the Zoom To option. 
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Complex Geometry 

Individual civil geometry elements are connected together as a single entity using the Complex By 
Element command. 
 
Select Geometry > Complex Geometry > Complex By Element to access the command. 

 
In the example above, the Feature Definition is set to Use Active Feature as defined in the Feature 
Definition Toggle Bar. 
 
When the Method is set to Automatic, the software will automatically select elements to make up the 
complex geometry by searching for elements with endpoints that connect within the Maximum Gap value. 
If a fork is found, where two elements are found within the Maximum Gap tolerance, the user is prompted 
to identify which path to accept to complete the operation. 
 
Be sure to enter a Name for the geometry. Standard geometry names are defined in the Location & Design 
Manual, Volume 3 – Highway Plans, See section 1204.3.6.2 
 
When locating the starting element an arrow is displayed defining the direction to store the element. 
Complex elements can be stored in the opposite direction than they were originally defined by selecting the 
other end of the graphics. 
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Stations and Station Equations 

Start Station 
When an OpenRoads alignment is stored, the software assumes a beginning station value of 0+00. The 
station can be redefined by use of the Start Station command. 

 
 
The command has two parameters: 
 
Start Distance 
The distance along the alignment to assign the Start Station. The 
beginning station is computed based on the Start Distance and the 
Start Station value. 
 
Start Station 
The station value to be assigned at the Start Distance location. 
 
 
 

 
 

 
After the beginning station has been defined, selecting the alignment will display the station rules as shown 
below. 

 
 
 
 
 
 
 
 
 

 
The station parameters can be edited by selecting the rule in the design file, or from the Properties dialog. 
 

Add Station Equation 
The Add Station Equation command, located below the Start Station command, adds parameters for the 
Ahead Station and Back Station. 
 
When the command is selected, the user is prompted to select the alignment to assign the station equation. 
 
After the alignment has been selected, the location of the equation can be identified graphically, or by 
keying in the Back Station value. 
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The ahead station is stored as a “region” much like the legacy GEOPAK format. When the Ahead Station 
value is entered, it is not necessary to define the region number. 
 
The station equation value can be reviewed and edited by selecting the element as shown below. The 
parameters can also be edited in the Properties dialog. 
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Reports 

Several preconfigured reports are provided with the OpenRoads software that can be used to review 
alignment information. 
 
Various reports can be accessed from the Home tab, as shown below. 

Additionally, reports can be generated by selecting a civil geometry element and choosing the Reports icon 
from the pop-up menu. 

When a report is generated, the default report for the element type is displayed. The example below shows 
the default report for an alignment. 
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Several reports are available and can be selected from the list at left. Depending on the element type that 
the selected report has been configured to accept, it may not show any information. 
 
The format of the report can be modified by selecting Tools > Format Options. The dialog below is 
opened. 

 
The format options are stored as 
a user setting in the Windows 
Registry and must be manually 
set by each user on their 
computer. 
 
The settings shown at left are 
recommended for ODOT 
projects. 
 
Changes made to the Format 
Options dialog are dynamically 
applied to the current report 
when the dialog is closed. 
 
 
 

 

 
Reports can be saved in various formats using the File > Save As… 
command from the main Report Browser dialog. Reports should be 
saved to the EngData Folder of the project to the corresponding 
engineering discipline. 
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Section 303 Civil AccuDraw 
Civil AccuDraw Overview 
Placing elements in a 2D model is like manual drafting — all elements appear on the same plane, like 
drawing on a sheet of paper.  
 
In 3D, you place elements in space — horizontally (for example, a floor), vertically (for example, a wall), or 
at any other angle or direction (for example, a sloping roof).  
 
By default, data points in a 3D model are placed at the view's Active Depth. Where you snap a tentative 
point or place a data point in a blank part of a view, it will be located at the active depth. You can, however, 
snap a tentative point to an existing element at any depth in a view. When you accept such tentative points, 
the data point is placed at the level of the snap point. 
 
AccuDraw and its drawing plane let you place elements away from the active depth. Often this improves 
productivity since you need not constantly change the active depth. 
 
Civil Accudraw is activated by selecting the Civil Accudraw icon from the Geometry tab as shown below.  
 
You can find Civil Accudraw tool set under 
these 2 workflows  

• OpenRoads Modeling 
• Survey 

 
 
 
 
 
The first icon is used to turn Civil AccuDraw on or off. 

 
Civil AccuDraw performs many of the same functions as MicroStation AccuDraw but has greatly expanded 
capabilities for the civil designer. This guide will cover only a few of the functions available when using 
Civil AccuDraw. For more information, see the ORD online help. 
 

Note: Simultaneous use of Civil AccuDraw and MicroStation AccuDraw will cause errors. Close 
MicroStation AccuDraw when using Civil AccuDraw. 

 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services September, 2024 

 

Section 303 – Civil AccuDraw 303-2 
 

Civil Accudraw Settings 
Civil AccuDraw Settings are accessed by selecting the second icon as shown below.  

 

Auto Load – (Default OFF) 

Toggle this option ON to automatically load Civil 
Accudraw 

Floating Origin - (Default OFF)  

ON: the origin moves to the last point placed. 

OFF: the origin remains fixed. 

ODOT recommends turning this option off. 

Context Sensitivity - (Default ON)  

ON: the compass rotates in response to the context of 
various tools.  

ODOT recommends turning this option off. 

 

Smart Key-Ins - (Default ON)  

ON: Civil AccuDraw interprets a number as positive or negative, depending on the direction of the 
pointer from the compass.  

XY ordinates only: Smart Key-ins cause Civil AccuDraw to move the focus to either the x or the y 
field depending on the pointer position.  

Preserve Method Locks - (Default ON)  

ON: the locked values remain locked after switching the ordinate methods. For example, using 
station-offset ordinates and a lock station of 1+00, switch to distance-direction ordinates. Station 
1+00 will remain locked while inputting distance-direction. The resulting effect will be a distance-
direction-station lock.  

Sticky Z Lock - (Default OFF)  

ON: inputs to Z ordinates remain locked (sticky) until they are changed. This is useful in a 3D DGN 
to control the Z ordinate. For example, input 100.00 for the Z ordinate and the value remains 
constant until changed.  

OFF: The Z ordinate follows the cursor dynamics.  
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This also controls whether the origin for delta Z measurements follows the XY origin or is 
independent of XY.  

ON: the origin for delta Z is completely independent of the XY origin. For example, the user can set 
the origin for dXdY measurements from point A and set dZ to be measured from a second point B. 
The Z origin does not change until reset by the user. The effect will be apparent when drawing a 
linestring. When drawing a linestring, the dynamic orientation of the compass will adjust to align 
with the most recent line segment. The Z origin will remain fixed wherever the user placed it at in 
the beginning.  

Note: When AccuDraw ordinates are set to X, Y the sticky Z toggle does not apply. This is because, 
by definition, XY mode is always assumed to be absolute.  

Always Show Compass - (Default OFF)  

ON: the compass is always visible.  

OFF: the compass is only visible when the appropriate input is required. 

Civil Accudraw Shortcuts 
Hold down the second icon to reveal the shortcut menu shown below. 
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XY 

 
When the XY mode is selected and a civil command is active, the coordinates of the current cursor position 
are displayed in a floating dialog as shown below. 

 
The Tab key is used to move through the key-in fields in the dialog. 
 
Values entered in the floating dialog are locked when the Enter key 
is pushed. 
 
To unlock a value, tab to the field and push the End key. 

 
 

Civil AccuDraw Compass 
When the Always Show Compass setting is toggled on, a compass is displayed at AccuDraw’s origin point 
when Civil AccuDraw is active. 
 

 
The compass is always circular and is marked by a few tics. The default is 4 
compass points which can be changed in the settings. 

The north arrow on the compass will always point to north as defined by selecting 
File > Settings > File > Design File Settings > Angle Readout. 
 

 
 

If the Civil AccuDraw Settings dialog (shown above) has the Context Sensitive option turned on (default), 
then the compass auto-rotates in a similar fashion to MicroStation AccuDraw: 

 
Note that rather than direction being shown, the label and value are now an Angle. This is because the 
context is based on the direction of the preceding line segment rather than an absolute direction. 
 
The compass can be rotated with the V, B, T, RQ, RE shortcuts.  
 

V rotates the drawing plane to align with the view axes. 
T rotates the drawing plane to align with the axes in a standard Top view. 
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RQ is used to quickly and temporarily 
rotate the drawing plane. 
RE rotates the drawing plane to match the 
orientation of a selected element. 

 
Use the T (Top) shortcut or the corresponding 
drop-down to return to a pure direction. 
 

 
 

Distance-Direction 
The Distance-Direction ordinate is used to enter points in polar coordinates as shown below. 

 

Angle Syntax 
The input for angle and direction fields follows the File > Settings File > Design File Settings > Angle 
Readout settings. 
 
Valid forms for the various settings are as follows: 
 

DD.DDDD, Radians or Grads - Use the customary decimal input. 
 
DD MM SS or DD MM - The following delimiters are supported between degrees, minutes, and 
seconds: 
 

Colon - For example DD:MM:SS 
 
^ (caret) to designate degrees, minute (’) and second (”) - For example DD^MM’SS” 

 
The following are not supported: 
 

A space between degrees, minutes, and seconds because space launches the Civil AccuDraw 
popup menu. 
 
Use d, m, and s to designate degrees, minutes, and seconds. 

 
 
  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services September, 2024 

 

Section 303 – Civil AccuDraw 303-6 
 

Station-Offset 
The Station-Offset ordinate is used with a reference element to enter information as a station and offset 
relative to a selected element. 

 
The reference element can be a MicroStation element or an ORD Geometry element. If a MicroStation 
element is selected, the beginning of the element is assumed to be station 0+00. If a civil element is selected 
with stationing defined, the station value of the selected element is used. 
 
Take the following steps to select the reference element with the Station-Offset ordinate active: 

• Tab to activate the Offset field that is floating on the cursor. 
• Enter the letter “O” shortcut to set the origin. You are prompted to select the reference element. 

 
Once selected, data can be entered using station and offset values relative to the reference element as 
shown above. 
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Defining a Direction-Direction Intersection Ordinate 

Civil AccuDraw allows users to customize the dialog or add additional ordinates. This section documents 
how to add a direction-direction intersection ordinate. This is useful for computing a bearing-bearing 
intersection. 

Take the following steps to add a direction-direction ordinate: 

• Open ProjectWise Explorer 

 
 

• Open the Ohio DOT Projects data source. 
 

• Browse to the following folder to open the following design file: 
400-Engineering\Roadway\Basemaps\123456_BK004.dgn 
 

 Open the Civil Accudraw dialog by choosing Geometry > Civil Toggles > Civil AccuDraw 
 

 Click the second icon on the Civil AccuDraw dialog, Shortcuts: Civil AccuDraw Settings 

 

 Select the Favorites tab. 

 

 Choose the Add button to add a new favorite. 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services September, 2024 

 

Section 303 – Civil AccuDraw 303-8 
 

 
 Configure the Direction-Direction ordinate as shown above. 

 
 Close the Civil AccuDraw dialog and reopen it to see the added favorite, as shown below. 

 

The added Civil AccuDraw favorite is saved in the following file: 

C:\Users\username\AppData\Local\Bentley\OpenRoadsDesigner\XX.0.0\prefs\accudrawFavorites.xml 

 You will also find the Civil AccuDarw settings under the following Root directory. 

C:\Users\username\AppData\Local\Bentley\OpenRoadsDesigner\XX.0.0\prefs\accudrawSettings.xml 

Note: the XX indicates the ORD schema the user is using to open the file and modifying the accudraw 
settings.
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Section 304 Alignment Annotation 
Alignment Feature Definitions 

Alignment elements are assigned a Feature Definition, 
which controls the symbology of the element (level, color, 
line style, and line weight) as well as the annotation 
properties of the element. The OHDOT Standards include 
feature definitions for alignments, which can be reviewed 
from the Project Explorer dialog, as shown below. 

 
Note that the alignment feature definition controls the 
symbology and annotation settings for both the horizontal 
geometry and the proposed vertical alignment. 

 

 

 

 

 

Alignment Annotation 
When geometric alignments are placed in the file, the annotation is not automatically generated by the 
software. The user must identify the alignments that are to be annotated either individually, by selecting 
the specific alignments, or by annotating all of the alignments contained in the active model, or all models 
in the active file. 

Annotation commands are selected from the OpenRoads Modeling WorkFlow in the Drawing Production 
tab, as shown below. 
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Element Annotation 
Individual elements are annotated by selecting the Element 
Annotation command from the Drawing Production tab. Two 
commands are available as shown below. 

Annotate Element 
The Annotate Element command is used to annotate one of the more selected elements. The command 
prompts to select the OpenRoads element to be annotated. Multiple elements can be selected. Reset (right-
click) to complete the selection process and initiate the annotation placement. 

An example of annotation at the beginning of an alignment is shown below. 

The annotation definition is part of the Alignment feature definition. The default annotation for alignment 
annotations using the OHDOT Standards places station labels every 100’ like the example above.  

Remove Element Annotations 
The Remove Element Annotations command is used to remove the annotation from selected elements. 
When prompted, select the elements to remove the annotation. Reset (right-click) to end the selection 
process and initiate the removal process. 

Model Annotation 
The Model Annotation command is used to annotate all of the elements in 
the active model, or all models, by selecting a specfic Annotation Group. Two 
options are available as shown below. 

Annotate Model 
Select this command to annotate all the elements in a model, or in all models, by selecting a specific 
Annotation Group. 

When the command is selected, the user is prompted as shown below. Issue a data point (left mouse-click) 
to initiate the process. 

Remove Model Annotations 
Select this command to remove all annotations from the active model or all models in the active file. 
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Alignment Annotation Levels 

For a typical ODOT plan set, the annotation for centerline stationing is displayed at different intervals along 
the alignment depending on the type of sheet showing the alignment information and the scale of the sheet 
(20-scale plan vs. a 500-scale schematic sheet for example). Depending on the sheet scale, the annotation 
may need to display stations at 100’, 500’, or 1000’ intervals. These different station intervals are used to 
reduce clutter on the plan sheets. 

The Feature Definition assigned to the alignment also includes an Annotation Group definition. The 
annotations are placed on separate levels as detailed below. 

• GE_P_Alignment_XXX_Bearings 
• GE_P_Alignment_XXX_Cardinal_Points 
• GE_P_Alignment_XXX__Curve_Data 
• GE_P_Alignment_XXX__Distances 
• GE_P_Alignment_XXX__Stations 

 
Where XXX = the station interval (100, 500, or 1000). 

There are also three groups of levels for existing alignment annotation. 

• GE_X_Alignment_XXX_Bearings 
• GE_X_Alignment_XXX_Cardinal_Points 
• GE_X_Alignment_XXX__Curve_Data 
• GE_X_Alignment_XXX__Distances 
• GE_X_Alignment_XXX__Stations 

 

In older versions of the OHDOT CADD Standards that are compatible with OpenRoads version 10.09 and 
earlier, the default annotation definition was configured to place three sets of annotations on the 100, 500, 
and 1000 level groups at once. With this workflow, users were required to turn on/off the levels that they 
want to use for the plans depending on the desired station annotation interval.  

This workflow has been changed with the OHDOT CADD Standards for OpenRoads version 10.10 and 
higher. By default, alignments are now annotated with only one set of annotations with stations shown at 
100’ intervals. If annotations are required using either the 500’ or 1000’ station interval, the default 
annotation definition can be overridden by toggling on the new Override Annotation Group setting as 
shown below. 
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ODOT provides several annotation definitions as shown below. 

 

Note: Annotating an alignment with the 
Override Annotation Group option toggled 
on does not remove any previous annotations 
from the file. Use the Remove Element 
Annotations command to remove any 
previously placed annotations before re-
annotating the element using an override. 

 

 

 

 

 

 

 

 

The various annotation groups are summarized below. Annotation groups starting with the letter “P” are 
configured for proposed alignments. Annotation groups starting with the letter “X” are configured for 
existing alignments. 

Annotation Group Name Description 
P Alignment – 100’ Stations 
P Alignment – 500’ Stations 
P Alignment – 1000’ Stations 

These are the normal annotation groups for 
most plan sheet applications. Station annotation 
is placed on the left side of the alignment. Spiral 
and curve key-point annotations are placed 
towards the curve center. 

P Alignment – Force all Left 100’ Stations 
P Alignment – Force all Left 500’ Stations 
P Alignment – Force all Left 1000’ Stations 

These annotation groups force all station and 
key-point annotations to the left side of the 
alignment. 

P Alignment – Force all Right 100’ Stations 
P Alignment – Force all Right 100’ Stations 
P Alignment – Force all Right 100’ Stations 

These annotation groups force all station and 
key-point annotations to the right side of the 
alignment. 

P Alignment – Force Stations Right 100’ Stations 
P Alignment – Force Stations Right 500’ Stations 
P Alignment – Force Stations Right 1000’ Stations 

Station annotation is placed on the right side of 
the alignment. Spiral and curve key-point 
annotations are placed towards the curve center. 

 

Annotation Groups for existing alignments are also available for each of the group definitions detailed in 
the table above starting with the letter “X” instead of “P”. 

 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 304 – Alignment Annotation 304-5 
 

In the example below, the Annotation Scale value is set to 1:100 with the levels for 500’ station intervals 
toggled on. 

 

Additional Notes: 

• The levels are named according to the station label intervals (100’, 500’, and 1000’), not the 
annotation scale value. For example, the GE_P_100 group of levels are appropriate for multiple 
annotation scale values (1:10, 1:20, 1:50). 
 

• In the event a Spiral-Curve-Spiral (SCS) is encountered, the SCS data 
is annotated at the location of the intersection of tangents. An 
example is shown at right. This data has been configured to include as 
much of the SCS annotation as the software currently allows. The text 
can be edited to include additional information for the Emax, T.S., and 
S.T. information. The individual spiral data is still placed in the file 
even when the combined SCS data is included. 
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Section 305 Alignment Exercises 
Alignment Exercises Overview 

The following exercises step through the process to define proposed alignments for the sample project. 
Two proposed alignments will be developed for S.R. 185 and Jameson Road. The existing alignment for St. 
Peter Road will be used for the proposed improvements. 

 
 

For these exercises, the following files have already been created in a previous exercise: 
 

File Name Content 
300-Survey\Basemaps\123456_FB001.dgn Survey mapping and the existing ground 

terrain 
400-Engineering\Roadway\Basemaps\123456_BK001.dgn Centerline of Proposed S.R. 185 
400-Engineering\Roadway\Basemaps\123456_BK002.dgn Centerline of Proposed St. Peter Road 
400-Engineering\Roadway\Basemaps\123456_BK003.dgn Centerline of Proposed Jameson Road 
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Exercise A – Proposed State Route 185 

State Route 185 is the main alignment for the sample project. In this exercise we will define a new 
proposed alignment for State Route 185. 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

 Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
 Open the geometry basemap for State Route 185: 

400-Engineering\Roadway\Basemaps\123456_BK001.dgn 
 

 Attach the survey information as a reference file (Home > Attach Tools > References). The survey 
information is in the following design file: 
 

300-Survey\Basemaps\123456_FB001.dgn 
 
When attaching the reference file, which Orientation option should be used? Coincident – World, 
or Geographic – Reprojected?  
 
Should Live Nesting be used? 
 

 Turn on/off levels for the survey information as necessary. Start by turning off the levels listed 
below, and any other levels that you may not want to see while working on the geometry for the 
project. 
 

• PV_X_COP 
• SV_X_Break_Lines 
• SV_X_Random_Point 
• SV_X_Shot_Marker 
• SV_X_Text_Comment 
• SV_X_Text_Elevation 
• SV_X_Text_Name 

 
 Select the terrain model graphics from the reference attachment and set it as the Active Terrain 

(select the terrain boundary and then hover the mouse over the boundary to get the pop-up toolbar 
seen below, a long right click on the boundary will bring up a context menu where the Set of Active 
Terrain Model button can be found as well). 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services September, 2024 

 

Section 305 – Alignment Exercises 305-3 
 

 
 From the Geometry tab, choose Standards > Features Definition Toolbar. Set the active feature 

to Alignments > GE_P_Alignment. Toggle on the Use Active Feature Definition icon. 

 
 From the Geometry tab, choose the Lines > Line Between Points command. 

 
Start by placing the first line from the RSPK feature located at the intersection of St. Peter Road and 
S.R. 185. This is point SV901 in the Survey file. As shown below. 

 
Use the MicroStation Origin Snap to ensure you are starting the first point of the line by snapping 
to the origin of the RRSKP cell. 
 

 Define the second point of the line with a Distance value of 1556.74’ and a Line Direction value of 
N00^44’28”E as shown below. 
 
Tip: Degrees, minutes, and seconds are entered using the colon character as a separator. 

Example: n00:44:28e 
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 Use the Line Between Points command to store the following lines.  

 
Define the second line starting from the RRSPK feature, point SV901, using the following 
settings: 

Distance:  1595.31 
Direction: s01:13:48w 

 
Define the third line starting from the end of the second line. 

Distance:  1838.00 
Direction:  s63:50:18e 

 
Define the fourth like starting from the end of the third line. 

Distance:  650.00 
Direction:  s03:35:00w 

 
 Next, use the Design Standards Toolbar to place a spiral-curve-spiral set. From the MicroStation 

Geometry tab, choose Standards > Design Standards Toolbar icon. 
 

 Choose the 202-7E, 2-Lane Undivided 55 MPH design standard as shown below. 
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 Toggle on the second icon, Toggle Active Design Standard 

 
 From the Geometry tab, choose the Arcs > Arc Between Elements > Spiral Arc Spiral command.  

 
When using a Design Standard, the software will set the length of the spirals and the degree of 
curvature to the default values defined by the selected design standard.  

 
 Select Trim/Extend Both to complete the process. 

 
Be sure to enter a left click (data point) to accept the Trim/Extend parameter. OpenRoads requires 
a left click to accept parameters as data is entered. 

 
 
Use the Spiral Arc Spiral command to place the second curve for the alignment. For the second curve will 
match the existing alignment, the values defined by the active Design Standard will be overwritten. 

 
 Place the second spiral-curve-spiral using the following values: 

Radius:    d7:45 
Back Transition Length:  250 
Ahead Transition Length: 250 
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Tip: The degree of curve can be set by keying in the degree value in the Radius field prefixed with a 
lower case “d”. Degrees, minutes, and seconds are separated by the colon character. 
 

 Use the Trim/Extend and select the Both options to complete the process, issuing a left-click to 
accept the parameter. 

 
The 7°45’ curve does not meet the currently selected 55 MPH Design Standard. 
A red X is displayed on the curve as shown on the right. 
 
Design errors can be reviewed in the Civil Message Center dialog by selecting 
Standards > Civil Message Center from the Geometry tab. 
 
 Be sure to select the spiral-curve-spiral set to check the spiral lengths after 

the data is placed in the file. The Design Standard may have switched the 
length back to 205’. If the spirals were placed with a length of 205’, edit the 
rule for each spiral length to change the value to 250’ 
 

 
 
 
 
 
 
 

 
No action is required to continue designing the corridor model. This is strictly informational and can be 
ignored if the data is correct. 
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Next, create a complex chain from the individual elements that have been placed for the proposed 
centerline of S.R. 185. 
 
 From the Geometry tab, choose the Complex Geometry > Geometry > Complex By Elements 

icon  
o Set the Feature Definition to the Alignments > GE_P_Alignment. 
o Key in the Name for the centerline element. See the Location & Design Manual, Volume 3 

– Highway Plans, Section 1204.3.6.2 for more information on naming geometry elements. 
o Using the Automatic Method, choose the first element to define the complex element. Note 

that the direction of the element is significant. When you move the cursor over the first 
element, an arrow is displayed indicating the direction the complex element will be defined. 

o When prompted to Locate First Element, select and accept the first element at the north 
end of the alignment as shown below. 

 
The chain is stored with a default beginning station value of 0+00. Use the Start Station tool to define the 
beginning station for the newly created alignment as detailed below. 
 
 From the Geometry tab, choose Modify > Start Station 
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The Start Distance parameter defines the location along the selected alignment where the Start 
Station value is applied. The Start Distance should be 0 and the Start Station is 385+00.00 
 
The station value can be reviewed or edited by using the MicroStation Element Selection tool to 
select the complex element. That station rules are displayed as the example below. 

 
The parameters for the alignment can be reviewed using the Project Explorer dialog’s OpenRoads Model 
group. 

 
Various parameters can be reviewed and/or edited in 
Project Explorer by right-clicking on an item and 
selecting Properties. 
 
For example, the Assigned Station value can be 
reviewed and edited in the Properties dialog as shown 
below. 
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 Annotate the alignment using the Drawing Production tab Element Annotation command. 

 From the Drawing Production tab, change the Drawing Scale value to 1:50. Note how the 
annotation is scaled, including station tics and leader lines. 

 
This completes Exercise A 
 
 Save settings and exit OpenRoads Designer. Be sure to check the file back into ProjectWise. 

 

 

  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services September, 2024 

 

Section 305 – Alignment Exercises 305-10 
 

Exercise B – St. Peter Road 

Take the following steps to define the centerline for St. Peter Road: 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

 Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
 Open the geometry basemap for St. Peter Road: 

400-Engineering\Roadway\Basemaps\123456_BK002.dgn 
 
 Attach the survey information as a reference file using a Nest Depth value of 0. The survey 

information is in the following design file: 
 

300-Survey\Basemaps\123456_FB001.dgn 
 

 Turn on/off levels for the survey information as necessary. Start by turning off the levels listed 
below, and any other levels that you may not want to see while working on the geometry for the 
project. 
 
• PV_X_COP 
• SV_X_Break_Lines 
• SV_X_Random_Point 
• SV_X_Shot_Marker 
• SV_X_Text_Comment 
• SV_X_Text_Elevation 
• SV_X_Text_Name 

 Select the terrain model graphics from the reference attachment and set it as the Active Terrain 
(select the terrain boundary and then hover the mouse over the boundary to get the pop-up toolbar 
seen below, a long right click on the boundary will bring up a context menu where the Set of Active 
Terrain Model button can be found as well). 
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Now we are ready to define the centerline alignment for St. Peter Road. 
 
 From the Geometry tab, choose Standards > Features Definition Toolbar. Set the active feature 

to Alignments > GE_P_Alignment. Toggle on the Use Active Feature Definition icon. 

 
 From the Geometry tab, choose Lines > Line Between Points.  

 
The survey crew has provided coordinates for the start of St. Peter Road. Use CivilAccudraw with 
the XY ordinate to enter the first point for the Line Between Points command with the following 
coordinates: 
 

Easting = 1414827.690 
Northing = 805922.456 

 

The second point will end at survey point SV901. Use the MicroStation Origin Snap to snap to the 
survey point to end the line. 

 

 

Use the Start Station tool to define the beginning station for the line as detailed below. 
 
 From the Geometry tab, choose Modify > Start Station 

 
The Start Distance parameter defines the location along the selected alignment where the Start 
Station value is applied. The Start Distance should be 0 and the Start Station is 15+00.00 
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 Annotate the alignment using the Drawing Production tab Element Annotation command. 

This completes Exercise B 
 
 Save settings and exit OpenRoads Designer. Be sure to check the file back into ProjectWise. 
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Exercise C – Jameson Road Relocation 

Jameson Road will be relocated by defining a new horizontal curve using the existing centerline as the back 
tangent and defining the ahead tangent that is perpendicular to the proposed S.R. 185 alignment. 

 
Take the following steps to define the centerline for Jameson Road: 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 
 

 Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
 

 Open the geometry basemap for Jameson Road: 

400-Engineering\Roadway\Basemaps\123456_BK003.dgn 
 
 Attach the survey information as a reference file using a Nest Depth value of 0. The survey 

information is in the following design file: 
 

300-Survey\Basemaps\123456_FB001.dgn 
 

 Turn on/off levels for the survey information as necessary. Start by turning off the levels listed 
below, and any other levels that you may not want to see while working on the geometry for the 
project. 
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• PV_X_COP 
• SV_X_Break_Lines 
• SV_X_Random_Point 
• SV_X_Shot_Marker 
• SV_X_Text_Comment 
• SV_X_Text_Elevation 
• SV_X_Text_Name 

 
 Select the terrain model graphics from the reference attachment and set it as the Active Terrain 

(select the terrain boundary and then hover the mouse over the boundary to get the pop-up toolbar 
seen below, a long right click on the boundary will bring up a context menu where the Set of Active 
Terrain Model button can be found as well). 

 
 
 Attach the geometry basemap containing the centerline of proposed S.R. 185 as a reference using a 

Nest Depth value of 0. The survey information is in the following design file: 
 

400-Roadway\Basemaps\123456_BK001.dgn 
 
Now we are ready to define the centerline alignment for the Jameson Road relocation. 
 
 From the Geometry tab, choose Standards > Features Definition Toolbar. Set the active feature 

to Alignments > GE_P_Alignment. Toggle on the Use Active Feature Definition icon. 

 
 From the Geometry tab, choose Lines > Line Between Points. Draw the first tangent line for 

proposed Jameson Road using CivilAccudraw to enter the following coordinates. 
 

Point 1 Easting = 1413832.052 
Northing = 804471.371 

Point 2 Easting = 1414291.830 
Northing = 804274.892 
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 Place the second tangent line from the end of the first using the MicroStation Perpendicular Snap to 
place the line perpendicular to the proposed S.R. 185 alignment, as shown below. 

 

 From the Geometry tab, select Arcs > Arc Between Elements > Simple Arc to place an arc with a 
230’ radius between the two tangent lines. Be sure to trim both elements. 
 

 From the Geometry tab, select Complex Geometry > Complex by Element to create a complex 
element for proposed Jameson Road. Use a Name value of CLP_JAMESON 

 
 From the Geometry tab, choose Modify > Start Station. Define the beginning station for the 

alignment with a Start Distance value of 0 and a Start Station value of 10+00 
 

 Annotate the alignment by selecting the Drawing Production tab Element Annotation command. 
 

 
This completes Exercise C 
 
 Save settings and exit OpenRoads Designer. Be sure to check the file back into ProjectWise.  
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Section 400 Vertical Geometry 
Vertical Geometry 

OpenRoads Designer stores vertical alignments as a component of the horizontal alignment in the same 
design file as the horizontal geometry. This is true for both existing vertical alignments, which are extracted 
from an OpenRoads Terrain Model, and proposed vertical alignments. 
 
Although the vertical geometry is stored in the design file, the graphical display of the vertical alignment 
information is not plotted in the design file. Vertical alignments are displayed in a profile window for 
review and editing. 
 
Vertical geometry tools are accessed from the Geometry tab of the OpenRoads Modeling workflow, as 
shown below. 

 
This training guide will not document each geometry tool that is available in the OpenRoads interface. See 
the online help for commands not detailed in this document. 

Profile Settings 

The Design File settings contain parameters for formats as you work with vertical alignments. Select File > 
Settings > File > Design File Settings and then click the Civil Formatting item from the list on the left of 
the dialog. The Profile Settings are set to the values shown below in the ODOT seed files. 
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Existing Ground Profiles 

Existing ground profiles are extracted along the selected civil geometry element from the active terrain 
model. The active terrain model is set by selecting the terrain element and choosing the Set As Active 
Terrain Model icon as shown below. 

 
To display the existing profile, select the alignment graphics and let the cursor rest on the graphic element 
until the pop-up menu appears. Choose the Open Profile Model icon as shown below. 

 
You are prompted to select or open a view window to use for the profile display. Open a new view window 
and then left click in the view window to display the profile. An example is shown below. 

 
Note: The profile is displayed in the profile view for review and editing; however, the profile is not written 
to the design file. The selected view window is used as a temporary display of all the profiles associated 
with the selected alignment. The selected view window is not specifically associated with an 
alignment/profile and can be used to display the profiles from different geometric alignments as needed. 
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Alternately, a profile can be displayed by holding down the left mouse button in the view window until the 
pop-up menu shown below is opened. Select the 2 Views Plan/Profile option. 
 

 
You are prompted to create a dynamic profile view as shown below. Select OK to continue. 
 

 
After selecting OK, the View 4 window is opened to display the profile graphics. 
 
When prompted to select the plan element that will be used to display the profile. You are next prompted to 
Select or Open View. Left click in the newly opened View 4 window to select this view to display the 
profile. 
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The Profile Window 

View Attributes 
The View Attributes for a profile view contain an additional parameter to control the vertical exaggeration 
of the profile display, as shown below. 

 

 

To change the profile display exaggeration factor, select 
the desired exaggeration factor from the drop-down list. 

Tip: With the cursor in the profile view, holding down 
the shift key while scrolling the mouse wheel will 
dynamically change the profile exaggeration. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Version 10.10 adds additional controls for the profile view attributes under the Horizontal Geometry Info 
tab shown below. 

 

The Horizontal Geometry Info option toggles on the 
display of the geometry tangent length, and length and 
radius for horizontal curves. This information is 
displayed across the top of the profile window as shown 
below. 
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The Show Horizontal Control Points toggles on the display of the station of any key-points in the 
horizontal alignment across the bottom of the profile view. 

The Station interval allows keying in an incremental value to show stations across the bottom of the 
profile window. A value of 100 is shown below. 

  

 

 

 

 

 

 

 

 

 

 

 

 
  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 400 – Vertical Geometry 400-6 
 

Profile Commands 
The Profile view window contains command icons specific to a profile view window as shown below. 

 
The following commands are available: 
 

• Fit Plan Extents 
• Fit Profile Elements 
• Vertical Geometry Tools 
• Attach All Profile Views 
• Create 3d Cut 
• Refresh 3d Cut 
• Dynamic Annotation: Annotate Element 

 

Vertical Geometry Tools 
The vertical geometry tools can be accessed from the profile view’s Vertical Geometry Tools icon as 
shown below. 

 

See the online help for information on the individual 
Vertical Geometry commands. 
 

These commands are also available in the OpenRoads 
ribbon menu by selecting OpenRoads Modeling > 
Geometry 
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Create 3d Cut/Refresh 3d Cut 
3D elements that cross the currently displayed profile, such as underground utilities, another corridor or 
bridge that passes over the active profile, can be displayed on the profile by choosing the Create 3d Cut or 
Refresh 3d Cut commands. 
 
When the 3d profile is created, two Placement Methods are available: 
 

• Corners - The Corners option allows the user to define a bounding box that defines both the 
horizontal and vertical extent of the 3D cut. 
 

• Full Profile - The Full Profile options automatically sets the extents of the 3d cut. 
 
In either case, a bounding box is drawn in the profile view line the example shown below. 

 
When the element is selected, four handles appear that allow adjusting the extents of the bounding area, as 
shown above. 
 
Delete the bounding box to remove the 3d cut from the view. 
 
Use the MicroStation Select Element to select the bounding box. Allow the cursor to rest over the bounding 
element until the pop-up menu appears. Two options are available: Properties and Delete. Select 
Properties to access the parameters shown below. 
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The example below shows an existing 48” pipe that passes under the profile. 

 
 
The 3d Cut graphics are a static representation of the elements in the 3d model at the time the 3d cut 
graphics were generated. To update the 3d cut graphics, the following commands are available in the 
Profile View window. 
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Annotate Profile Element 
OpenRoads 10.10 adds the ability to annotate a profile directly in the profile window. Commands to 
Annotate Element and Remove Element Annotations are available as shown below. 

Notes: 
These annotations can be useful when working in the profile view, however, the same annotations 
will be placed in the drawing models when sheets are created.  
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Profile Pop-Up Menu 

Selecting a profile graphic and allowing the cursor to rest on the element reveals a pop-up menu with 
commonly used commands as shown below. 

 
The following commands are available. See the online help for more information not covered in this 
document 

• Properties 
• Set as Active profile 
• Rules 
• Create Best Fit Profile 
• Profile Report 
• Annotate Element 
• Delete 

 

Properties 
Select the Properties item to access the menu shown below. This is commonly used to edit the Feature 
Definition or the Feature Name for the selected profile. 

 

Set as Active Profile 
This option is used to set the selected profile as the active profile. Once a profile is set active, it is used as 
the default profile for subsequent actions such as the corridor modeling process. 
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Rules 
Like the Horizontal Geometry, profile elements have a set of rules that define the element parameters. In 
the example below, the rules for a vertical curve are shown. 
 
The rules may be activated (unlocked) or deactivated (locked) from the pop-up menu for the selected 
profile like the example below. 

 

Create Best Fit Profile 
For existing alignments, the pop-up menu includes the option to create a best fit profile as shown below. 

 
 

 
The dialog shown at left is opened. 
 
Various parameters are available to refine the best fit 
profile that is to be created. See the online help for 
more information. 
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Profile Report 
Various vertical alignment reports can be generated by selecting the profile using the Home > Element 
Selection tool, and then choosing the Profile Report icon from the pop-up menu as shown below. 

 
The default Vertical Alignment Review Report is shown below. 

 
Various report formats can be selected from the list at the left of the dialog. 
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Annotate Element 
The pop-up menu also provides the profile annotation commands, documented previously in this 
document, that are available from the profile window menu. 

The annotations can be removed from a profile that has been previously annotated by choosing the 
Remove Element Annotation option, shown below. 
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Profile Feature Definitions 

The symbology of vertical geometry is defined by Feature Definitions. The vertical geometry feature 
definitions define the symbology for the profile lines and vertical curves as well as the annotation 
parameters. 
 
Feature definitions for vertical alignments are typically defined as follows: 
 

• Existing vertical alignments inherit their display parameters from the feature definition that has 
been assigned to the terrain model that was used to extract the profile. 
 

• Proposed vertical alignments inherit their display parameters from the feature definition that has 
been assigned to the horizontal geometry that the vertical geometry is associated with. 

 
In the example below, a proposed profile line is drawn using the Profile Line Between Points command. 
The Feature Definition option is set to use the Alignment > GE_P_Alignment feature. This sets the 
symbology for the vertical geometry since the alignment feature definition also includes the profile feature 
parameters. 

 
 
The feature definition is defined to differentiate between the tangent lines and vertical curves. Proposed 
profiles are defined to display the vertical curves with color 58, and tangent lines with color 0, as shown 
below. 

 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 400 – Vertical Geometry 400-15 
 

There are cases where the user may need to display the profile information using different symbology 
other than the parameters defined with the horizontal geometry feature definition. The OHDOT Workspace 
includes additional features for profiles in the Linear > Profiles category as shown below. 
 

 
Linear > Profiles > PF_P_Grade_Line 
This option is typically used for utility profiles with no annotation definitions for vertical curve data. 
 
Linear > Profiles > PF_P_Grade_Line_LT 
Linear > Profiles > PF_P_Grade_Line_RT 
Linear > Profiles > PF_X_Grade_Line_LT 
Linear > Profiles > PF_X_Grade_Line_RT 
 
These features are used for divided highways to draw the profile graphics on separate levels with different 
symbology’s. This allows the user to turn on/off the levels for a specific left or right profile while designing 
the proposed vertical geometry with less clutter onscreen. 
 
There are also profile definitions under the Linear > Profile Runs category. These features are used with 
Drainage and Utilities functions and are not used for vertical alignments. 
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Section 401 Vertical Geometry 
Exercises 

S.R. 185 Proposed Profile 

In this exercise, we’ll define the proposed profile for State Route 185.  
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Open the project with PID number 123456. 
 Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
 Open the geometry basemap for State Route 185: 

400-Engineering\Roadway\Basemaps\123456_BK001.dgn 
 
 Open a profile window for S.R. 185. This can be accomplished by selecting the alignment and then 

choosing the Open Profile Model icon from the pop-up menu, or by holding down the right-mouse 
button until the menu shown below appears and choosing the 2 Views Plan/Profile option and 
then following the prompts. 

 
The existing ground is displayed in the profile view. 

 
Use Civil Accudraw to store the tangent lines for the profile. Once these lines are stored, go back 
and store the vertical curves for the proposed alignment using the Parabola Between Elements 
command. 
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 Open the Civil AccuDraw dialog by choosing Civil Toggles > Civil Accudraw from the Geometry 
tab 

• Toggle Civil AccuDraw on by choosing the first icon 
 

 
With the profile window active, the Civil AccuDraw dialog will  
display icons relative to vertical geometry functions as shown 
 

 Store the vertical tangent lined for the proposed profile for S.R. 185 using the values shown in the 
table below. 
 
Use Civil Accudraw with the appropriate ordinate to facilitate entering the profile points.  

 
VPI Station Civil Accudraw 

Ordinate 
Offset/Elevation 

1 386+25 ProfileOffset Offset = 0 
2 387+00 ProfileOffset Offset = 0.25 
3 392+00 Z Elevation = 1014.07 
4 398+00 Z Elevation = 998.65 
5 403+00 Z Elevation = 993.65 
6 410+00 Z Elevation = 982.17 
7 422+50 Z Elevation = 966.61 
8 426+00 Z Elevation = 964.45 
9 427+50 ProfileOffset Offset = 0 

 
 Start by choosing the Lines > Profile Line Between Points command to enter the first two VPI 

points listed above. 

• Set GE_P_Alignment as the active Feature Defintion 

• Toggle on the CivilAccudraw ProfileOffset ordinate 

• With the Profile Line Between Points command active, tab so the Profile Offset field that 
is floating on the cursor has focus 

• Type in the letter “o” to select the existing ground profile element as the origin for entering 
profile offset values. 

• Select the existing ground profile. With the existing ground profile active, the cursor station 
and offset values will change relative to the cursor position in relation to the profile 

• Key in the values for the first VPI point in the table above to enter the first point on the 
tangent line. Left-click to enter the first point 

• Key in the values for the second VPI from the table above. Left-click to accept the second 
data point 
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 Take the following steps to place the second tangent line, defined by VPI 2 and VPI 3: 

 
• Start the line by snapping to the end of the first tangent line 
• Place the second point, defined by VPI 3 in the table above, by toggling the Civil AccuDraw 

ordinate to the Z mode 
• Enter the Station and Elevation for the point 

 
 Continue placing the remaining tangent lines using the values in the table above and the approprite 

Civil AccuDraw ordinate. 
 
The tangent lines for the profile are defined like the example below 
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 After placing the tangent lines, from the Geometry tab, select Curves > Profile Curve Between 
Elements > Parabola Between Elements to place the vertical curves for the alignment 
 

VPI Station Curve Length 
1 386+25  
2 387+00 No Curve 
3 392+00 700’ 
4 398+00 300’ 
5 403+00 300’ 
6 410+00 300’ 
7 422+50 450’ 
8 426+00 150’ 
9 427+50  

 
 Toggle off Civil AccuDraw. It is not needed to define the vertical curves 

 
 Place the first curve at VPI 3 as shown below. Use the Trim/Extend Both option. Be sure to enter a 

left-click (data point) to accept the Trim/Extend parameter. 

 
 Continue to place the remaing vertical curves 

 
The vertical curves are defined like the example below 
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Next create a complex element for the vertical profile. 
 
 From the Geometry tab, select Complex Geometry > Profile Complex By Elements 

• Set the Feature Definition to GE_P_Alignment 
• Define the Name as PGL_CLP_S185 (See the Location & Design Manual, Volume 3 - 

Highway Plans, Section 1204.3.6.2 for standards geometry element names.) 
• Using the Automatic Method, choose the first tangent element to define the complex chain 

 
• Left-click to accept the solution 

 
Take the following steps to define the proposed profile as the active profile: 
 
 Use the MicroStation Select Element tool to select the proposed profile line 

• Allow the cursor to rest on the selected element until the pop-up menu appears 
• Choose the Set As Active Profile icon 

 
Review the profile by generating a report: 
 
 Use the MicroStation Select Element tool to select the proposed profile line 
 Allow the cursor to rest on the selected element until the pop-up menu appears 
 Choose the Profile Report icon 

 
A report is displayed in the Bentley Civil Report Browser dialog 
 
The default Vertical Alignment Review report is displayed as shown below. Click on the other 
formats options to view the available options. 
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The format for the report, such as the number of decimal places, can be customized by choosing Tools > 
Format Options. Changes to these parameters are applied to the report when the Format Options dialog 
is closed. Suggested values for ODOT reports are shown below. 

The report can be saved by choosing File > Save As from the Bentley Civil Report Browser dialog. 
 
This completes this exercise. 

• Exit OpenRoads Designer, checking the file back in to ProjectWise 
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St. Peter Road Proposed Profile 

In this exercise, we’ll define the proposed profile for St. Peter Road.  
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

 Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
 Open the geometry basemap for St. Peter Road: 

400-Engineering\Roadway\Basemaps\123456_BK002.dgn 
 
 Open a profile window for St. Peter Road. This can be accomplished by selecting the alignment and 

then choosing the Open Profile Model icon from the pop-up menu, or by holding down the right-
mouse button until the menu shown below appears and choosing the 2 Views Plan/Profile option 
and then following the prompts. 

 
The existing ground is displayed in the profile view. 
 
The profile for St. Peter Road will tie into S.R. 185. The profile grade point for the intersection of St. 
Peter Road with S.R. 185 can be drawn on the profile with the following steps: 
 

 From the Geometry tab, choose the Profile Creation > Profile Intersection Point command and 
take the following steps: 

o When prompted to Locate Element to Show Intersection, choose the plan view graphic 
for St. Peter Road 

o When prompted to Locate Element Which Intersects, choose the plan view graphic for 
proposed S.R. 185 

A point representing the PGL location of S.R. 185 at the intersection with St. Peter Road is 
drawn on the profile 

 
Next, use Civil Accudraw to store the tangent lines for the profile. Once these lines are stored, go back 
and store the vertical curves for the proposed alignment using the Parabola Between Elements 
command. 
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 Open the Civil AccuDraw dialog by choosing Civil Toggles > Civil Accudraw from the Geometry 
tab 
 

• Toggle Civil AccuDraw on by choosing the first icon 
 

With the profile window active, the Civil AccuDraw dialog will 
display icons relative to vertical geometry functions as shown  

 
 Set GE_P_Alignment as the active Feature Defintion 

 
 Store the proposed tangent lines for St. Peter Road using the values shown 

in the table below. Use Civil Accudraw with the appropriate ordinate to facilitate entering the 
profile points.  

 
Station Elevation Civil Accudraw Ordinate 
17+00 Meet Existing ProfileOffset 
18+25 997.8800 Z 
19+70 995.6026 Z 
20+00 Snap to S.R. 185 PGL Point  

 
Tips: 
To use the Civil Accudraw Profile Offset ordinate, use the tab key to shift keyboard focus to the 
Offset field as shown below. 

 
With focus in the Offset field, key in the “o” shortcut to select the 
profile element that will be used as the origin for the Station and 
Profile Offset values. You are prompted to Select a reference 
element. Select the exiting ground line for St. Peter Road. 

 

 After placing the tangent lines, from the Geometry tab, select Curves > Profile Curve Between 
Elements > Parabola Between Elements to place the vertical curves for the alignment 
 
Toggle off Civil AccuDraw. It is not needed to define the vertical curves 
 

Station Curve Length 
18+25 200’ 
19+70 10’ 

 
Use the Trim/Extent Both option when defining the curves. 
 

Create a complex element for the profile. 
 
 From the Geometry tab, select Complex Geometry > Profile Complex by Elements 
 Set the Feature Definition to GE_P_Alignment 
 Set the Name to PGL_CLP_STPETER (See the Location & Design Manual, Volume 3 - Highway 

Plans, Section 1204.3.6.2 for standards geometry element names.) 
 Using the Automatic Method, choose the first tangent element to define the complex chain 
 Left-click to accept the solution 
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Take the following steps to define the proposed profile as the active profile: 
 
 Use the MicroStation Select Element tool to select the proposed profile line 
 Allow the cursor to rest on the selected element until the pop-up menu appears 
 Choose the Set As Active Profile icon 

 
The completed profile should appear like the example shown below. 

This completes this exercise. 

• Exit OpenRoads Designer, checking the file back in to ProjectWise 
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Jameson Road Proposed Profile 

In this exercise, we’ll define the proposed profile for Jameson Road.  
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

 Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
 Open the geometry basemap for Jameson Road: 

400-Engineering\Roadway\Basemaps\123456_BK003.dgn 
 
 Open a profile window for Jameson Road. This can be accomplished by selecting the alignment and 

then choosing the Open Profile Model icon from the pop-up menu, or by holding down the right-
mouse button until the menu shown below appears and choosing the 2 Views Plan/Profile option 
and then following the prompts. 

 
The existing ground is displayed in the profile view. 
 
The profile for Jameson will tie into S.R. 185. The profile grade point for the intersection of Jameson 
with S.R. 185 can be drawn on the profile with the following steps: 
 

 From the Geometry tab, choose the Profile Creation > Profile Intersection Point command and 
take the following steps: 

o When prompted to Locate Element to Show Intersection, choose the plan view graphic 
for Jameson Road 

o When prompted to Locate Element Which Intersects, choose the plan view graphic for 
proposed S.R. 185 

A point representing the PGL location of S.R. 185 at the intersection with Jameson Road is 
drawn on the profile 

 
Next, use Civil Accudraw to store the tangent lines for the profile. Once these lines are stored, go back 
and store the vertical curves for the proposed alignment using the Parabola Between Elements 
command. 
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 Open the Civil AccuDraw dialog by choosing Civil Toggles > Civil Accudraw from the Geometry 
tab 
 

• Toggle Civil AccuDraw on by choosing the first icon 
 

With the profile window active, the Civil AccuDraw dialog will 
display icons relative to vertical geometry functions as shown  

 
 Set GE_P_Alignment as the active Feature Defintion 

 
 Store the proposed tangent lines for Jameson Road using the values shown 

in the table below. Use Civil Accudraw with the appropriate ordinate to facilitate entering the 
profile points.  
 
Note: Store the VPI points in this order: 

• Store VPI 1 and VPI 2 first 
• Then store the line from the point at the intersection with S.R. 185 moving backwards to 

define VPI 4 using a -8.0% slope for a lenth of -12’ 
• Next store VPI 3 moving backwards from VPI 4 using a -3.0% slope for a lenth of -12’ 
• Finally, place the tangent line between points VPI 2 and VPI 3 

 
VPI Station Elevation Civil Accudraw Ordinate 
1 12+00 Meet Existing ProfileOffset 
2 12+75 -0.65% Slope from VPI 1 NA 
3  -3.0% Slope, 12’ left of VPI 4 NA 
4  -8.0% Slope, 12’ left of VPI 5 NA 
5  Snap to S.R. 185 PGL Point NA 

 
Tips: 
To use the Civil Accudraw Profile Offset ordinate, use the tab key to shift keyboard focus to the 
Offset field as shown below. 

 
With focus in the Offset field, key in the “o” shortcut to select the 
profile element that will be used as the origin for the Station and 
Profile Offset values. You are prompted to Select a reference 
element. Select the exiting ground line for St. Peter Road. 
 

 After placing the tangent lines, from the Geometry tab, select Curves > Profile Curve Between 
Elements > Parabola Between Elements to place the vertical curves for the alignment 
 
Toggle off Civil AccuDraw. It is not needed to define the vertical curves 
 

Station Curve Length 
VPI 2, Station 12+75 100’ 
VPI 3 10’ 
VPI 4 No Curve 

 
Use the Trim/Extent Both option when defining the curves. 
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Create a complex element for the profile. 
 
 From the Geometry tab, select Complex Geometry > Profile Complex by Elements 
 Set the Feature Definition to GE_P_Alignment 
 Set the Name to PGL_CLP_JAMESON (See the Location & Design Manual, Volume 3 - Highway 

Plans, Section 1204.3.6.2 for standards geometry element names.) 

 Using the Automatic Method, choose the first tangent element to define the complex chain 
 Left-click to accept the solution 

 
Take the following steps to define the proposed profile as the active profile: 
 
 Use the MicroStation Select Element tool to select the proposed profile line 
 Allow the cursor to rest on the selected element until the pop-up menu appears 
 Choose the Set As Active Profile icon 

 
The completed profile should appear like the example below. 

 
This completes this exercise. 

• Keep OpenRoads Designer open for exercise section 501 Corridor Modeling Basemap. 
 
 

 

 

 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 500 – Corridor Modeling 500-1 
 

Section 500 Corridor Modeling 
Corridor Modeling Overview 

OpenRoads Designer provides several corridor modeling and site design tools to facilitate generating 3D 
representations of a new roadway or other type of surface. Designers work primarily in 2D files. The 
OpenRoads tools automatically generate the 3D model. 
 
Tools for the design, creation, modification, management, and report functions are provided. The tools are 
accessed by choosing the Corridors tab as shown below. 

  
Reference files are used to federate the data on a typical design project. Very small projects may have much 
of the data in a few files while larger projects will use multiple files for the geometry, terrain, 
superelevation, etc., and the 3D model. All these files can reference one another to present a complete 
model of the project. 
 
Each road within the project is used to define a 3D corridor model representing the proposed design. A 
corridor consists of an alignment, profile, and a template defining the initial roadway typical section. 
Multiple templates may be applied within a corridor to better define the roadway. Additionally, transitions 
and other modifications to the template can be defined using various modification tools. As changes are 
made, the 3D corridor model is automatically updated. 
 

Corridor Modeling Workflow 

The workflow for corridor modeling is summarized below. 
 

1. Create Civil horizontal and vertical geometry element(s) 
2. Create a DGN file for the corridor model 
3. Attach references for the existing ground terrain and the alignment data 
4. Define templates for the project 
5. Set the active terrain (existing ground) if the template ties to ground 
6. Create a corridor based on the horizontal and vertical elements 
7. Add template drop(s) 
8. Add horizontal and/or vertical controls for template points (optional) 
9. Define any transitions and connections 
10. Associate superelevation information 
11. Review the results and adjust as necessary using additional controls, such as end condition 

exceptions, secondary alignments, parametric constraints, or target aliasing 
12. Continue the process/review/modify 
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Templates 

In simple terms, the template is a “smart” typical section that you “push” along an alignment to create the 
proposed 3D model.  An example of a template for a 2-Lane undivided highway, with cut and fill slope 
options, is shown below. 

Templates are stored in a template library (*.itl). 
 
Templates are defined by inserting Points, Components, and End Conditions. A component is a set of 
points that define an open or closed shape. There is no limit to the number of points or components in a 
template. 

ODOT Template Library 
ODOT provides a sample template library in the following folder: 
 

..\Standards\Template Library\OHDOT_Templates.itl 
 
The templates contained in the ODOT library can be used as a starting point to define templates for specific 
projects. Many of the templates represent individual components that can be combined to generate the full 
template for a specific typical section design. For example, a template representing a lane of pavement can 
be combined with another template representing curb and gutter. 
 
The templates for each project are stored in their own project specific template library. When a new project 
is created in ProjectWise using the ODOT Project Creation application, the ODOT template library is copied 
into the 990-WorkSet Standards\Template Library\ folder for the project and renamed as follows: 
 

######_Templates.itl 
Where ###### = the 6-digit PID number for the project. 

 
The template library is specified in the .cfg file for the WorkSet by the MicroStation configuration variable 
listed below: 
 
CIVIL_ROADWAY_TEMPLATE_LIBRARY = $(_USTN_WORKSETSTANDARDS)Template 
Library/$(OHDOT_PID)_Templates.itl 
 
Template creation is a key component to the Corridor Modeling process.  
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Corridors 

Corridor Modeling Basemap Design Files 
For ODOT projects, the 3D model is generated in a “KM” basemap design file. For smaller projects with only 
one alignment, it is acceptable to generate the entire model in one KM design file. For projects with more 
than one alignment, it is recommended that users take a federated approach to store each corridor model 
in its own KM design file. 
 
For projects with lengthy alignments, it may be desirable to create multiple KM files for a single alignment. 
When a corridor is defined, beginning, and ending stations are specified. Using this workflow, multiple 
corridor design files are referenced together. 
 
The OHDOT Create Design Files application is used to create the KM design files for the project. 

Corridor Model 3D Graphics 
When a corridor is processed, the 3D model is generated in a separate MicroStation model named “Design-
3D”.  The corridor graphics consist of 3D line strings and 3D surfaces for each design component. 

The example below shows a portion of the pavement for a corridor with the individual pavement layers 
that were generated for the 3D model as well as a portion of the side slope. 

 
When the template is processed, the template points are connected between template “drop” locations to 
form the longitudinal break lines that are used to create the proposed surface.  An example of the 
longitudinal break lines plotted from a 3-dimensional design surface is shown below. 
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Only the top template points are used to create the proposed surface mesh. Points below the surface are 
excluded from the proposed design surface. 
 
The sub-surfaces can be included in the proposed cross sections as “components” or alternate surfaces. These 
components can be used for volume calculations. 

Corridor 2D Graphics 
In addition to the 3D graphics, the corridor modeling process draws 2D plan view graphics. These graphics 
can be used to generate the plan sheets for the project. An example of the 2D plan-view graphics drawn as 
part of the corridor modeling process for the pavement, shoulders, and a ditch, is shown below. 
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Section 501 Corridor Modeling Basemap 
Exercise 

Exercise A: Corridor Modeling Design Files 

In this exercise we will create separate design files for the 3D model of each alignment in the project. 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 401-Engineering\Roadway\Basemaps\ folder. 
• Open the 123456_BK001.dgn file or continue in 123456_BK003.dgn if following exercise 401 

completion. 
• Select the OHDOT Create Design Files application (OHDOT WorkFlow) to create the corridor 

modeling basemaps for the project. Create the corridor basemap design files for the following 
alignments: 

 
File Name Comments 
123456_KM001.dgn S.R. 185 Corridor Model 
123456_KM002.dgn St. Peter Road Corridor Model 
123456_KM003.dgn Jameson Road Corridor Model 
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The settings in the OHDOT Create Design Files application are shown on the following page 
 Once you’ve selected the corridor modeling basemap (KM) type fill out the Comments column 

• S.R. 185 Corridor Model 
• St. Peter Road Corridor Model 
• Jameson Road Corridor Model 

 
 Choose the Create Files button to initiate the process. Three files are created. 

 
Note: As you can see when you fill out the Comments column it fills in the file description in PW. 

This completes this exercise. 
 

• Keep OpenRoads Designer open. 
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Section 502 Templates 
ODOT Template Library 

Templates are used to define the typical section for each alignment. Multiple templates can be used to 
define different typical section designs, or the template geometry can be modified using a variety of 
corridor editing tools. 
 
When the WorkSet for a new project is created in ProjectWise, the OHDOT_Templates.itl library is copied 
from the OHDOT Standards to the 990-WorkSet Standards\Template Library\ folder and renamed 
using the PID number for the project. 
 
For users working outside of the ProjectWise environment, when the Startup.mvba application is 
processed on a new WorkSet, the template library is copied to the 990-WorkSet Standards\Template 
Library\ folder as part of the program operation. 

ProjectWise Template Library Check-in/Out 
When a template library is opened in ProjectWise, the file is checked out to the current user and cannot be 
viewed or edited by other users. When the Create Templates, dialog is closed, the software does not ask 
the user to check the template library back into ProjectWise. The user is prompted to check the template 
library back into ProjectWise when the design file is closed, as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

The template library can be checked back in after closing the template library from the ProjectWise 
Explorer dialog as shown below. 
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Create Template 

Templates are created and edited in the template library by choosing Template > Create Template from 
the Corridors tab. 

 
The dialog is split into several areas. Each area is briefly described on the following pages. See the online 
help for information not presented here. 
  

Menu Commands 

File 
The File menu contains familiar commands for creating new Templates and new folders within the 
template library, as well as commands to save and open template libraries, 

Edit 
The Edit menu contains commands used when editing templates such as Undo, Redo, Cut, Copy, Paste, 
etc.… 

Add 
The Add menu contains commands to add points and components to the active template. 

Tools 
The Tools menu contains various tools for template creation. The Options and Dynamic Settings menu 
items are described on the following page. 
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Tools > Options 
Selecting Tools > Options… displays the Template Options dialog which allows you to specify naming 
and step options for the current template. Use the Dynamic Settings dialog, detailed on the following 
page, to toggle these settings on/off as you design the template.  
 
 

Naming Options>Component Seed Name > From 
Feature Definition indicates, when selected, the 
component name is derived from the style specified 
when the component is created. 
 
Specify indicates, when selected, the component 
name is specified in the field. 
 
Point Seed Name allows you to specify the seed 
name for a point in the current template. Since point 
names must be unique, the seed name is appended 
with a different number each time a point is created. 

 
Apply Affixes 
Indicates when checked “on”, that affixes are applied. 

 
Left Prefix/Suffix specifies which prefix/suffix should be added to a point or component when the 
value is on the left of 0.0 (absolute). 

 
Right Prefix/Suffix specifies which prefix/suffix should be added to a point or component when the 
value is on the right of 0.0 (absolute). 

 
 

Step Options 
These options are used to specify precision step input 
for components and points. These values can also be 
accessed from the Dynamic Settings dialog. 
 

X Step specifies the step increment for the X distance from the dynamic origin. If this value is non-
zero, then the cursor moves to the horizontal increments of the specified value as measured from the 
dynamic origin. 

 
Y Step specifies the step increment for the Y distance from the dynamic origin. If this value is non-
zero, then the cursor moves in vertical increments of the specified value as measured from the 
dynamic origin. 

 
Slope specifies the step increment for slope from the dynamic origin. If this value is not 0, then the 
cursor moves in slope increments of the dynamic origin. Slope is applicable only when the dynamic 
settings are in horizontal/slope mode. 
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Tools > Dynamic Settings 
Select Tools > Dynamic Settings to display the Dynamic Settings dialog, which is used for precision 
input of template components and to assign point names and styles when defining components.  

 

X:Y/X:Slope toggles between X,Y step lock and X/Slope step lock. 
 
X Value displays the current X distance from the dynamic origin. 
 
X Step specifies the step increment.  If this value is non-zero, then the cursor moves in 
horizontal increments of the specified value as measured from the dynamic origin. 
 
Y value displays the current Y distance from the dynamic origin. 
 
Y Step specifies the step increment.  If this value is non-zero, then the cursor moves in vertical 
increments of the specified value as measured from the dynamic origin. 
 
Point Name specifies the name of the point to be placed. 
 
Point Style allows you to set the style of the point. The style is used to draw feature lines in 
the plan view. For ODOT projects, the style CM_P_Feature_Line should be used as the default 
style for most template points unless you want to assign a specific style that can be plotted in 
the display view 3D model.  
 
Apply Affixes specifies, when selected, that point name affixes (prefix or suffix) are to be 
applied to the point name when placing points. The Affixes are defined in the Template 
Options dialog. 
 
The Key-in pull down is used to specify the type of key in to be performed. 
 

• XY= key in absolute coordinates 
• DL= key in delta coordinates from last point placed (defaults to the dynamic origin if 

it is the first point of a component. 
• HS= key in horizontal delta distance and slope from last point placed. 
• VS= key in vertical delta distance and slope from last point placed. 
• OL= key in delta coordinates from dynamic origin. 
• OS= key in horizontal delta distance and slope from dynamic origin. 

 
Set Dynamic Origin sets the location of the dynamic origin. 
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Template Library 
On the left side of the Create Template dialog is the Template Library area 
which contains a Windows-like folder structure. This area is used to 
manage the content of the current template library. Two tabs are 
supported for the Template Library area as described below. 
 

Library 
When the Library tab is selected, the Template Library displays 
the contents of the current template library in a familiar Windows 
folder structure as shown at right. The Template Library area also 
supports common Windows functions like drag, drop, cut, paste, 
etc. 
 
If you double-click a template name, it becomes the active 
template. 
 
When a template is selected from the list, the Preview window is 
used to display a preview of the template. 
 
Double-click the template name to set it as the active template. 
 
The ODOT category contains various components and end conditions that can be used to build 
templates for your project. 
 
The Project Templates category is used to create new templates for the active project. 
 

Active Template 
When this tab is selected, the Template Library area displays the 
contents of the active template as shown in the image to the right. 
 
The Active Template option is used to review and edit template 
points, components, and parameters in a table format. 
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Creating New Folders and Templates 
Templates can be organized into folders in the active template library. The Project Templates folder is 
intended to be used to create new folders and templates for a specific project. 
 
To create a new folder, right click on the Project Templates folder and choose the New > Folder option. 
 
To create a new template, right click on the folder and choose the New > Template option. 

 
 
You can also cut, copy, and paste templates from 
the ODOT folders to the desired Project Templates 
folder. 
 
 
 
 
 
 
 
 
 

 

Current Template 
The right side of the Create Template dialog is used to display and edit the current template. 

 
 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 502 – Templates 502-7 
 

Name 
Shows the name of the current template. 

Description 
Allows you to review/edit the current template description. 

Display 
Components/Constraints 
This option is used to set the display mode of the template. If Components are selected, then the 
template components are displayed. If Constraints are selected, then the point constraints for the 
template are displayed. Template points are always displayed. 
 
Display Point Names 
Toggle this option “on” to display the template point names. 
 
Display All Components 
When this option is checked on, any components that are “hidden” are displayed with dashed lines. 

Current Template Window 
The Current Template Window is used to display and edit the current template. The window uses 
its own graphics engine and is not a MicroStation view.  
 
A magenta-colored box is used to designate the origin of the template. 
At the bottom of the Current Template Window are view commands like the MicroStation view 
commands. 

 
The two buttons that look like MicroStation View Previous and View Next commands are undo and 
redo commands used on template operations. The CTRL-Z keyboard shortcut can also be used to 
undo the last template operation. 
 
Within the Current Template Window, you can right-click to access commonly used template 
functions. You can also double click template components for editing purposes. 
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Template Points 

When the template is processed using the corridor modeling command, the points of a template are 
connected to form breakline features. Each point will be connected longitudinally to the next template drop 
location to form 3-D longitudinal breakline surface features. The breaklines are drawn using the symbology 
defined with the Feature Definition that is assigned to each point. 
 
Since the template points are connected to generate the completed surface, establishing a standard name for 
template features that are used on each template is very important to the quality of the proposed design 
surface. For example, if a pavement point is named ACSC_T_CL on the first template, and it is named 
PAVT_SURFACE on the next, the software will not automatically connect these points to generate the 
breakline feature. Following a point naming convention is important to obtain the best results with 
Corridor Modeling. 
 
It is equally important to ensure that the feature definition assigned to points is consistent from template to 
template. 
 
Each template point name must be unique to the template. The software automatically appends a number 
to the point name if the same name is used during template creation. 
 
There is no limit to the number of points in a template. 
 

Template Components 

A component is a set of points that define an open or closed shape. Each component, whether open or 
closed, can represent a different material or area of interest. Components are named and have an assigned 
feature style. There are 6 types of components as described below: 

Simple Components 
A simple component typically represents a section of pavement. It’s a closed parallelogram (4 constrained 
points) that is defined by the slope and thickness. 

 

Constrained Components 
A constrained component consists of points that are all restricted to the movement of the first point. A 
constrained point is typically used to manage the behavior of other points in the template. When a point 
(parent) is moved, any constrained point (child) also moves. This restriction only affects the offset and 
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elevation (x,y) of the restrained point and the relationship is unidirectional (movement of child point does 
not move the parent point).  Fully constrained points are displayed with a red + symbol. 

 

Unconstrained Components 
An unconstrained component is open or closed-shaped with no movement restrictions. Moving one point 
has no impact on the other points that make up the component. 

 

Null Point 
A null point is a template point that is purposely not related to a specific component. It’s most often used as 
a reference for controlling other points. 
 

End Condition 
An end condition is a special open-shaped component that targets a surface, an elevation, or an alignment. 
End conditions are typically used to define cut and fill slope solutions. 

 

Overlay/Stripping Components 
A specialized component type that is used for defining pavement planning and overlay materials. 
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Circle 
Circular components can be created as shown in the example below. 

 

Creating Template Components 

ODOT provides an example template library that contains several commonly used components. These 
components can be used to build templates. It may also be necessary to make specialized components to 
meet specific project requirements. 
 
Components are added to the current template 
by selecting the component that you wish to 
add from the Add pull-down menu, or by right-
clicking in the Current Template window to 
access the Add New Component menu shown 
at right. 
 
 
 
As new components are created, the Current Component portion of the Create Templates dialog is used to 
define the Name, Style, and any other relevant parameters for the component type being created. 
 
In the example below, a simple component is created representing a single lane of pavement. 
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Before placing the component in the template, various options are available to control how the template is 
placed by right-clicking in the template window to reveal the menu shown below. 

 
Change placement Point can be used to change which component point is used as the point placed 
at the point you specify. Each time this command is selected, the placement point will move in a 
clockwise direction to the next point in the component. 
 
Mirror will create the original component as well as a mirrored component reflected horizontally 
about the template origin. 
 
Reflect will create a single component reflected about the template origin. 
 
The Mirror and Reflect options are toggles that are turned on or off and remain active. The on/off 
status of the Mirror and Reflect options can also be turned on/off by toggle switches at the bottom 
right corner of the Create Templates dialog. 

 
Select Set Dynamic Origin to set the location of the dynamic origin. The dynamic origin is indicated by the 
purple box in the template display window. 
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Point Names and Affixes 

When components are added to a template, the points that make up the component are named according to 
the Point Name and the Pont Style defined in the Dynamic Settings dialog (Tools > Dynamic Settings). 
The Point Name is automatically appended with the number 1, and the appended number is automatically 
incremented for each point in the component as shown in the example below. 

 
The Point Name can be keyed in or selected from the drop-down menu. When selected from the 
menu, the Point Style is automatically assigned for the point according to ODOT standards. 
 
The point and component name designations are a bit cryptic. A listing of the point and component 
names can be reviewed in the following document in the OHDOT Standards: 
 
..\OHDOT\Standards\Template Library\OHDOT_RoadwayTemplateDefinitions.xlxs 
 
The Apply Affixes option is used to add a user defined prefix or suffix to the point name. In the 
example below a simple component was added with the Mirror option toggled on (as the 
component is being placed, right-click to reveal a menu to choose the Mirror option). The prefix of 
“L-“ is applied to the points on the left side of the template. The prefix of “R-“ is applied to the points 
on the right side of the template. 

 
The affixes are defined in the Template Options dialog. 
 
Tip: As a rule, affixes should not be applied to templates that contain individual components that 
will be used as “building blocks” for complete roadway templates. This is because the component 
may be used on either the left or right side of the template. Affixes should always be applied when 
creating completed templates for use with Roadway Designer. 
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Note that all the points of the component are named using the currently defined Point Name. In the 
example on the previous page, the points were placed using the ACSC_T_CL (Asphalt Concrete 
Surface Course Top Center Line) point name. After the component is placed, it is necessary to 
rename the points and assigned feature definitions to ensure that the points and 3D line strings are 
drawn using the appropriate standards. This can be done by double-clicking on each point to access 
the Point Properties dialog shown below. 
 
The Name can be typed in or selected from the drop-down list. If the Name is selected from the list, 
the associated Feature Definition is automatically defined. The Point Properties dialog is covered 
later in this document. 

 
 

Reviewing and Editing Point and Component Names 

Point and component names can easily be reviewed and edited using the Active Template tab as shown 
below. 

 
Right-click on a point or component name to reveal the menu 
shown at left. Choose Rename to rename the selected 
element. 
 
The Item and Value list, shown below the elements, is used 
to review various parameters but cannot be used for editing. 
 
Choose the Edit option for more editing operations. 
 
Points and components can also be edited by double-
clicking on a point or component in the template window. 
The Point Properties and Component Properties dialogs are 
covered later in this document. 
 
Note: The Feature Definition cannot be edited using the 
Active Template editing options.  
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Drag and Drop Component Operations 

A previously created template component can be included in the active template by use of drag and drop 
operations. Select a previously drawn component from the active template library and drag the component 
into the Current Template window. The component dynamically floats on the cursor. Release the mouse 
button to drop the component at the desired location. 
 
While dragging the component in the Current Template window, right-click anywhere in the Current 
Template window to access the placement options discussed previously (Mirror, Reflect, etc…) 
  
When connecting two components by dragging a component into the active template, the connecting point 
will change to a white colored plus sign prior to placing the component to indicate that the points are 
coincident. The point name from the previously placed component will be retained. Point names can be 
edited at any time during the template creation process. 
 
In the example below, a previously defined curb and gutter component is placed at the edge of pavement in 
the active template (New Template1) by dragging the Curb – Type 2 component and dropping it on the 
right edge of pavement point. The Mirror option is turned on, with Apply Affixes also toggled on, to place 
the curb and gutter on both sides of the pavement. 
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Component Editing 

Components are edited by double-clicking on a component to open the Component Properties dialog 
shown below. 

 
 
See the online help for details on 
each of these parameters. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Issue a right mouse click on a previously drawn component to access the menu shown below. 

 
See the online help for details on each of these functions. 
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Mouse Wheel Functions While Creating Templates 

The mouse wheel has the following functions when creating templates: 
 

• Scroll the wheel to zoom in or out in the template window. 
 

• Hold down the Shift key while scrolling the mouse wheel to zoom in or out in the vertical direction 
only. 

 
• Hold down the Ctrl key while scrolling the mouse wheel to zoom in or out in the horizontal direction 

only. 
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The ODOT template Library 

ODOT provides a template library with many template components defined that can be used as the starting 
point for creating and editing templates for your project. When a new WorkSet is created, the OHDOT 
template library is copied to the 990-WorkSet Standards\Template Library\ folder. 

 
 

The OHDOT template library has two main folders, ODOT 
and Project Templates. 
 
The ODOT folder contains various Components and End 
Conditions that can be used to create completed templates. 
 
The Project Templates folder is an empty folder to be used 
by the designer to create templates for the project. 
 
 
 
 
 
 
 
 
 
 
 

 
The contents of the ODOT folder are summarized below: 
 

Backbones 
The “backbone” is defined as the pavement and shoulder portion of the template. The Backbones 
folder contains several common pavement and shoulder configurations for divided and undivided 
roadways. A variety of configurations are available for superelevated and non-superelevated 
roadways. 
 
Components 
The Components folder contains individual design components that can be used as the “building 
blocks” for a complete template. A Type 2 Curb and Gutter is an example of a component.  
 
End Conditions 
Several end conditions are defined for cut and fill conditions according to ODOT design standards. 
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Template Creation Workflow 

While the process to create templates will have many variables, the general procedure to create templates 
is summarized below: 
 

• Open the template library 
 

• Create a new template or copy a template. Templates can be copied from one library to another by 
selecting Tools > Template Library Organizer from the Create Templates dialog. 

 
• Drag and drop template backbones or individual components into the active template 

 
• Create/edit the components as necessary 

 
• Merge components as desired 

 
• Review the point names and point name overrides 

 
• Review the component names and component name overrides 

 
• Test the template behavior 

 
• Save the template library 
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Advanced Template Design 

The corridor modeling tools provide a lot of options that can be used to create very complex templates that 
handle a variety of design scenarios. However, care should be taken not to create overly complex “Franken-
Templates” to create a single template to account for all the design elements that occur over the length of 
the project. Overly complex templates can be hard to edit and even harder to diagnose when things don’t 
work as expected. It’s better to define a few simpler templates for specific station ranges than it is to define 
one overly complex template. 
 
In this section, we will take a deeper look at the available template parameters. 
 

Point Constraints 
Point constraints are used to manage the behavior of points in a template.  They are used so that if a point 
is moved in a template, either by the user editing the template or by the application of a horizontal or 
vertical control during design processing, all the points related to the point being moved behave in a 
rational and predictable manner. 
 
For example, when a Simple component is inserted into the active template, it is comprised of four points 
which are connected to define the component as shown in the example below. 

 
Three of the four points are constrained with relation to the insertion point. If the original insertion point is 
moved, the other three points move in relation to the first point. 
 
A point can have at most two constraints. If two constraints are defined, the point is said to be “fully 
constrained”.  A point that is fully constrained is represented by a red plus sign. In the example above, 
points R-ACSC_T_EP, R-ACSC_B_EP, and ACSC_B_CL are fully constrained. 
 
A point that is partially constrained, meaning that it has only one constraint on it, is shown as a yellow plus 
sign. 
 
An unconstrained point is shown as a green plus sign. In the example above, point ACSC_T_CL is 
unconstrained. 
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Point constraints are two-dimensional and one-way. Two-dimensional means that the constraints can only 
affect the points offset and elevation (x and y coordinates in the cross-section view). One-way means there 
is a child-parent relationship between points. In other words, if point B is constrained by point A, point A is 
said to be the parent of point B and moving point A will affect point B, but you cannot move point B to affect 
point A. The example below shows a sample of this where the blue arrow indicates a parent/child 
relationship from point A to point B: 

 
Constraints can also be labeled so that during processing, the value(s) of labeled constraint(s) may be 
changed. For example, the template may have a constraint label called ACSC Thickness that controls the 
thickness of the first pavement layer. This value can then be changed over one or more station ranges during 
the corridor modeling process. 
 
The constraints for all the points in a template can be displayed by choosing the Display Constraints option 
on the Create Template dialog. 

 
 
 
 
 
 
 

 
Constraints are displayed as blue lines between the parent and the child point. At the midpoint of the 
constraint line, there is a short white line designating the constraint type as follows: 
 

• Horizontal line = Horizontal Constraint 
• Vertical line = Vertical Constraint 
• Sloped line = Slope Constraint 

 
Multiple lines will be shown for points with two constraints. 
 
Floating the cursor over a point will temporarily display an arrow designating the direction of the 
constraint (the arrow points to the child point) and a pop-up menu displaying information about the point. 
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The Point Properties Dialog 
The Point Properties dialog is used to review and edit various properties associated with the template 
points, including the definition of the point constraints. To access the Point Properties dialog, in the Create 
Template dialog double-click on the point in the Current Template window. The Point Properties dialog, 
shown below, is opened. 
 
The dialog contains the following options: 
 

Name displays the point name. The point name 
can be keyed-in or selected from the drop-down 
list. If the point name is selected from the list, the 
corresponding Feature Definition is 
automatically assigned. Point names must be 
unique to the template. 

 
Use Feature Name Override displays the name 
of the feature that will be created in the surface 
to correspond to the point. This field is 
optional. If it is blank, then the point name will 
be used as the feature name. 

 
• The option is intended primarily for end 

condition components to create connectivity 
from one station to the next when the 
template end conditions change. For 
example, if you want all surface tie-in points 
to belong to one feature, then set the feature 
name of all the ending end condition points 
on each side of the template to the same 
name (i.e. all Cut and Fill end points on the 
right would be given the feature name R-Tie 
and all the ones on the left would be given 
the feature name L-Tie). 
 

• If the point has a Feature Name Override defined, the point name is displayed in red in the Template 
window. 

 
Feature Definition is used to define the feature definition of the point. If no style is specified, then it 
comes from the first component of which the point is a member. 
 
The Superelevation Flag is used to identify the point as a candidate to be used for assigning 
superelevation control lines. This option should only be toggled on four pavement points on the surface 
of the pavement. 
 
Alternate Surface allows you to specify the name of an alternate surface for a point. You may choose 
multiple alternate surface names. Select from the list of available surfaces in the active template. 
 
Member Of indicates in which components the point is included. 

 
Constraints 
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The Constraints portion of the Point Properties dialog allows you to review/edit the constraints on a 
point. 
 

Type specifies the constraint type: None, Horizontal, Vertical, Slope, Vector-Offset, Project to 
Surface, Project to Design, Horizontal Maximum, Horizontal Minimum, Vertical Maximum, 
Vertical Minimum, Angle Distance. The constraints are described in more detail below. 
 
Setting up the appropriate constraint types is critical to achieve the desired results when pavement 
layers, superelevation, and transitioning are introduced to the design. 

 
Label displays the optional label for the constraint. Constraints that are labeled can have their value 
changed during design processing. The same label name can be assigned to more than one constraint 
and more than one point. See Section 10.4 for details. 

 
Horizontal Feature Constraint is used to allow a point to target elements in the design file that 
are defined with the specified Feature Definition within a specific Range. The use of this option is 
not recommended. 

 

Point Constraint Types 

Horizontal 
The child point remains at the given horizontal distance from the parent point.  

 
In the example above, point B has been constrained to point A with one constraint as shown below. 

 
If point A is moved horizontally, point B will 
maintain its relative distance from point A. 

 
If point A is moved vertically, point B is 
unaffected. 
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Vertical 
The child point remains at the given vertical distance from the parent point. 

 
In the example above, point B has been constrained to point A with one constraint as shown below. 
 

 
If point A is moved horizontally, point B is 
unaffected. 
 
If point A is moved vertically, point B will 
maintain its vertical relationship to point A. 
 
 
 
 

 
 

Slope 
The child point will maintain the given slope from the parent point. 

 
In the example above, point C has been defined with a Horizontal and a Slope constraint as shown below: 
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Slope constraints are absolute. Slopes going from lower-left to upper-right are positive regardless of 
whether the child point is to the left or right of the parent. 
 
Slope constraints can also have Rollover Values assigned to them. Rollover values are used to set the slope 
constraint based on a variety of high side and low side slope parameters. A Reference Point is specified 
which defines the controlling slope to the parent point. 
 

 
The example above documents the Rollover Values can as defined in ODOT’s example templates for the 
shoulder break point behavior. See the online help for more information on the available parameters. 
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Horizontal Maximum  
The child point has two parent points and remains at the given horizontal distance from the parent point that 
is farthest to the right (has the maximum horizontal or X value). 

Horizontal Minimum 
The child point has two parent points and remains at the given horizontal distance from the parent point that 
is farthest to the left (has the minimum horizontal or X value). 

Vertical Maximum 
The child point has two parent points and remains at the given vertical distance from the parent point that 
is highest (has the maximum vertical or Y value). 

Vertical Minimum 
The child point has two parent points and remains at the given vertical distance from the parent point that 
is lowest (has the minimum vertical or Y value). 

Vector Offset 
The child point has two parent points and will be projected onto the vector defined by the two parents. If the 
offset is not zero, then the child point will maintain a perpendicular offset from the parent vector at the 
specified offset value. Negative values indicate an offset to the left of the vector defined by the parent 
points. Positive values indicate an offset to the right. 

Project to Surface 
This constraint must be used in conjunction with one of the previously defined constraints. The other 
constraint will define the projection direction. The child point will then be projected to the surface with the 
name or parametric label given when the design is processed. If the surface does not exist, or no solution is 
found, then the point will remain where it is placed in the template. 

Project to Design 
This constraint is like the Project to Surface, except that the point is projected to the design surface of the 
template. A projection value is given to indicate whether the projection is to be to the left or to the right. The 
point must also be constrained by one of the previous constraints, excluding the Project to Surface, so that a 
direction for the projection may be determined. A negative value limits the projection to the left of 0; a 
positive value limits the projection to the right. A value of 0 will seek to the left and to the right of 0 to project 
the point.  If no solution is found, then the point will remain where it is placed in the template. 

Angle Distance 
This constraint takes two parent points, a distance, and an angle. The selected point is then fully 
constrained to the location defined by the first parent, and the angle from the first parent relative to the 
vector defined by the two parent points. This constraint creates a rigid-body rotation. When selected, no 
other constraint types are available. 
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Constraint Labels 
Constraint Labels can be assigned for points in your template that may have a variable value in your design, 
or a different value from one project to another. The value for the Label can be modified in the corridor 
modeling process. Assigning labels will allow your templates to be more flexible and therefore make them 
useful for more than one project. 
 
In the example below, a simple component has been created representing the Asphalt Concrete Surface 
Course for one lane of pavement. 

 
The depth of the pavement at points ACSC_B_CL and R-ACSC_B_EP has been defined as -0.1042’ as shown 
below. 

 
The thickness of the pavement can be changed by editing the template points, or by adding a Label. In the 
example above, the Label “ACSC Thickness” has been assigned for point ACSC_B_CL and for point R-
ACSC_B_EP. 
 
The Label name is user definable. The same label name is used for each point in the template that will use 
the value of the label. Once a label name has been assigned, it is available to be selected from the drop-
down label list as other points are defined. 
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The value of the label can be changed in the Create Template dialog, or 
during the corridor modeling process. 
 
To change the value in the Create Template dialog, select Parametric 
Constraints in the Active Template option. The points that have been 
assigned the label are listed as shown at right. 
 
Double-click the name of the Parametric Constraint that you wish to 
edit. The Edit Default Parametric Value dialog show below is opened 
which allows you to edit the value. 

 
The template graphics are automatically updated to reflect the new 
value. 
 
 

Editing Points with the Right-Click Menu 
In addition to the Point Properties dialog, points can be edited from a pop-up menu that is accessed by 
right-clicking on a point in the Active Template window. The menu is shown below. 

 
Some of these commands are covered later in this training guide. See the online help for documentation of 
commands not covered in this document. 
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Adding Components to the Template 
A component is a set of points that define an open or closed shape. 
 
When defining new components using precision input, the sign of the distance is dependent on the parent-
child relationship of the points. The parent is always the first point placed when creating template 
components. The following rules apply: 
 

• A child placed to the right of the Parent point is at a positive distance 
• A child placed to the left of the Parent point is at a negative distance 
• A child placed above the Parent point is at a positive distance 
• A child placed below the Parent point is at a negative distance 
• The Slope is the algebraic slope 

 
There are six types of components: 
 

• Simple 
• Constrained 
• Unconstrained 
• Null Point 
• End Condition 
• Overlay/Stripping 

 
Each component type is described in further detail on the following pages. 
 
As you add components to your template, the area under the active template window is used to display 
various parameters for the component. This is called the Current Component area. 
 
Right-click in the current template window at any time during the component creation process to access 
the menu shown below: 

 
Select Finish when you have completed creation of the component. 
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Creating Simple Components 
A simple component consists of four points defined by Slope, Thickness, and Width.  The top points are 
constrained by Horizontal and Slope constraints. The lower points are constrained to the points directly 
above them by a Horizontal and Vertical constraint. 
 
To create a simple component, right-click in the active template window and select Add New Component 
> Simple or select Add > Simple from the drop-down menu of the Create Template dialog to initiate the 
command. 
 
Define the Name, Slope, Thickness, Width, and Feature of the component before placing the component 
in the template. 
 
The Feature is used to set the symbology for the graphics drawn to represent the component in the 3D 
model. 

 
The Dynamic Settings dialog is used to facilitate component placement. The point names are derived from 
the Point Name selected in the Dynamic Settings dialog. Each point is appended with a number that is 
incremented. The points are assigned the Point Style feature that is active in the Dynamic Settings dialog. 
 
Point names and the feature that is assigned to each point should be reviewed and edited after the 
component is placed. 
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Creating Constrained and Unconstrained Components 
Constrained or Unconstrained components can be used to create any open or closed shapes in the template 
such as curb and gutter, median barriers, retaining walls, or complex pavement situations such as the 
shoulder break on the high side of superelevation. 
 

Constrained Components 
To create a constrained component, right-click in the current template window and select Add New 
Component > Constrained or select Add > Constrained from the pull-down menu of the Create 
Template dialog to initiate the command. 
 
When constrained components are created, both horizontal and vertical constraints are applied to 
each point. 
 
Unconstrained Components 
To create an unconstrained component, right-click in the current template window and select Add 
New Component > Unconstrained or select Add > Unconstrained from the pull-down menu of the 
Create Template dialog to initiate the command. 
 
When unconstrained components are created, no constraints are applied. This option is useful when 
you wish to define constraints other than Horizontal and Vertical constraints. 

 
 
The Dynamic Settings dialog can be for precision input when creating the component. In the example below, 
point ACSC_T_EP will be created at a defined horizontal distance and slope from point ACSC_T_CL using a 
horizontal distance of 12 and a slope of -1.6% by using the hs=12 option with a value of 12, -1.6%.  

Use the Enter key to execute the command. 
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Right-click in the current template window at any time during the component creation process to access 
the menu shown below: 

 
• Select Finish when you have completed creation of the component. 

 
• Components can be created as open or closed shapes. To toggle on/off the option to placed closed 

shapes, select Closed Shape. 
 

• Select Mirror to create two components at the same time. The second component is a mirror image 
of the one you are defining. The component is mirrored about a vertical line passing through the 
Dynamic Origin location. 

 
• Select Undo Last to undo the last point that was added to the component. 

 
• Select Cancel to terminate the component creation process. 

 
• Select Set Dynamic Origin to specify the location of the dynamic origin. 

 
 

Null Points 
A null point is a template point that is purposely not related to any component. It’s most often used as a 
reference for controlling other points. 
 
To create a null point, right-click in the current template window and select Add New Component > Null 
Point or select Add > Null Point from the pull-down menu of the Create Template dialog to initiate the 
command. 
 
 

Testing Point Controls 
The behavior of fully constrained points can be tested by right-clicking on the point and selecting Test 
Point Controls as shown below. 
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Select the desired option to test the behavior of a template as the point is moved either horizontally, 
vertically, or both at the same time.  

ODOT Standard Point and Component Names and Features 
As you create templates, each point and component in the template is assigned a Name and a Feature 
Definition. It is important to ensure that the points and components are named and assigned features 
consistently in each template. 
 
Feature definitions for template points and components are defined in 
OHDOT_Feature_Definitions.dgnlib, which is attached by a configuration variable. 
 

Point Names and Features 
As the template is applied to the corridor, 3D line strings are drawn in the design file by connecting the 
points from template drop to template drop by their Name. The symbology of these line strings is 
controlled by the Feature Definition that is assigned to each point. 
 
The ODOT workspace for OpenRoads includes several Feature Definitions that can be used for template 
points. 
 

• The point feature definitions can be reviewed by browsing to the following folder in the Civil 
Standards tab: 

Libraries > Feature Definitions > Linear > Modeling > Template Points 
 
Features can be reviewed and assigned in a variety of ways. 
 

• We have already discussed the Point Properties dialog which is accessed by double-clicking the 
point in the Current Template window. The Name and Feature Definition can easily be edited 
using this dialog. 
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• The Dynamic Settings dialog can be used to define the Point Name that will be assigned to points as 
they are created. The Point Name field can be used to key-
in a name for the point or to select a name from a 
predefined list as shown at right. It is recommended that 
you use the point names from this list when designing your 
templates. 

 
When a point name is selected from the list, the Point 
Style, which is the Feature Definition, is automatically set 
to the appropriate value. The Point Style list contains a list 
of all the Feature Definitions available in the 
OHDOTCEv02 workspace. 

 
• Features can also be assigned to one or more points by selecting Tools > Apply Feature Definition 

to Points from the Create Template dialog as shown below. 

Component Names and Features 
Component Names and Features are defined by the user as each component is created. 
 

• The component feature definitions can be reviewed by browsing to the following folder in the Civil 
Standards tab: 

Libraries > Feature Definitions > Mesh 
 
Component Names and Features can be reviewed and edited in a variety of ways: 
 

• Double-click on a component to open the Component Properties dialog. 
 

• Select Tools > Apply Feature Definition to Components… to apply a selected Feature Definition 
to one of more components in the template. 
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End Conditions 

An end condition is a special open-shaped component that targets a surface, a feature of a surface, an 
elevation, or an alignment.  End Conditions are commonly used for cut and fill definitions. End Conditions 
are added to the end of simple, constrained, or unconstrained components. 
 
To create an end condition, right-click in the template window and select Add New Component > End 
Condition or select Add > End Condition from the Create Template dialog’s pull-down menu. 
 
When adding an end condition to the current template, the Current Component portion of the Create 
Template dialog displays the following options: 

 
The Name field is used to specify the user defined name for the component. 
 
The Feature is used to set the feature definition for the component. 
 
Target Type specifies the type of target the End Condition is seeking. Targets include: 

• Terrain Model – Seeks an OpenRoads Terrain Model 
• Elevation – Seeks an elevation 
• Linear Horizontal/Vertical/Both – Seeks the intersection with a linear element selected from a 

list. 
• Feature Definition Horizontal/Vertical/Both – Seeks the intersection with a feature type. 

 
Horizontal Offset specifies a horizontal offset from the target. This option only applies if the target is a 
horizontal target or has a horizontal aspect. 
 
Vertical Offset specifies a vertical offset from the target. Applies only if the target is a vertical target or has 
a vertical aspect. For an elevation target, specify the elevation here. 
 
Priority specifies the order in which end conditions are attempted in seeking a solution. Where more than 
one End Condition starts at the same point, this value determines the order in which End Conditions are 
attempted to find a solution. Lower numbers, which have a higher priority, are attempted first. 
 
Benching Checkbox indicates, when on, the set of segments of the End Condition are repeated until a 
solution is found. 
 

The Benching Count indicates the maximum number of times that benching should occur. If this 
value is 0, then the repeat count is unlimited, and the benching End Condition must find its target 
for it to be valid. If any other number is entered, then if the benching is repeated for the specified 
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count and if the target is not reached, the benching End Condition will still be considered successful 
if an End Condition attached to the end of the benching End Condition is successful. 
 
From Datum indicates, when on, the benching will use a datum elevation and step elevation to set 
the benching rather than using the End Condition segments as they are defined. 

 
Datum Elevation specifies the elevation that represents the basis for the step elevation. Datum + 
Current bench elevation = n * Step Elevation. 
 
Step Elevation specifies the increment for benching when a datum is being used. Each bench 
elevation is always located at the end of the first segment (or the second point) of the benching End 
Condition. 

 
Rounding Length specifies the length used to round the end condition. When this value is something other 
than 0.0, 4 additional points are added to the end of the end condition using a parabolic formula to smooth 
out the transition of the intersection of the end condition with the surface. This rounding effect is only 
applied when the target is a terrain model or an elevation. Any other end conditions attached to the end of 
this one is attached to the end of the rounded section. 

 
 
  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 502 – Templates 502-36 
 

End Condition Point Properties 
As you are defining points for an end condition, the Dynamic Settings dialog includes additional options for 
the point definition as shown below. 
 

 Check for Interception specifies the preceding segment 
will be checked for interception of the target when the end-
conditions are solved. If it is turned off, then the segment 
will be ignored when checking for interceptions. 
 
Place Point at Interception specifies that when an 
interception is found along the preceding line segment, the 
line segment will be drawn to the interception. Otherwise, if 
the interception is found, the line segment will be drawn to 
its maximum width. 
 
End Condition is Infinite specifies the last segment will be 
of infinite length when attempting to intercept the target. 
This option is applicable only to the last point on the end 
condition. 
 
Do Not Construct specifies the point will be solved like all 
other points in the end-condition, but the point will be 
skipped when drawing the component segments. 

 
These end condition point properties can be edited in the Point Properties dialog. Double click on an end 
condition point to review or edit the properties. 
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End Condition Priority 
The end condition priority value is used when more than one end condition is defined starting at the same 
point. A simple end condition consisting of two fill lines is shown in the example below. 

When the end condition is processed in corridor modeling, each end condition will be tested in the order 
specified by the user. The order is determined by the Priority value entered by the user during the end 
condition creation. The most desirable solution, and the first condition to be tested, is given a priority value 
of 1. 
 
Double-clicking on a component will open the Component Properties dialog shown below. If the component 
is an end condition, the End Condition Properties are displayed. The Priority is set as shown below. 
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The properties for point R-EC_FSLP were defined 
as shown at right. Check for Interception is 
toggled “on”, and End Condition is Infinite is 
toggled “off”. The point is defined with a value of -
33.33% Slope for a vertical distance of 16.0’ from 
the graded shoulder point R-EC_GSH1.  
 
The properties for the point R-EC_FSLP1 were 
defined to specify a 2:1 slope with the End 
Condition is Infinite option toggled on. The 
priority for the end condition component R-FILL_2 
is set to a value of 2. 
 
With these settings, the end condition R-FILL_3 
will be tested first (Priority=1) for an interception 
with the surface within the vertical distance of 
16.0’. If an interception is found within the vertical 
distance, the end condition is used for the cross 
section and a point will be placed at the 
interception. 
 
If no interception is found within 16.0’ vertically 
from point R-EC_GSH1, the condition fails and the 
software will test the next end condition, R-FILL_2, 
which has a Priority value of 2. 
 
Since End Condition is Infinite is toggled on for point R-EC_FSLP1, the solution will solve for an 
interception with the surface regardless of the vertical constraint definition. 
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Testing End Conditions 
End conditions can be tested in the Create Template dialog before processing the template with corridor 
modeling. Testing simulates how the end condition will behave when the corridor is processed. 
 
This is extremely useful for complex end condition definitions with multiple solutions. To test the end 
condition, select the Test command, located below the Current Template window. The Test End 
Conditions dialog is opened. 

 
The software will check for conflicts in the priorities defined in the template before opening the Test End 
Condition dialog. If conflicts exist, a warning is issued. 
 
The dialog displays the current template. Non-solved end conditions, and their child components, are 
displayed in dashed lines. Normal components and solved end conditions are displayed as solid lines. 
 
To test the end condition, select one of the available targets and then select the Draw button. Move your 
cursor over to the testing window. The end conditions will change from a dotted line to a solid line 
indicating the solution for the target interception. 
 

Failure Report activates the Results dialog. When you fail to get a solution on one or both sides, the 
results show which components failed and which end condition start points were not solved. 
 
Check Priorities tests the template for priority conflicts. When conflicts exist, a message is 
displayed indicating there are end conditions that start from the same point and have the same 
priorities. The End Condition Priority Conflicts dialog is displayed. If no conflicts exist, a message box 
indicating no conflicts is displayed. 
Available Targets lists all the targets applicable to the current template. You can select the desired 
target and draw it in the display. 
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Use Surface Slope specifies the slope of the surface that is being placed. This is useful in certain 
instances where an end condition intersects a surface more than once, such as a ditch profile. 

 
Draw draws the selected target. Surfaces and elevations are drawn as horizontal lines. Features 
and alignments are drawn as a “+” mark. As you draw a target, the display dynamically updates to 
show the solution(s). 
 
Reset clears all the drawn targets. 

 
Display Rules list the display rules for the current template. Left click the Value to toggle between 
True and False. Press the Reset button to restore the original Display Rules values. 
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OhioDOT Released End Conditions 

The following section will help explain how to use and work with the Template end conditions that are 
released in the OHDOT standards. 
 
The end condition templates are based off the Location & Design Manual, Volume 
1 – Roadway Design, Section 300. These templates can be found within the 
ODOT\End Conditions folder inside the worksets .itl file. 
 

Standard Points and Components for End Conditions 
While end conditions or grading can get very complicated in certain situations these templates were set up 
to cover most of the standard cases and can be used as a starting point for more complicated situations. To 
make sure all points and components will connect correctly from drop location to drop location the 
following points and components have been set up. 

Grading with Ditches 

 

See tables on the next page for more details on the points and components that make up this template.  
 

• Note that the foreslopes consist of three components. A Graded Shoulder, Foreslope and Ditch 
Foreslope. If only two different foreslopes are needed, then instead of deleting the foreslope 
component, simply change the constraints on the EC_FLSP point so that the point moves to be at the 
same location as the EC_GSH point. This is done so that if another template is used in the corridor 
that uses three foreslopes the two template drops will be able to connect all the points and 
components together and not leave gaps in the model. 
 

• Note that in some cases the EC_FLSP point will represent the clear zone location. Is this situation 
the CLEAR ZONE point should be used to set this distance and the EC_FLSP point should be 
horizontally constrained about the CLEAR ZONE POINT. 
 

• Note the EC_BKSLP#:1-HeightCheck point is an optional point that can be added to the BKSLP 
component to represent the minimal ditch depth. Set the check for interception checkbox to be 

GSH 

FSLP 

FSLP_DITCH 

DT 
BKSL 
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checked off to ensure the end condition fails if the minimum depth is not met, to ignore this remove 
the point or check on the check for intersection checkbox. 
 

• Note when adding multiple end condition branches to a template, simply add a number to the end 
of point/component names and increment that for additional branches. Ensure override names 
remain the same.   
 

• Note the last point in an end condition branch should always have an override name of TIE. It can 
be used as a basis for construction limits. 
 

• Note backslope points can optionally contain the slope in the name.
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Point Name 
Override 
Name Desc  Constraint Type Parent Label NOTES 

EC_BRANCH --Merge with edge of shoulder point-- 

EC_GSH GSH point for end of 
graded shoulder 

Constraint 1 Slope EC_BRANCH GSH_SLOPE Graded Shoulder slope 
Constraint 2 Horizontal EC_BRANCH GSH_WIDTH width of graded shoulder 

EC_FSLP FSLP 

point for end of 
foreslope, if not 
needed change 

constraint #2 value to 
0, keep for connection 

to other templates 

Constraint 1 Slope EC_GSH FSLP Foreslope 

Constraint 2 Vertical EC_GSH FSLP_DEPTH 

Depth of foreslope, if this 
point needs to match Clear 
Zone, then change to be 
horizontally constrained 
about CLEAR ZONE Point  

EC_DITCH-
INSIDE 

DITCH-
INSIDE 

point for end of ditch 
foreslope/inside 
bottom of ditch 

Constraint 1 Slope EC_FLSP DITCH_FSLP Foreslope of ditch 

Constraint 2 Vertical EC_FLSP DITCH_DEPTH_NEGATIVE depth of ditch 
EC_DITCH-
OUTSIDE 

DITCH-
OUTSIDE 

point of outside 
bottom of ditch 

Constraint 1 Horizontal EC_DITCH-INSIDE DITCH_WIDTH width of ditch 
Constraint 2 Vertical EC_DITCH-INSIDE   leave at 0 

EC_BKSLP#:1 TIE point for end of 
backslope 

Constraint 1 Slope EC_DITCH-OUTSIDE DITCH_BKSLP backslope 
Constraint 2 Vertical EC_DITCH-OUTSIDE   height of backslope 

EC_BKSLP#:1-
HeightCheck   

check point to check 
min depth of ditch-

OPTIONAL 

Constraint 1 Slope EC_DITCH-OUTSIDE DITCH_BKSLP backslope 

Constraint 2 Vertical EC_DITCH-OUTSIDE DITCH_DEPTH min. depth of ditch 

EC_CZONE CLEAR_ZONE Point to represent 
clear zone - OPTIONAL Contraint1 Horizontal EC_BRANCH CZ_WIDTH 

Sets width of clear zone, can 
be used to move EC_FLSP 
point 

 

Component Name Override Name Description Parent 

GSH GSH Graded Shoulder   
FSLP FSLP Foreslope-keep for connection to other templates GSH 
FSLP_DITCH FSLP_DITCH Ditch Foreslope FSLP 
DT DITCH Ditch FSLP_DITCH 
BKSLP BKSLP Backslope DT 
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Grading without Ditches 

 

See tables on next page for more details on the points and components that make up this template.  
 
Unlike the ditch template which had three separate components for each part of the foreslope, there are 
only two components, the graded shoulder and the foreslope. Where the foreslope component consists of a 
middle point to allow an additional slope change. This was done to ensure components from drop location 
to drop location connect. If only two different foreslopes are needed, then instead of deleting the point, 
simply change the constraints on the EC_FSLP point so that the point moves to be at the same location of 
the EC_GSH point. 
 

• Note when adding multiple end condition branches to a template, simply add a number to the end 
of point/component names and increment that for additional branches. Ensure override names 
remain the same. 
 

• Note the last point in an end condition branch should always have an override name of TIE. It can 
be used as a basis for construction limits. 

 
 

GSH 

FLSP 

FLSP 
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Point Name Override Name Desc  Constraint Type Parent Label NOTES 
EC_BRANCH --Merge with edge of shoulder point-- 

EC_GSH GSH point for end of graded 
shoulder 

Constraint 1 Slope EC_BRANCH GSH_SLOPE Graded Shoulder slope 
Constraint 2 Horizontal EC_BRANCH GSH_WIDTH width of graded shoulder 

EC_FSLP FSLP 

point for slope change of 
foreslope, if not needed 

change constraint #2 value 
to 0, keep for connection to 

other templates 

Constraint 1 Slope EC_GSH FSLP Foreslope 

Constraint 2 Vertical EC_GSH FSLP_DEPTH Depth of foreslope 

EC_TIE TIE point for end of foreslope Constraint 1 Slope EC_FSLP  Foreslope 

Constraint 2 Vertical EC_BRANCH  Overall depth 

EC_CZONE  CLEAR_ZONE 
Point to represent clear 
zone - OPTIONAL Constraint 1 Horizontal EC_BRANCH CZ_WIDTH 

Sets width of clear zone, can 
be used to move EC_FLSP 
point 

 
 

Component Name Override Name Description Parent 

GSH GSH Graded Shoulder   
FSLP FSLP Foreslope GSH 

Fixed Ditch Templates 

 
These templates are set up to force a minimum ditch depth. Once the backslope becomes shorter than the minimum depth then the ditch will 
be pushed lower in order to maintain the required minimum depth of the ditch. These templates are useful when dealing with fill conditions. 
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These templates have additional do not construct (DNC) points. These points are needed to set up the 
template to push the ditch to lower elevations in order to meet minimum ditch depths. 
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Point Name 
Override 
Name Desc  Constraint Type Parent Label NOTES 

EC_BRANCH --Merge with edge of shoulder point-- 

EC_GSH GSH point for end of graded 
shoulder 

Constraint 1 Slope EC_BRANCH GSH_SLOPE Graded Shoulder slope 
Constraint 2 Horizontal EC_BRANCH GSH_WIDTH width of graded shoulder 

EC_FSLP FSLP 

point for end of 
foreslope, if not needed 

change constraint #2 
value to 0, keep for 
connection to other 

templates 

Constraint 1 Slope EC_GSH FSLP Foreslope 

Constraint 2 Vertical EC_GSH FSLP_DEPTH 

Depth of foreslope, if this 
point needs to match Clear 
zone, then change to be 
horizontally constrained 
about CLEAR ZONE Point  

DNC  
Do not construct point in 

line with Ditch 
foreslope/inside ditch 

Constraint 1 Slope EC_FSLP DITCH_FSLP Foreslope of ditch 

Constraint 2 Vertical EC_FSLP DITCH_DEPTH_NEGATIVE Negative Depth of ditch 

DNC1  
Do not construct point 
parallel with outside 

ditch 

Constraint 1 Vertical DNC   

Constraint 2 Horizontal DNC DITCH_WIDTH Width of ditch 

DNC2  Do not construct point 
parallel with backslope 

Constraint 1 Slope DNC1 DITCH_BKSLP Backslope of ditch 

Constraint 2 Vertical DNC1 DITCH_DEPTH Depth of ditch 

DNC3  
Do not construct point 

lines up with end of 
backslope 

Constraint 1 Slope DNC2 DITCH_FSLP Foreslope of ditch 

Constraint 2 Vertical DNC2   

EC_BKSLP#:1 TIE point for end of 
backslope 

Constraint 1 Horizontal DNC3   

Constraint 2 Vertical DNC3    

EC_DITCH-
OUTSIDE 

DITCH-
OUTSIDE 

point of outside bottom 
of ditch 

Constraint 1 Slope EC_BKSLP#:1 DITCH_BKSLP Backslope of ditch 

Constraint 2 Vertical EC_BKSLP#:1  DITCH_DEPTH_NEGATIVE Negative Depth of ditch 

EC_DITCH-
INSIDE 

DITCH-
INSIDE 

point for end of ditch 
foreslope/inside bottom 

of ditch 

Constraint 1 Vertical EC_DITCH-OUTSIDE   
Constraint 2 Horizontal EC_DITCH-OUTSIDE DITCH_WIDTH_NEGATIVE negative width of ditch 

CLEAR ZONE  Point to represent clear 
zone - OPTIONAL Contraint1 Horizontal EC_BRANCH CZ_WIDTH 

Sets width of clear zone, can 
be used to move EC_FLSP 
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Component Name Override Name Description Parent 

GSH GSH Graded Shoulder   
FSLP FSLP Foreslope-keep for connection to other templates GSH 

DNC  
Hidden component needed to push ditch down to 
maintain min. ditch depth FSLP 

BKSLP BKSLP Backslope DNC 
DT DITCH Ditch BKSLP 
FSLP_DITCH FSLP_DITCH Ditch Foreslope DT 

 

 

  

 

 Modifying Fixed Ditch Templates 
Since these templates are more complicated to edit, it is recommended you make edits via the Parametric 
Constraints (Labels). Simply select the Active Template Tab and then expand the Parametric Constraints 
Section. Double click on a given Constraint (Label) to change its value. For example, to change the Ditch 
foreslope, double click on the DITCH_FSLP constraint and a dialog will open displaying the current value. 
Change to the desired value and click okay. 
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The above screen shots of fixed ditch templates only show the fixed ditch part of the template. The actual 
templates delivered with the workspace take the Grading with Ditches template and combines it with the 
fixed ditch template. An example is shown below. Notice that some points are duplicated and end with a 1, 
that is okay. The Grading with Ditches part of the template has a higher priority than the fixed ditch part. 
This way, the backslope will search up to solve first and once the backslope reaches the minimum ditch 
depth the fixed ditch solves and pushes the ditch deeper to maintain the minimum ditch depth.  

Using Fixed Ditch Templates 
Since these ditches are more complicated it is recommended you use them as a starting point to get the 
ditch profile. Do not try to add point controls off these templates. The simple workflow is as follows. 
 

1. Push fixed ditch template along alignment 
2. Open Profile of inside ditch line. There might be bumps in profile and it might be desired to 

smooth out the profile. REMEMBER when drawing in a new profile to always stay at or 
below the current profile. The current profile represents the highest elevation that profile 
can be in order to solve. Going above that profile will cause your end condition to not solve 
in those areas. 
Also keep in mind the lower you draw in your profile, the further the horizontal distance of 
the ditch will be from the alignment. 
Make sure to complex and give a feature definition to your drawn in profile. 

3. Project profile to centerline alignment. 
4. Remove rules from projected profile! 
5. Replace fixed ditch template with equivalent non-fixed ditch template 
6. Add a vertical point control to the ditch point based off the projected ditch profile.  
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Component Properties 
The properties of the component can be edited by double-clicking on the component. The Component 
Properties dialog is opened. 

Name 
Specifies the name of the current component. Select a different component using the locate button. 
 
Use Name Override 
The name override is used to specify the name used by the software to connect components from 
one template drop location to the next. 
 
The option is intended to create connectivity from one station to the next when the template 
components change. For example, a template may contain more than one solution for a fill 
condition as shown below.

 
Two end conditions are defined for the fill slopes named R-FILL2 and R-FILL3. When the templates are 
processed, the software will evaluate each template drop location to determine whether the R-FILL2 or the 
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R-FILL3 component is used. 3D Mesh elements are created by connecting all the components by the name 
of the component. All the components named R-FILL2 will be connected to create a 3D Mesh element, and 
all the components named R-FILL3 will be connected to create another mesh element.  This leaves a gap in 
components at the locations where the fill slope transitions from 3:1 to 2:1 since the components named R-
FILL3 will not be connected to the components named R-FILL2. The solution is to assign the same 
Override Name for each component. 

Description 
Specifies an optional description of the component. 
 
Feature Definition 
Specifies the feature style of the component. This option is used for display and to define the 
component’s material. ODOT has defined a specific group of styles to be used for components 
prefixed with the word “Component”. When the components are plotted in MicroStation, either as a 
3D model, or as cross sections, the symbology defined by the selected Style is used.  Care should be 
taken to select the appropriate style for each template component. 

 

Parent Component 
Specifies the parent component. If a component has a parent component, then it is only displayed if 
the parent component is displayed. The parent component can be either a non-end condition 
component, or an end condition component. Specify the component or identify it using the locate 
button. 
The Active Template listing can also be used to display and edit the 
parent child relationship between points and components. In the 
example at right, the Components category is open to show the 
parent/child relationship between the components in the tree. Drag 
and drop operations can be used to move one component under 
another. 

 
Note: The component names are listed alphabetically, not from top to 
bottom as drawn in the template. 
 

Exclude from Top/Bottom Mesh 
Specifies that the component will be excluded from the top and bottom mesh 
elements that are created in the corridor modeling process. 
 

Close Shape 
This option is only available for non-End Condition components. Only closed shapes can be used to 
compute component quantities. 
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Section 503 Template Exercises 
Exercise 1: Create Templates from Components 

In this exercise we will assemble the template for St. Peter Road by dragging and dropping components 
from the ODOT template library. 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 401-Engineering\Roadway\Basemaps\ folder.  
• Continue in the file 123456_KM003.dgn. The design file that is used does not matter since we are 

editing the template library .itl file. 
 From the Corridors tab, choose Template > Create Template. The Create Templates dialog is 

opened with the template library for the WorkSet loaded 
 Create a folder named St. Peter Road to store all the templates for St. Peter Road. Right-click on the 

Project Templates folder and choose the New > Folder option. 

 
Take the following steps to create the template for St. Peter Road: 

 
 Right-click on the Project Templates folder and choose New > Template to create the first 

template for St. Peter Road. Name the template “St. Peter Road”. 
 Open the Dynamic Settings dialog (Tools > Dynamic Settings) to define the Step increment 

values as 0.5 and 0.1. This is helpful to ensure that the initial pavement placement is constrained on 
the “grid” 

 In the Dynamic Settings dialog, turn off the Affixes option. We will drag in a pavement backbone 
that already has the left and right sides defined.  

 Drag the following pavement backbone into the template at the (0,0) origin: 
 
ODOT > Backbones > Undivided Roadways > Pavement and Shoulder 301-8E Uncurbed > 2-
Lane > Asphalt Concrete without Stabilization 
 

St. Peter Road will use a pavement width of 10’. Take the following steps to define the pavement width: 
 

 Edit point L-ACSC_T_EP to define the Horizontal constraint with a value of -10 
 Edit point R-ACSC_T_EP to define the Horizontal constraint with a value of 10 

Next add the end conditions to the template. 
 

 In the Dynamic Settings dialog, turn on the Affixes option 
 Drag the following component onto the edge of shoulder point. 

 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 503 – Template Exercises 503-2 
 

ODOT > End Conditions > 307-4E Common and Barrier Grading > 307-4E Cut 3:1 
 
Tip: Since this template is symmetrical, you can right-click while dragging the end condition into 
the template to activate the Mirror option (CTRL+M) to place it on both sides simultaneously. 

 
The completed template should appear as shown below. 

 
 When complete, save your template by choosing File > Save from the Create Template dialog pull-

down menu. 
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Exercise 2: Creating the S.R. 185 and Jameson Road Templates 

In this exercise we will create the templates for S.R. 185 for and Jameson Road 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 401-Engineering\Roadway\Basemaps\ folder.  
 Open the file 123456_BK001.dgn. The design file that is used does not matter since we are editing 

the template library .itl file. 
 

S.R. 185 Template 
 
 From the Corridors tab, choose Template > Create Template. The Create Templates dialog is 

opened with the template library for the WorkSet loaded 
• Create a new template named S.R. 185 in the Project Templates folder. 
• Open the Dynamic Settings dialog to ensure the Step values are defined as desired. 
• Create the S.R. 185 template by dragging in the components listed below. 

Be sure to pay attention to the Apply Affixes setting (Dynamic Settings dialog). Should this 
setting be toggled on or off as each of the components listed below is dragged into the 
template? 

 
ODOT > Backbones > Undivided Roadways > Pavement and Shoulder 301-8E Uncurbed > 2-
Lane > Asphalt Concrete without Stabilization 

 
ODOT > End Conditions > 307-4E Common and Barrier Grading > 307-4E 3:1 Cut, Fill Table 
 

 After dragging in the end conditions, the next step is to remove some of the options. For this 
project, slopes of 3:1 or 2:1 will be used. 
 
There are two different Graded Shoulder components in the end condition on each side of the 
template. The components R-GSH1 and L-GSH1 are used when the 6:1 slope is used. Remove these 
two components by right-clicking on the component and choosing the Delete Component option. 
Since these two graded shoulder solutions overlap, you are prompted to select the component you 
wish to delete as shown on the following page. Remove the R-GSH1 and L-GSH1 components. The 
6:1 slope component is also removed since it has been defined as a “child” component of the graded 
shoulder 1 component. 
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 Delete the 4:1 fill slope component on each side of the template. The completed template should 

appear as shown below. 
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Intersection and Driveway Display Rules 
The backbone for the template contains four Null Points that are used to seek the intersection with another 
road (INT-Left and INT-Right) and points that are used to seek the intersection with a driveway (DRIVE-
Left and DRIVE-Right). These points are defined to find elements of specific symbology defining the limits 
of an intersecting road or driveway. The properties for the point INT-Left are shown below. 

 
The Horizontal Feature Constraint item 
defines the symbology for the element that the 
point will seek. 
 
The Range defines the horizontal limit that the 
software will search for an element matching 
the defined symbology. 
 
When the template is applied to a corridor, 
these points will seek for any elements 
matching the assigned symbology and will 
move to intersect the element. If the point 
moves, a Display Rule is applied to toggle off 
the display of selected components. 
 
For example, if a driveway is found to the right, 
point DRIVE-Right moves to intersect the line 
that defines the limits of the drive. The display 
rule turns off the display of the shoulder 
components. 
 

 
 

The behavior of the points can be tested in the template dialog. Take the following steps to test the 
behavior of the DRIVE-Right point: 
 
 Right-click the point DRIVE-Right 

• Choose Test Point Controls > Test Horizontal Point Control 
• Move the cursor to the left and right of the template center point. Observe the behavior of 

the template components 
 

As the point is moved to the right, the shoulder components on the right side of the 
template disappear. Notice that the end condition components are not defined to observe 
the display rules at this point, as shown below 
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Take the following steps to assign the display rule to the end condition components: 

 
 Left click on the template window to terminate the testing process. 

 

 
The Display Rule is applied to the top shoulder component. Take the following steps to review the 
display rule: 
 

 Double-click the top component of the right shoulder,  
R-ACSC-SH (shown to the right) 

 
 Select the Edit button to the right of the Display Rule 

parameter to open the Component Display Conditional 
Expression dialog. (shown below) 
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 Review the display rule settings. Select the Cancel button when complete. 

 
 From the Component Properties dialog, select Close. 
 

Note that the display rule is only applied to the top component of the shoulder buildup in this template. 
Each of the sub-components of the shoulder are defined as “child” components with the top component as 
the parent component. Display rules assigned to the parent are inherited by the children. 
 
This parent-child relationship can be reviewed or defined using the Active 
Template portion of the Create Template dialog as shown at right. 
 
The parent component is at the top of the hierarchy for each branch. 
Components can be arranged in a hierarchal relationship by using drag-and-
drop operations within the Active Template portion of the dialog. 
 
If a display rule is set to turn off the display of the parent component, the 
display of each child component is also toggled off. 
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When an intersection or a driveway element is encountered, the display of the end conditions must also be 
turned off. 
 
Take the following steps to apply displays rule to the parent component of the left and right end conditions: 
 
 Double-click on the component L-GSH2 to access the Component Properties dialog 

o Select the Edit button to the right of the Display Rules 
o Add the following display rule: 

NOT (Intersection-LT or Drive-LT) 
o Select OK to accept the display rule 
o Select Apply on the Component Properties dialog 

 
 Test the point control by right-clicking on points INT-Left and DRIVE-Left to test the Horizontal 

Point Control. 
 
If the display rule is applied correctly, the shoulder and end condition will not display when point 
INT-Left is moved to the left, and the shoulder steps and the end condition will not display when 
point DRIVE-Left is moved to the left. 
 
Note: The Library option must be selected to test the display rule behavior. If the Active Template 
option is selected, the display rules cannot be tested. Be sure to select the Library option before 
testing the point and display rule behavior. 
 

 Repeat the process to define the display rule for the right end condition by editing the R-GSH2 
component. 
 

 When complete, choose File > Save from the Create Template dialog to save the changes to the 
template library. 
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Jameson Road Template 
The Jameson Road template will use the same design as the S.R. 185 template. 

 Right-click on the name of the S.R. 185 template 
 Choose the Copy command 
 Right-click on the Project Templates folder 
 Choose the Paste command 
 Rename the copied Folder and Template as “Jameson Road” 

 
The pavement width for the proposed Jameson Road is 20’. Take the following steps to edit the template 
with the pavement width values: 

 Double-click on the name of Jameson Road template to edit the template 
 Edit points R-ACSC_T_EP and L-ACSC_T_EP to change the Horizontal constraint value to 10 & -10 

 
This completes this exercise. 

 From the Create Template dialog, choose File > Save. Close the Create Template dialog. 
 Exit OpenRoads designer, checking the design file back into ProjectWise 

 

 

  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 503 – Template Exercises 503-10 
 

Additional Template Exercises 

Simple Components 
In this exercise we will create a simple template consisting of pavement and shoulders for a two-lane road. 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 401-Engineering\Roadway\Basemaps\ folder.  
• Open the file 123456_BK001.dgn. The design file that is used does not matter since we are editing 

the template library .itl file. 

Take the following steps to create a new template for this exercise: 

 From the Corridors tab, choose Template > Create Template. The Create Templates dialog is 
opened with the template library for the WorkSet loaded 

 In the Template Library list, right-click on the Project Templates folder and choose the New > 
Template option. Name the new template Exercise 1. 
 

• Select Tools > Options to open the Template 
Options dialog. Set the parameters for the 
dialog as shown on the right. 
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• Select Tools > Dynamic Settings to open the 
Dynamic Settings dialog. Set the parameters as 
shown at right. 

• Right-Click in the template window and choose 
Add New Component > Simple. A simple 
component is floating on the cursor using the 
default settings for the Slope, Thickness, and 
Width. 

 
• Set the parameters for the new component that 

will be created as follows: 
Name:  ACSC 
Feature: MD_P_Asphalt_Concrete_Surface_Course 
Slope:  -1.60% 
Thickness: 1.25”  
Width:  12 

• Right-Click in the template window and choose the Mirror option (Ctrl-M). The simple 
component is now mirrored and appears on both the left and right sides. The component is 
mirrored about the Dynamic Origin location.  

• Identify the template origin by issuing a data point at the (0,0) coordinate location in the 
template window. The component is constrained to the nearest point in the grid by the Step 
values defined in the Dynamic Settings dialog. The mirrored components are shown below. 

 
Tip: You can use the XY= option in the Dynamic Settings dialog to enter the (0,0) coordinate. 

 
Take note of the point names for the components. Each point is named according to the Point 
Name parameter in the Dynamic Settings dialog. Points to the left and right of the origin are 
prefixed according to the affixes defined in the Template Options dialog shown on the previous 
page. The Point Style (feature definition) is the same for each point. It is necessary to review 
and edit the points to assign the appropriate point name and style. 

 
The Point Properties dialog is used to edit points. 

 
 Double-click on point L-ACSC_T_CL to review and edit the properties of the point. Take the 

following steps in the Point Properties dialog: 
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• Change the point name to ACSC_T_EP by selecting the name from the list. 

 
o When the point name is selected from the list, the corresponding Feature Definition is 

automatically assigned for the point. Verify that the Feature Definition is now set to 
MD_P_ACSC_T_EP 
 

o The point name still needs to have a prefix assigned. Add the prefix L- to the point name. 
The point name and feature definition should be set as shown below. 

 

o Select the Apply button to save the changes. 
 

 Review the remaining points to set the appropriate point Name and Feature Definition for the top 
and bottom of the pavement layer. Remember, the feature definition that is assigned to each point 
will control the level symbology for the 3D line strings that are drawn in the corridor model. 
 

 Add a simple component for the shoulder surface to the template using the Mirror option with the 
following settings: 

Name:  ACSC-OS 
Feature: MD_P_Asphalt_Concrete_Surface_Course 
Slope:  -4.00% 
Thickness: 1.25” 
Width:  4 

 Edit the point names for the shoulders by double-clicking on each point to open the Point Properties 
dialog. Be sure to pick the point names from the drop-down menu list so that the corresponding 
feature definitions are assigned. When completed, the points should be named as shown below. 
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 When complete, save your template by choosing File > Save from the Create Template dialog pull-

down menu. 
 
 

Creating and Testing End Conditions 
In this exercise, you will create a simple cut end condition with a 3:1 foreslope and a 2’ ditch. The backslope 
will contain two end conditions, a 3:1 slope and a 2:1 slope as shown below. 

  
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 
 

• Browse to the 401-Engineering\Roadway\Basemaps\ folder.  
 

• Open the file 123456_BK001.dgn. The design file that is used does not matter since we are editing 
the template library .itl file. 
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Take the following steps to create a new template for this exercise: 
 
 From the Corridors tab, choose Template > Create Template. The Create Templates dialog is 

opened with the template library for the WorkSet loaded 

 Right-click on the Project Templates folder and choose New > Template. Create a new template 
named Normal Ditch. 
 

 Open the Dynamic Settings dialog and select the Point Name to “EC_HINGE” from the list. The 
Point Style is automatically set. Set the Step values as desired. Uncheck Apply Affixes. 

 
 Add an end condition for the graded shoulder 

• Right-click in the template window and choose Add New Component > End Condition. 
• Start the End Condition at coordinate (XY=0, 0). 
• Name the component “GSH1” 
• Use the Feature “MD_P_Graded_Shoulder” for the component 
• Be sure to check off Check for Interception in the Dynamic Settings dialog after placing the 

first point. 
• Change the Point Name in the Dynamic Settings dialog to “EC_GSH1” After placing the first 

point but before placing the second point. By choosing the name from the list, the Feature 
Definition is automatically assigned. 

• Place the second point 6’ horizontally from the first point at a slope of -8% (hs=6, -8%) 
• Right click and select Finish. 

 

 Add an End Condition for the ditch foreslope. 
• In the Dynamic Settings dialog, select the Point Name EC_FSLP. 
• Right-click in the template window and choose Add New Component > End Condition. 
• Name the component “3:1 Foreslope” 
• Use the Feature “MD_P_Foreslope” for the component 
• Create the component with a vertical constraint of -1.5 at a 3:1 slope (vs=-1.5, -1:3) from the 

point EC_GSH1. Be sure to check off Check for Interception in the Dynamic Settings dialog 
after placing the first point. 

• Right click and select Finish. 
• Double click on the 3:1 Foreslope End Condition and set the Parent component to GSH1. Hit 

Apply. 
 

 Add an End Condition for the 2’ ditch bottom. 
• In the Dynamic Settings dialog, select the Point Name EC_DITCH. 
• Right-click in the template window and choose Add New Component > End Condition. 
• Name the component “DITCH” 
• Use the Feature “MD_P_Ditch” for the component 
• Create the component with a horizontal constraint of 2.0 and a vertical constraint of 0 

(dl=2,0) from the point EC_FSLP. Be sure to check off Check for Interception in the 
Dynamic Settings dialog after placing the first point. 

• Right click and select Finish. 
• Double click on the DITCH End Condition and set the Parent component to 3:1 Foreslope. 

Hit Apply. 
 
Next, define two end conditions for the backslope. 
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 In the Dynamic Settings dialog, select the Point Name EC_BKSLP 
 Right-click in the template window and choose the Add New Component > End Condition option. 
 Name the end condition “3:1 Backslope” 
 Set the Feature for the end condition to “MD_P_Backslope” 
 Create the component with a vertical constraint of 5’ at a 3:1 slope (vs=5,1:3) from the point 

EC_DITCH. Be sure to check on Check for Interception in the Dynamic Settings dialog after placing 
the first point. 

 Right click and select Finish. 
 Double click on the 3:1 Backslope End Condition and set the Parent component to DITCH. Hit 

Apply. 
 

Add a second End Condition for the 2:1 backslope using the settings detailed below. 
 In the Dynamic Settings dialog, select the Point Name EC_BKSLP 
 Right-click in the template window and choose Add New Component > End Condition. 
 Name the end condition “2:1 Backslope” 
 Set the Feature for the end condition to “MD_P_Backslope” 
 Set the component Priority to 2 
 In the Dynamic Settings dialog, toggle on the Check for Interception and End Condition is Infinite 

options (options not available until the first point of the end condition is placed).  
 Create the component with a vertical constraint of 5’ at a 2:1 slope (vs=5,1:2) from the point 

EC_DITCH 
 Right click and select Finish. 
 Double click on the 2:1 Backslope End Condition and set the Parent component to DITCH. Hit 

Apply. 
 
Next, review the point names and feature styles, as well as the Override names for the points and 
components. 
 Double-Click on the point EC_BKSLP to make the following change: 

o Toggle on the Use Feature Name Override option and enter an override name of “BKSLP” 
and change the name to “EC_BKSLP3” then hit Apply. 

 Double-Click on the point EC_BKSLP1 to make the following changes: 
o Toggle on the Use Feature Name Override option and enter an override name of “BKSLP” 

and change the name to “EC_BKSLP2” then hit Apply. 
 
Review the component properties for the backslope components to set the override name. 
 
 Double-click the 2:1 Backslope component. Toggle on the Use Name Override option and set the 

override name to “Backslope” 
 

 Double-click the 3:1 Backslope component. Toggle on the Use Name Override option and set the 
override name to “Backslope” 

 
The completed template should appear as shown below. 
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 Use the Test option to ensure that the backslope components behave as intended. The 3:1 

backslope should solve first for backfills up to 5’ high. The 2:1 solution should solve for backslopes 
greater than 5’. 

 
 When complete, choose File > Save from the Create Template dialog to save the changes to the 

template library. 
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Section 504 Corridor Modeling 
Corridor Creation 

A corridor model is created by applying a template to the selected horizontal and vertical geometry. 
 
Corridor models are created by choosing the New Corridor command from the Corridors tab, or by 
selecting an alignment and choosing the Create Corridor command from the pop-up menu. When the 
command is selected, the software will step you through a series of prompts. These prompts appear on the 
cursor and can also be defined using the Tool Settings dialog. 

 
You are prompted to define the following parameters: 
 

Locate Profile – Reset For Active Profile 
Select the profile name from the drop-down list or issue a reset button to accept the Active Profile 
that is defined for the Horizontal Alignment. 
 
Corridor Name 
Define the name for the corridor. It is recommended that you use the same name as the horizontal 
alignment. 
 
Feature Definition 
The assigned Feature Definition defines a variety of parameters to control the template drop 
interval as well as which elements are drawn in the 3D model. (3D line strings, 3D components, 
surface meshes, etc.) 
 
The feature definitions can be reviewed in the Civil Standards tab of the Project Explorer dialog as 
shown below. 
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The feature definition assigned to a corridor can be changed at any time throughout the corridor 
modeling process. 
 
Each Corridor feature definition is defined to provide more detailed modeling as you work from 
conceptual design to the final design. The settings for each Corridor feature definition are defined in 
the OHDOT standards and vary for each design stage. 
 

Template Drop Interval Multiplier 
When templates are applied to the horizontal and vertical geometry, the user is prompted 
to enter a template drop interval. ODOT recommends an interval of 5. The Template Drop 
Interval Multiplier parameter is used to specify a multiplier, which is applied to the initial 
template drop interval, to determine the actual interval of each template drop location 
according to the selected design stage. This is useful to speed up processing for early design 
stages where less detailed information is required. The ODOT design stages have been 
defined with the multiplier values shown in the table below. 
 

Design Stage Template Drop 
Interval Multiplier 

Conceptual 5 
Design 2 
Final 1 
Final w/Contours 1 
Final w/Meshes 1 
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After defining the Profile, Corridor Name, and Feature Definition, you are prompted to define the 
Template Drop information as shown below. 

 
The parameters can be defined in the Crete Template Drop 
window, as shown at left, or by dialogs floating on the cursor 
that will step you through the parameters. 
 
Each parameter is defined below: 
 
 
 
 
 
 

 
 
Lock to Start 
Toggle this option on to lock the start of the corridor to the start of the horizontal alignment. 
 
Start 
Define the Start station for the corridor. 
 
Lock to End 
Toggle this option on to lock the end of the corridor to the end of the horizontal alignment. 
 
End 
Define the end station for the Corridor. 
 
Drop Interval 
This parameter is used to define the interval that the template will be applied to the corridor. We 
recommend a Drop Interval of 5 for ODOT projects. 

 
Minimum Transition Before Drop / Minimum Transition After Drop 
If they are non-zero, then a transition drop is created at the beginning/end of the template drop 
with a length greater than or equal to the value entered. The actual length is determined by how far 
it is between the new drop and the drop before/after the new drop. If there isn't enough space to 
meet the minimum, then the previous/next drop is shortened to accommodate the transition. If 
there is no previous/next drop, then no transition drop is created. 
 
Template 
Define the template from the library to be applied to the alignment and profile. The … button to the 
right of the template name is used to browse the template library to choose the desired template. 
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After defining the Create Template Drop parameters, the template is applied to the selected horizontal and 
vertical alignments to create the corridor. 
 

• A 3-Dimensional model named Design-3D is automatically created in the active design file and 
referenced to the active model. 

 
Note: The referenced graphics are not always desirable and can be turned off using the 
MicroStation Reference Attachment tools. 

 
The 3d model of the corridor can be displayed by holding down the right-mouse button in the 
MicroStation view until the pop-up menu appears, and then choosing View Control > 2 Views 
Plan/3D.  

 
In addition to the 3d graphics, 2d graphics are drawn in the active model as described below: 
 

• 2-Dimensional graphics are drawn in the active model as defined by the features assigned to the 
individual points in the template. The ODOT feature definitions that are assigned to points on the 
surface of the template, such as the edge of pavement, shoulder, or ditches, are the only template 
features that draw these 2D plan graphics. 
 

• Graphics representing the length of the corridor model and the template drop range are created in 
the active model. This graphic includes several “handles” at intervals along the length of the 
corridor that can be easily selected to identify the corridor model as shown below. 
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• The corridor is added to the OpenRoads Model, which can be reviewed in the Project Explorer 

dialog. 
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Corridor Editing Tools 

Select one of the corridor handles, as shown below, to access a menu of common corridor commands. 

 
The commands in the menu are grouped as follows: 
 

• Properties 
• Corridor Views 
• Reports 
• Corridor References 
• Corridor Creation Tools 
• Lock – Deactivate Rule 
• Zoom To 
• Delete 

 
Commonly used commands are detailed in this training guide. For additional information, see the online 
help. 
 

Corridor Properties 
Select Properties from the corridor pop-up menu to access the dialog shown below. 

 
The corridor parameters shown above can also be edited in the Properties dialog when a corridor is 
selected. 
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Corridor Views 
The Corridor Views icon has one command, Open Cross Section Model. This command is used to create a 
dynamic cross section view to review the model by scrolling through cross sections. 
 

When selected, you are prompted to Open or Select View for the cross-section display. In the 
example below, View 2 was selected to display the dynamic cross sections. 

 
This dynamic view is a temporary display of the cross sections. The sections are not written to the design 
file using this command. 

 
The View Properties contains parameters for adjusting the cross-
section display, as shown at left. 
 
 
 
 
 
 
 

 
 

Hold down the right mouse button in the cross-section view to 
access the pop-up menu shown at right. Five additional commands 
relevant to cross sections are available. See the online help for 
additional information. 
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Reports 
The Reports icon provides access to the following four reports: 
 

• Corridor Component Quantities 
• Design Input Report 
• Results Report 
• Milling Report 

 
The Corridor Component Quantities report is used to generate a quick cost estimate for the selected 
corridor by assigning a unit cost for each component in the corridor templates. 

 
The remaining reports are offered within the software’s online help documentation. 
 

Corridor References 
The following four Corridor References commands are available: 
 

Add Corridor Reference 
This tool is used to add graphical elements to the corridor processing. This must be done when a 
Feature is targeted in the template definition. This enables the software to process only the 
identified elements, which speeds up processing. For example, if the template targets a right-of-way 
line, the right-of-way lines must be included as a Corridor Reference for the template to find the 
lines. 
 
Remove Corridor Reference 
This tool is used to remove graphical elements from the corridor processing. 
 
Add Clipping Reference 
This command is used to remove areas of overlap when working with multiple corridors. For 
example, in a corridor intersected by a crossing roadway, clipping is used to remove overlapping 
features within the intersection. 
 
Remove Clipping Reference 
This tool is used to remove any clipping references defied for a corridor. 

 

https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20Help-v19/en/GUID-1B18BC16-7361-4DA1-BC57-D8A9EEF3F9E7.html
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Corridor Creation Tools 
The Corridor Creation Tools menu contains commonly used corridor commands. The tools are listed 
below. These tools are detailed on the following pages. 

 
 

Corridor Objects 
 
Create Template Drop 
 
Create Transition 
 
Create Secondary Alignment 
 
Define Target Aliasing 
 
Create Parametric Constraint 
 
Create End Condition Exception 
 
Create Point Control 
 
Create Curve Widening 
 
Key Station 
 
Assign Superelevation to Corridor 
 
 

 
 

Corridor Objects 
This option is a one-stop shop to view, create, and edit corridor objects. Most of the options 
contained in the Corridor Creation Tools can be accessed from this dialog as shown below. 
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Create Template Drop 
This tool is used to create a new template drop location on the corridor. 

 

Create Transition 
A transition is created between templates of different names, as templates generally don't 
instantaneously change from one template to another. This tool creates the transition by selecting the 
two template drops which are adjacent to it. Once the transition location is created, it is up to the user to 
define how the transition is applied. 

 
See the online help for more information. 
 

Create Secondary Alignment 
Secondary alignments are used to modify the direction of cross section processing. By default, at any 
given station, the cross section is created orthogonal to the main alignment. If a secondary alignment 
exists, then that portion of the cross section which lies outside the secondary alignment will be 
orthogonal to the secondary alignment instead of the main alignment. 

 
See the online help for more information. 
 

Define Target Aliasing 
Target aliasing allows you to target other corridor surfaces or features or to set up a prioritized target 
list for end condition solutions on surfaces, features, and alignments. 

 
See the online help for more information. 

 

Create Parametric Constraint 
Parametric constraints can be used to change one or more labeled constraint values of a template 
while the template is being processed in the corridor modeler. 

 
In the example at left, the Constraint Label “ACSC Thickness” is 
assigned in the template for the Vertical constraint of the Asphalt 
Concrete Surface Course point. The Parametric Constraint can be 
used to define a new value for a specified station range. 
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Create End Condition Exception 
End Condition Exceptions are used to modify the behavior of an end condition solution without 
requiring the use of additional template drops. When an end condition exception is added, it must 
be edited to change its behavior. End condition exceptions come in two classes: 

 
• Overrides allow you to replace or override the template drop end conditions on the left or right 

of the backbone. When you choose this option, you must edit the override to set up the new end 
condition. When the override exception is edited, the Create Template dialog is displayed 
allowing you to edit the end-condition. 

 
• End condition Transitions are used where the end condition may change suddenly due to 

changes in the existing surface or other reasons, and you want the transition to be smooth over 
a specified station range rather than a sudden change over a short length. 

 

Create Point Control 
Point controls are used to override the normal locations of one or more points and or components in a 
cross section. Examples of this include lane widening, staying within the right-of-way, or maintaining a 
slope for a ditch. 
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Create Curve Widening 
Curve widening is used to automatically create and apply horizontal controls to widen lanes and/or 
edge of pavement lines around curves, moving them further away from the centerline at each curve 
of the controlling alignment. The tool is used in conjunction with an ASCII file (*.wid) which 
contains parameters to define the widening. 

 
Curve widening is defined in the Location and Design Manual, Volume 1 Roadway Design, 
Section 301.1.3 Travelled Way Widening on Highway Curves. 

 
ODOT does not provide curve widening tables currently. Use point controls to manually assign the 
station ranges and offsets for curve widening. 

 

Key Station 
This command is used to add stations that are not coincident to the template interval to the corridor 
processing. For example, a key station can be added at a drive or culvert location to ensure the template 
is processed at that station. 
 

Assign Superelevation to Corridor 
Superelevation is covered in another section of this training. 

 

Processing Order for Point Overrides 
As you can see, there are several ways in the corridor processing to override the template definition 
for various constraints using Parametric Constraints, Point Controls, and Horizontal Feature 
Constraints. 

 
This is generally the order in which OpenRoads solves the location of points and components at 
each template drop: 
 
1. Template is dropped, and points are placed according to the point constraints stored in the 

template. 
2. Parametric constraints are applied as defined in the template, and in the corridor. 
3. Horizontal Feature constraints are applied to move points if the feature is found in the specified 

range. 
4. Point controls are applied to the assigned points, overriding the corresponding constraint, and 

all points that are constrained back to the point-controlled point will be recalculated. 
5. Component display rules are solved based on the current position of all points. 
6. End conditions are solved by extending designated segments along the specified slope to seek 

their targets. 
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Process Corridor 
Select the corridor line to highlight corridor then pop out menu with appear. Then click the icon to 
reprocess the corridor. 

Lock – Deactivate Rule 
This command can be used to temporarily deactivate processing rules on the corridor. This is useful 
when making edits so that the corridor does not automatically update as the edits are made. Once 
the edits have been completed, the rules can be turned back on, and the corridor reprocessed. 

 

Zoom To 
  Select the command to zoom to the full extents of the corridor. 
 
 

Delete 
Select this command to delete the corridor. 
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Template Drop Tools 

Edit the Template Range 
When the template range graphic is selected, the range can be edited by accessing rule that defines the 
template drop location. 

 

 
The template range can be edited by 
selecting the station and editing the value 
of by selecting the arrow icon to 
dynamically mode the start (or end) of the 
template range. 
 
 
 
 
 
 
 
 

 
 

Template Pop-Up Menu 
Select the template range graphic and let the cursor rest on the element to access the pop-up menu shown 
below. 

 
The following commands are available: 
 

• Properties 
• Edit Template Drop 
• Copy Template Drop 
• Synchronize with Library 
• Delete 
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Properties 
Choosing Properties from the pop-up menu allows editing the parameters shown at left. 

Edit Template Drop 
When a template is applied to generate the corridor, the template definition is copied into the design file. 
The template definition can be edited in the design file, independent of the definition that is stored in the 
template library .itl file. Use this command to edit the template definition as applied to the corridor, not the 
template as defined in the library. 
 
When the command is selected, the Editing Roadway Designer Template Drop dialog is opened. This tool 
is useful when you wish to make local changes to the corridor without editing the template library 
definition. 
 
ODOT recommends making all changes to the template library and then using the Synchronize with 
Library command to apply the changes made in the library to the corridor model. 
 

Copy Template Drop 
This tool is used to copy a template drop to a new station range along the alignment by defining the 
beginning and ending station for the new template drop range. 
 

Synchronize with Library 
Select this tool to synchronize the local copy of the template that has been applied to the corridor with any 
changes that have been made to the template in the library .itl file. 
 
Note: Synchronizing the template with the library will override and changes that may have been made to 
the corridor’s template definition by using the Edit Template Drop command. 
 
For consistency, ODOT recommends making changes to the template library and using the Synchronize 
with Library command to apply template changes to the corridor. 
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Section 505 Corridor Modeling 
Exercises 

Exercise 1: S.R. 185 Corridor 

This exercise illustrates the process of creating the initial corridor model. Additional exercises will be 
added in the future to illustrate different corridor editing tools. 
 
The purpose of this exercise is to demonstrate various modeling tools, not to generate a model that 
accurately represents the best design of this type of project. 
 
In this exercise we will create a corridor for State Route 185. 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 401-Engineering\Roadway\Basemaps\ folder. 
 Open the file 123456_KM001.dgn. 
 Attach the following design files as references (Home > Attach Tools > References): 

Geometry Basemap for S.R. 185 
401-Engineering\Roadway\Basemaps\123456_BK001.dgn 
• Set the Nest Depth parameter to a value of 0 when attaching the geometry basemap. 

 
Survey Basemap 
300-Survey\Basemaps\123456_FB001.dgn 
• Set the Nest Depth parameter to a value of 0 when attaching the survey basemap. 

 
 Select the terrain model boundary and choose the Set As Active Terrain Model option 
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Take the following steps to create the corridor for S.R. 185: 
 
 Select the State Route 185 alignment and choose the Create Corridor command from the pop-up 

menu. 

 
• Create a corridor named CLP_S185 using the Active Profile, and the Conceptual Feature 

Definition. 

 
• Use the parameters below and the S.R. 185 template created in the previous exercise. 
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A portion of the corridor model is shown on the 
right. 
 
The Design-3D model is attached as a reference. 
Most users elect to turn off the display of the 
referenced corridor graphics. Take the 
following steps to turn off the reference to 
display only the 2D information. 
 
 From the Home tab, select Attach 

Tools > References 
 

 Turn off the display of the Design-3D 
model. 
 

The 3D model can be displayed in a separate 
view window. Take the following steps to open 
a new view to display the 3D model: 

 Hold down the right mouse button in 
the empty space in the view window. 
Choose View Control > 2 Views 
Plan/3D from the pop-up menu. 

This concludes this exercise. 

 Close OpenRoads Designer and check 
the file back into ProjectWise 
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Exercise 2 (Optional): Parametric Constraints 

This exercise demonstrates the use of a Parametric Constraint to override the pavement slope defined in 
the template to tie into the existing pavement at the beginning of the project 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 401-Engineering\Roadway\Basemaps\ folder. 
• Open the file 123456_KM001.dgn. 

To override the pavement slope using a Parametric Constraint, it is first necessary to define a Label for 
the point constraint that we wish to manipulate in the template definition. The label is defined in the point 
properties in the template. 
 
Many parametric labels are already defined in the 
ODOT template library. Take the following steps to 
review the labels assigned to the edge of pavement 
point in the S.R. 185 template: 
 
 Open the Create Template dialog 
 Double-click the S.R. 185 template to make 

it active 
 Double-click the point R-ACSC_T_EP in the 

template dialog 
 Review the point properties. The edge of 

pavement point has two constraints 
assigned as shown below. Each constraint 
has a Label defined. These labels can be 
overridden in the corridor definition by 
assigning a parametric constraint. 

 Close the template library after reviewing 
the point properties 

 
 
 
 
 
 
 
 
The next step is to analyze the existing pavement to get the existing elevation at the beginning of the 
project to compute the existing pavement cross slopes at station 386+25. To do this, we will use the 
Analyze Point command. 
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 From the Home tab, select Civil Analysis > Analyze Point. 

 
This command can be used to analyze the terrain model as well as 3D linear features. When 
prompted to Select Element to Analyze Point, choose the existing edge of pavement line on the 
west (right) side of the alignment. As you drag the cursor along the selected element, the Elevation, 
Slope, and Direction are reported as shown below. 

 
Civil Accudraw can be used to key in the station on the proposed centerline that you wish to 
analyze the selected feature. 
 

• With Civil Accudraw toggled on select the Station-Offset ordinate. 

 
• In the Civil Accudraw settings floating on the cursor, select the Tab key to highlight the 

Offset field as shown below 
 

With the keyboard focus set to the Offset field, key in the 
letter “o” to define the element that you wish to use for the 
station and offset ordinate. Select the centerline of 
proposed S.R. 185. 
 
 

 
 
Once defined, you can now key in a Station value to get the elevation on the selected linear 
feature at the station location. The results are shown below. 
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Note: The Offset value is 
irrelevant as the command will 
project a perpendicular from the 
alignment to the selected linear 
feature to report the elevation 
on the linear feature. 
 
 
 
 

 
 
Using the Analyze Point command, get the elevations for the left and right edge of pavement and 
the center of the existing pavement at station 386+25. Note, the surveyed line for the center of 
pavement is on the level SV_X_COP. Enter the elevation values in the table below. 
 

Selected Linear Feature Elevation 
Existing Left Edge of Pavement  
Proposed Center of Pavement  
Existing Right Edge of Pavement  

 
Compute the existing pavement cross slope and enter the value in the table below. 
 

Side Width Cross Slope % 
Left 12.0  
Right 12.0  

 
Take the following steps to define the Parametric Constraints to override the pavement slope at the 
beginning of the project. 
 
 Select the Create Parametric Constraint command from the ribbon or from the pop-up menu 

that is accessed by selecting one of the corridor handles.  
 

 Create parametric constraints for the L-Lane Slope and R-Lane Slope labels from station 
386+25 using the slopes computed above, to end at 1.60% at station 387+00. 
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After the parametric constraints have been defined to set the value for the labels, the proposed pavement 
slope should meet the existing pavement in the 3D model, within an acceptable tolerance. 
 
Whether it is necessary to adjust the model to this level of detail is debatable as the construction contractor 
will ensure that the proposed pavement ties into the existing pavement. However, this exercise illustrates 
the power of point controls and parametric constraints to override the initial template definition. 
 
The 3D model for the right edge of pavement, after the parametric constraint for the proposed pavement 
slope was added, is shown below. 
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Exercise 3 (Optional): Ditch Profiles 

The template definition for S.R. 185 contains end condition definitions for both cut and fill conditions. 
When the template is applied, the priority of each end condition is used to determine the order in which the 
end conditions are processed. As each option is evaluated, the first option that is successful will be used for 
the template drop location. 
 
In many cases, it will be necessary to define a new profile for a ditch or even override the template solution 
to force a ditch in areas where the solution that was used for a range of template drop locations did not 
include a ditch. This exercise will look at two different ditch modification scenarios. 
 
The length of the example project contains too many ditches for us to define all of them in this training 
course. We will look at two specific areas to introduce users to the available tools to define ditch profiles. 
 

Part 1: Redefining a Ditch Profile with an Elevation and Grade Point Control 
Point controls can be used to defile a ditch profile by a starting elevation and a grade for a range of stations. 
 
The template used for S.R. 185 will draw a ditch in cut conditions. This ditch point R-EC_DITCH is set with 
a Vertical constraint value of -1.5’ from point R-EC_GSH2 as shown below. 

 
Defining a point control for point R-EC_Ditch will also adjust the elevation for point R-EC_Ditch1 since it is 
constrained vertically to point R-EC_Ditch. 
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In this example we will define a new profile for the ditch on the right side of the corridor from stations 
390+75 to 394+00. 
 

• Open ProjectWise Explorer 

 
• Browse to the folder containing the training data. The folder location will be provided by the 

instructor for each class. 
• Browse to the 401-Engineering\Roadway\Basemaps\ folder. 
 Open the file containing the S.R. 185 corridor, 123456_KM001.dgn. 

Before defining the point control, it is necessary to evaluate the elevation of the current ditch that was 
drawn as part of the corridor modeling process. The Analyze Point command is used to analyze selected 
civil elements. 
 
 From the Home tab, select the Analyze Point command. 

 
 Select the R-Ditch line when prompted to Select Element to Analyze Point. Values along the 

selected element is reported relative to the cursor location as shown below. 
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Note: The Station value reported in the dialog is computed relative to the selected element, not the 
centerline. Civil Accudraw can be used to specify a specific station location along the centerline 
element. 
 
For this example, use the elevation at the beginning to the R-Ditch element by snapping the to ditch 
line graphic 
 

 From the Corridors tab, select Edits > Create Point Control. When prompted to Locate Corridor, 
select one of the handles for the S.R. 185 corridor model. 

 Create the vertical point control using the settings shown 
at right below. 

 When the point control is applied, the 3:1 slope from the 
graded shoulder to the ditch elevation is maintained. The 
ditch line moves out appropriately. 

 
 The results can be reviewed by opening a cross-section 

view. From the Tasks menu, select Tasks > Civil Tools > 
Corridor Modeling > Open Cross Section View. When 
prompted, select the S.R. 185 corridor and then data 
point inside view 2. The cross section for Station 391+50 
is shown below. The point control is indicated by the 
purple box drawn around point R-EC_Ditch. 

 
 Review the 3D model to inspect the changes. This is not a legitimate design solution as the ditch 

does not have an outlet, but the example illustrates one way to manipulate a ditch profile. 
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Part 2: Defining a Special Ditch Profile 
When a corridor model is created, some of the Feature Definitions that have been assigned to the points in 
the template are configured to draw 2D plan view graphics into the corridor design file. These plan view 
graphics have a profile defined that can be reviewed in a profile window.  
 
The Feature Definition MD_P_EC_DITCH is configured to draw 2D plan graphics in the corridor design file. 
The ditch profiles can be displayed relative to the centerline stationing in the profile window. All profiles 
must be defined in the same design file that contains the centerline geometry, the geometry basemap “BK” 
design file. 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class.  

• Browse to the 401-Engineering\Roadway\Basemaps\ folder. 
 To define a new profile for the ditch, open the file that contains the S.R. 185 alignment, 

123456_BK001.dgn. 
 Attach a refence for the corridor model design file, 123456_KM001.dgn 
 In the plan view window, hold down the right-mouse button until the pop-up menu appears. Select 

the View Control > 2 Views Plan/Profile option. Follow the prompts to open a profile view for the 
S.R. 185 alignment. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Select Element to Project, select the inside ditch line (R-Ditch) on the right side of S.R. 185. 
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Select Plan Element to Project Onto, select the plan view S.R. 185 alignment element 

 

Start Station:  

End Station:  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 505 – Corridor Modeling Exercises 505-13 
 

 
 Open the design file for the S.R. 185 geometry: 

..\Design\Geopak\Basemaps\12345_BK001.dgn 
 
 Attach the Design model for the S.R. 185 corridor design file with a Nest Depth value of 0. 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 
It is not necessary to attach the corridor model to design a new ditch profile. This is only necessary 
if you wish to display the ditch profile that was generated by the corridor model onto the S.R. 185 
profile. 
 
We will define a new ditch profile for the right side of the corridor from stations 405+00 to 412+00. 
Notice that the template did not place a ditch for the full station range. 

 
The profile of the ditch line as defined by the 
initial corridor model processing can be 
projected to the S.R. 185 profile by use of the 
Project Profile to Element command, or the 
Project Profile Range to Element command, 
contained in the Tasks > Civil Tools > 
Vertical Geometry group. 

 
 To define the new ditch profile, select the 

centerline of S.R. 185 and choose the Open 
Profile Model command from the pop-up 
menu. Open view 2 to display the profile. 
 

 To display the current ditch profile as defined in the corridor model, select the Project Profile to 
Element command. 

 

• When prompted to Select Element to Project, choose the inside ditch line on the right side 
of the corridor  
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• When prompted to Select Element to Project Onto, choose the horizontal alignment for SR 

185. The ditch profile is displayed in the profile view as shown below. 
 

 
 In the Profile view window, choose the Profile Complex by VPI command. 

 
 Toggle on Civil Accudraw and select the Z ordinate option. 

 
 Place a profile without any vertical curves (Curve Length = 0) using the following station and 

elevation values. 
 

405+00  987.94 
409+00   979.00 
410+00  965.25 
410+15  965.25 
411+00  972.25 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 505 – Corridor Modeling Exercises 505-15 
 

412+00  977.00 
 

 After placing the profile, select the profile and choose the Properties icon from the pop-up menu. 
Define the Feature Name of the profile as R-Ditch. The ditch profile should appear like the 
example below. 

 
 
 
 
 
 
 
 
 
 
 
 
 Open the design file for the S.R. 185 corridor model: 

..\Design\Geopak\Basemaps\12345_KM001.dgn 
 

First we will define an End Condition Override to define a ditch for the full station range from 
405+00 to 412+00. 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create End Condition 
Exception. When promoted, select the S.R. 185 corridor. 

 
 Define the end condition exception with the values shown below. 
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 The Right Override dialog is opened to display the right side template drop at station 405+00. Right-

click in the template window and choose the Delete Components option to delete the graded 
shoulder and side slope lines. The deleted lines are still displayed as shown below. 

 
 
 Open the Dynamic Settings dialog (Tools > Dynamic Settings) and toggle on the Apply Affixes 

option 
 
 
 Select the following end condition and drag it onto the edge of shoulder point: 

 
ODOT > End Conditions > 307-4E Common and Barrier Grading > 307-4E Cut 3:1 

 
 Delete the 3:1 backslope component. The end condition override should appear as shown below. 
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When the dialog is closed, the corridor is reprocessed and the ditch is drawn for template drop 
locations where the template conditions are met. 
 
For this example, there will be stations where the end condition does not solve as shown below. We 
will remedy this by assigning the new ditch profile to the corridor. 

 
 
 
 
 
 
 
 
 

 From the Tasks menu, select Tasks > Civil Tools > Corridor Modeling > Create Point Control. 
Select the S.R. 185 corridor when prompted. 

 

 Create the point control using the settings shown below. 
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When the ditch profile is applied, some of the template drops will display the new ditch line as shown in the 
example below 

 
Normally a culvert would be designed for this location. Culvert design and grading around the culvert are 
beyond the scope of this training course. The purpose of this exercise is to illustrate the process to define 
and apply a special ditch profile in the corridor model. 
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Exercise 4 (Optional): End Condition Overrides 

This exercise will demonstrate how to apply an end condition override to the side slopes for a specified 
station range. 
 

• Open ProjectWise Explorer 

 
 

• Open the Ohio DOT Training/Testing data source 
• Under Active Projects, browse to your home District. Central Office employees use District 06 
• Open the _D## folder. You should see your username in the folder. Open your username. Browse to 

the Design_Training folder.  
• Open the project with PID number 123456. 
• Browse to the 401-Engineering\Roadway\Basemaps\ folder. 
 Open the file 123456_KM001.dgn. 
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Section 506 Superelevation 
Superelevation Overview 

Superelevation commands calculate how much banking to apply to curves in the horizontal alignment to 
help offset centrifugal force. These commands also compute how the road will make the transition from 
normal crown to a fully banked curve and back again. 
 
Pavement slopes are initially defined in the template.  Superelevation is created and applied after the 
corridor is defined and the template drops have been assigned. This chapter will detail how superelevation 
is computed with OpenRoads as well as how to accurately model the shoulder break for the high side of 
Superelevation as defined in the Location & Design Manual, Volume 1 - Roadway Design, Figures 301-
8E, 301-9E, and 301-10E using the Table Wizard with ODOT’s ASCII Superelevation Tables. 
 
For this example, we will reference the shoulder break for uncurbed roadways defined in Figure 301-8E 
shown below. 

 
The behavior for the low side of superelevation is easily facilitated by applying a Rollover Lock to the 
shoulder point in the template definition. 
 
The high side of superelevation presents some challenges. For pavement slopes greater than 3%, the 
shoulder slope maintains a 7% maximum break. This can also be facilitated with the Rollover Lock 
parameter in the template point properties. If the pavement slope exceeds 6%, a 2’ break is introduced. 
Modeling this behavior cannot be modeled using the rollover lock. This chapter will document the 
procedure to model the superelevation using the ODOT template library. 
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Superelevation Design Files 

Superelevation graphics for each alignment are normally be placed in a separate “KS” design file. The 
OHDOT Create Design files application is used to create superelevation design files for the project as 
shown below. 

 

Applying Superelevation to a Corridor 

The Superelevation tools are located under the Corridors tab, as shown below. 

 
The following tools are available: 
 

• Create Superelevation Sections 
• Create Superelevation Lanes 
• Create Superelevation Lanes by 

Road Template 
• Calculate Superelevation 
• Edit Superelevation rule File 

• Import Superelevation 
• Assign to Corridor 
• Insert Station Cross-Slope 
• Superelevation Editor 
• Superelevation Report 
• Open Superelevation View 

 
Note: See the Bentley online help documentation for tools not covered in this training guide.  

https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20Help-v19/en/GUID-1B18BC16-7361-4DA1-BC57-D8A9EEF3F9E7.html
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Create Superelevation Sections 
When the Create Superelevation Section tool is accessed, the user is prompted to enter a Name for the 
superelevation section. After accepting the Name, the user is next prompted to select the alignment as 
shown below. 

 
Select the Superelevation feature 
definition from the ODOT library. 
 
 
 
 
 

 
 
After the alignment is selected, enter the Start and End Stations for the superelevation definition. Use the 
<ALT> key to lock the values to the beginning and end of the selected alignment. 
 
When prompted, enter a Minimum Tangent Length value of 0. If the tangent distance between two 
adjacent curves is less the specified value, the two curves and adjacent tangent are included in a single 
superelevation section. If the tangent distance between two adjacent curves is greater than the specified 
value, each curve and half of the adjacent tangent are included into each superelevation section. Enter a 
value larger than the total alignment length to create a single superelevation section. 

 
ODOT recommends using a value of 0 to create a separate 
superelevation section for each curve set. 
 
 

 
 

The user is next prompted to define the pavement lanes for the roadway. Each lane is entered like the 
example below. Reset (right-click) after defining all the pavement lanes. 

  
After the lanes have been defined, the user is prompted to select the superelevation rules file. Two rules 
files are provided as part of the OHDOT standards. 
 

• OHDOT_Divided.xml 
• OHDOT_Undivided.xml 

 
Select the appropriate file for the project. 
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Set the remaining parameters appropriately for the project. 
 
Note: The ODOT Superelevation Rules Files are provided as a starting point for the superelevation 
computation. It is the responsibility of the designer to review and adjust the values as necessary for the 
project. 
 
If the Open Editor parameter is toggled on, the Superelevation Editor dialog is opened like the example 
below. 
 

 
This dialog is used to review and edit the superelevation parameters. See the online help for information on 
the Superelevation Editor dialog. 
 
The superelevation rules can also be reviewed and edited by selecting one of the pavement lanes as shown 
below. Each of the text items designating the station and cross slope can be edited by selecting the text. 
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Superelevation values can also be reviewed and edited in the Properties dialog when the Superelevation 
Section graphic is selected. 
 
Superelevation values can also be edited in the Explorer dialog’s OpenRoads Model tab as shown below. 

 
 
Selecting a superelevation shape, as shown at right, allows you 
to access a menu with the following commands: 
 

• Properties 
• Insert Superelevation Station/Cross Slope 
• Create Single Control Line 
• Apply Shoulder Rollover Lock 
• Delete 

 
Note: See the Bentley online help documentation for more information on these commands. 

 

https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20Help-v19/en/GUID-1B18BC16-7361-4DA1-BC57-D8A9EEF3F9E7.html
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Assign a Superelevation to Corridor 
After the superelevation values have been computed, the next step in the process is to assign the 
superelevation sections to a corridor. Before assigning the superelevation to the corridor, it is necessary to 
attach the reference file containing the superelevation definition (KS file) to the corridor model (KM file). 
 
After the reference file containing the superelevation definition has been attached, it can now be assigned 
to the corridor. From the Corridor tab, choose the Calculate > Assign to Corridor command.  

 
When prompted, select each superelevation section that you wish to 
apply to the corridor. Reset (right-click) after selecting each 
superelevation section. 
 
When prompted, select the corridor. 
 
 
 

 
After the sections and the corridor have been identified, the Associate 

Superelevation dialog is opened. This dialog is used to associate specific points in the template to the 
superelevation lanes. 

 
In the example above, the Superelevation Lane Left-Lane1 and Right-Lane1 are shown. The objects 
default to the points that have been identified with the Superelevation Flag toggled on in the template 
definition. 
 
After reviewing and making any corrections to the assigned points for each lane, select OK to apply the 
superelevation to the corridor. 
 
The model is automatically updated with superelevation values, which override the cross slopes defined in 
the templates. 
 
Superelevation is applied to the pavement lanes. The shoulder slope is controlled by the rollover lock 
values defined in the template. 
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The example below shows a cross-section view displaying the slopes for the shoulder roll-over for the high 
side of superelevation using the OHDOT template. 
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Import Superelevation from CSV file 

Many users may prefer to create a csv file with the superelevation transition information rather than use 
one of the xml files provided by ODOT to compute the superelevation values. 

See the provided Bentley online help for a complete listing of all available parameters for CSV file import. 
The minimum required parameters will be discussed in this document. 

The file format of the comma separated values file containing the required information is as follows: 

Superelevation Lane, Station, Cross Slope, Pivot About 

Data Description 

Superelevation 
Lane Name 

Required – Links the data to an existing superelevation lane, therefore, the name in 
the CSV file must match the lane names created prior to importation. 

Station Required - Station where cross slope is defined. 

Cross Slope Required - Cross slope at the specified station formatted as a double value: (-2% = -
0.02). 

Pivot About Required - Identifies which edge to pivot about. Generally, if you are rotating about 
the center line, the right lane would pivot about the left edge (LS) while the left lane 
would pivot about the right edge (RS). 
LS = left side (edge) 
RS = right side (edge) 

 

Example input: 
 Right-Lane1, 386+25, -0.016, LS 

Right-Lane1, 408+98.26, -0.016, LS 
Right-Lane1, 409+39.26, 0.00, LS 
Right-Lane1, 409+80.26, 0.016, LS 
Right-Lane1, 411+44.26, 0.080, LS 
 

The workflow to import superelevation from a CSV file is as follows: 
1. Create the CSV file, based on file format. 
2. Create superelevation section and lanes, ensuring the lane names match those used in the CSV file. 
3. Select the Import Superelevation tool. 
4. Follow the heads-up prompts to choose the Superelevation Section and the CSV file to import. 
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Adding Addition Lanes 

Additional lanes can be added to an existing superelevation section by use of the Create Superelevation 
Lanes command. 

From the Corridor tab, select Create > Create Superelevation Lanes. 

 

When prompted, select the superelevation section to create 
additional lanes. 

 

 

 

The parameters for the superelevation lane are shown below. 

 

Define a Name for the lane definition. 

Two values are supported for the Type parameter: 

• Primary lanes - a normal cross slope is specified when the lane is defined and then the cross slope 
is calculated from the superelevation rate file or imported from a CSV file when the superelevation 
is calculated. Primary lanes extend the entire length of a section. The begin and end stations are 
defined by the section. Primary lanes are generally the through lanes that extend throughout the 
project. 

• Auxiliary lanes - the cross slope is a fixed user-specified value or is automatically set to match an 
adjacent superelevation lane. Auxiliary lanes have a user-specified begin and end station but must 
be within a single section. Auxiliary lanes are lanes that are added and dropped along the alignment 
such as turn lanes. 

When the Type is set to Auxiliary, the dialog is adjusted to reflect the parameters shown below: 
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The Application Type parameter is used to define how the cross slope will 
be defined. The parameter can be set as follows: 

None - no cross slopes are assigned. Use this option if the cross 
slopes are defined by importing a CSV file with the superelevation 
values. 

Constant - Fixed slope of specified value. If lane is transition, use 
this option, then modify one end in the editor or graphically after 
creation. 

Follow Adjacent – This option projects cross slopes from the 
adjacent lane to this lane. 

 

In the example below, an Auxiliary lane was defined for a turn lane. The cross slopes were defined by 
importing a CSV file with the values. 
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Section 507 Superelevation Exercises 
Exercise 1: S.R. 185 Superelevation 

In this exercise we will define the superelevation sections for the State Route 185 Corridor. 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 
 

• Browse to the 400-Engineering\Roadway\Basemaps\ folder.  

Create new design files for the project using the OHDOT Create Design Files application. To create these 
files, one of the existing BK files may be opened.  

• Select the OHDOT Create Design Files application to create the superelevation basemap design 
files for the project.  

o Create the file listed below 
 

Design File name Comments 
123456_KS001.dgn S.R. 185 Superelevation 

 
• Open the file 123456_KS001.dgn, checking the current file back in to ProjectWise 

 
• Attach the following reference files: 

300-Survey\Basemaps\123456_FB001.dgn 
400-Engineering\Roadway\Basemaps\123456_BK001.dgn 
400-Engineering\Roadway\Basemaps\123456_KM001.dgn 
 

 From the Corridors tab, select Create Superelevation Sections 
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 You are prompted to define the Name for the superelevation 

section. Use the same name as the horizontal alignment, 
CLP_S185. 

 
 Next you are prompted to select the alignment. Select the 

CLP_S185 alignment 
 
 Use the entire length of the chain for the start and ending 

stations by toggling on the Lock to Start and Lock to End 
options 

 

 Before accepting the creation of the superelevation dialog 
select the feature definition and Name. (Shown to the right) 

 
 
Next, the software will step you through the process to define the pavement lanes. 

 Define two lanes for the superelevation as shown below 

 

 After defining both lanes, right click to terminate the lane creation process. The Calculate 
Superelevation dialog is opened. Choose the ODOT_Undivided.xml file by navigating to the 
following location in the OHDOT standards 
 

..\OHDOTCEv02\Standards\Superelevation\ 
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Use the settings shown below. 

 
 After accepting the dialog settings, the Superelevation Editor dialog is opened.  
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Review the superelevation parameters and close the dialog when completed. The maximum 
superelevation rate should be 8.0% for this alignment. 
 

 Save settings in the superelevation design file 
 

The Assign Superelevation to Corridor command is used to associate the superelevation settings with 
the corridor model and the template points. This assignment is made in the corridor design file. 

 
 Browse to open the 12345_KM001.dgn file containing the corridor for S.R. 185. Be sure to check 

the superelevation design file back into ProjectWise. 
 

 Attach the superelevation definition design file, 12345_KS001.dgn, to the corridor design file, 
12345_KM001.dgn. 

 
 From the Corridors tab, select the Assign to Corridor command 

to associate the superelevation settings with the corridor model. 
(Shown to the right) 

 

 Choose the graphics that were drawn for the boundary of both 
superelevation sections, and then right-click (reset) to accept the 
sections  

 
 When prompted to Locate Corridor, select one of the handles for the S.R. 185 corridor boundary. 
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 The Associate Superelevation dialog is opened. The dialog should default to the correct settings, but 
it is good practice to review the settings before accepting them. 

After associating the superelevation sections with the corridor, use the Open Cross Section View 
command to review the corridor. 
 
 From the Corridors tab, select the Dynamic Sections > Open Cross Section View command.  

Advanced tip: 
If a multi-model view isn’t already open, you can use the View Control command by holding the 
right-mouse button within the design model view. Select 3 views Plan/XS/3D.  Then follow 
software prompts to view cross sections. 

 
 When prompted, select the corridor, and select a new view window to display the corridor. 

 
 Add some temporary dimension lines to the cross-section view to facilitate reviewing the pavement 

width and cross slopes 
• Hold down the right-mouse button in the cross-section view. 
• Choose the Place Horizontal Temporary Dimension command 
• Identify the starting and ending points to add temporary dimension lines for each lane of 

pavement like the example below 
• Once you’ve placed Temporary dimensions you can also remove them by holding down the 

right-mouse button and select Remove All Temporary Dimensions command. 

 
After reviewing the corridor cross sections, close the cross-section view window. Click Save settings 
to save view layout. 

 
This completes the work on S.R. 185. Exit OpenRoads Designer and check the file back into ProjectWise.  
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Optional Superelevation Exercises 

Optional Exercise 1: S.R. 185 Superelevation 
In this exercise we will define the superelevation sections for the State Route 185 Corridor. 

• Open ProjectWise Explorer 

 
 

• Open the Ohio DOT Training/Testing data source 
 

• Under 06 Training Projects, browse to your provided folder. If you don’t have a folder reach out to 
the CADD & Mapping office to have one created. 

 
• You should see your username in the folder. Open your username. Browse to the Design_Training 

folder.  
 

• Open the project with PID number 123456. 
 

• Browse to the 400-Engineering\Roadway\Basemaps\ folder.  
 

Create new design files for the project using the OHDOT Create Design Files application. To create these 
files, one of the existing BK files may be opened.  

• Select the OHDOT Create Design Files application to create the superelevation basemap design 
files for the project.  

o Create two files, as listed below 
 

Design File name Comments 
123456_KS001.dgn S.R. 185 Superelevation 
123456_KS002.dgn Jameson Road Superelevation 

 
• Open the file 123456_KS001.dgn, checking the current file back in to ProjectWise 

 
• Attach the following reference files: 

300-Survey\Basemaps\123456_FB001.dgn 
400-Engineering\Roadway\Basemaps\123456_BK000.dgn 
400-Engineering\Roadway\Basemaps\123456_KM001.dgn 

 

 From the Corridors tab, select Create Superelevation Sections 
 

 You are prompted to define the Name for the superelevation section. Use the same name as the 
horizontal alignment, CLP_S185. 
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 Next you are prompted to select the alignment. Select the CLP_S185 alignment 
 
 Use the entire length of the chain for the start and ending stations by toggling on the Lock to Start 

and Lock to End options 
 
Next, the software will step you through the process to define the pavement lanes. 
 

 Define two lanes for the superelevation as shown below 

 

 After defining both lanes, right click to terminate the lane creation process. The Calculate 
Superelevation dialog is opened. Choose the ODOT_Undivided.xml file by navigating to the 
following location in the OHDOT standards 
 

..\OHDOTCEv02\Standards\Superelevation\ 
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Use the settings shown below. 

 
 After accepting the dialog settings, the Superelevation Editor dialog is opened.  
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Review the superelevation parameters and close the dialog when completed. The maximum 
superelevation rate should be 8.0% for this alignment. 
 

 Save settings in the superelevation design file 
 

The Assign Superelevation to Corridor command is used to associate the superelevation settings with 
the corridor model and the template points. This assignment is made in the corridor design file. 

 
 Browse to open the 12345_KM001.dgn file containing the corridor for S.R. 185. Be sure to check 

the superelevation design file back in to ProjectWise. 
 

 Attach the superelevation definition design file, 12345_KS001.dgn, to the corridor design file, 
12345_KM001.dgn. 

 
 From the Corridors tab, select the Assign Superelevation to Corridor command to associate the 

superelevation settings with the corridor model. 
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 Choose the graphics that were drawn for the boundary of both superelevation sections, and then 
right-click (reset) to accept the sections  

 
 When prompted to Locate Corridor, select one of the handles for the S.R. 185 corridor boundary. 

 
 The Associate Superelevation dialog is opened. The dialog should default to the correct settings but 

it is good practice to review the settings before accepting them. 

 
After associating the superelevation sections with the corridor, use the Open Cross Section View 
command to review the corridor. 
 
 From the Corridors tab, select the Dynamic Sections > Open Cross Section View command 

 
 When prompted, select the corridor and select a new view window to display the corridor. 

 
 Add some temporary dimension lines to the cross-section view to facilitate reviewing the pavement 

width and cross slopes 
• Hold down the right-mouse button in the cross-section view. 
• Choose the Place Horizontal Temporary Dimension command 
• Identify the starting and ending points to add temporary dimension lines for each lane of 

pavement like the example below 

 
After reviewing the corridor cross sections, close the cross-section view window. 
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Optional Exercise 2: S.R. 185 and Jameson Road Turn Lane 
This exercise will demonstrate the process of adding a right-turn lane to S.R. 185 at the Jameson Road 
intersection. 

Part A – Adding the turn lane to S.R. 185 
The first step is to add the turn lane for S.R. 185. Begin by defining the pavement slopes for the turn lane in 
a CSV file. 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

 
• Browse to the 400-Engineering\Roadway\Basemaps\EngData\ folder 

 
• Use Notepad to create an ASCII file in CSV format with the following values: 

Lane Name Station Cross Slope Pivot About 
Turn-Lane 413+00 0.08 LS 
Turn-Lane 413+50 0.08 LS 
Turn-Lane 415+00 0.03 LS 
Turn-Lane 415+84 0.03 LS 

 

o Name the file SR185_Turn_Lane.csv 
o Save the file in the following folder within ProjectWise: 

 \400-Engineering\Roadway\EngData\ 

 

• Open the file 123456_KS001.dgn 
 

• From the Corridors tab Superelevation group, select Create > Create Superelevation Lanes 
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o When prompted to Locate Superelevation Section, 
select the first S.R. 185 Superelevation boundary 
element 

o Use the settings shown on the right to create the turn 
lane 
 

• From the Corridors tab Superelevation group, select 
Calculate > Import Superelevation 

o In the Import Superelevation dialog, browse to select 
the CSV file 

o When prompted to Locate Superelevation Section, 
select the first S.R. 185 Superelevation boundary 
element 
 
 
The slopes are assigned to the turn lane like the example below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Next, create a new template with the 
turn lane to the S.R. 185 corridor. This is necessary since the pavement cross slope for the new turn lane 
does not match the mainline cross slope. 

 Copy the S.R. 185 template and paste a copy in the Project Templates folder 
 

 Rename the copied template “S.R. 185 Turn Lane” 
 
 Double-click the template name to make it the active template 

 
 Delete the shoulder and side slope components from the copied template 

 
 Open the Dynamic Settings dialog and toggle on the Apply Affixes option 
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 Drag the pavement component ODOT > Components > Pavement > Buildups > Asphalt 

Concrete without Stabilization on to the right edge of pavement point. The new lane is added to 
the template like the example below. 

 
 Drag the shoulder component ODOT > Components > Shoulder > 301-8E Asphalt Concrete 

Without Subgrade Stabilization onto point R-ASCS_T_EP 
 

 Drag the end condition ODOT > End Conditions > 307-4E Common and Barrier Grading > 307-
4E 3:1 Cut, Fill Table on to the point R-ACSC_T_EP1 
 

 Delete the following components from the end condition: 
o R-GSH1 
o R-FILL4-FSLP 

 
The template should appear like the example shown on the next page. 

 
The shoulder component includes null points, INT-Right and DRIVE-Right, that seek out the 
intersection with a driveway or an intersecting road. When the shoulder component was added to 
the S.R. 185 Turn Lane template, these points are given the prefix R- and are named R-INT-Right 
and R-DRIVE-Right. These points will function as defined to remove the pavement steps in the 
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event a driveway match line is encountered, and to remove the shoulder components in the event 
an intersection match line is encountered. 
 

 Delete the points INT-Right and DRIVE-Right. 
 
Point R-DRIVE-Right is not needed for this template drop range as there are no driveways in this 
station range. 
 

 Delete the point R-DRIVE-Right 
 

 Test the behavior of points R-INT-Right by right-clicking on the point and choosing Test Point 
Controls > Test Horizontal Point Control. 

 
Note that the shoulder components are removed appropriately, but the end condition components 
are not removed. 
 

 Double-click on the component R-GSH2 to access the Component Properties dialog. 
o Assign component R-ACSC-SH as the Parent Component 
o Select Apply and Close the Component Properties dialog 

Right-Click on point R-INT-Right and choose Test Point Controls > Test Horizontal Point 
Control to test the behavior of the point. The shoulder and the end condition should both be 
removed as the point is moved to the right. 

 Save and close the template library 

The next step is to create a new template drop for the turn lane template 

 From the Corridors tab, select New Template Drop 
o When prompted to Locate Corridor, choose one of the handles for the S.R. 185 corridor 

 
The turn lane is added to the corridor like the example below. 
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The turn lane will transition from 12’ right of the centerline to 24’ right of the centerline from station 
413+00 to station 413+50. Add a point control to point R-ACSC_T_EP1 to define this transition. 

 From the Corridors tab, select Edits > Create Point Control 
o When prompted to Locate Corridor, choose one of the handles for the S.R. 185 corridor. 
o Create the point control using the values shown below. 

 

After the point control is defined, the turn lane should transition 
as shown in the example below. 

 

The next step is to assign the superelevation transition to the new pavement lane. 

 From the Corridors tab Superelevation group, select Calculate > Assign to Corridor 
o When prompted to Locate First Superelevation Section, choose the boundary element for 

the superelevation. Right-click to continue. 
o When prompted to Locate Corridor, choose one of the handles for the S.R. 185 corridor. 

The Associate Superelevation dialog is opened. This allows you to assign the superelevation to 
any of the lanes that have not already been defined. Enter the values shown below. 
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The superelevation transitions for the turn lane are assigned to the corridor. 

 

The superelevation assignment can be reviewed in a Cross-Section view like the example below. 

Take the following steps to open a cross-section view to review the superelevation values: 

 Hold down the right mouse button in empty space in the view window until the pop-up menu 
appears. 

o Select View Control > 2 Views Plan/XS 
o When prompted, select OK to create the dynamic view 
o When prompted to Locate Corridor or Alignment, choose one of the handles for the S.R. 

185 corridor. 
o When prompted to Select or Open View, issue a left-mouse click (data point) in the new 

view window that was opened. The first cross-section for the corridor is displayed in the 
view window 

o Scroll to station 415+00 (tip: use the Key-In option) 
o Hold down the right-mouse button in the cross-section view until the pop-up menu appears 
o Choose the Place Horizontal Temporary Dimension command 
o Follow the prompts to enter data points to define temporary dimension lines for the 

pavement lanes, like the example above. 

This completes the work on S.R. 185. 
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Part B – Defining the Jameson Road Corridor 
The next step is to create a corridor and define the superelevation for Jameson Road. 

 Open the file \400-Engineering\Roadway\Basemaps\123456_KS003.dgn. Be sure to check the 
current file back into ProjectWise. 
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Section 508 Intersection Modeling 
Exercise 1: St. Peter Road Corridor 

The St. Peter Road corridor model will be created in its own design file. The design files for the corridor 
models were created in a previous exercise. Take the following steps to prepare the 12345_KM002.dgn file 
for the corridor modeling process. 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
• Open the file 123456_KM002.dgn. 
• From the Home tab, choose Attach Tools > References to attach the following references with a 

Nest Depth value of 0: 
• Survey Field Book: 

o 300-Survey\Basemaps\123456_FB001.dgn 
o Set the survey terrain model as the active terrain model (Use the Element Selection 

tool to select the terrain boundary, allow the cursor to pause over the boundary 
element until the pop-up menu appears. Choose the Set As Active Terrain icon). 

• Geometry for proposed S.R. 185: 
o 400-Engineering\Roadway\Basemaps\123456_BK001.dgn 

• Geometry for Existing St. Peter Road: 
o 400-Engineering\Roadway\Basemaps\123456_BK002.dgn 

• S.R. 185 Corridor Model 
o 400-Engineering\Roadway\Basemaps\123456_KM001.dgn 

• Before closing the References dialog, turn off the display of the self-referenced 3D model, 
Design-3D 

The template for St. Peter Road was created in a previous exercise. Take the following steps to create the 
corridor model for St. Peter Road 

• Use the Element Selection tool select the alignment for St. Peter Road. Allow the cursor to rest on 
the alignment element until the pop-up menu appears. Select the Create Corridor icon. 
 

• Create the corridor using the settings shown below. 
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The corridor is created like the example below. 
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Exercise 2: St. Peter Road Intersection using a Civil Cell 

This exercise will demonstrate the use of a civil cell for the intersection of St. Peter Road with S.R. 185. 

Part 1: Placing the Civil Cell 
With the references attached and the existing terrain active, take the following steps to place a civil cell for 
the St. Peter Road intersection: 

 From the Model Detailing tab, select the Place Civil Cell command 

 
 Choose the Browse button to select the civil cell. 

 
 
 
 

 
 
The Pick Civil Cell dialog is opened 
 

 
• Choose the T-Intersection civil cell shown above and select OK. 
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The civil cell requires two elements for placement: The centerline of the intersecting road 
and the edge of pavement of the through road. 
 

• When prompted, select the element that represents the centerline of the intersecting road 
(St. Peter Road) and the through Edge of Pavement for S.R. 185. 

  

After selecting the two reference elements, the solution is displayed. Depending on the direction of the 
elements and how the civil cell was created, the solution may or may not appear correctly. 

In the example below, the direction of the elements differs from the way the civil cell was created. This can 
be remedied by clicking on each of the reference elements to view different placement alternatives. 

 

Left clicking on the center line of St. Peter Road will reverse the direction of the element for the civil cell 
placement as shown below.  
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The edge of pavement element can also be reversed by left-clicking the edge of pavement line. 

 
 When the solution appears correct, issue a reset (right-click) to skip the process of viewing 

alternatives. 
 

 Issue a data-point (left click) to accept the civil cell placement. 2D and 3D graphics are placed to 
represent the surface of the intersection. 
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The length of the civil cell overlaps the St. Peter Road corridor. This can be corrected either by editing the 
civil cell length, or by adjusting the ending location of the corridor. 

 To adjust the corridor, select the template range graphic, and then select the arrow handle to move 
the ending location of the corridor. The location can be specified by snapping to the end of the civil 
cell as shown below. 

 
 To adjust the civil cell, select the civil cell element that overlays the St. Peter Road alignment. The 

length of the civil cell is a rule that can be edited (the value is 100.000’ in the example below), or the 
length can be dynamically modified by choosing the left arrow at the end of the civil cell and 
dragging the length to the desired location. 
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The civil cell can be edited to further meet specific project requirements. Take the following steps to edit 
the lane widths for the civil cell: 

 Use the Element Selection command to select the edge of pavement on the north side of St. Peter 
Road 

• The underlying rules for the element are displayed but are grey cannot be edited until the 
underlying element is selected. 

• Right-click the element until the rules are editable 
• Select the center lane width ruled dimension. Change the value to -10 
• The edge of pavement is adjusted to the new value 
• Repeat this process to change the lane width for the opposite side to a value of 10 

 
 The same type of editing can be applied to the radius returns. 

• Edit one of the radii returns to use a radius value of 40’ 
o Observe the behavior of the civil cell elements. The interval displayed for the edge of 

pavement is automatically adjusted according to the new radius value and the 
surface terrain model for the civil cell is also adjusted in response to the radius 
change 

• Change the edited radius value back to 50’ 
 

 Additionally, the radius returns have start and ending offset values for the tie-in with the edge of 
pavement lines. This is useful for meeting differing pavement widths on each side of the 
intersection. 

• Select the radius return element on the south of St. Peter Road. The Properties dialog can be 
used to edit various parameters. From the Fillet Rule group, change the Ahead Offset value 
to -12. The fillet is adjusted as shown below. 
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 Change the Ahead Offset parameter back to 0 
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Part 2: Defining the Pavement Buildup 
The pavement surface for the intersection is placed as a terrain model. The feature definition assigned to 
the terrain model is P_Pavement_Surface which is configured to display contour lines for the pavement 
surface at 0.1’ intervals. 

To complete the St. Peter Road pavement, a template will be applied to the surface terrain. Take the 
following steps to apply a template with the pavement buildup for St. Peter Road: 

 From the Corridors tab, select Template > Create Template 
• Copy the St. Peter Road Template. 
• Paste the copy into the Project Templates folder. 
• Rename the copied template to St. Peter Road Pavement. 
• Double-click the St. Peter Road Pavement template to make it active. 
• Right-click in the Current Template window and choose the Delete Components 

command. Delete the shoulders and the side slopes on both sides of the template. 
• Delete the pavement layers for the left lane, leaving the pavement layers for the right lane in 

place. 
• Delete the Null points above the pavement layers (right-click on each point and choose the 

Delete Point command). 
• Close and save the template library. 

 

The completed St. Peter Road Pavement template contains 
only the pavement as shown below. The pavement slope 
and width of the components is irrelevant as the terrain 
model for the intersection will define the slope and width. 

 
 
 
 
Take the following steps to assign the pavement template to the intersection terrain model. 

 From the Model Detailing tab, select Apply Surface Template 
 

• When prompted to Locate a Terrain Model, 
select the surface terrain model for the 
intersection. 

• Select No for the Apply Clipping Boundary 
option. 

• Choose the St. Peter Road Pavement 
template.  

• Left click (data point) to accept the selection. 
• Data point to accept the selection. The 

pavement template is applied to the terrain 
model as shown below. 
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Part 3: St. Peter Road Shoulder Templates 
A new template is necessary to define the pavement, shoulders, and side slopes for the St. Peter Road 
intersection area. 

Take the following steps to create the radius return template: 

 From the Corridors tab, select Template > Create Template 
• Copy the St. Peter Road template 
• Paste the copy into the Project Templates folder 
• Rename the copied template to St. Peter Road Shoulder 
• Double-click the St. Peter Road Shoulder template to make it active 
• Right-click in the Current Template window and choose the Delete Components 

command. Delete the pavement, the left shoulder, and end conditions on the left side. Leave 
the right shoulder and the right end conditions in place. 

• Delete the null points above the pavement layers (right-click on each point and choose the 
Delete Point command) 

At this point, the template should appear like the example below. 

 
The shoulder components are currently located 10’ right of the origin. The next step is to move the 
shoulder to the 0,0 origin in the template dialog. 

 Open the Dynamic Settings dialog to ensure the Step values are defined 
 

 Right-click on point R-ACSC_T_EP and choose the Move Point command. Move the point to the 
(0,0) position 
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Notice the point at the shoulder break is partially constrained (the point location is shown with a 
yellow plus sign indicating that only one constraint is defined). When the pavement lane was deleted, 
the rule for the slope was removed since it referred to point PGL as part of the rollover lock definition. 
Take the following steps to define a Slope constraint for point R-ACSC_T_SB: 
 
 Double-click point R-ACSC_T_SB to access the Point Properties dialog. Add a Slope constraint to the 

point with a -4.00% slope from point R-ACSC_T_EP as shown below.

 

The completed template for the radius returns should appear as shown below 

 
 Save and close the Template library. 
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Take the following steps to apply the St. Peter Road Shoulder template to the edge of pavement tangent 
lines and the radius return elements: 
 
 Select the right radius return graphic and choose the Apply Linear Template command from the 

pop-up menu. Alternately, the Apply Linear Template command can be selected from the Model 
Detailing tab. 

 
 Choose the St. Peter Road Shoulder template from the library 

• The template can be applied for a portion of the selected graphic, or the entire element. 
Define the Start Station and End Station to encompass the entire length of the element by 
using the <ALT> key  

• When applying a linear template, the template can be placed on either the left or right side 
of the selected element. When prompted to Select Side – Reflect Option, issue a data point 
on the side of the element that you wish to apply the template 

• Use the default Exterior Corner Sweep Angle value of 5 degrees 
 

The template is applied to the radius return. Repeat the process for the remaining edge of 
pavement lines and radius return. 

 
When complete, the intersection should appear like the example below. 
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Part 4: Adjusting the S.R. 185 Corridor in the Intersection 
The last step is to remove the left shoulder and end conditions on the S.R. 185 corridor through the 
intersection area. 
 
The template for S.R. 185 is defined with Null Points to seek an intersection with an element in the design 
that defines the limits of the intersection. If the intersection graphic element is found, a display rule is used 
to turn off the side slopes. 
 
Take the following steps to draw a line in the design that will be used as the intersection element the null 
point will seek: 
 
 Open the design file containing the corridor model for S.R. 185 

400-Engineering\Roadway\123456_KM001.dgn 
 

 Attach the St. Peter Road corridor as a reference 
• From the Home tab, select Attach Tools > References to attach the following file: 

400-Engineering\Roadway\123456_KM002.dgn 
 
 From the Geometry tab, choose Standards > Feature Definition Toggle Bar 

• Set the Feature Definition to Linear\Modeling > Template Points > Misc > 
MD_P_INTERSECTION_MATCHLINE 

• Turn on the Use Active Feature Definition option  
• Turn off the Persist Snaps and Rule option as shown below 

 
  
 From the Geometry tab, Horizontal group, select Offsets and Tapers > Single Offset Partial 

• When prompted to Locate Element, choose the S.R. 185 alignment 
• Name the element St. Peter Match Line 
• Create an offset line 50’ to the left of S.R. 185 by snapping to the radius returns of St. Peter 

Road 
 

The completed line should be like the example shown below. 
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The match line element must be added as a corridor reference to the S.R. 185 corridor for the template to 
find the graphic. Take the following steps to add the match line element as a corridor reference: 
 
 From the Corridors tab, select Corridor References > Add Corridor Reference 

• When prompted to Locate Corridor, choose the S.R. 185 corridor 
• When prompted to Locate First Reference, choose the match line element 
• Reset (right-click) 

 
The element is added as a corridor reference and the corridor is reprocessed. The corridor model 
should appear like the example below. 
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Depending on the template drop interval and the location of the radius returns, there may be a gap 
in the model as shown above. This can be remedied by inserting a key station on the S.R. 185 
corridor to ensure that the model is processed up to the station where the radius return starts. 

Take the following steps to insert a key station on the S.R. 185 corridor: 

 From the Corridors tab, select Edits > Create Key Station 
• Make sure the Persist Snaps and Rule option is toggled off in the Feature Definition toggle 

bar when adding key station locations to a corridor 
• When prompted to Locate Corridor, choose the S.R. 185 corridor 
• Identify the station by snapping to the radius return at the point where it meets the S.R. 185 

edge of pavement but do not accept this location 
• This function works best if you use a station value that is slightly outside of the range of the 

radius return. For example, if the station value is 399+89.30 at the snap point of the first 
radius return, key in a value of 399+89.29 that is just before the start of the radius return. 
For the second radius return, key in a station value that is just beyond the ending station 
value. 
 
Note: You can adjust the key-point location after it has been placed by selecting the line that 
is drawn at the key point location and then edit the station rule. 

The key station graphic is drawn on the level CM_Corridor_Key_Station 

There may be a small gap at the south end of the intersection as well. Insert another key station 
to close this gap. 

 

This completes this exercise. 

 Exit OpenRoads Designer and check the file back in to ProjectWise. 
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Optional Exercise 3: Intersection Modeling Step-by-Step 
This section will step through the process to model the intersection of S.R. 185 and St. Peter Road using the 
OpenRoads tools without the use of a civil cell. This exercise is used in place of Exercise 2 Part 1 above. 

Process Overview 
The process to model the intersection will take several steps as summarized below: 
 

• Define the Horizontal and Vertical geometry for each road 
• Create Templates for each road 
• Model the mainline corridor 
• Model the side road corridor 
• Add radius returns to the side road and define the vertical profile for each of the radius returns 
• Modify the mainline corridor to remove any side slopes through the limits of the intersection 
• Adjust the side road corridor to end at the radius return 
• Create a surface terrain for the pavement surface of the side road in the intersection area. The 

surface terrain is defined by the radius returns, the edge of pavement for the mainline corridor, and 
the centerline and profile of the side road corridor. 

• Apply a “surface template” to the surface terrain of the intersection. This will establish the 
pavement buildup components beneath the pavement surface terrain. 

 
Apply linear templates to the radius returns to model the shoulders and side slopes for the intersecting side 
road. 

Modeling the Intersection Pavement 
The corridor for St. Peter Road was created up to station 19+25 in this example. Ending at this station will 
allow room for modeling the intersection with S.R. 185. The intersection will be modeled by first defining a 
terrain model representing the pavement surface for the intersection. Start by placing the edge of 
pavement lines and radius returns for the intersection. 
 
The edge of pavement lines and the radius returns must be created using Civil Geometry tools. Take the 
following steps to create the edge of pavement lines: 

 
 From the Geometry tab, open the Features Definition Toggle Bar by choosing Standards > Feature 

Definition Toolbar. Set the active feature definition to Linear > Pavement > 
PV_P_Edge_of_Pavement.  
 

 In the Features Definition Toggle Bar, toggle on the Use Active Feature Definition option 
 
 From the Geometry tab, choose Offsets and Tapers > Single Offset Partial. This command is used 

to place a civil geometry element at an offset from the selected alignment. 
 

• When prompted to Locate Element, choose the St. Peter Road alignment. 
• Enter a Name for the element a shown below, R-EOP St Peter Road. 
• Using an Offset of 10’, define the starting point of the offset element by snapping to the edge 

of pavement line at the end of the corridor as shown below. 
• Enter the End Distance by entering the <ALT> key to lock to the end of the alignment. 
• When prompted to Mirror the solution, choose Yes. 
• The mirrored line is named R-EOP St Peter Road1. Change the name to L-EOP St Peter 

Road by selecting the line element and choosing the Properties command from the pop-up 
menu. 
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Next, assign a profile to the newly created edge of pavement elements. 

 
 From the Geometry tab, choose Element Profiles > Profile By Slope From Element 

 
• When prompted to Locate First Element to Profile, choose one of the edges of pavement 

elements. Continue by choosing the other element when prompted to Locate Next Element 
to Profile. After choosing both elements, right click (reset) to end the selection process. 

• Choose the centerline of St. Peter Road when prompted to Locate Reference Element. 
• Enter a Slope value of -1.6% 
• Choose the Point Selection mode All 
• Use a Profile Adjustment of None 
• Enter a Vertical Offset of 0 

 
Next, create the radius returns for the intersection. 
 
 From the Geometry tab, select Arcs > Arc Between Elements > Simple Arc. 

 
Create the first arc on the right side of St. Peter Road using a 50’ radius. 

• Be sure to enter a Name of R-Radius St Peter Road for the radius return element. 
• Choose the R-EOP St Peter Road line as the first element. 
• When prompted to Trim/Extend, choose the Back option. 
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 Create the second arc on the left side of St. Peter Road with a Radius of 50’, a Name of L-Radius St 

Peter Road, and use the Trim/Extend Back option. 
 
Next, assign a profile to the radius return elements using the Quick Profile Transition command. 
 
 From the Geometry tab, select Element Profiles > Quick Profile Transition 

o After selecting the command, you are prompted to choose the Quick Transition Method. 
Select the Parabolic option. 

o When prompted to Locate What to Define, select one of the radii return elements. A quick 
profile is created for the element. 

o Repeat the procedure for the second radius return 
 

After the profiles are assigned, the edge of pavement and radius return lines should appear in the 3D 
model like the example shown below. 

 
The profile for each radius return can be reviewed and edited by selecting one of the radii returns and 
selecting the Open Profile Model command. The profile for R-Radius St Peter Road is shown below. 
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In addition to the two radius returns, it is necessary to define a line that follows the edge of pavement for 
S.R. 185 that extends from the ends of the radius returns. This is necessary to define the boundary of the 
intersection area that will be used to make the surface terrain model. We cannot use the edge of pavement 
line from the CLP_S185 corridor model as the line must be constrained to the limits of the radius returns. 
 
Since this new edge of pavement line will overlap the edge of pavement lines already drawn for the 
CLP_S185 corridor we will use a different feature definition. 
 
 In the Features Definition Toggle Bar, set the active feature definition to Modeling > Template 

Points > Misc > MD_P_DNC. The initials “DNC” stand for Do Not Construct. This feature definition 
can be used for linear elements used in the modeling process whose graphics will not be used for 
part of the plan production process. Graphics drawn with this feature are placed as construction 
elements on the level MD_P_DNC. 
 

 From the Geometry tab, choose Offsets and Tapers > Single Offset Partial. 
• Create an offset line 12’ to the left of the CLP_S185 alignment from the ends of the radius 

returns. 
• Because this new line is drawn on top of the edge of pavement line for S.R. 185, it is easier to 

temporarily turn off the reference file display of the S.R. 185 corridor model to ensure the 
line was drawn correctly. Open the References dialog and turn off the display of the 
12345_KM001.dgn file. 
 

The completed graphic should appear like the example below. 
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Next, assign a profile to this new DNC line. 

 From Geometry tab, choose Element Profiles > Profile By Slope From Element. 
• When prompted to Locate First Element to Profile, choose the DNC line 
• Reset (right-click) to complete the location process 
• When prompted to Locate Reference Element, choose the S.R. 185 alignment 
• Define the profile with a -1.6% slope from the centerline of S.R. 185 

 
The edge of pavement and radius return lines will be used to define the boundary of a terrain model for the 
surface of the pavement in the intersection. 

 
 From the Terrain tab, choose the From Elements command. 

 
• Set the Feature Type to Boundary 
• Set the Edge Method to None 
• Set the Feature Definition to Terrain > Proposed > 

P_Pavement Surface. Since this is a terrain feature it 
cannot be selected from the Feature Definition tool 
bar. 

• Set the feature Name to St Peter Road 
• When prompted to Locate Elements to Add, choose 

the edge of pavement and radius returns for St. Peter 
Road as well as the DNC for S.R. 185 (five elements total – don’t forget the edge of pavement 
lines for St. Peter Road between the radius returns and the corridor). 

• Reset when the elements are selected. 
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The surface is created, and contour lines are 
drawn as shown on the right. 

 
One more graphic is necessary to complete the 
pavement surface definition. The center line and 
profile of St. Peter Road will be added to define the 
crown of the pavement surface. This will be 
accomplished by creating one more partial offset 
element. 
 
 In the Features Definition Toggle Bar, set the 

active feature definition to Modeling > 
Template Points > Misc > MD_P_DNC. 
 

 From the Geometry tab, choose Offsets and 
Tapers > Single Offset Partial command. 
 

 Choose the centerline of St. Peter Road when prompted to Locate Element. 
 

• Start the line at the end of the St. Peter Road corridor, Station 19+25 with an Offset value of 0. 
• Use the MicroStation Intersection Snap to end the line at the intersection of St. Peter Road 

with the S.R. 185 Edge of Pavement. 

  

After placing the line, assign a profile to the line using the Profile By Slope From Element command. 
 
 From the Geometry tab, select Element Profile > Profile Slope from Element 
 The Reference Element is the centerline of St. Peter Road. 
 Since the new element overlaps the centerline of St. Peter Road, use a Slope value of 0.0%. 

 
The 3d line is created as shown below. 
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Add this new partial offset line to the surface terrain model as a break line. 

 From the Terrain tab, select Feature Management > Add Features. 
• When prompted to Locate Terrain Model to Add Elements, select the St. Peter Road 

pavement surface terrain model. 
• When prompted to Locate Element to Add, select the DNC line at the center of St. Peter 

Road. 
• Reset (right-click) 
• Set the Feature Type to Break Line 

 
After the break line element is added, the St Peter Road terrain model should appear like the example 
below. 

 
The process to define the pavement buildup, add the shoulder and side slopes, and trim the S.R. 185 
corridor model through the limits of the intersection are detailed in Parts 2, 3, & 4 of Exercise 2. 

This completes this exercise. 

 Exit OpenRoads Designer and check the file back in to ProjectWise. 
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Section 509 3D Guardrail 
Process Overview 

ODOT’s CADD Standards for OpenRoads Designer includes feature definitions, element templates, and cross 
section templates for the placement of 3D guardrail lines. The 3D guardrail graphics are intended for 
visualization purposes and should not be evaluated critically for strict compliance with design standards.  

Note, the guardrail placement examples shown in this document are intended to demonstrate the process 
and do not necessarily represent proper guardrail design. 

 

 
 
Placement of 3D guardrail runs requires the following software components: 

• 3D linestrings are used to draw the posts. 
o The line strings for legacy guardrail types are in the file OHDOT_3DGuardrail.rsc. 
o New linestyles for the Midwest Guardrail Systems guardrail specifications are included in 

the file OHDOT_MGS_Guardrail_3D.rsc 
• The rail, and the cables for a cable barrier, are drawn using OpenRoads templates. 

 
The 3D guardrail is placed by first drawing the guardrail run in a 2D plan view using an OpenRoads feature. 
After a profile is defined for the 2D guardrail run, a 3D guardrail linestyle is added to the 3D model. The 3D 
linestring is made up of the guardrail posts and does not contain the rail faces. 

The following feature definitions in ODOT_Features_Design.dgnlib are used to draw 3D MGS guardrail 
runs: 

• Linear > Guardrail & Barriers > MGS-2.1 > RD_P_Guardrail MGS-2.1 Steel Post Barrier Design 
• Linear > Guardrail & Barriers > MGS-2.1 > RD_P_Guardrail MGS-2.1 Steel Post Left 
• Linear > Guardrail & Barriers > MGS-2.1 > RD_P_Guardrail MGS-2.1 Steel Post Right 
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• Linear > Guardrail & Barriers > MGS-2.1 > RD_P_Guardrail MGS-2.1 Wood Post Barrier Design 
• Linear > Guardrail & Barriers > MGS-2.1 > RD_P_Guardrail MGS-2.1 Wood Post Left 
• Linear > Guardrail & Barriers > MGS-2.1 > RD_P_Guardrail MGS-2.1 Wood Post Right 

 
The rail itself, or the cables for cable barrier runs, are placed using a corridor template and the Apply 
Linear Template command. 
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Required Templates 

OHDOT_Templates.itl contains the templates shown below to draw the actual rail in the 3D model. The 
corridor templates must be present in the template library you are using for the project. These templates 
can be copied from OHDOT_Templates.itl by use of the Template Library Organizer function, if 
necessary. 
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Placing 3D Guardrail Elements 

Take the following steps to place the 2D guardrail lines: 

• Use the OpenRoads Feature Definition Toggle Bar to select the desired feature. 
• Toggle on the Use Active Feature Definition and Create 3D Automatically icon as shown below. 

 
• Use the OpenRoads Geometry > Single Offset Partial tool to place the 2D guardrail element. 

In the example below, the guardrail line is placed adjacent to the edge of shoulder. When prompted 
to select an element, the edge of shoulder line was selected. The Offset value is set to 0. 

 

Since the edge of shoulder element does not have stationing assigned, the centerline will be used as 
the reference element to define the station value. Civil AccuDraw is used to facilitate this task. 

Take the following steps to use Civil AccuDraw to define the guardrail station limits: 
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o Toggle on Civil AccuDraw 
o Tab to the Offset field - there are two offset fields shown in the screen capture on the 

previous page: one for the Single Offset Partial command and one for Civil Accudraw. Be 
sure to toggle to the offset field for Civil Accudraw, which is the one below the Station value. 

o With keyboard focus set to the Offset field, type in the letter “o” 
o Civil AccuDraw prompts you to select the reference element or issue a reset to return to the 

active command. Select the centerline as the reference element. 

After selecting the centerline element, the Station value should reflect the cursor location relative 
to the selected element. In the example on the preceding page, a Station value of 11+50 was keyed-
in. The second Offset value, which is part of the Civil AccuDraw function, is irrelevant as the Offset 
value for the Single Offset Partial command is the value used to define the offset value, relative to 
the shoulder line, for the new element. 

After accepting the starting location, the ending Station value or a Length can be keyed in. We 
recommend using the Length function rather than an ending Station value. This is due to the post 
spacing of the 3D guardrail line. Use the following guidelines: 

o Guardrail runs should be drawn in 6.25’ increments for the visualization of the posts to 
appear correct at the end of the run. 

o Cable Barrier runs should be drawn in 10.5’ increments for the visualization of the posts to 
appear correct at the end of the run. 

After the guardrail is placed, graphics for both the 2D and 3D view are drawn like the example below.  

 

 
 
 
The rail is placed using the Model Detailing > Apply Linear Template command to assign the template to 
the guardrail run in the 2D view. 
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When complete, the guardrail run should appear like the example shown below. 
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Placing a Cable Barrier Element 

Placing a cable barrier run is like the process of placing a guardrail run. The cable barrier is typically placed 
offset from the edge of shoulder or from the ditch line. See the Location and Design Manual for cable 
barrier placement information. The Single Offset Partial command is used to place the cable barrier; 
however, the user will have to adjust the profile since the element is offset from the shoulder, or from a 
ditch line. 

The following steps detail the process to place the cable barrier at an offset from the edge of shoulder. 

• From the Feature Definition Toggle Bar, select the desired feature definition and toggle on the Use 
Active Feature Definition, Create 3D Automatically, and Use Feature Definition Template 
icons as shown below 

 
• Use the Horizontal Geometry > Single Offset Partial command to place the barrier, like the 

methodology described for placing guardrail on the preceding pages. 
 

• After placing the cable barrier line, use the Apply Linear Template command to add the cables to 
the design file. 

 
The cable barrier run is placed in the file like the example shown below. 
 

 
 
In the example above, the cable barrier was placed at an offset of 1.0’ from the edge of shoulder. 
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NOTE: There are different cable barrier types and attachment methods. The barrier type shown here is 
intended for visualization purposes and not intended to relay to the construction contractor that they must 
use a specific cable barrier type. 

The Single Offset Partial command uses the same profile for the cable barrier as the selected element that 
it was offset from. The profile for the cable barrier can be adjusted using the Profile By Slope From 
Element command. 

• Select the Vertical Geometry > Profile By Slope From Element command 
• When prompted to Locate First Element To Profile, select the cable barrier line in the 2D view 
• After selecting the cable barrier line, issue a reset button to move to the next step. 
• When prompted to Locate Reference Element, select the element that was initially used to place 

the cable barrier (the edge of shoulder in this example) 
• Enter the Slope for the graded shoulder, or the side slope, depending on location of the cable 

barrier line and the element that was used as the initial offset. In this example, a slope of -8.0% is 
used since the cable barrier line is on the graded shoulder which was defined as a -8.0% slope in 
the roadway template. 

 
After defining the rest of the parameters, a new profile is created for the cable barrier line, but it is not set 
as the active profile. Take the following steps to set the new profile as the active profile: 

• Select the 2D element representing the cable barrier line. From the pop-up menu, select the Open 
Profile Model command. 

 
• When prompted, open a new view window, and issue a data point in the view to display the profiles 

for the cable barrier element. An example is shown below. 
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• Notice that there are two proposed profile lines. The lower line is the new profile, which was 

defined at a -8.0% slope from the shoulder. 
 

• Select the lower profile line and choose the Set As Active Profile command. 

 
When the command is selected, the cable barrier is automatically adjusted to use the new profile. 
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Cross Sections 

The display of the guardrail in the cross sections is automated by the feature definitions. A cell is placed in 
the cross section for each guardrail or cable barrier type. The following cells, some of which were added in 
the January 2017 CADD Standards release, are used for the display of the guardrail in the cross sections: 

• GR_CABLE_LT_XS 
• GR_CABLE_RT_XS 
• GRBAR_MGS_STEEL_XS 
• GRBAR_MGS_WOOD_XS 
• GRBAR_STEEL_XS 
• GRBAR_WOOD_XS 
• GRLT_MGS_STEEL_XS 
• GRLT_MGS_WOOD_XS 
• GRLT_X_XS 
• GRRT_MGS_STEEL_XS 
• GRRT_MGS_WOOD_XS 
• GRRT_X_XS 

 
An example of the cells displayed in the cross section is shown below. 
 

 
 
The cells should be automatically displayed. If the cells do not display, check the cell library 
OHDOT_Symbols.cel to ensure that you have the latest version of the cell library containing the cells listed 
above. 
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Section 510 Modeling Existing Features 
Overview 

Existing features such as the existing pavement, sidewalk, and driveways, can be modeled by creating a 
surface terrain model from the survey elements and then applying a surface template to the terrain. 

This document will demonstrate the process to generate a terrain model for the surface of the existing 
pavement for Jameson Road. This surface terrain model will be created using the surveyed edge of 
pavement, center of pavement, and break line elements. After the surface terrain has been defined, a 
template with the existing pavement buildup will be applied to the surface terrain to create the 3D mesh 
elements representing the existing pavement buildup. Once defined as a 3D mesh element, the existing 
pavement can be displayed on the cross sections and used in quantity calculations. An example of the 
existing pavement as shown in a dynamic cross-section view is shown below.  

 

Note: See Page 15 for alternative method using the Create Closed Mesh tool. This method doesn’t support 
the Element Component Quantities.   
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Exercise 1: Modeling the Existing Pavement using a Surface Terrain Model 

This section will demonstrate the process to create 3D mesh elements for the existing pavement. A portion 
of Jameson Road will be removed so we will create two separate surface terrains, one for the portion that 
will remain in place, and a second for the portion to be removed. 

Part 1: Creating the Existing Features Design File 
A new design file will be for the 3D mesh elements representing the existing features. 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
 Open one of the design files for the WorkSet. The file opened does not matter since it is being used 

to access the file creation application. 

Create a new design file to use for modeling the existing features. Select the OHDOT Create Design Files 
application (OHDOT WorkFlow) to create the corridor modeling basemaps for the project. 

 
• Use the Roadway Digital Terrain Model file type, “KD”, to model the existing features 
• Choose the Create Files button to initiate the process. 

Part 2: References 
The surveyed edge of pavement and center of pavement elements will be used to generate the 3D mesh 
elements representing the existing pavement. 

 Attach the following files as references (Home > Attach Tools > References): 

Geometry Basemap for Jameson Road: 
400-Engineering\Roadway\Basemaps\123456_BK003.dgn 
 
Survey Basemap: 
300-Survey\Basemaps\12345_FB001.dgn 
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Use the Level Display function (OpenRoads Modeling > Home > Level Display) to turn off all the levels in 
the attached survey design file (123456_FB001.dgn), except for the levels shown below 
 
 From the Home tab, select the Level Display icon. 

• Select the file 123456_FB001.dgn in the top 
portion of the dialog. 

• Turn off all the levels by right-clicking in the 
lower portion of the dialog and choose the All 
Off from the pop-up menu. 

• After turning off all the levels, turn on the 
following levels by clicking on each level 
name as shown on the right. 

o PV_X_COP 
o PV_X_EOP 
o SV_X_Break_Lines 
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Part 3: Creating the Surface Terrain Model for the Existing Pavement 
The surface terrain can be created for the existing pavement by directly using the referenced survey 
elements, or by copying the elements from the FB reference attachment into the active file. 

In this example, we will create a surface terrain model limited to the station limits of the pavement removal 
areas, from station 12+00 to meet existing S.R. 185. A copy of the existing survey elements is required since 
the elements will be edited to specific station ranges. 

Take the following steps to create the surface terrain for Jameson Road. 

 Use the MicroStation Copy Element command (Drawing > Copy) to copy the existing edge of 
pavement, center of pavement, and break line elements from the Survey Field Book design file (FB) 
to the active design file. The elements to be copied are shown below. 
 
Be careful to copy the elements exactly on top of the original survey elements. 

 
 

 After copying the elements, turn off the reference attachment display of the survey basemap design 
file, 123456_FB001.dgn (Home > Attach Tools > References). 
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Take the following steps to prepare the copied elements to generate the surface terrain model for the 
existing pavement: 

 Use the Break Element command (OpenRoads Modeling > Drawing > Break Element) to break 
each edge of pavement line and the center of pavement line at station 12+00 of Jameson Road. 
 
The result is shown below with the elements from station 12+00 forward selected to show that the 
lines are broken at station 12+00. 

 

The edge of pavement elements will be used to define the boundary of the existing pavement surface 
terrain model. The surveyed center of pavement elements will be used as a break line to define the 
pavement crown. In this case, these elements are 3D graphics as generated from the Survey software and 
can be used to generate the surface terrain model directly. 2D elements can also be used if they have an 
OpenRoads profile defined. 

Take the following steps to create the surface terrain for the pavement portion that will remain in place: 

 From the References dialog (Home > Attach Tools > References), turn off the display of the file 
containing the proposed alignment for Jameson Road (123456_BK001.dgn) 
 

 From the Terrain tab, select the From Elements command to create a terrain model from selected 
elements. 

 
• Set the Feature Type to Boundary 
• Set the Edge Method to Remove Slivers 
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• Choose the X_Triangles2 feature definition. 
• Key-in the Name for the terrain model X_PAVT_Jameson. 
• Select each edge of pavement element as shown below. 

 

• Right-click (reset) when you are done selecting the elements. 
• When prompted, left click to accept each parameter. 
• After accepting each parameter, the terrain model is generated like the example below. 

Take the following steps to add the center of pavement element to the terrain model as a break line. 
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From the Terrain tab, select Feature Management > Add Features 

• Select the Terrain Model name from the drop-down list. 
• Set the Feature Type parameter to Break Line. 
• Select the center of pavement element as shown below. 

 

Follow the prompts to accept the element. When complete, the center of pavement element is 
added to the terrain model as a break line. 

Following the steps above, create a second surface terrain for the portion of Jameson Road to be removed. 

 Create a terrain named X_PAVT_Removed_Jameson from the edge of pavement and the break line 
at the intersection with S.R. 185. 

 
 Add the crown of pavement element as a break line to the newly created terrain. 
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When complete, two separate terrains are created for the surface of existing Jameson Road like the 
example below. 
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Part 4: Create the Surface Templates 
OpenRoads templates can be applied to a terrain model to define the subsurface composition of the surface 
terrain. We will create two templates, one for the portion of Jameson Road that will remain in place, and a 
second for the portion to be removed. 

Existing Pavement Feature Definitions 
The OHDOT Standards contain several Mesh features for existing pavement as shown below. 

 

Features for Asphalt and Concrete 
Removed features differ in the Volume 
Option parameter setting. 

The features MD_X_Asphalt_Pavement 
and MD_X_Concrete Pavement have the 
Volume Option set to a value of None. 

The features 
MD_X_Asphalt_Pavement_Removed and 
MD_X_Concrete_Pavement_Removed 
have the Volume Option set to a value 
of Unsuitable. 

These settings are used to determine 
how the components are included in 
earthwork computations. 

 

 

Creating an Existing Pavement Template 
Take the following steps to create a template to the Jameson Road surface terrain: 

 From the Corridors tab, select Template > Create Template 
 Right-click on the Project Templates folder and select New > Template 
 Rename the new template “Jameson_X_Pavt” 

Add components to define the pavement building of the exiting road. 

 Choose Tools > Dynamic Settings to open the dialog shown below. 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 510 – Modeling Existing Features 510-10 
 

 

Use the settings shown on the right. The Feature 
Definition is set as follows: 

Linear\Modeling\Template 
Points\Scratch\Scratch1 

 

 

 

 

 In the Current Template window, right-click and choose Add New Component > Simple. 
 A simple component consists of four points defining a rectangular shape. Set the parameters as 

shown below. 

 
Note: The slope and width parameters are irrelevant as this is defined by the terrain surface. 
 

 Place the component at the 0,0 location as shown below. 

 
 Right-Click in the Current Template window and choose Add New Component > Simple to add a 

component for a concrete pavement layer. Use the settings shown below. 
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 Place the component at the bottom of the previous component. The completed template should 

appear as show below 

 

 

Creating an Existing Pavement Removed Template 
Take the following steps to create a template for the existing pavement removal areas. 

 Right click the name of the Jameson_X_Pavt template and choose the Copy option. 
 Right click on the Project Templates folder name and choose the Paste option. 
 Rename the copied template as “Jameson_X_Pavt_Removed. 
 Change the feature definition that is assigned to each of the two pavement layers as follows: 

• Right click the X_Asphalt component and choose the Edit Component command. 
• Change the Feature Definition to X_Asphalt_Pavement_Removed. Select the Apply button. 
• Edit the X_Concrete component to use the Feature Definition. 

.X_Concrete_Pavement_Removed. Select the Apply button and close the Component 
Properties dialog.  

 In the Create Templates dialog, choose File > Save and then close the template library. 
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Part 5: Apply the Surface Template 
The template is applied to terrain model using the Apply Surface Template command. 

 From the Model Detailing tab, select Apply Surface Template. 

 
 Select the Template for the portion of Jameson Road that will remain in place to apply the template 

as shown below. 

 
 When prompted, select the terrain model. 

 
The template is applied to the 3D model, like 
the example at right. 
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Part 6: Dynamic Cross Section View 
Take the following steps to display the elements in a dynamic cross-section view: 

 Turn on the reference file display of the Jameson Road alignment (123456_BK003.dgn), which was 
turned off in a prior step in this training exercise (OpenRoads Modeling > Home > Attach Tools). 
 

 Turn on the reference file display of the survey design file (123456_FB001.dgn), which was turned 
off in a prior step in this training exercise (OpenRoads Modeling > Home > Attach Tools). 

 
 Use the Level Display dialog (OpenRoads Modeling > Home > Level Display) to turn on the 

following levels for the survey file (123456_FB001.dgn): 
• DT_X_Terrain_Boundary 
• DT_X_Terrain_Ground_Line 

 
 Set the survey existing ground terrain model as the active terrain. 

• Choose the Element Selection tool (OpenRoads Modeling > Home > Element Selection). 
• Select the survey terrain model boundary. Allow 

the cursor to rest on the boundary element until 
the pop-up menu appears. 

• From the pop-up menu, choose the second icon 
to set the selected terrain model as the active 
terrain. 
 

 Hold down the right-mouse button in the view window. 
Select View Control > 2 Views Plan/XS from the pop-up menu. 

 
 When prompted, select OK to generate a Dynamic XS view. 

• When prompted to Locate Corridor or Alignment, choose the Jameson Road alignment. 
• Enter a Left Offset value of -100 
• Enter a Right Offset value of 100 
• Enter a Station value of 12+00 
• Enter an Interval of 50 
• When prompted to Select or Open View, enter a data point (left mouse click) in the cross-

section view window. An example is shown below. 
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Part 7: Component Quantities 
The OpenRoads component quantities report can be used with the surface terrain and mesh elements. Take 
the following steps to generate the component quantities for the Jameson Road pavement removal 3D mesh 
elements: 

 From the OpenRoads Modeling workflow, Home 
tab, select Civil Analysis > Element component 
Quantities as shown at right. 
 

 When prompted to Locate First Element, choose 
the surface terrain model for Jameson Road. Right-
click (reset) when complete. 

 
 The Element Component Quantities report is 

opened like the example below. 

Both the Volume and Surface Area are reported for 
each of the components as shown below. 

The Unit Cost can be assigned for each Material to 
generate a cost estimate. 

Select the Report button to send the quantities to 
the OpenRoads Report Browser. From there, the 
report can be saved in ASCII, Word, or Excel formats. 
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Alt. Exercise 2: Modeling the Existing Pavement using Create Closed Mesh 

This section will demonstrate the process to create 3D mesh elements for the existing pavement using the 
Create Closed Mesh tool. A portion of St. Peters Rd. will be removed so we will create two separate surface 
terrains, one for the portion that will remain in place, and a second for the portion to be removed. 

Part 1: References 
The surveyed edge of pavement and center of pavement elements will be used to generate the 3D mesh 
elements representing the existing pavement. 

 Attach the following files as references (Home > Attach Tools > References): 

Geometry Basemap for St. Peters Rd: 
400-Engineering\Roadway\Basemaps\123456_BK002.dgn 
 

Part 2: Creating the Surface Terrain Model for the Existing Pavement 
The surface terrain can be created for the existing pavement by directly using the referenced survey 
elements, or by copying the elements from the FB reference attachment into the active file. 

In this example, we will create a surface terrain model limited to the station limits of the pavement removal 
areas, from station 17+00 to meet existing S.R. 185. A copy of the existing survey elements is required since 
the elements will be edited to specific station ranges. 

Take the following steps to create the surface terrain for St. Peters Rd. 

 Use the MicroStation Copy Element command (Drawing > Copy) to copy the existing edge of 
pavement, center of pavement, and break line elements from the Survey Field Book design file (FB) 
to the active design file. The elements to be copied are shown below. 
 
Note: Be careful to copy the elements exactly on top of the original survey elements. 

 

 

Copy these 
four elements 
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 After copying the elements, turn off the reference attachment display of the survey basemap design 
file, 123456_FB001.dgn (Home > Attach Tools > References). 

 Then use the View Rotation: Rotate View by 3 points so that the St. Peters Rd. alignment 
annotations are in the correct orientation. 

Take the following steps to prepare the copied elements to generate the surface terrain model for the 
existing pavement: 

 Use the Break Element command (OpenRoads Modeling > Drawing > Break Element) to break 
each edge of pavement line and the center of pavement line at station 17+00 of St. Peters Rd. 
 
The result is shown below with the elements from station 17+00 forward selected to show that the 
lines are broken at station 17+00. 

  
 Select the level PV_P_Saw_Cut_Line  

 
 Use the Place Line command (OpenRoads Modeling > Drawing > Place Line) to draw a line to 

each point edge of pavement line at sta. 17+00 of St. Peters Rd. 
 

The edge of pavement elements and sawcut element will be used to define the boundary of the existing 
pavement surface terrain model. The surveyed center of pavement elements will be used as a break line to 
define the pavement crown. In this case, these elements are 3D graphics as generated from the Survey 
software and can be used to generate the surface terrain model directly. 2D elements can also be used if 
they have an OpenRoads profile defined. 

Take the following steps to create the surface terrain for the pavement portion that will remain in place: 

 From the References dialog (Home > Attach Tools > References), turn off the display of the file 
containing the proposed alignment for St. Peters Rd. (123456_BK002.dgn). Then turn the survey 
file back on (123456_FB001.dgn). 
 

 From the Level Display dialog (Home > Primary > Level Display), turn off all levels within the 
survey (123456_FB001.dgn) then turn on the DT_X_Terrain_Ground_Line & 
DT_X_Terrain_Boundary level. 
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 From the Drawing tab, select the Create Complex Chain command under the Groups. Then select 
all the EOP from Sta. 17+00 of St. Peters Rd. to S.R. 185. 

 From the Terrain tab, select the Additional Methods command to create a terrain model from 
selected elements. 

 
 Once the Create Clipped Terrain Model tool has been selected then survey terrain boundary. 

• Set the Clipping Method to External 
• Horizontal Offset = 0.000 
• Vertical Offset = 0.000 
• Choose the X_Triangles2 feature definition. 
• Key-in the Name for the terrain model X_PAVT_Remove_StPeters. 
• Select each edge of pavement element as shown below. 
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• Right-click (reset) when you are done selecting the elements. 
• When prompted, left click to accept each parameter. 
• After accepting each parameter, the terrain model is generated like the example below. 

Note: this method automatically adds the center of pavement element to the terrain model as a 
break line. 

• Repeat the process above for the Existing to Remain section of St. Peters Rd. using 
X_Triangles3 feature definition and Key-in the Name for the terrain model 
X_PAVT_Remain_StPeters. 
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Part 3: Applying a Closed Mesh to a Surface 
The Create Closed Mesh can be applied to a terrain model to define the subsurface composition of the 
surface terrain. We will create two templates, one for the portion of St. Peters Rd. that will remain in place, 
and a second for the portion to be removed. 

From the Modeling Detailing tab, select Create Closed Mesh tool under the 3D Tools sections. 

• Set the Method to Element to Depth 
• Depth = 0.25 
• Choose the MD_X_Asphalt_Pavement feature definition. 
• Key-in the Name for the closed mesh X_PAVT_Remain_StPeters 
• Data selected the first prompt. 
• Select the surface of pavement element as shown below. 

 

 Following the steps above, create a second closed mesh for the surface terrain for the portion of St. 
Peters Rd. to be removed. 
 

• Choose the MD_X_Asphalt_Pavement_Removed feature definition. 
• Key-in the Name for the closed mesh X_PAVT_Removed_StPeters. 
• Select the surface terrain shown below. 
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 When complete, two separate closed mesh’s are created form the surface of existing St. Peters Rd. 
like the example below. 
 

 

Tip: go to the view attributes  drop down to change the view display style to 
Illustration:IgnoreLighting. 

Creating an Existing Asphalt Concrete Base 
From the Modeling Detailing tab, select Create Closed Mesh tool. 

• Set the Method to Element to Depth 
• Top Mesh Side = Use Lowest 
• Depth = 0.75 
• Choose the MD_X_Concrete_Pavement feature definition. 
• Key-in the Name for the closed mesh X_Concrete_Pavt_Remain_StPeters 
• Data selected the first prompt. 
• Select the surface of pavement element as shown below. 

• A new Drop down with appear Top Mesh Side select Use Lowest. 
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 Following the steps above, create a second closed mesh for the surface terrain for the portion of St. 
Peters Rd. to be removed. 
 

• Choose the MD_X_Concrete_Pavement_Removed feature definition. 
• Key-in the Name for the closed mesh X_Concrete_Pavt_Removed_StPeters. 
• Select the surface terrain shown below. 

 
 When complete, you should have a Pavement layer and a concrete layer along St. Peters Rd. like the 

example below. 

 
 
 
 
 
 

 

 Dynamic XS view of St. Peters Rd. use the View Properties shown below.



 
Ohio Department of Transportation 
Office of CADD and Mapping Services November, 2019 

 

Section 514 – Widening and Resurfacing 514-1 
 

Section 514 Widening and Resurfacing 
Overview 

Widening and resurfacing projects can be accommodated using the OpenRoads Designer tools. Template 
components can be added to define pavement planning and wedge course components. This section will 
introduce users to the tools available for widening and resurfacing projects. 

Template Components for Overlay and Stripping 

From the OpenRoads Modeling WorkFlow, select the Create Template icon from the Corridors tab to 
open the Create Template dialog. To add an Overlay/Stripping component to the template, right-click in 
the current template window and choose Add New Component > Overlay/Stripping as shown below. 

 

Several parameters are available to define the overlay/stripping component. 

 

Name 
Specifies the name of the new component.  
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Feature Definition 
Specifies the feature style of the new component. This option is used for display and to define the 
component's material. The OHDOT standards contains two features for an overlay/stripping 
component: 

Mesh\Resurfacing\MD_P_Pavement_Planing 
Mesh\Resurfacing\MD_P_Wedge Course 
 

Top Option 
Specifies how the top of the component is defined. The following options are available: 

Follow Surface 
Specifies the top of the component will follow the surface.  

Follow Component 
Specifies the top of the component will follow the defined top of the component.  

Follow Highest 
Specifies the top of the component will follow the higher of the defined segments or surface.  

Bottom Option 
Specifies how the bottom of the component is defined. The behavior of these options can be 
different, depending on the selected Top Option.  

Follow Surface 
Specifies the bottom of the component will follow the surface at the defined depth but will 
not cross over the top of the component. The following options are available: 

Follow Component 
Specifies the bottom of the component will follow the defined top of the component at the 
defined depth but will not go above the top of the component.  

Follow Lowest 
Specifies the bottom of the component will follow the lower of the component/surface at 
the defined depths.  

Follow Highest 
Specifies the bottom of the component will follow the higher of the component/surface at 
the defined depths.  

Component Depth 
Sets the depth of the bottom below to the defined component line. This value cannot be negative.  

Surface 
Defines the surface to follow along. Does not support aliasing.  

Surface Depth 
Sets the depth of the bottom below the surface. This value cannot be negative.  

Alternate Bottom Surface 
If this field is populated, when alternate surfaces are created from the Roadway Designer Create 
Surface command, the bottom of this component will generate an alternate surface of the specified 
name.  
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Label (Component Depth/Surface Depth) 
Parametric label, used to change the default depth(s) from within Roadway Designer > Tools > 
Parametric Constraints.  

Stripping Component 
Defines whether this component is designed to remove material or add material. Used in end-area 
volumes. 
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ODOT Example Templates for Overlay and Widening 

The OHDOT_Templates.itl library contains two sample templates for widening and resurfacing as shown 
below. These templates can be used as the starting point for customization to meet a variety widening and 
resurfacing project needs. 

 

These templates have pavement planning and wedge course components defined. The pavement planning 
component is defined as shown below: 
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The pavement planing component is defined as a straight line across the template. The component is 
defined in the template below the pavement, but the actual location of the component within the template 
is not important. When the template is processed, the top of the pavement planing component will follow 
the existing terrain surface. The bottom is defined to follow the terrain surface with a depth of 1”. An 
example is shown below. 
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The wedge course component is defined to overlap the bottom of the Asphalt Concrete Intermediate 
Course layer as shown below. 

 
When the template is processed, the top of the wedge course component will follow the component 
definition. The bottom is defined to follow the terrain surface with a depth of 1” which is the depth of the 
pavement planing. An example is shown below. 
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The Overlay and Widening template is configured with the same settings for the overlay/stripping 
components as the example shown above. The difference is that this template is configured to search for a 
saw cut line on the left and right sides of the centerline to define the limits of pavement widening. 
 
The right side of the template, showing the R-SAWCUT point is shown below. 

 
 
The L-SAWCUT and R-SAWCUT points are defined at a 10’ offset from the center of the template. These 
points are configured with a Horizontal Feature Constraint to search for a graphic defining the saw cut 
line location in the case that the sawcut is not at a constant offset from the centerline of the alignment. The 
point properties are shown below. 
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The elements representing the saw cut 
must be added as corridor references 
using the OpenRoads Modeling > 
Corridors > Corridor References > 
Add Corridor References command. 

 

 

 

 

 

 

 

 

 

 

 

An example of this template, with an additional lane added to the right side, is shown below. The Sawcut 
and wedge course components are defined like the Overlay template example. 
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Processing Overlay Templates using the Existing Profile 

The examples above were generated using a proposed profile to process the overlay template. The point 
named “PGL” is at the origin of the template as shown below and is applied to the alignment and profile. 

 

For many projects, the user will want to process a template that overlays the existing pavement using the 
existing profile rather than a proposed profile. For example, the project may require planing off a portion of 
the pavement and replacing that with new asphalt pavement layers. 

There are many variations for overlay project requirements. Two examples are illustrated below. 
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Example 1 
For this scenario, we will overlay the existing pavement with 3” of new pavement using the 1.6% cross 
slope for the new pavement, as defined in the template. The following template is used for this example: 

ODOT > Backbones > Undivided Roadways > Widening & Resurfacing 301-8E > Overlay > 
Asphalt Concrete without Stabilization 

The template can be processed as defined using the existing profile to place 3” of new pavement by planing 
the existing pavement as necessary. 

Defining the Existing Ground Profile 
The existing ground profile displayed in the profile view is read from the active terrain model. This profile 
is not a “named” profile that can be used for corridor modeling. It is necessary to generate a profile from 
the alignment and terrain model that can be used for corridor modeling. 

The Profile From Surface, or Quick Profile From Surface command, located in the OpenRoads 
Modeling workflow, Geometry tab, can be used to generate the existing profile. 

 

The Quick Profile From Surface command extracts a profile from 
the selected alignment, using the selected terrain model, for the 
entire length of the alignment. No additional parameters are 
available. 

The Profile From Surface command allows additional parameters 
to define starting and ending stations, horizontal and vertical 
offsets, etc. 

 

 

In the example below, the Quick Profile From Surface command was used to generate an existing profile. 
The existing profile lies on top of the profile that is displayed from the terrain model. 

 

The newly created profile can be 
named using the Properties dialog 
from the pop-up menu when the profile 
is selected, as shown at left. 
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The profile is given a name according to the OHDOT CADD Standards as shown below. 

 

Defining the Pavement Planing Parameters 
The template is applied like the example below. Note that the proposed 1.6% pavement slope does not 
match the existing pavement slope. 

 

The pavement planing follows the existing pavement slope for both the top and bottom depths. This can be 
adjusted to follow the bottom the proposed pavement by editing the template as follows: 
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Add a point to the pavement planing component by right-
clicking on the component and choosing the Add Point 
command. 

Add a point to the component by clicking on top of the point 
ACIC_B_CL point. 

Next, move point L-Planing on top of point L-ACIC_B_EP by 
right-clicking on point L-Planing and choosing the Move 
Point command. 

Move point R-Planing on top of point R-ACIC_B_EP by right-
clicking on point R-Planing and choosing the Move Point 

command. 

 

When complete, the PAVT_PLANING component now follows the bottom of the proposed pavement as 
shown below. 

 

Note: There are now two points on top of each other at the left and right point locations. These 
points can be merged by right-clicking on the points and choosing the Merge Point command to 
remove the L-PLANING and R-PLANING points 

Double-click the bottom of the pavement layers to edit the PAVT_PLANING component properties. Three 
components are defined at this location. Select the PAVT_PLANING component from the list to edit the 
properties. 

Note: The WEDGE_COURSE component is not needed for this example and can be deleted. 
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Change the Bottom Option to 
Follow Component. 

Set the Component Depth to a 
value of 0. 

 

 

 

 

 

 

 

 

When the template is processed, the pavement planing now follows the top of the existing pavement and 
the bottom of the proposed pavement like the example below. 
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Example 2 
For this scenario, we will overlay the existing pavement with 3” of new pavement by matching the existing 
pavement width and cross-slope. The following template is used as the basis for this example: 

ODOT > Backbones > Undivided Roadways > Widening & Resurfacing 301-8E > Overlay > 
Asphalt Concrete without Stabilization 

A few changes need to be made to the template for this example: 

1. Edit the constraints for points L-ACIC_B_EP and R-ACIC_B_EP to define these points so that they 
will find the existing edge of pavement lines and meet the pavement surface. The properties for the 
point L-ACIC_B_EP are shown below. Point R-ACIC_B_EP will be defined similarly, with at an offset 
of 8’ to the right of point ACIC_B_CL.  

 
2. Edit the remaining EP points so that the pavement buildup is defined from the bottom-up instead of 

the top-down. 
 

3. Delete the WEDGE_COURSE component. It is not needed for this example. 
 

4. Modify the PAVEMENT_PLANING component to follow the bottom of the proposed pavement with 
a Component Depth value of 0. 
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When the edited template is processed, the pavement slopes meet the existing terrain like the example 
below. 

 

The left and right edge of pavement lines are defined with an offset of 12’ and do not meet the existing edge 
of pavement lines from the survey data. The Horizontal Feature Constraint parameter, which is defined 
in the template Point Properties dialog, can be used to set points L-ACIC_B_EP and R-ACIC_B_EP to meet 
the existing edge of pavement lines will be define the Feature Definition of the edge of pavement element. 

With this release of the software, the Horizontal Feature Constraint parameter does not allow selecting 
Survey features. The surveyed edge of pavement lines must be copied from the survey design file to the 
modeling design file and then assigned a new feature definition that can be used for the modeling process. 

After copying the existing edge of pavement lines from the survey design file to the modeling design file, set 
the feature definition for the newly copied elements by using the OpenRoads Modeling > Set Feature 
Definition command as shown below. 

 

The feature Linear > Modeling > Template Points 
> Scratch > Scratch1 is used in this example. 

Select each copied edge of pavement element to 
assign the new feature definition. 

The feature definition is assigned like the example 
below. 
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In the Create Template dialog, edit 
the point properties for points L-
ACIC_B_EP and R-ACIC_B_EP to assign 
the Horizontal Feature Constraint 
parameter using the Scratch1 feature 
like the example at left. 

Note: The Horizontal offset value of 8’ 
is used to position the pavement 
points inside the limits of the existing 
pavement. The software will search 
from the location of the points, 
outward, for the intersecting elements. 
If the template points are already 
wider than the existing pavement the 
process will not find the existing 
pavement lines. 

 

 

 

 

The edge of pavement elements must be added as a corridor reference for the modeling process to 
recognize the lines. Choose the OpenRoads Modeling > Corridors > Add Corridor Reference command. 

 

• When prompted to locate the corridor, choose one of the corridor handle graphics to identify the 
corridor. 

• Next choose the edge of pavement elements to add them as corridor references 
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Section 600 Right-of-Way 
Right-of-Way Basemap Design Files 

ODOT’s CADD Standards detail the use of basemap design files to draw plan, profile, and cross section 
information for your project in real world dimensions. These drawings are then referenced into sheet 
design files to produce the plan sheets for the project. 
 
Several basemap files may be used depending on the complexity of the project. The ODOT CADD Standards 
allow for multiple basemap design files for each unique discipline (Drainage, Lighting, MOT, Right-of-Way, 
Roadway, Signals, etc.) 
 
The OHDOT Create Design Files application is used to create new design files using the seed files for the 
project. 
 
Right-of-Way information can be placed in a single design file, or multiple depending on the size of the 
project and the number of people needing access to edit the information. For most projects, as a minimum, 
the use of two right-of-way basemap design files is recommended: 
 

File Name Purpose 
400-Engineering\RW\Basemaps\######_BR001.dgn Existing right-of-way information 
400-Engineering\RW\Basemaps\######_BR002.dgn Proposed right-of-way information 

  
See the ODOT CADD Engineering Standards Manual (OHDOT), Section 300 File Management for more 
details. 
 
The right-of-way information is often generated by ODOT’s survey personnel. all right-of-way information 
is stored in the 400-Engineering\RW\Basemaps\ folder regardless of who generates the information. 
 
 
 

  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 600 – Right-of-Way 600-2 
 

Right-of-Way Feature Definitions 

The OHDOT WorkSpace contains several feature definitions intended for right-of-way areas, such as the 
parent tract area, or taking areas, as well as features for the right-of-way lines that are shown on the right-
of-way plans. 

Point Features 
Several features are available for storing right-of-way points in the \Points\Control Points and 
Monuments folder. 
 
These features are used with the Geometry > Point commands, selected from the OpenRoads Modeling 
or the Survey Workflow. 

 
Civil Accudraw is used to place points at specific coordinates or at a station and offset location from a 
selected OpenRoads Alignment. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
See the OHDOT_ORD_Design_303_CivilAccudraw guide for more information using Civil Accudraw. 
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An example placing an Iron Pin with Civil Accudraw is shown below. 

 
 
The point element is placed with rules for the station and offset value. The rules can be edited by selecting 
the element and then clicking on one of the rules as shown below. 

 
The rules for the selected 
point can also be edited in 
the Point Constraints 
section of the Properties 
dialog. 
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Parcel Area Features 
The parcel area features are used when defining the closed geometry that makes up a specific area, such as 
an easement or taking area. The graphics drawn for these areas are not intended to be shown on the final 
plans. Areas created using these features are intended to be used for computation purposes. These features 
are in the \Linear\Parcel Areas folder in the OHDOT Standards. 
 
Areas can be placed using the OpenRoads Geometry tools to place lines and arcs. After placing the elements 
that define the closed area, the Complex Geometry command is used to create the closed shape. 
 
In the example below, the Geometry > Lines > Line Between Points command is used to place the lines 
defining the parcel area by snapping to previously placed geometry points. The MicroStation Origin snap is 
used to snap to the center of the geometry points. 

 
Note: If the Origin snap is used to snap to the points when placing the curvilinear elements, the point name 
is associated with the endpoints of the curvilinear element. The Properties dialog shows the name of the 
points associated with the endpoints of the selected element as shown in the example below. 
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The Geometry > Complex Geometry > Complex By Element command is used to create the closed shape 
for the area. In the example below, an easement area is created. Note that the direction for the closed area, 
when using the Automatic Method, is indicated by the arrow drawn at the end of the first element 
selected, at the opposite end from the end closest to the location where the element is selected. 

 
The closed geometry element is intended to be used to generate parcel areas and is not shown on the 
completed plan. The graphics that are placed when using these Parcel Area feature definitions are placed as 
construction class elements. These closed areas are useful to generate parcel reports. 
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Right-of-Way Linear Features 
Features for right-of-way and lines are in the \Linear\Right-of-Way folder in the ODOT Standards. These 
features are used to draw the right-of-way lines that will be shown in the right-of-way plans. 

The right-of-way lines can be drawn by using the Origin Snap to snap to previously placed geometry 
points or by using the Keypoint Snap to snap to the corners of previously placed curvilinear elements used 
to define a closed parcel area. 

If these lines are drawn by snapping to the underlying parcel element or the geometry points, a rule is 
created to link the lines to the underlying graphics. The right-of-way lines will respond to changes made to 
the underlying graphics. 

In the example below, the feature definition Linear\Right-of-Way\Easaements\RW_P_Standard 
Highway Easement was used to draw the easement lines that will be shown on the right-of-way plans. The 
level for the underlying parcel area element can be turned off. 

 

Tip: The Geometry > Offsets and Tapers > Single Offset Partial command can also be used to easily 
draw right-of-way lines along curves like the example below. Note: The element is drawn in the direction 
that the parcel area was stored. In the example below, the area was stored in the counterclockwise 
direction. 

 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 600 – Right-of-Way 600-7 
 

Parcel Annotation 
The feature definitions for parcel areas have annotation definitions defined. The Drawing Production > 
Element Annotation > Annotate Element tool is used to annotate selected parcel area elements. 
 
Parcel annotation is typically placed in the drawing model of the sheet design file. The process to clip 
sheets is detailed in the OHDOT_Plan_and_Profile_Sheets document. 
 
In the example below, the closed element representing the easement area was annotated in the drawing 
model using the Drawing Production > Element Annotation > Annotate Element tool. The bearings, 
lengths, and the parcel name are annotated. 

 
Annotation graphics can be moved or deleted as needed. 
 
Note that if multiple areas adjacent to one another are annotated the bearing and length labels will be 
placed for each component of the complex element. This will result in overlapping labels that the user can 
manually delete.  
 
If the parcel area includes an arc element, the radius, length, chord bearing, and chord length are annotated. 
 
If the element is annotated again, previous annotations are left in place. The Drawing Production > 
Element Annotation > Remove Element Annotations command is used to remove previous annotations. 
 
All annotations are drawn using the active Annotation Scale value. 
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Parcel Labels 

ORD supports placing labels that have fields computed from the selected geometry graphic or data point 
location. The label maintains an association to the element that is being labeled and is automatically 
updated if changes are made to the element. 

Two separate tools that may be used for placing labels are documented below. The new Civil Labeler tool 
was added to the 2021 Release 1 version of ORD, Version 10.10, and is the preferred labeling tool moving 
forward. The older Place Label tool is still valid and may be used if desired. 

Civil Labeler 
A new annotation tool, Civil Labeler, has been added to the 2021 Release 1 version of ORD. As of this 
writing, the function is in a “tech preview” status as the tool is refined. The Civil Labeler can be accessed 
from the OpenRoads Modeling WorkFlow by selecting Drawing Production > Labels > Civil Labeler 
from the ORD Ribbon menu. 

 

When the command is selected, the Civil Labeler Tool dialog is opened with the 
OHDOT_Civil_Labeler.xml file loaded as shown below. 
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The xml file is configured with multiple folders containing multiple label definitions as shown above. Each 
folder contains multiple labels. It is beyond the scope of this training guide to document each label option. 
A few of the common labels will be documented below. Contact the CADD and Mapping Support team with 
questions or requests to add additional labeling options. 

Cross Section and Drainage and Utilities labels will not be covered in this document. 

ODOT recommends placing most labels in the various Drawing models for the sheets. Labels should not be 
placed in the sheet model. 

When a label is selected, the dialog presents several options to the user like the example below. 

 

It is beyond the scope of this manual to document every option. The ODOT labels have been configured 
with the default options most used for each label type. Examples of commonly used labels are included 
below. 

For more information, see the OHDOT_ORD_Design_800_Plan_and_Profile_Sheets training guide. 
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Place Label 
With a 2021 Release 1 version of OpenRoads Designer 10.10, ODOT recommends using the new Civil 
Labeler tools. This section is retained in the document for reference. 

A label can maintain two types of associations. The first is regular association, in which if you move the 
element, the label remains at the same place, only the leader line moves along with the element. The second 
is relative association, in which the label will stay at the same location relative to the original snap point. 
That is, if you move the element the label will also move with it. 

Several labels have been configured in the OHDOT standards for various types of labels. These labels are 
placed using the Drawing Production > Notes > Place Label command. 

 

The Place Label Settings parameters are displayed in the Tool Settings dialog as shown below. 
 

 
Labels can be placed with or without a leader line by 
selecting the corresponding icon at the top of the 
dialog. 
 
 
 
 
 
 
 
 
 
 

 
The dialog has the following parameters: 
 
Type 

The Type option is used to place labels using a Cell or a Text Favorite. The cell option allows for 
labels that contain multiple computed annotations. When the cell option is selected, the dialog 
allows selection of the label from a cell library. 

If Cell is selected, the Cell Name parameter lists all the cells found in the libraries defined by the 
configuration variable MS_CELLLIST. The labels that have been defined in the OHDOT standards are 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Section 600 – Right-of-Way 600-11 
 

named with the prefix _Lbl_ so that they will be listed first in the dialog. A partial list of the cells in 
the OHDOT WorkSpace that have been defined as labels is shown below. 

 

If the Type parameter is set to Text Favorite, the Favorite Name item allows selection of a 
predefined text favorites. 

In general, the Cell option is used for placing labels as they have been defined in the OHDOT 
WorkSpace. The text favorites are used as a component of the Cell labels, or other annotation 
functions within ORD such as the station annotation or the curve data. There may be occasions 
when using one of the text favorites directly is desired. 

Dimension Style 

The Dimension Style parameter us used to select a dimension style from the OHDOT standards 
that will be used to set the symbology settings for leader lines. Two options are provided in the 
OHDOT Standards that are used for the labeling process: 

_Lbl_Leader_Line 

_Lbl_Leader_Line_With_Terminator 

See the online documentation for a description of the remaining parameters. 
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Station and Offset Labels 
Labels that have been defined using a station or offset text favorite require that the alignment is selected 
before the label is placed. 
 
In the example below, the _Lbl_Pln_Sta-Off cell is selected. 

 
The user is prompted to Identify Element or Data Point in the prompt field at the lower left corner of the 
ORD interface. Take the following steps: 
 

• Select the alignment for the station and offset reference 
• Select the location for the label. The Start At parameter is set to define whether the data point is at 

the Terminator, or the Placement point for the label. 
• Additional labels can be placed without the need to re-identify the alignment  

 
Additional label types have been defined for Right-of-Way plans. See the Cell Name drop-down list to 
review the available labels. The _Lbl_Pln_Begin_RW_Acquisition label is shown below. 
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Geometry Builder  

There are multiple ways to create a parcel in ORD. The Geometry Builder tool is specifically designed for 
creating and editing parcel elements. 

Select Geometry > Complex Geometry > Geometry Builder from the OpenRoads Modeling workflow as 
shown below. 

 

The Geometry Builder Tool dialog is opened as shown below. 

 
See the Bentley online help for options not covered in this document. 
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Creating Parcel Elements 
The steps to create a closed parcel area are summarized below. 

• Select the Add new geometry button  
 

 
A geometry definition named NewGeometry1 is 
created as shown at left. 
 
 
 
 

 
• Choose the feature definition from the drop-down list. By default, No Feature Definition is defined 

as shown above. 
• Edit the name of the geometry element by selecting the name, and then left-clicking on the name a 

second time once it has been selected. 
• Toggle on the Create ruled civil elements option 

 
• Enter the data to create the parcel area. An example is shown below. 

 
Information about the parcel, such as the perimeter, area, and closure of the shape, is displayed at 
the bottom of the geometry builder dialog. 
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• Select the Begin Point icon, or key-in the (X, Y) coordinates for the start of the parcel location. 
 
When the Begin Point icon is selected, the parcel graphics will drag on the cursor until a data point 
location is defined. 
 
The graphics are displayed in the file as temporary graphics like the example below. Changes to the 
parcel definition are dynamically reflected in the temporary graphics. 

 
• Select the Place button to write the graphics to the design file. The parcel element is placed in the 

design file using the symbology defined by the selected feature definition. 
 

Saving Parcel Definitions to an XML File 
After the geometry has been defined, it is good practice to save an XML file with the geometry data. 

• Choose the Save icon at the top left of the Geometry Builder dialog. 
 
Note: In this release, the software does not allow saving the file directly in ProjectWise. Save the file 
to the desktop and then copy the file into ProjectWise in the \400-Engineering\RW\EngData 
folder for the WorkSet. 

Previously saved XML files can be re-opened for editing using the Open File icon. 
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Locking Right-of-Way Elements 

Parcel areas and right-of-way curvilinear elements can be locked by deactivating the rules. The rules for 
selected elements can be deactivated by selecting the element and choosing the Deactivate Rules 
command from the pop-up menu as shown below. 

Alternately, the rules can be deactivated by choosing the Geometry > Civil Toggles > Deactivate Rules 
command and then selecting the element(s) to deactivate the rules. 

Once deactivated, the element is locked and cannot be edited or deleted. Use the Activate Rules command, 
which can be selected from the pop-up menu or by choosing Geometry > Civil Toggles > Activate Rules, 
to reactivate the rules to allow editing or deleting the element. 
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Export Right-of-Way Geometry to XML 

XML files can be saved with the parcel element definition as a back-up to the parcel data. This is useful to 
recreate the parcel should the data be inadvertently modified or deleted. To save an XML file for a parcel 
element, select the Geometry > Import/Export > Export Geometry command. 

 

When prompted, choose the element that you wish to export to an XML file. 

Save the XML file in the \400-Engineering\RW\EngData folder. Name the XML file using the name of the 
parcel element. 

The Geometry > Import/Export > Import Geometry command is used to import the XML file if it is 
necessary to recreate the parcel element. 
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Reports 

Various reports are provided for parcel areas and points. 

Horizontal Geometry Report 
Select a parcel area and let the cursor rest on the element until the pop-up menu appears. The Horizontal 
Geometry Report option can be used to generate a report for the area. 

 

 

 

 

 

 

 

When the report icon is selected from the pop-up menu, the Report Browser dialog is opened with the 
default Horizontal Alignment Review Report selected. 

In the Report Browser dialog, the LegalDescription and Map Check folders contain various reports for 
parcel areas. 

Depending on the report command that is used to open the Report Browser dialog, the selected report may 
not contain the desired information. For example, if the Report Browser dialog is accessed by selecting the 
Horizontal Geometry Report icon as shown above, selecting the ParcelLayoutFromRefernce report 
does not have the necessary information to generate the station and offset data for the report. 

When using the Horizontal Geometry Report, the Horizontal Alignment Review report is the default 
report as shown below. 
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Parcel Reports 
Various reports applicable to parcels are available on the Home tab in the Reports group as shown below. 
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Legal Report 
Legal descriptions can be generated by selecting Reports > Legal Report from the Home tab. When this 
command is selected, the user is prompted to enter the following information: 

• Locate First Element 
o Choose the first parcel element to be included in the report 

• Locate Next Element – Reset to Complete 
o Choose additional parcel elements to be included in the report or reset to complete the 

parcel selection process 
• Locate Parent Element – Reset to Skip 

o Choose the parent tract element 
• Locate Primary Reference – Reset to Skip 

o Choose the primary alignment for station and offset references 
• Primary Reference Alignment: Bandwidth 

o Enter the bandwidth value 
• Locate First Secondary Reference Element 

o Choose the secondary reference element for station offset references. Reset to skip this step 

After entering the data as prompted, the report is generated. By default, the LegalDescription 
HorizontalAlignmentLegalDescription report is selected. Any of the reports in the LegalDescription 
category can be selected. If a reference element is included in the selection process, the station and offset 
information is included depending on the selected report. 
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Map Check Report 
The map check report is generated by selecting Reports > Map Check Report from the Home tab. When 
this command is selected, the user is prompted to locate the parcel element for the report. An example of 
the report is shown below. 

 

The MapCheck.xsl report is the default report for this command as shown above. Reports in other formats 
can be selected from the list at the left side of the dialog. 
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Point Feature Station Offset Elevation Report 
This report is generated by selecting Reports > Point Feature Station Offset Elevation Report from the 
Home tab. When this command is selected, the user is prompted as follows: 

• Locate Baseline Element 
o Select the alignment to be used for station and offset references 

• Locate First Offset Element 
o Select the geometry point element to include in the report 

• Locate Next Offset Element – Reset to Complete 
o Select additional geometry point elements or reset to complete the selection 

An example of the report is shown below. 

 

The StationOffsetElevationFeature report is the default report for this command. Note that a few other 
station and offset report formats are available for selection in the list on the left side of the dialog. 
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Report Format 
The Report Browser allows the user to set the output format for the reports by choosing Tools > Format 
options.  

The values shown below are recommended for most ODOT applications. 

 

Saving Reports 
Reports can be saved by choosing File > Save As from the Report Browser dialog. 

Right-of-Way related reports are typically saved in the \400-Engineering\RW\EngData\ folder. 
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Displaying Right-of-Way on Cross Sections 

The location of the Right-of-Way and Easement lines can be displayed in a dynamic cross-section view and 
on the cross-section sheets like the example shown below: 

 
To display the Right-of-Way lines on the cross-sections, each Right-of-Way line must have a profile defined. 
This is accomplished by opening a profile view for each Right-of-Way line and defining the exiting ground 
profile as the active profile. When the profile is defined for right-of-way lines, a 3D line string is created in 
the 3D model for the line. 
 
The workflow to assign a profile to the right-of-way lines is as follows: 
 

• In the right-of-way basemap design file (BR), attach the design file containing the existing terrain 
 

• Set the referenced terrain model as the active terrain by selecting the terrain and choosing the Set 
As Active Terrain option from the pop-up menu 

 
• Open a profile model for each right-of-way line, either by selecting the element and choosing the 

Open Profile Model option, or by holding down the right-mouse button and choosing View 
Control > 2 Views Plan/Profile from the pop-up menu. 
 

• Select the existing groundline in the profile window and choose the Set As Active Profile option 
from the pop-up menu 
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A 3D element is generated in the 3D model like the example below. 
 

 
When cross sections are generated, if the cross section intersects a 3D Right-of-Way line in the 3D model, a 
cell is placed in the cross section at the right-of-way line offset and elevation. 
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Construction Limits 

Construction limits can be generated from the graphics drawn during the 3D modeling process. There may 
be multiple ways to generate the construction limit lines using the template. This section documents that 
process that seem to work best for ODOT projects. The process is summarized below: 

• Assign the Feature Name Override 
name consistently for the outer tie-
down points in the template. This 
applies to all points in the template 
that tie to ground for both cut and 
fill conditions. In the example at 
right, the name R-TIE is assigned to 
all the outer tie-down points on the 
right side of the template. 
 

• Assign the DT_P_Grade_Tie_Line 
Feature Definition, as shown at 
right, to all the outer tie down 
points in the template. 
 

• When the template is processed, a 
continuous element is drawn in the 
2D model at the outer tie-down 
location. This line will connect 
between different cut and fill 
transitions if the same Feature 
Name Override is used for all the 
outer tie-down points. An example is 
shown below. 
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Construction limits can be generated from the outer tie-down lines as follows: 

• The construction limits are normally drawn in the right-of-way design file (BR) containing the 
proposed right-of-way information. Attach the corridor design file (KM) containing the outer tie-
down lines as a reference. 
 

• From the OpenRoads Modeling Workflow, select Geometry > Offsets and Tapers > Single Offset 
Entire Element 

 
• Enter the desired Offset value 

 
• Set the Feature Definition to Linear\Right-of-Way\RW_P_Construction Limits 

 
• Select the DT_P_Tie element to create the new offset the element. An example is shown below. 

 
•  
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• The newly created construction limit element is a ruled geometry element. To make edits to the 
element, it is necessary to remove the rules. Use the Element Selection tool to select the element 
and choose the Remove Rule option from the pop-up menu as shown below. After removing the 
rules, the element can be modified as desired using standard MicroStation drawing commands. 

Rule Icons 

• Deactivate Rule 
• Remove Rule 
• Activate Referencing Rules 
• Deactivate Referencing Rules 
• Remove Rule
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Section 800 Plan and Profile Sheets 
Process Overview 

OpenRoads designer provides tools to easily create plan sheets in various formats such as plan only, plan 
and profile, or profile only. MicroStation Named Boundaries are used to define the clipping areas for the 
plan and profile portions of the sheets. In the example below, two named boundaries have been placed in 
the plan and profile views. 

 

The various basemap design files required to assemble the sheets are attached as reference files to the 
Design Model in the sheet design file. In the example above, the geometry and survey basemaps are 
attached to the plan view with a profile window displayed. 

Sheets can be clipped into the active design file, or separate design files. 

When the sheets are generated, the software creates a MicroStation Drawing Model for each named 
boundary. An example of the drawing model for a plan view named boundary is shown below. 
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The drawing models are referenced to a sheet model with a sheet border to assemble the completed sheets 
for plotting and PDF generation as shown in the example below. 
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The sheet model is intended for plotting or PDF generation. Annotations should be placed in the drawing 
models, not in the sheet models. 

File Types and Usage 
Sheets can be clipped into a single file, or into multiple design files, one sheet per file. In either case, ODOT 
recommends using the fist file of a sheet series, the 000, 100, 200, etc. file, as the container file to attach 
references and place the named boundaries.  

Each container file is used to generate the sheets for a single alignment. For example, a project with three 
alignments using the option to clip the sheets into separate files (one sheet per file) would typically use 
three container files as detailed below: 

Design File Usage Models Used 
GP000 Container file for S.R. 185 Design 
GP001, GP002, GP003… Plan and profile sheets for S.R. 185 Drawing and Sheet 
 
GP100 Container file for St. Peter Road Design 
GP101, GP102, GP103… Plan and profile sheets for St. Peter Road Drawing and Sheet 
 
GP200 Container file for Jameson Road Design 
GP201, GP202, GP203… Plan and profile sheets for Jameson Road Drawing and Sheet 

 
The references are attached as illustrated below: 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services December, 2021 

 

Section 800 – Plan and Profile Sheets 801-4 
 

 

If all the sheets for a single alignment are to be clipped into one file, the container file is used for the sheets 
as follows: 

Design File Usage Models Used 
GP000 Container file and sheets for S.R. 185 Design, Drawing, and Sheet 
 
GP100 Container file and sheets for St. Peter Road Design, Drawing, and Sheet 
 
GP200 Container file and sheets for Jameson Road Design, Drawing, and Sheet 

 
The references are attached as illustrated below: 

Basemap Files
The various basemap 
design files (survey, 

alignments, drainage, 
etc.) are used to draw 

the existing and 
proposed information 

for the project.

Container File
The container file's 

design model is used 
to attach the various 
basemap design files 
as references, and to 

place the named 
boundaries for the 

both plan and profile 
views.

Sheet File
The drawing models 

reference the 
container file's design 
model. The drawing 

models are also used 
for sheet annotation.

The sheet models 
references the drawing 

models. The sheet 
models are used for 

the sheet border and 
for plotting.
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The container file is also used to control the reference attachment and level display settings for all the 
sheets from one location. More information on level display can be found in the Level Management section 
of this document.  
 

Creating the Sheet Container File 
Sheet design files can be created using the OHDOT Create Files application. The application is accessed 
from the Ohio DOT WorkFlow by selecting the New Design File icon. 

 

Basemap Files
The various basemap 
design files (survey, 

alignments, drainage, 
etc.) are used to draw 

the existing and 
proposed information 

for the project.

Container File 
Design Model
The container file's 

design model is used 
to attach the various 
basemap design files 
as references, and to 

place the named 
boundaries for the 

both plan and profile 
views.

Container File 
Drawing 
Model

The drawing models 
reference the 

container file's design 
model. The drawing 

models are also used 
for sheet annotation.

Container File 
Sheet Model
The sheet models 

reference the 
container file's 

drawing models. The 
sheet models are used 

for the sheet border 
and for plotting.
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When creating sheet design files, it is important to consider the seed file that will be used to create the new 
file. Normally, a sheet design file is created using the Sheet Seed as defined by the OHDOT WorkSpace 
configuration. When creating design files for OpenRoads sheet clipping, it is important to use the Design 
Seed. 

When the File Suffix value is entered, the Create Design Files application will automatically select the 
Design Seed if a suffix of 000, 100, 200, 300… is entered as shown below. This will ensure that the file is 
created with a design model instead of a sheet model. The design model is necessary for attaching the 
references that will be displayed in the sheets as well as laying out the named boundaries. 

 

Named Boundaries 
Sheets are clipped using the Named Boundary tool. From the OpenRoads Modeling workflow, select the 
Drawing Production tab to access the Named Boundary tool as shown below. 

 

The Place Named Boundary Civil Plan dialog is opened as shown below. 
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The top of the dialog contains several icons to select 
the type of named boundary that you wish to place.  

The following icons will be discussed in this document: 

  Civil Plan  

  Civil Profile 

  Civil Cross Section 

  Civil Cross Section 2 Points 

 

 

 

ODOT has configured several sheet clipping options for plan, profile, and cross section sheets. These 
configurations are stored in a MicroStation DGN Library. The Configuration files are defined in the 
OHDOT_WorkSpace.cfg file as follows: 

MS_DGNLIBLIST > $(_USTN_WORKSPACESTANDARDS)Dgnlib/Sheet Seeds/*.dgnlib 

 

Named Boundary Level 
The named boundaries are placed on the active level. Set the active level to SH_Named_Boundaries before 
placing the named boundaries in the design, 
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Sheet Clipping 

Plan Only Sheets 
From the OpenRoads Modeling WorkFlow, select Drawing Production > Named Boundaries. On the 
Place Named Boundary Civil Plan dialog, select the Civil Plan icon. 

 

The Drawing Seed item is used to select the 
configuration for the named boundaries to be 
placed. Several options are available as 
defined by the OHDOT DGN Libraries. 

For clipping Plan-Only sheets, select the Plan 
Only option for the Drawing Seed parameter 
as shown at left. 

When one of the Drawing Seed options is 
selected, several parameters in the dialog are 
automatically populated with default values 
according to the configured settings.  

The Detail Scale parameter is used to select 
the sheet scale. In the left example, 20-scale 
plan sheets will be generated. 

The Length, Left Offset, and Right Offset 
parameters are set according to the selected 
Detail Scale value. 

 

Take the following steps to select the alignment and define the Start Location and Stop Location values: 

• Issue a left mouse-click in the Start Location Field. 
• Select the desired alignment that will be used as the centerline for the sheet clipping. The Start 

Location value will dynamically change as the cursor is moved within the view window. 
• Identify the desired Start Location by issuing a data-point (left-click) within the view, by keying in 

a station value, or by selecting the icon to the right of the Start Location field to lock the starting 
location to the beginning of the selected alignment. 

• After the Start Location has been established, identify the desired Stop Location. As the cursor is 
moved, the Stop Location will track the station value relative to the cursor position. Clipping 
borders are dynamically displayed as the cursor is moved. The stop location can be entered by 
issuing a right-mouse click in the view, keying in the desired station, or by selecting the icon to the 
right of the Stop Location field to lock the ending location to the end of the selected alignment. 
Note that the last sheet will always assume the value of the Length field even if the stop location is 
not equal to the Length value. 

The Overlap, and Boundary Chords items are set according to the selected Drawing Seed item. These 
items should typically be left to their default values. 
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After defining the parameters, issue a data point (left click) in the plan view to accept the Start Location 
value. A second data point accepts the Stop Location value. A third data point accepts the placement of the 
named boundaries. If the Create Drawing and Show Dialog options are toggled on, as shown on the 
preceding page, the Create Drawing dialog is opened as shown below.  

  

Some of the parameters for the Create 
Drawing dialog have been predefined in 
the DGN Library for the selected Drawing 
Seed. 

If you wish to create a separate design file 
for each sheet, toggle the One Sheet Per 
DGN option on and set the path for the 
sheet file location. 

The View Name parameter is used for the 
named views that will be created in the 
container file as part of the clipping 
process. This parameter is not normally 
changed by the user. 

 

 

 

 

 

 

 

 

 

 

Drawing Model parameters 

The Model Name is used as the seed name for each of the drawing models that will be created. This 
name is incremented by the software. In most cases, the default name is used. 

Set the Annotation Scale value for the Drawing Model to the desired value. This parameter should 
default to the same value used for the Detail Scale in the Place Named Boundary dialog, but it is 
good practice to review the value to ensure it is set correctly. 

Sheet Model parameters 

The Model Name entered for the sheet model is also the name that is used for the created design 
files when the One Sheet Per Design option is selected.  
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Do not change the Annotation Scale value for the Sheet Model. Leave this value at 1:1, as shown at 
above. 

Set the Detail Scale value for the Sheet Model to the desired value. This parameter should default 
to the same value used for the Detail Scale in the Place Named Boundary dialog, but it is good 
practice to review the value to ensure it is set correctly. 

After reviewing the dialog settings, select OK to continue the sheet clipping process. If Open Model is 
toggled on, the application will open the last created file upon completion. 

An example of the models generated for a Plan Only sheet configuration when using the One Sheet per 
DGN option is shown below. Note the sheet model name is the same as the design file name. 

 

An example of a completed sheet is shown on the next page. 
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Notes: 

• Each sheet design file contains a Drawing model corresponding to the plan view named boundary 
• The Drawing models reference the original Container file 
• The Sheet model references the Drawing model 
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Plan-Plan Sheets 
The process to create dual-plan sheets is like the process to create plan-only sheets, as described above. 
The differences are detailed below. 

From the OpenRoads Modeling WorkFlow, select Drawing Production > Named Boundaries. On the 
Place Named Boundary Civil Plan dialog, select the Civil Plan icon. 

 
Select the Drawing Seed option Plan-Plan to 
generate sheets with two plan views. 
 
The Detail Scale parameter defaults to 1:1. 
Set the parameter to the desired value. The 
Length, Left Offset, and Right Offset values 
are adjusted accordingly. 
 
The process to define the alignment Start 
Location and Stop Location values is the 
same as described for the Plan-Only option 
above. 
 
After defining the parameters, issue a data 
point (left click) in the plan view to accept the 
Start Location value. A second data point 
accepts the Stop Location value. A third data 
point accepts the placement of the named 
boundaries and opens the Create Drawing 
dialog, shown on the following page. 
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Some of the parameters for the Create 
Drawing dialog have been predefined in 
the DGN Library for the selected Drawing 
Seed. 

If you wish to create a separate design file 
for each sheet, toggle the One Sheet Per 
DGN option on and set the path for the 
sheet file location. 

The View Name parameter is used for the 
named views that will be created in the 
container file as part of the clipping 
process. This parameter is not normally 
changed by the user. 

 

 

 

 

 

 

 

 

 

 

Drawing Model parameters 

The Drawing Model Name is used as the seed name for each of the drawing models that will be 
created. This name is incremented by the software. In most cases, the default name is used. 

Set the Annotation Scale value for the Drawing Model to the desired value. This parameter should 
default to the same value used for the Detail Scale in the Place Named Boundary dialog, but it is 
good practice to review the value to ensure it is set correctly. 

Sheet Model parameters 

The Sheet Model Name entered for the sheet model is also the name that is used for the created 
design files when the One Sheet Per Design option is selected.  

Do not change the Annotation Scale value for the Sheet Model. Leave this value at 1:1, as shown at 
above. 
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Set the Detail Scale value for the Sheet Model to the desired value. This parameter should default 
to the same value used for the Detail Scale in the Place Named Boundary dialog, but it is good 
practice to review the value to ensure it is set correctly. 

After reviewing the dialog settings, select OK to continue the sheet clipping process. If Open Model is 
toggled on, the application will open the last created file upon completion. 

An example of the models generated for a Plan Only sheet configuration when using the One Sheet per 
DGN option is shown below. Note the sheet model name is the same as the design file name. 

 

Select OK to continue the sheet clipping process. 

After selecting OK, the software generates a drawing model for each named boundary. The drawing models 
are attached as references to a sheet model to generate the sheets. 

An example of a Plan-Plan sheet is shown on the following page. 
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Ohio Department of Transportation 
Office of CADD and Mapping Services December, 2021 

 

Section 800 – Plan and Profile Sheets 801-16 
 

Plan-Profile Sheets 
Plan and profile sheet clipping starts by configuring the MicroStation view windows to display both plan 
and profile information. This is facliltated using the right-mouse button menu. Hold down the right mouse 
button with the cursor positioned in a MicroStation view window until the pop-up menu appears. Select the 
2 Views Plan/Profile option as shown at right below. 

Follow the prompts to open a profile window. 

• Select OK when prompted to Create a Dynamic 
Profile View 

• Locate the plan element 
• Issue a left-click in the newly opened profile view 

to display the profile information for the selected 
alignment 

 

 

When complete two view windows displaying the plan and profile are opened like the example below. 

 

 

The named boundaries for plan and profile sheet clipping will be placed as two separate actions. From the 
OpenRoads Modeling WorkFlow, select Drawing Production > Named Boundary to initiate the process. 
The Place Named Boundary Civil Plan dialog is opened. 
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Select the first icon, Civil Plan to begin the process 
of placing the plan view named boundaries. 

The Drawing Seed is used to select the 
configuration for various plan view named 
boundaries. Select the Plan-Pro – PLAN option. 

The process to create the named boundaries for 
the plan view is the same as described previously 
in this document, with one significant difference: 

Be sure to toggle off the Create Drawing option 
before placing the named boundaries as shown at 
left. It is necessary to generate the profile named 
boundaries before creating the drawings. 
 
 
 
 
 

After the named boundaries for the plan view 
have been placed, take the following steps to 
create the named boundaries for the profile view: 
 

• From the OpenRoads Modeling 
WorkFlow, select Drawing Production > 
Named Boundary to initiate the process. 
The Place Named Boundary Civil Plan 
dialog is opened. 
 

• Select the third icon, Civil Profile to begin 
the process of placing the plan view 
named boundaries 
 

• Select the Drawing Seed that 
corresponds to the previously selected 
plan view drawing seed. In this case, 
select Plan-Pro – PROFILE as shown at 
left. 

 
• Set the Detail Scale to the desired 

horizontal plan scale, typically 1:20 or 
1:50 for most ODOT plan and profile 
sheets 
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• Set the placement Method parameter to From Plan Group 
 

• Key in the desired Vertical Exaggeration value 

The Detail Scale and Vertical Exaggeration parameters work together to determine the Available 
Profile Height parameter. 

The Available Profile Height value, as defined in the ODOT standards, is based on a profile grid 
that will measure 9” in height on the printed 22”x34” sheet. Typically, the Available Profile Height 
parameter is not changed by the user. It is best to allow the software to set this value as the Detail 
Scale and Vertical Exaggeration parameters are adjusted. 

For a typical ODOT project, 1:20 or 1:50 Detail Scale settings are the most often used values. The 
Vertical Exaggeration is then set to the desired value, typically a value of 4 for 1:20 scale plans, or 
a value of 5 for 1:50 scale plans. 

The Available Profile Height is computed as follows: 

Available Profile Height = Detail Scale * 9 / Vertical Exaggeration 

Example: A 20-scale plan with a 4:1 vertical exaggeration  

 Available Profile Height = 20 * 9 / 4 

 Available Profile Height = 45  

Occasionally other horizontal scale values are used, such as 1:5, 1:10, 1:25, 1:40, etc... In each case, 
the user must set the Vertical Exaggeration to the desired value. The Available Profile Height is 
adjusted by the software corresponding to the Detail Scale and Vertical Exaggeration values 
entered. 

For 5:1 Vertical Scale  For 10:1 Vertical Scale 
Horizontal 

Sheet 
Scale 

Vertical 
Exaggeration 

Horizontal 
Sheet 
Scale 

Vertical 
Exaggeration 

5 1 5 0.5 
10 2 10 1 
20 4 20 2 
25 5 25 2.5 
40 8 40 4 
50 10 50 5 

 

• Toggle on the Create Drawing option. 
 

• Issue a data point (left click) in the profile view. The named boundaries are displayed in the view. 
Issue a second data point to accept the named boundary placement. The boundaries are drawn in 
the profile view and the Create Drawing dialog is opened. 
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The left side of the Create Drawing dialog lists parameters related to the plan view named boundaries. The 
right side corresponds to the profile named boundaries. Most of the parameters for the Create Drawing 
dialog have been predefined in the DGN Library for the selected Drawing Seed. 

If you wish to create sheets in multiple files, toggle the One Sheet Per DGN option on and set the path for 
the sheet file location. 

The View Name parameters are used for the named views that will be created in the container file as part 
of the clipping process. These parameters are not normally changed by the user. 

Drawing Model parameters 

The Drawing Model Name is used as the seed name for each of the drawing models that will be 
created, plan and profile. The name is incremented by the software. In most cases, the default name 
is used. 

Set the Annotation Scale value for the Drawing Model to the desired value. This parameter should 
default to the same value used for the Detail Scale in the Place Named Boundary dialog, but it is 
good practice to review the value to ensure it is set correctly. 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services December, 2021 

 

Section 800 – Plan and Profile Sheets 801-20 
 

Sheet Model parameters 

The Sheet Model Name entered for the Plan sheet model (left side of the dialog) is also the name 
that is used for the created design files when the One Sheet Per Design option is selected.  

Do not change the Annotation Scale value for the Sheet Model. Leave this value at 1:1 for both 
plan and profile, as shown above. 

The Profile Annotation Group setting (shown 
at right) will default to an appropriate 
annotation group for a 4:1 vertical exaggeration. 
If a different vertical exaggeration value was 
used when placing the profile named 
boundaries, different annotation options are 
available as shown at left. 

For sheets with a 5:1 Vertical Exaggeration, 
select the Profile Grid – 10’ Vertical Labels 
option from the drop-down menu. 

 

Set the Detail Scale value for the Sheet Model to the desired value for both the plan and profile. 
This parameter should default to the same value used for the Detail Scale in the Place Named 
Boundary dialog, but it is good practice to review the value to ensure it is set correctly. 

After reviewing the dialog settings, select OK to continue the sheet clipping process. If Open Model is 
toggled on, the application will open the last created file upon completion. 

An example of the models generated for a Plan Only sheet configuration with all the sheets in one file is 
shown below. 
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An example of a plan and profile sheet is shown below. 
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Profile Annotations 
The drawing model for the profile contains the grid lines and annotations, like the example below. 

 

The annotation for the proposed profile elevations (shown across the top of the profile grid) is controlled 
by the Feature Definition assigned to profile itself in the BK design file. This feature definition defaults to 
25’ increments as shown above. This may not be desirable for 50-Scale plan and profile sheets and can be 
changed by the user. In the BK file, take the following steps to change the Annotation Group parameter: 

• Open the BK file containing the profile 
• Open the Project Explorer dialog 
• From the Project Explorer, select the OpenRoads Standards tab. 
• Expand the active design file to select the Feature Definitions > Alignment > GE_P_Alignment 

option as shown below 
• In the Properties dialog, change the Profile Feature to the GE_P_Profile 50 option as shown below 
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After making this change, it is necessary to redraw the annotation for the profile Drawing Models. Take the 
following steps in the sheet design file: 

• Open the drawing model for the first profile 
• From the Drawing Production tab, select Model Annotation > Remove Model Annotations as 

shown below 

 
• When prompted, on the cursor menu, select Yes to remove the annotations from all the profile 

drawing models. 
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• After removing the annotations, redraw the annotation by selecting the Model Annotation > 

Annotate Model command from the Drawing Production tab 
• When prompted to annotate all the drawing models, choose Yes 
• Use the Profile Grid – 10’ Vertical Labels annotation group 

 

The annotation is redrawn according to the select annotation group and the profile feature. 
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Single or Dual Profile Sheets 
OpenRoads provides options to clip a sheet containing a single profile grid on the sheet, or two continuous 
profile grids across the top and bottom of a sheet. The following options are available: 

• Pro-Pro 
• Profile Only 

The process is like creating named boundaries for the profile view detailed above. A profile view must be 
displayed to place the named boundaries. Take the following steps to open a profile window: 
 

• Hold down the right mouse button with the cursor positioned in a MicroStation view window until 
the pop-up menu appears. Select the 2 Views Plan/Profile option as shown below. 

 
 
 
 
 
 
 
 
 
 
 
 

• Follow the prompts to open a profile window. 
o Select OK when prompted to Create a Dynamic Profile View 
o Locate the plan element 
o Issue a left-click in the newly opened profile view to display the profile information for the 

selected alignment 
 
From the OpenRoads Modeling WorkFlow, select Drawing Production > Named Boundaries. On the 
Place Named Boundary Civil Plan dialog, select the Civil Profile icon. 
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From the Place Named Boundary Civil Profile dialog, take the following steps: 
 

• Select the Drawing Seed (Pro-Pro or 
Profile Only) 

• Select the Detail Scale 
• Set the Method to Station Limits 
• Left click in the Start Location dialog item 
• Identify the profile view by issuing a left 

mouse-click in the profile view 
• Define the Start Location and Stop 

Location parameters 
• Set the Vertical Exaggeration value to 4 

for 20-scale sheets, 5 for 50-scale sheets. 
The Available Profile Height parameter 
is adjusted automatically. See the Plan and 
Profile sheet section for more information. 

• Issue another left mouse-click in the 
profile view to place the named 
boundaries and initiate the process. The 
Create Drawing dialog is opened as shown 
on the following page. 
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If you wish to create sheets in multiple 
files, toggle the One Sheet Per DGN 
option on and set the path for the sheet 
file location.  

The View Name parameter is used for the 
named views that will be created in the 
container file as part of the clipping 
process. This parameter is not normally 
changed by the user. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Drawing Model parameters 

The Drawing Model Name is used as the seed name for each of the drawing models that will be 
created. The name is incremented by the software. In most cases, the default name is used. 

Set the Annotation Scale value for the Drawing Model to the desired value. This parameter should 
default to the same value used for the Detail Scale in the Place Named Boundary dialog, but it is 
good practice to review the value to ensure it is set correctly. 

 

Sheet Model parameters 

The Sheet Model Name is also the name that is used for the created design files when the One 
Sheet Per Design option is selected.  
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Do not change the Annotation Scale value for the Sheet Model. Leave this value at 1:1 as shown 
above. 

The Profile Annotation Group setting (shown 
at right) will default to an appropriate 
annotation group for a 4:1 vertical exaggeration. 
If a different vertical exaggeration value was 
used when placing the profile named 
boundaries, different annotation options are 
available as shown at left. 

For sheets with a 5:1 Vertical Exaggeration, 
select the Profile Grid – 10’ Vertical Labels 
option from the drop-down menu. 

 

Set the Detail Scale value for the Sheet Model to the desired value. This parameter should default 
to the same value used for the Detail Scale in the Place Named Boundary dialog, but it is good 
practice to review the value to ensure it is set correctly. 

After reviewing the dialog settings, select OK to continue the sheet clipping process. If Open Model is 
toggled on, the application will open the last created file upon completion. 

A drawing model is created for each of the named boundaries. The drawing models are referenced to the 
sheet model to generate the completed sheets. The drawing models contain the annotations for the profile. 
See the Profile Annotations section for details. 

An example of the models generated for a Pro-Pro sheet configuration when using the One Sheet per DGN 
option is shown below. Note the sheet model name is the same as the design file name. 

 

An example of a pro-pro sheet is shown on the following page. 
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Bridge Site Plan 
Bridge site plans can be generated using a container file or directly in the SP file. When the bridge site plan 
will consist of more than one sheet, the preferred process is to use a container file. See the File Types and 
Usage section of this document for more information on container files. 

The OHDOT Create Design Files application is used to create the design file as shown below. 

If a container file is used to generate multiple sheets, key in the appropriate 000, 100, 200, etc. File Suffix. 
The application will automatically set the Seed file to the Design Seed as shown below. 

 

If a container file is not used, the File Suffix is set to the appropriate number for the site plan design file, 
001 in the example below. The application will default to the Sheet Seed. Be sure to change the Seed file to 
the Design Seed as shown below. 
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After creating the file, the next step is to attach the necessary design file references for the site plan. 

Like the plan and profile sheet clipping process, configure the MicroStation view windows to display both 
plan and profile information. This is facliltated using the right-mouse button menu. Hold down the right 
mouse button with the cursor positioned in a MicroStation view window until the pop-up menu appears. 
Select the 2 Views Plan/Profile option as shown below. 

Follow the prompts to open a profile window. 

• Select OK when prompted to Create a Dynamic 
Profile View 

• Locate the plan element 
• Issue a left-click in the newly opened profile view 

to display the profile information for the selected 
alignment 

 

 

When complete two view windows displaying the plan and profile are opened like the example below. 

 

In this example, the horizontal geometry is defined in the \roadway\basemaps\102930_BK001.dgn file. 
Graphics that have been drawn in the profile window of the BK file will also be displayed here. 

This example will make no attempt to define the bridge profile graphics or recommend a best practice for 
generating these graphics. The graphics can be drawn in the profile view in the SP design file. The Create 
3D Cut command may also be used to read the Design-3D model and will display and 3d graphics 
encountered in the model. 
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The named boundaries for plan and profile sheet clipping will be placed as two separate actions. From the 
OpenRoads Modeling WorkFlow, select Drawing Production > Named Boundary to initiate the process. 
The Place Named Boundary Civil Plan dialog is opened. 

 

Select the first icon, Civil Plan to begin the 
process of placing the plan view named 
boundaries. 

The Drawing Seed is used to select the 
configuration for various plan view named 
boundaries. Select the Bridge Site Plan option. 

The process to create the named boundaries for 
the plan view is the same as described 
previously in this document. 

Be sure to toggle off the Create Drawing option 
before placing the named boundaries as shown 
at left. It is necessary to generate the profile 
named boundaries before creating the drawings. 

 

 

 

 
 

After the named boundaries for the plan view have been placed, take the following steps to create the 
named boundaries for the profile view: 
 

• From the OpenRoads Modeling WorkFlow, select Drawing Production > Named Boundary to 
initiate the process. The Place Named Boundary dialog is opened. 
 

• Select the third icon, Civil Profile to begin the process of placing the plan view named boundaries 
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• Select the Drawing Seed that corresponds to the previously selected plan view drawing seed. In 

this case, select Bridge Site Plan – PROFILE as shown at left. 
 

• Set the Detail Scale as desired. The Vertical Exaggeration and Available Profile Height 
parameters are automatically defined based on the selected Detail Scale. See the Plan and Profile 
Sheet section for more information. 
 

• Set the placement Method parameter to From Plan Group.  
 
The boundary is displayed as shown in the example above. The software determines the vertical 
location of the profile named boundary. Depending on the vertical extent of the profile graphics, the 
default placement location may need to be adjusted. 
 

o If the displayed boundary location is acceptable, toggle on the Create Drawing option 
before placing the boundary to proceed to the next step. 

o If the profile vertical location needs to be adjusted, toggle off the Create Drawing option 
before placing the named boundary. After placing the boundary, the Adjust Profile Named 
Boundary tool is used to adjust the vertical location of the boundary element as described 
below. 

To adjust the named boundary vertically, select the Adjust Profile Named Boundary command from the 
Drawing Production tab as shown below. 
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Select the named boundary element to adjust. The named boundary floats on the cursor and can be 
adjusted vertically based on the Elevation Datum Spacing parameter. Issue a left click (data point) to 
move the named boundary to the desired location. 

 
After adjusting the named boundary, the Manage Named Boundaries command is used to resume the 
sheet clipping process. Select the small icon in the lower right corner of the Named Boundaries group as 
shown below. 

 
From the Named Boundaries dialog, select the Plan Group to process. Toggle on the Show the Create 
Drawing icon and then select the Create plan/profile drawing icon. 
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The Create Drawing dialog is opened as shown below. 
 

 
The parameters, highlighted above, must be adjusted before selecting the OK button. 
 

• If you are using a container file to place the named boundaries and will be generating separate SP 
files: 
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o Enter a Name according to the OHDOT Standard File names for the sheet type you wish to 
create. See the Location & Design Manual, Volume 3 – Highway Plans, Section 1204.3.4 
for more information. 

o Toggle on the One Sheet Per Design option and select the discipline\sheets\ folder where 
the sheet design files are to be created. 

• Set the Drawing Model Annotation Scale parameters, and the Sheet Model Detail Scale 
parameters to the intended scale for both the plan and profile settings as shown in the example 
above. 
 

• The profile Annotation Group parameter is defaulted to the appropriate value for 20 Scale sheets 
with a 4:1 vertical exaggeration. 
 
For 20-Scale bridge site plans with a 1:1 vertical exaggeration, select the Profile Grid – 20’ Vert 25’ 
Horiz Lines-20’ Vert 100’ Horiz Labels  option from the drop-down menu. 
 
For 10-Scale bridge site plans, select the Profile Grid - 10' Vert 10' Horiz Lines-10'Vert 50'Horiz 
Label option from the drop-down menu. 

 
• Select OK to initiate the process. 

 
The bridge site plan sheet is generated like the example below. 
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Notes: 

• If using a Container file for the named boundaries and the references: 
o Each sheet design file contains a Drawing model for each of the named boundaries, one for 

the plan and one for the profile 
o The Drawing models reference the original Container file 
o The Sheet model references the Drawing models 

• If the named boundaries and the references are defined in the SP file: 
o Each SP design file contains a Drawing model for each of the named boundaries, one for the 

plan and one for the profile 
o The Drawing models reference the design model in the SP file 
o The Sheet model references the Drawing models 

• In either case, the profile drawing model includes both the grid lines and the annotation for the 
profile 
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Terrain Model Contour Interval 
If the existing ground terrain model contours will be show on the site plan, it is possible that the interval 
for the contour lines as saved in the survey “FB” design file may be set to display the contour interval that is 
required for the bridge site plan. Changing the contour interval display can be accomplished by using the 
terrain model Override Symbology setting. 
 
Select the terrain model boundary and choose the Properties command from the pop-up menu. 
 

 
Change the Override Symbology setting to Yes. 
 

 
The Override Template option is used to choose the Element Template with the contour interval that will 
be used to override the current settings as saved in the “FB” design file. 

 
After selecting the element template, the changes are applied in the active design file. Note that the 
triangles may also be turned on when changing this setting and can be turned off using the MicroStation 
Level Display dialog. 
 
Note that OpenRoads adjusts the major contour text annotation location dynamically based on the view 
extents. This may result in text falling into locations that are undesirable. Unfortunately, there is no way to 
know where the text is going to fall on the printed sheet until the sheet is printed. There are two options to 
address this issue, both of which are accomplished by editing the element template that has ben copied into 
the active design file when the override template was selected. 
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1. Adjust the major contour text spacing. This option may not solve the problem as all it does is move 
the text to a different spacing interval. 

2. Turn off the display of the major contour text and then manually annotate the major contour lines 
by placing the text at the desired location 

 
In either case, the first step is to edit the element template that has been copied into the local file. From the 
Home tab, select the Manage command from the Element Template drop-down menu as shown below. 

 
 

The Element Templates dialog is opened. Browse to the 
Terrain Models group to edit the template that had been 
copied into the design file as shown below. 
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• Change the TextInterval option to a different value to adjust the text spacing. 
 

• To turn off the text, toggle the Display Text option to No. Note: You may also have to change the 
TextInterval value for this change to take effect. 

If you elect to turn off the text display, the Terrain > Labeling > Label Terrain Contours command is 
used to place contour labels at the desired locations by dragging a line through the contour(s) that are to be 
labeled. An example is shown below. 
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Named Boundaries and Saved Views 

When the named boundaries are processed to generate the sheets, the software also creates a MicroStation 
saved view for each named boundary. The saved views can be reviewed by selecting OpenRoads Modeling 
> View > Saved Views as shown below. 

 

The Saved Views dialog is opened, as shown below. 

 

The saved views are named according to the name that is entered in the sheet generation process on the 
Create Drawing dialog. 
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Reprocessing Sheets 
Occasionally it may be necessary to reprocess a set of sheets. The previously placed named boundaries can 
be reused, however, if the same name is used for the sheet files the software does not overwrite the 
previously created saved views, models, or design files. The user must delete the previously generated 
saved views, models, and design files before reprocessing the named boundaries. 

If the sheets are all in one file, take the following steps before reprocessing the named boundaries: 

• Open the Saved Views dialog. Delete the saved views corresponding to the sheets to be reprocessed 
• Open the Models dialog. Delete all the drawing and sheet models corresponding to the sheets to be 

reprocessed 

If the sheets are in separate design files, take the following steps before reprocessing the named 
boundaries: 

• In the KC design file, open the Saved Views dialog. Delete the saved views corresponding to the 
sheets to be reprocessed 

• Delete all the sheet design files in the \discipline\sheets\ folder that are to be reprocessed 

Tip for ProjectWise users: Before deleting files, in ProjectWise Explorer right-click on the file 
name and choose the Purge Local Copies option. 

The Named Boundaries dialog is used to reprocess the sheets from the previously placed named 
boundaries. 

• From the OpenRoads Modeling WorkFlow, select Drawing Production > Named Boundaries as 
shown below. The Named Boundaries dialog is opened. 
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• Select the Plan Group to be processed.  
• Toggle on the option to Show the Create Drawing Dialog 
• Select the appropriate icon to open the Create Drawing dialog (Create plan drawing, Create 

Profile drawing, Create plan/profile drawing). The Create Drawing dialog is opened and can be 
processed as previously detailed in this document. 
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Level Management 

Managing Sheet Design File Levels from the Container File 
Managing levels across multiple drawing and sheet models with multiple references (both direct and 
nested) can be confusing. When sheets are assembled, the reference files are attached as follows: 

Basemaps > Container File (Design Model) > Sheet File (Drawing Model) > Sheet File (Sheet Model) 

By default, the ODOT sheet clipping DGN Libraries are configured to allow users to manage the levels 
displayed on the completed sheets from the container file. This allows users to configure the levels 
displayed in the final sheets from a single location, the container file, with the changes reflected in every 
plan or profile sheet. 

The 2021 Release 1 version of OpenRoads enhances this functionality with significant improvements: 

• A new option has been added for reference attachments to synchronize the view settings from the 
attached file. The parameter is found in the Attachment Properties dialog for the selected 
reference file. Double-click the reference file name in the References dialog to access the 
Attachment Properties dialog shown below. 
 
The Settings From Design Model parameter has been configured as the default setting in the 
OHDOT Standards. 
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• The Settings From Design Model parameter also allows the view attributes settings in the 
container file to be reflected in the sheets. This allows turning off the display of construction class 
elements (Constructions) container file’s View Attribute settings to carried through to all the 
sheets. 

• Adding or removing reference attachments is reflected in the completed sheets 

Tip: Use View 1 when turning on or off plan view levels in the container file for the level changes to carry 
through to the drawing and sheet models. 

 

  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services December, 2021 

 

Section 800 – Plan and Profile Sheets 801-47 
 

Sheet Annotation 

Bentley’s recommended workflow is for sheet annotations to be placed in the drawing models, not in the 
sheet models. 

Plan View Alignment Annotation 
Alignments are often annotated in the geometry basemap (BK) design file. These annotations can be shown 
on the completed sheets, however, editing the annotation in the BK file may impact other sheets in the 
WorkSet. 

The example below shows the drawing model containing the plan view portion of a plan and profile sheet. 
The alignment annotation is referenced from the BK design file. 

 

In this example, the curve data is partially clipped due to the named boundary limits. This can be resolved 
as follows: 
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Option 1 – Edit the Named Boundary. 

Named boundaries can be edited, but there are limits to how much editing can be done. The boundary is 
chorded around a curve. In the example below, the vertices were deleted using the MicroStation Delete 
Vertex command. In this example, the named boundary was deleted so that the referenced curve data 
annotation is not clipped. 

 

Option 2 – Place the Alignment annotation in the container file’s Design Model 

While this is not significantly different than alignment data placed in the geometry basemap, it does allow 
the user to move or delete unnecessary annotations without impacting other sheets. 

Option 3 – Place the Alignment Annotation in the various Drawing Models 

Using this option, the alignment is annotated in the drawing models for the limits of the named boundary. 
This method is advantageous because the annotation for each sheet is controlled by the drawing model for 
the sheet. 

Take the following steps to use this option: 

• From the container design file, turn off the alignment annotation levels from the attached BK file(s). 
 

• In the drawing model for one of the sheets, from the Drawing Production tab, select the Annotate 
Element command. Select the alignment element to be annotated. OpenRoads version 10.10 adds 
the ability to annotate the element in multiple drawing models, as shown below. 
 

Follow the prompts to annotate the selected 
alignment(s). 
 
 

 
• Edit the annotation in the drawing models as necessary for each sheet 
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• Annotations added to the drawing models are not automatically visible in the sheet models. The 
attachment of the design model to the sheet is a “direct reference”, not a “nested reference”. As 
such, the level display is not automatically synchronized as nested references are. It is necessary to 
turn the annotation levels on for the drawing model attachment in each sheet model 

 

Plan View North Arrow Annotation 
The north arrow symbol is placed in the plan view as part of the drawing model annotation. The location of 
the north arrow is defined in relation to the alignment. 

The May 1, 2020 release of the OHDOT CADD Standards removed the north arrow placement block from 
the upper right corner of the sheet borders. It is no longer necessary to move the north arrow cell from the 
default location as defined in ODOT’s CADD Standards to the upper right corner of the sheet border. 

 

Civil Labeler 
A new annotation tool, Civil Labeler, has been added to the 2021 Release 1 version of ORD. As of this 
writing, the function is in a “tech preview” status as the tool is refined. The Civil Labeler can be accessed 
from the OpenRoads Modeling WorkFlow by selecting Drawing Production > Labels > Civil Labeler 
from the ORD Ribbon menu. 

 

When the command is selected, the Civil Labeler Tool dialog is opened with the 
OHDOT_Civil_Labeler.xml file loaded as shown below. 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services December, 2021 

 

Section 800 – Plan and Profile Sheets 801-50 
 

 

The xml file is configured with multiple folders containing multiple label definitions as shown above. Each 
folder contains multiple labels. It is beyond the scope of this training guide to document each label option. 
A few of the common labels will be documented below. Contact the CADD and Mapping Support team with 
questions or requests to add additional labeling options. 

Cross Section and Drainage and Utilities labels will not be covered in this document. 

ODOT recommends placing most labels in the various Drawing models for the sheets. Labels should not be 
placed in the sheet model. 

When a label is selected, the dialog presents several options to the user like the example below. 
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It is beyond the scope of this manual to document every option. The ODOT labels have been configured 
with the default options most used for each label type. Examples of commonly used labels are included 
below. 

Plan – General Labels 
This group of labels provides label options for annotating the centerline or construction limits. An example 
is shown below. 

 

Plan – Intersection Labels 
The Plan – Intersection group includes options to label the station of a point at the intersection of two 
alignments. In the example below, the user is prompted to select each alignment. The annotation is placed 
at the location defined by the user. 
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Plan – Linear Labels 
Various labels are available to annotate curvilinear elements as shown below 
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Plan – Points Labels 
Various label options are provided for the annotation of points. In cases where a station and offset is to be 
annotated, after selecting the Place command it is required that you select the geometry element to be used 
as the station and offset reference. 

An example using the Station-Offset label is shown below. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services December, 2021 

 

Section 800 – Plan and Profile Sheets 801-54 
 

Plan – Profile Elevation Labels 
Several labels have been constructed to annotate profile elevations in the plan view. The Elevation – Along 
Geometry – Radial Leader LT option is shown below. 

 

Plan – Project Flags Labels 
The Plan – Project Flags group includes several labels as shown below. 
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Profile Labels 
The Profile labels are configured for the profile drawing model. Various labels are provided as shown 
below. 
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Computed Labels 
With the 2021 Release 1 version of OpenRoads Designer, ODOT recommends using the new Civil Labeler 
tools. This section is retained in the document for reference. 

The Place Label command, located in the Drawing Production tab as shown below, is used to place 
various labels for plan production.  

The labels contain Text Favorites which compute the value of the label based on selected geometry. 

 

When the command is selected, the Place Label Settings dialog is opened as shown below. 

 

Two icons are provided to place labels with or 
without a leader line. 

The Type option is used to select placing either a 
label composed of a Text Favorite, or a label 
composed of a cell. An example of placing a cell is 
shown in this document. 

The Cell Name parameter is used to select the label 
type. Several labels have been configured for ODOT 
users. The process to create labels is not documented 
in this manual. 

 

Cells that have been configured as labels are named with an “_Lbl” prefix. Additional labels can be 
configured as requested. 

The Dimension Style parameter is used to define the leader line for labels placed using the Place Label 
with Leader option. Two leader line dimension styles have been configured as shown below: 

• _Lbl_Leader_Line 
• _Lbl_Leader_Line_With_Terminator 

The Label Rotation parameter is used to set the rotation of the label relative to the leader line: Horizontal, 
Vertical, or Inline. 

Start At defines whether the label placement starts from the terminator of from the cell. 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services December, 2021 

 

Section 800 – Plan and Profile Sheets 801-57 
 

The Horizontal Attachment parameter sets the leader attachment side: Auto, Left or Right. 

The three icons at the bottom of the dialog are as follows: 

Annotation Scale 
Turns on annotation scale. When this lock is on, the annotation scale is applied to the label. 

Place Label With Regular Association 
Sets regular association with the element. If you place a label with this setting turned on and the Place 
Label With Relative Association turned off, the label is placed with regular association. In this case, if you 
move the element, the label remains at the same place, only the leader line moves along with the element. 

Place Label With Relative Association 
(Enabled only when Place Label With Association is enabled) Sets relative association with the element. 
If a label is placed with relative association with an element, the label will stay at the same location relative 
to the original snap point. That is, if you move the element the label will also move with it. 

To Place a Station and Offset Label with a Leader 
• Select the Place Label With Leader icon. 

 
• Select the Type value Cell with the Cell Name of _Lbl_Pln_Sta-Off 

 
• Set the Dimension Style, Label Rotation method, and Horizontal Attachment method. 

 

• (Optional) Select Place Label With Regular Association and then select Place Label With 

Relative Association .  
 

• Enter a data point to select the alignment element that will be used to compute the station and 
offset values.  
 

• Enter a data point to place the label with leader line. 
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Several label types have been configured in the OHDOT standards. Additional labels can be configured upon 
request. 
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Section 801 Plan and Profile Sheet 
Exercise 

Exercise 1: S.R. 185 Plan and Profile Sheets 

Part A: Sheet Design Files 
 
Take the following steps to create the design file for the plan and profile sheets: 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 402-Engineering\Roadway\Basemaps\ folder.  
• Open the file 123456_BK001.dgn 
• Select the Ohio DOT Workflow 
• Select the OHDOT Create Design Files application 

 
 

• Create the sheet design file for S.R. 185 using the settings below: 
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o When the File Suffix value of 100 is entered, the application will change the selected seed 

file to use the 123456_DesignSeed2d.dgn file. 
o Select Settings > Open Last Created File 
o Select the Create Files option 

The new file is created in the 402-Engineering\Roadway\Sheets folder 
 

• When prompted, check the current file back into ProjectWise 
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Part B: Plan View References 
 

• From the OpenRoads Modeling WorkFlow, select Home > Attach Tools > References to attach 
the files with the plan view information. Start by attaching the Survey Field Book (FB) design file 
from the following folder: 
 

300-Survey\Basemaps\123456_FB001.dgn 

• When selecting the references, set 
the Attachment Method to 
Interactive. This will open the 
Reference Attachment dialog for 
each file as it is attached. This is 
necessary to review and set the 
Nested Attachments parameter 
for each file. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• From the Reference Attachment dialog, set the Nested Attachments parameter to No Nesting.  
 

• After attaching the Survey Field Book design file (FB) set the terrain model as the active terrain by 
selecting the terrain model element and choosing the Set As Active Terrain Model icon from the 
pop-up menu. 
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• The 3D model will not be displayed on the sheets. From the References dialog, turn off the display 
of the Design-3D model. 

 
• Attach the following files using the Nested Attachments setting of No Nesting: 

o 401-Engineering\Roadway\Basemaps\123456_BK001.dgn (CL Proposed S.R. 185) 
o 401-Engineering\Roadway\Basemaps\123456_BK002.dgn (CL Existing St. Peter Road) 
o 401-Engineering\Roadway\Basemaps\123456_BK003.dgn (CL Proposed Jameson Road) 
o 401-Engineering\Roadway\Basemaps\123456_KM001.dgn (S.R. 185 Corridor Model) 
o 401-Engineering\Roadway\Basemaps\123456_KM002.dgn (St. Peter Road Corridor 

Model) 
o 401-Engineering\Roadway\Basemaps\123456_KM003.dgn (Jameson Road Corridor 

Model) 
o 401-Engineering\RW\Basemaps\123456_BR001.dgn (Existing Righ-of-Way) 

 
• After the references are attached, from the Home 

tab, select the Level Display icon to turn on/off the 
levels that you wish to display in the Plan View of the 
sheets. 

o Select each reference file to turn on/off the 
desired levels 
 

• Select File > Save Settings after you have completed 
the task of turning on/off the levels 
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Part C: Profiles 
A profile window must be displayed to lay out the named boundaries for the profile portion of the sheets. 
Take the following steps to open the profile window: 
 
 Hold down the right-mouse button in the view window to access the menu shown below. 

o Select the 2 Views Plan/Profile option and follow the prompts to open a profile view for 
the S.R. 185 Alignment 

 
 If the profile is not displayed in the profile window, use the Level Display dialog (Home > Level 

Display) to turn on the levels for the existing and proposed alignments and then choose the Fit 
Profile Elements command from the profile window. 

 
The profile is now ready to define the named boundaries. 
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Part D: Plan View Named Boundaries 
MicroStation Named Boundaries are placed to define the limits of each plan and profile sheet. 
 
When the named boundaries are placed, they are spaced according to the Starting Location station value 
and the Length the selected sheet configuration file. 
 
In some cases, placing the named boundaries from start to finish may result in boundaries that fall with the 
match line locations in the middle of a bridge or intersection. 
 
Take the following steps to define the plan view named boundaries as a continuous run for S.R. 185: 
 
 From the Drawing Production tab, select the Place Named Boundaries command 

 
 From the Place Named Boundary 

command, take the following steps: 
 

o Select the Civil Plan icon (first 
icon at the top of the dialog) 
 

o Set the Drawing Seed to use the 
Plan-Pro - PLAN option 
 

o Toggle off the Create Drawing 
option at the bottom of the dialog. 
 

o Click inside the Start Location 
key-in field 
 

o Left-click on the plan view 
alignment graphic for S.R. 185. The 
dialog will track the start location 
station value relative to the cursor 
location 
 

o Key in a Start Location value of 
385+00 
 

o Key in a Stop Location value of 
430+00 
 Note that the default Length parameter for the Plan-Pro - PLAN option is 500’. If 

the value does not default to an even 500.0’, change the parameter setting in the 
dialog. 
 

o Issue a left-click in the plan view. 
 This will display the named boundaries before they are placed in the file. 
 Issue a left-click in the plan view (it may take two clicks) to accept the placement of 

the first two named boundaries. 
 The Place Named Boundaries dialog is automatically closed 
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Part E: Profile Named Boundaries 
Take the following steps to define the profile view named boundaries for S.R. 185: 
 
 From the Drawing Production tab, 

select the Place Named Boundaries 
command 
 

 From the Place Named Boundary 
command, take the following steps: 

o Select the Civil Profile icon 
(third icon at the top of the 
dialog) 
 

o Set the Drawing Seed to use 
the Plan-Pro 20 - PROFILE 
option 
 

o Set the Method to From Plan 
Group  
 

o Toggle On the following 
options: 
 Use Terrains 
 Use Active Vertical 
 Whole Conduits Only 
 Create Drawing 
 Show Dialog 

 
o Issue a left-click in the profile 

view (it may take three clicks) 
to accept the placement of the 
named boundaries for the 
profile. 
 

 
The boundaries are placed like the example below.  

 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services April, 2021 

 

Section 800 – Plan and Profile Sheets 801-8 
 

Part E: Create Drawing 
If the Show Dialog option is toggled on as shown on the previous page, the Create Drawing dialog is 
opened. 

 

 Toggle on the One Sheet Per Dgn option if you desire to create a new design file for each sheet. 
When this option is toggled on, the name entered for the plan view Sheet Model > Model Name 
parameter is used to create each sheet design file. 
 
ODOT recommendation: When using the One Sheet Per Dgn option, enter the Sheet Model > 
Model Name value using the PID number for the project with the two-character code for the sheet 
type and a three-digit number. 
 

Example: 123456_GP101 
 

 Set the Drawing Model Annotation Scale and the Sheet Model Detail Scale parameters for both 
the plan and profile to the desired scale as shown above. Do NOT set the Sheet Model Annotation 
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Scale value. Leave this parameter at 1:1 as shown above. 
 

 Select the OK button to initiate the sheet creation process. 
 
A drawing model is created for each named boundary. A sheet model is created for each sheet. The 
plan and profile drawing models are referenced to the sheet model  
 

 Review the drawing and sheet models by choosing the model name from the Models dialog, as 
shown below. 

 
An example of a completed sheet is shown below. 
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This completes this exercise. Exit OpenRoads Designer and check the file back into ProjectWise. 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services May, 2024 

 

Section 802 – Cross-Section Sheets 802-1 
 

Section 802 Cross-Section Sheets 
Cross-Section Sheet Process Overview 

The process to generate cross-section sheets is very similar to the plan and profile sheet process. 

OpenRoads designer uses MicroStation Named Boundaries to define the cross section clipping areas. The 
named boundaries are placed in a 3D Design model relative to a selected alignment. 

The example below shows the 3D Named Boundaries placed relative to the St. Peter Road 3D model. 

Before generating the named boundaries, a design file is created as a “container file” to attach references 
and place the named boundaries for the cross-section locations. The 3D model must be displayed in order 
to create the named boundaries. The cross sections are cut from the 3D model. In the example above, the 
geometry, survey, and corridor model basemaps are attached to the plan view with the 3D model displayed. 
The named boundaries are placed in the 3D model relative to a selected alignment.  

When the sheets are generated, the software creates a MicroStation drawing model for each named 
boundary. An example of the drawing model for a cross-section is shown below. 

 
The drawing models are referenced to a sheet model with a sheet border to assemble the completed cross-
section as shown in the example below. 
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The sheet model is intended for plotting or PDF generation. Most annotations should be placed in the 
various drawing models, not in the sheet models. 
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File Types and Usage 
A “container file” is used to attach references for the information that will be shown in the cross sections as 
well as to place the named boundaries for the cross-section locations. 

Sheets can be clipped into the container file itself, or clipped into multiple files, one sheet per design file, if 
desired. 

Each container file is used to generate the sheets for a single alignment. For example, a project with three 
alignments would typically use three container files as detailed below: 

Design File Usage Models Used 
XS000 Container file for S.R. 185 Design 
XS001, XS002, XS003… Cross-section sheets for S.R. 185 Drawing and Sheet 
 
XS100 Container file for St. Peter Road Design 
XS101, XS102, XS103… Cross-section sheets for St. Peter Road Drawing and Sheet 
 
XS200 Container file for Jameson Road Design 
XS201, XS202, XS203… Cross-section sheets for Jameson Road Drawing and Sheet 

 
The references are attached as illustrated below. 
 

 
 
The container file is used to control the reference attachment and level display settings for all the sheets 
from one location. More information on level display can be found in the Level Management section of this 
document. 

It is possible to put the named boundaries for multiple alignments in one container file if all the sheets will 
share the same reference attachments and level display settings.  

Basemap Files
The various basemap 
design files (survey, 

alignments, drainage, 
etc.) are used to draw 

the existing and 
proposed information 

for the project.

Container File
The container file's 

design model is used 
to attach the various 
basemap design files 
as references, and to 

place the named 
boundaries for the 

cross-sections.

Sheet File
The drawing models in 

the sheet file 
references the 

container file's design 
model. The drawing 
models are used for 
sheet annotation.

The sheet model self-
references the sheet 
design file's drawing 
models. The sheet 

models are used for 
the sheet border and 

for plotting.
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End Area Volumes 
End areas can be extracted from the 3D model for each named boundary and included on the completed 
sheets. This process requires 3D mesh elements for the cut and fill areas. The 3D mesh elements should be 
created in a separate design file. These 3D meshes are normally created before starting the sheet clipping 
process. 
 
 

Cross-Section Sheet Summary 
The steps to generate cross-section sheets are summarized below: 

1. If the end area quantities are to be displayed, create a design file to contain the 3D mesh elements 
and run the Create Cut Fill Volumes command 

2. Create a design file to act as the container file 
3. In the container file, take the following steps to prepare for clipping the cross-section sheets: 

a. Attach the various design files containing the 3D models and survey information, 
underground utilities, 3D right-of-way lines, etc. that will be shown on the cross-sections. 
Also attach the design file containing the 3D mesh volume elements 

b. Assign the existing ground terrain model as the active terrain 
c. Open a 3D view of the model 
d. Toggle on/off the Global Display of the levels in the Design-3D model that you wish to be 

displayed in the cross-sections. 
e. Create Named Boundaries for the cross-section locations, but do not create the sheets yet. 
f. If end area quantities are to be displayed, run the End Area Volume report. Each named 

boundary is tagged with quantity values 
4. Create the cross-section sheets. The sheets can be generated into the active design file (the 

container file) or into separate design files. 
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Create Cut and Fill 3D Meshes 

The Create Cut Fill Volumes command is used to generate 3D mesh elements for the cut and fill volumes. 
These elements are required to generate end area volumes for the cross-section sheets. This training guide 
will document the process to create simple cut/fill quantities. 
 
An example of the 3D mesh elements is shown below. 
 

 
 
 
The 3D mesh elements are generated in the Roadway Digital Terrain Model file type. 
 
When using the OHDOT Create Design Files application the Seed option will default to the DesignSeed3d 
file. Change this to the DesignSeed2d option as shown below. 
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After the file is created, the next step is to attach the design files as a reference that contains the existing 
ground terrain and the proposed corridor models. 
 
The Create Cut Fill Volumes process will compare the lowest proposed component to the active terrain to 
generate 3D prismoid volumes. Be sure to set the existing ground terrain as the active terrain before 
running the command. The command is accessed by selecting OpenRoads Modeling > Home > Civil 
Analysis > Create Cut Fill Volumes. 

 
 

The tool settings for the command are shown at left. 
 
Accept each option by issuing a left click as each option is 
presented on the cursor. 
 
The 3D mesh elements for the cut and fill volumes are placed in 
the 3D model like the example shown on the previous page. 
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Creating the Container File 

Design files are created using the OHDOT Create Files application. The application is accessed from the 
Ohio DOT WorkFlow by selecting the New Design File icon. 

The application is opened as shown below. 

 

In the example above, the file suffix of 000 has been entered for the Cross Sections sheet type. The 
application recognizes the 000, 100, 200, etc. series as container files and has automatically switched the 
Seed file to the appropriate design seed for the WorkSet. 
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Reference Attachments 
After creating the new design file for the cross section named boundaries, attach the references necessary 
to generate the cross sections. 

As a minimum, the following files will need to be attached: 

• Survey basemap containing the existing ground terrain model. 
o Note: Be sure to set the existing ground as the active terrain after the file is attached. This 

will create a 3D model in the active cross section sheet design file 
• Geometry basemap containing the alignments 
• Corridor Modeling basemaps containg the applicable corridors 

Several additional files may be included as attachments depending on the project: 

• Any other files that contain 3D information (utilities, right-of-way, etc.) that is to be displayed on 
the cross sections 

• The design file that contains the prismoidal volume areas, which is required to display end-area 
quantities on the sheets 

After the references are attached, it is necessary to configure the view windows to display both plan and 3D 
model information. Hold down the right mouse-button with the cursor positioned in a MicroStation view 
window until the pop-up menu appears. Select the 2 Views Plan/3D option as shown below. 

 

The graphics that will be displayed on the clipped cross sections are controlled by what is displayed in the 
3D view. Toggle on/off the desired levels in the 3D view before proceeding. 
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Named Boundaries 
Sheets are clipped using Named Boundary tool. From the OpenRoads Modeling workflow, select the 
Drawing Production tab to access the Named Boundary tool as shown below. 

Note: The Named Boundary tool can also be accessed from most of the default workflows provided within 
ORD. 

The Place Named Boundary Civil Plan dialog is opened as shown below. 

 

The top of the dialog contains several icons to 
select the type of named boundary that you wish to 
place.  

The following icons will be discussed in this 
document: 

  Civil Cross Section 

  Civil Cross Section 2 Points 

 

 

 

 

 

 

Note: Toggle the Create Drawing option off if generating end area volume quantities to be displayed on 
the cross-section sheets. The Named Boundaries must be placed before running the End Area Volumes 
Report. See End Area Volume Report for more information. 

Select the fourth icon, Civil Cross Section to begin the process of placing the cross section named 
boundaries. The Drawing Seed item is used to select the configuration for placing the cross section named 
boundaries. Currently ODOT has two options that are available to define the named boundaries for cross 
section sheet clipping. 

o Cross Sections 5-Scale 
o Cross Sections 10-Scale 
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Issue a left mouse-click in the Start Location Field. And then select the desired alignment that will be used 
as the centerline for the cross-section clipping. The Start Location value will dynamically change as the 
cursor is moved within the view window. Note that the second Name field will change from “Untitled”, as 
shown above, to the name of the selected alignment. 

• Identify the desired Start Location by issuing a data-point within the view, by keying in a station 
value, or by selecting the icon to the right of the Start Location field to lock the starting location to 
the beginning of the selected alignment. 

After the Start Location has been established, identify the desired Stop Location. As the cursor is moved, 
the Stop Location will track the station value relative to the cursor position. Clipping borders are 
dynamically displayed as the cursor is moved. The stop location can be entered by issuing a right-mouse 
click in the view, keying in the desired station, or by selecting the icon to the right of the Stop Location 
field to lock the ending location to the end of the selected alignment. An example is shown below. 

Create Drawing 
This option is used to initiate the process to create the sheets after the named boundaries are placed.  

• Turn this option OFF if you want to update the named boundaries with the end area quantities 
before generating the sheets. See the End Area Volume Report section. 

• Turn this option ON to generate the sheets without any end area values. The end areas can be 
updated later as detailed below. 
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Placing the Named Boundaries 
After the parameters in the Place Named Boundaries dialog has been defined, it takes two left-mouse 
clicks to initiate the named boundary placement. 

• Issue a left mouse-click to accept the Start and Stop Location values 
• Issue another left mouse-click to accept the named boundary placement. Named boundaries are 

drawn in the 3D view representing the clipping limits for each cross section as shown below 

If the Create Drawing and Show Dialog options 
are toggled on, the Create Drawing dialog, shown 
at left, is opened. 

Toggle in the One Sheet Per DGN option if desired 
and set the path for the new cross-section sheets. 
When this option is selected, the Sheet Model > 
Model Name parameter is used to specify the 
name of the cross-section sheet design files. 

Check to ensure that the Drawing Model 
annotation scale and Sheet Model Detail Scale 
parameters are set properly for the corresponding 
cross-sections. 

Always set the Sheet Model annotation scale 
parameter to 1:1 as shown at left. 

Select OK to initiate the sheet clipping process. 

Open Model 
• Turn this option OFF if you don’t want this 

process to open the last generated sheet. 
• Turn this option ON if you want this process 

to open the last generate sheet. 
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Deleting Named Boundaries 
The Named Boundaries tool as you’ll notice can be found under various workflows. But it will always be 
located under either the View tab or Drawing Production tab. For this example, we will be using the 
OpenRoads Modeling workflow. 

 

 

 

Open the Named boundaries Manager by clicking the Open Dialog arrow.  

 

 

 

 

 

The Named Boundary Manager dialog shows all the 
named boundaries that have been placed within the dgn 
file that they were generated.  

To delete these named boundaries right click and 
highlight the boundary then hit the red “X”.   

 

 

 

 

You will then be prompted with a warning 
dialog (shown below). Once you click “yes” the 
named boundary will be deleted from the 
Named Boundaries Manager and the Saved 
View will be deleted from the Saved View 
Manager the dgn.  
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Sheet Clipping Models and Saved Views 
After clicking the OK button within the Create Drawing dialog software creates a drawing model that 
contains the cross-section annotations which is automatically generated. Also, within this process the 
software will create a “snapshot” of the cross sections design-3D model which is considered a Saved View. 
This will be done for each cross-section. 

Cross Section Sheet models  
These consist of  

• Sheet borders.  
• Referenced Cross section drawing models. 
• Sheet totals for seeding, cut, and fill. 

Note: No annotations should be placed within the 
sheet model apart from the listed above. 

 

The Models dialog (Home > Models) can be used to review each of the newly created model, as shown 
below. The software will attempt to place as many cross-sections as possible on the sheets. 
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Note: The spacing above and below each cross-section, 
within the grid lines, is set in the Place Named Boundary 
dialog by setting the Top Clearance and Bottom 
Clearance values. The default values for the bottom 
clearance have been set to account for the presence of 
underground utilities, however, the value represents a 
default setting and may not be appropriate for all cases.  

 

 

 

 

 

The spacing between the cross sections is set by a configuration variable. 

 

 

 

 

 

 

 

 

 

 

Saved Views 
The Saved Views tools can be accessed under various workflows under the Drawing Production tab. The 
Saved View tab gives you the ability to apply views as well as to create new views that you can recall later. 
Views display as thumbnails sorted alphabetically. You can filter the list by using the search bar or change 
from thumbnails to a list by selecting the list display icon. 
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Saved views allow you to easily jump to points of interest in the model. A saved view remembers the 
camera location and orientation along with the levels and models that have been set to display. 

 

Saved Views quick access dialog icons. This can be used to navigate between the cross sections from the 
sheet models. 

 Open Design Model 

 Open Drawing Model 

 Show Callouts (Not used at this time) 

 Open Sheet Model (Only visible from the Drawing and Design models) 

Manage Saved Views 

You can view all the Save Views of your cross sections within the 
design model where the cross sections were clipped from using 
the named boundaries tools. By clicking on the Manage Save 
Views (shown to the right). 

Note: Anytime you use the named boundaries tools to create 
sheets it will always generate a saved view of that named 
boundary. (This is a snapshot of how the view looks at the time of 
creating the named boundary). 

Within the Saved Views 
Manager dialog, you can 
select the saved view and 
update it from the Design-3D 
model view 1 if changes have 
been made after the cross 
sections named boundary has 
been created. 

You can also delete the saved 
views within this dialog.  
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Note: In the case of the deletion of the Named Boundaries graphic element you will need to open the Saved 
View Manager and manually delete the saved view for that Named Boundary. If the saved view isn’t deleted 
out of the Saved View Manager, you will run into issues when trying to recreate Named Boundaries.  

Drawing Model vs. Sheet Model Usage 
Each cross-section is displayed in a drawing model. The various drawing models are referenced to the 
sheets. Each sheet is contained in its own sheet model. The models are intended to be used as follows: 

Drawing Models 
All annotations placed in the cross-sections should be placed in the drawing model. The cross-
section grid area represents the clipping limits of the cross-section on the sheets; therefore, 
anything drawn outside of the grid will not be displayed on the cross-section sheets. 

Sheet Models 
The sheet model is intended to be used for printing. All annotations, other than the sheet border 
information, should be placed in the various drawing models. 

 

End Area Volume Report 

Quantities can be extracted from the 3D mesh elements (see Create Cut and Fill 3D Meshes) using a 
previously placed set of cross section named boundaries using the End Area Volume Report, shown 
below. When the command is processed, the named boundaries are tagged with the end area quantity 
values, which can then be used for cross-section annotation. 
 

 
After selecting the command, choose the named boundary 
group that will be tagged with the quantity information. 

 
When prompted, select any named boundary group that you 
wish to exclude from the process. Right-click (reset) when 
complete. 
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After processing the End Area Volume Report is displayed as shown below. 

 
Each named boundary is tagged with quantity information. 
By default, the End Area Volume Report shows cut and fill volumes in Cubic Feet. From the Civil Report 
Browser dialog, select Tools > Format Options to access the dialog shown below. 

 
 

 
 
For ODOT projects, 
toggle on the Convert 
to Cubic Yard option as 
shown at left. 
 
Select Close to apply 
the changes. Changes in 
format are applied to 
the current report 
values. 
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Various reports are available as shown on the previous page. It is good practice to save this report by 
choosing the File > Save As option. 
 
Another report you may want to consider saving is the Volumes report, shown below. This report shows 
the quantities for each component. 

 

Displaying End Area Quantities 
End area volumes are annotated in a table in the drawing model for each cross section as shown below. 

 

The table is placed as part of the cross-section annotation. The table uses ORD Civil Fields for the end area 
quantities. These fields are automatically updated using the current values assigned to the named 
boundary when the drawing model is opened. 

Notes: 

• The table is placed only if a 3D line string is encountered in the 3D model generated by a point 
named “PGL” or “EX_Table” in the template that was used to generate the corridor model. 
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• The Seeding quantities are not computed by ORD. These entries are included in the table for use to 
manually place seeding quantities in the table. 

Updating the End Area Quantities 
If changes are made to the model, the 3D mesh prismoidal cut and fill elements must be regenerated, and 
the end area volume report must be reprocessed. Take the following steps to update the quantities if 
changes are made to the model: 

1. Open the DGN file containing the 3D mesh prismoidal volume elements 
2. Delete the previously created prismoidal volume cut and fill elements  
3. Run the Home > Civil Analysis > Create Cut Fill Volumes command 
4. Open the cross-section container DGN file 
5. Run the Home > Civil Analysis > End Area Volume Report command 
6. Open each cross-section drawing model. The quantity fields are automatically synchronized with 

the earthwork quantity values that have been assigned to the named boundaries as each cross-
section drawing model is opened 

Processing Sheets from Previously Generated Named Boundaries 
If the named boundaries were generated without creating the sheets, as is the case when running the End 
Area Volume Report after generating the named boundaries, the sheets can be generated from the named 
boundaries with the following steps: 

1. From the Drawing Production tab, select the icon at the lower right of the Named Boundaries 
group as shown below. The Named Boundaries dialog is opened. 

 
2. In the Named Boundaries dialog, select the cross-section group from the list. Toggle the Show the 

Create Drawing Dialog option on as shown below. 
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3. Choose the Create Cross Section Drawing command. The Create Drawing dialog, previously 
described, is opened. Complete the Create Drawing dialog to generate the cross-section sheets. 

 

Adding Cross Sections at Specific Stations 

The initial cross section named boundary placement is defined by selecting an alignment and specifying an 
interval. Additional named boundaries for specific locations such as a driveway or a drainage structure can 
be inserted using the Civil Cross Section 2 Points option. 

Additional cross section locations may be defined prior to, or after generating the initial sheets. Each 
workflow is summarized below. 

Adding Named Boundary Locations Before Generating the Initial Sheets 
When the initial set of named boundaries is defined for the cross sections, be sure to toggle the Create 
Drawing option OFF. This allows the user the opportunity to define additional named boundaries at 
specific locations not covered by the initial named boundary interval placement. 

Take the following steps to define additional cross section named boundary locations: 

• From the OpenRoads Modeling WorkFlow, select Drawing Production > Named Boundary to 
initiate the process. The Place Named Boundary dialog is opened. 

• If multiple locations are to be defined, toggle the Create Drawing option OFF 
• Select the fifth icon, Civil Cross Section 2 Points to begin the process of placing the cross section 

named boundaries 
• Select the desired Drawing Seed for the cross section named boundaries. 
• Select the Group. The drop-down list will include any previously defined cross-section groups. 
• Select the alignment for the named boundaries 
• After the alignment has been identified, enter data points for the start and end of the named 

boundary location. A third data point is required to accept the named boundary placement 
• To define additional named boundary locations, the path element (alignment) must be identified 

each time. Follow the prompts in the lower left corner of the MicroStation window. 

In the example below, a named boundary has been added at a driveway location. 



 
Ohio Department of Transportation 
Office of CADD and Mapping Services May, 2024 

 

Section 802 – Cross-Section Sheets 802-21 
 

 

Tip: For best results, create any additional named boundaries using Civil AccuDraw to define the 
station and offset values for the boundary. Use the same offset values as the primary cross-sections. 

• Toggle on the Create Drawing option ON prior to defining the last boundary to launch the Create 
Drawing dialog. 
 
If you forget to toggle this option back on, the Create Drawing dialog can be accessed from the 
Named Boundaries dialog. See Processing Sheets from Previously Generated Named Boundaries, 
for more information. 

Adding Named Boundary Locations to Previously Generated Sheets 
Occasionally it is necessary to add a cross-section location after the initial sheets have been generated. 
OpenRoads version 10.10 provides functionality to generate new sheet models while retaining previously 
generated cross-section drawing models. 

Before processing a new set of cross-section sheets, it is necessary to manually delete previously generated 
sheet models. Open the Models dialog from one of the OpenRoads WorkFlows by selecting the Models icon 
on the Home tab. Select the sheet models to be deleted, and then choose the Delete Model(s) icon like the 
example below. 
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1. From the Drawing Production tab, select the icon at the lower right of the Named Boundaries 
group as shown below. The Named Boundaries dialog is opened. 

 
2. In the Named Boundaries dialog, select the cross-section group from the list. Toggle the Show the 

Create Drawing Dialog option on as shown below. 

 

3. Right click on the named boundary group name and choose the Create Cross Sections from 
Drawings option. 
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4. The Create Sheets from Drawings dialog is opened as shown below.  

 

Select OK to initiate the process. 

 

 

 

 

 

 

 

 

 

 

It is also possible to create new sheets from specifically selected named boundaries as shown 
below. 
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Displaying Right-of-Way on Cross-Sections 

The location of both the existing and proposed Right-of-Way lines can be displayed in a dynamic cross-
section view and on the cross-section sheets like the example shown below: 
 
To display the Right-of-Way lines on the cross-sections, each Right-of-Way line must have an existing 
profile defined. This is accomplished by opening a profile view for each Right-of-Way line and defining the 
exiting ground profile as the active profile. When the profile is defined for right-of-way lines, a 3D line 
string is created in the 3D model for the line. 
 
The workflow to assign a profile to the right-of-way lines is as follows: 
 

• In the right-of-way basemap design file (BR), attach the design file containing the existing terrain 
• Set the referenced terrain model as the active terrain by selecting the terrain and choosing the Set 

As Active Terrain option from the pop-up menu 

 
• Open a profile model for each right-of-way line, either by selecting the element and choosing the 

Open Profile Model option, or by holding down the right-mouse button and choosing View 
Control > 2 Views Plan/Profile from the pop-up menu. 

• Select the groundline in the profile window and choose the Set As Active Profile option from the 
pop-up menu 
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A 3D element is generated in the 3D model like the example below. 
 

 
When cross sections are generated, if the cross section intersects a 3D Right-of-Way line in the 3D model, a 
cell is placed in the cross section at the right-of-way line offset and elevation. 
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Section 803 Cross-Section Sheet 
Exercise 

Exercise 1: S.R. 185 Cross Sections 

Part A: Design Files 
Take the following steps to create the design file for the cross-section sheets: 
 

• Open ProjectWise Explorer 

 
 

• Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

• Browse to the 402-Engineering\Roadway\Basemaps\ folder.  
• Open the file 123456_BK000.dgn 
• Select the Ohio DOT Workflow 
• Select the OHDOT Create Design Files application 

 
 

• Create the cross-section sheet design file for S.R. 185 using the settings below: 
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o Be sure to change the Seed file option to use the 123456_DesignSeed2d.dgn file. 
o Select Settings > Open Last Created File 
o Select the Create Files option 

The new file is created in the 402-Engineering\Roadway\Sheets folder 
 

• When prompted, check the current file back into ProjectWise 
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Part B: Plan View References 
 

• From the OpenRoads Modeling WorkFlow, select Home > Attach Tools > References to attach 
the files with the plan view information. Start by attaching the Survey Field Book (FB) design file 
from the following folder: 
 

300-Survey\Basemaps\123456_FB001.dgn 

• When selecting the references, set 
the Attachment Method to 
Interactive. This will open the 
Reference Attachment dialog for 
each file as it is attached. This is 
necessary to review and set the 
Nested Attachments parameter 
for each file. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• From the Reference Attachment dialog, set the Nested Attachments parameter to No Nesting.  
 

• After attaching the Survey Field Book design file (FB) set the terrain model as the active terrain by 
selecting the terrain model element and choosing the Set As Active Terrain Model icon from the 
pop-up menu. 
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The cross sections are extracted from the 3D model. 

 Open a 3D view by holding down the right-mouse button in the view window and choosing View 
Control > 2 Views Plan/3D 

Attach the files that contain the 3D information that will be displayed on the cross-sections. Set the Nested 
Attachments setting to Live Nesting with a depth value of 0 unless otherwise stated. 

o 401-Engineering\Roadway\Basemaps\123456_BK001.dgn 
o 401-Engineering\Roadway\Basemaps\123456_BK002.dgn 
o 401-Engineering\Roadway\Basemaps\123456_BK003.dgn 
o 401-Engineering\Roadway\Basemaps\123456_KM001.dgn 
o 401-Engineering\Roadway\Basemaps\123456_KM002.dgn 
o 401-Engineering\Roadway\Basemaps\123456_KM003.dgn 
o 401-Engineering\RW\Basemaps\123456_BR001.dgn 

 
• After the references are attached, select the 3D view so that it is the active view. From the Home 

tab, select the Level Display icon to turn on/off the levels that you wish to display in the cross-
section sheets. 

o Select each reference file to turn on/off the desired levels 
o The only thing that is needed from the survey basemap (FB) design file is the terrain model. 

Turn off all the levels in the FB design file except the following 
 DT_X_TIN_Hull 
 XS_X_Ground_Line 

 
• Select File > Save Settings after you have completed the task of turning on/off the levels 
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Part C: Placing Named Boundaries 
MicroStation Named Boundaries are placed to define the limits of each cross-section. 
 
Take the following steps to define the cross-section named boundaries for S.R. 185: 

 From the Drawing Production tab, select the Place Named Boundaries command 
 

 From the Place Named Boundary command, take the following steps: 
o Select the Civil Cross Section command 

(4th icon)  
o Set the Drawing Seed parameter to Cross 

Sections 5-Scale 
o Toggle off the Create Drawing option at 

the bottom of the dialog. 
o Click inside the Start Location key-in field 
o Left-click on the plan view alignment 

graphic for S.R. 185. The dialog will track 
the start location station value relative to 
the cursor location 

o Key in a Start Location value of 386+00 
o Key in a Stop Location value of 428+00 
o Key in a value of 50 for the Interval 

parameter 
o Enter a data point (left-click) in the plan 

view to initiate the process to create the 
named boundaries for the cross-sections. 
It takes three clicks to place the boundary 
elements. 

 
The boundaries are drawn for the cross sections and the 
Placed Named Boundary dialog is closed.  
 
Additional cross sections at specific locations, such as at a driveway or culvert, can be specified by selecting 
the Named Boundary command and entering a single location by setting the Start Location and End 
Location to the same value. Set the Group parameter to use the same group as the previously placed 
named boundaries rather than (New) as shown above. 
 
Cross section named boundaries can also be placed at a 
single location by using the Civil Cross Section 2 
Points option as shown at right. 
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Part D: End Area Quantities 
Quantities can be extracted from the 3D mesh elements using the location of a previously placed set of 
cross section named boundaries. The named boundaries are tagged with the quantity values, which can 
then be used for cross section sheet annotation. 

Take the following steps to create a new design file to generate 3D mesh elements from the corridor model 
graphics. 

• Select the Ohio DOT Workflow 
• Select the OHDOT Create Design Files application 

 
• Create the design file for 3D mesh elements using the settings below: 

 
o Be sure to change the Seed file option to use the 123456_DesignSeed2d.dgn file. 
o Select Settings > Open Last Created File 
o Select the Create Files option 

 
The new file is created in the 402-Engineering\Roadway\Basemaps folder 
 

• When prompted, check the current file back into ProjectWise 
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• From the OpenRoads Modeling WorkFlow, select Home > Attach Tools > References to attach 
the files with the plan view information. Start by attaching the Survey Field Book (FB) design file 
from the following folder: 
 

300-Survey\Basemaps\123456_FB001.dgn 

• When selecting the references, set 
the Attachment Method to 
Interactive. This will open the 
Reference Attachment dialog for 
each file as it is attached. This is 
necessary to review and set the 
Nested Attachments parameter 
for each file. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

• From the Reference Attachment dialog, set the Nested Attachments parameter to No Nesting.  
 

• After attaching the Survey Field Book design file (FB) set the terrain model as the active terrain by 
selecting the terrain model element and choosing the Set As Active Terrain Model icon from the 
pop-up menu. 
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The 3D mesh elements are created from the 3D model. 

 Open a 3D view by holding down the right-mouse button in the view window and choosing View 
Control > 2 Views Plan/3D 

Attach the files that contain the 3D information that will be used to extract the volume elements. Set the 
Nested Attachments setting to Live Nesting with a depth value of 1. 

o 400-Engineering\Roadway\Basemaps\123456_BK000.dgn 
o 400-Engineering\Roadway\Basemaps\123456_KM001.dgn 
o 400-Engineering\Roadway\Basemaps\123456_KM002.dgn 
o 400-Engineering\Roadway\Basemaps\123456_KM003.dgn 

 
 From the Home tab, select Civil Analysis > Create Cut Fill Volumes 

o Issue a data-point (left-click) to accept each of the parameters. 

 
The 3D meshes are placed in the 3d Model on the following levels: 
 

o VL_Cut_Volume 
o VL_Fill_Volume 

 
  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services April, 2019 

 

Section 803 – Cross-Section Sheets Exercise 803-9 
 

Part E: Cross Section Sheets 
After placing the named boundaries and generating the 3D meshes for the cut and fill quantities, take the 
following steps to attach the design file containing the cut and fill 3D mesh elements to generate the end 
area quantities. 

 Open the cross-section sheet design file. Be sure to check the current file back into ProjectWise. 
o 402-Engineering\Roadway\Sheets\123456_XS001.dgn 

 Attach the file containing the 3D mesh elements as a reference to the 2D plan view. 
o From the Home tab, select Attach Tools > References 
o Attach the following file with No Nesting: 

402-Engineering\Roadway\Basemaps\123456_KD001.dgn 
 Turn off the display of the 3D mesh elements in the 3D view 

o Click the 3D view window to make it active 
o From the Home tab, select Level Display 
o Turn off the following levels: 

 VL_Cut_Volume 
 VL_Fill_Volume 

 From the Home tab, select Civil Analysis > End Area Volume Report 
o When prompted, choose the CLP_S185 Named Boundary Group 
o Left-click to accept the selection. Follow the prompts to generate the end area volume 

report 
 The report is displayed in the Civil Report Browser dialog. Select Tools > Format Options to 

adjust the output format of the report. The settings shown below are recommended for ODOT 
projects. 

 

 

Changes to the Format 
Options are applied to the 
active report when the 
dialog is closed. 
 
Close the report when 
complete. 
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Create the cross-section sheets. 

 From the Drawing Production tab, select the Manage Named Boundaries icon in the lower right 
corner of the Named Boundaries group. 

 
 From the Named Boundaries dialog, take the following steps: 

o Toggle on the Show the Create Drawing Dialog option 
o Select the Cross Section Group name from the list 
o Select the Create cross section drawing icon. 

 
The Create Cross Sections dialog is opened as shown below.  
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The settings on this dialog have been preconfigured for ODOT projects. 

 Select OK to initiate the sheet creation 
process. 
 
A drawing model is created for each named 
boundary. 

The sheets are composed by referencing the 
drawing models. 

Earthwork quantities are annotated on each 
cross section in the drawing model. If the End 
Area Volume Report is processed again, the 
quantity values are updated for each named 
boundary. The value shown in the drawing 
model is updated when each drawing model is 
opened. All the drawing models can be 
updated at once by removing the annotations 
from all drawing models and the re-
annotating all the drawing models (Drawing 
Production > Model Annotation > Remove 
Model Anntations/Annotate Model) 

Annotation is typically placed in the drawing 
models, not in the sheet models. 

 

 Take some time to review the cross-section model 
and sheets. 

 

This completes this exercise. 

 Exit OpenRoads Designer, checking the file back in to ProjectWise 
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Section 900 Drainage and Utilities 
Overview 

Drainage and utilities, such as culverts, catch basins, manholes, telephone, water, gas lines, etc., must be 
defined in the 3D model to display this information on the roadway profile and cross sections. This guide 
will provide an overview of the process to model Drainage and Utility features in 3D, using the OpenRoads 
Drainage and Utility tools. 
 

This guide will go over the modeling side of the Drainage and Utility tools. There is a separate guide for 
running analytics on drainage networks that is currently in development. 

Configuration and setup 
All the features set up for Drainage and Utility have been created within the 
OHDOT_Features_DrainageAndUtilities.dgnlib file. This file also contains all the settings for a Drainage & 
Utility Project, such as prototypes, catalogs, storm events, scenarios, flex tables, and default design 
constraints. The 2D and 3D cells that are used with the feature definitions are defined in the 
OHDOT_DraiangeAndUtilities.cel file. These cells should not be placed directly using the place cell tool. 
They are made specifically for use with the Drainage and utilities feature definitions. 

Drainage & Utility Project 

A Drainage & Utility Project contains all the settings for drainage and utilities. This includes prototypes, 
catalogs, storm events, scenarios, flex tables, and default design constraints.  

Whenever a Drainage and Utilities tool is used a Drainage & Utility Project is created within that file if one 
does not already exist. This Drainage & Utility Project is a copy of all the Drainage and Utility settings that 
are set up in the OHDOT_Features_DrainageAndUtilities.dgnlib. Please note this means that any future 
updates to the OHDOT_Features_DrainageAndUtilities.dgnlib will not be used/applied to this file since the 
Drainage & Utility Project is already created.  This does not copy all the feature definitions within the 
OHDOT_Features_DrainageAndUtilities.dgnlib file as those get copied into the file as they are used. 

Drainage and Utility Features 

Feature Definitions are currently defined as the following 3 different feature definition types 
• Nodes – consists of point like features for example Catch Basins, Headwalls, Manholes… 
• Conduit -consists of linear like features for example Gas line, Fiber Optic Line, and Culverts  
• Drainage Area- consists of polygon like features for example catchment areas, ponds… 

Use the OpenRoads Standards tab of Explorer within ORD to see the available feature definitions 

Modeling Existing Drainage and Utility Features 

Majority of the time existing Drainage and Utility features will be displayed within the survey fieldbook 
(FB) file. It is important to understand these graphics from the survey fieldbook are not truly modeled and 
are not using the Drainage and Utilities Feature Definitions. But these graphics can be used to help create 
your Drainage and Utility model. 
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Creating Drainage and Utility models should be done within separate files. For Drainage a “BD” drainage 
basemap design file should be created and for Utility a “BU” Utility basemap design file should be used. 

The OHDOT Create Design Files application can be used to create these files.  

 

 

If existing drainage or utility graphics are contained with the projects Survey Fieldbook then the Extract 
From Graphic  tool can be used to create existing drainage or utility models.  

Extract From Graphic 
The Drainage and Utilities > Layout > Extract From Graphic tool is used to extract 3D 
information from a 2D plan view graphic. 

The first time a Subsurface Utility command is selected, the software prompts the user to create a utility 
model in the design file if one has not been previously created. Select Yes when prompted as shown below. 

 

After the utility model has been created, the 
user must reselect the Drainage & Utility 
command to initiate the command. 

The Extract Utilities from Graphic dialog is 
shown at left below. 

 

 

 

 

 

Method 

The elements that will be used to create the 3D model can be selected, using the Selection option, either by 
selecting a single element or by a selection set, or by use of a Graphical Filter, which creates 3D utility 
models for many different types of utility types as defined in the filter group.  
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When the Method parameter is set to Selection, the 
dialog inputs are as follows: 

• Vertical Offset – Defines the depth of the utility 
like under the selected surface. 
o NOTE: The depth value is assumed to be the 

depth to the top of the utility line. 
• Create trench – Defines whether to create the 

trench defined in feature definition. Currently, 
ODOT does not provide feature definitions for 
trenching. 

• Design Stage – Selection of OpenRoads design 
stage which defines settings applied to the trench 
corridor, such as stroking tolerances 

• Feature Definition – Assigns the selected feature 
definition to the resulting utility features 

• Name Prefix – The prefix that is used to name 
the created 3D utility element 

• Description – Pick list for the utility size 

When the Method parameter is set to Graphical Filter, 
the dialog inputs are as follows: 

• Vertical Offset – Defines the depth of the utility 
like under the selected surface. 
o NOTE: The depth value is assumed to be the 

depth to the top of the utility line. 
• Create trench – Defines whether to create the 

trench defined in feature definition. Currently, 
ODOT does not provide feature definitions for 
trenching. 

• Select Filter- defines which filter or filter group 
to use to extract utilities. 

• Design Stage – Selection of OpenRoads design 
stage which defines settings applied to the trench 
corridor, such as stroking tolerances 
 

Filter Manager 
Filter Manager is set up with several filters and filter groups to make utility extraction easier. The 
OHDOT workspace has 4 main filter groups, imaged below. Each filter group is set up to extract 
existing features from graphics. For example, the All Catch 
Basins filter group will find all existing catch basin cells.  
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Filters are not set up for extracting drainage pipes as there is not currently a reliable way to extract the 
correct pipe size & material. 

 Utility line filters have default depths below the surface as defined by the table below. 

  

Utility Lines Default Depth Default Size 

Cable, TV, Telecom, Fiber Optic Lines -2 2” 
Electrical Lines -2.5 2” 
Gas Lines -3 6” 
Water Lines -4.5 6” 
Oil Lines 5 6” 

 

Extracting Utility Features 
• To extract utility lines, you can use the Extract From Graphic tool in the select mode or the filter 

mode.  

In the Selection Method,  

• Set the Desired Feature Definition, Feature Name (Name Prefix), and size (Description). 
• Select the element(s) to be extracted to create the utility model 
• These selected utility elements may result from survey processes, GIS graphic data, 

OpenRoads Geometry, or other sources. But, in every case the elements are DGN graphic 
elements. In the example below, a MicroStation SmartLine was used to draw the telephone 
line graphics 

 
• Issue a reset comment (right-click) to complete the selection process 
• When prompted, select the surface that will be used for the utility extraction. Reset (right-

click) to use the active terrain model. 
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• Set the depth below the terrain to create the utility. 
• Follow the prompts to accept the remaining options to complete the extraction process. 
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Tip 1: When extracting from a surface, keep the utility line graphics within the limits of the surface. If the 
plan view graphics for the utility line extend beyond the surface boundary the software will assume an 
elevation of zero for that portion of the utility line. 

 In the Filter Method, 

• The Feature Definition, Feature Name (Name Prefix), and size 
(Description) will be grayed out since its being set within the 
filter. 

• Select the desired filter (All Utilities), data point (left-click) to 
accept filter. 

 
• When prompted, select the surface that will be used for the 

utility extraction. Reset (right-click) to use the active terrain 
model. 

• Follow the prompts to accept the remaining options to complete 
the extraction process. 

 

Tip 2: After extraction turn off display of elements used to extract utilities as the extracted utilities have a 
plan view display. 

NOTE: You can always check over the extracted utilities and change pipe sizes and vertical offsets. Water 
lines and Gas lines will need to be checked to ensure proper pipe sizes and inverts. Sanitary lines are not 
included with the All-Utilities filter and should follow the same process as the following section, Extracting 
Drainage Features. 

When should I use the Selection Mode versus the Filter method? 

Both methods offer different benefits. In the selection mode you get to specify the desired depths for each 
extraction but for each feature a different extraction is required. Whereas the filter method can extract all 
utilities in one extraction, but the user does not get to specify depths but rather default depths are used. 
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Editing Utility Profiles 
 After the utility is extracted, it was a uniform depth under the surface. This depth can be changed in 
the utility properties. 

  

 

 

 

 

But if more accurate data is known at certain locations of the utility the profile can be edited to account for 
the more accurate data by following the below steps.  

Caution should be taken with the direction the utility was extracted; it could be going the opposition 
direction of your centerline. 

• Open the profile view of the utility.  
• You could draw a new profile and make it active but if you want to utilize some of the current 

profile then follow the rest of the steps below 
• Select the profile and convert to Profile Rule 

 
 
 
 
 
 

• Now profile the profile again and select create best fit profile 
 

 
 
 
 
 

• Click through the prompts taking the defaults for the best fit profile (Note: a feature definition does 
not matter as later when it becomes the active profile it will automatically get set to the utility feature 
definition). 
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• Now select the newly created profile and convert to profile rule 

 
• The newly created profile is now editable and can be modified as needed. While moving/inserting 

vertexes civil Accudraw can be used with profile offset ordinate to specify a depth below existing 
ground.  

• Once modifications are complete make the new profile the active profile. You will notice the profile 
will automatically get assigned the utility feature definition. 

 

 

 

 

 

 

Extracting Drainage Features 
Extracting drainage features is a little more involved then extracting Utilities. There are so many variations 
of pipe sizes and materials that the Extract from graphics tool is not feasible to extract pipes. You can 
however use the Extract from graphics tool to extract the nodes. Nodes are required at each end of a 
conduit. Manholes, catch basins, Inlets are considered Nodes.  

Typically, the existing drainage manholes, catch basins and inlets will be displayed in the survey fieldbook 
file as 2d cells. These cells can be used with the extract from graphics tools to create your drainage model. 

During extraction the node (manhole, catch basin, inlet) invert elevation can be extracted at the same time. 
This is only possible is the survey fieldbook collected an additional point to represent the invert. This point 
will have a FLINE cell. If this point is not present, then a default invert for the node is used and will have to 
be set correctly after extraction. 

Notes: 
• Drainage models should be extracted within a drainage basemap (BD). 
• Use the 2D seed file to create the drainage basemap. The Subsurface Utilities software will 

generate a separate 3D model in the drainage basemap design file for the 3D drainage information 
• The file is created in the 400-Engineering\Drainage\Basemaps\ folder 
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Extracting 3D Drainage Nodes 
 The following actions can be used to create a 3D network of pipes and drainage structures. 

Take the following steps to extract the Drainage Nodes.  
 
1. Select the Extract from Graphics tool. 
2. Set the Method to Utility Filter. Several filters are provided in the 

OHDOT CADD Standards for individual drainage items as well as 
groups of items. 
 

3. Use the Select Filter item to choose All Catch Basins filter. This 
filter is configured to extract only the drainage cells for the catch 
basins and not the pipes. The pipes will be extracted individually 
as a separate process. 
 

4. Toggle on the Use 3D Element Elevations option. 
 
5. Accept the options as you are prompted on the cursor to initiate 

the extraction process. 
 
Note: The Design Stage item is not relevant to this process. 

 
The 3D drainage structures are extracted using the elevation of the 
cells mapped by the Survey process. As each drainage structure is 
processed, the extraction process will search for a FLINE feature to 
establish the depth of the drainage structure. If a FLINE feature is not 
found, the depth is set using at a default value. 
 
 
 

If the drainage basemap was created with a 2D seed file, which is the recommended best practice, the 
Extract Utilities from Graphics process will create a new model named Design-3D containing the 3D 
drainage structures. This new model is automatically attached as a reference to the current 2D model. 
 
In addition to the 3D model, a 2D graphic is placed in the current 2D model for each extracted drainage 
structure nodes. This graphic is linked to the 3D model and can be used to make edits to the drainage 
structure. 
 
In the example below, the reference file display of the survey basemap and the Design-3D model has been 
turned off to show the 2D graphic that is placed for one of the drainage structures. 
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Selecting the graphic reveals a pop-up menu that 
can be used to make edits to the drainage 
structure as well as two rules (Node Top 
Elevation, and Node Rotation) that can be 
edited by selecting the displayed text. 
 
The extracted drainage structures do not 
consider the rotation angle of the original cells 
and are placed at a zero-degree rotation. The 
example at left below shows the original cell as 
referenced from the Survey basemap, and the 2D 
cell that was placed as part of the utility 
extraction process. It is necessary to rotate each 
structure manually. 
 
Once the 2D node is selected, parameters for the 
rotation of the 3D structure are displayed as 
shown at left. The angle can be keyed-in by 
selecting the angle text, or the 3D structure can 
be rotated by selecting one of the rotation 
arrows.  
 
Typically, it is best to get the rotation angle of the 
original cell and use that value to key-in the 
rotation angle for the drainage node as described 
on the following page. 

 
 
 
Take the following steps to key-in the rotation angle for the drainage structure: 
 
 Change the Angle Readout as shown below by selecting File > Settings > File > Design File 

Settings 
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 Use the MicroStation Element Information command to get the rotation angle of the original cell 

as shown below. 
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 Select the drainage node graphic and choose the Properties command from the pop-up menu. The 
Rotation can be modified as shown below. The graphics for the node in the 3D model are updated 
as changes are made to the properties. 

 
 
After extracting the drainage structures and rotating them into place we are ready to extract the pipes.  
 
After extracting the graphics, If the FLINE cell was not found or does not exist it is necessary to select each 
structure and manually key-in the Invert Elevation value. An example is shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note: The Filters are set up to search within a 12foot buffer of the cell. There is a chance that the process 
could not find the FLINE cell or find and use the wrong FLINE cell. Each structure should be verified the 
correct invert elevation is set. 
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Repeat the process using the All Inlets and All Manholes filter groups. 

Extracting Drainage Links 
The Extract Utilities from Graphics command could be configured to extract pipe information; however, 
as of this writing the current release of the software will not connect the extracted pipes to the previously 
extracted nodes. Even though it is more cumbersome, it is better to place each pipe manually as a “link” 
using the Place Conduit command, shown below. 

 
 
 
 
 
 
 
 

The dialog shown below is opened. 
 

General information for the command can be found by 
selecting Drainage and Utilities > Help > Help 
Contents from the MicroStation ribbon menu. 
 
The Feature Definition is used to select the pipe type. 
 
The Description item is used to select the pipe size.  
 
The Name Prefix is used to name each pipe and is 
incremented as you extract the pipes. 
 
 
 

 
When the command is selected, you are prompted to Select Start Node. 
 
The ODOT 3D drainage items have specific connection regions on each side of rectangular structures. 
Circular structures have a circular connection region. When the first node is selected, the link starts from 
one of the connection regions. Follow the prompts to select the second node.  
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A line is placed in 
the current 3D 
model that can be used to modify the link. The extruded 3D link is placed in the 3D model as shown below. 

 
The link is placed at the lowest elevation of the selected nodes. The elevation values can be edited by 
selecting the link in either the 2D or the 3D model, and then choosing the Properties icon from the pop-up 
menu. 

 
From the Properties menu, shown at left, the Start Invert 
and Stop Invert values can be edited if necessary to set the 
correct elevations for the pipe. 
 
Note:  Sanitary manholes and conduits should be extracted 
following the same methods outlined in this section. 
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Connecting Links to FDO or PIO Points 
The field codes PIO (pipe inlet or outlet) and FDO (for direction only) can both be used to designate the end 
of a pipe. PIO is used to designate an inlet or outlet point for an open pipe of culvert. FDO (for direction 
only), is used to designate the direction of a pipe when the other end cannot be located. 
 
There must be a node defined at the PIO and FDO locations to place a link in the design file using the PIO 
and FDO points. The Place Node command is used to place nodes at the PIO and FDO locations. 
 
The command is selected from the Drainage and Utilities WorkFlow as shown below. 

Take the following steps to create nodes for the PIO and FDO points: 
 

• Select the Place Node command 
• Set the Feature Definition to the GenericNode-X item 
• When prompted as shown below, issue a reset (right-click) to type in the elevation for the node 

 
• Type in the Elevation for the node 
• Enter a data point for the node location by snapping to the PIO or FDO point 
• A triangle is placed in the 2D and the 3D models at the location of the node. The direction of the 

triangle is irrelevant 
 
The extracted node for the PIO and FDO points is 
placed as a triangle at each point on the level 
SC_Scratch1 as shown at right. 
 
The Place Conduit command described in the previous 
section is used to place the 3D pipes between the 
nodes. 
 
Tip: There is also a PIO filter that can be used with the 
Extract from Graphics tool instead. 

Box Culverts 
The graphics for existing storm water utilities are normally placed in a 2D model in the drainage (BD) 
basemap design file. The Drainage and Utilities software is used to place the box culvert in a 2D model. 
The software will automatically generate the 3D model for the box culvert. 
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After creating a drainage basemap design file, attach the survey basemap as a reference file to view the 
culvert shots. Box culverts are surveyed using the CULV field code to take a shot at the invert elevation at 
each end of the culvert. 

 
Box culverts are placed as a link by the Drainage and 
Utilities software by use of the Connect Conduit 
Between Nodes command. A node must first be placed 
at each end of the proposed box culvert in the design 
file by use of the Place Node command. The generic 
headwall feature definition is used to define the 
location of each end of the box culvert.  

 
Select the Place Node command from the task list as 
shown below. 

 
 

Place a node at each end of the box culvert using the 
Generic Headwall-X feature definition as shown above. 
 
The user is prompted to select a reference element for the 
node elevation as shown below.  
 
Nodes can be placed at a specific elevation, or relative to 
the selected surface or a corridor model. Issue a Reset to 
type an elevation. 
 
 
 
 
 
 
 
 

After the elevation reference is defined, the user is prompted to set the Placement Type. 
 
The By Minimum Depth option is used to set the initial 
depth using a default value. The invert elevation can be 
edited after placement if necessary. 
 
 
 
Next the user is prompted to set the location of the node. Place the 
node at the location of the CULV survey point. 
 
The generic headwall node is placed using a X symbol on the level 
SC_Scratch1 as shown at right. The direction of the triangle, defined by the 
Rotation parameter, is irrelevant to the flow direction of any links 
connected to the node. 
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After the headwall points have been placed at each end of the culvert, the box culvert is placed using the 
Place Conduit command shown below. 
 
 

 
 
 
 
 
 
 
 
 
 

 
 
 

Feature definitions for existing and proposed 
box culverts are provided in the ODOT 
standards. The available features for existing 
box culverts are shown on the following page. 
The span and rise for each available culvert 
feature is defined by the Description field as 
shown at right above. 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
Available culvert sizes are based on the Figure 1008-14 of the ODOT Location and Design Manual – 
Volume 2, Drainage Design. 
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The culvert is placed by selecting each node as shown below. 

 
Two sets of graphics are drawn for the box culvert as shown below. 
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The culvert is drawn on 2 different levels DR_X_Culvert and DR_X_Culvert3D these will be shown on custom 
line styles in the 2D design model. The 2D design model can be referenced back to the survey basemap (BE) 
if desired or attached as a reference by the design personnel. 

The Subsurface Utility software also creates a 3D model in the drainage basemap named “Design-3D” 
containing the 3D model of the box culvert as shown below.

 

Modeling Proposed Drainage Features 

Creating a proposed drainage model is somewhat like modeling existing drainage features but the extract 
from graphics tool is not relevant.  
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Modeling the drainage features should be done within a drainage basemap (BD) file. If the proposed 
network will attach to the existing modeled network, then the proposed network MUST be created in the 
same file as the modeled existing network. 

To place conduit, the ends of that conduit must have nodes. So, the first step is to place the nodes. 

Placing Nodes 
The Place Node and Place Nodes tools can be used to place Drainage nodes like Manholes, Catch 
Basins, Inlets, and headwalls. 

 The Place Node tool offers a couple different ways to place 
nodes. The workflow is listed below 

• Set the desired feature definition and Name Prefix.  
Tip: The feature name (name prefix) can be used to 
annotate call outs.  

• In the heads-up prompt you can select an element to be used 
for the grate/rim elevation or reset click (right click) to key in 
the elevation. 

Tip: If placing curb/curb & gutter catch basins, use the 
CURB_GUTTER element as the elevation reference. 

• Next if a reference element as selected you can enter a vertical 
offset from that reference element. If a reference element was 
not selected, you can enter the desired elevation. 

Tip: When entering a vertical offset value don’t forget the 
negative sign to offset below the selected element. Also, basic calculations are supported for 
example to vertically offset 0.5” below the reference element you can enter -0.5/12.  

Note: Don’t forget about catch basin depressions when placing catch basins for curb/curb & gutter. 

• Next enter a data point (left click) at the location you want the node to be placed.  

Tip: Use Civil AccuDraw station-offset ordinate to place the node at a desired station and offset. 

• Next you can specify the rotation of the node. There are two options, absolute or relative to 
alignment. Data point (left click) to accept the selected rotation mode. 

• If relative to alignment is selected as the rotation mode the user is prompted to select the alignment 
to base the rotation off, then can enter the desired rotation and data point (left click) to complete 
the placement of the node. 
 

 The Place Nodes tool can be used to place a series of node at a given interval as well as place 
conduits between the nodes at the same time. The workflow is listed below. 
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• First fill out the tools dialog as desired 
o Check on Create conduits and set the feature 

definition, name prefix, and description (size) to 
desired values. Note only one feature and size 
can be set and will be used for all conduit placed. 
If conduits are not desired, then uncheck the 
create conduits checkbox. The name prefix will 
increment the number for each conduit placed. 

o Set the feature definition and name prefix to the 
desired feature for the node. The name prefix 
will increment the number for each node placed. 

• The first prompt is to select the element to use as a 
reference for the locations of the nodes. This will 
typically be your centerline. Select the desired 
element. 

• Next in the heads-up prompt you can select an 
element to be used for the grate/rim elevation or 
reset click (right click) to key in the elevation. If 
keying in an elevation, the same elevation will be 
used for all notes being placed whereas using an 
element for the reference elevation will use the 
elevation of that reference element at the given location of the nodes. 

Tip: If placing curb/curb & gutter catch basins, use the CURB_GUTTER element as the elevation 
reference. 

• Next if a reference element was selected for node elevation you can enter a vertical offset from that 
reference element. This is not shown in the heads-up prompt and needs to be entered into the tools 
dialog. If a reference element was not selected, you can enter the desired elevation. 

Tip: When entering a vertical offset value don’t forget the negative sign to offset below the 
selected element. Also, basic calculations are supported for example to vertically offset 0.5” below 
the reference element you can enter -0.5/12.  

Note: Don’t forget about catch basin depressions when placing catch basins for curb/curb & 
gutter. 

• Next specify the desired interval to place the nodes. And issue a Data Point (left click) to accept 
value 

• Next enter in the start station, which is the station location of the first node, the station value is 
based off the first element reference you selected with this tool, which is the reference element to 
be used for node location. Issue a Data point to accept the value. 

• Next enter the end station, which is the station location of the last node, the station value is based 
off the first element reference you selected with this tool, which is the reference element to be 
used for node location. Issue a Data point to accept the value. 

Note: If the end location ends at the exact station of an interval the value might need to be 
bumped up slightly for the software to place a node at that location, the view window will show 
the nodes as a preview which can be used to see where the nodes will be placed.  



 
Ohio Department of Transportation 
Office of CADD and Mapping Services August, 2022 

 

Information  900-22 
 

• Next enter in the desired offset. This is the offset from the selected element used for the node 
location. Issue a data point to accept the value. 

• Next specify the desired relative rotation of the node. This is relative to the selected element used 
for the node location. Issue a data point to accept the value. 

• Issue a final data point to finish placing the nodes and conduits. 

 

Placing Conduit 
To place conduit a node must exist at each and of the conduit. Think of a conduit as a link between 
two nodes. A link can’t exist between two nodes if there are not two nodes. 

The workflow for placing conduit is listed below. 

• Set the desired Feature Definition and Description 
(size) 

• Select the start node where the start of the conduit 
will connect to the node. 
o There are connection regions defined on the 

nodes to specify the locations the conduit can 
connect to. In general, the connection regions are 
to the inside boundary of the node. Square nodes 
have connection regions at the center of each side 
while circular nodes have the connection region 
all around the inside edge. 

• Select the end node where the end of the conduit will connect to the node 
o In rare situation a curve or bend can be introduced while placing the pipe by holding down 

the alt key or ctrl key while selecting the end node.  

Reviewing and Editing Nodes and Links 

After the nodes and links have been created, it is good practice to review the values for accuracy. The 
parameters of the 3D drainage information can be edited by using the MicroStation Element Selection tool 
to select a node or link, and then choosing the Properties icon from the pop-up menu as shown below. 
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The parameters are shown below. Note that the invert values for a link cannot be edited if the link was 
extracted from graphics. 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Currently the Node invert elevation will automatically 
change to match the lowest connected conduit invert elevation. Until this behavior is addressed by the 
software it is best practice to set all pipe begin and end invert elevations then set the node invert. 
 

Creating Profile Runs 

There are several tools available to help with creating profile runs. Profile 
runs can be created to view profiles of Drainage and Utility networks. 
Profile Runs can be as short as one pipe or “run” the whole drainage 
network.  

Node Properties 
Conduit Properties 
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Setting Description 

 

Hydraulic Run 
From Node 

Creates a profile run from a selected node to the outfall, or between two selected nodes. This 
tool only works on hydraulic (i.e. storm or sanitary) networks. 

 

Hydraulic Runs 
to Outfall 

Creates a profile run for every path, from the most upstream nodes to the outfall. These paths are 
sometimes known as trunks or branches. This tool only works on hydraulic (i.e. storm or sanitary) 
systems. 

 

Utility Run From 
Links 

Creates a profile run from selected links, for any type of utility (e.g. storm, communications, 
electric, etc.) The links must be consecutive, without gaps between them. 

 

Project Run 

Projects a profile run created using the tools above onto a linear element, which could be a road 
centerline, or another profile run. 

 

The Hydraulic Run From Node and Hydraulic Runs to Outfall tools are great for a more automated 
profile run creation process and the Utility Run From Links tool is a more manual process. This Guide will 
cover the process for using Utility Run From Links tool.  

Profile Runs must be created in the model containing the Drainage or Utility Network as well as the profile 
run can only include connected conduits (as in no branches or jumps in the network). 

 

Follow the process below to create a Profile run using the Utility Run From Links Tool. 

• Select the desired feature definition within the toolbox (there are ProfileRun1, ProfileRun2, 
ProfileRun3, and ProfileRun4 feature definitions created for this 
purpose. 
• Graphically select the first conduit desired to be included within the 

profile. 
• Continue selecting conduits to be included within the profile. 
• When done selecting conduit reset click (right click) to accept 

selection. 
 
Profile runs can be found from within the Drainage and Utilities Model Tab of Explorer in the profile 
Runs section. 
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There are several options in the right click menu of a profile run, as shown above. The profile run will also 
have linear element in the 2d plan view to represent the profile run. If using the ProfileRun1-4 feature 
definitions, then the 3d plan view graphic will be on the SC_ProfileRun1-4 level(s). note that the priority on 
these levels is set to be under the DR_P_Storm_Sewer level so it might be covered up by that level. 

Use the Open profile model tool to open the Profile Run’s Profile. After selecting this tool simply click inside 
the view window that you want the profile view to be displayed in.  

 

 

 

 

 

 

 

 

Some of the display settings for viewing Profile Runs are controlled via User Preferences > View Options – 
Civil. 
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Showing Proposed Ground on Profile Runs 
 In the profile view of a profile run the active terrain will automatically be displayed along with the 
drainage network itself. But the proposed ground is not shown. Take the following steps to add proposed 
ground to the profile run. 

A Profile run typically will be within the extents of a corridor. The Corridor top mesh can be used to project 
its top elevation online the profile run. The corridor has design stages set up so that the top mesh is display 
when the design stage is set to Final w/Meshes. If you do not see the CM_Corridor_Top_Mesh level in use in 
the 3d Design model of your corridor file then you need to open that file, select the corridor graphic and 
change the corridor feature definition to Final w/Meshes as imaged below.  

 

 

 

 

 

 

You can use the Profile from Surface tool to generate a dynamic profile from a surface. 

• When using this tool set the feature definition to                                      
Linear/Profiles/PF_P_Grade_Line.  

• Select the profile run (not the conduit feature, but the actual profile 
run) that you want to create the proposed ground profile for. 

• You can select multiple profile runs if desired.  
• Reset click (right click) to accept selection and move on to the next step. 
• Next select the surface to create the profile from. (You can select this from the view with the 3D 

model displayed) 

 
• Reset click to end surface selection after you have selected the desired surface 
• Alt to lock to start and click to accept 
• Alt to lock to end and click to accept 
• Set point selection to all and click to accept 
• Set profile adjustment to none and chick to accept 
• Set Draping options to Triangles and click to accept 
• Set Horizontal offsets to 0 and click to accept 
• Set vertical offsets to 0 and click to accept 

The profile is rules to the surface so if the surface changes this profile will automatically update with 
the changes. 
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Deleting projected profile runs 
If a profile run was projected onto a centerline on accident or no longer is needed, you can open the project 
view and delete the conduit and profile run graphic, but you will notice that the nodes can not be deleted. 
This is a bug. The work around is to regenerate the profile run. This can be done from Explorer as shown in 
the image below.  

 

 

 

 

 

 

 

 

Create Profile Run Sheets 

When putting together a plan set containing drainage there are a couple of options for how to display the 
drainage information. See L&D Vol. 3 section 1310.2 for details. One of the options is to show drainage 
information on a storm sewer profile sheet. This section will outline the steps to create these sheets. 

Storm Sewer profile sheets should be created within the Drainage Profile (DF) file. Use the Create Design 
files application to create a Drainage Profile sheet file. Note that Named boundaries will be placed to create 
these sheets and as outlined in chapter 800, the named boundaries can be placed in the same file the sheets 
are generated in or a container file. For this example, we will put the named boundaries in the same file the 
sheets are generated in. 
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• Create a Drainage Profile sheet, don’t forget to change 
the seed to 123456_DesignSeed2d.dgn 

 

 

 

• After creating the file, add all desired references. This is typically the Fieldbook, alignment, 
corridors, and Drainage basemap files. 

• Open the profile view of the Profile Run you would like to create a Storm Sewer Profile Sheet of. 
• Select the Place Named Boundary tool and set the mode to profile, and the Drawing seed to 

either Pro-Pro or Profile Only. Pro-Pro seed will stack two named boundaries on top of each 
other in one sheet whereas Profile Only will take up the whole sheet for one named boundary. 

• Set the scale to the desired value. 
• Data point inside the Profile view to select the view to place the named boundaries. 
• Data point to set the start location for the first named boundary. 
• Data point to set the end location for the last-named boundary. 
• Check on the Create drawing check box. 

Tip: there is a check box for Whole Conduits Only 
• Data point to accept and place the named 

boundary 
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• In the create Drawing dialog that opens make sure 
to set the drawing model scale to match the scale 
set in the place named boundary dialog. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
This will create a drawing model for each named boundary and sheet models. Annotation is placed 
in the drawing model.  

 

 

 

 

 

 

 

 

 

 

Tip: You can bulk create profile sheets for all profile runs by adding them to a selection set before starting 
the Place Named Boundary tool. There is a Graphical filter named Profile Runs which can be used with the 
Select by Graphical Filter Tool to help create the selection set. 
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Creating Profile Run sheets for divided highways  

This Section is currently under development. 

Setting up Drainage to show on Plan and Profile Sheets 

To have a drainage network to show up in the profile section of a centerline profile it first needs to be 
modeled using the Drainage and Utilities tools outlined in the Modeling Proposed Drainage Features 
section of this guide. After it is modeled a profile run can be created as outlined in the Creating Profile Runs 
section of this guide, and these profile runs can be projected onto the centerline profile. Crossing pipes can 
also be shown with the use of the 3d cut tool. This section will outline the steps to set this up. 

Projecting profile runs 
Profile runs can be projected onto other profiles with the Project Run tool. This projection can be 
done either from within the drainage basemap file or from a file that has referenced in the drainage 
basemap. Currently it is recommended to project profile runs onto alignments from within the 
drainage basemap. The following steps outline how to project profile runs. 

• Open the Drainage Basemap (BD) containing the drainage network you want to project to your 
center line alignment’s profile 

• Select the Project Run tool.  
• Set the Feature Definition to one of the ProfileRun features (typically 

the same feature definition you created the profile runs with). Leaving 
the feature set to No Feature Definition will put a projection on the 
default level. 

• Select the profile run you want to project 
• Select the alignment you want to project the profile run onto. 
• Open the profile view of the alignment to verify the profile run has been projected. 

 

 

 

 

 

The profile run is projected perpendicular onto the alignment’s profile. Notice if you turn off the 
DR_P_Storm_Sewer level you will see the Profile run element on the SC_ProfileRun1 level. 

 

 

 

Showing Crossing Features 
The previous section showed how to project a profile run onto an alignment but if there is a pipe crossing 
the road that is not shown. The create 3D cut tool can be used to show this crossing pipe. 
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• Select the create 3D cut button from within the Alignment’ profile view. 

 

 

 

• Data point to accept the placement method as corners 
• Data point in the profile view at one corner to start the area of the 3d cut 
• Next data point in the profile view at the opposite corner to create the 3d 

cut area. 
 

 

 

 

This process can be repeated for any number of 3d cut areas needed. Note that these areas 
can be selected and changed in size. You must hit the refresh 3d Cut button to update the 
graphics within the 3d cut area anytime a change it made included level display. This is a 
static 3d cut so changes to the model would require a refresh to the 3d cut as well. 

 

Setting up Utilities to show on Plan and Profile Sheets 

To have utilities show up in the profile section of a centerline profile it first needs to be modeled using the 
Drainage and Utilities tools outlined in the Extracting Utility Features section of this guide. After it is 
modeled its profile can be projected onto the centerline profile. Crossing utilities can also be shown with 
the use of the 3d cut tool. This section will outline the steps to set this up. 

Projecting Profiles 
The following steps show how to project utility profiles onto centerline profiles. This is a workaround 
workflow to using profile runs until some defects/enhancements are addressed with ORD. Utility text 
favorites for annotation will not be able to be used with this workflow! See alternative workflow for 
projecting profiles section for more info. 

Currently to project a utility profile onto the centerline profile you must be within the file that contains the 
centerline element. This is typically a BK file. 

1. Open the file containing the centerline alignment that the plan and profile sheet will be based 
upon. 

2. Add a reference to the utility basemap.  
3. Select the Project Profile to Element Tool 
4. Select the appropriate feature definition 
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5. Select the Utility you want to project 

 
6. Select the Centerline you want to project onto 

 
7. Open Profile View of centerline to verify the utility profile was projected. 

 
 

 

 

 

 

Note: The Utility feature definitions are set up to project the top of the conduit (not the invert) whereas 
Sanitary and Drainage project the bottom (invert).  

Alternative workflow for projecting Utility Profiles 
This workflow will project utilities onto centerline profile. This will allow for easier annotation of utilities 
with the use of text favorites, but the projection will show two lines (top and bottom of conduit). Typically 
for small diameter utilities we only show one line. There is currently a bug where the profile run graphic 
does not follow the profile of the pipe. When this is fixed this will be the preferred workflow. 

 

To have a utility network show up in the profile section of a centerline profile it first needs to be modeled 
using the Drainage and Utilities tools outlined in the Extracting Utility Features section of this guide. After it 
is modeled a profile run can be created as outlined in the Creating Profile Runs section of this guide, and 
these profile runs can be projected onto the centerline profile. This section will outline the steps to set this 
up. 
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Profile runs can be projected onto other profiles with the Project Run tool. This projection can be 
done either from within the utility basemap (BU) file or from a file that has referenced in the utility 
basemap. Currently it is recommended to project profile runs onto alignments from within the 
utility basemap. The following steps outline how to project profile runs. 

• Open the Utility Basemap (BU) containing the utility network you want to project to your center 
line alignment’s profile 

• Select the Project Run tool.  
• Set the Feature Definition to one of the ProfileRun features (typically 

the same feature definition you created the profile runs with). Leaving 
the feature set to No Feature Definition will put a projection on the 
default level. 

• Select the profile run you want to project 
• Select the alignment you want to project the profile run onto. 
• Open the profile view of the alignment to verify the profile run has been projected. 

 

 

 

 

 

 

 

 

 

 

 

The profile run is projected perpendicular onto the alignment’s profile. Since all conduits must connect to a 
node, you will notice nodes draw in, these are on the Default level and should be turned off. Also notice the 
profile run graphic and the bug that is does not follow the utility profile. This need turned off as well. This 
graphic will be on the SC_ProfileRun1 level is the ProfileRun1 feature definition was used. Also notice the 
two lines for the top and bottom of the conduit. In a future release of ORD when the profile run graphic is 
fixed to follow the conduit profile, the workflow will be to turn off the conduit and leave the profile run 
graphic on.  The Showing Drainage and Utilities on Plan and Profile Section will show how to get these 
projected utilities to show up on profile sheets with the use of the attach all profile views button. 

Showing Crossing Features 
The previous section showed how to project a utility’s profile onto an alignment but if there is a utility 
crossing the road that is not shown. The create 3D cut tool can be used to show this crossing utility. 

• Open the Utilities Basemap. 
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• Select the create 3D cut button from within the Alignment’ profile view. 

 

 

 

• Data point to accept the placement method as corners 
• Data point in the profile view at one corner to start the area of the 3d cut 
• Next data point in the profile view at the opposite corner to create the 3d 

cut area. 
 

 

 

 

This process can be repeated for any number of 3d cut areas needed. Note that these areas 
can be selected and changed in size. You must hit the refresh 3d Cut button to update the 
graphics within the 3d cut area anytime a change it made included level display. This is a 
static 3d cut so changes to the model would require a refresh to the 3d cut as well. 

 

Showing Drainage and Utilities on Plan and Profile sheets 

The previous two sections showed how to set up drainage and utilities for plan and profile sheets. Now that 
the setup is done this section will show the steps for showing these features on a plan and profile sheet. 

Note that Named boundaries will be placed to create these sheets and as outlined in chapter 800, the 
named boundaries can be placed in the same file the sheets are generated in or a container file. For this 
example, we will put the named boundaries in the same file the sheets are generated in. First, we will need 
to create a plan and profile sheet file to set up for our plan and profile sheet.  

• Create a Plan and Profile sheet, don’t forget to change the seed to 123456_DesignSeed2d.dgn 

 

• After creating the file, add all desired references. This is typically the Fieldbook, alignment, 
corridors, Right of Way basemap, Drainage basemap, and Utility basemap files. 
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• Open the profile view of the alignment that the plan and profile sheet will be based on. 
 

• Select the Attach All Profile Views button from within the profile view window. 
This will attach the profile view for any references that have drawn content for 
this profile view within that reference file. 
 

 

 

 

 

 

• Select the Place Named Boundary tool and set the mode to Civil Plan, and the Drawing seed to 
either Plan-Pro - PLAN. 

• Set the scale to the desired value. 
• Select the Center Line alignment which will be used to 

create named boundaries along. 
• Key in or data point at the station you want the first 

named boundary to start at. 
• Key in or data point at the station you want the last-

named boundary to end at. 
• Before issuing a final data point to place the plan view 

named boundaries make sure to check off create 
drawing, as we don’t want to create the drawings 
until we set up our profile named boundaries. 

• Now data point in the view window to accept and 
place the plan view named boundaries 

• Select the Place Named Boundary tool again and this 
time set the mode to Civil Profile, and the Drawing 
seed to either Plan-Pro - Profile. 

• Set the scale to the same set when placing the plan 
view named boundaries. 

• Set the Method to From Plan Group and set the plan 
group to the group that was just created with the plan 
view named boundaries. this is typically the name of 
the selected alignment. 

• Data point inside the view window containing your profile view. 
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• The profile named boundaries should now be shown in 
the profile view window. These are temporary 
graphics. 

• Before issuing the final data point make sure to check 
on the Create Drawing and show dialog checkboxes 
since now, we are ready to generate the sheets. 

• Now data point in the profile view to place the profile 
Named boundaries. 

• Since Create Drawing was check on the software will 
not start generating the sheets. Since Show Dialog is 
check on a dialog will show up where you can 
review/edit settings for the sheet creation. 

• Below shows the screen shot of the create drawing 
dialog. Make sure the Drawing model annotation scales 
match the scale you selected when placing the named 
boundaries, make sure the sheet model annotation 
scale is 1:1 and the sheet model detail scale matches 
the scale you selected when placing the named 
boundaries. Select OK and the software will generate 
the sheets. 
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Showing Drainage and Utilities on Cross Sections 

This section will explain how drainage and utility features are shown on cross section sheets. Refer to 
Chapter 800 of this guide for details on creating cross section sheets. 

 
If you have modeled the drainage and utilities as outlined in this chapter with using the drainage and 
utilities tool, then your drainage and utilities should be modeled in 3D. When cross sections are generated, 
the graphics that are displayed on the cross sections are a slice of the 3d model. This means that when you 
cut cross sections if a drainage or utility feature is in 3d model at the location of the cross section then it 
will be displayed on the cross section.  
 
If you want to show drainage nodes on cross sections, then a section cross must be cut at the location of the 
node. 
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Annotating Drainage and Utility Features 

Several things have been set up to assist in the process of annotating drainage and utility features. 
Annotation of drainage and utility features starts with Text Favorites. Text Favorites are basically 
predefined text that contains text fields. These text fields are placeholders for property values. The 
properties can come from element properties, model properties, file properties, etc. 

An excel file can be found within the OHDOT cadd standards that provides more detail on what text 
favorites are available for Drainage and Utilities and example of each one. The screen shot below shows 
some of the text favorites.  

\..\WorkSpaces\OHDOT\Standards\OHDOT Utilities\Documentation\Drainage and Utilities Text 
Favorites.xlsx 

**PLEASE NOTE CURRENTLY ANNOTATION FOR DRAINAGE AND UTILITY FEATURES DOES NOT WORK 
ACROSS A REFERENCE. WITH ORD 2020 R3. YOU CAN ANNOTATION ACROSS A REFERENCE WHILE YOU 
ARE IN THE FILE BUT WILL NEED TO COPY/PASTE THE TEXT FIELDS DOWN TO STATIC TEXT FOR 
PRINTING. THIS SHOULD BE FIXED IN AN UPCOMING RELEASE OF ORD. IF USING A VERSION PREVIOUS 
TO ORD 2020 R3 THEN ANNOTATION WILL NOT WORK ACROSS A REFERENCE. IF USING ORD 2020 R3 
THEN SEE ANNOTATING IN ORD 2020 R3 SECTION FOR WORKFLOW. ** 
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Typically, annotation should be done in the drawing models. 
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There are several tools available to assist in placing annotation. 

 

 

 

Place Label: can place cells or text favorites with or without a leader line.   

Element Annotation: if the element has an annotation group defined then element annotation will 
annotate the element. 

Remove Element Annotation: removes the annotation that’s associated with the element. 

Model Annotation: annotates the entire drawing model. 

Remove Model Annotation: Removes all annotation from the model that was. 

Plan View Drainage Annotation 

Call outs  
 There are many ways to annotate a cell out. One way is to use _Lbl_Pln_FeatureName cell with the 

Place Label tool. This cell uses the Plan – Feature Name Text favorite and puts a circle around it. 
The Plan – Feature Name text favorite will display the feature name of the specified feature.  

When using the place label tool make sure to select the element or the label will not get associated to that 
element and won’t be able to pull properties from the element.  

  

 

 

 

 

 

 

 

Note: Element annotation has been defined for Proposed Catch Basins, Manholes, and Inlets to place these 
call outs.  

 Plan View Drainage Pipe Annotation 

 Pipe Annotation has been defined on all proposed conduits. This means   can be 
used. This will place a flow arrow in the direction of flow for the pipe as well as the size and type. 
Note that the type is coming from the Notes drainage property which has been preset on the feature 
definition. 
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 ** While annotation should typically be placed within drawing models. There are currently some 
bugs in the software, and it is best to place these pipe annotations in the Drainage Basemap file. ** 

 

Profile View Drainage Annotation 
 When profile sheets are generated, features that have annotation groups defined will automatically 
get annotated. Both node and pipe annotations for profile view have annotation groups defined so these 
elements should auto annotate. Note that more work needs to be done to the node annotation.  

Node Annotation 
 As mentioned above node annotation should be auto annotated during sheet 
creation. The Model annotation and Element annotation tools could be used 
as well. But the annotation is missing the information about the connecting 
pipes. Currently this cannot be auto annotated. Follow the below steps to add 
in the annotation for each pipe that connects to the node. 

• Double click on text element or use edit text tool to open the text editor 
for the node annotation. 

• Within the text editor insert a text favorite for the connected pipe. There 
are two text favorites to choose from for proposed nodes 

 
The Profile/XS DrainageNode-P-PipeEnd will pull the end of the pipe invert elevation while the 
Profile/XS DraiangeNode-P-PipeStart pulls the start of the pipe invert elevation.  
 
NOTE: the pipe start/end locations represent the order/direction the pipe was drawn in not 
necessarily the direction of flow. Care must be taken to select the correct text favorite.  
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• After selecting the text favorite, it will be inserted into the text editor dialog. But the fields 
within the text favorite still need to be assigned to an element to know the property values 
to display. To do this you simply right click on the field and select reassign then select the 
element to assign the field to. Repeat this for all the fields. 

  

 

 

 

 

• The (D) standards for direction and must be manually typed in. This is the direction the 
pipe is going away from the node. 

 

 

 

• Repeat the above two steps for any additional pipes connected to that node making sure to 
select the appropriate text favorite for each pipe.   
 
 
 
 

This process is the same for existing drainage nodes with the exception that the Profile/XS 
DrainageNode-X-PipeEnd and Profile/XS DrainageNode-X-PipeStart should be used instead. 

 

Additional Info 
 The auto annotation of nodes is using the Profile/XS DrainageNode-P or Profile/XS 

DrainageNode-P-MH text favorites (Profile/XS DrainageNode-X, and Profile/XS 
DraiangeNode-X-MH text favorites for existing). You could use the Place Label tool with 
these text favorites to achieve the same annotation.  
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The structure type field in the annotation is coming from the Notes drainage property as imaged below. 

 

 

 

 

 

 

 

 

STATION AND OFFSET ANNOTATION 
The Station and offset values are coming from a point constraint property that 
has been applied to the node. These point constraint properties are only added if 
the node was placed using civil AccuDraw station-offset ordinate or the Place 
Nodes tool. If the node was not placed using one of the above two mentioned 

methods, then the annotation will not have a station or offset property to get the value from and will be 
blank. If this is the case, you can either use civil AccuDraw station-offset ordinate while moving the node 
(to the same spot) to apply the needed point constraints or below lists an alternative workaround to 
annotating station and offset. 

• In the Drainage basemap select all the drainage nodes and open the Properties dialog. 
• In the properties dialog select the three horizontal dots in the 

Station/Offset Reference property. 
• Now select the desired alignment to use that the station/offset reference. 

 
• Now go back to the Profile Drawing model. 

 
• Additional text favorites have been set up to use the Station/Offset Reference properties 

instead of the point constraint properties, but there are limitations to the formatting of 
these text favorites. The text favorites available are Profile/XS DrainageNode-
P_Unformatted, Profile/XS DrainageNode-P-MH_Unformatted, and Profile/XS SanNode-P-
MH_Unformatted (Profile/XS DrainageNode-X_Unformatted, Profile/XS DrainageNode-X-
MH_Unformatted, Profile/XS SanNode-X-MH_Unformatted text favorites for existing). 

 
• Use the Place label tool and select the Profile/XS DrainageNode-P_Unformatted text favorite 

for inlet nodes, Profile/XS DrainageNode-P-MH_Unformatted text favorite for storm 
manholes, or Profile/XS SanNode-P-MH_Unformatted text favorite for sanitary manholes. 

 
• After placing the label, you will notice that the station value is not formatted correctly, this 

is a current limitation of the software that will eventually get fixed.  
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• Edit the text element and type over the station text field to format it as desired. Note that 
this will make the station value static and if the node is moved the value will not 
dynamically update. 

 
 
 

• Follow the Node Annotation section for the steps on annotation the connecting pipes. 

Pipe Annotation 
 As mentioned above pipe annotation should be auto annotated when profile sheets are generated. 

Model Annotation and Element Annotation tools could be used as well. 
This auto-annotation is using the Profile DrainagePipe-P text favorite 
(Profile DraingePipe-X text favorite for existing). You could use the Place 
Label tool to achieve the same annotation.  

The Length value in this text field is the center of node to center of node length. The slope value is also 
based off the center of node to center of node length. Just as in the plan view annotation the Type is coming 
from Notes Drainage Property. 

Cross Section View Drainage Annotation 
 Cross section drainage annotation is very similar to Profile drainage annotation except that element 
annotation tool will not work for cross sections and currently nothing is auto annotated.  

 Cross section annotation should be done in the drawing models that are created from named 
boundaries. 

Node Annotation 
Unlike Profiles, drainage networks are not projected to the nearest cross section. If you want to 

show a drainage node on a cross-section, then a cross section must be cut at that location. The same text 
favorites that are used to annotate nodes in a profile view are used to annotate nodes in a cross-section 
view. Please follow the Profile View Drainage Annotation – Node Annotation Section for the workflow. 

When annotating connecting pipes (as outlined in the Profile View Drainage Annotation – Node 
Annotation Section) there is a good chance that the connecting pipe will not be visible on the cross section 
making it hard to pull annotation values for that pipe. Follow the steps below to temporary display the 
connecting pipes to set up the connecting pipe annotation. 

• Select the 3d named boundary from the 3D model for the cross section containing the 
drainage node that has connecting pipes that are not visible and change the Forward or 
Back Depth properties. This will widen the cross-section slice to show a thicker section of 
the 3D. the Forward depth will widen the named boundary in the up-station direction. The 
value needs to be great enough to get the named boundary to cut where the pipe is. 
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• After the value is updated notice how the connecting pipe shows up in the cross-section 
view. Now the connection pipe annotation can be added to the node. (Follow the steps 
outlined in the Profile View Drainage Annotation – Node Annotation Section). 

 

 

 

 

• Change the Forward/Back depth back to zero. And repeat of the other side if needed. 

Pipe Annotation 
Pipes will only be shown in the cross section if that pipe is crossing the Cross section named 
boundary. 

The following steps outline how to annotate these pipes. 

• Select the Place Label Tool. Select type then set as Text 
Favorite and use the XS DrainagePipe-X for existing 
pipes and XS DrainagePipe-P for proposed pipes. 
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• Select the pipe and place the annotation 
 

 

 

Just as in the plan view and profile view annotation the Type is coming from Notes Drainage Property. 

Profile View Utility Annotation 
While there are several text favorites set up for utility annotation, these will not work if the 

workflow outlined in the Setting up Utilities to show on Plan and Profile Sheets - Projecting Profiles section. 
This is because that workflow is just creating profiles using regular linear feature definitions and NOT an 
actual conduit feature definition, meaning that none of the utility properties exist on those elements. This 
workflow is used because currently projecting the actual utility shows two lines (the top and bottom of the 
conduit). Typically, we only show one line for these utilities as the diameter is small and two lines adds a 
lot of unneeded clutter. If you would like to use text favorites to annotate utilities, then follow the 
alternative workflow for projecting utilities section.  

• If the Setting up Utilities to show on Plan and Profile Sheets - Projecting Profiles section was used to show 
utility profiles on centerline profile, then annotation will be manual using the Place Note tool. 

By hovering over the element, you can see what feature/level it is on to know what utility it is 
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Then use the place note tool to place the annotation as shown in the screen shot below. 

 

 

 

 

 

 

 

 

 

 

 

• If the Alternative workflow for projecting utilities section was used to show utility profiles on centerline 
profile, then annotation can be dynamically pulled from the utility properties using text favorites with the 
Place Label Tool. (Remember if you’re missing the projected utility runs to use the Attach all profile 
views button). 

Remember before annotating Drainage & Utility features that the Drainage & Utility Project needs 
to be created in this project so that the drainage & Utility properties can be accessed. This is done easily by 
simply opening the Utility properties of any of the Drainage and Utility elements that are referenced into 
the file. 

 

 

 

Now simply use Place Label tool. Note the different text favorites available for utilities.  
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Text favorites are specific to the utility type. For each type there is a text favorite for annotating just 
the utility type and another for the utility size and type. 

The Utility text favorites are pulling the Network Type (User Defined) property. This has been 
predefined on the utility feature definitions with appropriate values. 

 

 

 

 

Currently this method does show a line for the top and bottom of the utility. You could also follow 
this workflow Setting up Utilities to show on Plan and Profile Sheets - Projecting Profiles to show utility as 
one line in addition to this workflow, Alternative workflow for projecting utilities to use with the text 
favorites and turn off levels from the utility run projections. 

 

Cross Section View Utility Annotation 
Cross section utility annotation is very similar to Profile Utility annotation.  

 Cross section annotation should be done in the drawing models that are created from named 
boundaries. 

 Use The Place Label Tool with the Utility text favorites to annotate Utilities in cross section 
drawing models. 
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See the Profile View Utility Annotation Section for more details in the Utility Text Favorites.  

 

Annotation in ORD 2020 R3 
With ORD 2020 R3 it is possible to annotate drainage and utility features across a reference. There are still 
some bugs that will be fixed in a future release of ORD. For now, to annotate Drainage & Utility features 
across a reference you first open the utility properties of any referenced in node/conduit. You will be 
prompted with the below dialog. Select yes and it will then expose the Drainage & Utility properties from 
the reference, which can then be used within text favorites. 

 

 

 

 

 

 

 

 There are two major bugs when annotates Drainage and Utility features across a reference in ORD 2020 
R3.  

1. Auto-Annotation (element/model annotation) does not associate fields in text favorites to the 
actual element. (It does not work).  

To fix this, every field within the text favorite needs to be re-assigned to the element. 
 

2. Annotation values do not hold after you close and reopen the file.  

The workaround for this is to change the fields to static text. This will make it so the values 
WILL NOT update if the Drainage & Utility network changes.   
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After you close and reopen the file, you will notice that the Drainage & Utility annotation are 
blank. 

  

 

 

To fix this you must again open the Utility properties.  

 

 

 

Now the text field should refresh, and the annotation will have the correct values. 

 

 

 

When printing sheets to PDF this does have the possibility to print to PDF without the 
values. To alleviate this possibility, you can copy and paste the text fields down to static text. 
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OpenRoads Software Version 
This document was prepared using the following software version: 

OpenRoads Designer CONNECT Edition – 2020 Release 3 Update 9 – Version 10.09.00.91 

This document was updated using the following software version: 

OpenRoads Designer CONNECT Edition – 2021 Release 2 Update 10 – Version 10.10.21.04 

 

Contacts 
For any questions, suggestions, or problems with this document please contact the ODOT Office of CADD 
and Mapping Services by use of the following form on the ODOT website: 

https://odot.formstack.com/forms/cadd_servicerequest 
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