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OpenRoads Designer: 
Horizontal Geometry 

 

OpenRoads Geometry Tab 

The OpenRoads Geometry commands are selected from the Geometry tab of the OpenRoads Modeling 
workflow, as shown below. 

 
The commands are separated into two main categories, General Tools and Horizontal as shown above. 

This training guide will not document each geometry tool that is available in the OpenRoads interface. See 
the online help for commands not detailed in this document. 
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Feature Definitions 

As you draw information using the OpenRoads horizontal geometry tools, OpenRoads Feature Definitions 
are used to define the plan view representation of an object as well as how the object will appear in other 
contexts such as the profile, cross sections, and 3D. 
 
What is a Feature? 
Simply stated, a feature is anything in your design that represents a real-world object such as: 

 Curb and Gutter 
 Pavement 
 Catch basins, Manholes, Inlets 
 Walls 
 Ditches 
 Cut and Fill Slopes 
 Etc. 

 
Features are defined in MicroStation DGN Libraries. The OHDOT configuration defines which feature 
libraries are available for ODOT use. The available feature definitions can be reviewed in the Explorer 
dialog as shown below. 

 
In addition to defining the symbology settings, 
feature definitions can also define annotation 
settings for each item. 
 
For example, the Alignment feature 
definitions also define how an alignment will 
be annotated using the OpenRoads Element 
Annotation and Model Annotation 
commands. These tools are described later in 
this document. 
 
The features are organized by categories. 
Expanding a category will reveal the features 
available in the category. 
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The feature definition is assigned when an element is placed. This can be accomplished by choosing the 
Feature Definition from the Tool Settings dialog as shown below. 

 

Feature Name 
As civil geometry elements are placed, each element is given a feature name. The Name field displays the 
seed name that has been assigned to the selected feature definition. 
 
In the example at right, the Line Between Points command has been 
selected. The GE_P_Alignment feature definition has a seed Name 
prefix of CLP_1 defined. If the name value is not changed, the software 
will automatically increment the name of each line placed. For 
example, the first line placed is named “CLP_1”, the second is named 
“CLP_2”, etc. 
 
Note: By default, the software always displays the seed name, not the 
actual name of the element that is placed. 
 
The element name can be reviewed by using the Select Element tool and 
floating the cursor over the element as shown below (you do not need to select the element). 

 
The Feature Definition and Feature Name for a selected element can be edited in the Properties dialog as 
shown below. 
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Standard element names for alignments are defined in the ODOT 
CADD Engineering Standards Manual. 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Feature Definition Toggle Bar 
 
The Feature Definition Toggle Bar is accessed from the ribbon by selecting OpenRoads Modeling > 
Geometry > Standards > Feature Definition Toolbar. 

 
Toggle on the first icon to automatically assign the selected feature as the active feature as you use various 
OpenRoads Geometry commands. 
 
In the example below, the Line Between Points command is selected. The Feature Definition is defined 
by the active feature selected in the Feature Definition Toggle Bar. 

 
See the online help for a description of the remaining Feature 
Definition Toggle Bar icons. 
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Geometry Rules 

Civil Geometry elements drawn using the OpenRoads tools are “ruled” graphics that behave according to 
the geometric rules that define how the element was placed. 
 
For example, a line drawn using the Line Between Points command has the following rules: Distance and 
Line Direction as shown below. 

 
These parameters can be entered in the Tool Settings dialog, shown at right above, or by using the 
parameters floating on the cursor. 
 

 If you use the input field that floats on the cursor, the left and right arrow keys are used to switch 
between multiple parameters. 
 

 When a parameter value is entered, it is locked as shown below. The parameter can be unlocked by 
unchecking the item in the Tool Settings dialog, or by pressing the End key on the keyboard while 
the parameter value on the cursor has the keyboard focus. 

 
 After a parameter value has been keyed in, use the left and right arrow keys, or the Tool Settings 

dialog to enter values for the remaining parameters 
 

 Issue a data point (left-click) to place the element. 
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The rules can be reviewed and edited by using the MicroStation Element Selection tool to select the 
element. In the example below, the rules for the selected line are displayed. 

 
The rules can be edited by left-clicking on one of the parameters as shown below. 

 
The rules for the selected element can also be reviewed and edited in the Properties dialog as shown 
below. 

 
MicroStation’s Manipulate commands (Copy, Scale, Rotate, etc.) cannot be used on ruled geometry. The 
rule must be removed to use these commands. 
 
To remove a rule, select the element and let the cursor rest on the selected element until the pop-up menu 
appears. Choose the Rules menu as shown below. 
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The following options are provided: 

 Deactivate Rules (Activate Rules is the selected elements rules are currently deactivated) 
 Remove Rule 
 Activate Referencing Rules 
 Deactivate Reference Rules 
 Remove Rule (Remove Referencing Rules) 

 
Selecting the Deactivate/Activate Rules and Remove Rule icons affect only the selected element. 
 
Reference rules are elements upon which the chosen element is dependent, thus a curve between elements 
depends on the two other elements that define it. This command allows deactivating the rules for those 
other elements. 
 

Element Manipulators 
OpenRoads Geometry elements have Manipulators that are displayed in MicroStation when an element is 
selected. These manipulators can be used to edit the selected element graphically or by entering a value. 
 
Clicking on one of the key-point manipulators will display direction arrows to edit the line, as shown on the 
example below. 

  
Tip: The size and color of the Manipulator Text can be adjusted in the User Preferences. From the 
MicroStation menu, select File > Settings > User > Preferences and then choose the View Options – Civil 
item on the left side of the dialog. The Manipulator Size or the Manipulator Font Scale parameters can be 
used to adjust the text size. 
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Design Intent 
As geometric elements are drawn in MicroStation using the OpenRoads Horizontal Geometry tools, the 
software retains information about not only what element was drawn, but how it was drawn. This is 
referred to as the Design Intent. 
 
In the example below, the horizontal line was drawn first. The second line was drawn using the 
Perpendicular snap to draw the line at a perpendicular form the horizontal line to a specific ending point. 

 
If the horizontal line is modified by changing the direction of the line, the design intent for the 
perpendicular line is preserved. The Perpendicular rule, and the ending location are preserved as shown 
below.  
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Snaps 
As geometry elements are placed in the design, the elements are “ruled” to one another using snaps. 
 
The most common snap is the Key Point snap. In the example below, the second line was placed using a Key 
Point snap. When the line is selected, the icon for the snap mode that was used is displayed. 
 
If the first line is modified, the second line will maintain its relationship to the first line according to the Key 
Point snap rule. 
 

 
 
 
 
 
 
 
 

 
 

Occasionally you may wish to create civil geometry elements that are not “ruled” to other elements. Turn 
off the Persist Snaps icon on the Feature Definition Toggle Bar to place civil geometry elements by 
snapping to other geometry without creating a rule. 
 

  

Editing Dynamic Text 
When a civil geometry element is selected, and the various rules are displayed, some rules are shown in 
grey and cannot be edited by left-clicking on the text. To edit these rules, you must select the underlying 
geometry directly. 

 
Take the following steps to select the underlying element. 
 

 Use the MicroStation Element Selection tool to select the geometry element 
 Right-click on the element that you wish to edit 
 The underlying element is selected, and the associated rules can be edited as shown below 
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Deactivating Rules 
Geometry elements that have active rules can be selected, edited, and deleted at any time. Deactivating the 
rules will lock the element in place so that it cannot be edited or deleted unless the rules are reactivated. 
This is useful to lock an alignment in place once the design has been completed. 
 
To deactivate the rules on a given element, select the element and let the cursor rest on the element until 
the pop-up menu appears. Choose the Deactivate Rule option as shown below. 

 
Multiple elements can be locked at once by choosing Geometry > Civil Toggles > Deactivate Rules. 
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Design Standards  

Design Standards are used to monitor various alignment parameters on OpenRoads geometry elements. 
The standards are stored in the DGN Library OHDOT_DesignStandards.dgnlib. 
 
The design standards can be used for two purposes: 
 

 Provide default values for element creation tools such as radius of a curve for a selected ODOT 
standard 

 Check and report on the compliance of a geometric element with the design standard that has been 
assigned to the element 

 

When a design standard is violated, the user is notified in two ways: 
 

 An icon is displayed on the graphics to indicate that there is a problem 
 The Civil Message Center reports any errors 

 
The Design Standards Toolbar allows you to select and apply a design standard. From the OpenRoads 
Modeling Geometry tab, select Standards > Design Standards Toolbar to access the dialog shown below. 

 
The toolbar contains a drop-down list to select the design standards and the design speed. The vertical 
design standard, displayed in the drop-down menu to the right, is automatically set when the horizontal 
design standards is selected. 
 
There are two icons located to the left of the drop-down menus. The first, Set Design Standard, is used to 
apply the current design standard to selected geometric elements. The second, Toggle Active Design 
Standard, is used to set the selected design standards active for relevant commands. 
 

To Apply a Design Standard 
The example below details the process to apply a selected design standard to the Simple Arc command to 
place a curve between two tangent lines. 
 

 The Design Standards Toolbar is set to the ODOT standard 202-7E, 2-Lane Undivided with a 
design speed of 55 MPH 
 

 The Toggle Active Design Standard icon is checked on 
 

 Using the Simple Arc command, the Radius value defaults to the value defined in the selected 
design standard, 954.9279 
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 The design standard defines a minimum transition length of 205 for the default radius. Spirals will 
be placed even though the Simple Arc command was initially selected. 

 

Design Standards can also be applied to an element after it has been created by using the Set Design 
Standard icon on the Design Standards Toolbar. 
 

To Review a Design Standard Violation 
If a design standard is violated, the software will display an icon on the element with the violation like the 
example below. Floating the cursor over the icon will display the error message. 

 
Errors can also be reviewed in the Civil Message Center by selecting Geometry > Standards > Civil 
Message Center. Toggle on the Error option to view any errors. 

 
You can zoom to the error by right-clicking on the error and choosing the Zoom To option. 
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Complex Geometry 

Individual civil geometry elements are connected together as a single entity using the Complex By 
Element command. 
 
Select Geometry > Complex Geometry > Complex By Element to access the command. 

 
In the example above, the Feature Definition is set to Use Active Feature as defined in the Feature 
Definition Toggle Bar. 
 
When the Method is set to Automatic, the software will automatically select elements to make up the 
complex geometry by searching for elements with endpoints that connect within the Maximum Gap value. 
If a fork is found, where two elements are found within the Maximum Gap tolerance, the user is prompted 
to identify which path to accept to compete the operation. 
 
Be sure to enter a Name for the geometry. Standard geometry names are defined in the CADD Engineering 
Standards Manual, Section 306.2. 
 
When locating the starting element an arrow is displayed defining the direction to store the element. 
Complex elements can be stored in the opposite direction than they were originally defined by selecting the 
other end of the graphics. 
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Stations and Station Equations 

Start Station 
When an OpenRoads alignment is stored, the software assumes a beginning station value of 0+00. The 
station can be redefined by use of the Start Station command. 

 
 
The command has two parameters: 
 
Start Distance 
The distance along the alignment to assign the Start Station. The 
beginning station is computed based on the Start Distance and the 
Start Station value. 
 
Start Station 
The station value to be assigned at the Start Distance location. 
 
 
 

 
 

 
After the beginning station has been defined, selecting the alignment will display the station rules as shown 
below. 

 
 
 
 
 
 
 
 
 

 
The station parameters can be edited by selecting the rule in the design file, or from the Properties dialog. 
 

Add Station Equation 
The Add Station Equation command, located below the Start Station command, adds parameters for the 
Ahead Station and Back Station. 
 
When the command is selected, the user is prompted to select the alignment to assign the station equation. 
 
After the alignment has been selected, the location of the equation can be identified graphically, or by 
keying in the Back Station value. 
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The ahead station is stored as a “region” much like the legacy GEOPAK format. When the Ahead Station 
value is entered, it is not necessary to define the region number. 
 
The station equation value can be reviewed and edited by selecting the element as shown below. The 
parameters can also be edited in the Properties dialog. 
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Reports 

Several preconfigured reports are provided with the OpenRoads software that can be used to review 
alignment information. 
 
Various reports can be accessed from the Home tab, as shown below. 

 
Additionally, reports can be generated by selecting a civil geometry element and choosing the Reports icon 
from the pop-up menu. 

 
When a report is generated, the default report for the element type is displayed. The example below shows 
the default report for an alignment. 
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Several reports are available and can be selected from the list at left. Depending on the element type that 
the selected report has been configured to accept, it may not show any information. 
 
The format of the report can be modified by selecting Tools > Format Options. The dialog below is 
opened. 

 
The format options are stored as 
a user setting in the Windows 
Registry and must be manually 
set by each user on their 
computer. 
 
The settings shown at left are 
recommended for ODOT 
projects. 
 
Changes made to the Format 
Options dialog are dynamically 
applied to the current report 
when the dialog is closed. 
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Reports can be saved in various formats using the File > Save As… command from the main Report 
Browser dialog. Reports should be saved to the EngData Folder of the project to the corresponding 
engineering discipline.  
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OpenRoads Software Version 

This document was prepared using the following software version: 

OpenRoads Designer CONNECT Edition – 2021 Release 1 Update 10 – Version 10.10.01.03 

This document was updated using the following software version: 

 OpenRoads Designer CONNECT Edition – 2022 Release 3 Update 12 – Version 10.12.02.04 

 

Contacts 

For any questions, suggestions, or problems with this document please contact the ODOT Office of CADD 
and Mapping Services by use of the following form on the ODOT website: 

https://odot.formstack.com/forms/cadd_servicerequest 

 

 


