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OpenRoads Design: 
Modeling Existing Features 

 

Overview 

Existing features such as the existing pavement, sidewalk, and driveways, can be modeled by creating a 
surface terrain model from the survey elements and then applying a surface template to the terrain. 

This document will demonstrate the process to generate a terrain model for the surface of the existing 
pavement for Jameson Road. This surface terrain model will be created using the surveyed edge of 
pavement, center of pavement, and break line elements. After the surface terrain has been defined, a 
template with the existing pavement buildup will be applied to the surface terrain to create the 3D mesh 
elements representing the existing pavement buildup. Once defined as a 3D mesh element, the existing 
pavement can be displayed on the cross sections and used in quantity calculations. An example of the 
existing pavement as shown in a dynamic cross-section view is shown below.  

 

Note: See Page 15 for alternative method using the Create Closed Mesh tool. This method doesn’t support 
the Element Component Quantities.   
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Exercise 1: Modeling the Existing Pavement using a Surface Terrain Model 

This section will demonstrate the process to create 3D mesh elements for the existing pavement. A portion 
of Jameson Road will be removed so we will create two separate surface terrains, one for the portion that 
will remain in place, and a second for the portion to be removed. 

Part 1: Creating the Existing Features Design File 
A new design file will be for the 3D mesh elements representing the existing features. 

 Open ProjectWise Explorer 

 
 

 Browse to the folder containing the training data. The folder location will be provided by the 
instructor for each class. 

 Browse to the 400-Engineering\Roadway\Basemaps\ folder. 
 Open one of the design files for the WorkSet. The file opened does not matter since it is being used 

to access the file creation application. 

Create a new design file to use for modeling the existing features. Select the OHDOT Create Design Files 
application (OHDOT WorkFlow) to create the corridor modeling basemaps for the project. 

 
 Use the Roadway Digital Terrain Model file type, “KD”, to model the existing features 
 Choose the Create Files button to initiate the process. 

Part 2: References 
The surveyed edge of pavement and center of pavement elements will be used to generate the 3D mesh 
elements representing the existing pavement. 

 Attach the following files as references (Home > Attach Tools > References): 

Geometry Basemap for Jameson Road: 
400-Engineering\Roadway\Basemaps\123456_BK003.dgn 
 
Survey Basemap: 
300-Survey\Basemaps\12345_FB001.dgn 
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Use the Level Display function (OpenRoads Modeling > Home > Level Display) to turn off all the levels in 
the attached survey design file (123456_FB001.dgn), except for the levels shown below 
 

 From the Home tab, select the Level Display icon. 
 Select the file 123456_FB001.dgn in the top 

portion of the dialog. 
 Turn off all the levels by right-clicking in the 

lower portion of the dialog and choose All Off 
from the pop-up menu. 

 After turning off all the levels, turn on the 
following levels by clicking on each level 
name as shown at right. 

o PV_X_COP 
o PV_X_EOP 
o SV_X_Break_Lines 
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Part 3: Creating the Surface Terrain Model for the Existing Pavement 
The surface terrain can be created for the existing pavement by directly using the referenced survey 
elements, or by copying the elements from the FB reference attachment into the active file. 

In this example, we will create a surface terrain model limited to the station limits of the pavement removal 
areas, from station 12+00 to meet existing S.R. 185. A copy of the existing survey elements is required since 
the elements will be edited to specific station ranges. 

Take the following steps to create the surface terrain for Jameson Road. 

 Use the MicroStation Copy Element command (Drawing > Copy) to copy the existing edge of 
pavement, center of pavement, and break line elements from the Survey Field Book design file (FB) 
to the active design file. The elements to be copied are shown below. 
 
Be careful to copy the elements exactly on top of the original survey elements. 

 
 

 After copying the elements, turn off the reference attachment display of the survey basemap design 
file, 123456_FB001.dgn (Home > Attach Tools > References). 
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Take the following steps to prepare the copied elements to generate the surface terrain model for the 
existing pavement: 

 Use the Break Element command (OpenRoads Modeling > Drawing > Break Element) to break 
each edge of pavement line and the center of pavement line at station 12+00 of Jameson Road. 
 
The result is shown below with the elements from station 12+00 forward selected to show that the 
lines are broken at station 12+00. 

 

The edge of pavement elements will be used to define the boundary of the existing pavement surface 
terrain model. The surveyed center of pavement elements will be used as a break line to define the 
pavement crown. In this case, these elements are 3D graphics as generated from the Survey software and 
can be used to generate the surface terrain model directly. 2D elements can also be used if they have an 
OpenRoads profile defined. 

Take the following steps to create the surface terrain for the pavement portion that will remain in place: 

 From the References dialog (Home > Attach Tools > References), turn off the display of the file 
containing the proposed alignment for Jameson Road (123456_BK001.dgn) 
 

 From the Terrain tab, select the From Elements command to create a terrain model from selected 
elements. 

 
 Set the Feature Type to Boundary 
 Set the Edge Method to Remove Slivers 
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 Choose the X_Triangles2 feature definition. 
 Key-in the Name for the terrain model X_PAVT_Jameson. 
 Select each edge of pavement element as shown below. 

 

 Right-click (reset) when you are done selecting the elements. 
 When prompted, left click to accept each parameter. 
 After accepting each parameter, the terrain model is generated like the example below. 

Take the following steps to add the center of pavement element to the terrain model as a break line. 
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From the Terrain tab, select Feature Management > Add Features 

 Select the Terrain Model name from the drop-down list. 
 Set the Feature Type parameter to Break Line. 
 Select the center of pavement element as shown below. 

 

Follow the prompts to accept the element. When complete, the center of pavement element is 
added to the terrain model as a break line. 

Following the steps above, create a second surface terrain for the portion of Jameson Road to be removed. 

 Create a terrain named X_PAVT_Removed_Jameson from the edge of pavement and the break line 
at the intersection with S.R. 185. 

 
 Add the crown of pavement element as a break line to the newly created terrain. 
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When complete, two separate terrains are created for the surface of existing Jameson Road like the 
example below. 
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Part 4: Create the Surface Templates 
OpenRoads templates can be applied to a terrain model to define the subsurface composition of the surface 
terrain. We will create two templates, one for the portion of Jameson Road that will remain in place, and a 
second for the portion to be removed. 

Existing Pavement Feature Definitions 
The OHDOT Standards contain several Mesh features for existing pavement as shown below. 

 

Features for Asphalt and Concrete 
Removed features differ in the Volume 
Option parameter setting. 

The features MD_X_Asphalt_Pavement 
and MD_X_Concrete Pavement have the 
Volume Option set to a value of None. 

The features 
MD_X_Asphalt_Pavement_Removed and 
MD_X_Concrete_Pavement_Removed  
have the Volume Option set to a value 
of Unsuitable. 

These settings are used to determine 
how the components are included in 
earthwork computations. 

 

 

Creating an Existing Pavement Template 
Take the following steps to create a template to the Jameson Road surface terrain: 

 From the Corridors tab, select Template > Create Template 
 Right-click on the Project Templates folder and select New > Template 
 Rename the new template “Jameson_X_Pavt” 

Add components to define the pavement building of the exiting road. 

 Choose Tools > Dynamic Settings to open the dialog shown below. 
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Use the settings show at right. The Feature 
Definition is set as follows: 

Linear\Modeling\Template 
Points\Scratch\Scratch1 

 

 

 

 

 In the Current Template window, right-click and choose Add New Component > Simple. 
 A simple component consists of four points defining a rectangular shape. Set the parameters as 

shown below. 

 
Note: The slope and width parameters are irrelevant as this is defined by the terrain surface. 
 

 Place the component at the 0,0 location as shown below. 

 
 Right-Click in the Current Template window and choose Add New Component > Simple to add a 

component for a concrete pavement layer. Use the settings shown below. 
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 Place the component at the bottom of the previous component. The completed template should 

appear as show below 

 

 

Creating an Existing Pavement Removed Template 
Take the following steps to create a template for the existing pavement removal areas. 

 Right click the name of the Jameson_X_Pavt template and choose the Copy option. 
 Right click on the Project Templates folder name and choose the Paste option. 
 Rename the copied template as “Jameson_X_Pavt_Removed. 
 Change the feature definition that is assigned to each of the two pavement layers as follows: 

 Right click the X_Asphalt component and choose the Edit Component command. 
 Change the Feature Definition to X_Asphalt_Pavement_Removed. Select the Apply button. 
 Edit the X_Concrete component to use the Feature Definition. 

.X_Concrete_Pavement_Removed. Select the Apply button and close the Component 
Properties dialog.  

 In the Create Templates dialog, choose File > Save and then close the template library. 
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Part 5: Apply the Surface Template 
The template is applied to terrain model using the Apply Surface Template command. 

 From the Model Detailing tab, select Apply Surface Template. 

 
 Select the Template for the portion of Jameson Road that will remain in place to apply the template 

as shown below. 

 
 When prompted, select the terrain model. 

 
The template is applied to the 3D model, like 
the example at right. 
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Part 6: Dynamic Cross Section View 
Take the following steps to display the elements in a dynamic cross-section view: 

 Turn on the reference file display of the Jameson Road alignment (123456_BK003.dgn), which was 
turned off in a prior step in this training exercise (OpenRoads Modeling > Home > Attach Tools). 
 

 Turn on the reference file display of the survey design file (123456_FB001.dgn), which was turned 
off in a prior step in this training exercise (OpenRoads Modeling > Home > Attach Tools). 

 
 Use the Level Display dialog (OpenRoads Modeling > Home > Level Display) to turn on the 

following levels for the survey file (123456_FB001.dgn): 
 DT_X_Terrain_Boundary 
 DT_X_Terrain_Ground_Line 

 
 Set the survey existing ground terrain model as the active terrain. 

 Choose the Element Selection tool (OpenRoads  Modeling > Home > Element Selection). 
 Select the survey terrain model boundary. Allow 

the cursor to rest on the boundary element until 
the pop-up menu appears. 

 From the pop-up menu, choose the second icon 
to set the selected terrain model as the active 
terrain. 
 

 Hold down the right-mouse button in the view window. 
Select View Control > 2 Views Plan/XS from the pop-up menu. 

 
 When prompted, select OK to generate a Dynamic XS view. 

 When prompted to Locate Corridor or Alignment, choose the Jameson Road alignment. 
 Enter a Left Offset value of -100 
 Enter a Right Offset value of 100 
 Enter a Station value of 12+00 
 Enter an Interval of 50 
 When prompted to Select or Open View, enter a data point (left mouse click) in the cross-

section view window. An example is shown below. 
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Part 7: Component Quantities 
The OpenRoads component quantities report can be used with the surface terrain and mesh elements. Take 
the following steps to generate the component quantities for the Jameson Road pavement removal 3D mesh 
elements: 

 From the OpenRoads Modeling workflow, Home 
tab, select Civil Analysis > Element component 
Quantities as shown at right. 
 

 When prompted to Locate First Element, choose 
the surface terrain model for Jameson Road. Right-
click (reset) when complete. 

 
 The Element Component Quantities report is 

opened like the example below. 

Both the Volume and Surface Area are reported for 
each of the components as shown below. 

The Unit Cost can be assigned for each Material to 
generate a cost estimate. 

Select the Report button to send the quantities to 
the OpenRoads Report Browser. From there, the 
report can be saved in ASCII, Word, or Excel formats. 
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Alt. Exercise 2: Modeling the Existing Pavement using Create Closed Mesh 

This section will demonstrate the process to create 3D mesh elements for the existing pavement using the 
Create Closed Mesh tool. A portion of St. Peters Rd. will be removed so we will create two separate surface 
terrains, one for the portion that will remain in place, and a second for the portion to be removed. 

Part 1: References 
The surveyed edge of pavement and center of pavement elements will be used to generate the 3D mesh 
elements representing the existing pavement. 

 Attach the following files as references (Home > Attach Tools > References): 

Geometry Basemap for St. Peters Rd: 
400-Engineering\Roadway\Basemaps\123456_BK002.dgn 
 

Part 2: Creating the Surface Terrain Model for the Existing Pavement 
The surface terrain can be created for the existing pavement by directly using the referenced survey 
elements, or by copying the elements from the FB reference attachment into the active file. 

In this example, we will create a surface terrain model limited to the station limits of the pavement removal 
areas, from station 17+00 to meet existing S.R. 185. A copy of the existing survey elements is required since 
the elements will be edited to specific station ranges. 

Take the following steps to create the surface terrain for St. Peters Rd. 

 Use the MicroStation Copy Element command (Drawing > Copy) to copy the existing edge of 
pavement, center of pavement, and break line elements from the Survey Field Book design file (FB) 
to the active design file. The elements to be copied are shown below. 
 
Note: Be careful to copy the elements exactly on top of the original survey elements. 

 

 

Copy these 
four elements 
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 After copying the elements, turn off the reference attachment display of the survey basemap design 
file, 123456_FB001.dgn (Home > Attach Tools > References). 

 Then use the View Rotation: Rotate View by 3 points so that the St. Peters Rd. alignment 
annotations are in the correct orientation. 

Take the following steps to prepare the copied elements to generate the surface terrain model for the 
existing pavement: 

 Use the Break Element command (OpenRoads Modeling > Drawing > Break Element) to break 
each edge of pavement line and the center of pavement line at station 17+00 of St. Peters Rd. 
 
The result is shown below with the elements from station 17+00 forward selected to show that the 
lines are broken at station 17+00. 

  
 Select the level PV_P_Saw_Cut_Line  

 
 Use the Place Line command (OpenRoads Modeling > Drawing > Place Line) to draw a line to 

each point edge of pavement line at sta. 17+00 of St. Peters Rd. 
 

The edge of pavement elements and sawcut element will be used to define the boundary of the existing 
pavement surface terrain model. The surveyed center of pavement elements will be used as a break line to 
define the pavement crown. In this case, these elements are 3D graphics as generated from the Survey 
software and can be used to generate the surface terrain model directly. 2D elements can also be used if 
they have an OpenRoads profile defined. 

Take the following steps to create the surface terrain for the pavement portion that will remain in place: 

 From the References dialog (Home > Attach Tools > References), turn off the display of the file 
containing the proposed alignment for St. Peters Rd. (123456_BK002.dgn). Then turn the survey 
file back on (123456_FB001.dgn). 
 

 From the Level Display dialog (Home > Primary > Level Display), turn off all levels within the 
survey (123456_FB001.dgn) then turn on the DT_X_Terrain_Ground_Line & 
DT_X_Terrain_Boundary level. 
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 From the Drawing tab, select the Create Complex Chain command under the Groups. Then select 
all the EOP from Sta. 17+00 of St. Peters Rd. to S.R. 185. 

 From the Terrain tab, select the Additional Methods command to create a terrain model from 
selected elements. 

 
 Once the Create Clipped Terrain Model tool has been selected then survey terrain boundary. 

 Set the Clipping Method to External 
 Horizontal Offset = 0.000 
 Vertical Offset = 0.000 
 Choose the X_Triangles2 feature definition. 
 Key-in the Name for the terrain model X_PAVT_Remove_StPeters. 
 Select each edge of pavement element as shown below. 
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 Right-click (reset) when you are done selecting the elements. 
 When prompted, left click to accept each parameter. 
 After accepting each parameter, the terrain model is generated like the example below. 

Note: this method automatically adds the center of pavement element to the terrain model as a 
break line. 

 Repeat the process above for the Existing to Remain section of St. Peters Rd. using 
X_Triangles3 feature definition and Key-in the Name for the terrain model 
X_PAVT_Remain_StPeters. 
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Part 3: Applying a Closed Mesh to a Surface 
The Create Closed Mesh can be applied to a terrain model to define the subsurface composition of the 
surface terrain. We will create two templates, one for the portion of St. Peters Rd. that will remain in place, 
and a second for the portion to be removed. 

From the Modeling Detailing tab, select Create Closed Mesh tool under the 3D Tools sections. 

 Set the Method to Element to Depth 
 Depth = 0.25 
 Choose the MD_X_Asphalt_Pavement feature definition. 
 Key-in the Name for the closed mesh X_PAVT_Remain_StPeters 
 Data selected the first prompt. 
 Select the surface of pavement element as shown below. 

 

 Following the steps above, create a second closed mesh for the surface terrain for the portion of St. 
Peters Rd. to be removed. 
 

 Choose the MD_X_Asphalt_Pavement_Removed feature definition. 
 Key-in the Name for the closed mesh X_PAVT_Removed_StPeters. 
 Select the surface terrain shown below. 
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 When complete, two separate closed mesh’s are created form the surface of existing St. Peters Rd. 
like the example below. 
 

 

Tip: go to the view attributes  drop down to change the view display style to 
Illustration:IgnoreLighting. 

Creating an Existing Asphalt Concrete Base 

From the Modeling Detailing tab, select Create Closed Mesh tool. 

 Set the Method to Element to Depth 
 Top Mesh Side = Use Lowest 
 Depth = 0.75 
 Choose the MD_X_Concrete_Pavement feature definition. 
 Key-in the Name for the closed mesh X_Concrete_Pavt_Remain_StPeters 
 Data selected the first prompt. 
 Select the surface of pavement element as shown below. 

 A new Drop down with appear Top Mesh Side select Use Lowest. 
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 Following the steps above, create a second closed mesh for the surface terrain for the portion of St. 
Peters Rd. to be removed. 
 

 Choose the MD_X_Concrete_Pavement_Removed feature definition. 
 Key-in the Name for the closed mesh X_Concrete_Pavt_Removed_StPeters. 
 Select the surface terrain shown below. 

 
 When complete, you should have a Pavement layer and a concrete layer along St. Peters Rd. like the 

example below. 

 
 
 
 
 
 

 

 Dynamic XS view of St. Peters Rd. use the View Properties shown below. 
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OpenRoads Software Version 

This document was prepared using the following software version: 

OpenRoads Designer CONNECT Edition – 2021 Release 1 Update 10 – Version 10.10.01.03 

This document was updated using the following software version: 

OpenRoads Designer CONNECT Edition – 2022 Release 3 Update 12 – Version 10.12.02.04 

 

Contacts 

For any questions, suggestions, or problems with this document please contact the ODOT Office of CADD 
and Mapping Services by use of the following form on the ODOT website: 

https://odot.formstack.com/forms/cadd_servicerequest 

 

 


